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Safety messages

Safety messages are provided throughout this manual to protect personnel and equipment. Read each safety message carefully
before proceeding to the next step.

Safety and approval information

This Micro Motion product complies with all applicable European directives when properly installed in accordance with the
instructions in this manual. Refer to the EU declaration of conformity for directives that apply to this product. The following are
available: the EU Declaration of Conformity, with all applicable European directives, and the complete ATEX installation drawings
and instructions. In addition, the IECEx installation instructions for installations outside of the European Union and the CSA
installation instructions for installations in North America are available at Emerson.com or through your local Micro Motion
support center.

Information affixed to equipment that complies with the Pressure Equipment Directive, can be found at Emerson.com. For
hazardous installations in Europe, refer to standard EN 60079-14 if national standards do not apply.

Other information

Troubleshooting information can be found in the Configuration Manual. Product data sheets and manuals are available from the
Micro Motion web site at Emerson.com.

Return policy

Follow Micro Motion procedures when returning equipment. These procedures ensure legal compliance with government
transportation agencies and help provide a safe working environment for Micro Motion employees. Micro Motion will not accept
your returned equipment if you fail to follow Micro Motion procedures.

Return procedures and forms are available on our web support site at Emerson.com, or by calling the Micro Motion Customer
Service department.
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1 Before you begin

1.1 About this document
This document provides information about how to integrate a Model 5700 Ethernet transmitter
communicating with a Siemens Simatic S7-400 PLC using a Simatic Manager project.

Important
This manual assumes that:
• The transmitter has been installed correctly and completely according to the instructions in the

transmitter installation manual.

• Users understand basic transmitter and sensor installation, configuration, and maintenance concepts and
procedures.

1.2 Related documentation
You can find all product documentation via the product documentation DVD shipped with the product or at
Emerson.com.

• Hazardous area installation — see the approval documentation shipped with the transmitter, or download
the appropriate documentation
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2 5700 transmitters in Ethernet networks

• Make sure that each cable is no longer than 328 ft (100 m).

• Connect the 5700 Ethernet transmitter to the host system via a LAN (Local Area Network) and not a WAN
(Wide Area Network).

• Follow all network security best practices.

2.1 Star topology
5700 Ethernet transmitters can be installed in a star network.

Figure 2-1: 5700 star network

A. Programmable Logic Controller (PLC)
B. 5700 with Ethernet output
C. External Ethernet switch
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2.2 Ring topology
5700 Ethernet transmitters can be installed in a ring network.

Figure 2-2: 5700 ring network

A. Programmable Logic Controller (PLC)
B. 5700 with Ethernet output
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2.3 Daisy-chain topology
5700 Ethernet transmitters can be installed in a daisy-chain network.

Figure 2-3: 5700 daisy-chain network

A. Programmable Logic Controller (PLC)
B. 5700 with Ethernet output
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3 Establish cyclic data

3.1 Install the GSDXML file
Procedure

1. Download the GSDXML file using one of the following methods:

Option Description

Use a USB
memory drive

a. Insert a USB memory drive into the 5700 Ethernet service port.
The service port connection is located under the transmitter cap.

b. From the transmitter display, choose Menu → USB Options → Transmitter →
USB Drive → Download Support Files → GSD file.

c. Follow the menu to copy the GSDXML file to the USB memory drive.

d. Copy the zip file from the USB memory drive to the PC where SIMATIC Manager
is installed.

e. Unzip the file to a chosen location.

Download the
file

a. Download the GSDXML file from the Micro Motion 5700 Ethernet product
website.

b. Unzip the file to a chosen location.

2. To install the 5700 PROFINET GSDXML file into your GSD file catalog using the HW config in SIMATIC
Manager:

a) Choose Options → Install GSD File.
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Example

b) Select Install.

c) Choose Update Catalog.

3.2 Create a PROFINET network
Procedure

1. Configure the primary protocol as PROFINET in the 5700 device:

a) From the transmitter display, choose Device Tools → Configuration → Network Settings.
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b) Select Profinet.

2. From SIMATIC Manager, choose File → 'New Project' Wizard.

3. Follow the wizard to select the CPU for your PLC.

Example

CPU 400

4. In the Component View, click on the CPU.

5. Double-click Connections.
A graphical representation of the network is displayed.

6. Double-click the CPU icon.
The HW Config screen is displayed.

7. Double-click the interface, then click Properties.

Example

The network settings of the S7 400 PLC Ethernet interface are configured.

8. Right-click on the Ethernet interface, and select Insert PROFINET IO System.
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Example

The Ethernet network is created.

9. Double-click on the PROFINET network you just created.
The Properties menu is displayed.

10. Enter the name of the network.

Example
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11. (Optional) To use the network name in the IO device and in the controller, check Use the name in IO
device/controller.

12. Drag and drop the device called Standard from the GSD file catalog to the 5700 Ethernet network.

The 5700 Ethernet network is located at PROFINET IO → Additional Field Devices → Sensors →
Coriolis → 5700 Coriolis Meter.

Example

13. Double-click on the device to enter the configuration menu.

14. Enter the Device name.

Note
The Device name must:

• Follow all DNS conventions

• Cannot start with a number

• Cannot contain uppercase alpha characters

15. Make the appropriate IP address configuration of the device, and press Ok.

You can use the Ethernet button if required.

If the Use name in IO device/controller checkbox is checked in the network properties, then Device
name will have the following format: device_name.network_name.
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Option Description

Device name when the Use
name in IO device/
controller checkbox is
unchecked
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Option Description

Device name when the Use
name in IO device/
controller checkbox is
checked

16. Click on the 5700 Ethernet icon to display the HW configuration in the lower screen.

17. From the HW Catalog, drag the input and output slots to one of the following locations:
• PROFINET IO → Additional Field Devices → Sensors → Coriolis → 5700 Coriolis Meter →

Standard → Input Modules – Slot 1

• PROFINET IO → Additional Field Devices → Sensors → Coriolis → 5700 Coriolis Meter →
Standard → Output Modules – Slot 2

Example

If Empty is selected, delete the slot by right-clicking on the slot, and selecting Delete.

For a description of the Input and Output slots, see Input and output slots.

Example

In this example, Small Configurable Data has been added to Slot 1.
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18. Press Save and Compile.

19. Press Download to Module to download the configuration into the CPU module.

Note
The modules configured and downloaded in the HW Config are set in the transmitter. You do not need
to set the Input or Output modules on the transmitter first. You can configure the variables in the input
data sets using the web server or ProLink III.

Example

The configuration is downloaded into the CPU module. The PLC should show a red LED bus fault.
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3.3 Configure Ethernet IP address and device name
Use this procedure to configure the Ethernet IP address and device name for the Model 5700 Ethernet device.

Procedure

1. Choose PLC → Ethernet → Edit Ethernet Node.

Example

2. To configure the programming machine (PG) to PC interface, choose Options → Set PG/PC Interface…

Example

3. Press Browse to find the Model 5700 Ethernet device on the network.

Tip
If you cannot find the Model 5700 device, turn off your firewall. Firewalls sometimes prevent SIMATIC
Manager from browsing network devices.

Example

Establish cyclic data Integration Guide
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4. Select the device from the list and press Ok.

Example

5. Fill in the appropriate network settings and press Assign IP Configuration.

6. Fill in the device name and press Assign Name.

Make sure the IP configuration and device name are the same as what you configured in Create a
PROFINET network.

Example

7. Press Browse again to make sure the changes were applied to the device.
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Example

8. Choose PLC → Ethernet → Verify Device Name to verify the device name was properly assigned.

Example

Establish cyclic data Integration Guide
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3.4 Verify communications
Procedure

1. Verify that the PLC shows no faults (red lights).

The most likely error will be a Bus Fault (BF LED is red), which means either the Device Name, the IP
address, the Input Slot, or the Output Slot between the PLC and the Model 5700 Ethernet transmitter
does not match.

2. To verify you are receiving data:

a) In the HW Config, click the Model 5700 Ethernet icon.

b) Right-click on the Input Slot and press Monitor/Modify.

c) Click the I/O Display box and the Monitor box to see the process variables updating.
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Example

3. If the transmitter is still not communicating, from the transmitter display, choose Menu →
Configuration → Ethernet settings → Primary Protocol → Profinet to verify that PROFINET is the
configured primary protocol on the Model 5700 Ethernet transmitter.

3.5 Troubleshooting the PROFINET integration

3.5.1 Cannot download PROFINET into the PLC controller
Use the following procedure if you cannot download the PROFINET program into the PLC controller.

Procedure

1. Choose PLC → Ethernet → Edit Ethernet Node.

2. Select Browse.
A list of network devices with MAC IDs is displayed.

3. Select the PROFINET controller and press OK.
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Example

Integration Guide Establish cyclic data
MMI-20029785 June 2022

PROFINET Siemens PLC Integration Guide 23



4 Configuring Siemens PLC read/write
operation
Procedure

1. To insert the data blocks:

You will use the data blocks to configure the request and response parameters on the Siemens PLC.

a) From the SIMATIC Manager screen, select Insert → S7 Block → Data Block.

Example

b) From the Properties screen, enter the values as shown in the following example and select OK.

Example

The first of two data blocks is created.
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c) From the Properties screen, enter the values as shown in the following example and select OK.

The second of two data blocks is created.

2. To copy the SFB52 and SFB53 data blocks to your project:

a) From the SIMATIC Manager screen, select File → Open and select the Library tab.

b) Select Standard Library and press OK.

Example

The pre-defined library opens.

c) From the Standard Library tree view, select System Function Blocks → Blocks.

d) From the right panel, select SFB52 and SFB53, and select Copy.
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SFB52 and SFB53 are copied to your Projects folder under CPU → S7 Program → Blocks.

3. To add the SFB52 and SFB53 DB instances:

a) To create the data blocks, choose Insert → S7 Block → Data Block.

b) Enter the values as shown in the following example and select OK.

Example

The first of the two data block DB instances is added.

c) Enter the values as shown in the following example and select OK.
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The second of the two data block DB instances is added. The SIMATIC Manager displays the
entries.

4. To configure the DB2 Request data block, double-click DB2 Request and enter the values as shown in
the following example.

Example

5. To configure the DB3 Response data block, double-click DB3 Response and enter the values as shown
in the following example.
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Example

6. To program acyclic read:

a) Double-click OB1.

Example

b) Choose Insert → Network.

Example

c) To configure the input and output parameters, from SFB blocks, drag SFB52 to Network.
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Example

Parameter Description

REQ The Read request is sent to the Model 5700 using
bit memory M8.2. You have the following options:
• 1 (true) starts the read request. You must end

the request.

• 0 (false) ends the request. Reset Bit logic is used
to reset M8.2.

VALID Bit memory M8.4 indicates whether a new data
record was received and valid.

BUSY Bit memory M8.3 indicates whether the read
process has terminated or not.

ERROR Bit memory M8.5 indicates whether an error has
occurred while processing the function.

STATUS The double-word bit memory MD18 contains an
error code. For error descriptions, see Help on
system functions / function blocks.

ID Displays the PN-IO diagnostic address (for example,
“8180” = 1FF4 hex). This address is used for
PROFINET acyclic read/write to the Model 5700E
station to perform pre-defined diagnoses.

INDEX Displays the data record number (247 – starting
Modbus register for mass flow). For the Model
5700, the starting address is 1.

MLEN The maximum length in bytes of data record
information to be fetched.

RECORD The destination area for the read data record. For
DB3 in this example, the starting address is 0 and
the address length is two bytes.

d) Read the acyclic parameters displayed in the Actual value field.
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Example

7. To program acyclic write, choose S7 Program → Blocks and double-click OB1.

The OB1 block is a Program Cycle Organization Block. The S7 CPU operating system executes OB1
periodically. When OB1 has been executed, the operating system restarts it. Cyclic execution of OB1 is
started after the start-up has been completed.

a) To edit the program, select OB1.

b) Choose Insert → Network.

c) From SFB blocks, drag SFB53 to Network and and configure the input and output as shown in
the following example.

Example
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June 2022 MMI-20029785

30 Micro Motion 5700 Ethernet transmitters



8. To create a variable table:

Use the variable table to modify and monitor the connected PLC variables and memory content.

a) From the SIMATIC Manager screen, choose Insert → S7 Block → Variable Table.

b) Enter the values as shown in the following examples and save your changes.

Example

The write request is sent to the Model 5700 using bit memory M1.0.

c) To start the read request, enter 1 (true) in the Modify value field, right-click, and press Modify.

d) To end the request, enter 0 (false) in the Modify value field, right-click, and press Modify.

9. To download a project to PLC:

a) From the SIMATIC Manager screen, select the Download to Module icon.
The configuration is downloaded to your CPU.

b) After the project downloads, open the vat table and make the corresponding M 1.0, 8.2 bits high
for read and read/write.

The read request is sent to the Model 5700 using bit memory M8.2. The write request is sent to
the Model 5700 using bit memory M1.0.

c) Go online to read and write acyclic data into the Model 5700 device module.
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A Input and output slots

A.1 Input slots
Empty

Use the Empty Input slot when no input data is required. Typically for an Ethernet mass flow meter, the Empty
Input slot is unused because this meter is a measuring device.

Table A-1: Common input data

Assembly
Dword
index

Name Data type

0 Mass Flow REAL

1 Temperature REAL

2 Density REAL

3 Drive Gain REAL

4 Totalizer 1 (default = Mass Total) REAL

5 Inventory 1 (default = Mass Inventory) REAL

6 Status DWORD

Severity (bits 0-15) • Bit #0 = Immediate Failure

• Bit #1 = Last Measure Value Failure

• Bit #2 = Function Check

• Bit #3 = Out of Specification

• Bit #4 = Maintenance Required

Counter/Heartbeat (bits 16-32) The PLC will display the counter/
heartbeat as a signed INT, therefore
the counter can be negative.
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Table A-1: Common input data (continued)

Assembly
Dword
index

Name Data type

7 Alert detail • Bit #0 = Electronics Failure

• Bit #1 = Sensor Failed

• Bit #2 = Configuration Error

• Bit #3 = Core Low Power

• Bit #4 = Security Breach

• Bit #5 = Sensor-Transmitter
Communication Error

• Bit #6 = Tube Not Full

• Bit #7 = Extreme Primary Purpose
Variable

• Bit #8 = Reserved

• Bit #9 = Flowmeter Initializing

• Bit #10 = Function Check in
Progress

• Bit #11 = Sensor Being Simulated

• Bit #12 = Output Fixed

• Bit #13 = Drive Over Range

• Bit #14 = Process Aberration

• Bit #15 = Discrete Event X Active

• Bit #16 = Output Saturated

• Bit #17 = Function Check Failed

• Bit #18 = Data Loss Possible

DWORD

8 Echo Output Data Discrete Actions DWORD

Table A-2: Liquid volume flow

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9 Volume Flow REAL

10 Totalizer 2 (default = Volume Total) REAL

11 Inventory 2 (default = Volume Inventory) REAL
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Table A-3: Gas volume flow

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9 Gas Volume Flow REAL

10 Totalizer 4 (default = Gas Volume Total) REAL

11 Inventory 4 (default = Gas Volume Inventory) REAL

Table A-4: API referral

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9 Volume Flow REAL

10 Totalizer 2 (default = Volume Total) REAL

11 Inventory 2 (default = Volume Inventory) REAL

12 Corrected Density REAL

13 Corrected Vol Flow REAL

14 Totalizer 3 (default = Corrected Vol Total) REAL

15 Inventory 3 (default = Corrected Vol Inv) REAL

16 Avg Density REAL

17 Avg Temperature REAL

18 CTL REAL

Table A-5: Concentration measurement

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9 Volume Flow REAL

10 Totalizer 2 (default = Volume Total) REAL

11 Inventory 2 (default = Volume Inventory) REAL

12 Density at Reference REAL

13 Std Vol Flow Rate REAL

14 Totalizer 5 (default = Std Vol Total) REAL

15 Inventory 5 (default = Std Vol Inv) REAL

16 Net Mass Flow Rate REAL
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Table A-5: Concentration measurement (continued)

Assembly
Dword
index

Name Data type

17 Totalizer 6 (default = Net Mass Total) REAL

18 Inventory 6 (default = Net Mass Inv) REAL

19 Net Vol Flow Rate REAL

20 Totalizer 7 (default = Net Vol Flow Total) REAL

21 Inventory 7 (default = Net Vol Flow Inv) REAL

22 Concentration REAL

23 Density - Fixed SG Units REAL

24 Density - Special Density Units REAL

Table A-6: Batcher

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-2

9–11 Liquid Volume

12 Batch Total REAL

13 Overshoot Compensation Value (Reg 1457) REAL

14 Batch Fill Time REAL
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Table A-6: Batcher (continued)

Assembly
Dword
index

Name Data type

15 Fill status and diagnostics

• Bit #0 - Primary Fill in progress (reg 2495 bit 0)

• Bit #1 - Primary AOC training (reg 2495 bit 9)

• Bit #2 = Primary Valve (reg 2495 bit 5

• Bit #3 = Undefined

• Bit #4 = Undefined

• Bit #5 = Undefined

• Bit #6 - Fill Start Not Okay (reg 2496 bit 0)

• Bit #7 - AOC Flow Rate Too High (reg 2496 bit 1)

• Bit #8 - Maximum Fill Time Exceeded (reg 2496 bit 2)

• Bit #9 - Slug Flow (reg 2496 bit 3)

• Bit #10 - Tube Not Full (reg 2496 bit 4)

• Bit #11 - Drive Overrange (reg 2496 bit 5)

• Bit #12 - Critical Sensor Failure (reg 2496 bit 6)

• Bit #13 - Critical Transmitter Failure (reg 2496 bit 7)

• Bit #14 - Density Out of Limits (reg 2496 bit 8)

• Bit #15 - Temperature Out of Limits (reg 2496 bit 9)

• Bit #16 - Bit #31 for future expansion

DWORD

Table A-7: Small input configurable data set

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9–16 8 configurable slots REAL *8

Table A-8: Medium input configurable data set

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9–24 16 configurable slots REAL *16
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Table A-9: Large input configurable data set

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9–40 32 configurable slots REAL *32

Table A-10: Advanced Phase Measurement (APM) – liquid

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9 Volume Flow REAL

10 Totalizer 2 (default = Volume Total) REAL

11 Inventory 2 = (default = Volume Inventory) REAL

12 Gas Void Fraction REAL

13 Contract Total 1 REAL

14 Contract Total 2 REAL

15 Contract Total 3 REAL

16 Contract Total 4 REAL

17 Net Oil Flow @ Line REAL

18 Net Water Flow @ Line REAL

19 Watercut @ Line REAL

20 Net Oil Total @ Line REAL

21 Net Water Total @ Line REAL

22 Density Oil @ Line REAL

23 Net Oil Flow @ Ref REAL

24 Net Water Flow @ Ref REAL

25 Watercut @ Ref REAL

26 Net Oil Total @ Ref REAL

27 Net Water Total @ Ref REAL

Table A-11: Advanced Phase Measurement (APM) – gas volume

Assembly
Dword
index

Name Data type

0–8 Common input data See Table A-1

9 Gas Volume Flow REAL
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Table A-11: Advanced Phase Measurement (APM) – gas volume (continued)

Assembly
Dword
index

Name Data type

10 Totalizer 4 (default = Gas Volume Total) REAL

11 Inventory 4 = (default = Gas Volume Inventory) REAL

12 Contract Total 1 REAL

13 Contract Total 2 REAL

14 Contract Total 3 REAL

15 Contract Total 4 REAL

16 Total time mist detected DWORD

17 APM Status
• Bit #0 – TMR Algorithm Active (reg 433 bit 12)(1)

• Bit #1 – Bit #15 currently not defined

• Bit #16 – Bit #31 for future expansion

DWORD

18 Liquid Mass Flow Estimate REAL

19 Watercut @ Ref REAL

(1) Do not include the parenthesis in the label.

Table A-12: Wet Gas Measurement

Assembly
Dword
index

Name Data type

0-8 Common input data See Table A-1

9 Gas Volume Flow REAL

10 RPO REAL

11 Live Zero REAL

12 Tube Frequency REAL

13 Core Temperature REAL

14 Inventory 2 (default = Volume Inventory) REAL

15 Contract Total 1 REAL

16 Contract Total 2 REAL

17 Contract Total 3 REAL

18 Contract Total 4 REAL
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Table A-12: Wet Gas Measurement (continued)

Assembly
Dword
index

Name Data type

19 Total time mist detected DWORD

20 APM Status
• Bit #0 – TMR Algorithm Active (reg 433 bit 12)

• Bit #1 – Bit #15 undefined

• Bit #16 – Bit #31 for future expansion

DWORD

21 Liquid Mass Flow Estimate REAL

22 Watercut @ Ref REAL

23 Gas Mass Flow (Reg 2008) REAL

24 Liquid Volume Flow (Reg 2261) REAL

25 Gas to Liquid Ratio (Reg 2255) REAL

26 Gas to Oil Ratio (Reg 2263) REAL

27 Net Oil Flow @ Ref REAL

28 Net Water Flow @ Ref REAL

29 Net Oil Total @ Ref REAL

30 Net Water Total @ Ref REAL

Table A-13: Device Status

Assembly
Dword
index

Name Data type

0 Status & Diagnosis

• Bit #0 – Smart Meter Verification Running

• Bit #1 – Smart Meter Verification Passed

• Bit #2 – Smart Meter Verification Failed

• Bit #3 – Smart Meter Verification Aborted

• Bit #4 – Bit #31 for future expansion

DWORD

1 LPO REAL

2 RPO REAL

3 Live Zero REAL

4 Tube Frequency REAL

5 Core Temperature REAL

6 Case Temperature REAL

7 Core In Volts REAL
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Table A-13: Device Status (continued)

Assembly
Dword
index

Name Data type

8 Flow Verification Zero REAL

9 Result 1 (LPO Normalized Stiffness Reg 5782) REAL

10 Result 1 (RPO Normalized Stiffness Reg 5784) REAL

11 Result 3 – Future Use REAL

12 Result 4 – Future Use REAL

13 Result 5 – Future Use REAL

14 Result 6 – Future Use REAL

15 Data 1 – (Confidence Interval LPO Reg 6360) REAL

16 Data 2 – (Confidence Interval RPO Reg 6362) REAL

17 Data 3 – (LPO Std. Dev. Reg 6356) REAL

18 Data 4 – (RPO Std. Dev. Reg 6358) REAL

19 Data 5 – (LPO Meter Factor Reg 6371) REAL

20 Data 6 – (RPO Meter Factor Reg 6373) REAL

21 Data 7 – Future Use REAL

22 Data 8 – Future Use REAL

23 Data 9 – Future Use REAL

24 Smart Meter Verification Run Number (Reg 5826) UINT

25 Smart Meter Verification Progress (Reg 3020) UINT

26 Code 1 (Abort Code Reg 3002) UINT

27 Code 2 – Future Use UINT

28 Code 3 – Future Use UINT

A.2 Output slots
Empty

Use the Empty Input slot when no output data is required. No output data is a typical application and is the
default.

Table A-14: Common output data — Discrete actions only

Note
Common output data is required for every output assembly in order to access 5700 functions. Depending on the
application, not all functions may be used.
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Assembly
Dword
index

Name Data type

0 Discrete Actions:

• Bit #0 – Start Sensor Zero (trigger start with a 1, no abort)

• Bit #1 – Reset All Process Totals (same as setting bits 2-8)

• Bit #2 – Reset Totalizer 1 (Mass Total by default)

• Bit #3 – Reset Totalizer 2 (Volume Total by default)

• Bit #4 – Reset Totalizer 3 (PM Ref Vol Total by default)

• Bit #5 – Reset Totalizer 4 (GSV Total by default)

• Bit #6 – Reset Totalizer 5 (CM Ref Vol Total by default)

• Bit #7 – Reset Totalizer 6 (CM Net Mass Total by default)

• Bit #8 – Reset Totalizer 7 (CM Net Vol Total by default)

• Bit #9 – Start All Totals (trigger start with a 1)

• Bit #10 – Stop All Totals (trigger stop with a 1)
If both start and stop =1, then totals are stopped

• Bit #11 – Start Smart Meter Verification (Continue Measuring Mode
only)
Trigger start with a 1, no abort

• Bit #12 – Reset all Inventory Totals

• Bit #13 – Bit #31 for future expansion

DWORD

Table A-15: External process data

Assembly
Dword
index

Name Data type

0 Common output data See Table A-14

1 External Pressure REAL

2 External Temperature REAL

Table A-16: Batcher

Assembly
Dword
index

Name Data type

0 Common output data See Table A-14

1 Batch Target REAL
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Table A-16: Batcher (continued)

Assembly
Dword
index

Name Data type

2 Batcher Control – Discrete Actions

• Bit #0 – Reserved

• Bit #1 – Start Fill

• Bit #2 – End Fill

• Bit #3 – Pause Fill

• Bit #4 – Resume Fill

• Bit #5 – Reserved

• Bit #6 – Start Training

• Bit #7 – Save AOC Calibration

• Bit #8 – Reset Batch Total

• Bit #9 – Print Batch Ticket

• Bit #10 – Reset Preset 1 Inventory

• Bit #11 – Reset Preset 2 Inventory

• Bit #12 – Reset Preset 3 Inventory

• Bit #13 – Reset Preset 4 Inventory

• Bit #14 – Reset Preset 5 Inventory

• Bit #15 – Reset Preset 6 Inventory

• Bit #16 – Inhibit Totalizer

• Bit #17 – Inhibit Flow

• Bit #18 – Inhibit Batch

• Bit #19 – Bit #31 for future expansion

DWORD

3 Maximum Batch Time (Reg 1305) REAL

4 Batch Preset UINT

Table A-17: Batcher and external process data

Assembly
Dword
index

Name Data type

0–2 External process data See Table A-15

3 Batch Target REAL

Input and output slots Integration Guide
June 2022 MMI-20029785

42 Micro Motion 5700 Ethernet transmitters



Table A-17: Batcher and external process data (continued)

Assembly
Dword
index

Name Data type

4 Batcher Control – Discrete Actions

• Bit #0 – Reserved

• Bit #1 – Start Fill

• Bit #2 – End Fill

• Bit #2 – Pause Fill

• Bit #4 – Resume Fill

• Bit #5 – Reserved

• Bit #6 – Start Training

• Bit #7 – Save AOC Calibration

• Bit #8 – Reset Batch Total

• Bit #9 – Print Batch Ticket

• Bit #10 – Reset Preset 1 Inventory

• Bit #11 – Reset Preset 2 Inventory

• Bit #12 – Reset Preset 3 Inventory

• Bit #13 – Reset Preset 4 Inventory

• Bit #14 – Reset Preset 5 Inventory

• Bit #15 – Reset Preset 6 Inventory

• Bit #16 – Inhibit Totalizer

• Bit #17 – Inhibit Flow

• Bit #18 – Inhibit Batch

• Bit #19 – Bit #31 for future expansion

DWORD

5 Maximum Batch Time (Reg 1305) REAL

6 Batch Preset UINT

Table A-18: Output configurable data

Assembly
Dword
index

Name Data type

0 Common output data DWORD

1 Configurable Slot 1 (Register) DWORD

2 Configurable Slot 2 (Register) DWORD

3 Configurable Slot 3 (Register) DWORD

4 Configurable Slot 4 (Register) DWORD

5 Configurable Slot 5 (Register) DWORD
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Table A-18: Output configurable data (continued)

Assembly
Dword
index

Name Data type

6 Configurable Slot 6 (Register) DWORD

7 Configurable Slot 7 (Register) DWORD

8 Configurable Slot 8 (Register) DWORD

9 Configurable Slot 9 (Coil) DWORD

10 Configurable Slot 10 (Coil) DWORD

11 Configurable Slot 11 (Coil) DWORD

12 Configurable Slot 12 (Coil) DWORD

Table A-19: Advanced Phase Measurement (APM)

Assembly
Dword
index

Name Data type

0 Common output data See Table A-14

1 External Pressure REAL

2 External Temperature REAL

3 External Water Cut REAL
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