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Part I
Getting started

Chapters covered in this part:

• Introduction to filling with the Filling Mass Transmitter

• Quick start using ProLink II

• Quick start using the PROFIBUS EDD

• Quick start using PROFIBUS bus parameters
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1 Introduction to filling with the Filling
Mass Transmitter
Topics covered in this chapter:

• The Filling Mass Transmitter from Micro Motion

• Fill types and fill options

• Options for user interface

1.1 The Filling Mass Transmitter from
Micro Motion
The Filling Mass Transmitter is designed for any process that requires high-speed high-
accuracy filling or dosing.

The Filling Mass Transmitter, paired with a Coriolis sensor from Micro Motion, enables
mass-based measurement that is immune to variations in process fluid, temperature, or
pressure. Integrated-valve-control fills are implemented via high-precision discrete
outputs, for the fastest possible valve response. Automatic Overshoot Compensation
adjusts the system to minimize processing delays in valve control. Volume-based filling is
also available.

The Filling Mass Transmitter implements all of the advanced digital signal processing
algorithms, diagnostics, and features of the Micro Motion family of transmitters.

1.2 Fill types and fill options
Depending on your purchase option, the Filling Mass Transmitter supports either
integrated-valve-control fills or external-valve-control fills. For integrated-valve-control
installations, there are five types of integrated-valve-control fills and three fill options. Each
fill type and combination has different output requirements and is configured differently.

Fill types and descriptionsTable 1-1:   

Transmitter model code Supported fill types Description

FMT*P

FMT*Q

External valve control The transmitter measures flow and sends flow data to a host
over the frequency/pulse output. The host opens and closes
the valves and performs fill measurement. The transmitter is
unaware of the filling application.

FMT*R

FMT*S

FMT*T

Integrated valve control The host inititates the fill. The transmitter resets the fill total,
opens the valves, performs fill measurement, and closes the
valves.

Introduction to filling with the Filling Mass Transmitter
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Fill types and descriptions (continued)Table 1-1:   

Transmitter model code Supported fill types Description

FMT*U

FMT*V

One-stage discrete The fill is controlled by a single discrete (ON/OFF) valve. The
valve opens completely when the fill begins, and closes com-
pletely when Fill Target is reached, or the fill is paused or ended.

Two-stage discrete The fill is controlled by two discrete valves: a primary valve and
a secondary valve. One valve must open at the beginning of
the fill; the other opens at a user-defined point. One valve
must stay open until the end of the fill; the other closes at a
user-defined point.

Timed The valve is open for the specified number of seconds.

Dual-fillhead Fill sequence:
1. Container #1 is moved into position.
2. Fillhead #1 begins filling Container #1, and Container #2 is

moved into position.
3. Fill #1 ends. Fillhead #2 begins filling Container #2. Con-

tainer #1 is replaced by a new container.

Standard one-stage filling control is implemented for both fills:
The valve opens completely when the fill begins, and closes
completely when Fill Target is reached, or the fill is paused or
ended.

Dual-fillhead timed Fill sequence:
1. Container #1 is moved into position.
2. Fillhead #1 begins filling Container #1, and Container #2 is

moved into position.
3. Fill #1 ends. Fillhead #2 begins filling Container #2. Con-

tainer #1 is replaced by a new container.

Timed control is implemented for both fills: Each valve is open
for the specified number of seconds.

Fill options and descriptionsTable 1-2:   

Option Description Compatibility

Purge The Purge feature is used to control an auxiliary valve that
can be used for any non-filling purpose. For example, it can
be used for adding water or gas to the container after the
fill ends, or “padding.” Flow through the auxiliary valve is
not measured by the transmitter.

Compatible with:

• One-stage discrete fills
• Two-stage discrete fills
• Timed fills

Pump The Pump feature is used to increase pressure during the
fill by starting an upstream pump just before the fill begins.

Compatible with:

• One-stage discrete fills

Automatic Over-
shoot Compensa-
tion (AOC)

Automatic Overshoot Compensation (AOC) is used to ad-
just fill timing to compensate for the time required to
transmit the valve close command or for the valve to close
completely.

Compatible with:

• One-stage discrete fills
• Two-stage discrete fills
• Dual-fillhead fills

Introduction to filling with the Filling Mass Transmitter
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1.2.1 I/O requirements
To implement a specific fill type and fill option, the transmitter outputs must be wired to
the appropriate valves or devices, and configured appropriately.

I/O requirements for fill types and fill optionsTable 1-3:   

Fill type
Precision
DO1

Precision
DO2

Channel B
operating as
DO mA output

Frequency
output

External valve control N/A N/A As desired N/A To host

Integrated
valve control

One-stage discrete Primary valve N/A N/A As desired N/A

One-stage discrete
with purge

Primary valve N/A Purge valve As desired N/A

One-stage discrete
with pump

Primary valve Pump As desired As desired N/A

Two-stage discrete Primary valve Secondary
valve

As desired As desired N/A

Two-stage discrete
with purge

Primary valve Secondary
valve

Purge valve As desired N/A

Timed Primary valve N/A As desired As desired N/A

Timed with purge Primary valve N/A Purge valve As desired N/A

Dual-fillhead Valve in
Fillhead #1

Valve in
Fillhead #2

As desired As desired N/A

Timed dual-fillhead Valve in
Fillhead #1

Valve in
Fillhead #2

As desired As desired N/A

1.3 Options for user interface
Your options for user interface and fill operation depend on the protocol supported by
your transmitter. Your transmitter's model code identifies the protocol.

Transmitter protocol and user interface optionsTable 1-4:   

Transmitter model
code Supported protocol

User interface options

Configuration, maintenance,
and troubleshooting Fill operation

FMT*P

FMT*R

FMT*S

FMT*T

Modbus • ProLink II
• Modbus utility

• ProLink II
• Modbus host

Introduction to filling with the Filling Mass Transmitter
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Transmitter protocol and user interface options (continued)Table 1-4:   

Transmitter model
code Supported protocol

User interface options

Configuration, maintenance,
and troubleshooting Fill operation

FMT*Q

FMT*U

FMT*V

PROFIBUS-DP • ProLink II
• EDD
• Bus parameters

• ProLink II
• EDD
• GSD
• Bus parameters

Introduction to filling with the Filling Mass Transmitter
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2 Quick start using ProLink II
Topics covered in this chapter:

• Power up the transmitter

• Check flowmeter status

• Connect from ProLink II to the transmitter

• Complete the configuration and commissioning process

2.1 Power up the transmitter
The transmitter must be powered up for all configuration and commissioning tasks, or for
process measurement.

1. Follow appropriate procedures to ensure that a new device on the network does not
interfere with existing measurement and control loops.

2. Ensure that the cables are connected to the transmitter, as described in Micro Motion
Filling Mass Transmitters: Installation Manual .

3. Ensure that all transmitter and sensor covers and seals are closed.

CAUTION!

To prevent ignition of flammable or combustible atmospheres, ensure that all covers
and seals are tightly closed. For hazardous area installations, applying power while
housing covers are removed or loose can cause an explosion.

4. Turn on the electrical power at the power supply.

The transmitter will automatically perform diagnostic routines. During this period,
Alarm 009 is active. The diagnostic routines should complete in approximately
30 seconds.

Postrequisites

Although the sensor is ready to receive process fluid shortly after power-up, the electronics
can take up to 10 minutes to reach thermal equilibrium. Therefore, if this is the initial
startup, or if power is been off long enough to allow components to reach ambient
temperature, allow the electronics to warm up for approximately 10 minutes before
relying on process measurements. During this warm-up period, you may observe minor
measurement instability or inaccuracy.

2.2 Check flowmeter status
Check the flowmeter for any error conditions that require user action or that affect
measurement accuracy.

Quick start using ProLink II
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1. Wait approximately 10 seconds for the power-up sequence to complete.

Immediately after power-up, the transmitter runs through diagnostic routines and
checks for error conditions. During the power-up sequence, Alarm A009 is active.
This alarm should clear automatically when the power-up sequence is complete.

2. Connect to the transmitter and check for active alarms.

Postrequisites

For information on viewing the list of active alarms, see Section 18.3.

For information on individual alarms and suggested resolutions, see Section 20.1.

2.3 Connect from ProLink II to the transmitter
Making a connection from ProLink II allows you to view process data, use ProLink II to
configure the transmitter, perform maintenance and troubleshooting tasks, or run a fill.

Prerequisites

You must have the following installed and ready to use:

• ProLink II v2.91 or later

• ProLink II installation kit for Modbus/RS-485 connections

Procedure

1. Attach the leads of your signal converter to the wires that are attached to the
RS-485 or service port pins on the transmitter. See Micro Motion Filling Mass
Transmitters: Installation Manual for more information.

2. Start ProLink II and choose Connect > Connect to Device.

3. In the Connection dialog box, enter parameters as shown here, then click Connect.

Connection parameter

Transmitter protocol

Modbus PROFIBUS-DP

Protocol Modbus RTU Service Port

COM Port The port on your PC that you
are using for this connection

The port on your PC that you
are using for this connection

Address Transmitter's configured
Modbus address (default = 1)

N/A

Note
The transmitter automatically analyzes the incoming connection request and responds to all
connection requests with any setting for parity and stop bits, and all network speeds between
1200 and 38,400 baud. You do not need to set values for these connection parameters.

Quick start using ProLink II
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If the connection is successful, ProLink II displays the Process Variables screen.

Need help?  If an error message is displayed:

• Ensure that you have specified the correct COM port.

• Check all the wiring between your PC and the transmitter.

• Add 120-Ω, 1/2-watt terminating resistors at both ends of the segment.

2.4 Complete the configuration and
commissioning process
Use the following procedure as a general guideline to complete transmitter configuration
and commissioning.

1. Configure the fill.

• For integrated-valve-control fills, see Chapter 6.

• For external-valve-control fills, see Chapter 12.

2. Perform any required transmitter configuration that is not specifically related to
filling.

See Chapter 15, Chapter 16, and Chapter 17.

3. Test or tune your system using sensor simulation.

See Section 2.4.1.

4. Back up the transmitter configuration to a file on your PC.

See Section 2.4.2.

Need help?  At any time, you can restore the factory configuration to return the transmitter to a
known operational configuration. See Section 2.4.3.

2.4.1 Test or tune the system using sensor simulation
Use sensor simulation to test the system's response to a variety of process conditions,
including boundary conditions, problem conditions, or alarm conditions, or to tune the
loop.

Prerequisites

Before enabling sensor simulation, ensure that your process can tolerate the effects of the
simulated process values.

Procedure

1. Navigate to the sensor simulation menu.

Quick start using ProLink II
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Communications tool Menu path

ProLink II ProLink > Configuration > Sensor Simulation

ProLink III Device Tools > Diagnostics > Testing > Sensor Simulation

2. Enable sensor simulation.

3. For mass flow, set Wave Form as desired and enter the required values.

Option Required values

Fixed Fixed Value

Sawtooth Period

Minimum

Maximum

Sine Period

Minimum

Maximum

4. For density, set Wave Form as desired and enter the required values.

Option Required values

Fixed Fixed Value

Sawtooth Period

Minimum

Maximum

Sine Period

Minimum

Maximum

5. For temperature, set Wave Form as desired and enter the required values.

Option Required values

Fixed Fixed Value

Sawtooth Period

Minimum

Maximum

Sine Period

Minimum

Maximum

6. Observe the system response to the simulated values and make any appropriate
changes to the transmitter configuration or to the system.

7. Modify the simulated values and repeat.

Quick start using ProLink II
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8. When you have finished testing or tuning, disable sensor simulation.

Sensor simulation
Sensor simulation allows you to test the system or tune the loop without having to create
the test conditions in your process. When sensor simulation is enabled, the transmitter
reports the simulated values for mass flow, density, and temperature, and takes all
appropriate actions. For example, the transmitter might apply a cutoff, activate an event,
or post an alarm.

When sensor simulation is enabled, the simulated values are stored in the same memory
locations used for process data from the sensor. The simulated values are then used
throughout transmitter functioning. For example, sensor simulation will affect:

• All mass flow rate, temperature, and density values shown on the display or
reported via outputs or digital communications

• The mass total and mass inventory values

• All volume calculations and data, including reported values, volume totals, and
volume inventories

• All mass, temperature, density, or volume values logged to Data Logger

Sensor simulation does not affect any diagnostic values.

Unlike actual mass flow rate and density values, the simulated values are not temperature-
compensated (adjusted for the effect of temperature on the sensor’s flow tubes).

2.4.2 Back up transmitter configuration
ProLink II and ProLink III provide a configuration upload/download function which allows
you to save configuration sets to your PC. This allows you to back up and restore your
transmitter configuration. It is also a convenient way to replicate a configuration across
multiple devices.

Prerequisites

One of the following:

• An active connection from ProLink II

• An active connection from ProLink III

Restriction
This function is not available with any other communications tools.

Procedure

• To back up the transmitter configuration using ProLink II:

1. Choose File > Load from Xmtr to File.

2. Specify a name and location for the backup file, and click Save.

Quick start using ProLink II
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3. Select the options that you want to include in the backup file, and click Download
Configuration.

• To back up the transmitter configuration using ProLink III:

1. Choose Device Tools > Configuration Transfer > Save or Load Configuration Data.

2. In the Configuration groupbox, select the configuration data you want to save.

3. Click Save, then specify a file name and location on your computer.

4. Click Start Save.

The backup file is saved to the specified name and location. It is saved as a text file and can
be read using any text editor.

2.4.3 Restore the factory configuration

ProLink II ProLink > Configuration > Device > Restore Factory Configuration

ProLink III Device Tools > Configuration Transfer > Restore Factory Configuration

Overview

Restoring the factory configuration returns the transmitter to a known operational
configuration. This may be useful if you experience problems during configuration.

Tip
Restoring the factory configuration is not a common action. You may want to contact Micro Motion
to see if there is a preferred method to resolve any issues.

Quick start using ProLink II
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3 Quick start using the PROFIBUS EDD
Topics covered in this chapter:

• Power up the transmitter

• Check flowmeter status

• Set up the PROFIBUS EDD

• Make a PROFIBUS EDD connection to the transmitter

• Complete the configuration and commissioning process

3.1 Power up the transmitter
The transmitter must be powered up for all configuration and commissioning tasks, or for
process measurement.

1. Follow appropriate procedures to ensure that a new device on the network does not
interfere with existing measurement and control loops.

2. Ensure that the cables are connected to the transmitter, as described in Micro Motion
Filling Mass Transmitters: Installation Manual .

3. Ensure that all transmitter and sensor covers and seals are closed.

CAUTION!

To prevent ignition of flammable or combustible atmospheres, ensure that all covers
and seals are tightly closed. For hazardous area installations, applying power while
housing covers are removed or loose can cause an explosion.

4. Turn on the electrical power at the power supply.

The transmitter will automatically perform diagnostic routines. During this period,
Alarm 009 is active. The diagnostic routines should complete in approximately
30 seconds.

Postrequisites

Although the sensor is ready to receive process fluid shortly after power-up, the electronics
can take up to 10 minutes to reach thermal equilibrium. Therefore, if this is the initial
startup, or if power is been off long enough to allow components to reach ambient
temperature, allow the electronics to warm up for approximately 10 minutes before
relying on process measurements. During this warm-up period, you may observe minor
measurement instability or inaccuracy.

Quick start using the PROFIBUS EDD
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3.2 Check flowmeter status
Check the flowmeter for any error conditions that require user action or that affect
measurement accuracy.

1. Wait approximately 10 seconds for the power-up sequence to complete.

Immediately after power-up, the transmitter runs through diagnostic routines and
checks for error conditions. During the power-up sequence, Alarm A009 is active.
This alarm should clear automatically when the power-up sequence is complete.

2. Connect to the transmitter and check for active alarms.

Postrequisites

For information on viewing the list of active alarms, see Section 18.3.

For information on individual alarms and suggested resolutions, see Section 20.1.

3.3 Set up the PROFIBUS EDD
The PROFIBUS EDD supports acyclic communications between the transmitter and a
PROFIBUS host. You can use the EDD to configure the transmitter and perform manual
operation and maintenance functions.

1. Download the EDD for your transmitter from the Emerson web site.

a. Use your browser to go to www.micromotion.com.

b. In the Quick Links list, click Software Downloads , then navigate to the Device
Drivers page.

c. Drill down to the device install kit for your transmitter, select the EDD, and
download it to your PC.

2. Import the EDD into your PROFIBUS host.

3. Configure your PROFIBUS host with the transmitter's node address and any other
required data.

Tip
The transmitter's node address was set during transmitter installation. See Micro Motion Filling
Mass Transmitters: Installation Manual for more information.

3.4 Make a PROFIBUS EDD connection to the
transmitter
Making a PROFIBUS EDD connection allows you to use the PROFIBUS EDD and your
PROFIBUS tool to view process data, configure the transmitter, perform maintenance and
troubleshooting tasks, or run a fill.

Quick start using the PROFIBUS EDD
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Prerequisites

You must have a PROFIBUS configuration tool such as Siemens Simatic PDM.

The EDD from Micro Motion must be installed.

Procedure

1. Launch your PROFIBUS configuration tool.

2. Connect to the transmitter using the methods appropriate to your environment.

Tip
The transmitter's node address was set during transmitter installation. See Micro Motion Filling
Mass Transmitters: Installation Manual for more information.

3.5 Complete the configuration and
commissioning process
Use the following procedure as a general guideline to complete transmitter configuration
and commissioning.

1. Configure the fill.

• For integrated-valve-control fills, see Chapter 8.

• For external-valve-control fills, see Chapter 13.

2. Perform any required transmitter configuration that is not specifically related to
filling.

See Chapter 15, Chapter 16, and Chapter 17.

Quick start using the PROFIBUS EDD
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4 Quick start using PROFIBUS bus
parameters
Topics covered in this chapter:

• Power up the transmitter

• Check flowmeter status

• Make a PROFIBUS bus parameters connection to the transmitter

• Complete the configuration and commissioning process

4.1 Power up the transmitter
The transmitter must be powered up for all configuration and commissioning tasks, or for
process measurement.

1. Follow appropriate procedures to ensure that a new device on the network does not
interfere with existing measurement and control loops.

2. Ensure that the cables are connected to the transmitter, as described in Micro Motion
Filling Mass Transmitters: Installation Manual .

3. Ensure that all transmitter and sensor covers and seals are closed.

CAUTION!

To prevent ignition of flammable or combustible atmospheres, ensure that all covers
and seals are tightly closed. For hazardous area installations, applying power while
housing covers are removed or loose can cause an explosion.

4. Turn on the electrical power at the power supply.

The transmitter will automatically perform diagnostic routines. During this period,
Alarm 009 is active. The diagnostic routines should complete in approximately
30 seconds.

Postrequisites

Although the sensor is ready to receive process fluid shortly after power-up, the electronics
can take up to 10 minutes to reach thermal equilibrium. Therefore, if this is the initial
startup, or if power is been off long enough to allow components to reach ambient
temperature, allow the electronics to warm up for approximately 10 minutes before
relying on process measurements. During this warm-up period, you may observe minor
measurement instability or inaccuracy.

Quick start using PROFIBUS bus parameters
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4.2 Check flowmeter status
Check the flowmeter for any error conditions that require user action or that affect
measurement accuracy.

1. Wait approximately 10 seconds for the power-up sequence to complete.

Immediately after power-up, the transmitter runs through diagnostic routines and
checks for error conditions. During the power-up sequence, Alarm A009 is active.
This alarm should clear automatically when the power-up sequence is complete.

2. Connect to the transmitter and check for active alarms.

Postrequisites

For information on viewing the list of active alarms, see Section 18.3.

For information on individual alarms and suggested resolutions, see Section 20.1.

4.3 Make a PROFIBUS bus parameters connection
to the transmitter
Making a PROFIBUS bus parameters connection allows you to use PROFIBUS bus
parameters and your PROFIBUS tool to view process data, configure the transmitter,
perform maintenance and troubleshooting tasks, or run a fill.

Prerequisites

You must have a PROFIBUS tool that supports DP-V1 read and write services.

Procedure

1. Launch your PROFIBUS tool.

2. Connect to the transmitter using the methods appropriate to your environment.

Tip
The transmitter's node address was set during transmitter installation. See Micro Motion Filling
Mass Transmitters: Installation Manual for more information.

4.4 Complete the configuration and
commissioning process
Use the following procedure as a general guideline to complete transmitter configuration
and commissioning.

1. Configure the fill.

• For integrated-valve-control fills, see Chapter 10.

• For external-valve-control fills, see Chapter 14.

Quick start using PROFIBUS bus parameters
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2. Perform any required transmitter configuration that is not specifically related to
filling.

See Chapter 15, Chapter 16, and Chapter 17.

Need help?  At any time, you can restore the factory configuration to return the transmitter to a
known operational configuration. See Section 4.4.1.

4.4.1 Restore the factory configuration using PROFIBUS bus
parameters
Restoring the factory configuration returns the transmitter to a known operational
configuration. This may be useful if you experience problems during configuration.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

Write 1 to the Diagnostic block, Index 51.

Quick start using PROFIBUS bus parameters

Configuration and Use Manual 19



Quick start using PROFIBUS bus parameters

20  Micro Motion® Filling Mass Transmitters with PROFIBUS-DP



Part II
Configure and operate integrated-valve-
control fills

Chapters covered in this part:

• Preparing to configure an integrated-valve-control fill

• Configure an integrated-valve-control fill using ProLink II

• Fill operation using ProLink II

• Configure an integrated-valve-control fill using the PROFIBUS EDD

• Fill operation using the PROFIBUS EDD

• Configure an integrated-valve-control fill using PROFIBUS bus parameters

• Fill operation using PROFIBUS bus parameters

Configure and operate integrated-valve-control fills
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5 Preparing to configure an integrated-
valve-control fill
Topics covered in this chapter:

• General procedure for configuring and running an integrated-valve-control fill

• Tips and tricks for configuring an integrated-valve-control fill

Preparing to configure an integrated-valve-control fill
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5.1 General procedure for configuring and running
an integrated-valve-control fill

Configuring and running an integrated-valve-control fillFigure 5-1:   

Configure fill

Configure fill options

Configure fill control methods

Configure fill reporting methods

Choose fill type

Fill operation methodManual Automatic

Choose operation tool

Run fill

Set up and program host

Run fill

Choose configuration tool
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5.2 Tips and tricks for configuring an integrated-
valve-control fill
Before beginning your fill configuration, review the following:

• When you configure a fill, start with the factory-default settings. If you do not, the
transmitter may reject certain parameter combinations. See Section 5.2.1.

• The setting of Mass Flow Cutoff or Volume Flow Cutoff is important for fill accuracy. Be
sure to set the appropriate cutoff before running a fill, or before performing AOC
calibration. If you are using mass to measure the fill, see Section 15.2.3. If you are
using volume to measure the fill, see Section 15.3.2.

• The setting of Flow Direction controls how your fill total is measured. For integrated-
valve-control fills, see Effect of Flow Direction on the fill total.

• Fill measurement and operation may be affected by other transmitter parameters.
Review the general configuration information in Chapter 15, Chapter 16, and 
Chapter 17.

• You can change the fill configuration or general transmitter configuration while a fill
is running. The configuration change will take effect after the fill ends.

5.2.1 Factory-default settings for basic fill parameters
When you configure a fill, start with the factory-default settings listed here. If you do not,
the transmitter may reject certain parameter combinations.

Basic fill parameters and factory-default settingsTable 5-1:   

Parameter Factory-default setting

Enable Filling Option Enabled

Enable Dual Fill Disabled

Enable AOC Enabled

Enable Purge Disabled

Enable Timed Fill Disabled

Fill Type One Stage Discrete

Count Up Enabled

Configure By % Target

Preparing to configure an integrated-valve-control fill
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6 Configure an integrated-valve-
control fill using ProLink II
Topics covered in this chapter:

• Configure an integrated-valve-control fill using ProLink II

• Configure fill options using ProLink II

• Configure fill control using ProLink II (optional)

• Configure fill reporting using ProLink II (optional)

6.1 Configure an integrated-valve-control fill using
ProLink II
Configure the fill type that is appropriate for your application.

Tip
A one-stage discrete fill is appropriate for most applications. Use this fill type unless you have specific
requirements for another fill type. In most cases, the transmitter is configured for a one-stage
discrete fill at the factory, and will be operational with a minimum of site configuration.

6.1.1 Configure a one-stage discrete fill using ProLink II
Configure a one-stage discrete fill when you want to fill a single container from a single
valve. The valve will be open until Fill Target is reached.

Prerequisites

Ensure that you are starting from the factory-default configuration.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Choose ProLink > Configuration > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

Configure an integrated-valve-control fill using ProLink II
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Option Signal from transmitter Voltage

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Open the Flow panel.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Open the Filling panel.

4. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Configure an integrated-valve-control fill using ProLink II
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Option Description

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Enable Dual Fill Disabled

Enable AOC Enabled

Enable Purge Disabled

Enable Timed Fill Disabled

Fill Type One Stage Discrete

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.

6. Set Count Up as desired.

Count Up controls how the fill total is calculated and displayed.

Option Description

Enabled The fill total starts at 0 and increases toward Fill Target.

Disabled The fill total starts at Fill Target and decreases toward 0.

7. Set Fill Target to the quantity at which the fill will be complete.

Enter the value in the measurement units configured for Flow Source.

8. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.

To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

9. Set Measured Fill Time as desired.

Measured Fill Time controls how the fill duration will be measured.

Configure an integrated-valve-control fill using ProLink II
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Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.

Postrequisites

Options for one-stage discrete fills include:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.

• Implementing the Purge feature.

• Implementing the Pump feature.

6.1.2 Configure a two-stage discrete fill using ProLink II
Configure a two-stage discrete fill when you want to fill a single container from two valves.

Prerequisites

Ensure that you are starting from the factory-default configuration.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Open the Discrete Output panel.

b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

d. Set Precision DO2 to Secondary Valve.

e. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Configure an integrated-valve-control fill using ProLink II
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Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Open the Flow panel.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Open the Filling panel.

4. Set Flow Source to the process variable to be used to measure this fill.
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Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Enable Dual Fill Disabled

Enable AOC Enabled

Enable Purge Disabled

Enable Timed Fill Disabled

Fill Type Two Stage Discrete

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.

6. Set Count Up as desired.

Count Up controls how the fill total is calculated and displayed.

Option Description

Enabled The fill total starts at 0 and increases toward Fill Target.

Disabled The fill total starts at Fill Target and decreases toward 0.

7. Set Configure By as desired.

Configure By controls how valve control timing is configured.

Option Description

% Target Valve Open and Valve Close timing is configured as a percentage of Fill Target. For
example:
• Valve Open = 0%: The valve opens when the current fill total is 0% of Fill Target.
• Valve Close = 90%: The valve closes when the current fill total is 90% of Fill Tar-

get.

Quantity Valve Open and Valve Close timing is configured in terms of the configured meas-
urement unit. For example:
• Valve Open = 0 g: The valve opens when the current fill total is 0 g.
• Valve Close = 50 g: The valve closes when the current fill total is 50 g less than

Fill Target.
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8. Set Fill Target to the quantity at which the fill will be complete.

Enter the value in the measurement units configured for Flow Source.

9. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.

To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

10. Set Measured Fill Time as desired.

Measured Fill Time controls how the fill duration will be measured.

Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.

11. Set Open Primary, Open Secondary, Close Primary, and Close Secondary as desired.

These values control the point in the fill at which the primary and secondary valves
open and close. They are configured either by quantity or by percent of the target,
as controlled by the Configure By parameter.

Either Open Primary or Open Secondary must be set to open at the beginning of the fill.
Both can open at the beginning of the fill if desired. If you set one to open later, the
other one is automatically reset to open at the beginning.

Either Close Primary or Close Secondary must be set to close at the end of the fill. Both
can close at the end of the fill if desired. If you set one to close earlier, the other one
is automatically reset to close at the end.

Postrequisites

Options for two-stage discrete fills include:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.

• Implementing the Purge feature.

Valve opening and closing sequences for two-stage discrete
fills
The following figures illustrate the opening and closing of the primary and secondary
valves, as controlled by the configuration of Open Primary, Open Secondary, Close Primary, and
Close Secondary.

These illustrations assume that the fill runs from beginning to end without interruption.
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Open Primary first, Close Primary firstFigure 10-1:   
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Open Primary first, Close Secondary firstFigure 10-2:   
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Open Secondary first, Close Primary firstFigure 10-3:   
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Open Secondary first, Close Secondary firstFigure 10-4:   
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Effects of Configure By on valve opening and closing
Configure By controls how the Open Primary, Open Secondary, Close Primary, and Close Secondary
values are configured and applied.

• When Configure By = % Target, the transmitter adds the configured Valve Open and
Valve Close values to 0%.

• When Configure By = Quantity, the transmitter adds the configured Valve Open values
to 0, and subtracts the configured Valve Close values from Fill Target.

Example: Configure By and valve open/close commands

Fill Target = 200 g. You want the primary valve to open at the beginning of the fill and close
at the end of the fill. You want the secondary valve to open after 10 g has been delivered,
and close after 190 g has been delivered. See Table 10-1 for the settings that will produce
this result.

Configure By and valve configuration Table 10-1:   

Configure By Valve Open and Valve Close values

% Target • Open Primary = 0%
• Open Secondary = 5%
• Close Secondary = 95%
• Close Primary = 100%

Quantity • Open Primary = 0 g
• Open Secondary = 10 g
• Close Secondary = 10 g
• Close Primary = 0 g

6.1.3 Configure a timed fill using ProLink II
Configure a timed fill when you want to fill a single container from a single valve. The valve
will be open for the specified number of seconds.

Prerequisites

Ensure that you are starting from the factory-default configuration.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Choose ProLink > Configuration > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.
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Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Open the Flow panel.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled
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Parameter Setting

Count Up Enabled

Enable Dual Fill Disabled

Enable AOC Disabled

Enable Purge Disabled

Enable Timed Fill Enabled

Fill Type One Stage Discrete

4. Set Target Time to the number of seconds that the fill will run.

Postrequisites

The following option is available for timed fills:

• Implementing the Purge feature.

6.1.4 Configure a dual-fillhead fill using ProLink II
Configure a dual-fillhead fill when you want to fill two containers alternately, using two
fillheads. Each valve will be open until Fill Target is reached.

Important
The configured Fill Target is applied to both fillheads.

Prerequisites

Ensure that you are starting from the factory-default configuration.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Choose ProLink > Configuration > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

d. Set Precision DO2 to Secondary Valve.
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e. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Open the Flow panel.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Open the Filling panel.
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4. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Count Up Enabled

Enable Dual Fill Enabled

Enable AOC Enabled

Enable Purge Disabled

Enable Timed Fill Disabled

Fill Type One Stage Discrete

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.

6. Set Fill Target to the quantity at which the fill will be complete.

Note
The configured Fill Target is applied to both fillheads.

7. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.

To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

8. Set Measured Fill Time as desired.

Measured Fill Time controls how the fill duration will be measured.

Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.
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Option Description

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.

Postrequisites

Options for dual-fillhead fills include:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.

6.1.5 Configure a dual-fillhead timed fill using ProLink II
Configure a dual-fillhead timed fill when you want to fill two containers alternately, using
two fillheads. Each valve will be open for the specified number of seconds.

Important
The configured Target Time is applied to both fillheads.

Prerequisites

Ensure that you are starting from the factory-default configuration.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Choose ProLink > Configuration > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

d. Set Precision DO2 to Secondary Valve.

e. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.
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Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Open the Flow panel.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Open the Filling panel.

4. Set Flow Source to the process variable to be used to measure this fill.
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Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Count Up Enabled

Enable Dual Fill Enabled

Enable AOC Disabled

Enable Purge Disabled

Enable Timed Fill Enabled

Fill Type One Stage Discrete

6. Set Target Time to the number of seconds that the fill will run.

Note
The configured Target Time is applied to both fillheads.

6.2 Configure fill options using ProLink II
Depending on your fill type, you can configure and implement Automatic Overshoot
Compensation, the Purge feature, or the Pump feature.

6.2.1 Configure and implement Automatic Overshoot
Compensation (AOC) using ProLink II
Automatic Overshoot Compensation (AOC) is used to adjust fill timing to compensate for
the time required to transmit the valve close command or for the valve to close
completely.

Prerequisites

Before setting up AOC, ensure that all other fill parameters are correctly configured.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Choose ProLink > Configuration > Filling.

2. Choose the type of AOC that you want to implement.
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Option Description

Fixed The valve will close at the point defined by Fill Target, minus the quantity specified
in Fixed Overshoot Comp. Use this option only if the "prewarn" value is already known.

Overfill Defines the direction used by the AOC algorithm to approach the target. The AOC
algorithm starts by estimating an overfill amount, and reduces the overfill in suc-
cessive calibration fills.

Underfill Defines the direction used by the AOC algorithm to approach the target. The AOC
algorithm starts by estimating an underfill amount, and reduces the underfill in
successive calibration fills.

Tip
The Fixed option is typically not used. If you choose Fixed, the transmitter will operate like a
legacy batch controller. In typical applications, the other AOC options provide enhanced
accuracy and repeatability.

Restriction
The Fixed and Overfill options are not supported for dual-fillhead fills.

3. To implement Fixed AOC:

a. Disable Enable AOC.

b. Set AOC Algorithm to Fixed.

c. Set Fixed Overshoot Comp as desired.

The default value is 0, measured in process units.

The transmitter will close the valve when the current fill total is equal to Fill Target
minus the specified value (in process units).

4. To implement Overfill or Underfill:

a. Ensure that Enable AOC is enabled.

b. Set AOC Algorithm to either Overfill or Underfill.
c. Set AOC Window Length to the number of fills that will be used for AOC calibration.

The default is 10. The range is 2 to 32.

Tip
Micro Motion recommends using the default value unless you have special application
requirements.

Important
Do not change the values of AOC Change Limit or AOC Convergence Rate unless you are working
with Micro Motion customer service. These parameters are used to adjust the operation of
the AOC algorithm for special application requirements.
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Postrequisites

If you set AOC Algorithm to Overfill or Underfill, you must perform an AOC calibration.

Perform AOC calibration using ProLink II
AOC calibration is used to calculate the AOC (Automatic Overshoot Compensation) value
from actual fill data. If you set AOC Algorithm to Overfill or Underfill, you must perform AOC
calibration.

There are two types of AOC calibration:

• Standard: The calibration is performed manually. The AOC coefficient is calculated
from fill data obtained during this calibration, and the same AOC coefficient is
applied until the calibration is repeated.

• Rolling: The calibration is performed continuously and automatically, and the AOC
coefficient is updated continuously based on fill data from the last set of fills.

Tip
For stable processes, Micro Motion recommends standard AOC calibration. If required, test both
methods and choose the method that yields the best results.

Perform standard AOC calibration

Standard AOC calibration is used to generate a constant AOC coefficient.

Prerequisites

AOC Window Length must be set appropriately. Micro Motion recommends using the default
value (10) unless you have special application requirements.

Mass Flow Cutoff or Volume Flow Cutoff must be set appropriately for your environment.

• If Flow Source is set to Mass Flow Rate, see Section 15.2.3.

• If Flow Source is set to Volume Flow Rate, see Section 15.3.2.

Your system must be ready to run fills, and you must know how to run fills.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Choose ProLink > Run Filler.
2. To calibrate the primary valve (all fill types):

a. Click Start AOC Cal.
b. Run two or more calibration fills, up to the number specified in AOC Window

Length.
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Note
You can run more calibration fills if you choose. The AOC coefficient is calculated from the
most recent fills.

Tip
In common use, the first few fills are slightly overfilled or underfilled due to factory-default
settings. As the calibration proceeds, the fills will converge on Fill Target.

c. When the fill totals are consistently satisfactory, click Save AOC Cal.

3. To calibrate the secondary valve (dual-fillhead fills):

a. Click Start Secondary AOC Cal.
b. Run two or more calibration fills, up to the number specified in AOC Window

Length.

The transmitter automatically runs fills through the secondary valve.

Note
You can run more calibration fills if you choose. The AOC coefficient is calculated from the
most recent fills.

Tip
In common use, the first few fills are slightly overfilled or underfilled due to factory-default
settings. As the calibration proceeds, the fills will converge on Fill Target.

c. When the fill totals are consistently satisfactory, click Save Secondary AOC Cal.

The current AOC coefficient is displayed in the Run Filler window. If you are running a dual-
fillhead fill, the Run Filler window displays the AOC coefficient for both the primary and the
secondary valve. These coefficients will be applied to fills as long as AOC is enabled.

Note
For two-stage discrete fills, the AOC value is applied to the valve that closes when the target is
reached. If the fill is configured to close both valves when the target is reached, the AOC value is
applied to both.

Tip
Micro Motion recommends repeating the AOC calibration if any of the following are true:

• Equipment has been replaced or adjusted.

• The flow rate has changed significantly.

• Fill accuracy is consistently lower than expected.

• Mass Flow Cutoff or Volume Flow Cutoff has been changed.
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Set up rolling AOC calibration

Rolling AOC calibration is used to update the AOC coefficient continuously, based on fill
data from the last set of fills.

Prerequisites

AOC Window Length must be set appropriately. Micro Motion recommends using the default
value (10) unless you have special application requirements.

Your system must be ready to run fills, and you must know how to run fills.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Choose ProLink > Run Filler.
2. To calibrate the primary valve (all fill types), click Start AOC Cal. To calibrate the

secondary valve (dual-fillhead fills), click Start Secondary AOC Cal.

You can set up rolling AOC calibration for either valve or both valves.

3. Begin production filling.

The transmitter recalculates the AOC coefficient(s) after each fill, based on the last x fills
where x is the number specified in AOC Window Length. Current values are displayed in the
Run Filler window. If the configuration has changed or if process conditions have changed,
rolling AOC calibration will compensate for the change. However, the adjustment will take
place over several fills; that is, AOC will take a few fills to catch up.

Tip
At any time while AOC calibration is running, you can click Save AOC Cal or Save Secondary AOC Cal.
The current AOC coefficient will be saved and applied to all subsequent fills through the
corresponding valve. In other words, this action changes the AOC calibration method for that valve
from rolling to standard.

6.2.2 Configure the Purge feature using ProLink II
The Purge feature is used to control an auxiliary valve that can be used for any non-filling
purpose. For example, it can be used for adding water or gas to the container after the fill
ends, or “padding.” Flow through the auxiliary valve is not measured by the transmitter.
You can configure the Purge feature for automatic or manual purge control. If you choose
automatic control, the auxiliary valve is opened after each fill, and closed after the
configured purge time has elapsed.

Restriction
The Purge feature is not supported for dual-fillhead fills or dual-fillhead timed fills.

Prerequisites

The discrete outputs must be wired appropriately for your fill type and fill options.
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ProLink II must be running and must be connected to the transmitter.

Procedure

1. Configure Channel B to operate as a discrete output:

a. Choose ProLink > Configuration > Channel.
b. Set Channel B Type Assignment to Discrete Output.
c. Open the Discrete Output panel.

d. Set DO1 Assignment to Discrete Batch: Purge Valve.

e. Set DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

f. Set DO1 Fault Action as appropriate for your installation.

Option Description

Upscale The discrete output will be set to ON (valve open) if a fault
occurs.

Downscale The discrete output will be set to OFF (valve closed) if a
fault occurs.

None No action will be taken if a fault occurs. The discrete out-
put will remain in the state it was in before the fault occur-
red.

2. Configure the purge:

a. Choose ProLink > Configuration > Filling.

b. Enable Enable Purge.

c. Set Purge Mode as desired.

Option Description

Auto A purge is performed automatically after each fill.

Manual Purges must be started and stopped manually.
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Tip
When Purge Mode is set to Auto, manual control of the purge valve is still possible. You can
start a purge manually and stop it manually, or you can let the transmitter stop it after
Purge Time has expired. If a purge is started automatically, you can stop it manually.

d. If you set Purge Mode to Auto, set Purge Delay to the number of seconds that the
transmitter will wait, after the fill has ended, to open the purge valve.

The default value for Purge Delay is 2 seconds.

e. If you set Purge Mode to Auto, set Purge Time to the number of seconds that the
transmitter will keep the purge valve open.

The default value for Purge Time is 1 second. The range is 0 seconds to
800 seconds.

Tip
The next fill cannot start until the purge valve is closed.

6.2.3 Configure the Pump feature using ProLink II
The Pump feature is used to increase pressure during the fill by starting an upstream pump
just before the fill begins.

Restriction
The Pump feature is not supported for two-stage discrete fills, dual-fillhead fills, timed fills, or dual-
fillhead timed fills.

Prerequisites

The discrete outputs must be wired appropriately for your fill type and fill options.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Open the Discrete Output panel.

b. Set Precision DO2 to Pump.

c. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC
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Option Signal from transmitter Voltage

OFF Site-specific up to 30 VDC

2. Choose ProLink > Configuration > Filling.

3. Set Pump to Valve Delay to the number of seconds that the pump will run before the
valve is opened.

The default value is 10 seconds. The range is 0 seconds to 30 seconds.

When the Begin Filling command is received, the transmitter starts the pump, waits for the
number of seconds specified in Pump to Valve Delay, then opens the valve. The pump runs
until the fill is ended.

6.3 Configure fill control using ProLink II (optional)
In a typical production environment, fill control (beginning and ending the fill) is
performed by the host or PLC. If you choose, you can set up the system so that you can
begin, end, pause, and resume the fill from the discrete input (if available). You can also
define an event to begin, end, pause, or resume the fill.

6.3.1 Configure the discrete input for fill control using
ProLink II
If Channel B is available, you can configure it as a discrete input and use it to begin and end
the fill, or to pause and resume a fill in progress. You can also configure it to reset the mass
total, volume total, or all totals. When the discrete input is activated, all assigned actions
will be performed.

Prerequisites

Channel B must be wired to operate as a discrete input.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Configure Channel B to operate as a discrete input.

a. Choose ProLink > Configuration > Channel.
b. Set Type Assignment for Channel B to Discrete Input.

2. Assign fill control actions to the discrete input.

a. Open the Discrete Input panel.

b. Select the action or actions to be performed when the discrete input is activated.
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Action Description Comments

Begin Filling Starts a fill using the current fill configuration.
The fill total is automatically reset before the
fill begins.

If a fill is in progress, the command is ignored.

If an automatic purge is in progress, the begin-
ning-of-fill functions are executed when the
purge is complete.

End Filling Ends the current fill and performs end-of-fill
functions. The fill cannot be resumed.

Executed while a fill is running or paused, and
during a purge or purge delay.

For dual-fillhead fills and dual-fillhead timed
fills, the command always ends the currently
active fill.

Pause Filling Timed fills, dual-fillhead fills, and dual-fillhead
timed fills: Same as End Filling.

One-stage discrete fills and two-stage discrete
fills: Temporarily stops the fill. The fill can be
resumed if the fill total is less than Fill Target.

If a purge or purge delay is in progress, the
command is ignored.

Resume Filling Restarts a fill that has been paused. Counting
resumes from the total or time at which the fill
was paused.

Executed only when a one-stage discrete fill or
a two-stage discrete fill has been paused. Ig-
nored at all other times.

Reset Mass Total Resets the value of the mass totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset Volume Total Resets the value of the volume totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset All Totals Resets the value of the mass totalizer and vol-
ume totalizer to 0, and resets the fill total to 0.

Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

c. For each selected action, open the dropdown list and select Discrete Input 1.

3. Set DI1 Polarity as appropriate for your installation.

Ensure that the ON signal sent by the discrete input is read as ON, and vice versa.

Option
Voltage applied across ter-
minals Transmitter reads

Active High 3 to 30 VDC ON

<0.8 VDC OFF

Active Low <0.8 VDC ON

3 to 30 VDC OFF
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6.3.2 Set up an event to perform fill control using ProLink II
You can assign an event to start, stop, pause, or resume a fill. You can also assign the event
to reset the mass total, volume total, or all totals. When the event transitions to ON, all
assigned actions will be performed.

Prerequisites

All events that you want to use must be configured. You can configure them before or
after you assign actions to them.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Assign fill control actions to the event.

a. Choose ProLink > Configuration > Discrete Events.

b. Identify the action or actions to be performed when Discrete Event 1 occurs.

Action Description Comments

Begin Filling Starts a fill using the current fill configuration.
The fill total is automatically reset before the
fill begins.

If a fill is in progress, the command is ignored.

If an automatic purge is in progress, the begin-
ning-of-fill functions are executed when the
purge is complete.

End Filling Ends the current fill and performs end-of-fill
functions. The fill cannot be resumed.

Executed while a fill is running or paused, and
during a purge or purge delay.

For dual-fillhead fills and dual-fillhead timed
fills, the command always ends the currently
active fill.

Pause Filling Timed fills, dual-fillhead fills, and dual-fillhead
timed fills: Same as End Filling.

One-stage discrete fills and two-stage discrete
fills: Temporarily stops the fill. The fill can be
resumed if the fill total is less than Fill Target.

If a purge or purge delay is in progress, the
command is ignored.

Resume Filling Restarts a fill that has been paused. Counting
resumes from the total or time at which the fill
was paused.

Executed only when a one-stage discrete fill or
a two-stage discrete fill has been paused. Ig-
nored at all other times.

Reset Mass Total Resets the value of the mass totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset Volume Total Resets the value of the volume totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset All Totals Resets the value of the mass totalizer and vol-
ume totalizer to 0, and resets the fill total to 0.

Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.
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2. Repeat for Discrete Events 2–5.

Example: Events monitor process and pause or end fill

The acceptable density range for your process is 1.1 g/cm3 to 1.12 g/cm3. The acceptable
temperature range is 20 °C to 25 °C. You want to pause the fill if the density goes out of
range. You want to end the fill if the temperature goes out of range.

Event configuration:

• Discrete Event 1:

- Event Type: Out of Range
- Process Variable: Density
- Low Setpoint (A): 1.1 g/cm3

- High Setpoint (B): 1.12 g/cm3

• Discrete Event 2:

- Event Type: Out of Range
- Process Variable: Temperature
- Low Setpoint (A): 20 °C

- High Setpoint (B): 25 °C

Action assignments:

• Pause Fill: Discrete Event 1
• End Fill: Discrete Event 2

Postrequisites

If you have assigned actions to events that are not configured, you must configure those
events before you can implement this fill control method.

6.3.3 Multiple actions assigned to a discrete input or event
If multiple actions are assigned to a discrete input or event, the transmitter performs only
the actions that are relevant in the current situation. If two or more of the actions are
mutually exclusive, the transmitter performs actions according to the priority scheme
defined in the transmitter firmware.

The following examples show three configurations that Micro Motion recommends, and
two configurations that are not recommended.

Example: Using the discrete input or event to begin and end the fill (recommended)

Action assignments:

• Begin Fill
• End Fill
• Reset Mass Total

Configure an integrated-valve-control fill using ProLink II

52  Micro Motion® Filling Mass Transmitters with PROFIBUS-DP



• Reset Volume Total

Result of activation:

• If no fill is running, the mass totalizer and volume totalizer are reset and a fill is
started.

• If a fill is running, it is ended and the mass totalizer and volume totalizer are reset.

Example: Using the discrete input or event to begin, pause, and resume the fill
(recommended)

Action assignments:

• Begin Fill
• Pause Fill
• Resume Fill

Result of activation:

• If no fill is running, a fill is started.

• If a fill is running and not paused, it is paused.

• If a fill is paused, it is resumed.

Example: Using the discrete input to begin the fill and reset the volume flow
(recommended)

Action assignments:

• Begin Fill
• Reset Volume Total

Result of activation:

• If no fill is running, the volume totalizer is reset and a fill is started.

• If a fill is running, the volume totalizer is reset.

Tip
This configuration is useful if you have configured your fill in terms of mass but you would also like to
know the volume total for the fill. In this case, do not activate the discrete input while the fill is in
progress. At the end of the fill, read the volume total. Then continue with the next fill.

Example: Incompatible assignments (not recommended)

Action assignments:

• Begin Fill
• End Fill
• Pause Fill
• Resume Fill

Result of activation:

• If no fill is running, a fill is started.
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• If a fill is running, it is ended.

In this example, the discrete input or event will never pause the fill because the End Fill
action takes priority.

Example: Incompatible assignments (not recommended)

Action assignments:

• End Fill
• Reset All Totals

Result of activation:

• If no fill is running, all totals, including the fill total, are reset.

• If a fill is running, it is ended and all totals, including the fill total, are reset.

The result of this combination is that the fill total is reset before the data can be retrieved.

6.4 Configure fill reporting using ProLink II
(optional)
You can configure the transmitter to report the fill ON/OFF state over Channel B (if it is
available), and percent of fill delivered over the mA output.

6.4.1 Configure Channel B to operate as a discrete output and
report the fill ON/OFF state using ProLink II
If Channel B is available, you can use it to report whether or not a fill is running.

Prerequisites

ProLink II must be running and must be connected to the transmitter.

Channel B must be wired to operate as a discrete output.

Procedure

1. Choose ProLink > Configuration > Channel.
2. Set Channel B Type Assignment to Discrete Output.
3. Open the Discrete Output panel.

4. Set DO1 Assignment to Discrete Batch: Batching/Filling In Progress
5. Set DO1 Polarity as appropriate for your installation.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC
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Option Signal from transmitter Voltage

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

6. Set DO1 Fault Action as appropriate for your installation.

Option Description

Upscale The discrete output will be set to ON (valve open) if a fault
occurs.

Downscale The discrete output will be set to OFF (valve closed) if a fault
occurs.

None No action will be taken if a fault occurs. The discrete output
will remain in the state it was in before the fault occurred.

Tip
When the discrete output is used for fill reporting, Micro Motion recommends setting DO1
Fault Action to None.

6.4.2 Configure the mA output to report percentage of fill
delivered using ProLink II
You can configure the mA output to report the percentage of Fill Target that has been
delivered. In a typical configuration, the current increases from 4 mA to 20 mA as the fill
total moves from 0% to 100%.

Prerequisites

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Choose ProLink > Configuration > Analog Output.
2. Set Secondary Variable Is to Discrete Batch: Percent Fill.
3. Set Lower Range Value to the percentage of the fill to be represented by 4 mA.

4. Set Upper Range Value to the percentage of the fill to be represented by 20 mA.

5. Set AO Fault Action as desired.

If Lower Range Value is set to 0% and Upper Range Value is set to 100%: When the fill starts, the
mA output will generate a current of 4 mA (0% of Fill Target). The current will increase in
proportion to the fill total, up to a current of 20 mA (100% of Fill Target).
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Note
If Flow Direction is set to Bidirectional or Negate Bidirectional, the fill total may decrease under certain flow
conditions. If this occurs, the current generated by the mA output will decrease proportionally.
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7 Fill operation using ProLink II
Topics covered in this chapter:

• Run an integrated-valve-control fill using ProLink II

• Perform a manual purge using ProLink II

• Perform Clean In Place (CIP) using ProLink II

• Monitor and analyze fill performance using ProLink II

7.1 Run an integrated-valve-control fill using
ProLink II
You can use ProLink II to start a fill, monitor the fill, pause and resume the fill, and end a fill.

Prerequisites

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Choose ProLink > Run Filler.
2. (Optional) If desired, enter a different value for Fill Target (one-stage discrete fills,

two-stage discrete fills, or dual-fillhead fills), or for Target Time (timed fills or dual-
fillhead timed fills).

3. (Optional) If Automatic Overshoot Compensation (AOC) is enabled, you can enter a
different value for AOC Coeff.

Tip
In production use, Micro Motion recommends leaving AOC Coeff at the value determined
during AOC calibration. If you are running AOC calibration fills and you have an AOC Coeff
value available from a similar device, you can use that value as the "first approximation" value
on the current device. This may be helpful if you want to prevent or minimize spilling.

4. Click Begin Filling.

The fill total is reset automatically and the valve(s) are opened. The Filling In Progress
indicator should be On. If it is not, and the Start Not Okay indicator or the AOC Flow Rate
Too High indicator is On instead, troubleshoot the fill configuration and try again.

5. Monitor the fill using the Current Total and Percent Fill values and the Fill Status
indicators.

Fill operation using ProLink II

Configuration and Use Manual 57



Fill progress values Description

Current Total Fill quantity at the current time. This value is affected by
Count Up:
• If Count Up is enabled, Current Total begins at 0 and increa-

ses to Fill Target.
• If Count Up is disabled, Current Total begins at Fill Target and

decreases to 0.

Percent Fill Percentage of Fill Target that has been measured up to the
current time. This value is not affected by Count Up.

Fill Status indicator Description

Filling in Progress A fill is currently being performed through the primary valve.
This indicator is active even when the fill is paused.

Secondary Fill in Progress A fill is currently being performed through the secondary
valve. This indicator is active even when the fill is paused. It
applies only to dual-fillhead fills.

Max Fill Time Exceeded The current fill has exceeded the current setting for Max Fill
Time. The fill is aborted.

Primary Valve The primary valve is open.

Secondary Valve The secondary valve is open.

Pump The pump is running.

Purge In Progress A purge has been started, either manually or automatically.

Purge Delay Phase An automatic purge cycle is in progress, and is currently in
the delay period between the completion of the fill and the
start of the purge.

Purge Valve The purge valve is open.

6. (Optional) Pause the fill if desired.

While the fill is paused, you can change the value of Current Target, end the fill
manually with End Filling, or restart the fill with Resume Filling. The fill resumes at the
current value of Current Total and Percent Fill.

Restriction
You cannot pause a timed fill or a dual-fillhead timed fill.

Important
For two-stage discrete fills, the effects of pausing and resuming the fill depend on the timing
of the valve open and valve close commands, and on the point at which the fill is paused.

7. (Optional) Use End Filling to end the fill manually if desired.

Once the fill is ended, it cannot be restarted.
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Tip
In most cases, you should allow the fill to end automatically. End the fill manually only when
you are planning to discard the fill.

7.1.1 If the fill fails to start
If the fill fails to start, check the Start Not Okay and AOC Flow Rate Too High indicators.

If the Start Not Okay indicator is On, check the following:

• Ensure that filling is enabled.

• Ensure that the previous fill has been ended.

• Ensure that Fill Target or Target Time is set to a positive number.

• Ensure that all outputs have been assigned to the valve or pump appropriate for the
fill type and fill option.

• Ensure that there are no active fault conditions at the transmitter.

• For dual-fillhead fills and dual-fillhead timed fills, ensure that no fill is running on
either fillhead.

If the AOC Flow Rate Too High indicator is on, the last measured flow rate is too high to allow
the fill to start. In other words, the AOC coefficient, compensated for the flow rate,
specifies that the valve close command should be issued before the fill has begun. This can
happen if the flow rate has increased significantly since the AOC coefficient was calculated.
Micro Motion recommends the following recovery procedure:

1. Perform any setup that is required to perform AOC calibration.

2. In the Run Filler window, click Override Blocked Start.
3. Perform AOC calibration.

4. Return your system to production filling, using the new AOC coefficient.

7.1.2 If the fill did not run to completion
If your fill terminated abnormally, check the transmitter and the Max Fill Time Exceeded
indicator.

If a fault occurs during the fill, the transmitter automatically terminates the fill.

If the Max Fill Time Exceeded indicator is On, the fill did not reach its target before the
configured Max Fill Time. Consider the following possibilities or actions:

• Increase the flow rate of your process.

• Check for entrained gas (slug flow) in your process fluid.

• Check for blockages in the flow.

• Ensure that the valves are able to close at the expected speed.

• Set Max Fill Time to a higher value.

• Disable Max Fill Time by setting it to 0.
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7.1.3 Effects of Pause and Resume on two-stage discrete fills
For two-stage discrete fills, the effects of pausing and resuming the fill depend on where
the Pause and Resume actions occur in relation to the opening and closing of the primary
and secondary valves.

Open Primary first, Close Primary first

In the following illustrations:

• The primary valve opens at the beginning of the fill.

• The secondary valve opens at the user-configured point during the fill. T represents
the time or quantity configured for Open Secondary.

• The primary valve closes before the end of the fill.

• The secondary valve closes at the end of the fill.

Case AFigure 11-1:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

Pause Resume

TT

Open Secondary 
not performed

Case BFigure 11-2:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary
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Case CFigure 11-3:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Secondary valve 
opened early

Pause Resume

Open 
Secondary

Case DFigure 11-4:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Secondary valve 
opened early

Pause Resume

Open 
Secondary

Open Primary first, Close Secondary first

In the following illustrations:

• The primary valve opens at the beginning of the fill.

• The secondary valve opens at the user-configured point during the fill. T represents
the time or quantity configured for Open Secondary.

• The secondary valve closes before the end of the fill.

• The primary valve closes at the end of the fill.
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Case EFigure 11-5:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

Pause Resume

TT

Open Secondary 
not performed

Case FFigure 11-6:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary

Case GFigure 11-7:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Secondary valve 
not reopened

Pause Resume

Open 
Secondary
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Case HFigure 11-8:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary

Secondary valve 
not reopened

Open Secondary first, Close Primary first

In the following illustrations:

• The secondary primary opens at the beginning of the fill.

• The primary valve opens at the user-configured point during the fill. T represents the
time or quantity configured for Open Primary.

• The primary valve closes before the end of the fill.

• The secondary valve closes at the end of the fill.

Case IFigure 11-9:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

Pause Resume

TT

Open Primary 
not performed
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Case JFigure 11-10:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary

Case KFigure 11-11:   

Secondary valve

Primary valve

Start Open 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary not 
performed

Close 
Primary

Case LFigure 11-12:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open Primary 
not performed

Open Secondary first, Close Secondary first

In the following illustrations:

• The secondary primary opens at the beginning of the fill.
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• The primary valve opens at the user-configured point during the fill. T represents the
time or quantity configured for Open Primary.

• The secondary valve closes before the end of the fill.

• The primary valve closes at the end of the fill.

Case MFigure 11-13:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

Pause Resume

TT

Open Primary 
not performed

Case NFigure 11-14:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary
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Case OFigure 11-15:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Primary valve 
opened early

Pause Resume

Open 
Primary

Case PFigure 11-16:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Primary valve 
opened early

Pause Resume

Open 
Primary

7.2 Perform a manual purge using ProLink II
The Purge feature is used to control an auxiliary valve that can be used for any non-filling
purpose. For example, it can be used for adding water or gas to the container after the fill
ends, or “padding.” Flow through the auxiliary valve is not measured by the transmitter.

Prerequisites

The Purge feature must be implemented on your system.

The previous fill must be ended.

The auxiliary valve must be connected to the fluid you want to use, e.g., air, water,
nitrogen.

ProLink II must be running and must be connected to the transmitter.
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Procedure

1. Choose ProLink > Run Filler.
2. Click Begin Purge.

The Purge In Progress indicator and the Purge Valve indicator turn on.

3. Allow the purge fluid to flow for the appropriate amount of time.

4. Click End Purge

The Purge In Progress indicator and the Purge Valve indicator turn off.

7.3 Perform Clean In Place (CIP) using ProLink II
The Clean In Place (CIP) function is used to force a cleaning fluid through the system. CIP
allows you to clean the interior surfaces of pipes, valves, nozzles, etc., without having to
disassemble the equipment.

Prerequisites

No fill can be running.

The cleaning fluid must be available for running through the system.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Replace the process fluid with the cleaning fluid.

2. Choose ProLink > Run Filler.
3. Click Begin Cleaning.

The transmitter opens the primary valve, and the secondary valve if it is used for
filling. If the Pump feature is enabled, the pump is started before the valve is
opened. The Cleaning In Progress indicator turns on.

4. Allow the cleaning fluid to flow through your system for the appropriate amount of
time.

5. Click End Cleaning

The transmitter closes all open valves, and stops the pump if applicable. The Cleaning
In Progress indicator turns off.

6. Replace the cleaning fluid with the process fluid.
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7.4 Monitor and analyze fill performance using
ProLink II
You can collect detailed flow data for a single fill, and you can compare data across
multiple fills.

7.4.1 Collect detailed fill data for a single fill using ProLink II
When fill logging is enabled, detailed data for the most recent fill is stored on the
transmitter. You can retrieve it for analysis using digital communications. The detailed
data can be used for tuning or troubleshooting your production environment.

Restriction
Although you can use ProLink II to enable and disable fill logging, you cannot view the fill log with
ProLink II. To view the fill log, you must use a Modbus or PROFIBUS connection.

Prerequisites

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Choose ProLink > Configuration > Filling.

2. Enable Enable Fill Logging.

3. Run a fill.

4. Disable Enable Fill Logging when you are finished with data collection.

The fill log contains data records from a single fill, from the beginning of the fill until
50 milliseconds after flow stops, or until the maximum log size is reached. Data records are
written every 10 milliseconds. Each data record contains the current value of Flow Source
(the process variable used to measure the fill). The fill log is limited to 1000 records, or
10 seconds of filling. When the maximum size is reached, logging stops but the data is
available on the transmitter until the next fill starts. The fill log is cleared each time a fill
starts.

7.4.2 Analyze fill performance using fill statistics and ProLink II
The transmitter automatically records a variety of data about each fill. This data is available
to assist you in tuning your system.

Prerequisites

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Choose ProLink > Run Filler.
2. (Optional) Click Reset Fill Statistics to start your analysis with a fresh set of fill data.
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3. Run fills and observe the fill data.

Fill data Fill type Description

Fill Total Average One-stage discrete fills,
two-stage discrete fills,
and timed fills

Calculated average of all fill totals
since fill statistics were reset.

Dual-fillhead fills and du-
al-fillhead timed fills

Calculated average of all fill totals
through Fillhead #1 since fill statistics
were reset.

Fill Total Variance One-stage discrete fills,
two-stage discrete fills,
and timed fills

Calculated variance of all fill totals
since fill statistics were reset.

Dual-fillhead fills and du-
al-fillhead timed fills

Calculated variance of all fill totals
through Fillhead #1 since fill statistics
were reset.

Secondary Fill Total Average Dual-fillhead fills and du-
al-fillhead timed fills on-
ly

Calculated average of all fill totals
through Fillhead #2 since fill statistics
were reset.

Secondary Fill Total Var-
iance

Dual-fillhead fills and du-
al-fillhead timed fills on-
ly

Calculated variance of all fill totals
through Fillhead #2 since fill statistics
were reset.
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8 Configure an integrated-valve-
control fill using the PROFIBUS EDD
Topics covered in this chapter:

• Configure an integrated-valve-control fill using the PROFIBUS EDD

• Configure fill options using the PROFIBUS EDD

• Configure fill control using the PROFIBUS EDD (optional)

• Configure fill reporting using the PROFIBUS EDD (optional)

8.1 Configure an integrated-valve-control fill using
the PROFIBUS EDD
Configure the fill type that is appropriate for your application.

Tip
A one-stage discrete fill is appropriate for most applications. Use this fill type unless you have specific
requirements for another fill type. In most cases, the transmitter is configured for a one-stage
discrete fill at the factory, and will be operational with a minimum of site configuration.

8.1.1 Configure a one-stage discrete fill using the PROFIBUS
EDD
Configure a one-stage discrete fill when you want to fill a single container from a single
valve. The valve will be open until Fill Target is reached.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.
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Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Choose Online > Configure > Manual Setup > Measurements.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Choose Online > Configure > Manual Setup > Filling > Filling Configuration.

4. Set Flow Source to the process variable to be used to measure this fill.
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Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Dual Fill Disabled

Enable Timed Fill Disabled

Fill Stages One Stage Discrete

6. Set Fill Count Direction as desired.

Option Description

Count Up to Target The fill total starts at 0 and increases toward Fill Target.

Count Down to Target The fill total starts at Fill Target and decreases toward 0.

7. Set Fill Target to the quantity at which the fill will be complete.

Enter the value in the measurement units configured for Flow Source.

8. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.

To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

9. Set Measured Fill Time as desired.

Measured Fill Time controls how the fill duration will be measured.

Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.

10. Choose Online > Configure > Manual Setup > Filling > AOC Configuration.

11. Set AOC Enable to Enable.

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.
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12. Choose Online > Configure > Manual Setup > Filling > Purge Configuration.

13. Set Enable Purge to Disable.

Postrequisites

Options for one-stage discrete fills include:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.

• Implementing the Purge feature.

• Implementing the Pump feature.

8.1.2 Configure a two-stage discrete fill using the PROFIBUS
EDD
Configure a two-stage discrete fill when you want to fill a single container from two valves.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

d. Set Precision DO2 to Secondary Valve.

e. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC
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Option Signal from transmitter Voltage

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Choose Online > Configure > Manual Setup > Measurements.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Choose Online > Configure > Manual Setup > Filling > Filling Configuration.

4. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter
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Option Description

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Dual Fill Disabled

Enable Timed Fill Disabled

Fill Stages Two Stage Discrete

6. Set Fill Count Direction as desired.

Option Description

Count Up to Target The fill total starts at 0 and increases toward Fill Target.

Count Down to Target The fill total starts at Fill Target and decreases toward 0.

7. Set Configure By as desired.

Configure By controls how valve control timing is configured.

Option Description

% Target Valve Open and Valve Close timing is configured as a percentage of Fill Target. For
example:
• Valve Open = 0%: The valve opens when the current fill total is 0% of Fill Target.
• Valve Close = 90%: The valve closes when the current fill total is 90% of Fill Tar-

get.

Quantity Valve Open and Valve Close timing is configured in terms of the configured meas-
urement unit. For example:
• Valve Open = 0 g: The valve opens when the current fill total is 0 g.
• Valve Close = 50 g: The valve closes when the current fill total is 50 g less than

Fill Target.

8. Set Fill Target to the quantity at which the fill will be complete.

Enter the value in the measurement units configured for Flow Source.

9. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.

To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

10. Set Measured Fill Time as desired.
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Measured Fill Time controls how the fill duration will be measured.

Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.

11. Set Open Primary, Open Secondary, Close Primary, and Close Secondary as desired.

These values control the point in the fill at which the primary and secondary valves
open and close. They are configured either by quantity or by percent of the target,
as controlled by the Configure By parameter.

Either Open Primary or Open Secondary must be set to open at the beginning of the fill.
Both can open at the beginning of the fill if desired. If you set one to open later, the
other one is automatically reset to open at the beginning.

Either Close Primary or Close Secondary must be set to close at the end of the fill. Both
can close at the end of the fill if desired. If you set one to close earlier, the other one
is automatically reset to close at the end.

12. Choose Online > Configure > Manual Setup > Filling > AOC Configuration.

13. Set AOC Enable to Enable.

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.

14. Choose Online > Configure > Manual Setup > Filling > Purge Configuration.

15. Set Enable Purge to Disable.

Postrequisites

Options for two-stage discrete fills include:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.

• Implementing the Purge feature.

Valve opening and closing sequences for two-stage discrete
fills
The following figures illustrate the opening and closing of the primary and secondary
valves, as controlled by the configuration of Open Primary, Open Secondary, Close Primary, and
Close Secondary.

These illustrations assume that the fill runs from beginning to end without interruption.
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Open Primary first, Close Primary firstFigure 10-1:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T1 T2

Open Primary first, Close Secondary firstFigure 10-2:   
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Effects of Configure By on valve opening and closing
Configure By controls how the Open Primary, Open Secondary, Close Primary, and Close Secondary
values are configured and applied.

• When Configure By = % Target, the transmitter adds the configured Valve Open and
Valve Close values to 0%.

• When Configure By = Quantity, the transmitter adds the configured Valve Open values
to 0, and subtracts the configured Valve Close values from Fill Target.

Example: Configure By and valve open/close commands

Fill Target = 200 g. You want the primary valve to open at the beginning of the fill and close
at the end of the fill. You want the secondary valve to open after 10 g has been delivered,
and close after 190 g has been delivered. See Table 10-1 for the settings that will produce
this result.

Configure By and valve configuration Table 10-1:   

Configure By Valve Open and Valve Close values

% Target • Open Primary = 0%
• Open Secondary = 5%
• Close Secondary = 95%
• Close Primary = 100%

Quantity • Open Primary = 0 g
• Open Secondary = 10 g
• Close Secondary = 10 g
• Close Primary = 0 g

8.1.3 Configure a timed fill using the PROFIBUS EDD
Configure a timed fill when you want to fill a single container from a single valve. The valve
will be open for the specified number of seconds.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.
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Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Choose Online > Configure > Manual Setup > Measurements.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Choose Online > Configure > Manual Setup > Filling > Filling Configuration.

4. Set Flow Source to the process variable to be used to measure this fill.
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Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Dual Fill Disabled

Enable Timed Fill Enabled

Fill Stages One Stage Discrete

6. Set Fill Count Direction as desired.

Option Description

Count Up to Target The fill total starts at 0 and increases toward Fill Target.

Count Down to Target The fill total starts at Fill Target and decreases toward 0.

7. Set Target Time to the number of seconds that the fill will run.

8. Choose Online > Configure > Manual Setup > Filling > AOC Configuration.

9. Set AOC Enable to Disable.

10. Choose Online > Configure > Manual Setup > Filling > Purge Configuration.

11. Set Enable Purge to Disable.

Postrequisites

The following option is available for timed fills:

• Implementing the Purge feature.

8.1.4 Configure a dual-fillhead fill using the PROFIBUS EDD
Configure a dual-fillhead fill when you want to fill two containers alternately, using two
fillheads. Each valve will be open until Fill Target is reached.

Important
The configured Fill Target is applied to both fillheads.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.
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Procedure

1. Configure the precision discrete output(s):

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

d. Set Precision DO2 to Secondary Valve.

e. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Choose Online > Configure > Manual Setup > Measurements.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.
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Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Choose Online > Configure > Manual Setup > Filling > Filling Configuration.

4. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Dual Fill Enabled

Enable Timed Fill Disabled

Fill Stages One Stage Discrete

6. Set Fill Count Direction as desired.

Option Description

Count Up to Target The fill total starts at 0 and increases toward Fill Target.

Count Down to Target The fill total starts at Fill Target and decreases toward 0.

7. Set Fill Target to the quantity at which the fill will be complete.

Enter the value in the measurement units configured for Flow Source.

8. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.
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To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

9. Set Measured Fill Time as desired.

Measured Fill Time controls how the fill duration will be measured.

Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.

10. Choose Online > Configure > Manual Setup > Filling > AOC Configuration.

11. Set AOC Enable to Enable.

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.

12. Choose Online > Configure > Manual Setup > Filling > Purge Configuration.

13. Set Enable Purge to Disable.

Postrequisites

Options for dual-fillhead fills include:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.

8.1.5 Configure a dual-fillhead timed fill using the PROFIBUS
EDD
Configure a dual-fillhead timed fill when you want to fill two containers alternately, using
two fillheads. Each valve will be open for the specified number of seconds.

Important
The configured Target Time is applied to both fillheads.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.
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Procedure

1. Configure the precision discrete output(s):

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Output.
b. Set Precision DO1 to Primary Valve.

c. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

d. Set Precision DO2 to Secondary Valve.

e. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Choose Online > Configure > Manual Setup > Measurements.

b. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.
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Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

c. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

d. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

e. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Choose Online > Configure > Manual Setup > Filling > Filling Configuration.

4. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

5. Set or verify the following parameters:

Parameter Setting

Enable Dual Fill Enabled

Enable Timed Fill Enabled

Fill Stages One Stage Discrete

6. Set Target Time to the number of seconds that the fill will run.

Note
The configured Target Time is applied to both fillheads.

7. Choose Online > Configure > Manual Setup > Filling > AOC Configuration.

8. Set AOC Enable to Disable.

9. Choose Online > Configure > Manual Setup > Filling > Purge Configuration.

10. Set Enable Purge to Disable.
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8.2 Configure fill options using the PROFIBUS EDD
Depending on your fill type, you can configure and implement Automatic Overshoot
Compensation, the Purge feature, or the Pump feature.

8.2.1 Configure and implement Automatic Overshoot
Compensation (AOC) using the PROFIBUS EDD
Automatic Overshoot Compensation (AOC) is used to adjust fill timing to compensate for
the time required to transmit the valve close command or for the valve to close
completely.

Prerequisites

Before setting up AOC, ensure that all other fill parameters are correctly configured.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Choose Online > Configure > Manual Setup > Filling > AOC Configuration.

2. Choose the type of AOC that you want to implement.

Option Description

Fixed The valve will close at the point defined by Fill Target, minus the quantity specified
in Fixed Overshoot Comp. Use this option only if the "prewarn" value is already known.

Overfill Defines the direction used by the AOC algorithm to approach the target. The AOC
algorithm starts by estimating an overfill amount, and reduces the overfill in suc-
cessive calibration fills.

Underfill Defines the direction used by the AOC algorithm to approach the target. The AOC
algorithm starts by estimating an underfill amount, and reduces the underfill in
successive calibration fills.

Tip
The Fixed option is typically not used. If you choose Fixed, the transmitter will operate like a
legacy batch controller. In typical applications, the other AOC options provide enhanced
accuracy and repeatability.

Restriction
The Fixed and Overfill options are not supported for dual-fillhead fills.

3. To implement Fixed AOC:

a. Disable Enable AOC.

b. Set AOC Algorithm to Fixed.
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c. Set Fixed Overshoot Comp as desired.

The default value is 0, measured in process units.

The transmitter will close the valve when the current fill total is equal to Fill Target
minus the specified value (in process units).

4. To implement Overfill or Underfill:

a. Ensure that Enable AOC is enabled.

b. Set AOC Algorithm to either Overfill or Underfill.
c. Set AOC Window Length to the number of fills that will be used for AOC calibration.

The default is 10. The range is 2 to 32.

Tip
Micro Motion recommends using the default value unless you have special application
requirements.

Important
Do not change the values of AOC Change Limit or AOC Convergence Rate unless you are working
with Micro Motion customer service. These parameters are used to adjust the operation of
the AOC algorithm for special application requirements.

Postrequisites

If you set AOC Algorithm to Overfill or Underfill, you must perform an AOC calibration.

Perform AOC calibration using the PROFIBUS EDD
AOC calibration is used to calculate the AOC (Automatic Overshoot Compensation) value
from actual fill data. If you set AOC Algorithm to Overfill or Underfill, you must perform AOC
calibration.

There are two types of AOC calibration:

• Standard: The calibration is performed manually. The AOC coefficient is calculated
from fill data obtained during this calibration, and the same AOC coefficient is
applied until the calibration is repeated.

• Rolling: The calibration is performed continuously and automatically, and the AOC
coefficient is updated continuously based on fill data from the last set of fills.

Tip
For stable processes, Micro Motion recommends standard AOC calibration. If required, test both
methods and choose the method that yields the best results.

Perform standard AOC calibration

Standard AOC calibration is used to generate a constant AOC coefficient.
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Prerequisites

AOC Window Length must be set appropriately. Micro Motion recommends using the default
value (10) unless you have special application requirements.

Mass Flow Cutoff or Volume Flow Cutoff must be set appropriately for your environment.

• If Flow Source is set to Mass Flow Rate, see Section 15.2.3.

• If Flow Source is set to Volume Flow Rate, see Section 15.3.2.

Your system must be ready to run fills, and you must know how to run fills.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Choose Online > Overview > Fill Control > AOC Control.
2. To calibrate the primary valve (all fill types):

a. Click Start AOC Cal.
b. Run two or more calibration fills, up to the number specified in AOC Window

Length.

Note
You can run more calibration fills if you choose. The AOC coefficient is calculated from the
most recent fills.

Tip
In common use, the first few fills are slightly overfilled or underfilled due to factory-default
settings. As the calibration proceeds, the fills will converge on Fill Target.

c. When the fill totals are consistently satisfactory, click Save AOC Cal.

3. To calibrate the secondary valve (dual-fillhead fills):

a. Click Start Secondary AOC Cal.
b. Run two or more calibration fills, up to the number specified in AOC Window

Length.

The transmitter automatically runs fills through the secondary valve.

Note
You can run more calibration fills if you choose. The AOC coefficient is calculated from the
most recent fills.

Tip
In common use, the first few fills are slightly overfilled or underfilled due to factory-default
settings. As the calibration proceeds, the fills will converge on Fill Target.
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c. When the fill totals are consistently satisfactory, click Save Secondary AOC Cal.

The current AOC coefficient is displayed in the Run Filler window. If you are running a dual-
fillhead fill, the Run Filler window displays the AOC coefficient for both the primary and the
secondary valve. These coefficients will be applied to fills as long as AOC is enabled.

Note
For two-stage discrete fills, the AOC value is applied to the valve that closes when the target is
reached. If the fill is configured to close both valves when the target is reached, the AOC value is
applied to both.

Tip
Micro Motion recommends repeating the AOC calibration if any of the following are true:

• Equipment has been replaced or adjusted.

• The flow rate has changed significantly.

• Fill accuracy is consistently lower than expected.

• Mass Flow Cutoff or Volume Flow Cutoff has been changed.

Set up rolling AOC calibration

Rolling AOC calibration is used to update the AOC coefficient continuously, based on fill
data from the last set of fills.

Prerequisites

AOC Window Length must be set appropriately. Micro Motion recommends using the default
value (10) unless you have special application requirements.

Your system must be ready to run fills, and you must know how to run fills.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Choose Online > Configure > Manual Setup > Filling > AOC Configuration.

2. To calibrate the primary valve (all fill types), click Start AOC Cal. To calibrate the
secondary valve (dual-fillhead fills), click Start Secondary AOC Cal.

You can set up rolling AOC calibration for either valve or both valves.

3. Begin production filling.

The transmitter recalculates the AOC coefficient(s) after each fill, based on the last x fills
where x is the number specified in AOC Window Length. Current values are displayed in the
Run Filler window. If the configuration has changed or if process conditions have changed,
rolling AOC calibration will compensate for the change. However, the adjustment will take
place over several fills; that is, AOC will take a few fills to catch up.
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Tip
The current AOC coefficient will be saved and applied to all subsequent fills through the
corresponding valve. In other words, this action changes the AOC calibration method for that valve
from rolling to standard.

8.2.2 Configure the Purge feature using the PROFIBUS EDD
The Purge feature is used to control an auxiliary valve that can be used for any non-filling
purpose. For example, it can be used for adding water or gas to the container after the fill
ends, or “padding.” Flow through the auxiliary valve is not measured by the transmitter.
You can configure the Purge feature for automatic or manual purge control. If you choose
automatic control, the auxiliary valve is opened after each fill, and closed after the
configured purge time has elapsed.

Restriction
The Purge feature is not supported for dual-fillhead fills or dual-fillhead timed fills.

Prerequisites

The discrete outputs must be wired appropriately for your fill type and fill options.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Configure Channel B to operate as a discrete output:

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Channels.

b. Set Channel B Type Assignment to Discrete Output.
c. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Output.
d. Set DO1 Assignment to Discrete Batch: Purge Valve.

e. Set DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

f. Set DO1 Fault Action as appropriate for your installation.
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Option Description

Upscale The discrete output will be set to ON (valve open) if a fault
occurs.

Downscale The discrete output will be set to OFF (valve closed) if a
fault occurs.

None No action will be taken if a fault occurs. The discrete out-
put will remain in the state it was in before the fault occur-
red.

2. Configure the purge:

a. Choose Online > Configure > Manual Setup > Filling > Filling Configuration.

b. Enable Enable Purge.

c. Set Purge Mode as desired.

Option Description

Auto A purge is performed automatically after each fill.

Manual Purges must be started and stopped manually.

Tip
When Purge Mode is set to Auto, manual control of the purge valve is still possible. You can
start a purge manually and stop it manually, or you can let the transmitter stop it after
Purge Time has expired. If a purge is started automatically, you can stop it manually.

d. If you set Purge Mode to Auto, set Purge Delay to the number of seconds that the
transmitter will wait, after the fill has ended, to open the purge valve.

The default value for Purge Delay is 2 seconds.

e. If you set Purge Mode to Auto, set Purge Time to the number of seconds that the
transmitter will keep the purge valve open.

The default value for Purge Time is 1 second. The range is 0 seconds to
800 seconds.

Tip
The next fill cannot start until the purge valve is closed.

8.2.3 Configure the Pump feature using the PROFIBUS EDD
The Pump feature is used to increase pressure during the fill by starting an upstream pump
just before the fill begins.
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Restriction
The Pump feature is not supported for two-stage discrete fills, dual-fillhead fills, timed fills, or dual-
fillhead timed fills.

Prerequisites

The discrete outputs must be wired appropriately for your fill type and fill options.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Output.
b. Set Precision DO2 to Pump.

c. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Choose Online > Configure > Manual Setup > Filling > Filling Configuration
3. Set Pump to Valve Delay to the number of seconds that the pump will run before the

valve is opened.

The default value is 10 seconds. The range is 0 seconds to 30 seconds.

When the Begin Filling command is received, the transmitter starts the pump, waits for the
number of seconds specified in Pump to Valve Delay, then opens the valve. The pump runs
until the fill is ended.

8.3 Configure fill control using the PROFIBUS EDD
(optional)
In a typical production environment, fill control (beginning and ending the fill) is
performed by the host or PLC. If you choose, you can set up the system so that you can
begin, end, pause, and resume the fill from the discrete input (if available). You can also
define an event to begin, end, pause, or resume the fill.
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8.3.1 Configure the discrete input for fill control using the
PROFIBUS EDD
If Channel B is available, you can configure it as a discrete input and use it to begin and end
the fill, or to pause and resume a fill in progress. You can also configure it to reset the mass
total, volume total, or all totals. When the discrete input is activated, all assigned actions
will be performed.

Prerequisites

Channel B must be wired to operate as a discrete input.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Configure Channel B to operate as a discrete input.

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Channels.

b. Set Type Assignment for Channel B to Discrete Input.
2. Assign fill control actions to the discrete input.

a. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Intput.
b. Select the action or actions to be performed when the discrete input is activated.

Action Description Comments

Begin Filling Starts a fill using the current fill configuration.
The fill total is automatically reset before the
fill begins.

If a fill is in progress, the command is ignored.

If an automatic purge is in progress, the begin-
ning-of-fill functions are executed when the
purge is complete.

End Filling Ends the current fill and performs end-of-fill
functions. The fill cannot be resumed.

Executed while a fill is running or paused, and
during a purge or purge delay.

For dual-fillhead fills and dual-fillhead timed
fills, the command always ends the currently
active fill.

Pause Filling Timed fills, dual-fillhead fills, and dual-fillhead
timed fills: Same as End Filling.

One-stage discrete fills and two-stage discrete
fills: Temporarily stops the fill. The fill can be
resumed if the fill total is less than Fill Target.

If a purge or purge delay is in progress, the
command is ignored.

Resume Filling Restarts a fill that has been paused. Counting
resumes from the total or time at which the fill
was paused.

Executed only when a one-stage discrete fill or
a two-stage discrete fill has been paused. Ig-
nored at all other times.

Reset Mass Total Resets the value of the mass totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.
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Action Description Comments

Reset Volume Total Resets the value of the volume totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset All Totals Resets the value of the mass totalizer and vol-
ume totalizer to 0, and resets the fill total to 0.

Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

c. For each selected action, open the dropdown list and select Discrete Input 1.

3. Set DI1 Polarity as appropriate for your installation.

Ensure that the ON signal sent by the discrete input is read as ON, and vice versa.

Option
Voltage applied across ter-
minals Transmitter reads

Active High 3 to 30 VDC ON

<0.8 VDC OFF

Active Low <0.8 VDC ON

3 to 30 VDC OFF

8.3.2 Set up an event to perform fill control using the
PROFIBUS EDD
You can assign an event to start, stop, pause, or resume a fill. You can also assign the event
to reset the mass total, volume total, or all totals. When the event transitions to ON, all
assigned actions will be performed.

Prerequisites

All events that you want to use must be configured. You can configure them before or
after you assign actions to them.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Assign fill control actions to the event.

a. Choose Online > Configure > Alert Setup > Discrete Events.

b. Identify the action or actions to be performed when Discrete Event 1 occurs.
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Action Description Comments

Begin Filling Starts a fill using the current fill configuration.
The fill total is automatically reset before the
fill begins.

If a fill is in progress, the command is ignored.

If an automatic purge is in progress, the begin-
ning-of-fill functions are executed when the
purge is complete.

End Filling Ends the current fill and performs end-of-fill
functions. The fill cannot be resumed.

Executed while a fill is running or paused, and
during a purge or purge delay.

For dual-fillhead fills and dual-fillhead timed
fills, the command always ends the currently
active fill.

Pause Filling Timed fills, dual-fillhead fills, and dual-fillhead
timed fills: Same as End Filling.

One-stage discrete fills and two-stage discrete
fills: Temporarily stops the fill. The fill can be
resumed if the fill total is less than Fill Target.

If a purge or purge delay is in progress, the
command is ignored.

Resume Filling Restarts a fill that has been paused. Counting
resumes from the total or time at which the fill
was paused.

Executed only when a one-stage discrete fill or
a two-stage discrete fill has been paused. Ig-
nored at all other times.

Reset Mass Total Resets the value of the mass totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset Volume Total Resets the value of the volume totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset All Totals Resets the value of the mass totalizer and vol-
ume totalizer to 0, and resets the fill total to 0.

Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

2. Repeat for Discrete Events 2–5.

Example: Events monitor process and pause or end fill

The acceptable density range for your process is 1.1 g/cm3 to 1.12 g/cm3. The acceptable
temperature range is 20 °C to 25 °C. You want to pause the fill if the density goes out of
range. You want to end the fill if the temperature goes out of range.

Event configuration:

• Discrete Event 1:

- Event Type: Out of Range
- Process Variable: Density
- Low Setpoint (A): 1.1 g/cm3

- High Setpoint (B): 1.12 g/cm3

• Discrete Event 2:

- Event Type: Out of Range
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- Process Variable: Temperature
- Low Setpoint (A): 20 °C

- High Setpoint (B): 25 °C

Action assignments:

• Pause Fill: Discrete Event 1
• End Fill: Discrete Event 2

Postrequisites

If you have assigned actions to events that are not configured, you must configure those
events before you can implement this fill control method.

8.3.3 Multiple actions assigned to a discrete input or event
If multiple actions are assigned to a discrete input or event, the transmitter performs only
the actions that are relevant in the current situation. If two or more of the actions are
mutually exclusive, the transmitter performs actions according to the priority scheme
defined in the transmitter firmware.

The following examples show three configurations that Micro Motion recommends, and
two configurations that are not recommended.

Example: Using the discrete input or event to begin and end the fill (recommended)

Action assignments:

• Begin Fill
• End Fill
• Reset Mass Total
• Reset Volume Total

Result of activation:

• If no fill is running, the mass totalizer and volume totalizer are reset and a fill is
started.

• If a fill is running, it is ended and the mass totalizer and volume totalizer are reset.

Example: Using the discrete input or event to begin, pause, and resume the fill
(recommended)

Action assignments:

• Begin Fill
• Pause Fill
• Resume Fill

Result of activation:

• If no fill is running, a fill is started.
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• If a fill is running and not paused, it is paused.

• If a fill is paused, it is resumed.

Example: Using the discrete input to begin the fill and reset the volume flow
(recommended)

Action assignments:

• Begin Fill
• Reset Volume Total

Result of activation:

• If no fill is running, the volume totalizer is reset and a fill is started.

• If a fill is running, the volume totalizer is reset.

Tip
This configuration is useful if you have configured your fill in terms of mass but you would also like to
know the volume total for the fill. In this case, do not activate the discrete input while the fill is in
progress. At the end of the fill, read the volume total. Then continue with the next fill.

Example: Incompatible assignments (not recommended)

Action assignments:

• Begin Fill
• End Fill
• Pause Fill
• Resume Fill

Result of activation:

• If no fill is running, a fill is started.

• If a fill is running, it is ended.

In this example, the discrete input or event will never pause the fill because the End Fill
action takes priority.

Example: Incompatible assignments (not recommended)

Action assignments:

• End Fill
• Reset All Totals

Result of activation:

• If no fill is running, all totals, including the fill total, are reset.

• If a fill is running, it is ended and all totals, including the fill total, are reset.

The result of this combination is that the fill total is reset before the data can be retrieved.
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8.4 Configure fill reporting using the PROFIBUS
EDD (optional)
You can configure the transmitter to report the fill ON/OFF state over Channel B (if it is
available), and percent of fill delivered over the mA output.

8.4.1 Configure Channel B to operate as a discrete output and
report the fill ON/OFF state using the PROFIBUS EDD
If Channel B is available, you can use it to report whether or not a fill is running.

Prerequisites

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Channel B must be wired to operate as a discrete output.

Procedure

1. Choose Online > Configure > Manual Setup > Inputs/Outputs > Channels.

2. Set Channel B Type Assignment to Discrete Output.
3. Choose Online > Configure > Manual Setup > Inputs/Outputs > Discrete Output.
4. Set DO1 Assignment to Discrete Batch: Batching/Filling In Progress
5. Set DO1 Polarity as appropriate for your installation.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

6. Set DO1 Fault Action as appropriate for your installation.

Option Description

Upscale The discrete output will be set to ON (valve open) if a fault
occurs.

Downscale The discrete output will be set to OFF (valve closed) if a fault
occurs.

None No action will be taken if a fault occurs. The discrete output
will remain in the state it was in before the fault occurred.
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Tip
When the discrete output is used for fill reporting, Micro Motion recommends setting DO1
Fault Action to None.

8.4.2 Configure the mA output to report percentage of fill
delivered using the PROFIBUS EDD
You can configure the mA output to report the percentage of Fill Target that has been
delivered. In a typical configuration, the current increases from 4 mA to 20 mA as the fill
total moves from 0% to 100%.

Prerequisites

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Choose Online > Configure > Manual Setup > Inputs/Outputs > mA Output.
2. Set Secondary Variable Is to Discrete Batch: Percent Fill.
3. Set Lower Range Value to the percentage of the fill to be represented by 4 mA.

4. Set Upper Range Value to the percentage of the fill to be represented by 20 mA.

5. Set AO Fault Action as desired.

If Lower Range Value is set to 0% and Upper Range Value is set to 100%: When the fill starts, the
mA output will generate a current of 4 mA (0% of Fill Target). The current will increase in
proportion to the fill total, up to a current of 20 mA (100% of Fill Target).

Note
If Flow Direction is set to Bidirectional or Negate Bidirectional, the fill total may decrease under certain flow
conditions. If this occurs, the current generated by the mA output will decrease proportionally.
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9 Fill operation using the PROFIBUS
EDD
Topics covered in this chapter:

• Run an integrated-valve-control fill using the PROFIBUS EDD

• Perform a manual purge using the PROFIBUS EDD

• Perform Clean In Place (CIP) using the PROFIBUS EDD

• Monitor and analyze fill performance using the PROFIBUS EDD

9.1 Run an integrated-valve-control fill using the
PROFIBUS EDD
You can use PROFIBUS digital communications to start a fill, monitor the fill, pause and
resume the fill, and end a fill.

Prerequisites

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Choose Online > Overview > Fill Control > Fill Control.
2. (Optional) If desired, enter a different value for Fill Target (one-stage discrete fills,

two-stage discrete fills, or dual-fillhead fills), or for Target Time (timed fills or dual-
fillhead timed fills).

3. (Optional) If Automatic Overshoot Compensation (AOC) is enabled, you can enter a
different value for AOC Coeff.

Tip
In production use, Micro Motion recommends leaving AOC Coeff at the value determined
during AOC calibration. If you are running AOC calibration fills and you have an AOC Coeff
value available from a similar device, you can use that value as the "first approximation" value
on the current device. This may be helpful if you want to prevent or minimize spilling.

4. Click Begin Filling.

The fill total is reset automatically and the valve(s) are opened. The Filling In Progress
indicator should be On. If it is not, and the Start Not Okay indicator or the AOC Flow Rate
Too High indicator is On instead, troubleshoot the fill configuration and try again.

5. Monitor the fill using the Current Total and Percent Fill values and the Fill Status
indicators.
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Fill progress values Description

Current Total Fill quantity at the current time. This value is affected by
Count Up:
• If Count Up is enabled, Current Total begins at 0 and increa-

ses to Fill Target.
• If Count Up is disabled, Current Total begins at Fill Target and

decreases to 0.

Percent Fill Percentage of Fill Target that has been measured up to the
current time. This value is not affected by Count Up.

Fill Status indicator Description

Filling in Progress A fill is currently being performed through the primary valve.
This indicator is active even when the fill is paused.

Secondary Fill in Progress A fill is currently being performed through the secondary
valve. This indicator is active even when the fill is paused. It
applies only to dual-fillhead fills.

Max Fill Time Exceeded The current fill has exceeded the current setting for Max Fill
Time. The fill is aborted.

Primary Valve The primary valve is open.

Secondary Valve The secondary valve is open.

Pump The pump is running.

Purge In Progress A purge has been started, either manually or automatically.

Purge Delay Phase An automatic purge cycle is in progress, and is currently in
the delay period between the completion of the fill and the
start of the purge.

Purge Valve The purge valve is open.

6. (Optional) Pause the fill if desired.

While the fill is paused, you can change the value of Current Target, end the fill
manually with End Filling, or restart the fill with Resume Filling. The fill resumes at the
current value of Current Total and Percent Fill.

Restriction
You cannot pause a timed fill or a dual-fillhead timed fill.

Important
For two-stage discrete fills, the effects of pausing and resuming the fill depend on the timing
of the valve open and valve close commands, and on the point at which the fill is paused.

7. (Optional) Use End Filling to end the fill manually if desired.

Once the fill is ended, it cannot be restarted.
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Tip
In most cases, you should allow the fill to end automatically. End the fill manually only when
you are planning to discard the fill.

9.1.1 If the fill fails to start
If the fill fails to start, check the Start Not Okay and AOC Flow Rate Too High indicators.

If the Start Not Okay indicator is On, check the following:

• Ensure that filling is enabled.

• Ensure that the previous fill has been ended.

• Ensure that Fill Target or Target Time is set to a positive number.

• Ensure that all outputs have been assigned to the valve or pump appropriate for the
fill type and fill option.

• Ensure that there are no active fault conditions at the transmitter.

• For dual-fillhead fills and dual-fillhead timed fills, ensure that no fill is running on
either fillhead.

If the AOC Flow Rate Too High indicator is on, the last measured flow rate is too high to allow
the fill to start. In other words, the AOC coefficient, compensated for the flow rate,
specifies that the valve close command should be issued before the fill has begun. This can
happen if the flow rate has increased significantly since the AOC coefficient was calculated.
Micro Motion recommends the following recovery procedure:

1. Perform any setup that is required to perform AOC calibration.

2. In the Run Filler window, click Override Blocked Start.
3. Perform AOC calibration.

4. Return your system to production filling, using the new AOC coefficient.

9.1.2 If the fill did not run to completion
If your fill terminated abnormally, check the transmitter and the Max Fill Time Exceeded
indicator.

If a fault occurs during the fill, the transmitter automatically terminates the fill.

If the Max Fill Time Exceeded indicator is On, the fill did not reach its target before the
configured Max Fill Time. Consider the following possibilities or actions:

• Increase the flow rate of your process.

• Check for entrained gas (slug flow) in your process fluid.

• Check for blockages in the flow.

• Ensure that the valves are able to close at the expected speed.

• Set Max Fill Time to a higher value.

• Disable Max Fill Time by setting it to 0.
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9.1.3 Effects of Pause and Resume on two-stage discrete fills
For two-stage discrete fills, the effects of pausing and resuming the fill depend on where
the Pause and Resume actions occur in relation to the opening and closing of the primary
and secondary valves.

Open Primary first, Close Primary first

In the following illustrations:

• The primary valve opens at the beginning of the fill.

• The secondary valve opens at the user-configured point during the fill. T represents
the time or quantity configured for Open Secondary.

• The primary valve closes before the end of the fill.

• The secondary valve closes at the end of the fill.

Case AFigure 11-1:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

Pause Resume

TT

Open Secondary 
not performed

Case BFigure 11-2:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary
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Case CFigure 11-3:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Secondary valve 
opened early

Pause Resume

Open 
Secondary

Case DFigure 11-4:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Secondary valve 
opened early

Pause Resume

Open 
Secondary

Open Primary first, Close Secondary first

In the following illustrations:

• The primary valve opens at the beginning of the fill.

• The secondary valve opens at the user-configured point during the fill. T represents
the time or quantity configured for Open Secondary.

• The secondary valve closes before the end of the fill.

• The primary valve closes at the end of the fill.
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Case EFigure 11-5:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

Pause Resume

TT

Open Secondary 
not performed

Case FFigure 11-6:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary

Case GFigure 11-7:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Secondary valve 
not reopened

Pause Resume

Open 
Secondary
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Case HFigure 11-8:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary

Secondary valve 
not reopened

Open Secondary first, Close Primary first

In the following illustrations:

• The secondary primary opens at the beginning of the fill.

• The primary valve opens at the user-configured point during the fill. T represents the
time or quantity configured for Open Primary.

• The primary valve closes before the end of the fill.

• The secondary valve closes at the end of the fill.

Case IFigure 11-9:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

Pause Resume

TT

Open Primary 
not performed
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Case JFigure 11-10:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary

Case KFigure 11-11:   

Secondary valve

Primary valve

Start Open 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary not 
performed

Close 
Primary

Case LFigure 11-12:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open Primary 
not performed

Open Secondary first, Close Secondary first

In the following illustrations:

• The secondary primary opens at the beginning of the fill.
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• The primary valve opens at the user-configured point during the fill. T represents the
time or quantity configured for Open Primary.

• The secondary valve closes before the end of the fill.

• The primary valve closes at the end of the fill.

Case MFigure 11-13:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

Pause Resume

TT

Open Primary 
not performed

Case NFigure 11-14:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary
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Case OFigure 11-15:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Primary valve 
opened early

Pause Resume

Open 
Primary

Case PFigure 11-16:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Primary valve 
opened early

Pause Resume

Open 
Primary

9.2 Perform a manual purge using the PROFIBUS
EDD
The Purge feature is used to control an auxiliary valve that can be used for any non-filling
purpose. For example, it can be used for adding water or gas to the container after the fill
ends, or “padding.” Flow through the auxiliary valve is not measured by the transmitter.

Prerequisites

The Purge feature must be implemented on your system.

The previous fill must be ended.

The auxiliary valve must be connected to the fluid you want to use, e.g., air, water,
nitrogen.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.
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Procedure

1. Choose Overview > Fill Control > Fill Control.
2. Click Begin Purge.

The Purge In Progress indicator and the Purge Valve indicator turn on.

3. Allow the purge fluid to flow for the appropriate amount of time.

4. Click End Purge

The Purge In Progress indicator and the Purge Valve indicator turn off.

9.3 Perform Clean In Place (CIP) using the
PROFIBUS EDD
The Clean In Place (CIP) function is used to force a cleaning fluid through the system. CIP
allows you to clean the interior surfaces of pipes, valves, nozzles, etc., without having to
disassemble the equipment.

Prerequisites

No fill can be running.

The cleaning fluid must be available for running through the system.

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Replace the process fluid with the cleaning fluid.

2. Choose Online > Overview > Fill Control > Fill Control.
3. Click Begin Cleaning.

The transmitter opens the primary valve, and the secondary valve if it is used for
filling. If the Pump feature is enabled, the pump is started before the valve is
opened. The Cleaning In Progress indicator turns on.

4. Allow the cleaning fluid to flow through your system for the appropriate amount of
time.

5. Click End Cleaning

The transmitter closes all open valves, and stops the pump if applicable. The Cleaning
In Progress indicator turns off.

6. Replace the cleaning fluid with the process fluid.
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9.4 Monitor and analyze fill performance using the
PROFIBUS EDD
You can collect detailed flow data for a single fill, and you can compare data across
multiple fills.

9.4.1 Collect detailed fill data for a single fill using the
PROFIBUS EDD
When fill logging is enabled, detailed data for the most recent fill is stored on the
transmitter. You can retrieve it for analysis using digital communications. The detailed
data can be used for tuning or troubleshooting your production environment.

Prerequisites

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Choose Online > Configure > Manual Setup > Filling > Filling Configuration > Fill Type.

2. Enable Enable Fill Logging.

3. Run a fill.

4. Disable Enable Fill Logging when you are finished with data collection.

The fill log contains data records from a single fill, from the beginning of the fill until
50 milliseconds after flow stops, or until the maximum log size is reached. Data records are
written every 10 milliseconds. Each data record contains the current value of Flow Source
(the process variable used to measure the fill). The fill log is limited to 1000 records, or
10 seconds of filling. When the maximum size is reached, logging stops but the data is
available on the transmitter until the next fill starts. The fill log is cleared each time a fill
starts.

9.4.2 Analyze fill performance using fill statistics and the
PROFIBUS EDD
The transmitter automatically records a variety of data about each fill. This data is available
to assist you in tuning your system.

Prerequisites

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Choose Online > Overview > Fill Control > Fill Statistics.

2. (Optional) Click Reset Fill Statistics to start your analysis with a fresh set of fill data.
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3. Run fills and observe the fill data.

Fill data Fill type Description

Fill Total Average One-stage discrete fills,
two-stage discrete fills,
and timed fills

Calculated average of all fill totals
since fill statistics were reset.

Dual-fillhead fills and du-
al-fillhead timed fills

Calculated average of all fill totals
through Fillhead #1 since fill statistics
were reset.

Fill Total Variance One-stage discrete fills,
two-stage discrete fills,
and timed fills

Calculated variance of all fill totals
since fill statistics were reset.

Dual-fillhead fills and du-
al-fillhead timed fills

Calculated variance of all fill totals
through Fillhead #1 since fill statistics
were reset.

Secondary Fill Total Average Dual-fillhead fills and du-
al-fillhead timed fills on-
ly

Calculated average of all fill totals
through Fillhead #2 since fill statistics
were reset.

Secondary Fill Total Var-
iance

Dual-fillhead fills and du-
al-fillhead timed fills on-
ly

Calculated variance of all fill totals
through Fillhead #2 since fill statistics
were reset.
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10 Configure an integrated-valve-
control fill using PROFIBUS bus
parameters
Topics covered in this chapter:

• Configure an integrated-valve-control fill using PROFIBUS bus parameters

• Configure fill options using PROFIBUS bus parameters

• Configure fill control using PROFIBUS bus parameters (optional)

• Configure fill reporting using PROFIBUS bus parameters (optional)

10.1 Configure an integrated-valve-control fill using
PROFIBUS bus parameters
Configure the fill type that is appropriate for your application.

Tip
A one-stage discrete fill is appropriate for most applications. Use this fill type unless you have specific
requirements for another fill type. In most cases, the transmitter is configured for a one-stage
discrete fill at the factory, and will be operational with a minimum of site configuration.

10.1.1 Configure a one-stage discrete fill using PROFIBUS bus
parameters
Configure a one-stage discrete fill when you want to fill a single container from a single
valve. The valve will be open until Fill Target is reached.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Set Precision DO1 to Primary Valve.

b. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.
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Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

b. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

c. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

d. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter
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4. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Enable Dual Fill Disabled

Enable AOC Enabled

Enable Purge Disabled

Enable Timed Fill Disabled

Fill Type One Stage Discrete

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.

5. Set Count Up as desired.

Count Up controls how the fill total is calculated and displayed.

Option Description

Enabled The fill total starts at 0 and increases toward Fill Target.

Disabled The fill total starts at Fill Target and decreases toward 0.

6. Set Fill Target to the quantity at which the fill will be complete.

Enter the value in the measurement units configured for Flow Source.

7. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.

To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

8. Set Measured Fill Time as desired.

Measured Fill Time controls how the fill duration will be measured.

Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.
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Example: Configuring a one-stage discrete fill

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.

Block Index

Value
(decimal
or float) Description

Filling 33 110 Sets Precision DO1 to Primary Valve

Filling 34 1 Sets Precision DO1 Polarity to Active High

Measurement 21 0 Sets Flow Direction to Forward

Measurement 5 1318 Sets Mass Flow Units to g/sec

Measurement 11 1347 Sets Volume Flow Units to m3/sec

Filling 5 0 Sets Flow Source to Mass Flow Rate

Filling 17 0 Sets Enable Dual Fill to Disabled

Filling 15 0 Sets Enable Timed Fill to Disabled

Filling 7 1 Sets Fill Type to One Stage Discrete

Filling 8 1 Sets Count Up to Enabled

Filling 6 100.00 Sets Fill Target to 100 g

Filling 14 1.00 Sets Max Fill Time to 1 sec

Filling 19 1 Sets Measured Fill Time to Flow Stops

Postrequisites

Options for one-stage discrete fills include:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.

• Implementing the Purge feature.

• Implementing the Pump feature.

10.1.2 Configure a two-stage discrete fill using PROFIBUS bus
parameters
Configure a two-stage discrete fill when you want to fill a single container from two valves.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.
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Procedure

1. Configure the precision discrete output(s):

a. Set Precision DO1 to Primary Valve.

b. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

c. Set Precision DO2 to Secondary Valve.

d. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.
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b. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

c. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

d. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

4. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Enable Dual Fill Disabled

Enable AOC Enabled

Enable Purge Disabled

Enable Timed Fill Disabled

Fill Type Two Stage Discrete

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.

5. Set Count Up as desired.

Count Up controls how the fill total is calculated and displayed.

Option Description

Enabled The fill total starts at 0 and increases toward Fill Target.

Disabled The fill total starts at Fill Target and decreases toward 0.

6. Set Configure By as desired.
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Configure By controls how valve control timing is configured.

Option Description

% Target Valve Open and Valve Close timing is configured as a percentage of Fill Target. For
example:
• Valve Open = 0%: The valve opens when the current fill total is 0% of Fill Target.
• Valve Close = 90%: The valve closes when the current fill total is 90% of Fill Tar-

get.

Quantity Valve Open and Valve Close timing is configured in terms of the configured meas-
urement unit. For example:
• Valve Open = 0 g: The valve opens when the current fill total is 0 g.
• Valve Close = 50 g: The valve closes when the current fill total is 50 g less than

Fill Target.

7. Set Fill Target to the quantity at which the fill will be complete.

Enter the value in the measurement units configured for Flow Source.

8. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.

To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

9. Set Measured Fill Time as desired.

Measured Fill Time controls how the fill duration will be measured.

Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.

10. Set Open Primary, Open Secondary, Close Primary, and Close Secondary as desired.

These values control the point in the fill at which the primary and secondary valves
open and close. They are configured either by quantity or by percent of the target,
as controlled by the Configure By parameter.

Either Open Primary or Open Secondary must be set to open at the beginning of the fill.
Both can open at the beginning of the fill if desired. If you set one to open later, the
other one is automatically reset to open at the beginning.

Either Close Primary or Close Secondary must be set to close at the end of the fill. Both
can close at the end of the fill if desired. If you set one to close earlier, the other one
is automatically reset to close at the end.
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Example: Configuring a two-stage discrete fill

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.

Block Index

Value
(decimal
or float) Description

Filling 33 110 Sets Precision DO1 to Primary Valve

Filling 34 1 Sets Precision DO1 Polarity to Active High

Filling 35 111 Sets Precision DO2 to Secondary Valve

Filling 36 1 Sets Precision DO2 Polarity to Active High

Measurement 21 0 Sets Flow Direction to Forward

Measurement 5 1318 Sets Mass Flow Units to g/sec

Measurement 11 1347 Sets Volume Flow Units to m3/sec

Filling 5 0 Sets Flow Source to Mass Flow Rate

Filling 17 0 Sets Enable Dual Fill to Disabled

Filling 15 0 Sets Enable Timed Fill to Disabled

Filling 7 2 Sets Fill Type to Two Stage Discrete

Filling 8 1 Sets Count Up to Enabled

Filling 9 0 Sets Configure By to % Target

Filling 6 100 Sets Fill Target to 100 g

Filling 14 1.00 Sets Max Fill Time to 1 sec

Filling 19 1 Sets Measured Fill Time to Flow Stops

Filling 10 0.00 Sets Open Primary to 0% of Fill Target

Filling 12 80.00 Sets Close Primary to 80% of Fill Target

Filling 11 50.00 Sets Open Secondary to 50% of Fill Target

Filling 13 100 .00 Sets Close Secondary to 100% of Fill Target

Postrequisites

The following option is available for two-stage discrete fills:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.
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Valve opening and closing sequences for two-stage discrete
fills
The following figures illustrate the opening and closing of the primary and secondary
valves, as controlled by the configuration of Open Primary, Open Secondary, Close Primary, and
Close Secondary.

These illustrations assume that the fill runs from beginning to end without interruption.

Open Primary first, Close Primary firstFigure 10-1:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T1 T2

Open Primary first, Close Secondary firstFigure 10-2:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T1 T2

Open Secondary first, Close Primary firstFigure 10-3:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

T1 T2
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Open Secondary first, Close Secondary firstFigure 10-4:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T1 T2

Effects of Configure By on valve opening and closing
Configure By controls how the Open Primary, Open Secondary, Close Primary, and Close Secondary
values are configured and applied.

• When Configure By = % Target, the transmitter adds the configured Valve Open and
Valve Close values to 0%.

• When Configure By = Quantity, the transmitter adds the configured Valve Open values
to 0, and subtracts the configured Valve Close values from Fill Target.

Example: Configure By and valve open/close commands

Fill Target = 200 g. You want the primary valve to open at the beginning of the fill and close
at the end of the fill. You want the secondary valve to open after 10 g has been delivered,
and close after 190 g has been delivered. See Table 10-1 for the settings that will produce
this result.

Configure By and valve configuration Table 10-1:   

Configure By Valve Open and Valve Close values

% Target • Open Primary = 0%
• Open Secondary = 5%
• Close Secondary = 95%
• Close Primary = 100%

Quantity • Open Primary = 0 g
• Open Secondary = 10 g
• Close Secondary = 10 g
• Close Primary = 0 g

10.1.3 Configure a timed fill using PROFIBUS bus parameters
Configure a timed fill when you want to fill a single container from a single valve. The valve
will be open for the specified number of seconds.
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Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Set Precision DO1 to Primary Valve.

b. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

b. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

c. Set Volume Flow Units as desired.
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If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

d. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Count Up Enabled

Enable Dual Fill Disabled

Enable AOC Disabled

Enable Purge Disabled

Enable Timed Fill Enabled

Fill Type One Stage Discrete

4. Set Target Time to the number of seconds that the fill will run.

Example: Configuring a timed fill

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.

Block Index

Value
(decimal
or float) Description

Filling 33 110 Sets Precision DO1 to Primary Valve

Filling 34 1 Sets Precision DO1 Polarity to Active High

Measurement 21 0 Sets Flow Direction to Forward

Measurement 5 1318 Sets Mass Flow Units to g/sec

Measurement 11 1347 Sets Volume Flow Units to m3/sec

Filling 5 0 Sets Flow Source to Mass Flow Rate

Filling 17 0 Sets Enable Dual Fill to Disabled

Filling 15 1 Sets Enable Timed Fill to Enabled

Filling 7 1 Sets Fill Type to One Stage Discrete

Filling 8 1 Sets Count Up to Enabled
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Block Index

Value
(decimal
or float) Description

Filling 16 15.00 Sets Target Time to 15 sec

Postrequisites

The following option is available for timed fills:

• Implementing the Purge feature.

10.1.4 Configure a dual-fillhead fill using PROFIBUS bus
parameters
Configure a dual-fillhead fill when you want to fill two containers alternately, using two
fillheads. Each valve will be open until Fill Target is reached.

Important
The configured Fill Target is applied to both fillheads.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Set Precision DO1 to Primary Valve.

b. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

c. Set Precision DO2 to Secondary Valve.

d. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.
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Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

b. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

c. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

d. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter
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4. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Count Up Enabled

Enable Dual Fill Enabled

Enable AOC Enabled

Enable Purge Disabled

Enable Timed Fill Disabled

Fill Type One Stage Discrete

Tip
Micro Motion strongly recommends implementing Automatic Overshoot Compensation
(AOC). When enabled and calibrated, AOC increases fill accuracy and repeatability.

5. Set Fill Target to the quantity at which the fill will be complete.

Note
The configured Fill Target is applied to both fillheads.

6. Set Max Fill Time to the number of seconds at which the fill will time out.

If the fill does not complete normally before this time has elapsed, the fill is aborted
and fill timeout error messages are posted.

To disable the fill timeout feature, set Max Fill Time to 0.

The default value for Max Fill Time is 0 (disabled). The range is 0 seconds to
800 seconds.

7. Set Measured Fill Time as desired.

Measured Fill Time controls how the fill duration will be measured.

Option Description

Flow Stops The fill duration will be incremented until the transmitter detects that flow has
stopped, after valve closure.

Valve Closes The fill duration will be incremented until the transmitter sets the discrete out-
put as required to close the valve.

Example: Configuring a dual-fillhead fill

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.
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Block Index

Value
(decimal
or float) Description

Filling 33 110 Sets Precision DO1 to Primary Valve

Filling 34 1 Sets Precision DO1 Polarity to Active High

Filling 35 111 Sets Precision DO2 to Secondary Valve

Filling 36 1 Sets Precision DO2 Polarity to Active High

Measurement 21 0 Sets Flow Direction to Forward

Measurement 5 1318 Sets Mass Flow Units to g/sec

Measurement 11 1347 Sets Volume Flow Units to m3/sec

Filling 5 0 Sets Flow Source to Mass Flow Rate

Filling 17 1 Sets Enable Dual Fill to Enabled

Filling 15 0 Sets Enable Timed Fill to Disabled

Filling 7 1 Sets Fill Type to One Stage Discrete

Filling 8 1 Sets Count Up to Enabled

Filling 6 100.00 Sets Fill Target to 100 g

Filling 14 1.00 Sets Max Fill Time to 1 sec

Filling 19 1 Sets Measured Fill Time to Flow Stops

Postrequisites

Options for dual-fillhead fills include:

• Configuring Automatic Overshoot Compensation (AOC). If AOC is enabled, ensure
that AOC is appropriately configured and calibrated for your application.

10.1.5 Configure a dual-fillhead timed fill using PROFIBUS bus
parameters
Configure a dual-fillhead timed fill when you want to fill two containers alternately, using
two fillheads. Each valve will be open for the specified number of seconds.

Important
The configured Target Time is applied to both fillheads.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.
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Procedure

1. Configure the precision discrete output(s):

a. Set Precision DO1 to Primary Valve.

b. Set Precision DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

c. Set Precision DO2 to Secondary Valve.

d. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

2. Configure flow measurement:

a. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the di-
rection of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite
direction of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow
is in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.
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b. Set Mass Flow Units as desired.

If you set Flow Source to Mass Flow Rate, the corresponding mass unit is used to
measure your fill.

c. Set Volume Flow Units as desired.

If you set Flow Source to Volume Flow Rate, the corresponding volume unit is is used
to measure your fill.

d. Set other flow options as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most
filling applications, and is typically not changed.

3. Set Flow Source to the process variable to be used to measure this fill.

Option Description

Mass Flow Rate The mass flow process variable, as measured by the transmitter

Volume Flow Rate The volume flow process variable, as measured by the transmitter

4. Set or verify the following parameters:

Parameter Setting

Enable Filling Option Enabled

Count Up Enabled

Enable Dual Fill Enabled

Enable AOC Disabled

Enable Purge Disabled

Enable Timed Fill Enabled

Fill Type One Stage Discrete

5. Set Target Time to the number of seconds that the fill will run.

Note
The configured Target Time is applied to both fillheads.

Example: Configuring a dual-fillhead timed fill

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.
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Block Index

Value
(decimal
or float) Description

Filling 33 110 Sets Precision DO1 to Primary Valve

Filling 34 1 Sets Precision DO1 Polarity to Active High

Filling 35 111 Sets Precision DO2 to Secondary Valve

Filling 36 1 Sets Precision DO2 Polarity to Active High

Measurement 21 0 Sets Flow Direction to Forward

Measurement 5 1318 Sets Mass Flow Units to g/sec

Measurement 11 1347 Sets Volume Flow Units to m3/sec

Filling 5 0 Sets Flow Source to Mass Flow Rate

Filling 17 1 Sets Enable Dual Fill to Enabled

Filling 15 1 Sets Enable Timed Fill to Enabled

Filling 7 1 Sets Fill Type to One Stage Discrete

Filling 8 1 Sets Count Up to Enabled

Filling 16 15.00 Sets Target Time to 15 sec

10.2 Configure fill options using PROFIBUS bus
parameters
Depending on your fill type, you can configure and implement Automatic Overshoot
Compensation, the Purge feature, or the Pump feature.

10.2.1 Configure and implement Automatic Overshoot
Compensation (AOC) using PROFIBUS bus parameters
Automatic Overshoot Compensation (AOC) is used to adjust fill timing to compensate for
the time required to transmit the valve close command or for the valve to close
completely.

Prerequisites

Ensure that you are starting from the factory-default configuration.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Choose ProLink > Configuration > Filling.

2. Choose the type of AOC that you want to implement.
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Option Description

Fixed The valve will close at the point defined by Fill Target, minus the quantity specified
in Fixed Overshoot Comp. Use this option only if the "prewarn" value is already known.

Overfill Defines the direction used by the AOC algorithm to approach the target. The AOC
algorithm starts by estimating an overfill amount, and reduces the overfill in suc-
cessive calibration fills.

Underfill Defines the direction used by the AOC algorithm to approach the target. The AOC
algorithm starts by estimating an underfill amount, and reduces the underfill in
successive calibration fills.

Tip
The Fixed option is typically not used. If you choose Fixed, the transmitter will operate like a
legacy batch controller. In typical applications, the other AOC options provide enhanced
accuracy and repeatability.

Restriction
The Fixed and Overfill options are not supported for dual-fillhead fills.

3. To implement Fixed AOC:

a. Disable Enable AOC.

b. Set AOC Algorithm to Fixed.

c. Set Fixed Overshoot Comp as desired.

The default value is 0, measured in process units.

The transmitter will close the valve when the current fill total is equal to Fill Target
minus the specified value (in process units).

4. To implement Overfill or Underfill:

a. Ensure that Enable AOC is enabled.

b. Set AOC Algorithm to either Overfill or Underfill.
c. Set AOC Window Length to the number of fills that will be used for AOC calibration.

The default is 10. The range is 2 to 32.

Tip
Micro Motion recommends using the default value unless you have special application
requirements.

Important
Do not change the values of AOC Change Limit or AOC Convergence Rate unless you are working
with Micro Motion customer service. These parameters are used to adjust the operation of
the AOC algorithm for special application requirements.
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Example: Configuring AOC

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.

• Fixed AOC:

Block Index
Value
(decimal) Description

Filling 21 0 Sets Enable AOC to Disabled

Filling 22 2 Sets AOC Algorithm to Fixed

Filling 26 0 Sets Fixed Overshoot Comp to 0

• Overfill or Underfill AOC:

Block Index
Value
(decimal) Description

Filling 21 1 Sets Enable AOC to Enabled

Filling 22 0 Sets AOC Algorithm to Overfill

Filling 23 10 Sets AOC Window Length to 10 fills

Postrequisites

If you set AOC Algorithm to Overfill or Underfill, you must perform an AOC calibration.

Perform AOC calibration using PROFIBUS bus parameters
AOC calibration is used to calculate the AOC (Automatic Overshoot Compensation) value
from actual fill data. If you set AOC Algorithm to Overfill or Underfill, you must perform AOC
calibration.

There are two types of AOC calibration:

• Standard: The calibration is performed manually. The AOC coefficient is calculated
from fill data obtained during this calibration, and the same AOC coefficient is
applied until the calibration is repeated.

• Rolling: The calibration is performed continuously and automatically, and the AOC
coefficient is updated continuously based on fill data from the last set of fills.

Tip
For stable processes, Micro Motion recommends standard AOC calibration. If required, test both
methods and choose the method that yields the best results.
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Perform standard AOC calibration

Standard AOC calibration is used to generate a constant AOC coefficient.

Prerequisites

AOC Window Length must be set appropriately. Micro Motion recommends using the default
value (10) unless you have special application requirements.

Mass Flow Cutoff or Volume Flow Cutoff must be set appropriately for your environment.

• If Flow Source is set to Mass Flow Rate, see Section 15.2.3.

• If Flow Source is set to Volume Flow Rate, see Section 15.3.2.

Your system must be ready to run fills, and you must know how to run fills.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. To calibrate the primary valve (all fill types):

a. Write 1 to Start AOC Cal (Filling block, Index 99).

b. Run two or more calibration fills, up to the number specified in AOC Window
Length.

Note
You can run more calibration fills if you choose. The AOC coefficient is calculated from the
most recent fills.

Tip
In common use, the first few fills are slightly overfilled or underfilled due to factory-default
settings. As the calibration proceeds, the fills will converge on Fill Target.

c. When the fill totals are consistently satisfactory, write 1 to Save AOC Cal (Filling
block, Index 101).

2. To calibrate the secondary valve (dual-fillhead fills):

a. Write 1 to Start Secondary AOC Cal (Filling block, Index 100).

b. Run two or more calibration fills, up to the number specified in AOC Window
Length.

The transmitter automatically runs fills through the secondary valve.

Note
You can run more calibration fills if you choose. The AOC coefficient is calculated from the
most recent fills.
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Tip
In common use, the first few fills are slightly overfilled or underfilled due to factory-default
settings. As the calibration proceeds, the fills will converge on Fill Target.

c. When the fill totals are consistently satisfactory, write 1 to Save Secondary AOC Cal
(Filling block, Index 102).

The current AOC coefficient is displayed in the Run Filler window. If you are running a dual-
fillhead fill, the Run Filler window displays the AOC coefficient for both the primary and the
secondary valve. These coefficients will be applied to fills as long as AOC is enabled.

Note
For two-stage discrete fills, the AOC value is applied to the valve that closes when the target is
reached. If the fill is configured to close both valves when the target is reached, the AOC value is
applied to both.

Tip
Micro Motion recommends repeating the AOC calibration if any of the following are true:

• Equipment has been replaced or adjusted.

• The flow rate has changed significantly.

• Fill accuracy is consistently lower than expected.

• Mass Flow Cutoff or Volume Flow Cutoff has been changed.

Set up rolling AOC calibration

Rolling AOC calibration is used to update the AOC coefficient continuously, based on fill
data from the last set of fills.

Prerequisites

AOC Window Length must be set appropriately. Micro Motion recommends using the default
value (10) unless you have special application requirements.

Your system must be ready to run fills, and you must know how to run fills.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. To calibrate the primary valve (all fill types), write 1 to Start AOC Cal (Filling block,
Index 99). To calibrate the secondary valve (dual-fillhead fills), write 1 to Start
Secondary AOC Cal (Filling block, Index 100).

You can set up rolling AOC calibration for either valve or both valves.

2. Begin production filling.
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The transmitter recalculates the AOC coefficient(s) after each fill, based on the last x fills
where x is the number specified in AOC Window Length. Current values are displayed in the
Run Filler window. If the configuration has changed or if process conditions have changed,
rolling AOC calibration will compensate for the change. However, the adjustment will take
place over several fills; that is, AOC will take a few fills to catch up.

Tip
At any time while AOC calibration is running, you can write 1 to Save AOC Cal (Filling block, Index 101)
or write 1 to Save Secondary AOC Cal (Filling block, Index 102). The current AOC coefficient will be
saved and applied to all subsequent fills through the corresponding valve. In other words, this action
changes the AOC calibration method for that valve from rolling to standard.

10.2.2 Configure the Purge feature using PROFIBUS bus
parameters
The Purge feature is used to control an auxiliary valve that can be used for any non-filling
purpose. For example, it can be used for adding water or gas to the container after the fill
ends, or “padding.” Flow through the auxiliary valve is not measured by the transmitter.
You can configure the Purge feature for automatic or manual purge control. If you choose
automatic control, the auxiliary valve is opened after each fill, and closed after the
configured purge time has elapsed.

Restriction
The Purge feature is not supported for dual-fillhead fills or dual-fillhead timed fills.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Configure Channel B to operate as a discrete output:

a. Set Channel B Type Assignment to Discrete Output.
b. Set DO1 Assignment to Discrete Batch: Purge Valve.

c. Set DO1 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC
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d. Set DO1 Fault Action as appropriate for your installation.

Option Description

Upscale The discrete output will be set to ON (valve open) if a fault
occurs.

Downscale The discrete output will be set to OFF (valve closed) if a
fault occurs.

None No action will be taken if a fault occurs. The discrete out-
put will remain in the state it was in before the fault occur-
red.

2. Configure the purge:

a. Enable Enable Purge.

b. Set Purge Mode as desired.

Option Description

Auto A purge is performed automatically after each fill.

Manual Purges must be started and stopped manually.

Tip
When Purge Mode is set to Auto, manual control of the purge valve is still possible. You can
start a purge manually and stop it manually, or you can let the transmitter stop it after
Purge Time has expired. If a purge is started automatically, you can stop it manually.

c. If you set Purge Mode to Auto, set Purge Delay to the number of seconds that the
transmitter will wait, after the fill has ended, to open the purge valve.

The default value for Purge Delay is 2 seconds.

d. If you set Purge Mode to Auto, set Purge Time to the number of seconds that the
transmitter will keep the purge valve open.

The default value for Purge Time is 1 second. The range is 0 seconds to
800 seconds.

Tip
The next fill cannot start until the purge valve is closed.

Example: Configuring the Purge feature

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.
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Block Index

Value
(decimal
or float) Description

Filling 83 4 Sets Type Assignment for Channel B Discrete Output

Filling 70 110 Sets DO1 Assignment to Primary Valve

Filling 71 1 Sets DO1 Polarity to Active High

Filling 72 4 Sets DO1 Fault Action to None

Filling 29 1 Enables Enable Purge

Filling 30 0 Sets Purge Mode to Auto

Filling 31 3.00 Sets Purge Delay to 3 seconds

Filling 32 2.00 Sets Purge Time to 2 seconds

10.2.3 Configure the Pump feature using PROFIBUS bus
parameters
The Pump feature is used to increase pressure during the fill by starting an upstream pump
just before the fill begins.

Restriction
The Pump feature is not supported for two-stage discrete fills, dual-fillhead fills, timed fills, or dual-
fillhead timed fills.

Prerequisites

The discrete outputs must be wired appropriately for your fill type and fill options.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Configure the precision discrete output(s):

a. Set Precision DO2 to Pump.

b. Set Precision DO2 Polarity as appropriate for your installation.

Ensure that the ON signal opens the valve and the OFF signal closes the valve.

Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC
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Option Signal from transmitter Voltage

OFF Site-specific up to 30 VDC

2. Set Pump to Valve Delay to the number of seconds that the pump will run before the
valve is opened.

The default value is 10 seconds. The range is 0 seconds to 30 seconds.

When the Begin Filling command is received, the transmitter starts the pump, waits for the
number of seconds specified in Pump to Valve Delay, then opens the valve. The pump runs
until the fill is ended.

Example: Configuring the Pump feature

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.

Block Index

Value
(decimal
or float) Description

Filling 35 109 Sets Precision DO2 to Pump

Filling 36 1 Sets Precision DO2 Polarity to Active High

Filling 20 15.00 Sets Pump to Valve Delay to 15 seconds

10.3 Configure fill control using PROFIBUS bus
parameters (optional)
In a typical production environment, fill control (beginning and ending the fill) is
performed by the host or PLC. If you choose, you can set up the system so that you can
begin, end, pause, and resume the fill from the discrete input (if available). You can also
define an event to begin, end, pause, or resume the fill.

10.3.1 Configure the discrete input for fill control using
PROFIBUS bus parameters
If Channel B is available, you can configure it as a discrete input and use it to begin and end
the fill, or to pause and resume a fill in progress. You can also configure it to reset the mass
total, volume total, or all totals. When the discrete input is activated, all assigned actions
will be performed.
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Prerequisites

Channel B must be wired to operate as a discrete input.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Configure Channel B to operate as a discrete input.

a. Set Type Assignment for Channel B to Discrete Input.
2. Assign fill control actions to the discrete input.

a. Select the action or actions to be performed when the discrete input is activated.

Action Description Comments

Begin Filling Starts a fill using the current fill configuration.
The fill total is automatically reset before the
fill begins.

If a fill is in progress, the command is ignored.

If an automatic purge is in progress, the begin-
ning-of-fill functions are executed when the
purge is complete.

End Filling Ends the current fill and performs end-of-fill
functions. The fill cannot be resumed.

Executed while a fill is running or paused, and
during a purge or purge delay.

For dual-fillhead fills and dual-fillhead timed
fills, the command always ends the currently
active fill.

Pause Filling Timed fills, dual-fillhead fills, and dual-fillhead
timed fills: Same as End Filling.

One-stage discrete fills and two-stage discrete
fills: Temporarily stops the fill. The fill can be
resumed if the fill total is less than Fill Target.

If a purge or purge delay is in progress, the
command is ignored.

Resume Filling Restarts a fill that has been paused. Counting
resumes from the total or time at which the fill
was paused.

Executed only when a one-stage discrete fill or
a two-stage discrete fill has been paused. Ig-
nored at all other times.

Reset Mass Total Resets the value of the mass totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset Volume Total Resets the value of the volume totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset All Totals Resets the value of the mass totalizer and vol-
ume totalizer to 0, and resets the fill total to 0.

Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

3. Set DI1 Polarity as appropriate for your installation.

Ensure that the ON signal sent by the discrete input is read as ON, and vice versa.
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Option
Voltage applied across ter-
minals Transmitter reads

Active High 3 to 30 VDC ON

<0.8 VDC OFF

Active Low <0.8 VDC ON

3 to 30 VDC OFF

Example: Configuring the discrete input for fill control

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.

Block Index
Value
(decimal) Description

Filling 83 5 Sets Type Assignment for Channel B Discrete Input

Filling 75 98 Assigns Begin Filling to Discrete Input

Filling 82 1 Sets DI1 Polarity to Active High

10.3.2 Set up an event to perform fill control using PROFIBUS
bus parameters
You can assign an event to start, stop, pause, or resume a fill. You can also assign the event
to reset the mass total, volume total, or all totals. When the event transitions to ON, all
assigned actions will be performed.

Prerequisites

All events that you want to use must be configured. You can configure them before or
after you assign actions to them.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Assign fill control actions to the event.

a. Identify the action or actions to be performed when Discrete Event 1 occurs.
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Action Description Comments

Begin Filling Starts a fill using the current fill configuration.
The fill total is automatically reset before the
fill begins.

If a fill is in progress, the command is ignored.

If an automatic purge is in progress, the begin-
ning-of-fill functions are executed when the
purge is complete.

End Filling Ends the current fill and performs end-of-fill
functions. The fill cannot be resumed.

Executed while a fill is running or paused, and
during a purge or purge delay.

For dual-fillhead fills and dual-fillhead timed
fills, the command always ends the currently
active fill.

Pause Filling Timed fills, dual-fillhead fills, and dual-fillhead
timed fills: Same as End Filling.

One-stage discrete fills and two-stage discrete
fills: Temporarily stops the fill. The fill can be
resumed if the fill total is less than Fill Target.

If a purge or purge delay is in progress, the
command is ignored.

Resume Filling Restarts a fill that has been paused. Counting
resumes from the total or time at which the fill
was paused.

Executed only when a one-stage discrete fill or
a two-stage discrete fill has been paused. Ig-
nored at all other times.

Reset Mass Total Resets the value of the mass totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset Volume Total Resets the value of the volume totalizer to 0. Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

Reset All Totals Resets the value of the mass totalizer and vol-
ume totalizer to 0, and resets the fill total to 0.

Executed only when a fill is not running (be-
tween fills or when a fill has been paused). Ig-
nored at all other times.

2. Repeat for Discrete Events 2–5.

Example: Events monitor process and pause or end fill

The acceptable density range for your process is 1.1 g/cm3 to 1.12 g/cm3. The acceptable
temperature range is 20 °C to 25 °C. You want to pause the fill if the density goes out of
range. You want to end the fill if the temperature goes out of range.

Event configuration:

• Discrete Event 1:

Block Index

Value
(decimal
or float) Description

Diagnostic 4 0 Selects Discrete Event 1

Diagnostic 5 3 Sets Event Type to Out of Range

Diagnostic 8 3 Sets Process Variable to Density
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Block Index

Value
(decimal
or float) Description

Diagnostic 6 1.10 Sets Low Setpoint (A) to 1.1 g/cm3

Diagnostic 7 1.12 Sets High Setpoint (B) to 1.12 g/cm3

• Discrete Event 2:

Block Index

Value
(decimal
or float) Description

Diagnostic 4 1 Selects Discrete Event 2

Diagnostic 5 3 Sets Event Type to Out of Range

Diagnostic 8 1 Sets Process Variable to Temperature

Diagnostic 6 20.00 Sets Low Setpoint (A) to 20 °C

Diagnostic 7 25.00 Sets High Setpoint (B) to 25 °C

• Action assignments:

Block Index

Value

(hexadeci-
mal)

Value

(deci-
mal) Description

Filling 77 0x0039 57 Assigns Pause Fill to Discrete Event 1

Filling 76 0x003A 58 Assigns End Fill to Discrete Event 2

Postrequisites

If you have assigned actions to events that are not configured, you must configure those
events before you can implement this fill control method.

10.3.3 Multiple actions assigned to a discrete input or event
If multiple actions are assigned to a discrete input or event, the transmitter performs only
the actions that are relevant in the current situation. If two or more of the actions are
mutually exclusive, the transmitter performs actions according to the priority scheme
defined in the transmitter firmware.

The following examples show three configurations that Micro Motion recommends, and
two configurations that are not recommended.

Example: Using the discrete input or event to begin and end the fill (recommended)

Action assignments:
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• Begin Fill
• End Fill
• Reset Mass Total
• Reset Volume Total

Result of activation:

• If no fill is running, the mass totalizer and volume totalizer are reset and a fill is
started.

• If a fill is running, it is ended and the mass totalizer and volume totalizer are reset.

Example: Using the discrete input or event to begin, pause, and resume the fill
(recommended)

Action assignments:

• Begin Fill
• Pause Fill
• Resume Fill

Result of activation:

• If no fill is running, a fill is started.

• If a fill is running and not paused, it is paused.

• If a fill is paused, it is resumed.

Example: Using the discrete input to begin the fill and reset the volume flow
(recommended)

Action assignments:

• Begin Fill
• Reset Volume Total

Result of activation:

• If no fill is running, the volume totalizer is reset and a fill is started.

• If a fill is running, the volume totalizer is reset.

Tip
This configuration is useful if you have configured your fill in terms of mass but you would also like to
know the volume total for the fill. In this case, do not activate the discrete input while the fill is in
progress. At the end of the fill, read the volume total. Then continue with the next fill.

Example: Incompatible assignments (not recommended)

Action assignments:

• Begin Fill
• End Fill
• Pause Fill
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• Resume Fill

Result of activation:

• If no fill is running, a fill is started.

• If a fill is running, it is ended.

In this example, the discrete input or event will never pause the fill because the End Fill
action takes priority.

Example: Incompatible assignments (not recommended)

Action assignments:

• End Fill
• Reset All Totals

Result of activation:

• If no fill is running, all totals, including the fill total, are reset.

• If a fill is running, it is ended and all totals, including the fill total, are reset.

The result of this combination is that the fill total is reset before the data can be retrieved.

10.4 Configure fill reporting using PROFIBUS bus
parameters (optional)
You can configure the transmitter to report the fill ON/OFF state over Channel B (if it is
available), and percent of fill delivered over the mA output.

10.4.1 Configure Channel B to operate as a discrete output and
report the fill ON/OFF state using PROFIBUS bus
parameters
If Channel B is available, you can use it to report whether or not a fill is running.

Prerequisites

Channel B must be wired to operate as a discrete output.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Set Channel B Type Assignment to Discrete Output.
2. Set DO1 Assignment to Discrete Batch: Batching/Filling In Progress
3. Set DO1 Polarity as appropriate for your installation.
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Option Signal from transmitter Voltage

Active High ON Site-specific up to 30 VDC

OFF 0 VDC

Active Low ON 0 VDC

OFF Site-specific up to 30 VDC

4. Set DO1 Fault Action as appropriate for your installation.

Option Description

Upscale The discrete output will be set to ON (valve open) if a fault
occurs.

Downscale The discrete output will be set to OFF (valve closed) if a fault
occurs.

None No action will be taken if a fault occurs. The discrete output
will remain in the state it was in before the fault occurred.

Tip
When the discrete output is used for fill reporting, Micro Motion recommends setting DO1
Fault Action to None.

Example: Configuring the discrete output to report the fill ON/OFF state

Block Index
Value
(decimal) Description

Filling 83 4 Sets Type Assignment for Channel B Discrete Output

Filling 70 106 Sets DO1 Assignment to
Discrete Batch: Batch/Filling in Progress

Filling 71 1 Sets DO1 Polarity to Active High

Filling 72 4 Sets DO1 Fault Action to None

10.4.2 Configure the mA output to report percentage of fill
delivered using PROFIBUS bus parameters
You can configure the mA output to report the percentage of Fill Target that has been
delivered. In a typical configuration, the current increases from 4 mA to 20 mA as the fill
total moves from 0% to 100%.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.
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Procedure

1. Set Secondary Variable Is to Discrete Batch: Percent Fill.
2. Set Lower Range Value to the percentage of the fill to be represented by 4 mA.

3. Set Upper Range Value to the percentage of the fill to be represented by 20 mA.

4. Set AO Fault Action as desired.

If Lower Range Value is set to 0% and Upper Range Value is set to 100%: When the fill starts, the
mA output will generate a current of 4 mA (0% of Fill Target). The current will increase in
proportion to the fill total, up to a current of 20 mA (100% of Fill Target).

Note
If Flow Direction is set to Bidirectional or Negate Bidirectional, the fill total may decrease under certain flow
conditions. If this occurs, the current generated by the mA output will decrease proportionally.

Example: Configuring the mA output to report percentage of fill delivered

Block Index

Value
(decimal
or float) Description

Filling 42 207 Sets Secondary Variable Is to Discrete Batch: Percent Fill

Filling 43 10.00 Sets Lower Range Value to 10%

Filling 44 80.00 Sets Upper Range Value to 80%

Filling 47 4 Sets AO Fault Action to None
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11 Fill operation using PROFIBUS bus
parameters
Topics covered in this chapter:

• Run an integrated-valve-control fill using PROFIBUS bus parameters

• Perform a manual purge using PROFIBUS bus parameters

• Perform Clean In Place (CIP) using PROFIBUS bus parameters

• Monitor and analyze fill performance using PROFIBUS bus parameters

11.1 Run an integrated-valve-control fill using
PROFIBUS bus parameters
You can use PROFIBUS digital communications to start a fill, monitor the fill, pause and
resume the fill, and end a fill.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. (Optional) If desired, enter a different value for Fill Target (one-stage discrete fills,
two-stage discrete fills, or dual-fillhead fills), or for Target Time (timed fills or dual-
fillhead timed fills).

2. (Optional) If Automatic Overshoot Compensation (AOC) is enabled, you can enter a
different value for AOC Coeff.

Tip
In production use, Micro Motion recommends leaving AOC Coeff at the value determined
during AOC calibration. If you are running AOC calibration fills and you have an AOC Coeff
value available from a similar device, you can use that value as the "first approximation" value
on the current device. This may be helpful if you want to prevent or minimize spilling.

3. Write 1 to the Filling block, Index 106.

The fill total is reset automatically and the valve(s) are opened. The Filling In Progress
indicator should be On. If it is not, and the Start Not Okay indicator or the AOC Flow Rate
Too High indicator is On instead, troubleshoot the fill configuration and try again.

4. Monitor the fill using the Current Total and Percent Fill values and the Fill Status
indicators.
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Fill progress values Description

Current Total Fill quantity at the current time. This value is affected by
Count Up:
• If Count Up is enabled, Current Total begins at 0 and increa-

ses to Fill Target.
• If Count Up is disabled, Current Total begins at Fill Target and

decreases to 0.

Percent Fill Percentage of Fill Target that has been measured up to the
current time. This value is not affected by Count Up.

Fill Status indicator Description

Filling in Progress A fill is currently being performed through the primary valve.
This indicator is active even when the fill is paused.

Secondary Fill in Progress A fill is currently being performed through the secondary
valve. This indicator is active even when the fill is paused. It
applies only to dual-fillhead fills.

Max Fill Time Exceeded The current fill has exceeded the current setting for Max Fill
Time. The fill is aborted.

Primary Valve The primary valve is open.

Secondary Valve The secondary valve is open.

Pump The pump is running.

Purge In Progress A purge has been started, either manually or automatically.

Purge Delay Phase An automatic purge cycle is in progress, and is currently in
the delay period between the completion of the fill and the
start of the purge.

Purge Valve The purge valve is open.

5. (Optional) Pause the fill if desired.

While the fill is paused, you can change the value of Current Target, end the fill
manually with End Filling, or restart the fill with Resume Filling. The fill resumes at the
current value of Current Total and Percent Fill.

Restriction
You cannot pause a timed fill or a dual-fillhead timed fill.

Important
For two-stage discrete fills, the effects of pausing and resuming the fill depend on the timing
of the valve open and valve close commands, and on the point at which the fill is paused.

6. (Optional) Use End Filling to end the fill manually if desired.

Once the fill is ended, it cannot be restarted.
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Tip
In most cases, you should allow the fill to end automatically. End the fill manually only when
you are planning to discard the fill.

11.1.1 If the fill fails to start
If the fill fails to start, check the Start Not Okay and AOC Flow Rate Too High indicators.

If the Start Not Okay indicator is On, check the following:

• Ensure that filling is enabled.

• Ensure that the previous fill has been ended.

• Ensure that Fill Target or Target Time is set to a positive number.

• Ensure that all outputs have been assigned to the valve or pump appropriate for the
fill type and fill option.

• Ensure that there are no active fault conditions at the transmitter.

• For dual-fillhead fills and dual-fillhead timed fills, ensure that no fill is running on
either fillhead.

If the AOC Flow Rate Too High indicator is on, the last measured flow rate is too high to allow
the fill to start. In other words, the AOC coefficient, compensated for the flow rate,
specifies that the valve close command should be issued before the fill has begun. This can
happen if the flow rate has increased significantly since the AOC coefficient was calculated.
Micro Motion recommends the following recovery procedure:

1. Perform any setup that is required to perform AOC calibration.

2. Write 1 to the Filling block, Index 96 (Override Blocked Start).

3. Perform AOC calibration.

4. Return your system to production filling, using the new AOC coefficient.

Example: Values to check if a fill fails to start

Block Index Description

Filling 6 Check that Fill Target is a non-negative number

Filling 16 Check that Target Time is a non-negative number

Filling 41 Check the Start Not Okay and AOC Flow Rate Too High indicators

11.1.2 If the fill did not run to completion
If your fill terminated abnormally, check the transmitter and the Max Fill Time Exceeded
indicator.

If a fault occurs during the fill, the transmitter automatically terminates the fill.
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If the Max Fill Time Exceeded indicator is On, the fill did not reach its target before the
configured Max Fill Time. Consider the following possibilities or actions:

• Increase the flow rate of your process.

• Check for entrained gas (slug flow) in your process fluid.

• Check for blockages in the flow.

• Ensure that the valves are able to close at the expected speed.

• Set Max Fill Time to a higher value.

• Disable Max Fill Time by setting it to 0.

11.1.3 Effects of Pause and Resume on two-stage discrete fills
For two-stage discrete fills, the effects of pausing and resuming the fill depend on where
the Pause and Resume actions occur in relation to the opening and closing of the primary
and secondary valves.

Open Primary first, Close Primary first

In the following illustrations:

• The primary valve opens at the beginning of the fill.

• The secondary valve opens at the user-configured point during the fill. T represents
the time or quantity configured for Open Secondary.

• The primary valve closes before the end of the fill.

• The secondary valve closes at the end of the fill.

Case AFigure 11-1:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

Pause Resume

TT

Open Secondary 
not performed

Fill operation using PROFIBUS bus parameters

154  Micro Motion® Filling Mass Transmitters with PROFIBUS-DP



Case BFigure 11-2:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary

Case CFigure 11-3:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Secondary valve 
opened early

Pause Resume

Open 
Secondary

Case DFigure 11-4:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Primary

Target 
(AOC adjusted)

T T

Secondary valve 
opened early

Pause Resume

Open 
Secondary

Open Primary first, Close Secondary first

In the following illustrations:
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• The primary valve opens at the beginning of the fill.

• The secondary valve opens at the user-configured point during the fill. T represents
the time or quantity configured for Open Secondary.

• The secondary valve closes before the end of the fill.

• The primary valve closes at the end of the fill.

Case EFigure 11-5:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

Pause Resume

TT

Open Secondary 
not performed

Case FFigure 11-6:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary
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Case GFigure 11-7:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Secondary valve 
not reopened

Pause Resume

Open 
Secondary

Case HFigure 11-8:   

Secondary valve

Primary valve

Start Open 
Secondary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Secondary

Secondary valve 
not reopened

Open Secondary first, Close Primary first

In the following illustrations:

• The secondary primary opens at the beginning of the fill.

• The primary valve opens at the user-configured point during the fill. T represents the
time or quantity configured for Open Primary.

• The primary valve closes before the end of the fill.

• The secondary valve closes at the end of the fill.
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Case IFigure 11-9:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

Pause Resume

TT

Open Primary 
not performed

Case JFigure 11-10:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary

Case KFigure 11-11:   

Secondary valve

Primary valve

Start Open 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary not 
performed

Close 
Primary
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Case LFigure 11-12:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Primary

Target 
(AOC adjusted)

T T

Pause Resume

Open Primary 
not performed

Open Secondary first, Close Secondary first

In the following illustrations:

• The secondary primary opens at the beginning of the fill.

• The primary valve opens at the user-configured point during the fill. T represents the
time or quantity configured for Open Primary.

• The secondary valve closes before the end of the fill.

• The primary valve closes at the end of the fill.

Case MFigure 11-13:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

Pause Resume

TT

Open Primary 
not performed
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Case NFigure 11-14:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Pause Resume

Open 
Primary

Case OFigure 11-15:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Primary valve 
opened early

Pause Resume

Open 
Primary

Case PFigure 11-16:   

Secondary valve

Primary valve

Start Open 
Primary

Close 
Secondary

Target 
(AOC adjusted)

T T

Primary valve 
opened early

Pause Resume

Open 
Primary
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11.2 Perform a manual purge using PROFIBUS bus
parameters
The Purge feature is used to control an auxiliary valve that can be used for any non-filling
purpose. For example, it can be used for adding water or gas to the container after the fill
ends, or “padding.” Flow through the auxiliary valve is not measured by the transmitter.

Prerequisites

The Purge feature must be implemented on your system.

The previous fill must be ended.

The auxiliary valve must be connected to the fluid you want to use, e.g., air, water,
nitrogen.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Write 1 to the Filling block, Index 97 (Begin Purge).

In the Filling block, Index 40, the Purge In Progress indicator and the Purge Valve
indicator turn on.

2. Allow the purge fluid to flow for the appropriate amount of time.

3. Write 0 to the Filling block, Index 98 (End Purge).

In the Filling block, Index 40, the Purge In Progress indicator and the Purge Valve
indicator turn off.

11.3 Perform Clean In Place (CIP) using PROFIBUS
bus parameters
The Clean In Place (CIP) function is used to force a cleaning fluid through the system. CIP
allows you to clean the interior surfaces of pipes, valves, nozzles, etc., without having to
disassemble the equipment.

Prerequisites

No fill can be running.

The cleaning fluid must be available for running through the system.

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Replace the process fluid with the cleaning fluid.
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2. Write 1 to the Filling block, Index 111 (Begin Cleaning).

The transmitter opens the primary valve, and the secondary valve if it is used for
filling. If the Pump feature is enabled, the pump is started before the valve is
opened. In the Filling block, Index 40, the Cleaning In Progress indicator turns on.

3. Allow the cleaning fluid to flow through your system for the appropriate amount of
time.

4. Write 1 to the Filling block, Index 112 (End Cleaning).

The transmitter closes all open valves, and stops the pump if applicable. In the Filling
block, Index 40, the Cleaning In Progress indicator turns off.

5. Replace the cleaning fluid with the process fluid.

11.4 Monitor and analyze fill performance using
PROFIBUS bus parameters
You can collect detailed flow data for a single fill, and you can compare data across
multiple fills.

11.4.1 Collect detailed fill data for a single fill using PROFIBUS
bus parameters
When fill logging is enabled, detailed data for the most recent fill is stored on the
transmitter. You can retrieve it for analysis using digital communications. The detailed
data can be used for tuning or troubleshooting your production environment.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Write 1 to the Filling block, Index 37 (Enable Fill Logging).

2. Run a fill.

3. Write 0 to the Filling block, Index 37 (Enable Fill Logging) when you are finished with
data collection.

4. Read the fill log.

a. Write a fill log index to the Filling block, Index 38.

Fill log index values range from 0 to 1000, representing the last 1000 log records.

b. Read the log information for that index from the Filling block, Index 39.
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The fill log contains data records from a single fill, from the beginning of the fill until
50 milliseconds after flow stops, or until the maximum log size is reached. Data records are
written every 10 milliseconds. Each data record contains the current value of Flow Source
(the process variable used to measure the fill). The fill log is limited to 1000 records, or
10 seconds of filling. When the maximum size is reached, logging stops but the data is
available on the transmitter until the next fill starts. The fill log is cleared each time a fill
starts.

11.4.2 Analyze fill performance using fill statistics and
PROFIBUS bus parameters
The transmitter automatically records a variety of data about each fill. This data is available
to assist you in tuning your system.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. (Optional) Write 1 to the Filling block, Index 95 (Reset Fill Statistics) to start your
analysis with a fresh set of fill data.

2. Run fills and observe the fill data.

Fill data

Filling
block in-
dex Fill type Description

Fill Total Average 91 One-stage discrete fills,
two-stage discrete fills,
and timed fills

Calculated average of all fill to-
tals since fill statistics were re-
set.

Dual-fillhead fills and du-
al-fillhead timed fills

Calculated average of all fill to-
tals through Fillhead #1 since
fill statistics were reset.

Fill Total Variance 92 One-stage discrete fills,
two-stage discrete fills,
and timed fills

Calculated variance of all fill to-
tals since fill statistics were re-
set.

Dual-fillhead fills and du-
al-fillhead timed fills

Calculated variance of all fill to-
tals through Fillhead #1 since
fill statistics were reset.

Secondary Fill Total
Average

93 Dual-fillhead fills and du-
al-fillhead timed fills on-
ly

Calculated average of all fill to-
tals through Fillhead #2 since
fill statistics were reset.

Secondary Fill Total
Variance

94 Dual-fillhead fills and du-
al-fillhead timed fills on-
ly

Calculated variance of all fill to-
tals through Fillhead #2 since
fill statistics were reset.
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Part III
Configure and operate external-valve-
control fills

Chapters covered in this part:

• Configure and set up external-valve-control fills using ProLink II

• Configure and set up external-valve-control fills using the PROFIBUS EDD

• Configure and set up external-valve-control fills using PROFIBUS bus parameters
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12 Configure and set up external-valve-
control fills using ProLink II
Topics covered in this chapter:

• Configure an external-valve-control fill using ProLink II

• Set up and run an external-valve-control fill

12.1 Configure an external-valve-control fill using
ProLink II
Configuring an external-valve-control fill includes configuring the frequency output and
several flow parameters. When the fill is configured, the host will use flow data from the
transmitter's frequency output to measure the fill and close the valves.

Prerequisites

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Choose ProLink > Configuration > Frequency.

2. Set Tertiary Variable to the process variable that the host will use to measure the fill:
Mass Flow Rate or Volume Flow Rate.

3. Set the following as appropriate for your application: FO Scaling Method and related
parameters, Frequency Output Polarity, and Fault Action.

4. Open the Flow panel.

5. If you set Tertiary Variable to Mass Flow Rate:

a. Set Mass Flow Units to the mass flow units used by the host.

b. Set Mass Flow Cutoff to the lowest flow rate that will be measured and reported to
the host. All flow rates below this will be reported as 0.

6. If you set Tertiary Variable to Volume Flow Rate:

a. Set Volume Flow Units to the volume flow units used by the host.

b. Set Volume Flow Cutoff to the lowest flow rate that will be measured and reported
to the host. All flow rates below this will be reported as 0.

7. Set Flow Damping as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most filling
applications, and is typically not changed.
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8. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the direc-
tion of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite di-
rection of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow is
in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

Postrequisites

Ensure that your host is configured appropriately. For example, ensure that your host is
using the appropriate measurement unit and that it can convert flow rate into flow total if
required.

12.2 Set up and run an external-valve-control fill
The host must receive flow data from the transmitter, perform required calculations, and
open and close valves to manage the fill.

1. Ensure that the host is receiving flow data over the transmitter's frequency output.

2. Ensure that the host is correctly interpreting and processing the data from the
transmitter.

3. Perform any required wiring and configuration so that the host can open and close
valves at the appropriate times.

4. Initiate the program that starts and manages filling.
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13 Configure and set up external-valve-
control fills using the PROFIBUS EDD
Topics covered in this chapter:

• Configure an external-valve-control fill using the PROFIBUS EDD

• Set up and run an external-valve-control fill

13.1 Configure an external-valve-control fill using
the PROFIBUS EDD
Configuring an external-valve-control fill includes configuring the frequency output and
several flow parameters. When the fill is configured, the host will use flow data from the
transmitter's frequency output to measure the fill and close the valves.

Prerequisites

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Choose Online > Configure > Manual Setup > Frequency Output.
2. Set Tertiary Variable to the process variable that the host will use to measure the fill:

Mass Flow Rate or Volume Flow Rate.

3. Set the following as appropriate for your application: FO Scaling Method and related
parameters, Frequency Output Polarity, and Fault Action.

4. Choose Online > Configure > Manual Setup > Measurements > Flow.

5. If you set Tertiary Variable to Mass Flow Rate:

a. Set Mass Flow Units to the mass flow units used by the host.

b. Set Mass Flow Cutoff to the lowest flow rate that will be measured and reported to
the host. All flow rates below this will be reported as 0.

6. If you set Tertiary Variable to Volume Flow Rate:

a. Set Volume Flow Units to the volume flow units used by the host.

b. Set Volume Flow Cutoff to the lowest flow rate that will be measured and reported
to the host. All flow rates below this will be reported as 0.

7. Set Flow Damping as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most filling
applications, and is typically not changed.
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8. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the direc-
tion of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite di-
rection of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow is
in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

Postrequisites

Ensure that your host is configured appropriately. For example, ensure that your host is
using the appropriate measurement unit and that it can convert flow rate into flow total if
required.

13.2 Set up and run an external-valve-control fill
The host must receive flow data from the transmitter, perform required calculations, and
open and close valves to manage the fill.

1. Ensure that the host is receiving flow data over the transmitter's frequency output.

2. Ensure that the host is correctly interpreting and processing the data from the
transmitter.

3. Perform any required wiring and configuration so that the host can open and close
valves at the appropriate times.

4. Initiate the program that starts and manages filling.
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14 Configure and set up external-valve-
control fills using PROFIBUS bus
parameters
Topics covered in this chapter:

• Configure an external-valve-control fill using PROFIBUS bus parameters

• Set up and run an external-valve-control fill

14.1 Configure an external-valve-control fill using
PROFIBUS bus parameters
Configuring an external-valve-control fill includes configuring the frequency output and
several flow parameters. When the fill is configured, the host will use flow data from the
transmitter's frequency output to measure the fill and close the valves.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Procedure

1. Set Tertiary Variable to the process variable that the host will use to measure the fill:
Mass Flow Rate or Volume Flow Rate.

2. Set the following as appropriate for your application: FO Scaling Method and related
parameters, Frequency Output Polarity, and Fault Action.

3. If you set Tertiary Variable to Mass Flow Rate:

a. Set Mass Flow Units to the mass flow units used by the host.

b. Set Mass Flow Cutoff to the lowest flow rate that will be measured and reported to
the host. All flow rates below this will be reported as 0.

4. If you set Tertiary Variable to Volume Flow Rate:

a. Set Volume Flow Units to the volume flow units used by the host.

b. Set Volume Flow Cutoff to the lowest flow rate that will be measured and reported
to the host. All flow rates below this will be reported as 0.

5. Set Flow Damping as desired.

Tip
The default value of Flow Damping is 0.04 seconds. This is the optimum value for most filling
applications, and is typically not changed.

Configure and set up external-valve-control fills using PROFIBUS bus parameters

Configuration and Use Manual 171



6. Set Flow Direction to the option appropriate for your installation.

Option Description

Forward Process fluid flows in one direction only, matching the direc-
tion of the arrow on the sensor.

Bidirectional Process fluid can flow in either direction. Most of the flow
matches the direction of the arrow on the sensor.

Negate Forward Process fluid flows in one direction only, in the opposite di-
rection of the arrow on the sensor.

Negate Bidirectional Process fluid can flow in either direction. Most of the flow is
in the opposite direction of the arrow on the sensor.

Restriction
All other options for Flow Direction are invalid, and will be rejected by the transmitter.

Example: Configuring an external-valve-control fill

Important
This example uses standard or typical settings for the required parameters. Your application may
require different settings. Refer to the PROFIBUS bus parameters documentation for information on
data types and integer codes.

Block Index

Value
(decimal
or float) Description

Filling 57 0 Sets Tertiary Variable to Mass Flow Rate

Filling 58 0 Sets FO Scaling Method to Frequency=Flow

Filling 59 333.33 Sets Frequency Factor to 333.33

Filling 60 2000.00 Sets Rate Factor to 2000

Filling 66 1 Sets Frequency Output Polarity to Active High

Filling 64 1 Sets Frequency Output Fault Action to Downscale

Measurement 5 1318 Sets Mass Flow Units to g/sec

Measurement 18 3.00 Sets Mass Flow Cutoff to 3 g/sec

Measurement 11 1347 Sets Volume Flow Units to m3/sec

Measurement 19 0.03 Sets Volume Flow Cutoff to 0.03 m3/sec

Measurement 21 0 Sets Flow Direction to Forward
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Postrequisites

Ensure that your host is configured appropriately. For example, ensure that your host is
using the appropriate measurement unit and that it can convert flow rate into flow total if
required.

14.2 Set up and run an external-valve-control fill
The host must receive flow data from the transmitter, perform required calculations, and
open and close valves to manage the fill.

1. Ensure that the host is receiving flow data over the transmitter's frequency output.

2. Ensure that the host is correctly interpreting and processing the data from the
transmitter.

3. Perform any required wiring and configuration so that the host can open and close
valves at the appropriate times.

4. Initiate the program that starts and manages filling.
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Part IV
General transmitter configuration

Chapters covered in this part:

• Configure process measurement

• Configure device options and preferences

• Integrate the meter with the network

General transmitter configuration
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15 Configure process measurement
Topics covered in this chapter:

• Characterize the flowmeter (if required)

• Configure mass flow measurement

• Configure volume flow measurement for liquid applications

• Configure Flow Direction

• Configure density measurement

• Configure temperature measurement

• Configure pressure compensation
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15.1 Characterize the flowmeter (if required)

ProLink II ProLink > Configuration > Device > Sensor Type

ProLink > Configuration > Flow > Flow Cal

ProLink > Configuration > Density > D1

ProLink > Configuration > Density > D2

ProLink > Configuration > Density > Temp Coeff (DT)

ProLink > Configuration > Density > K1

ProLink > Configuration > Density > K2

ProLink > Configuration > Density > FD

ProLink III Device Tools > Calibration Data

PROFIBUS EDD Configure > Manual Setup > Characterize > Type

Configure > Manual Setup > Characterize > Flow FCF

Configure > Manual Setup > Characterize > D1

Configure > Manual Setup > Characterize > D2

Configure > Manual Setup > Characterize > DT

Configure > Manual Setup > Characterize > K1

Configure > Manual Setup > Characterize > K2

Configure > Manual Setup > Characterize > FD

PROFIBUS bus pa-

rameters

Sensor Type: Block: Device Information, Index 7

Flow Calibration Factor (FCF): Block: Calibration, Index 4

Temperature coefficient for flow (FT) : Block: Calibration, Index 5

D1: Block: Calibration, Index 21

D2: Block: Calibration, Index 22

Density temperature coefficient (DT): Block: Calibration, Index 26

K1: Block: Calibration, Index 16

K2: Block: Calibration, Index 17

FD: Block: Calibration, Index 18

Overview

Characterizing the flowmeter adjusts your transmitter to match the unique traits of the
sensor it is paired with. The characterization parameters (also called calibration
parameters) describe the sensor’s sensitivity to flow, density, and temperature.
Depending on your sensor type, different parameters are required. Values for your sensor
are provided by Micro Motion on the sensor tag or the calibration certificate.

Tip
If your flowmeter was ordered as a unit, it has already been characterized at the factory. However,
you should still verify the characterization parameters.
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Procedure

1. Specify Sensor Type.

• Curved-tube (all sensors except T-Series)

2. Set the flow characterization parameters. Be sure to include all decimal points.

• For curved-tube sensors, set Flow Cal (Flow Calibration Factor).

3. Set the density characterization parameters.

• For curved-tube sensors, set D1, D2, TC, K1, K2, and FD. (TC is sometimes shown
as DT.)

15.1.1 Sample sensor tags

Tag on newer curved-tube sensors (all sensors except T-Series)Figure 15-1:   

15.1.2 Flow calibration parameters (FCF, FT)
Two separate values are used to describe flow calibration: a 6-character FCF value and a 4-
character FT value. They are provided on the sensor tag.

Both values contain decimal points. During characterization, these may be entered as two
values or as a single 10-character string. The 10-character string is called either Flowcal or
FCF.

If your sensor tag shows the FCF and the FT values separately and you need to enter a
single value, concatenate the two values to form the single parameter value.

If your sensor tag shows a concatenated Flowcal or FCF value and you need to enter the FCF
and the FT values separately, split the concatenated value:

• FCF = The first 6 characters, including the decimal point
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• FT = The last 4 characters, including the decimal point

Example: Concatenating FCF and FT

FCF = x.xxxx
FT = y.yy
Flow calibration parameter: x.xxxxy.yy

Example: Splitting the concatenated Flowcal or FCF value

Flow calibration parameter: x.xxxxy.yy
FCF = x.xxxx
FT = y.yy

15.1.3 Density calibration parameters (D1, D2, K1, K2, FD, DT,
TC)
Density calibration parameters are typically on the sensor tag and the calibration
certificate.

If your sensor tag does not show a D1 or D2 value:

• For D1, enter the Dens A or D1 value from the calibration certificate. This value is the
line-condition density of the low-density calibration fluid. Micro Motion uses air. If
you cannot find a Dens A or D1 value, enter 0.001 g/cm3.

• For D2, enter the Dens B or D2 value from the calibration certificate. This value is the
line-condition density of the high-density calibration fluid. Micro Motion uses water.
If you cannot find a Dens B or D2 value, enter 0.998 g/cm3.

If your sensor tag does not show a K1 or K2 value:

• For K1, enter the first 5 digits of the density calibration factor. In the sample tag, this
value is shown as 12500.

• For K2, enter the second 5 digits of the density calibration factor. In the sample tag,
this value is shown as 14286.

If your sensor does not show an FD value, contact Micro Motion customer service.

If your sensor tag does not show a DT or TC value, enter the last 3 digits of the density
calibration factor. In the sample tag, this value is shown as 4.44.

15.2 Configure mass flow measurement
The mass flow measurement parameters control how mass flow is measured and reported.

The mass flow measurement parameters include:

• Mass Flow Measurement Unit
• Flow Damping
• Mass Flow Cutoff
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15.2.1 Configure Mass Flow Measurement Unit

ProLink II ProLink > Configuration > Flow > Mass Flow Units

ProLink III Device Tools > Configuration > Process Measurement > Flow

PROFIBUS EDD Configure > Manual Setup > Measurements > Flow > Mass Flow Unit

PROFIBUS bus pa-

rameters

Block: Measurement, Index 5

Overview

Mass Flow Measurement Unit specifies the unit of measure that will be used for the mass flow
rate. The unit used for mass total and mass inventory is derived from this unit.

Procedure

Set Mass Flow Measurement Unit to the unit you want to use.

The default setting for Mass Flow Measurement Unit is g/sec (grams per second).

Options for Mass Flow Measurement Unit
The transmitter provides a standard set of measurement units for Mass Flow Measurement
Unit, plus one user-defined special measurement unit. Different communications tools may
use different labels for the units.

Options for Mass Flow Measurement UnitTable 15-1:   

Unit description Label

ProLink II ProLink III

Grams per second g/sec g/sec

Grams per minute g/min g/min

Grams per hour g/hr g/hr

Kilograms per second kg/sec kg/sec

Kilograms per minute kg/min kg/min

Kilograms per hour kg/hr kg/hr

Kilograms per day kg/day kg/day

Metric tons per minute mTon/min mTon/min

Metric tons per hour mTon/hr mTon/hr

Metric tons per day mTon/day mTon/day

Pounds per second lbs/sec lbs/sec

Pounds per minute lbs/min lbs/min

Pounds per hour lbs/hr lbs/hr
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Options for Mass Flow Measurement Unit (continued)Table 15-1:   

Unit description Label

ProLink II ProLink III

Pounds per day lbs/day lbs/day

Short tons (2000 pounds) per minute sTon/min sTon/min

Short tons (2000 pounds) per hour sTon/hr sTon/hr

Short tons (2000 pounds) per day sTon/day sTon/day

Long tons (2240 pounds) per hour lTon/hr lTon/hr

Long tons (2240 pounds) per day lTon/day lTon/day

15.2.2 Configure Flow Damping

ProLink II ProLink > Configuration > Flow > Flow Damp

ProLink III Device Tools > Configuration > Process Measurement > Flow

PROFIBUS EDD Configure > Manual Setup > Measurements > Flow > Flow Damping

PROFIBUS bus pa-

rameters

Block: Measurement, Index 12

Overview

Damping is used to smooth out small, rapid fluctuations in process measurement. Damping
Value specifies the time period (in seconds) over which the transmitter will spread changes
in the reported process variable. At the end of the interval, the reported process variable
will reflect 63% of the change in the actual measured value.

Procedure

Set Flow Damping to the value you want to use.

The default value is 0.04 seconds. The range is 0 to 40.96 seconds.

Tips

• A high damping value makes the process variable appear smoother because the reported value
changes slowly.

• A low damping value makes the process variable appear more erratic because the reported value
changes more quickly.

• The combination of a high damping value and rapid, large changes in flow rate can result in
increased measurement error.

• Whenever the damping value is non-zero, the reported measurement will lag the actual
measurement because the reported value is being averaged over time.

• In general, lower damping values are preferable because there is less chance of data loss, and less
lag time between the actual measurement and the reported value.
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• Micro Motion recommends using the default value of 0.04 seconds.

The value you enter is automaticaly rounded down to the nearest valid value. The valid
values for Flow Damping are: 0, 0.04, 0.08, 0.16, ... 40.96.

Effect of Flow Damping on volume measurement
Flow Damping affects volume measurement for liquid volume data. The transmitter
calculates volume data from the damped mass flow data.

Interaction between Flow Damping and Added Damping
In some circumstances, both Flow Damping and Added Damping are applied to the reported
mass flow value.

Flow Damping controls the rate of change in flow process variables. Added Damping controls
the rate of change reported via the mA output. If mA Output Process Variable is set to Mass
Flow Rate, and both Flow Damping and Added Damping are set to non-zero values, flow
damping is applied first, and the added damping calculation is applied to the result of the
first calculation.

15.2.3 Configure Mass Flow Cutoff for filling applications

ProLink II ProLink > Configuration > Flow > Mass Flow Cutoff

ProLink III Device Tools > Configuration > Process Measurement > Flow

PROFIBUS EDD Configure > Manual Setup > Measurements > Flow > Mass Flow Cutoff

PROFIBUS bus pa-

rameters

Block: Measurement, Index 18

Overview

If you are performing an integrated-valve-control fill with Flow Source set to the Mass Flow
Rate, you must set Mass Flow Cutoff to a value that masks the effects of vibration and other
environmental factors. This is necessary because the transmitter will not complete fill
processing until it detects a zero flow.

If Flow Source is set to the Volume Flow Rate, Mass Flow Cutoff does not affect filling.

Prerequisites

Ensure that the zero value in the transmitter is accurate.

Procedure

1. Set the Mass Flow Cutoff to 0.

2. Stop flow through the sensor.

3. Power up the filling machine and any other sources of vibration.
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4. Observe the reported mass flow rate.

5. Set the Mass Flow Cutoff to a value slightly above the reported mass flow rate.

6. Verify that the mass flow rate is reported as 0.

Postrequisites

Important
Changes in Mass Flow Cutoff affect Automatic Overshoot Compensation (AOC). If you have
implemented standard AOC, you must repeat the AOC calibration whenever you change the setting
of Mass Flow Cutoff. This requirement does not apply to a rolling AOC or fixed AOC.

15.2.4 Configure Mass Flow Cutoff

ProLink II ProLink > Configuration > Flow > Mass Flow Cutoff

ProLink III Device Tools > Configuration > Process Measurement > Flow

PROFIBUS EDD Configure > Manual Setup > Measurements > Flow > Mass Flow Cutoff

PROFIBUS bus pa-

rameters

Block: Measurement, Index 18

Overview

Mass Flow Cutoff specifies the lowest mass flow rate that will be reported as measured. All
mass flow rates below this cutoff will be reported as 0.

Note
If you are configuring Mass Flow Cutoff for an integrated-valve-control filling application, and Flow
Source is set to the Mass Flow Rate, see Section 15.2.3.

Procedure

Set Mass Flow Cutoff to the value you want to use.

The default value for Mass Flow Cutoff is 0.0 g/sec or a sensor-specific value set at the
factory. The recommended setting is 0.05% of the sensor's rated maximum flow rate or a
value below the highest expected flow rate. Do not set Mass Flow Cutoff to 0.0 g/sec.

Effect of Mass Flow Cutoff on volume measurement
Mass Flow Cutoff does not affect volume measurement. Volume data is calculated from the
actual mass data rather than the reported value.
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Interaction between Mass Flow Cutoff and AO Cutoff
Mass Flow Cutoff defines the lowest mass flow value that the transmitter will report as
measured. AO Cutoff defines the lowest flow rate that will be reported via the mA output. If
mA Output Process Variable is set to Mass Flow Rate, the mass flow rate reported via the mA
output is controlled by the higher of the two cutoff values.

Mass Flow Cutoff affects all reported values and values used in other transmitter behavior
(e.g., events defined on mass flow).

AO Cutoff affects only mass flow values reported via the mA output.

Example: Cutoff interaction with AO Cutoff lower than Mass Flow Cutoff

Configuration:

• mA Output Process Variable: Mass Flow Rate
• Frequency Output Process Variable: Mass Flow Rate
• AO Cutoff: 10 g/sec

• Mass Flow Cutoff: 15 g/sec

Result: If the mass flow rate drops below 15 g/sec, mass flow will be reported as 0, and 0
will be used in all internal processing.

Example: Cutoff interaction with AO Cutoff higher than Mass Flow Cutoff

Configuration:

• mA Output Process Variable: Mass Flow Rate
• Frequency Output Process Variable: Mass Flow Rate
• AO Cutoff: 15 g/sec

• Mass Flow Cutoff: 10 g/sec

Result:

• If the mass flow rate drops below 15 g/sec but not below 10 g/sec:

- The mA output will report zero flow.

- The frequency output will report the actual flow rate, and the actual flow rate will
be used in all internal processing.

• If the mass flow rate drops below 10 g/sec, both outputs will report zero flow, and 0
will be used in all internal processing.

15.3 Configure volume flow measurement for liquid
applications
The volume flow measurement parameters control how liquid volume flow is measured
and reported.
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15.3.1 Configure Volume Flow Measurement Unit for liquid
applications

ProLink II ProLink > Configuration > Flow > Vol Flow Units

ProLink III Device Tools > Configuration > Process Measurement > Flow

PROFIBUS EDD Configure > Manual Setup > Measurements > Flow > Volume Flow Unit

PROFIBUS bus pa-

rameters

Block: Measurement, Index 11

Overview

Volume Flow Measurement Unit specifies the unit of measurement that will be displayed for the
volume flow rate. The unit used for the volume total and volume inventory is based on this
unit.

Prerequisites

Before you configure Volume Flow Measurement Unit, be sure that Volume Flow Type is set to
Liquid.

Procedure

Set Volume Flow Measurement Unit to the unit you want to use.

The default setting for Volume Flow Measurement Unit is l/sec (liters per second).

Options for Volume Flow Measurement Unit for liquid
applications
The transmitter provides a standard set of measurement units for Volume Flow Measurement
Unit, plus one user-defined measurement unit. Different communications tools may use
different labels for the units.

Options for Volume Flow Measurement UnitTable 15-2:   

Unit description Label

ProLink II ProLink III

Cubic feet per second ft3/sec ft3/sec

Cubic feet per minute ft3/min ft3/min

Cubic feet per hour ft3/hr ft3/hr

Cubic feet per day ft3/day ft3/day

Cubic meters per second m3/sec m3/sec

Cubic meters per minute m3/min m3/min

Cubic meters per hour m3/hr m3/hr

Configure process measurement

186  Micro Motion® Filling Mass Transmitters with PROFIBUS-DP



Options for Volume Flow Measurement Unit (continued)Table 15-2:   

Unit description Label

ProLink II ProLink III

Cubic meters per day m3/day m3/day

U.S. gallons per second US gal/sec US gal/sec

U.S. gallons per minute US gal/min US gal/min

U.S. gallons per hour US gal/hr US gal/hr

U.S. gallons per day US gal/day US gal/day

Million U.S. gallons per day mil US gal/day mil US gal/day

Liters per second l/sec l/sec

Liters per minute l/min l/min

Liters per hour l/hr l/hr

Million liters per day mil l/day mil l/day

Imperial gallons per second Imp gal/sec Imp gal/sec

Imperial gallons per minute Imp gal/min Imp gal/min

Imperial gallons per hour Imp gal/hr Imp gal/hr

Imperial gallons per day Imp gal/day Imp gal/day

Barrels per second(1) barrels/sec barrels/sec

Barrels per minute(1) barrels/min barrels/min

Barrels per hour(1) barrels/hr barrels/hr

Barrels per day(1) barrels/day barrels/day

Beer barrels per second(2) Beer barrels/sec Beer barrels/sec

Beer barrels per minute(2) Beer barrels/min Beer barrels/min

Beer barrels per hour(2) Beer barrels/hr Beer barrels/hr

Beer barrels per day(2) Beer barrels/day Beer barrels/day

15.3.2 Configure Volume Flow Cutoff for filling applications

ProLink II ProLink > Configuration > Flow > Vol Flow Cutoff

ProLink III Device Tools > Configuration > Process Measurement > Flow

PROFIBUS EDD Configure > Manual Setup > Measurements > Flow > Volume Flow Cutoff

PROFIBUS bus pa-

rameters

Block: Measurement, Index 19

(1) Unit based on oil barrels (42  U.S. gallons).

(2) Unit based on U.S. beer barrels (31 U.S. gallons).
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Overview

If you are performing an integrated-valve-control fill with Flow Source set to the Volume Flow
Rate, you must set Volume Flow Cutoff to a value that masks the effects of vibration and other
environmental factors. This is necessary because the transmitter will not complete fill
processing until it detects zero flow.

If Flow Source is set to the Mass Flow Rate, Volume Flow Cutoff does not affect filling.

Prerequisites

Ensure that the zero value in the transmitter is accurate.

Procedure

1. Set the Volume Flow Cutoff to 0.

2. Stop flow through the sensor.

3. Power up the filling machine and any other sources of vibration.

4. Observe the reported volume flow rate.

5. Set the Volume Flow Cutoff to a value slightly above the reported volume flow rate.

6. Verify that volume flow rate is reported as 0.

Postrequisites

Important
Changes in Volume Flow Cutoff affect Automatic Overshoot Compensation (AOC). If you have
implemented standard AOC, you must repeat AOC calibration whenever you change Volume Flow
Cutoff setting. This requirement does not apply to rolling AOC or fixed AOC.

15.3.3 Configure Volume Flow Cutoff

ProLink II ProLink > Configuration > Flow > Vol Flow Cutoff

ProLink III Device Tools > Configuration > Process Measurement > Flow

PROFIBUS EDD Configure > Manual Setup > Measurements > Flow > Volume Flow Cutoff

PROFIBUS bus pa-

rameters

Block: Measurement, Index 19

Overview

Volume Flow Cutoff specifies the lowest volume flow rate that will be reported as measured.
All volume flow rates below this cutoff are reported as 0.

Note
If you are configuring Volume Flow Cutoff for an integrated-valve-control filling application, and Flow
Source is set to the Volume Flow Rate, see Section 15.3.2.
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Procedure

Set Volume Flow Cutoff to the value you want to use.

The default value for Volume Flow Cutoff is 0.0 l/sec (liters per second). The lower limit is 0.
The upper limit is the sensor’s flow calibration factor, in units of l/sec, multiplied by 0.2.

Interaction between Volume Flow Cutoff and AO Cutoff
Volume Flow Cutoff defines the lowest liquid volume flow value that the transmitter will
report as measured. AO Cutoff defines the lowest flow rate that will be reported via the mA
output. If mA Output Process Variable is set to Volume Flow Rate, the volume flow rate reported
via the mA output is controlled by the higher of the two cutoff values.

Volume Flow Cutoff affects both the volume flow values reported via the outputs and the
volume flow values used in other transmitter behavior (e.g., events defined on the volume
flow).

AO Cutoff affects only flow values reported via the mA output.

Example: Cutoff interaction with AO Cutoff lower than Volume Flow Cutoff

Configuration:

• mA Output Process Variable: Volume Flow Rate
• Frequency Output Process Variable: Volume Flow Rate
• AO Cutoff: 10 l/sec

• Volume Flow Cutoff: 15 l/sec

Result: If the volume flow rate drops below 15 l/sec, volume flow will be reported as 0, and
0 will be used in all internal processing.

Example: Cutoff interaction with AO Cutoff higher than Volume Flow Cutoff

Configuration:

• mA Output Process Variable: Volume Flow Rate
• Frequency Output Process Variable: Volume Flow Rate
• AO Cutoff: 15 l/sec

• Volume Flow Cutoff: 10 l/sec

Result:

• If the volume flow rate drops below 15 l/sec but not below 10 l/sec:

- The mA output will report zero flow.

- The frequency output will report the actual flow rate, and the actual flow rate will
be used in all internal processing.

• If the volume flow rate drops below 10 l/sec, both outputs will report zero flow, and
0 will be used in all internal processing.
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15.4 Configure Flow Direction

ProLink II ProLink > Configuration > Flow > Flow Direction

ProLink III Device Tools > Configuration > Process Measurement > Flow

PROFIBUS EDD Configure > Manual Setup > Measurements > Flow > Flow Direction

PROFIBUS bus pa-

rameters

Block: Measurement, Index 21

Overview

Flow Direction controls how forward flow and reverse flow affect flow measurement and
reporting.

Flow Direction is defined with respect to the flow arrow on the sensor:

• Forward flow (positive flow) moves in the direction of the flow arrow on the sensor.

• Reverse flow (negative flow) moves in the direction opposite to the flow arrow on
the sensor.

Tip
Micro Motion sensors are bidirectional. Measurement accuracy is not affected by actual flow
direction or the setting of the Flow Direction parameter.

Procedure

Set Flow Direction to the value you want to use.

15.4.1 Options for Flow Direction

Options for Flow DirectionTable 15-3:   

Flow Direction setting Relationship to Flow Direction arrow on sensor

ProLink II ProLink III

Forward Forward Appropriate when the Flow Direction arrow is in
the same direction as the majority of flow.

Bidirectional Bidirectional Appropriate when both forward and reverse flow
are expected, and forward flow will dominate, but
the amount of reverse flow will be significant.

Negate Forward Negate Forward Appropriate when the Flow Direction arrow is in
the opposite direction from the majority of flow.

Negate Bidirectional Negate Bidirectional Appropriate when both forward and reverse flow
are expected, and reverse flow will dominate, but
the amount of forward flow will be significant.
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Effect of Flow Direction on mA outputs
Flow Direction affects how the transmitter reports flow values via the mA outputs. The mA
outputs are affected by Flow Direction only if mA Output Process Variable is set to a flow
variable.

Example: Flow Direction = Forward and Lower Range Value = 0

Configuration:

• Flow Direction = Forward
• Lower Range Value = 0 g/sec

• Upper Range Value = 100 g/sec

Result:

• Under conditions of reverse flow or zero flow, the mA output is 4 mA.

• Under conditions of forward flow, up to a flow rate of 100 g/sec, the mA output
varies between 4 mA and 20 mA in proportion to the flow rate.

• Under conditions of forward flow, if the flow rate equals or exceeds 100 g/sec, the
mA output will be proportional to the flow rate up to 20.5 mA, and will be level at
20.5 mA at higher flow rates.

Example: Flow Direction = Forward and Lower Range Value < 0

Configuration:

• Flow Direction = Forward
• Lower Range Value = −100 g/sec

• Upper Range Value = +100 g/sec

Result:

• Under conditions of zero flow, the mA output is 12 mA.

• Under conditions of forward flow, for flow rates between 0 and +100 g/sec, the mA
output varies between 12 mA and 20 mA in proportion to (the absolute value of) the
flow rate.

• Under conditions of forward flow, if (the absolute value of) the flow rate equals or
exceeds 100 g/sec, the mA output is proportional to the flow rate up to 20.5 mA,
and will be level at 20.5 mA at higher flow rates.

• Under conditions of reverse flow, for flow rates between 0 and −100 g/sec, the mA
output varies between 4 mA and 12 mA in inverse proportion to the absolute value
of the flow rate.

• Under conditions of reverse flow, if the absolute value of the flow rate equals or
exceeds 100 g/sec, the mA output is inversely proportional to the flow rate down to
3.8 mA, and will be level at 3.8 mA at higher absolute values.
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Effect of Flow Direction on frequency outputs
Flow Direction affects how the transmitter reports flow values via the frequency outputs. The
frequency outputs are affected by Flow Direction only if Frequency Output Process Variable is set
to a flow variable.

Effect of the Flow Direction parameter and actual flow direction on
frequency outputs

Table 15-4:   

Flow Direction setting Actual flow direction

Forward Zero flow Reverse

Forward Hz > 0 0 Hz 0 Hz

Bidirectional Hz > 0 0 Hz Hz > 0

Negate Forward 0 Hz 0 Hz Hz > 0

Negate Bidirectional Hz > 0 0 Hz Hz > 0

Effect of Flow Direction on discrete outputs
The Flow Direction parameter affects the discrete output behavior only if Discrete Output
Source is set to Flow Direction.

Effect of the Flow Direction parameter and actual flow direction on
discrete outputs

Table 15-5:   

Flow Direction setting Actual flow direction

Forward Zero flow Reverse

Forward OFF OFF ON

Reverse OFF OFF ON

Bidirectional OFF OFF ON

Absolute Value OFF OFF OFF

Negate Forward ON OFF OFF

Negate Bidirectional ON OFF OFF

Effect of Flow Direction on digital communications
Flow Direction affects how flow values are reported via digital communications.

Effect of the Flow Direction parameter and actual flow direction on flow
values reported via digital communications

Table 15-6:   

Flow Direction setting Actual flow direction

Forward Zero flow Reverse

Forward Positive 0 Negative
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Effect of the Flow Direction parameter and actual flow direction on flow
values reported via digital communications (continued)

Table 15-6:   

Flow Direction setting Actual flow direction

Forward Zero flow Reverse

Bidirectional Positive 0 Negative

Negate Forward Negative 0 Positive

Negate Bidirectional Negative 0 Positive

Effect of Flow Direction on flow totals
Flow Direction affects how flow totals and inventories are calculated.

Effect of the Flow Direction parameter and actual flow direction on flow
totals and inventories

Table 15-7:   

Flow Direction setting Actual flow direction

Forward Zero flow Reverse

Forward Totals increase Totals do not change Totals do not change

Bidirectional Totals increase Totals do not change Totals decrease

Negate Forward Totals do not change Totals do not change Totals increase

Negate Bidirectional Totals decrease Totals do not change Totals increase

Effect of Flow Direction on the fill total
Flow Direction affects how the transmitter measures fills and determines when the fill is
complete (the fill total has been achieved).

Effect of the Flow Direction parameter and actual flow direction on the
fill total

Table 15-8:   

Flow Direction setting Actual flow direction

Forward Zero flow Reverse

Forward Fill total increases Fill total does not
change

Fill total does not
change

Bidirectional Fill total increases Fill total does not
change

Fill total decreases

Negate Forward Fill total does not
change

Fill total does not
change

Fill total increases

Negate Bidirectional Fill total decreases Fill total does not
change

Fill total increases
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Forward flow Flow in same direction as flow direction arrow on sensor

Reverse flow Flow in opposite direction from flow direction arrow on sensor

Tip
If reverse flow could occur in your process and could cause consistency problems, Micro Motion
recommends setting Flow Direction to Bidirectional or Negate Bidirectional.

Note
Flow Direction also affects fill reporting over the mA output, the frequency output, and digital
communications, and affects flow rate reporting over the mA output, frequency output, and digital
communications.

15.5 Configure density measurement
The density measurement parameters control how density is measured and reported.
Density measurement (along with mass measurement) is used to determine liquid volume
flow.

The density measurement parameters include:

• Density Measurement Unit
• Slug Flow Parameters
• Density Damping
• Density Cutoff

15.5.1 Configure Density Measurement Unit

ProLink II ProLink > Configuration > Density > Density Units

ProLink III Device Tools > Configuration > Process Measurement > Density

PROFIBUS EDD Configure > Manual Setup > Measurements > Density > Density Unit

PROFIBUS bus pa-

rameters

Block: Measurement, Index 9

Overview

Density Measurement Unit specifies the units of measure that will be displayed for density
measurement.

Procedure

Set Density Measurement Unit to the option you want to use.

The default setting for Density Measurement Unit is g/cm3 (grams per cubic centimeter).
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Options for Density Measurement Unit
The transmitter provides a standard set of measurement units for Density Measurement Unit.
Different communications tools may use different labels.

Options for Density Measurement UnitTable 15-9:   

Unit description Label

ProLink II ProLink III

Specific gravity unit (not temperature-corrected) SGU SGU

Grams per cubic centimeter g/cm3 g/cm3

Grams per liter g/l g/l

Grams per milliliter g/ml g/ml

Kilograms per liter kg/l kg/l

Kilograms per cubic meter kg/m3 kg/m3

Pounds per U.S. gallon lbs/Usgal lbs/Usgal

Pounds per cubic foot lbs/ft3 lbs/ft3

Pounds per cubic inch lbs/in3 lbs/in3

API gravity degAPI degAPI

Short ton per cubic yard sT/yd3 sT/yd3

15.5.2 Configure slug flow parameters

ProLink II ProLink > Configuration > Density > Slug High Limit

ProLink > Configuration > Density > Slug Low Limit

ProLink > Configuration > Density > Slug Duration

ProLink III Device Tools > Configuration > Process Measurement > Density

PROFIBUS EDD Configure > Manual Setup > Measurements > Density > Slug Low Limit

Configure > Manual Setup > Measurements > Density > Slug High Limit

Configure > Manual Setup > Measurements > Density > Slug Duration

PROFIBUS bus pa-

rameters

Slug Low Limit: Block: Diagnostic, Index 2

Slug High Limit: Block: Diagnostic, Index 3

Slug Duration: Block: Diagnostic, Index 1

Overview

The slug flow parameters control how the transmitter detects and reports two-phase flow
(gas in a liquid process or liquid in a gas process).
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Procedure

1. Set Slug Low Limit to the lowest density value that is considered normal in your
process.

Values below this will cause the transmitter to perform the configured slug flow
action. Typically, this value is the lowest density value in the normal range of your
process.

Tip
Gas entrainment can cause your process density to drop temporarily. To reduce the
occurrence of slug flow alarms that are not significant to your process, set Slug Low Limit
slightly below your expected lowest process density.

You must enter Slug Low Limit in g/cm3, even if you configured another unit for
density measurement.

The default value for Slug Low Limit is 0.0 g/cm3. The range is 0.0 to 10.0 g/cm3.

2. Set Slug High Limit to the highest density value that is considered normal in your
process.

Values above this will cause the transmitter to perform the configured slug flow
action. Typically, this value is the highest density value in the normal range of your
process.

Tip
To reduce the occurrence of slug flow alarms that are not significant to your process, set Slug
High Limit slightly above your expected highest process density.

You must enter Slug High Limit in g/cm3, even if you configured another unit for
density measurement.

The default value for Slug High Limit is 5.0 g/cm3. The range is 0.0 to 10.0 g/cm3.

3. Set Slug Duration to the number of seconds that the transmitter will wait for a slug
flow condition to clear before performing the configured slug flow action.

The default value for Slug Duration is 0.0 seconds. The range is 0.0 to 60.0 seconds.

Tip
For filling applications, Micro Motion recommends leaving Slug Duration at the default value.

Slug flow detection and reporting
Slug flow is typically used as an indicator of two-phase flow (gas in a liquid process or liquid
in a gas process). Two-phase flow can cause a variety of process control issues. By
configuring the slug flow parameters appropriately for your application, you can detect
process conditions that require correction.
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Tip
To decrease the occurrence of slug flow alarms, lower Slug Low Limit or raise Slug High Limit.

A slug flow condition occurs whenever the measured density goes below Slug Low Limit or
above Slug High Limit. If this occurs:

• A slug flow alarm is posted to the active alarm log.

• All outputs that are configured to represent flow rate hold their last “pre-slug flow”
value for the configured Slug Duration.

If the slug flow condition clears before Slug Duration expires:

• Outputs that represent flow rate revert to reporting actual flow.

• The slug flow alarm is deactivated, but remains in the active alarm log until it is
acknowledged.

If the slug flow condition does not clear before Slug Duration expires, the outputs that
represent flow rate report a flow rate of 0.

If Slug Duration is set to 0.0 seconds, the outputs that represent flow rate will report a flow
rate of 0 as soon as slug flow is detected.

15.5.3 Configure Density Damping

ProLink II ProLink > Configuration > Density > Density Damping

ProLink III Device Tools > Configuration > Process Measurement > Density

PROFIBUS EDD Configure > Manual Setup > Measurements > Density > Density Damping

PROFIBUS bus pa-

rameters

Block: Measurement, Index 14

Overview

Damping is used to smooth out small, rapid fluctuations in process measurement. Damping
Value specifies the time period (in seconds) over which the transmitter will spread changes
in the reported process variable. At the end of the interval, the reported process variable
will reflect 63% of the change in the actual measured value.

Procedure

Set Density Damping to the value you want to use.

The default value is 1.28 seconds. The range is 0 to 40.96 seconds.

Tips

• A high damping value makes the process variable appear smoother because the reported value
changes slowly.

• A low damping value makes the process variable appear more erratic because the reported value
changes more quickly.
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• Whenever the damping value is non-zero, the reported measurement will lag the actual
measurement because the reported value is being averaged over time.

• In general, lower damping values are preferable because there is less chance of data loss, and less
lag time between the actual measurement and the reported value.

The value you enter is automaticaly rounded down to the nearest valid value. The valid
values for Density Damping are: 0, 0.04, 0.08, 0.16, ... 40.96.

Effect of Density Damping on volume measurement
Density Damping affects liquid volume measurement. Liquid volume values are calculated
from the damped density value rather than the measured density value.

Interaction between Density Damping and Added Damping
In some circumstances, both Density Damping and Added Damping are applied to the reported
density value.

Density Damping controls the rate of change in the density process variable. Added Damping
controls the rate of change reported via the mA output. If mA Output Process Variable is set to
Density, and both Density Damping and Added Damping are set to non-zero values, density
damping is applied first, and the added damping calculation is applied to the result of the
first calculation.

15.5.4 Configure Density Cutoff

ProLink II ProLink > Configuration > Density > Low Density Cutoff

ProLink III Device Tools > Configuration > Process Measurement > Density

PROFIBUS EDD Configure > Manual Setup > Measurements > Density > Density Cutoff

PROFIBUS bus pa-

rameters

Block: Measurement, Index 20

Overview

Density Cutoff specifies the lowest density value that will be reported as measured. All
density values below this cutoff will be reported as 0.

Procedure

Set Density Cutoff to the value you want to use.

The default value for Density Cutoff is 0.2 g/cm3. The range is 0.0 g/cm3 to 0.5 g/cm3.

Effect of Density Cutoff on volume measurement
Density Cutoff affects liquid volume measurement. If the density value goes below Density
Cutoff, the volume flow rate is reported as 0.
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15.6 Configure temperature measurement
The temperature measurement parameters control how temperature data from the
sensor is reported. Temperature data is used to compensate for the effect of temperature
on the sensor tubes during flow measurement .

The temperature measurement parameters include:

• Temperature Measurement Unit
• Temperature Damping

15.6.1 Configure Temperature Measurement Unit

ProLink II ProLink > Configuration > Temperature > Temp Units

ProLink III Device Tools > Configuration > Process Measurement > Temperature

PROFIBUS EDD Configure > Manual Setup > Measurements > Temperature > Temperature Unit

PROFIBUS bus pa-

rameters

Block: Measurement, Index 7

Overview

Temperature Measurement Unit specifies the unit that will be used for temperature
measurement.

Procedure

Set Temperature Measurement Unit to the option you want to use.

The default setting is Degrees Celsius.

Options for Temperature Measurement Unit
The transmitter provides a standard set of units for Temperature Measurement Unit. Different
communications tools may use different labels for the units.

Options for Temperature Measurement UnitTable 15-10:   

Unit description Label

ProLink II ProLink III

Degrees Celsius degC °C

Degrees Fahrenheit degF °F

Degrees Rankine degR °R

Kelvin degK °K
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15.6.2 Configure Temperature Damping

ProLink II ProLink > Configuration > Temperature > Temp Damping

ProLink III Device Tools > Configuration > Temperature

PROFIBUS EDD Configure > Manual Setup > Measurements > Temperature > Temperature Damping

PROFIBUS bus pa-

rameters

Block: Measurement, Index 13

Overview

Damping is used to smooth out small, rapid fluctuations in process measurement. Damping
Value specifies the time period (in seconds) over which the transmitter will spread changes
in the reported process variable. At the end of the interval, the reported process variable
will reflect 63% of the change in the actual measured value.

Procedure

Enter the value you want to use for Temperature Damping.

The default value is 4.8 seconds. The range is 0.0 to 38.4 seconds.

Tips

• A high damping value makes the process variable appear smoother because the reported value
changes slowly.

• A low damping value makes the process variable appear more erratic because the reported value
changes more quickly.

• Whenever the damping value is non-zero, the reported measurement will lag the actual
measurement because the reported value is being averaged over time.

• In general, lower damping values are preferable because there is less chance of data loss, and less
lag time between the actual measurement and the reported value.

The value you enter is automaticaly rounded down to the nearest valid value. Valid values
for Temperature Damping are 0, 0.6, 1.2, 2.4, 4.8, … 38.4.

Effect of Temperature Damping on process measurement
Temperature Damping affects the response speed for temperature compensation with
fluctuating temperatures. Temperature compensation adjusts the process measurement
to compensate for the effect of temperature on the sensor tube.
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15.7 Configure pressure compensation
Pressure compensation adjusts process measurement to compensate for the pressure
effect on the sensor. The pressure effect is the change in the sensor’s sensitivity to flow
and density caused by the difference between the calibration pressure and the process
pressure.

Tip
Do not implement pressure compensation for filling applications unless Micro Motion has specifically
recommended it. Contact Micro Motion customer service if you have any questions about the effect
of pressure on fill measurement.

15.7.1 Configure pressure compensation using ProLink II

Prerequisites

You will need the flow factor, density factor, and calibration pressure values for your
sensor.

• For the flow factor and density factor, see the product data sheet for your sensor.

• For the calibration pressure, see the calibration sheet for your sensor. If the data is
unavailable, use 20 PSI.

Procedure

1. Choose View > Preferences and ensure that Enable External Pressure Compensation is
checked.

2. Choose ProLink > Configuration > Pressure.

3. Enter Flow Factor for your sensor.

The flow factor is the percent change in the flow rate per PSI. When entering the
value, reverse the sign.

Example:

If the flow factor is 0.000004 % per PSI, enter −0.000004 %  per  PSI.

4. Enter Density Factor for your sensor.

The density factor is the change in fluid density, in g/cm3/PSI. When entering the
value, reverse the sign.

Example:

If the density factor is 0.000006 g/cm3/PSI, enter −0.000006 g/cm3/PSI.

5. Enter Cal Pressure for your sensor.

The calibration pressure is the pressure at which your sensor was calibrated, and
defines the pressure at which there is no pressure effect. If the data is unavailable,
enter 20 PSI.
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6. Determine how the transmitter will obtain pressure data, and perform the required
setup.

Option Setup

A user-configured
static pressure val-
ue

a. Set Pressure Units to the desired unit.
b. Set External Pressure to the desired value.

Polling for pres-
sure(3)

a. Ensure that the primary mA output has been wired to support
HART polling.

b. Choose ProLink > Configuration > Polled Variables.
c. Choose an unused polling slot.
d. Set Polling Control to Poll As Primary or Poll as Secondary, and click

Apply.
e. Set External Tag to the HART tag of the external pressure device.
f. Set Variable Type to Pressure.

Tip
• Poll as Primary: No other HART masters will be on the network.
• Poll as Secondary: Other HART masters will be on the network.

The Field Communicator is not a HART master.

A value written by
digital communica-
tions

a. Set Pressure Units to the desired unit.
b. Perform the necessary host programming and communications

setup to write pressure data to the transmitter at appropriate in-
tervals.

Postrequisites

If you are using an external pressure value, verify the setup by choosing ProLink > Process
Variables and checking the value displayed in External Pressure.

15.7.2 Configure pressure compensation using ProLink III

Prerequisites

You will need the flow factor, density factor, and calibration pressure values for your
sensor.

• For the flow factor and density factor, see the product data sheet for your sensor.

• For the calibration pressure, see the calibration sheet for your sensor. If the data is
unavailable, use 20 PSI.

Procedure

1. Choose Device Tools > Configuration > Process Measurement > Pressure Compensation.

2. Set Pressure Compensation Status to Enabled.

(3) Not available on all transmitters.
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3. Enter Flow Calibration Pressure for your sensor.

The calibration pressure is the pressure at which your sensor was calibrated, and
defines the pressure at which there is no pressure effect. If the data is unavailable,
enter 20 PSI.

4. Enter Flow Factor for your sensor.

The flow factor is the percent change in the flow rate per PSI. When entering the
value, reverse the sign.

Example:

If the flow factor is 0.000004 % per PSI, enter −0.000004 %  per  PSI.

5. Enter Density Factor for your sensor.

The density factor is the change in fluid density, in g/cm3/PSI. When entering the
value, reverse the sign.

Example:

If the density factor is 0.000006 g/cm3/PSI, enter −0.000006 g/cm3/PSI.

6. Set Pressure Source to the method that the transmitter will use to obtain pressure
data.

Option Description

Poll for external value(4) The transmitter will poll an external pressure device, using
HART protocol over the primary mA output.

Static or Digital Communications The transmitter will use the pressure value that it reads from
memory.
• Static: The configured value is used.
• Digital Communications: A host writes transmitter data

to transmitter memory.

7. If you chose to poll for pressure data:

a. Select the Polling Slot to use.

b. Set Polling Control to Poll as Primary or Poll as Secondary, and click Apply.

Tip

• Poll as Primary: No other HART masters will be on the network.

• Poll as Secondary: Other HART masters will be on the network. The Field Communicator
is not a HART master.

c. Set External Device Tag to the HART tag of the external pressure device, and click
Apply.

(4) Not available on all transmitters.
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8. If you chose to use a static pressure value:

a. Set Pressure Unit to the desired unit.

b. Set Static or Current Pressure to the value to use, and click Apply
9. If you want to use digital communications, click Apply, then perform the necessary

host programming and communications setup to write pressure data to the
transmitter at appropriate intervals.

Postrequisites

If you are using an external pressure value, verify the setup by checking the External Pressure
value displayed in the Inputs area of the main window.

15.7.3 Options for Pressure Measurement Unit
The transmitter provides a standard set of measurement units for Pressure Measurement Unit.
Different communications tools may use different labels for the units. In most
applications, Pressure Measurement Unit should be set to match the pressure measurement
unit used by the remote device.

Options for Pressure Measurement UnitTable 15-11:   

Unit description Label

ProLink II ProLink III

Feet water @ 68 °F Ft Water @ 68°F Ft Water @ 68°F

Inches water @ 4 °C In Water @ 4°C In Water @ 4°C

Inches water @ 60 °F In Water @ 60°F In Water @ 60°F

Inches water @ 68 °F In Water @ 68°F In Water @ 68°F

Millimeters water @ 4 °C mm Water @ 4°C mm Water @ 4°C

Millimeters water @ 68 °F mm Water @ 68°F mm Water @ 68°F

Millimeters mercury @ 0 °C mm Mercury @ 0°C mm Mercury @ 0°C

Inches mercury @ 0 °C In Mercury @ 0°C In Mercury @ 0°C

Pounds per square inch PSI PSI

Bar bar bar

Millibar millibar millibar

Grams per square centimeter g/cm2 g/cm2

Kilograms per square centimeter kg/cm2 kg/cm2

Pascals pascals pascals

Kilopascals Kilopascals Kilopascals

Megapascals megapascals Megapascals

Torr @ 0 °C Torr @ 0°C Torr @ 0°C

Atmospheres atms atms
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16 Configure device options and
preferences
Topics covered in this chapter:

• Configure alarm handling

• Configure informational parameters

16.1 Configure alarm handling
The alarm handling parameters control the transmitter’s response to process and device
conditions.

Alarm handling parameters include:

• Fault Timeout
• Status Alarm Severity

16.1.1 Configure Fault Timeout

ProLink II ProLink > Configuration > Frequency > Last Measured Value Timeout

ProLink III Device Tools > Configuration > Fault Processing

PROFIBUS EDD Configure > Alert Setup > Alert Severity > Fault Timeout

PROFIBUS bus pa-

rameters

Block: Diagnostic, Index 19

Overview

Fault Timeout controls the delay before fault actions are performed.

Restriction
Fault Timeout is applied only to the following alarms (listed by Status Alarm Code): A003, A004, A005,
A008, A016, A017, A033. For all other alarms, fault actions are performed as soon as the alarm is
detected.

Procedure

Set Fault Timeout as desired.

The default value is 0 seconds. The range is 0 to 60 seconds.

If you set Fault Timeout to 0, fault actions are performed as soon as the alarm condition is
detected.
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The fault timeout period begins when the transmitter detects an alarm condition. During
the fault timeout period, the transmitter continues to report its last valid measurements.

If the fault timeout period expires while the alarm is still active, the fault actions are
performed. If the alarm condition clears before the fault timeout expires, no fault actions
are performed.

Tip
ProLink II allows you to set Fault Timeout in two locations. However, there is only one parameter, and
the same setting is applied to all outputs.

16.1.2 Configure Status Alarm Severity

ProLink II ProLink > Configuration > Alarm > Alarm

ProLink > Configuration > Alarm > Severity

ProLink III Device Tools > Configuration > Alert Severity

PROFIBUS EDD Configure > Alert Setup > Alert Severity > Change Alert Severity

PROFIBUS bus pa-

rameters

Alarm index: Block: Diagnostic, Index 20

Alarm x severity: Block: Diagnostic, Index 21

Overview

Use Status Alarm Severity to control the fault actions that the transmitter performs when it
detects an alarm condition.

Restrictions

• For some alarms, Status Alarm Severity is not configurable.

• For some alarms, Status Alarm Severity can be set only to two of the three options.

Tip
Micro Motion recommends using the default settings for Status Alarm Severity unless you have a
specific requirement to change them.

Procedure

1. Select a status alarm.

2. For the selected status alarm, set Status Alarm Severity as desired.
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Option Description

Fault Actions when fault is detected:
• The alarm is posted to the Alert List.
• The fill is ended.(1)

• Outputs go to the configured fault action (after Fault Timeout has expired, if ap-
plicable).

• Digital communications go to the configured fault action (after Fault Timeout
has expired, if applicable).

• The status LED (if available) changes to red or yellow (depending on alarm se-
verity).

Actions when alarm clears:
• Outputs return to normal behavior.
• Digital communications return to normal behavior.
• The status LED (if available) returns to green and may or may not flash.
• Fill is not resumed.(1)

Informa-
tional

Actions when fault is detected:
• The alarm is posted to the Alert List.
• The status LED (if available) changes to red or yellow (depending on alarm se-

verity).
• For Alarm A105 only (Slug Flow), the fill is ended when Slug Duration expires.(1)

Actions when alarm clears:
• The status LED (if available) returns to green and may or may not flash.
• For Alarm A105 only (Slug Flow), the fill is not resumed.(1)

Ignore • For Alarm A105 only (Slug Flow), the fill is ended whenSlug Duration, and is not
resumed when the alarm clears.(1)

• For all other other alarms: No action.

Status alarms and options for Status Alarm Severity

Status alarms and Status Alarm SeverityTable 16-1:   

Alarm code Status message Default severity Notes Configurable?

A001 EEPROM Error (Core Pro-
cessor)

Fault No

A002 RAM Error (Core Processor) Fault No

A003 No Sensor Response Fault Yes

A004 Temperature Overrange Fault No

A005 Mass Flow Rate Overrange Fault Yes

A006 Characterization Required Fault Yes

A008 Density Overrange Fault Yes

A009 Transmitter Initializing/
Warming Up

Fault Yes

(1) Integrated-valve-control fills only. For external-valve-control fills, processing is controlled by the host program.
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Status alarms and Status Alarm Severity (continued)Table 16-1:   

Alarm code Status message Default severity Notes Configurable?

A010 Calibration Failure Fault No

A011 Zero Calibration Failed:
Low

Fault Yes

A012 Zero Calibration Failed:
High

Fault Yes

A013 Zero Calibration Failed: Un-
stable

Fault Yes

A014 Transmitter Failure Fault No

A016 Sensor RTD Failure Fault Yes

A017 T-Series RTD Failure Fault Yes

A020 No Flow Cal Value Fault Yes

A021 Incorrect Sensor Type (K1) Fault No

A029 PIC/Daughterboard Com-
munications Failure

Fault No

A030 Incorrect Board Type Fault No

A031 Low Power Fault No

A033 Insufficient Right/Left Pick-
off Signal

Fault Yes

A102 Drive Overrange Informational Yes

A104 Calibration in Progress Informational Can be set to either Informational or
Ignore, but cannot be set to Fault.

Yes

A105 Slug Flow Informational Yes

A107 Power Reset Occurred Informational Normal transmitter behavior; oc-
curs after every power cycle.

Yes

A110 Frequency Output Satura-
ted

Informational Can be set to either Informational or
Ignore, but cannot be set to Fault.

Yes

A111 Frequency Output Fixed Informational Can be set to either Informational or
Ignore, but cannot be set to Fault.

Yes

A113 mA Output 2 Saturated Informational Can be set to either Informational or
Ignore, but cannot be set to Fault.

Yes

A114 mA Output 2 Fixed Informational Can be set to either Informational or
Ignore, but cannot be set to Fault.

Yes

A118 Discrete Output 1 Fixed Informational Can be set to either Informational or
Ignore, but cannot be set to Fault.

Yes
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16.2 Configure informational parameters
The informational parameters can be used to identify or describe your flowmeter but they
are not used in transmitter processing and are not required.

The informational parameters include:

• Device parameters

- Descriptor
- Message
- Date

• Sensor parameters

- Sensor Serial Number
- Sensor Material
- Sensor Liner Material
- Sensor Flange Type

16.2.1 Configure Descriptor

ProLink II ProLink > Configuration > Device > Descriptor

ProLink III Device Tools > Configuration > Informational Parameters > Transmitter

PROFIBUS EDD Not available

PROFIBUS bus pa-

rameters

Not available

Overview

Descriptor lets you store a description in transmitter memory. The description is not used in
processing and is not required.

Procedure

Enter a description for the transmitter.

You can use up to 16 characters for the description.

16.2.2 Configure Message

ProLink II ProLink > Configuration > Device > Message

ProLink III Device Tools > Configuration > Informational Parameters > Transmitter

PROFIBUS EDD Not available

PROFIBUS bus pa-

rameters

Not available
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Overview

Message lets you store a short message in transmitter memory. This parameter is not used
in processing and is not required.

Procedure

Enter a short message for the transmitter.

Your message can be up to 32 characters long.

16.2.3 Configure Date

ProLink II ProLink > Configuration > Device > Date

ProLink III Device Tools > Configuration > Informational Parameters > Transmitter

PROFIBUS EDD Not available

PROFIBUS bus pa-

rameters

Not available

Overview

Date lets you store a static date (not updated by the transmitter) in transmitter memory.
This parameter is not used in processing and is not required.

Procedure

Enter the date you want to use, in the form mm/dd/yyyy.

Tip
ProLink II and ProLink III provide a calendar tool to help you select the date.

16.2.4 Configure Sensor Serial Number

ProLink II ProLink > Configuration > Sensor > Sensor s/n

ProLink III Device Tools > Configuration > Informational Parameters > Sensor

PROFIBUS EDD Configure > Manual Setup > Informational Parameters > Sensor Serial Number

PROFIBUS bus pa-

rameters

Block: Device Information, Index 6

Overview

Sensor Serial Number lets you store the serial number of the sensor component of your
flowmeter in transmitter memory. This parameter is not used in processing and is not
required.
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Procedure

1. Obtain the sensor serial number from your sensor tag.

2. Enter the serial number in the Sensor Serial Number field.

16.2.5 Configure Sensor Material

ProLink II ProLink > Configuration > Sensor > Sensor Matl

ProLink III Device Tools > Configuration > Informational Parameters > Sensor

PROFIBUS EDD Configure > Manual Setup > Informational Parameters > Tube Wetted Material

PROFIBUS bus pa-

rameters

Block: Device Information, Index 9

Overview

Sensor Material lets you store the type of material used for your sensor’s wetted parts in
transmitter memory. This parameter is not used in processing and is not required.

Procedure

1. Obtain the material used for your sensor’s wetted parts from the documents
shipped with your sensor, or from a code in the sensor model number.

To interpret the model number, refer to the product data sheet for your sensor.

2. Set Sensor Material to the appropriate option.

16.2.6 Configure Sensor Liner Material

ProLink II ProLink > Configuration > Sensor > Liner Matl

ProLink III Device Tools > Configuration > Informational Parameters > Sensor

PROFIBUS EDD Configure > Manual Setup > Informational Parameters > Tube Lining

PROFIBUS bus pa-

rameters

Block: Device Information, Index 10

Overview

Sensor Liner Material lets you store the type of material used for your sensor liner in
transmitter memory. This parameter is not used in processing and is not required.

Procedure

1. Obtain your sensor’s liner material from the documents shipped with your sensor, or
from a code in the sensor model number.

To interpret the model number, refer to the product data sheet for your sensor.
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2. Set Sensor Liner Material to the appropriate option.

16.2.7 Configure Sensor Flange Type

ProLink II ProLink > Configuration > Sensor > Flange

ProLink III Device Tools > Configuration > Informational Parameters > Sensor

PROFIBUS EDD Configure > Manual Setup > Informational Parameters > Sensor Flange

PROFIBUS bus pa-

rameters

Block: Device Information, Index 11

Overview

Sensor Flange Type lets you store your sensor’s flange type in transmitter memory. This
parameter is not used in processing and is not required.

Procedure

1. Obtain your sensor’s flange type from the documents shipped with your sensor, or
from a code in the sensor model number.

To interpret the model number, refer to the product data sheet for your sensor.

2. Set Sensor Flange Type to the appropriate option.
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17 Integrate the meter with the network
Topics covered in this chapter:

• Configure the transmitter channels

• Configure the mA output

• Configure the frequency output

• Configure the discrete output

• Configure the discrete input

• Configure an enhanced event

• Configure digital communications

17.1 Configure the transmitter channels

ProLink II ProLink > Configuration > Channel > Channel B > Type Assignment

ProLink III Device Tools > Configuration > I/O > Channels

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Channels

PROFIBUS bus pa-

rameters

Block: Filling, Index 83

Overview

You can configure Channel B on your transmitter to operate as a discrete output or a
discrete input. The channel configuration must match the wiring at the transmitter
terminals.

Prerequisites

To avoid causing process errors:

• Configure the channels before configuring the outputs.

• Before changing the channel configuration, ensure that all control loops affected by
the channel are under manual control.

CAUTION!

Before configuring a channel to operate as a discrete input, check the status of the remote
input device and the actions assigned to the discrete input. If the discrete input is ON, all
actions assigned to the discrete input will be performed when the new channel configuration is
implemented. If this is not acceptable, change the state of the remote device or wait to
configure the channel as a discrete input until an appropriate time.
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Procedure

Set Channel B as desired.

Option Description

Discrete output Channel B will operate as a discrete output.

Discrete input Channel B will operate as a discrete input.

Postrequisites

For each channel that you configured, perform or verify the corresponding input or output
configuration. When the configuration of a channel is changed, the channel’s behavior will
be controlled by the configuration that is stored for the selected input or output type, and
the stored configuration may not be appropriate for your process.

After verifying channel and output configuration, return the control loop to automatic
control.

17.2 Configure the mA output
The mA output is used to report the configured process variable. The mA output
parameters control how the process variable is reported. Your transmitter has one mA
output.

The mA output parameters include:

• mA Output Process Variable
• Lower Range Value (LRV) and Upper Range Value (URV)

• AO Cutoff
• Added Damping
• AO Fault Action and AO Fault Value

Important
Whenever you change an mA output parameter, verify all other mA output parameters before
returning the flowmeter to service. In some situations, the transmitter automatically loads a set of
stored values, and these values may not be appropriate for your application.

17.2.1 Configure mA Output Process Variable

ProLink II ProLink > Configuration > Analog Output > Secondary Variable

ProLink III Device Tools > Configuration > I/O > Outputs > mA Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > mA Output > Select Primary Variable

PROFIBUS bus pa-

rameters

Block: Filling, Index 42
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Overview

Use mA Output Process Variable to select the variable that is reported over the mA output.

Procedure

Set mA Output Process Variable as desired.

The default setting is Mass Flow Rate.

Options for mA Output Process Variable
The transmitter provides a basic set of options for mA Output Process Variable, plus several
application-specific options. Different communications tools may use different labels for
the options.

Options for mA Output Process VariableTable 17-1:   

Process variable Label

ProLink II ProLink III

Mass flow rate Mass Flow Rate Mass Flow Rate

Volume flow rate Volume Flow Rate Volume Flow Rate

Temperature Temperature Temperature

Density Density Density

Percentage of fill delivered Discrete Batch: Percent Fill Discrete Batch: Percent Fill

17.2.2 Configure Lower Range Value (LRV) and Upper Range
Value (URV)

ProLink II ProLink > Configuration > Analog Output > Lower Range Value

ProLink > Configuration > Analog Output > Upper Range Value

ProLink III Device Tools > Configuration > I/O > Outputs > mA Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > mA Output

PROFIBUS bus pa-

rameters

Lower Range Value: Block: Filling, Index 43

Upper Range Value: Block: Filling, Index 44

Overview

The Lower Range Value (LRV) and Upper Range Value (URV) are used to scale the mA output,
that is, to define the relationship between mA Output Process Variable and the mA output
level.
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Note
If you change LRV and URV from the factory default values, and you later change mA Output Process
Variable, LRV and URV will not be reset to the default values. For example, if you set mA Output Process
Variable to Mass Flow Rate and change the LRV and URV, then you set mA Output Process Variable to
Density, and finally you change mA Output Process Variable back to Mass Flow Rate, LRV and URV for Mass
Flow Rate are reset to the values that you configured.

Procedure

Set LRV and URV as desired.

• LRV is the value of mA Output Process Variable represented by an output of 4 mA. The
default value for LRV depends on the setting of mA Output Process Variable. If mA Output
Process Variable is set to Discrete Batch: Percent Fill, enter LRV in %.

• URV is the value of mA Output Process Variable represented by an output of 20 mA. The
default value for URV depends on the setting of mA Output Process Variable. If mA Output
Process Variable is set to Discrete Batch: Percent Fill, enter URV in %.

Tips
For best performance:

• Set LRV ≥ LSL (lower sensor limit).

• Set URV ≤ USL (upper sensor limit).

• Set these values so that the difference between URV and LRV is ≥ Min Span (minimum span).

Defining URV and LRV within the recommended values for Min Span, LSL, and USL ensures that the
resolution of the mA output signal is within range of the bit precision of the D/A converter.

Note

You can set URV below LRV. For example, you can set URV to 50 and LRV to 100.

The mA output uses a range of 4–20 mA to represent mA Output Process Variable. Between
LRV and URV, the mA output is linear with the process variable. If the process variable
drops below LRV or rises above URV, the transmitter posts an output saturation alarm.

Default values for Lower Range Value (LRV) and Upper Range
Value (URV)
Each option for mA Output Process Variable has its own LRV and URV. If you change the
configuration of mA Output Process Variable, the corresponding LRV and URV are loaded and
used.

Default values for Lower Range Value (LRV) and Upper Range Value
(URV)

Table 17-2:   

Process variable LRV URV

All mass flow variables –200.000 g/sec 200.000 g/sec
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Default values for Lower Range Value (LRV) and Upper Range Value
(URV) (continued)

Table 17-2:   

Process variable LRV URV

All liquid volume flow variables –0.200 l/sec 0.200 l/sec

All density variables 0.000 g/cm3 10.000 g/cm3

All temperature variables –240.000 °C 450.000 °C

Percent fill 0% 100%

17.2.3 Configure AO Cutoff

ProLink II ProLink > Configuration > Analog Output > AO Cutoff

ProLink III Device Tools > Configuration > I/O > Outputs > mA Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > mA Output

PROFIBUS bus pa-

rameters

Block: Filling, Index 45

Overview

AO Cutoff (Analog Output Cutoff) specifies the lowest mass flow rate or volume flow rate
that will be reported through the mA output. Any flow rates below AO Cutoff will be
reported as 0.

Restriction
AO Cutoff is applied only if mA Output Process Variable is set to Mass Flow Rate or Volume Flow Rate. If mA
Output Process Variable is set to a different process variable, AO Cutoff is not configurable, and the
transmitter does not implement the AO cutoff function.

Procedure

Set AO Cutoff as desired.

The default value for AO Cutoff is 0.0 g/sec.

Tip
For most applications, the default value of AO Cutoff should be used. Contact Micro Motion customer
service before changing AO Cutoff.

Interaction between AO Cutoff and process variable cutoffs
When mA Output Process Variable is set to a flow variable (for example, mass flow rate or
volume flow rate), AO Cutoff interacts with Mass Flow Cutoff or Volume Flow Cutoff. The
transmitter puts the cutoff into effect at the highest flow rate at which a cutoff is
applicable.
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Example: Cutoff interaction

Configuration:

• mA Output Process Variable = Mass Flow Rate
• AO Cutoff = 10 g/sec

• Mass Flow Cutoff = 15 g/sec

Result: If the mass flow rate drops below 15 g/sec, the mA output will report zero flow.

17.2.4 Configure Added Damping

ProLink II ProLink > Configuration > Analog Output > AO Added Damp

ProLink III Device Tools > Configuration > I/O > Outputs > mA Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > mA Output

PROFIBUS bus pa-

rameters

Block: Filling, Index 46

Overview

Damping is used to smooth out small, rapid fluctuations in process measurement. Damping
Value specifies the time period (in seconds) over which the transmitter will spread changes
in the reported process variable. At the end of the interval, the reported process variable
will reflect 63% of the change in the actual measured value. Added Damping controls the
amount of damping that will be applied to the mA output. It affects the reporting of mA
Output Process Variable through the mA output only. It does not affect the reporting of that
process variable via any other method (e.g., the frequency output or digital
communications), or the value of the process variable used in calculations.

Note
Added Damping is not applied if the mA output is fixed (for example, during loop testing) or if the mA
output is reporting a fault. Added Damping is applied while sensor simulation is active.

Procedure

Set Added Damping to the desired value.

The default value is 0.0 seconds.

When you specify a value for Added Damping, the transmitter automatically rounds the value
down to the nearest valid value.

Valid values for Added DampingTable 17-3:   

Valid values for Added Damping

0.0, 0.1, 0.3, 0.75, 1.6, 3.3, 6.5, 13.5, 27.5, 55, 110, 220, 440
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Interaction between Added Damping and process variable
damping
When mA Output Process Variable is set to a flow variable, density, or temperature, Added
Damping interacts with Flow Damping, Density Damping, or Temperature Damping. If multiple
damping parameters are applicable, the effect of damping the process variable is
calculated first, and the added damping calculation is applied to the result of that
calculation.

Example: Damping interaction

Configuration:

• Flow Damping = 1 second

• mA Output Process Variable = Mass Flow Rate
• Added Damping = 2 seconds

Result: A change in the mass flow rate will be reflected in the mA output over a time period
that is greater than 3 seconds. The exact time period is calculated by the transmitter
according to internal algorithms which are not configurable.

17.2.5 Configure mA Output Fault Action and mA Output Fault
Level

ProLink II ProLink > Configuration > Analog Output > AO Fault Action

ProLink > Configuration > Analog Output > AO Fault Level

ProLink III Device Tools > Configuration > Fault Processing

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > mA Output

PROFIBUS bus pa-

rameters

mA Output Fault Action: Block: Filling, Index 47

mA Output Fault Level: Block: Filling, Index 48

Overview

mA Output Fault Action controls the behavior of the mA output if the transmitter encounters
an internal fault condition.

Note
For some faults only: If Last Measured Value Timeout is set to a non-zero value, the transmitter will not
implement the fault action until the timeout has elapsed.

Procedure

1. Set mA Output Fault Action to the desired value.

The default setting is Downscale.
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2. If you set mA Output Fault Action to Upscale or Downscale, set mA Output Fault Level as
desired.

Options for mA Output Fault Action and mA Output Fault
Level

Options for mA Output Fault Action and mA Output Fault LevelTable 17-4:   

Option mA output behavior mA Output Fault Level

Upscale Goes to the configured fault level Default: 22.0 mA

Range: 21 to 24 mA

Downscale (default) Goes to the configured fault level Default: 2.0 mA

Range: 1.0 to 3.6 mA

Internal Zero Goes to the mA output level associated
with a process variable value of 0 (zero),
as determined by Lower Range Value and
Upper Range Value settings

Not applicable

None Tracks data for the assigned process vari-
able; no fault action

Not applicable

CAUTION!

If you set mA Output Fault Action or Frequency Output Fault Action to None, be sure to set Digital
Communications Fault Action to None. If you do not, the output will not report actual process data,
and this may result in measurement errors or unintended consequences for your process.

Restriction
If you set Digital Communications Fault Action to NAN, you cannot set mA Output Fault Action or Frequency
Output Fault Action to None. If you try to do this, the transmitter will not accept the configuration.

17.3 Configure the frequency output
The frequency output is used to report a process variable. The frequency output
parameters control how the process variable is reported. If you purchased a transmitter for
external-valve-control fills, your transmitter has one frequency output. If you purchased a
transmitter for integrated-valve-control fills, your transmitter does not have a frequency
output.

The frequency output parameters include:

• Frequency Output Polarity
• Frequency Output Scaling Method
• Frequency Output Maximum Pulse Width
• Frequency Output Fault Action and Frequency Output Fault Value
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Note
Frequency Output Process Variable was configured during the external-valve-control fill configuration. If
you change it, you are changing the process variable that the host uses to measure and control the
fill.

Important
Whenever you change a frequency output parameter, verify all other frequency output parameters
before returning the flowmeter to service. In some situations, the transmitter automatically loads a
set of stored values, and these values may not be appropriate for your application.

17.3.1 Configure Frequency Output Polarity

ProLink II ProLink > Configuration > Frequency > Freq Output Polarity

ProLink III Device Tools > Configuration > I/O > Outputs > Frequency Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Frequency Output > Frequency Output Polarity

PROFIBUS bus pa-

rameters

Block: Filling, Index 66

Overview

Frequency Output Polarity controls how the output indicates the ON (active) state. The default
value, Active High, is appropriate for most applications. Active Low may be required by
applications that use low-frequency signals.

Procedure

Set Frequency Output Polarity as desired.

The default setting is Active High.

Options for Frequency Output Polarity

Options for Frequency Output PolarityTable 17-5:   

Polarity Reference voltage (OFF) Pulse voltage (ON)

Active High 0 As determined by power sup-
ply, pull-up resistor, and load
(see the installation manual for
your transmitter)

Active Low As determined by power sup-
ply, pull-up resistor, and load
(see the installation manual for
your transmitter)

0
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17.3.2 Configure Frequency Output Scaling Method

ProLink II ProLink > Configuration > Frequency > Scaling Method

ProLink III Device Tools > Configuration > I/O > Outputs > Frequency Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Frequency Output

PROFIBUS bus pa-

rameters

Block: Filling, Index 58

Overview

Frequency Output Scaling Method defines the relationship between output pulse and flow
units. Set Frequency Output Scaling Method as required by your frequency receiving device.

Procedure

1. Set Frequency Output Scaling Method.

Option Description

Frequency=Flow (default) Frequency calculated from flow rate

Pulses/Unit A user-specified number of pulses represents one flow unit

Units/Pulse A pulse represents a user-specified number of flow units

2. Set additional required parameters.

• If you set Frequency Output Scaling Method to Frequency=Flow, set Rate Factor and
Frequency Factor.

• If you set Frequency Output Scaling Method to Pulses/Unit, define the number of pulses
that will represent one flow unit.

• If you set Frequency Output Scaling Method to Units/Pulse, define the number of units
that each pulse will indicate.

Calculate frequency from flow rate
The Frequency=Flow option is used to customize the frequency output for your application
when you do not know appropriate values for Units/Pulse or Pulses/Unit.

If you specify Frequency=Flow, you must provide values for Rate Factor and Frequency Factor:

Rate Factor The maximum flow rate that you want the frequency output to report.
Above this rate, the transmitter will report A110: Frequency Output Saturated.

Frequency
Factor

A value calculated as follows:

FrequencyFactor = x NRateFactor
T

where:
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T Factor to convert selected time base to seconds

N Number of pulses per flow unit, as configured in the receiving device

The resulting Frequency Factor must be within the range of the frequency output (0 to
10,000 Hz):

• If Frequency Factor is less than1 Hz,reconfigure the receiving device for a higher
pulses/unit setting.

• If Frequency Factor is greater than 10,000 Hz, reconfigure the receiving device for a
lower pulses/unit setting.

Tip
If Frequency Output Scale Method is set to Frequency=Flow, and Frequency Output Maximum Pulse Width is set
to a non-zero value, Micro Motion recommends setting Frequency Factor to a value below 200 Hz.

Example: Configure Frequency=Flow

You want the frequency output to report all flow rates up to 2000 kg/min.

The frequency receiving device is configured for 10 pulses/kg.

Solution:

FrequencyFactor = x 102000
60

333.33FrequencyFactor =

FrequencyFactor = x NRateFactor
T

Set parameters as follows:

• Rate Factor: 2000
• Frequency Factor: 333.33

17.3.3 Configure Frequency Output Maximum Pulse Width

ProLink II ProLink > Configuration > Frequency > Freq Pulse Width

ProLink III Device Tools > Configuration > I/O > Outputs > Frequency Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Frequency Output > Maximum Pulse Width

PROFIBUS bus pa-

rameters

Block: Filling, Index 61
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Overview

Frequency Output Maximum Pulse Width is used to ensure that the duration of the ON signal is
great enough for your frequency receiving device to detect.

The ON signal may be the high voltage or 0.0 V, depending on Frequency Output Polarity.

Interaction of Frequency Output Maximum Pulse Width and Frequency
Output Polarity

Table 17-6:   

Polarity Pulse width

Active High

Active Low

Procedure

Set Frequency Output Maximum Pulse Width as desired.

The default value is 277 milliseconds. You can set Frequency Output Maximum Pulse Width to
0 milliseconds or to a value between 0.5 milliseconds and 277.5 milliseconds. The
transmitter automatically adjusts the value to the nearest valid value.

Tip
Micro Motion recommends leaving Frequency Output Maximum Pulse Width at the default value. Contact
Micro Motion customer service before changing Frequency Output Maximum Pulse Width.

17.3.4 Configure Frequency Output Fault Action and Frequency
Output Fault Level

ProLink II ProLink > Configuration > Frequency > Freq Fault Action

ProLink III Device Tools > Configuration > Fault Processing

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Frequency Output

PROFIBUS bus pa-

rameters

Block: Filling, Index 64

Overview

Frequency Output Fault Action controls the behavior of the frequency output if the transmitter
encounters an internal fault condition.
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Note
For some faults only: If Last Measured Value Timeout is set to a non-zero value, the transmitter will not
implement the fault action until the timeout has elapsed.

Procedure

1. Set Frequency Output Fault Action as desired.

The default value is Downscale (0 Hz).

2. If you set Frequency Output Fault Action to Upscale, set Frequency Fault Level to the desired
value.

The default value is 15000 Hz. The range is 10 to 15000 Hz.

Options for Frequency Output Fault Action

Options for Frequency Output Fault ActionTable 17-7:   

Label Frequency output behavior

Upscale Goes to configured Upscale value:
• Range: 10 Hz to 15000 Hz
• Default: 15000 Hz

Downscale 0 Hz

Internal Zero 0 Hz

None (default) Tracks data for the assigned process variable; no fault action

CAUTION!

If you set mA Output Fault Action or Frequency Output Fault Action to None, be sure to set Digital
Communications Fault Action to None. If you do not, the output will not report actual process data,
and this may result in measurement errors or unintended consequences for your process.

Restriction
If you set Digital Communications Fault Action to NAN, you cannot set mA Output Fault Action or Frequency
Output Fault Action to None. If you try to do this, the transmitter will not accept the configuration.

17.4 Configure the discrete output
The discrete output is used to report specific flowmeter or process conditions. The discrete
output parameters control which condition is reported and how it is reported.
Depending on your purchase option and the configuration of Channel B, your transmitter
may have zero or one discrete output.

The discrete output parameters include:

• Discrete Output Source
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• Discrete Output Polarity
• Discrete Output Fault Action

Note
The precision discrete outputs were configured during fill configuration.

Important
Whenever you change a discrete output parameter, verify all other discrete output parameters
before returning the flowmeter to service. In some situations, the transmitter automatically loads a
set of stored values, and these values may not be appropriate for your application.

17.4.1 Configure Discrete Output Source

ProLink II ProLink > Configuration > Discrete Output > DO1 Assignment

ProLink III Device Tools > Configuration > I/O > Outputs > Discrete Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Discrete Output > Assignment

PROFIBUS bus pa-

rameters

Block: Filling, Index 70

Overview

Discrete Output Source controls which flowmeter condition or process condition is reported
via the discrete output.

Procedure

Set Discrete Output Source to the desired option.

Options for Discrete Output Source

Options for Discrete Output SourceTable 17-8:   

Option Label in ProLink II Condition Discrete output voltage

Fill in progress Batching/Filling in Progress Fill in progress (includes
paused fills)

0  V

Fill ended Site-specific

Purge valve Discrete Batch: Purge Valve Purge valve open Site-specific

Purge valve closed 0  V

Fault Fault Condition Indication One or more active faults Site-specific

No active faults 0  V
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Important
This table assumes that Discrete Output Polarity is set to Active High. If Discrete Output Polarity is set to Active
Low, reverse the voltage values.

17.4.2 Configure Discrete Output Polarity

ProLink II ProLink > Configuration > Discrete Output > DO1 Polarity

ProLink III Device Tools > Configuration > I/O > Outputs > Discrete Output

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Discrete Output > Polarity

PROFIBUS bus pa-

rameters

Block: Filling, Index 71

Overview

Discrete outputs have two states: ON (active) and OFF (inactive). Two different voltage
levels are used to represent these states. Discrete Output Polarity controls which voltage level
represents which state.

Procedure

Set Discrete Output Polarity as desired.

The default setting is Active High.

Options for Discrete Output Polarity

Options for Discrete Output PolarityTable 17-9:   

Polarity Description

Active High • When asserted (condition tied to DO is
true), the circuit provides a pull-up to
24 V.

• When not asserted (condition tied to DO
is false), the circuit provides 0 V.

Active Low • When asserted (condition tied to DO is
true), the circuit provides 0 V.

• When not asserted (condition tied to DO
is false), the circuit provides a pull-up to
24 V.
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17.4.3 Configure Discrete Output Fault Action

ProLink II ProLink > Configuration > Discrete Output > DO1 Fault Action

ProLink III Device Tools > Configuration > Fault Processing

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Discrete Output > Fault Action

PROFIBUS bus pa-

rameters

Block: Filling, Index 72

Overview

Discrete Output Fault Action controls the behavior of the discrete output if the transmitter
encounters an internal fault condition.

Note
For some faults only: If Last Measured Value Timeout is set to a non-zero value, the transmitter will not
implement the fault action until the timeout has elapsed.

CAUTION!

Do not use Discrete Output Fault Action as a fault indicator. If you do, you may not be able to
distinguish a fault condition from a normal operating condition. If you want to use the discrete
output as a fault indicator, see Fault indication with the discrete output.

Procedure

Set Discrete Output Fault Action as desired.

The default setting is None.

Options for Discrete Output Fault Action

Options for Discrete Output Fault ActionTable 17-10:   

Label Discrete output behavior

Polarity=Active High Polarity=Active Low

Upscale • Fault: discrete output is ON
(site-specific voltage)

• No fault: discrete output is con-
trolled by its assignment

• Fault: discrete output is OFF
(0 V)

• No fault: discrete output is con-
trolled by its assignment

Downscale • Fault: discrete output is OFF
(0 V)

• No fault: discrete output is con-
trolled by its assignment

• Fault: discrete output is ON
(site-specific voltage)

• No fault: discrete output is con-
trolled by its assignment

None (default) Discrete output is controlled by its assignment
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Fault indication with the discrete output

To indicate faults via the discrete output, set parameters as follows:

• Discrete Output Source = Fault
• Discrete Output Fault Action = None

Note
If Discrete Output Source is set to Fault and a fault occurs, the discrete output is always ON. The setting
of Discrete Output Fault Action is ignored.

17.5 Configure the discrete input
The discrete input is used to initiate one or more transmitter actions from a remote input
device. Your transmitter may have zero or one discrete input, depending on your purchase
option and the configuration of Channel B.

The discrete input parameters include:

• Discrete Input Action
• Discrete Input Polarity

Important
Whenever you change a discrete input parameter, verify all other discrete input parameters before
returning the flowmeter to service. In some situations, the transmitter automatically loads a set of
stored values, and these values may not be appropriate for your application.
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17.5.1 Configure Discrete Input Action

ProLink II ProLink > Configuration > Discrete Input > Assignment > Reset Mass Total

ProLink > Configuration > Discrete Input > Assignment > Reset Volume Total

ProLink > Configuration > Discrete Input > Assignment > Reset All Totals

ProLink > Configuration > Discrete Input > Assignment > Begin Fill

ProLink > Configuration > Discrete Input > Assignment > End Fill

ProLink > Configuration > Discrete Input > Assignment > Pause Fill

ProLink > Configuration > Discrete Input > Assignment > Resume Fill

ProLink III Device Tools > Configuration > I/O > Action Assignment

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Discrete Input > Reset Mass Total

Configure > Manual Setup > Inputs/Outputs > Discrete Input > Reset Volume Total

Configure > Manual Setup > Inputs/Outputs > Discrete Input > Reset All Totals

Configure > Manual Setup > Inputs/Outputs > Discrete Input > Begin Fill

Configure > Manual Setup > Inputs/Outputs > Discrete Input > End Fill

Configure > Manual Setup > Inputs/Outputs > Discrete Input > Pause Fill

Configure > Manual Setup > Inputs/Outputs > Discrete Input > Resume Fill

PROFIBUS bus pa-

rameters

Reset mass total: Block: Filling, Index 79

Reset volume total: Block: Filling, Index 80

Reset all totals: Block: Filling, Index 81

Begin filling: Block: Filling, Index 75

End filling: Block: Filling, Index 76

Pause filling: Block: Filling, Index 77

Resume filling: Block: Filling, Index 78

Overview

Discrete Input Action controls the action or actions that the transmitter will perform when the
discrete input transitions from OFF to ON.

CAUTION!

Before assigning actions to an enhanced event or discrete input, check the status of the event
or the remote input device. If it is ON, all assigned actions will be performed when the new
configuration is implemented. If this is not acceptable, wait until an appropriate time to assign
actions to the event or discrete input.

Procedure

1. Select an action.

2. Select the discrete input that will perform the selected action.

3. Repeat until you have assigned all the actions to be performed by the discrete input.
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Options for Discrete Input Action

Options for Discrete Input Action or Enhanced Event ActionTable 17-11:   

Action Label

ProLink II ProLink III

None (default) None None

Reset mass total Reset Mass Total Reset Mass Total

Reset volume total Reset Volume Total Reset Volume Total

Reset all totals Reset All Totals Reset All Totals

Begin fill Begin Fill Begin Fill

End fill End Fill End Fill

Resume fill Resume Fill Resume Fill

Pause fill Pause Fill Pause Fill

CAUTION!

Before assigning actions to an enhanced event or discrete input, check the status of the event
or the remote input device. If it is ON, all assigned actions will be performed when the new
configuration is implemented. If this is not acceptable, wait until an appropriate time to assign
actions to the event or discrete input.

17.5.2 Configure Discrete Input Polarity

ProLink II ProLink > Configuration > Discrete Input > Polarity

ProLink III Device Tools > Configuration > I/O > Inputs > Discrete Input

PROFIBUS EDD Configure > Manual Setup > Inputs/Outputs > Discrete Input > DI1 Polarity

PROFIBUS bus pa-

rameters

Block: Filling, Index 82

Overview

The discrete input has two states: ON and OFF. Discrete Input Polarity controls how the
transmitter maps the incoming voltage level to the ON and OFF states.

Procedure

Set Discrete Input Polarity as desired.

The default setting is Active Low.
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Options for Discrete Input Polarity

Options for Discrete Input PolarityTable 17-12:   

Polarity Voltage Status of discrete in-
put at transmitter

Active High Voltage applied across terminals is 3–30 VDC ON

Voltage applied across terminals is <0.8 VDC OFF

Active Low Voltage applied across terminals is <0.8 VDC ON

Voltage applied across terminals is 3–30 VDC OFF

17.6 Configure an enhanced event

ProLink II ProLink > Configuration > Discrete Events > Event Name

ProLink > Configuration > Discrete Events > Event Type

ProLink > Configuration > Discrete Events > Process Variable

ProLink > Configuration > Discrete Events > Low Setpoint

ProLink > Configuration > Discrete Events > High Setpoint

ProLink III Device Tools > Configuration > Events > Enhanced Events

PROFIBUS EDD Configure > Alert Setup > Discrete Events > Setup Event Trigger > Discrete Event x > Variable

Configure > Alert Setup > Discrete Events > Setup Event Trigger > Discrete Event x > Event Type

Configure > Alert Setup > Discrete Events > Setup Event Trigger > Discrete Event x > Setpoint A

Configure > Alert Setup > Discrete Events > Setup Event Trigger > Discrete Event x > Setpoint B

PROFIBUS bus pa-

rameters

Event index (x = 0, 1, 2, 3, 4): Block: Diagnostics, Index 4

Event x type: Block: Diagnostics, Index 5

Process variable: Block: Diagnostics, Index 8

Setpoint A: Block: Diagnostics, Index 6

Setpoint B: Block: Diagnostics, Index 7

Overview

An enhanced event is used to provide notification of process changes and, optionally, to
perform specific transmitter actions if the event occurs. An enhanced event occurs (is ON)
if the real-time value of a user-specified process variable moves above (HI) or below (LO) a
user-defined setpoint, or in range (IN) or out of range (OUT) with respect to two user-
defined setpoints. You can define up to five enhanced events. For each enhanced event,
you can assign one or more actions that the transmitter will perform if the enhanced event
occurs.

Procedure

1. Select the event that you want to configure.

Integrate the meter with the network

232  Micro Motion® Filling Mass Transmitters with PROFIBUS-DP



2. Specify Event Type.

Options Description

HI x > A

The event occurs when the value of the assigned process variable (x) is
greater than the setpoint (Setpoint A), endpoint not included.

LO x < A

The event occurs when the value of the assigned process variable (x) is
less than the setpoint (Setpoint A), endpoint not included.

IN A ≤ x ≤ B

The event occurs when the value of the assigned process variable (x) is
“in range,” that is, between Setpoint A and Setpoint B, endpoints included.

OUT x ≤ A or x ≥ B

The event occurs when the value of the assigned process variable (x) is
“out of range,” that is, less than Setpoint A or greater than Setpoint B, end-
points included.

3. Assign a process variable to the event.

4. Set values for the required setpoints.

• For HI and LO events, set Setpoint A.

• For IN and OUT events, set Setpoint A and Setpoint B.

5. (Optional) Configure a discrete output to switch states in response to the event
status.

6. (Optional) Specify the action or actions that the transmitter will perform when the
event occurs.

• With ProLink II: ProLink > Configuration > Discrete Input
• With ProLink III: Device Tools > Configuration > I/O > Action Assignment
• With the PROFIBUS EDD: Configure > Alert Setup > Discrete Events > Assign Discrete

Action
• With PROFIBUS bus parameters: Diagnostic block, Index 4 and 5.

17.6.1 Options for Enhanced Event Action

Options for Discrete Input Action or Enhanced Event ActionTable 17-13:   

Action Label

ProLink II ProLink III

None (default) None None

Reset mass total Reset Mass Total Reset Mass Total

Reset volume total Reset Volume Total Reset Volume Total
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Options for Discrete Input Action or Enhanced Event Action (continued)Table 17-13:   

Action Label

ProLink II ProLink III

Reset all totals Reset All Totals Reset All Totals

Begin fill Begin Fill Begin Fill

End fill End Fill End Fill

Resume fill Resume Fill Resume Fill

Pause fill Pause Fill Pause Fill

CAUTION!

Before assigning actions to an enhanced event or discrete input, check the status of the event
or the remote input device. If it is ON, all assigned actions will be performed when the new
configuration is implemented. If this is not acceptable, wait until an appropriate time to assign
actions to the event or discrete input.

17.7 Configure digital communications
The digital communications parameters control how the transmitter will communicate
using digital communications.

Your transmitter supports the following types of digital communications:

• Modbus/RS-485 over the RS-485 terminals

• Modbus RTU via the service port

Note
The service port responds automatically to a wide range of connection requests. It is not
configurable.

17.7.1 Configure Digital Communications Fault Action

ProLink II ProLink > Configuration > Digital Comm Settings > Digital Comm Fault Setting

ProLink III Device Tools > Configuration > Fault Processing

PROFIBUS EDD Configure > Alert Setup > Inputs/Outputs Fault Actions > Digital Communications > Fault Action

PROFIBUS bus pa-

rameters

Block: Diagnostics, Index 18

Overview

Digital Communications Fault Action specifies the values that will be reported via digital
communications if the transmitter encounters an internal fault condition.
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Procedure

Set Digital Communications Fault Action as desired.

The default setting is None.

Options for Digital Communications Fault Action

Options for Digital Communications Fault ActionTable 17-14:   

Label Description

ProLink II ProLink III

Upscale Upscale • Process variable values indicate that the value is great-
er than the upper sensor limit.

• Totalizers stop incrementing.

Downscale Downscale • Process variable values indicate that the value is great-
er than the upper sensor limit.

• Totalizers stop incrementing.

Zero Zero • Flow rate variables go to the value that represents a
flow rate of 0 (zero).

• Density is reported as 0.
• Temperature is reported as 0 °C, or the equivalent if

other units are used (e.g., 32 °F).
• Drive gain is reported as measured.
• Totalizers stop incrementing.

Not-a-Number (NAN) Not a Number • Process variables are reported as IEEE NAN.
• Drive gain is reported as measured.
• Modbus scaled integers are reported as Max Int.
• Totalizers stop incrementing.

Flow to Zero Flow to Zero • Flow rates are reported as 0.
• Other process variables are reported as measured.
• Totalizers stop incrementing.

None (default) None • All process variables are reported as measured.
• Totalizers increment if they are running.

CAUTION!

If you set mA Output Fault Action or Frequency Output Fault Action to None, be sure to set Digital
Communications Fault Action to None. If you do not, the output will not report actual process data,
and this may result in measurement errors or unintended consequences for your process.

Restriction
If you set Digital Communications Fault Action to NAN, you cannot set mA Output Fault Action or Frequency
Output Fault Action to None. If you try to do this, the transmitter will not accept the configuration.
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Part V
Operations, maintenance, and
troubleshooting

Chapters covered in this part:

• Transmitter operation

• Measurement support

• Troubleshooting
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18 Transmitter operation
Topics covered in this chapter:

• Record the process variables

• View process variables

• View and acknowledge status alarms

• Read totalizer and inventory values

• Start and stop totalizers and inventories

• Reset totalizers

• Reset inventories

18.1 Record the process variables
Micro Motion suggests that you make a record of specific process variable measurements,
including the acceptable range of measurements, under normal operating conditions. This
data will help you recognize when the process variables are unusually high or low, and may
help you better diagnose and troubleshoot application issues.

Procedure

Record the following process variables, under normal operating conditions:

Process variable

Measurement

Typical average Typical high Typical low

Flow rate

Density

Temperature

Tube frequency

Pickoff voltage

Drive gain
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18.2 View process variables

ProLink II ProLink > Process Variables

ProLink III View the desired variable on the main screen under Process Variables. See Section 18.2.1

for more information.

PROFIBUS EDD Service Tools > Variables > Process Variables

PROFIBUS bus pa-

rameters

Mass flow rate: Block: Measurement, Index 4

Volume flow rate: Block: Measurement, Index 10

Density: Block: Measurement, Index 8

Temperature: Block: Measurement, Index 6

Tube frequency: Block: Diagnostics, Index 33

Left pickoff voltage: Block: Diagnostics, Index 35

Right pickoff voltage: Block: Diagnostics, Index 36

Drive gain: Block: Diagnostics, Index 32

Overview

Process variables provide information about the state of the process fluid, such as flow
rate, density, and temperature, as well as running totals. Process variables can also provide
data about flowmeter operation, such as drive gain and pickoff voltage. This information
can be used to understand and troubleshoot your process.

18.2.1 View process variables using ProLink III
When you connect to a device, the process variables are displayed on the main screen of
ProLink III.

Procedure

View the desired process variable(s).

Tip
ProLink III allows you to choose the process variables that appear on the main screen. You can also
choose whether to view data in Analog Gauge view or digital view, and you can customize the gauge
settings. For more information, see the ProLink III user manual.

18.3 View and acknowledge status alarms
The transmitter posts status alarms whenever a process variable exceeds its defined limits
or the transmitter detects a fault condition. You can view active alarms, and you can
acknowledge alarms.
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18.3.1 View and acknowledge alarms using ProLink II
You can view a list containing all alarms that are active, or inactive but unacknowledged.

1. Choose ProLink > Alarm Log.

2. Choose the High Priority or Low Priority panel.

Note
The grouping of alarms into these two categories is hard-coded and is not affected by Status
Alarm Severity.

All active or unacknowledged alarms are listed:

• Red indicator: Alarm is currently active.

• Green indicator: Alarm is inactive but unacknowledged.

Note
Only Fault and Informational alarms are listed. The transmitter automatically filters out alarms
with Status Alarm Severity set to Ignore.

3. To acknowledge an alarm, check the Ack checkbox.

Postrequisites

• To clear the following alarms, you must correct the problem, acknowledge the
alarm, then power-cycle the transmitter: A001, A002, A010, A011, A012, A013,
A018, A019, A022, A023, A024, A025, A028, A029, A031.

• For all other alarms:

- If the alarm is inactive when it is acknowledged, it will be removed from the list.

- If the alarm is active when it is acknowledged, it will be removed from the list
when the alarm condition clears.

18.3.2 View and acknowledge alerts using ProLink III
You can view a list containing all alerts that are active, or inactive and have been
unacknowleged. From this list, you can acknowlege individual alerts or choose to
acknowledge all alerts at once.

1. View alerts on the ProLink III main screen under Alerts.

All active or unacknowledged alarms are listed, and displayed according to the
following categories:

Category Description

Failed: Fix Now A meter failure has occurred and must be addressed immediately.

Maintenance: Fix Soon A condition has occurred that can be fixed at a later time.

Advisory: Informational A condition has occurred, but requires no maintenance from you.
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Notes

• All fault alerts are displayed in the Failed: Fix Now category.

• All information alerts are displayed in either the Maintenance: Fix Soon category or the
Advisory: Informational category. The category assignment is hard-coded.

• The transmitter automatically filters out alerts with Alert Severity set to Ignore.

2. To acknowledge a single alert, check the Ack checkbox for that alert. To
acknowledge all alerts at once, click Ack All.

Postrequisites

• To clear the following alarms, you must correct the problem, acknowledge the
alarm, then power-cycle the transmitter: A001, A002, A010, A011, A012, A013,
A018, A019, A022, A023, A024, A025, A028, A029, A031.

• For all other alarms:

- If the alarm is inactive when it is acknowledged, it will be removed from the list.

- If the alarm is active when it is acknowledged, it will be removed from the list
when the alarm condition clears.

18.3.3 View and acknowledge alarms using the PROFIBUS EDD
You can view all active alarms, acknowledge all active alarms, and view detailed
information for each active alarm.

1. Choose Service Tools > Alerts.

A list of all active alarms is displayed.

2. To acknowledge all active alarms, click Acknowledge All Alerts.

An alarm remains in the list until the alarm condition has cleared.

3. To view more detailed information about a specific alarm, click its button.

18.3.4 Check alarm status and acknowledge alarms using
PROFIBUS bus parameters
You can check the status of an individual alarm, and acknowledge the individual alarm.
You can acknowledge all active alarms, and you can obtain more detailed diagnostic
information.

• To check the status of an individual alarm:

1. Write the alarm index to the Diagnostic block, Index 20.

2. Read the value in the Diagnostic block, Index 22.

• To acknowledge an individual alarm:

1. Write the alarm index to the Diagnostic block, Index 20.

2. Write 0 to the Diagnostic block, Index 22.
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• To acknowledge all alarms, write 1 to the Diagnostic block, Index 30.

• To obtain more detailed alarm information, read additional data from the
Diagnostic block, including the status words.

18.3.5 Alarm data in transmitter memory
The transmitter maintains three sets of data for every alarm that is posted.

For each alarm occurrence, the following three sets of data are maintained in transmitter
memory:

• Alert List

• Alert Statistics

• Recent Alerts

Alarm data in transmitter memoryTable 18-1:   

Alarm data structure Transmitter action if condition occurs

Contents Clearing

Alert List As determined by the alarm status bits, a list
of:
• All currently active alarms
• All previously active alarms that have not

been acknowledged

Cleared and regenerated with every transmit-
ter power cycle

Alert Statistics One record for each alarm (by alarm number)
that has occurred since the last master reset.
Each record contains:
• A count of the number of occurrences
• Timestamps for the most recent posting

and clearing

Not cleared; maintained across transmitter
power cycles

Recent Alerts 50 most recent alarm postings or alarm clear-
ings

Not cleared; maintained across transmitter
power cycles

18.4 Read totalizer and inventory values

ProLink II ProLink > Totalizer Control

ProLink III View the desired variable on the main screen under Process Variables.

PROFIBUS EDD Overview > Totalizer Control

PROFIBUS bus pa-

rameters

Mass totalizer: Block: Measurement, Index 27

Volume totalizer: Block: Measurement, Index 28

Mass inventory: Block: Measurement, Index 29

Volume inventory: Block: Measurement, Index 30
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Overview

Totalizers keep track of the total amount of mass or volume measured by the transmitter
since the last totalizer reset. Inventories keep track of the total amount of mass or volume
measured by the transmitter since the last inventory reset.

Tip
You can use the inventories to keep a running total of mass or volume across multiple totalizer
resets.

18.5 Start and stop totalizers and inventories

ProLink II ProLink > Totalizer Control > Start

ProLink > Totalizer Control > Stop

ProLink III Device Tools > Totalizer Control > Totalizer and Inventories > Start All Totals

Device Tools > Totalizer Control > Totalizer and Inventories > Stop All Totals

PROFIBUS EDD Overview > Totalizer Control > Start

Overview > Totalizer Control > Stop

PROFIBUS bus pa-

rameters

Block: Measurement, Index 22

Overview

When you start a totalizer, it tracks process measurement. In a typical application, its value
increases with flow. When you stop a totalizer, it stops tracking process measurement and
its value does not change with flow. Inventories are started and stopped automatically,
when totalizers are started and stopped.

Important
Totalizers and inventories are started or stopped as a group. When you start any totalizer, all other
totalizers and all inventories are started simultaneously.When you stop any totalizer, all other
totalizers and all inventories are stopped simultaneously. You cannot start or stop inventories
directly.
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18.6 Reset totalizers

ProLink II ProLink > Totalizer Control > Reset Mass Total

ProLink > Totalizer Control > Reset Volume Total

ProLink > Totalizer Control > Reset All Totals

ProLink III Device Tools > Totalizer Control > Totalizer and Inventories > Reset Mass Total

Device Tools > Totalizer Control > Totalizer and Inventories > Reset Volume Total

Device Tools > Totalizer Control > Totalizer and Inventories > Reset All Totals

PROFIBUS EDD Overview > Totalizer Control > Mass: Reset Total

Overview > Totalizer Control > Volume: Reset Total

Overview > Totalizer Control > Reset All

PROFIBUS bus pa-

rameters

Reset mass totalizer: Block: Measurement, Index 25

Reset volume totalizer: Block: Measurement, Index 26

Reset all totalizers: Block: Measurement, Index 23

Overview

When you reset a totalizer, the transmitter sets its value to 0. It does not matter whether
the totalizer is started or stopped. If the totalizer is started, it continues to track process
measurement.

Tip
When you reset a single totalizer, the values of other totalizers are not reset. Inventory values are not
reset.

18.7 Reset inventories

ProLink II ProLink > Totalizer Control > Reset Inventories

ProLink > Totalizer Control > Reset Mass Inventory

ProLink > Totalizer Control > Reset Volume Inventory

ProLink III Device Tools > Totalizer Control > Totalizer and Inventories > Reset Mass Inventory

Device Tools > Totalizer Control > Totalizer and Inventories > Reset Volume Inventory

Device Tools > Totalizer Control > Totalizer and Inventories > Reset Gas Inventory

Device Tools > Totalizer Control > Totalizer and Inventories > Reset All Inventories

PROFIBUS EDD Not available

PROFIBUS bus pa-

rameters

Reset mass inventory: Block: Measurement, Index 33

Reset volume inventory: Block: Measurement, Index 34

Reset all inventories: Block: Measurement, Index 24
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Overview

When you reset an inventory, the transmitter sets its value to 0. It does not matter
whether the inventory is started or stopped. If the inventory is started, it continues to track
process measurement.

Tip
When you reset a single inventory, the values of other inventories are not reset. Totalizer values are
not reset.

Prerequisites

To use ProLink II or ProLink III to reset the inventories, the feature must be enabled.

• To enable inventory reset in ProLink II:

1. Click View > Preferences.

2. Check the Enable Inventory Totals Reset checkbox.

3. Click Apply.

• To enable inventory reset in ProLink III:

1. Choose Tools > Options.

2. Select Reset Inventories from ProLink III.
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19 Measurement support
Topics covered in this chapter:

• Zero the flowmeter

• Validate the meter

• Perform a (standard) D1 and D2 density calibration

• Perform temperature calibration

19.1 Zero the flowmeter
Zeroing the flowmeter establishes a baseline for process measurement by analyzing the
sensor's output when there is no flow through the sensor tubes.

Important
In most cases, the factory zero is more accurate than the field zero. Do not zero the flowmeter unless
one of the following is true:

• The zero is required by site procedures.

• The stored zero value fails the Zero Verification procedure.

19.1.1 Zero the flowmeter using ProLink II
Zeroing the flowmeter establishes a baseline for process measurement by analyzing the
sensor's output when there is no flow through the sensor tubes.

Prerequisites

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Prepare the flowmeter:

a. Allow the flowmeter to warm up for at least 20 minutes after applying power.

b. Run the process fluid through the sensor until the sensor temperature reaches
the normal process operating temperature.

c. Stop flow through the sensor by shutting the downstream valve, and then the
upstream valve if available.

d. Verify that the sensor is blocked in, that flow has stopped, and that the sensor is
completely full of process fluid.

e. Observe the drive gain, temperature, and density readings. If they are stable,
check the Live Zero or Field Verification Zero value. If the average value is close to 0,
you should not need to zero the flowmeter.

2. Choose ProLink > Calibration > Zero Verification and Calibration.
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3. Click Calibrate Zero.

4. Modify Zero Time, if desired.

Zero Time controls the amount of time the transmitter takes to determine its zero-
flow reference point. The default Zero Time is 20 seconds. For most applications, the
default Zero Time is appropriate.

5. Click Perform Auto Zero.

The Calibration in Progress light will turn red during the zero procedure. At the end of
the procedure:

• If the zero procedure was successful, the Calibration in Progress light returns to
green and a new zero value is displayed.

• If the zero procedure failed, the Calibration Failure light turns red.

Postrequisites

Restore normal flow through the sensor by opening the valves.

Need help?  If the zero fails:

• Ensure that there is no flow through the sensor, then retry.

• Remove or reduce sources of electromechanical noise, then retry.

• Set Zero Time to a lower value, then retry.

• If the zero continues to fail, contact Micro Motion.

• If you want to return the flowmeter to operation using a previous zero value:

- To restore the zero value set at the factory: ProLink > Zero Verification and Calibration > Calibrate
Zero > Restore Factory Zero .

- To restore the most recent valid value from transmitter memory: ProLink > Zero Verification
and Calibration > Calibrate Zero > Restore Prior Zero . Restore Prior Zero is available only while the
Flow Calibration window is open. If you close the Flow Calibration window, you will no
longer be able to restore the prior zero.

Restriction
Restore the factory zero only if your flowmeter was purchased as a unit, it was zeroed at the factory,
and you are using the original components.

19.1.2 Zero the flowmeter using ProLink III
Zeroing the flowmeter establishes a baseline for process measurement by analyzing the
sensor's output when there is no flow through the sensor tubes.

Prerequisites

ProLink III must be running and must be connected to the transmitter.

Procedure

1. Prepare the flowmeter:
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a. Allow the flowmeter to warm up for at least 20 minutes after applying power.

b. Run the process fluid through the sensor until the sensor temperature reaches
the normal process operating temperature.

c. Stop flow through the sensor by shutting the downstream valve, and then the
upstream valve if available.

d. Verify that the sensor is blocked in, that flow has stopped, and that the sensor is
completely full of process fluid.

e. Observe the drive gain, temperature, and density readings. If they are stable,
check the Live Zero or Field Verification Zero value. If the average value is close to 0,
you should not need to zero the flowmeter.

2. Choose Device Tools > Calibration > Zero Verification and Calibration.

3. Click Calibrate Zero.

4. Modify Zero Time, if desired.

Zero Time controls the amount of time the transmitter takes to determine its zero-
flow reference point. The default Zero Time is 20 seconds. For most applications, the
default Zero Time is appropriate.

5. Click Calibrate Zero.

The Calibration in Progress message is displayed. When the calibration is complete:

• If the zero procedure was successful, a Calibration Success message and a new zero
value are displayed.

• If the zero procedure failed, a Calibration Failed message is displayed.

Postrequisites

Restore normal flow through the sensor by opening the valves.

Need help?  If the zero fails:

• Ensure that there is no flow through the sensor, then retry.

• Remove or reduce sources of electromechanical noise, then retry.

• Set Zero Time to a lower value, then retry.

• If the zero continues to fail, contact Micro Motion.

• If you want to return the flowmeter to operation using a previous zero value:

- To restore the zero value set at the factory: Device Tools > Zero Verification and Calibration >
Calibrate Zero > Restore Factory Zero .

- To restore the most recent valid value from transmitter memory: Device Tools > Zero
Verification and Calibration > Calibrate Zero > Restore Prior Zero . Restore Prior Zero is available only
while the Flow Calibration window is open. If you close the Flow Calibration window, you
will no longer be able to restore the prior zero.

Restriction
Restore the factory zero only if your flowmeter was purchased as a unit, it was zeroed at the factory,
and you are using the original components.
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19.1.3 Zero the flowmeter using the PROFIBUS EDD
Zeroing the flowmeter establishes a baseline for process measurement by analyzing the
sensor's output when there is no flow through the sensor tubes.

Prerequisites

You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Prepare the flowmeter:

1. Record the stored zero value.

2. Allow the flowmeter to warm up for at least 20 minutes after applying power.

3. Run the process fluid through the sensor until the sensor temperature reaches the
normal process operating temperature.

4. Stop flow through the sensor by shutting the downstream valve, and then the
upstream valve if available.

5. Verify that the sensor is blocked in, that flow has stopped, and that the sensor is
completely full of process fluid.

6. Observe the drive gain, temperature, and density readings. If they are stable, check
the Live Zero or Field Verification Zero value. If the average value is close to 0, you should
not need to zero the flowmeter.

Important
In many cases, the flowmeter was zeroed at the factory, and should not require a field zero.

Note
Do not verify the zero or zero the flowmeter if a high-severity alarm is active. Correct the problem,
then verify the zero or zero the flowmeter. You may verify the zero or zero the flowmeter if a low-
severity alarm is active.

Procedure

1. Choose Service Tools > Maintenance > Zero Calibration.

2. Click Perform Auto Zero.

3. Follow the instructions in the guided method.

Zero Time controls the amount of time the transmitter takes to determine its zero-
flow reference point. The default Zero Time is 20 seconds. For most applications, the
default Zero Time is appropriate.

Postrequisites

Restore normal flow through the sensor by opening the valves.

Need help?  If the zero fails:

• Ensure that there is no flow through the sensor, then retry.
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• Remove or reduce sources of electromechanical noise, then retry.

• Set Zero Time to a lower value, then retry.

• If the zero continues to fail, contact Micro Motion.

• If you want to return the flowmeter to operation using a previous zero value:

19.1.4 Zero the flowmeter using PROFIBUS bus parameters
Zeroing the flowmeter establishes a baseline for process measurement by analyzing the
sensor's output when there is no flow through the sensor tubes.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Prepare the flowmeter:

1. Record the stored zero value.

2. Allow the flowmeter to warm up for at least 20 minutes after applying power.

3. Run the process fluid through the sensor until the sensor temperature reaches the
normal process operating temperature.

4. Stop flow through the sensor by shutting the downstream valve, and then the
upstream valve if available.

5. Verify that the sensor is blocked in, that flow has stopped, and that the sensor is
completely full of process fluid.

6. Observe the drive gain, temperature, and density readings. If they are stable, check
the Live Zero or Field Verification Zero value. If the average value is close to 0, you should
not need to zero the flowmeter.

Important
In many cases, the flowmeter was zeroed at the factory, and should not require a field zero.

Note
Do not verify the zero or zero the flowmeter if a high-severity alarm is active. Correct the problem,
then verify the zero or zero the flowmeter. You may verify the zero or zero the flowmeter if a low-
severity alarm is active.

Procedure

1. Write the desired Zero Time to the Calibration block, Index 7.

Zero Time controls the amount of time the transmitter takes to determine its zero-
flow reference point. The default Zero Time is 20 seconds. For most applications, the
default Zero Time is appropriate.

2. Write 1 to the Calibration block, Index 6, then wait for the configured number of
seconds.

3. Read Status Word 5, Bit #15 (0x8000) to monitor the zero procedure.
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Value Description

0 Zero complete

1 Zero in progress

4. Read Status Word 3, Bit #9, #10, and #11 (0x0200, 0x0400, and 0x0800) for the
outcome of the zero procedure.

Bit (hexadec-
imal)

Bit (deci-
mal) Condition Value

0x0200 9 Zero failure: Zero too low • 0 = Condition inactive
• 1 = Condition active

0x0400 10 Zero failure: Zero too high • 0 = Condition inactive
• 1 = Condition active

0x0800 11 Zero failure: Unstable • 0 = Condition inactive
• 1 = Condition active

If all three conditions are inactive, the zero succeeded.

Postrequisites

Restore normal flow through the sensor by opening the valves.

Need help?  If the zero fails:

• Ensure that there is no flow through the sensor, then retry.

• Remove or reduce sources of electromechanical noise, then retry.

• Set Zero Time to a lower value, then retry.

• If the zero continues to fail, contact Micro Motion.

• If you want to return the flowmeter to operation using a previous zero value:

19.2 Validate the meter

ProLink II ProLink > Configuration > Flow

ProLink III Device Tools > Configuration > Process Measurement > Flow

Device Tools > Configuration > Process Measurement > Density

PROFIBUS EDD Configure > Manual Setup > Measurements

PROFIBUS bus pa-

rameters

Mass factor: Block: Measurement, Index 15

Volume factor: Block: Measurement, Index 17

Density factor: Block: Measurement, Index 16
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Overview

Meter validation compares flowmeter measurements reported by the transmitter to an
external measurement standard. If the transmitter value for mass flow, volume flow, or
density measurement is significantly different from the external measurement standard,
you may want to adjust the corresponding meter factor. The flowmeter’s actual
measurement is multiplied by the meter factor, and the resulting value is reported and
used in further processing.

Prerequisites

Identify the meter factor(s) that you will calculate and set. You may set any combination of
the three meter factors: mass flow, volume flow, and density. Note that all three meter
factors are independent:

• The meter factor for mass flow affects only the value reported for mass flow.

• The meter factor for density affects only the value reported for density.

• The meter factor for volume flow affects only the value reported for volume flow.

Important
To adjust volume flow, you must set the meter factor for volume flow. Setting a meter factor for
mass flow and a meter factor for density will not produce the desired result. The volume flow
calculations are based on original mass flow and density values, before the corresponding meter
factors have been applied.

If you plan to calculate the meter factor for volume flow, be aware that validating volume
in the field may be expensive, and the procedure may be hazardous for some process
fluids. Therefore, because volume is inversely proportional to density, an alternative to
direct measurement is to calculate the meter factor for volume flow from the meter factor
for density. See Section 19.2.1 for instructions on this method.

Obtain a reference device (external measurement device) for the appropriate process
variable.

Important
For good results, the reference device must be highly accurate.

Procedure

1. Determine the meter factor as follows:

a. Use the flowmeter to take a sample measurement.

b. Measure the same sample using the reference device.

c. Calculate the meter factor using the following formula:

NewMeterFactor ConfiguredMeterFactor
ReferenceMeasurement

FlowmeterMeasurement
= x

2. Ensure that the calculated meter factor is between 0.8 and 1.2, inclusive. If the
meter factor is outside these limits, contact Micro Motion customer service.

3. Configure the meter factor in the transmitter.
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Example: Calculating the meter factor for mass flow

The flowmeter is installed and validated for the first time. The mass flow measurement
from the transmitter is 250.27 lb. The mass flow measurement from the reference device
is 250 lb. The mass flow meter factor is calculated as follows:

MeterFactorMassFlow 1
250

250.27
= x = 0.9989

The first meter factor for mass flow is 0.9989.

One year later, the flowmeter is validated again. The mass flow measurement from the
transmitter is 250.07 lb. The mass flow measurement from the reference device is
250.25 lb. The new mass flow meter factor is calculated as follows:

MeterFactorMassFlow 0.9989 250.25

250.07
= x = 0.9996

The new meter factor for mass flow is 0.9996.

19.2.1 Alternate method for calculating the meter factor for
volume flow
The alternate method for calculating the meter factor for volume flow is used to avoid the
difficulties that may be associated with the standard method.

This alternate method is based on the fact that volume is inversely proportional to density.
It provides partial correction of the volume flow measurement by adjusting for the portion
of the total offset that is caused by the density measurement offset. Use this method only
when a volume flow reference is not available, but a density reference is available.

Procedure

1. Calculate the meter factor for density, using the standard method (see Section 19.2).

2. Calculate the meter factor for volume flow from the meter factor for density:

MeterFactorVolume
1

MeterFactorDensity
=

Note
The following equation is mathematically equivalent to the first equation. You may use
whichever version you prefer.

MeterFactorVolume ConfiguredMeterFactorDensity
DensityFlowmeter

DensityReferenceDevice
= x

3. Ensure that the calculated meter factor is between 0.8 and 1.2, inclusive. If the
meter factor is outside these limits, contact Micro Motion customer service.
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4. Configure the meter factor for volume flow in the transmitter.

19.3 Perform a (standard) D1 and D2 density
calibration
Density calibration establishes the relationship between the density of the calibration
fluids and the signal produced at the sensor. Density calibration includes the calibration of
the D1 (low-density) and D2 (high-density) calibration points.

Important
Micro Motion flowmeters are calibrated at the factory, and normally do not need to be calibrated in
the field. Calibrate the flowmeter only if you must do so to meet regulatory requirements. Contact
Micro Motion before calibrating the flowmeter.

Tip
Micro Motion recommends using meter validation and meter factors, rather than calibration, to
prove the meter against a regulatory standard or to correct measurement error.

19.3.1 Perform a D1 and D2 density calibration using ProLink II
Prerequisites

• During density calibration, the sensor must be completely filled with the calibration
fluid, and flow through the sensor must be at the lowest rate allowed by your
application. This is usually accomplished by closing the shutoff valve downstream
from the sensor, then filling the sensor with the appropriate fluid.

• D1 and D2 density calibration require a D1 (low-density) fluid and a D2 (high-
density) fluid. You may use air and water.

• The calibrations must be performed without interruption, in the order shown. Make
sure that you are prepared to complete the process without interruption.

• Before performing the calibration, record your current calibration parameters. You
can do this by saving the current configuration to a file on the PC. If the calibration
fails, restore the known values.

Procedure

See Figure 19-1.
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D1 and D2 density calibration using ProLink IIFigure 19-1:   

Enter density of D1 fluid

Calibration in Progress 
light turns green

Calibration in Progress 
light turns red

D1 calibration

Close shutoff valve 
downstream from sensor Fill sensor with D1 fluid Fill sensor with D2 fluid

Close

Enter density of D2 fluid

Calibration in Progress 
light turns green

Calibration in Progress 
light turns red

D2 calibration

Close

Done

Do Cal Do Cal

ProLink Menu >
     Calibration >
          Density cal – Point 1

ProLink Menu >
     Calibration >
          Density cal – Point 2

19.3.2 Perform a D1 and D2 density calibration using ProLink III
Prerequisites

• During density calibration, the sensor must be completely filled with the calibration
fluid, and flow through the sensor must be at the lowest rate allowed by your
application. This is usually accomplished by closing the shutoff valve downstream
from the sensor, then filling the sensor with the appropriate fluid.

• D1 and D2 density calibration require a D1 (low-density) fluid and a D2 (high-
density) fluid. You may use air and water.

• The calibrations must be performed without interruption, in the order shown. Make
sure that you are prepared to complete the process without interruption.

• Before performing the calibration, record your current calibration parameters. You
can do this by saving the current configuration to a file on the PC. If the calibration
fails, restore the known values.

Procedure

See Figure 19-2.
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D1 and D2 density calibration using ProLink IIIFigure 19-2:   

Enter density of D1 fluid

D1 calibration

Close shutoff valve 
downstream from sensor

Fill sensor with D1 fluid

Done

Device Tools >
  Calibration >
     Density Calibration >
        Density Calibration – Point 1 (Air)

Close

Start Calibration

Enter density of D2 fluid

D2 calibration

Fill sensor with D2 fluid

Device Tools >
  Calibration >
     Density Calibration >
        Density Calibration – Point 2 (Water)

Close

Start Calibration

19.3.3 Perform a D1 and D2 density calibration using the
PROFIBUS EDD
Prerequisites

• During density calibration, the sensor must be completely filled with the calibration
fluid, and flow through the sensor must be at the lowest rate allowed by your
application. This is usually accomplished by closing the shutoff valve downstream
from the sensor, then filling the sensor with the appropriate fluid.

• D1 and D2 density calibration require a D1 (low-density) fluid and a D2 (high-
density) fluid. You may use air and water.

• The calibrations must be performed without interruption, in the order shown. Make
sure that you are prepared to complete the process without interruption.

• Before performing the calibration, record your current calibration parameters. If the
calibration fails, restore the known values.

Procedure

1. To perform a D1 calibration:

a. Fill the sensor with your D1 fluid.

b. Choose Service Tools > Maintenance > Density Calibrations > First Point Calibration.
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The first screen of the guided method is displayed

c. Follow the instructions in the guided method.

2. To perform a D2 calibration:

a. Fill the sensor with your D2 fluid.

b. Choose Service Tools > Maintenance > Density Calibrations > Second Point Calibration.

The first screen of the guided method is displayed.

c. Follow the instructions in the guided method.

19.3.4 Perform a D1 and D2 density calibration using PROFIBUS
bus parameters
Prerequisites

• During density calibration, the sensor must be completely filled with the calibration
fluid, and flow through the sensor must be at the lowest rate allowed by your
application. This is usually accomplished by closing the shutoff valve downstream
from the sensor, then filling the sensor with the appropriate fluid.

• D1 and D2 density calibration require a D1 (low-density) fluid and a D2 (high-
density) fluid. You may use air and water.

• The calibrations must be performed without interruption, in the order shown. Make
sure that you are prepared to complete the process without interruption.

• Before performing the calibration, record your current calibration parameters. If the
calibration fails, restore the known values.

Procedure

See Figure 19-3.
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Perform a D1 and D2 calibration using PROFIBUS bus parametersFigure 19-3:   

Enter density of D1 fluid

Monitor status

D1 calibration

Close shutoff valve 
downstream from sensor

Fill sensor with D1 fluid

Block: Calibration, Index 11Start D1 calibration

Block: Calibration, Index 21

Block: Diagnostic, Index 14, 
Bit 14

Bit 14 0ff?No

Enter density of D2 fluid

Monitor status

D2 calibration
Fill sensor with D2 fluid

Block: Calibration, Index 12Start D2 calibration

Block: Calibration, Index 22

Block: Diagnostic, Index 14, 
Bit 13

Bit 13 0ff?No

Check K1 value Block: Calibration, Index 16

Yes

Check K2 value Block: Calibration, Index 17

Yes

Done Done

19.4 Perform temperature calibration
Temperature calibration establishes the relationship between the temperature of the
calibration fluids and the signal produced by the sensor.

19.4.1 Perform temperature calibration using ProLink II
Temperature calibration establishes the relationship between the temperature of the
calibration fluids and the signal produced by the sensor.

Prerequisites

The temperature calibration is a two-part procedure: temperature offset calibration and
temperature slope calibration. The two parts must be performed without interruption, in
the order shown. Ensure that you are prepared to complete the process without
interruption.

Important
Consult Micro Motion before performing a temperature calibration. Under normal circumstances,
the temperature circuit is stable and should not need an adjustment.

Procedure

See Figure 19-4.
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Temperature calibration using ProLink IIFigure 19-4:   

Enter temperature of low-
temperature fluid

Temperature Offset calibration

Do Cal

Wait until sensor achieves 
thermal equilibrium

Fill sensor with low-
temperature fluid

Calibration in Progress 
light turns green

Calibration in Progress 
light turns red

Close

Enter temperature of high-
temperature fluid

Temperature Slope calibration

Do Cal

Wait until sensor achieves 
thermal equilibrium

Fill sensor with high-
temperature fluid

Calibration in Progress 
light turns green

Calibration in Progress 
light turns red

Close

Done

ProLink Menu >
     Calibration >
          Temp offset cal

ProLink Menu >
     Calibration >
          Temp slope cal

19.4.2 Perform temperature calibration using ProLink III
Temperature calibration establishes the relationship between the temperature of the
calibration fluids and the signal produced by the sensor.

Prerequisites

The temperature calibration is a two-part procedure: temperature offset calibration and
temperature slope calibration. The two parts must be performed without interruption, in
the order shown. Ensure that you are prepared to complete the process without
interruption.

Important
Consult Micro Motion before performing a temperature calibration. Under normal circumstances,
the temperature circuit is stable and should not need an adjustment.

Procedure

See Figure 19-5.
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Temperature calibration using ProLink IIIFigure 19-5:   

Enter temperature of low-
temperature fluid

Temperature Offset calibration

Wait until sensor achieves 
thermal equilibrium

Fill sensor with low-
temperature fluid

Enter temperature of high-
temperature fluid

Temperature Slope calibration

Start Calibration

Wait until sensor achieves 
thermal equilibrium

Fill sensor with high-
temperature fluid

Done

Device Tools >
   Calibration >
      Temperature Calibration >
         Temperature Calibration - Offset

Start Calibration

Device Tools >
   Calibration >
      Temperature Calibration >
         Temperature Calibration - Slope
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20 Troubleshooting
Topics covered in this chapter:

• Status alarms

• Flow measurement problems

• Density measurement problems

• Temperature measurement problems

• Milliamp output problems

• Frequency output problems

• Use sensor simulation for troubleshooting

• Check power supply wiring

• Check grounding

• Perform loop tests

• Trim mA outputs

• Check Lower Range Value and Upper Range Value

• Check mA Output Fault Action

• Check for radio frequency interference (RFI)

• Check Frequency Output Maximum Pulse Width

• Check Frequency Output Scaling Method

• Check Frequency Output Fault Action

• Check Flow Direction

• Check the cutoffs

• Check for slug flow (two-phase flow)

• Check the drive gain

• Check the pickoff voltage

• Check for electrical shorts

20.1 Status alarms

Status alarms and recommended actionsTable 20-1:   

Alarm code Description Cause Recommended actions

A001 EEPROM Error (Core
Processor)

An uncorrectable
checksum mismatch
has been detected.

• Cycle power to the meter.
• Contact Micro Motion.

A002 RAM Error (Core Pro-
cessor)

ROM checksum error or
a RAM location cannot
be written to.

• Cycle power to the meter.
• Contact Micro Motion.
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Status alarms and recommended actions (continued)Table 20-1:   

Alarm code Description Cause Recommended actions

A003 No Sensor Response Continuity failure of
drive circuit, LPO, or
RPO, or LPO-RPO mis-
match when driving.

• Check the drive gain and the pickoff voltage.
See Section 20.21 and Section 20.22.

• Check for electrical shorts. See Section 20.23.
• Check the integrity of the sensor tubes.

A004 Temperature Over-
range

Combination of A016
and A017.

• Verify temperature characterization parame-
ters (Temp Cal Factor).

• Check your process conditions against the val-
ues reported by the flowmeter.

• Contact Micro Motion.

A005 Mass Flow Rate Over-
range

The measured flow has
exceeded the maxi-
mum flow rate of the
sensor (ΔT greater than
200 µs).

• If other alarms are present, resolve those
alarm conditions first. If the current alarm per-
sists, continue with the recommended ac-
tions.

• Check your process conditions against the val-
ues reported by the flowmeter.

• Check for slug flow. See Section 20.20.
• Check the drive gain and the pickoff voltage.

See Section 20.21 and Section 20.22.
• Check for electrical shorts. See Section 20.23.
• Check the integrity of the sensor tubes.
• Contact Micro Motion.

A006 Characterization Re-
quired

Calibration factors have
not been entered and
the sensor type is incor-
rect.

• Verify that all of the characterization parame-
ters match the data on the sensor tag.

• Contact Micro Motion.

A008 Density Overrange The measured density
has exceeded
10 g/cm3.

• If other alarms are present, resolve those
alarm conditions first. If the current alarm per-
sists, continue with the recommended ac-
tions.

• Verify process conditions, checking especially
for air in the flow tubes, tubes not filled, for-
eign material in the tubes, or coating in the
tubes.

• Check for slug flow. See Section 20.20.
• If accompanied by an A003 alarm, check for

electrical shorts. See Section 20.23.
• Verify that all of the characterization parame-

ters match the data on the sensor tag.
• Check the drive gain and the pickoff voltage.

See Section 20.21 and Section 20.22.
• Perform a density calibration.
• Contact Micro Motion.

A009 Transmitter Initializing/
Warming Up

Transmitter is in power-
up mode.

• Allow the meter to warm up.
• Verify that the tubes are full of process fluid.
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Status alarms and recommended actions (continued)Table 20-1:   

Alarm code Description Cause Recommended actions

A010 Calibration Failure Many possible causes,
such as too much flow
through the sensor dur-
ing a calibration proce-
dure.

• If this alarm appears during zeroing, verify that
there is no flow through the sensor, then retry
the procedure.

• Cycle power to the meter, then retry the pro-
cedure.

A011 Zero Calibration Failed:
Low

Many possible causes,
such as too much flow
– especially reverse
flow – through the sen-
sor during a calibration
procedure.

• Verify that there is no flow through the sensor,
then retry the procedure.

• Cycle power to the meter, then retry the pro-
cedure.

A012 Zero Calibration Failed:
High

Many possible causes,
such as too much flow
– especially forward
flow – through the sen-
sor during a calibration
procedure.

• Verify that there is no flow through the sensor,
then retry the procedure.

• Cycle power to the meter, then retry the pro-
cedure.

A013 Zero Calibration Failed:
Unstable

There was too much in-
stability during the cali-
bration procedure.

• Remove or reduce sources of electromechani-
cal noise (e.g., pumps, vibration, pipe stress),
then retry the procedure.

• Cycle power to the meter, then retry the pro-
cedure.

A014 Transmitter Failure Many possible causes. • Cycle power to the meter.
• Contact Micro Motion.

A016 Sensor RTD Failure The value computed for
the resistance of the
Line RTD is outside lim-
its.

• Check your process conditions against the val-
ues reported by the flowmeter.

• Contact Micro Motion.

A017 T-Series RTD Failure The value computed for
the resistance of the
Meter/Case RTD is out-
side limits.

• Check your process conditions against the val-
ues reported by the flowmeter. Temperature
should be between –200 °F and +400 °F.

• Verify that all of the characterization parame-
ters match the data on the sensor tag.

• Contact Micro Motion.

A020 No Flow Cal Value The flow calibration fac-
tor and/or K1 has not
been entered since the
last master reset.

• Verify that all of the characterization parame-
ters match the data on the sensor tag.

A021 Incorrect Sensor Type
(K1)

The sensor is recog-
nized as a straight tube
but the K1 value indi-
cates a curved tube, or
vice versa.

• Verify that all of the characterization parame-
ters match the data on the sensor tag.

Troubleshooting

Configuration and Use Manual 265



Status alarms and recommended actions (continued)Table 20-1:   

Alarm code Description Cause Recommended actions

A029 PIC/Daughterboard
Communications Fail-
ure

A communication fail-
ure has occurred with a
hardware sub-assem-
bly.

• Contact Micro Motion.

A030 Incorrect Board Type • Contact Micro Motion.

A031 Low Power The transmitter is not
receiving enough pow-
er.

• Check the power supply and power supply wir-
ing. See Section 20.8.

A033 Insufficient Right/Left
Pickoff Signal

No signal from LPO or
RPO, suggesting that
sensor tubes are not vi-
brating.

• Verify process conditions, checking especially
for air in the flow tubes, tubes not filled, for-
eign material in the tubes, or coating in the
tubes.

A102 Drive Overrange The drive power (cur-
rent/voltage) is at its
maximum.

• Check the drive gain and the pickoff voltage.
See Section 20.21 and Section 20.22.

• Check for electrical shorts. See Section 20.23.

A104 Calibration in Progress A calibration procedure
is in process.

• Allow the procedure to complete.
• For zero calibration, you may abort the calibra-

tion, set the zero time parameter to a lower
value, and restart the calibration.

A105 Slug Flow The density has excee-
ded the user-defined
slug (density) limits.

• Check for slug flow. See Section 20.20.

A107 Power Reset Occurred The transmitter has
been restarted.

• No action required.
• If desired, you can reconfigure the alarm se-

verity level to Ignore.

A110 Frequency Output Satu-
rated

The calculated frequen-
cy output is outside of
the linear range.

• Check the frequency output scaling. See 
Section 20.16.

• Check process conditions. Actual conditions
may be outside of the normal conditions for
which the output is configured.

• Verify process conditions, checking especially
for air in the flow tubes, tubes not filled, for-
eign material in the tubes, or coating in the
tubes.

• Verify that the measurement units are config-
ured correctly for your application.

• Purge the flow tubes.

A111 Frequency Output Fixed The frequency output
has been configured to
send a constant value.

• Check whether the output is in loop test
mode. If it is, unfix the output.

• Check whether the output has been set to a
constant value via digital communication.
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Status alarms and recommended actions (continued)Table 20-1:   

Alarm code Description Cause Recommended actions

A113 mA Output 2 Saturated • Check process conditions. Actual conditions
may be outside of the normal conditions for
which the output is configured.

• Verify process conditions, checking especially
for air in the flow tubes, tubes not filled, for-
eign material in the tubes, or coating in the
tubes.

• Verify that the measurement units are config-
ured correctly for your application.

• Purge the flow tubes.
• Check the settings of Upper Range Value and

Lower Range Value. See Section 20.12.

A114 mA Output 2 Fixed • Check whether the output is in loop test
mode. If it is, unfix the output.

• Exit mA output trim, if applicable.
• Check whether the output has been set to a

constant value via digital communication.

A118 Discrete Output 1 Fixed The discrete output has
been configured to
send a constant value.

• Check whether the output is in loop test
mode. If it is, unfix the output.

A132 Sensor Simulation Ac-
tive

Simulation mode is en-
abled.

• No action required.
• Disable sensor simulation.

20.2 Flow measurement problems

Flow measurement problems and recommended actionsTable 20-2:   

Problem Possible causes Recommended actions

Flow indication at no
flow conditions or
zero offset

• Misaligned piping (especially in new in-
stallations)

• Open or leaking valve
• Incorrect sensor zero

• Verify that all of the characterization parame-
ters match the data on the sensor tag.

• If the flow reading is not excessively high, re-
view the live zero. You may need to restore
the factory zero.

• Check for open or leaking valves or seals.
• Check for mounting stress on the sensor

(e.g., sensor being used to support piping,
misaligned piping).

• Contact Micro Motion.
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Flow measurement problems and recommended actions (continued)Table 20-2:   

Problem Possible causes Recommended actions

Erratic non-zero flow
rate under no-flow
conditions

• Leaking valve or seal
• Slug flow
• Plugged or coated flow tube
• Incorrect sensor orientation
• Wiring problem
• Vibration in pipeline at rate close to sen-

sor tube frequency
• Damping value too low
• Mounting stress on sensor

• Verify that the sensor orientation is appropri-
ate for your application (refer to the sensor
installation manual).

• Check the drive gain and the pickoff voltage.
See Section 20.21 and Section 20.22.

• Purge the flow tubes.
• Check for open or leaking valves or seals.
• Check for sources of vibration.
• Verify damping configuration.
• Verify that the measurement units are con-

figured correctly for your application.
• Check for slug flow. See Section 20.20.
• Check for radio frequency interference. See 

Section 20.14.
• Contact Micro Motion.

Erratic non-zero flow
rate when flow is
steady

• Slug flow
• Damping value too low
• Plugged or coated flow tube
• Output wiring problem
• Problem with receiving device
• Wiring problem

• Verify that the sensor orientation is appropri-
ate for your application (refer to the sensor
installation manual).

• Check the drive gain and the pickoff voltage.
See Section 20.21 and Section 20.22.

• Check for air entrainment, tube fouling,
flashing, or tube damage.

• Purge the flow tubes.
• Check for open or leaking valves or seals.
• Check for sources of vibration.
• Verify damping configuration.
• Verify that the measurement units are con-

figured correctly for your application.
• Check for slug flow. See Section 20.20.
• Check for radio frequency interference. See 

Section 20.14.
• Contact Micro Motion.

Inaccurate flow rate
or batch total

• Wiring problem
• Inappropriate measurement unit
• Incorrect flow calibration factor
• Incorrect meter factor
• Incorrect density calibration factors
• Incorrect flowmeter grounding
• Slug flow
• Problem with receiving device

• Verify that the measurement units are con-
figured correctly for your application.

• Verify that all of the characterization parame-
ters match the data on the sensor tag.

• Perform a bucket test to verify batch totals.
• Zero the meter.
• Check grounding. See Section 20.9.
• Check for slug flow. See Section 20.20.
• Verify that the receiving device, and the wir-

ing between the transmitter and the receiv-
ing device.

• Check sensor coil resistance and for shorts to
case. See Check the sensor coils.

• Replace the core processor or transmitter.
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20.3 Density measurement problems

Density measurement problems and recommended actionsTable 20-3:   

Problem Possible causes Recommended actions

Inaccurate density
reading

• Problem with process fluid
• Incorrect density calibration factors
• Wiring problem
• Incorrect flowmeter grounding
• Slug flow
• Plugged or coated flow tube
• Incorrect sensor orientation
• RTD failure
• Physical characteristics of sensor have

changed

• Check grounding. See Section 20.9.
• Check your process conditions against the

values reported by the flowmeter.
• Verify that all of the characterization parame-

ters match the data on the sensor tag.
• Check for slug flow. See Section 20.20.
• If two sensors with similar frequency are too

near each other, separate them.
• Purge the flow tubes.

Unusually high densi-
ty reading

• Plugged or coated flow tube
• Incorrect K2 value
• Incorrect temperature measurement
• RTD problem
• In high frequency meters, this can be an

indication of erosion or corrosion
• In low frequency meters this can indi-

cate tube fouling

• Verify that all of the characterization parame-
ters match the data on the sensor tag.

• Purge the flow tubes.
• Check for coating in the flow tubes.

Unusually low density
reading

• Slug flow
• Incorrect K2 value
• In low frequency meters this can indi-

cate erosion or corrosion

• Check your process conditions against the
values reported by the flowmeter.

• Verify that all of the characterization parame-
ters match the data on the sensor tag.

• Check for tube erosion, especially if the proc-
ess fluid is abrasive.
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20.4 Temperature measurement problems

Temperature measurement problems and recommended actionsTable 20-4:   

Problem Possible causes Recommended actions

Temperature reading
significantly different
from process temper-
ature

• RTD failure
• Wiring problem

• Check junction box for moisture or verdi-
gris.

• Perform RTD resistance checks and check
for shorts to case (see 
Check the sensor coils).

• Confirm the temperature calibration factor
matches the value on the sensor tag.

• Refer to status alarms (especially RTD fail-
ure alarms).

• Disable external temperature compensa-
tion.

• Verify temperature calibration.

Temperature reading
slightly different from
process temperature

• Sensor temperature not yet equalized
• Sensor leaking heat

• The RTD has a specification of ±1 °C. If the
error is within this range there is no prob-
lem. If the temperature measurement is
outside the specification for the sensor,
contact Micro Motion.

• The temperature of the fluid may be
changing rapidly. Allow sufficient time for
the sensor to equalize with the process flu-
id.

• Insulate the sensor if necessary.
• Perform RTD resistance checks and check

for shorts to case (see 
Check the sensor coils).

• The RTD may not be making good contact
with the sensor. The sensor may need to
be replaced.

Troubleshooting

270  Micro Motion® Filling Mass Transmitters with PROFIBUS-DP



20.5 Milliamp output problems

Milliamp output problems and recommended actionsTable 20-5:   

Problem Possible causes Recommended actions

No mA output • Wiring problem
• Circuit failure

• Check the power supply and power supply
wiring. See Section 20.8.

• Check the mA output wiring.
• Check the Fault Action settings. See 

Section 20.13.
• Measure DC voltage across output termi-

nals to verify that the output is active.
• Contact Micro Motion.

Loop test failed • Power supply problem
• Wiring problem
• Circuit failure
• Incorrect internal/external power configu-

ration

• Check the power supply and power supply
wiring. See Section 20.8.

• Check the mA output wiring.
• Check the Fault Action settings. See 

Section 20.13.
• Contact Micro Motion.

mA output below 4
mA

• Open in wiring
• Bad output circuit
• Process condition below LRV
• LRV and URV are not set correctly
• Fault condition if fault action is set to inter-

nal zero or downscale
• Bad mA receiving device

• Check your process conditions against the
values reported by the flowmeter.

• Verify that the receiving device, and the
wiring between the transmitter and the re-
ceiving device.

• Check the settings of Upper Range Value and
Lower Range Value. See Section 20.12.

• Check the Fault Action settings. See 
Section 20.13.

Constant mA output • Incorrect process variable assigned to the
output

• Fault condition exists
• Non-zero HART address (mA output 1)
• Output is configured for loop test mode
• Zero calibration failure

• Verify the output variable assignments.
• View and resolve any existing alarm condi-

tions.
• Check to see if a loop test is in process (the

output is fixed).
• If related to a zero calibration failure, cycle

power to the meter and retry the zeroing
procedure.

mA output consis-
tently out of range

• Incorrect process variable or units assigned
to output

• Fault condition if fault action is set to up-
scale or downscale

• LRV and URV are not set correctly

• Verify the output variable assignments.
• Verify the measurement units configured

for the output.
• Check the Fault Action settings. See 

Section 20.13.
• Check the settings of Upper Range Value and

Lower Range Value. See Section 20.12.
• Check the mA output trim. See 

Section 20.11.
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Milliamp output problems and recommended actions (continued)Table 20-5:   

Problem Possible causes Recommended actions

Consistently incorrect
mA measurement

• Loop problem
• Output not trimmed correctly
• Incorrect flow measurement unit config-

ured
• Incorrect process variable configured
• LRV and URV are not set correctly

• Check the mA output trim. See 
Section 20.11.

• Verify that the measurement units are con-
figured correctly for your application.

• Verify the process variable assigned to the
mA output.

• Check the settings of Upper Range Value and
Lower Range Value. See Section 20.12.

mA output correct at
lower current, but in-
correct at higher cur-
rent

• mA loop resistance may be set too high • Verify that the mA output load resistance
is below maximum supported load (see
the installation manual for your transmit-
ter).

20.6 Frequency output problems

Frequency output problems and recommended actionsTable 20-6:   

Problem Possible causes Recommended actions

No frequency output • Stopped totalizer
• Process condition below cutoff
• Fault condition if fault action is set to in-

ternal zero or downscale
• Slug flow
• Flow in reverse direction from config-

ured flow direction parameter
• Bad frequency receiving device
• Output level not compatible with receiv-

ing device
• Bad output circuit
• Incorrect internal/external power con-

figuration
• Incorrect pulse width configuration
• Output not powered
• Wiring problem

• Verify that the process conditions are below
the low-flow cutoff. Reconfigure the low-flow
cutoff if necessary.

• Check the Fault Action settings. See 
Section 20.13.

• Verify that the totalizers are not stopped. A
stopped totalizer will cause the frequency
output to be locked.

• Check for slug flow. See Section 20.20.
• Check flow direction. See Section 20.18.
• Verify that the receiving device, and the wir-

ing between the transmitter and the receiv-
ing device.

• Verify that the channel is wired and config-
ured as a frequency output.

• Verify the power configuration for the fre-
quency output (internal vs. external).

• Check the pulse width. See Section 20.15.
• Perform a loop test. See Section 20.10.

Consistently incorrect
frequency measure-
ment

• Output not scaled correctly
• Incorrect flow measurement unit config-

ured

• Check the frequency output scaling. See 
Section 20.16.

• Verify that the measurement units are con-
figured correctly for your application.
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Frequency output problems and recommended actions (continued)Table 20-6:   

Problem Possible causes Recommended actions

Erratic frequency out-
put

• Radio frequency interference (RFI) from
environment

• Check for radio frequency interference. See 
Section 20.14.

20.7 Use sensor simulation for troubleshooting
When sensor simulation is enabled, the transmitter reports user-specified values for mass
flow, temperature, and density. This allows you to reproduce various process conditions or
to test the system.

You can use sensor simulation to help distinguish between legitimate process noise and
externally caused variation. For example, consider a receiving device that reports an
unexpectedly erratic flow value. If sensor simulation is enabled and the observed flow rate
does not match the simulated value, the source of the problem is likely to be somewhere
between the transmitter and the receiving device.

Important
When sensor simulation is active, the simulated value is used in all transmitter outputs and
calculations, including totals and inventories, volume flow calculations, and concentration
calculations. Disable all automatic functions related to the transmitter outputs and place the loop in
manual operation. Do not enable simulation mode unless your application can tolerate these effects,
and be sure to disable simulation mode when you have finished testing.

For more information on using sensor simulation, see #unique_288.

20.8 Check power supply wiring
If the power supply wiring is damaged or improperly connected, the transmitter may not
receive enough power to operate properly.

Prerequisites

You will need the installation manual for your transmitter.

Procedure

1. Before inspecting the power supply wiring, disconnect the power source.

CAUTION!

If the transmitter is in a hazardous area, wait five minutes after disconnecting the
power.

2. Verify that the correct external fuse is used.

An incorrect fuse can limit current to the transmitter and keep it from initializing.
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3. Ensure that the power supply wires are connected to the correct terminals.

4. Verify that the power supply wires are making good contact, and are not clamped to
the wire insulation.

5. Reapply power to the transmitter.

CAUTION!

If the transmitter is in a hazardous area, do not reapply power to the transmitter with
the housing cover removed. Reapplying power to the transmitter while the housing
cover is removed could cause an explosion.

6. Use a voltmeter to test the voltage at the transmitter’s power supply terminals.

The voltage should be within specified limits. For DC power, you may need to size
the cable.

20.9 Check grounding
The sensor and the transmitter must be grounded.

Prerequisites

You will need:

• Installation manual for your sensor

• Installation manual for your transmitter

Procedure

Refer to the sensor and transmitter installation manuals for grounding requirements and
instructions.

20.10 Perform loop tests
A loop test is a way to verify that the transmitter and the remote device are
communicating properly. A loop test also helps you know whether you need to trim mA
outputs.

20.10.1 Perform loop tests using ProLink II
A loop test is a way to verify that the transmitter and the remote device are
communicating properly. A loop test also helps you know whether you need to trim mA
outputs.

Prerequisites

Before performing a loop test, configure the channels for the transmitter inputs and
outputs that will be used in your application.
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Follow appropriate procedures to ensure that loop testing will not interfere with existing
measurement and control loops.

ProLink II must be running and must be connected to the transmitter.

Procedure

1. Test the mA output(s).

a. Choose ProLink > Test > Fix Milliamp 2.

b. Enter 4 mA in Set Output To.

c. Click Fix mA.

d. Read the mA current at the receiving device and compare it to the transmitter
output.

The readings do not need to match exactly. If the values are slightly different,
you can correct the discrepancy by trimming the output.

e. Click UnFix mA.

f. Enter 20 mA in Set Output To.

g. Click Fix mA.

h. Read the mA current at the receiving device and compare it to the transmitter
output.

The readings do not need to match exactly. If the values are slightly different,
you can correct the discrepancy by trimming the output.

i. Click UnFix mA.

2. Test the frequency output(s).

a. Choose ProLink > Test > Fix Freq Out.
b. Enter the frequency output value in Set Output To.

c. Click Fix Frequency.

d. Read the frequency signal at the receiving device and compare it to the
transmitter output.

e. Click UnFix Freq.

3. Test the discrete output(s).

a. Choose ProLink > Test > Fix Discrete Output.
b. Select On.

c. Verify the signal at the receiving device.

d. Select Off.
e. Verify the signal at the receiving device.

f. Click UnFix.
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Postrequisites

• If the mA output reading at the receiving device was slightly inaccurate, you can
correct this discrepancy by trimming the output.

• If the mA output reading at the receiving device was significantly inaccurate, or if at
any step the reading was faulty, verify the wiring between the transmitter and the
remote device, and try again.

• If the discrete output reading is reversed, check the setting of Discrete Output Polarity.

20.10.2 Perform loop tests using ProLink III
A loop test is a way to verify that the transmitter and the remote device are
communicating properly. A loop test also helps you know whether you need to trim mA
outputs.

Prerequisites

Before performing a loop test, configure the channels for the transmitter inputs and
outputs that will be used in your application.

Follow appropriate procedures to ensure that loop testing will not interfere with existing
measurement and control loops.

ProLink III must be running and must be connected to the transmitter.

Procedure

1. Test the mA output(s).

a. Choose Device Tools > Diagnostics > Testing > mA Output 2 Test .
b. Enter 4 in Fix to:.
c. Click Fix mA.

d. Read the mA current at the receiving device and compare it to the transmitter
output.

The readings do not need to match exactly. If the values are slightly different,
you can correct the discrepancy by trimming the output.

e. Click UnFix mA.

f. Enter 20 in Fix to:.
g. Click Fix mA.

h. Read the mA current at the receiving device and compare it to the transmitter
output.

The readings do not need to match exactly. If the values are slightly different,
you can correct the discrepancy by trimming the output.

i. Click UnFix mA.

2. Test the frequency output(s).
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a. Choose Device Tools > Diagnostics > Testing > Frequency Output Test.
b. Enter the frequency output value in Fix to.

c. Click Fix FO.

d. Read the frequency signal at the receiving device and compare it to the
transmitter output.

e. Click UnFix FO.

3. Test the discrete output(s).

a. Choose Device Tools > Diagnostics > Testing > Discrete Output Test.
b. Set Fix To: to ON.

c. Verify the signal at the receiving device.

d. Set Fix To: to OFF.

e. Verify the signal at the receiving device.

f. Click UnFix.

4. Test the discrete input.

a. Set the remote input device to ON.

b. Choose Device Tools > Diagnostics > Testing > Discrete Input Test.
c. Verify the signal at the transmitter.

d. Set the remote input device to OFF.

e. Verify the signal at the transmitter.

Postrequisites

• If the mA output reading at the receiving device was slightly inaccurate, you can
correct this discrepancy by trimming the output.

• If the mA output reading at the receiving device was significantly inaccurate, or if at
any step the reading was faulty, verify the wiring between the transmitter and the
remote device, and try again.

• If the discrete output reading is reversed, check the setting of Discrete Output Polarity.

20.10.3 Perform loop tests using the PROFIBUS EDD
A loop test is a way to verify that the transmitter and the remote device are
communicating properly. A loop test also helps you know whether you need to trim mA
outputs.

Prerequisites

Before performing a loop test, configure the channels for the transmitter inputs and
outputs that will be used in your application.

Follow appropriate procedures to ensure that loop testing will not interfere with existing
measurement and control loops.
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You must have a PROFIBUS configuration tool, the PROFIBUS EDD must be installed, and
you must be connected to the transmitter.

Procedure

1. Test mA Output 2.

a. Choose Service Tools > Simulate > mA Output Loop Test.
b. Select 4 mA and click Next.
c. Read the mA current at the receiving device and compare it to the transmitter

output.

The readings do not need to match exactly. If the values are slightly different,
you can correct the discrepancy by trimming the output.

d. Click Next.
e. Select 20 mA and click Next.
f. Read the mA current at the receiving device and compare it to the transmitter

output.

The readings do not need to match exactly. If the values are slightly different,
you can correct the discrepancy by trimming the output.

g. Click Next.
h. Click End.

2. Test the frequency output.

a. Choose Service Tools > Simulate > Frequency Output Test.
b. Select 10 kHz and click Next.
c. Read the frequency signal at the receiving device and compare it to the

transmitter output.

d. Click Next.
e. Click End.

3. Test Discrete Output 1.

a. Choose Service Tools > Simulate > Discrete Output.
b. Select On and click Next.
c. Verify the signal at the receiving device.

The discrete output is ON. The actual voltage is determined by the setting of
Discrete Output Polarity.

d. Click Next.
e. Select Off and click Next.
f. Verify the signal at the receiving device.
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The discrete output is OFF. The actual voltage is determined by the setting of
Discrete Output Polarity.

g. Click Next.
h. Click End.

4. Test Precision Discrete Output 1.

a. Choose Service Tools > Simulate > Discrete Output Test > Precision Discrete Output 1.

b. Select On and click Next.
c. Verify the signal at the receiving device.

The discrete output is ON. The actual voltage is determined by the setting of
Precision Discrete Output 1 Polarity.

d. Click Next.
e. Select Off and click Next.
f. Verify the signal at the receiving device.

The discrete output is OFF. The actual voltage is determined by the setting of
Precision Discrete Output 1 Polarity.

g. Click Next.
h. Click End.

5. Test Precision Discrete Output 2.

a. Choose Service Tools > Simulate > Discrete Output Test > Precision Discrete Output 2.

b. Select On and click Next.
c. Verify the signal at the receiving device.

The discrete output is ON. The actual voltage is determined by the setting of
Precision Discrete Output 2 Polarity.

d. Click Next.
e. Select Off and click Next.
f. Verify the signal at the receiving device.

The discrete output is OFF. The actual voltage is determined by the setting of
Precision Discrete Output 2 Polarity.

g. Click Next.
h. Click End.

20.10.4 Perform loop tests using PROFIBUS bus parameters
A loop test is a way to verify that the transmitter and the remote device are
communicating properly. A loop test also helps you know whether you need to trim mA
outputs.
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Tip
Loop tests are not required. However, Micro Motion recommends performing a loop test for every
input or output available on your transmitter. The inputs and outputs available on your transmitter
vary according to your purchase option and your channel configuration. You may not need to
perform all of the loop tests described here.

Prerequisites

You must have a PROFIBUS configuration tool that supports DP-V1 read and write services,
and you must be connected to the transmitter.

Before performing a loop test, configure the channels for the transmitter inputs and
outputs that will be used in your application.

Follow appropriate procedures to ensure that loop testing will not interfere with existing
measurement and control loops.

Procedure

1. Test mA Output 2.

a. Write 4 to the Filling block, Index 51.

b. Write 1 to the Filling block, Index 50.

c. Read the mA current at the receiving device and compare it to the transmitter
output.

The readings do not need to match exactly. If the values are slightly different,
you can correct the discrepancy by trimming the output.

d. Write 20 to the Filling block, Index 51.

e. Write 1 to the Filling block, Index 50.

f. Read the mA current at the receiving device and compare it to the transmitter
output.

The readings do not need to match exactly. If the values are slightly different,
you can correct the discrepancy by trimming the output.

g. Write 0 to the Filling block, Index 50.

2. Test the frequency output(s).

a. Write the test value to the Filling block, Index 68.

b. Write 1 to the Filling block, Index 67.

c. Read the frequency signal at the receiving device and compare it to the
transmitter output.

d. Write 0 to the Filling block, Index 67.

3. Test Discrete Output 1.

a. Write 1 to the Filling block, Index 74.

b. Write 1 to the Filling block, Index 73.
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c. Verify the signal at the receiving device.

The discrete output is ON. The actual voltage is determined by the setting of
Discrete Output Polarity.

d. Write 0 to the Filling block, Index 74.

e. Write 1 to the Filling block, Index 73.

f. Verify the signal at the receiving device.

The discrete output is OFF. The actual voltage is determined by the setting of
Discrete Output Polarity.

g. Write 0 to the Filling block, Index 73.

4. Test Precision Discrete Output 1.

a. Write 1 to the Filling block, Index 88.

b. Write 1 to the Filling block, Index 87.

c. Verify the signal at the receiving device.

The discrete output is ON. The actual voltage is determined by the setting of
Precision Discrete Output 1 Polarity.

d. Write 0 to the Filling block, Index 88.

e. Write 1 to the Filling block, Index 87.

f. Verify the signal at the receiving device.

The discrete output is OFF. The actual voltage is determined by the setting of
Precision Discrete Output 1 Polarity.

g. Write 0 to the Filling block, Index 87.

5. Test Precision Discrete Output 2.

a. Write 1 to the Filling block, Index 90.

b. Write 1 to the Filling block, Index 89.

c. Verify the signal at the receiving device.

The discrete output is ON. The actual voltage is determined by the setting of
Precision Discrete Output 2 Polarity.

d. Write 0 to the Filling block, Index 90.

e. Write 1 to the Filling block, Index 89.

f. Verify the signal at the receiving device.

The discrete output is OFF. The actual voltage is determined by the setting of
Precision Discrete Output 2 Polarity.

g. Write 0 to the Filling block, Index 89.

Postrequisites

• If the mA output reading at the receiving device was slightly inaccurate, you can
correct this discrepancy by trimming the output.
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• If the mA output reading at the receiving device was significantly inaccurate, or if at
any step the reading was faulty, verify the wiring between the transmitter and the
remote device, and try again.

• If the discrete output reading is reversed, check the setting of Discrete Output Polarity.

20.11 Trim mA outputs
Trimming an mA output calibrates the transmitter's mA output to the receiving device. If
the current trim values are inaccurate, the transmitter will under-compensate or over-
compensate the output.

20.11.1 Trim mA outputs using ProLink II
Trimming the mA output establishes a common measurement range between the
transmitter and the device that receives the mA output.

Important
You must trim the output at both ends (4 mA and 20 mA) to ensure that it is compensated
accurately across the entire output range.

Prerequisites

Ensure that the mA output is wired to the receiving device that will be used in production.

Procedure

1. Choose ProLink > Calibration > Milliamp 2 Trim .

2. Follow the instructions in the guided method.

3. Check the trim values, and contact Micro Motion customer service if any value is less
than −200 microamps or greater than +200 microamps.

20.11.2 Trim mA outputs using ProLink III
Trimming the mA output establishes a common measurement range between the
transmitter and the device that receives the mA output.

Important
You must trim the output at both ends (4 mA and 20 mA) to ensure that it is compensated
accurately across the entire output range.

Prerequisites

Ensure that the mA output is wired to the receiving device that will be used in production.
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Procedure

1. Choose Device Tools > Calibration > MA Output Trim > mA Output 2 Trim.

2. Follow the instructions in the guided method.

3. Check the trim values, and contact Micro Motion customer service if any value is less
than −200 microamps or greater than +200 microamps.

20.11.3 Trim mA outputs using the PROFIBUS EDD
Trimming the mA output establishes a common measurement range between the
transmitter and the device that receives the mA output.

Important
You must trim the output at both ends (4 mA and 20 mA) to ensure that it is compensated
accurately across the entire output range.

Prerequisites

Ensure that the mA output is wired to the receiving device that will be used in production.

Procedure

1. Choose Service Tools > Maintenance > mA Output Trim.

2. Follow the instructions in the guided method.

3. Check the trim values, and contact Micro Motion customer service if any value is less
than −200 microamps or greater than +200 microamps.

20.11.4 Trim mA outputs using PROFIBUS bus parameters
Trimming the mA output establishes a common measurement range between the
transmitter and the device that receives the mA output.

Important
You must trim the output at both ends (4 mA and 20 mA) to ensure that it is compensated
accurately across the entire output range.

Prerequisites

Ensure that the mA output is wired to the receiving device that will be used in production.

Procedure

1. Trim mA Output 2 at 4 mA.

a. Write 4 to the Filling block, Index 51.

b. Write 1 to the Filling Block, Index 53.

c. Read the output level at the remote device.
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d. Write the output level from the previous step to the Filling block, Index 52.

e. Write 1 to the Filling Block, Index 53.

f. Read the output level at the remote device.

g. If the transmitter's output is close enough to the output at the remote device,
write 0 to the Filling block, Index 53. Continue with the 20 mA trim.

h. If the transmitter's output is not close enough to the output at the remote
device, repeat Steps 1c through 1e.

2. Trim mA Output 2 at 20 mA.

a. Write 1 to the Filling Block, Index 55.

b. Read the output level at the remote device.

c. Write the output level from the previous step to the Filling block, Index 52.

d. Write 1 to the Filling Block, Index 55.

e. Read the output level at the remote device.

f. If the transmitter's output is close enough to the output at the remote device,
write 0 to the Filling block, Index 53. The trim is complete.

g. If the transmitter's output is not close enough to the output at the remote
device, repeat Steps 2c through 2e.

3. Check the trim values, and contact Micro Motion customer service if any value is less
than −200 microamps or greater than +200 microamps.

20.12 Check Lower Range Value and Upper Range
Value
If the process conditions fall below the configured Lower Range Value (LRV) or rise above the
configured Upper Range Value (URV), the transmitter outputs may send unexpected values.

1. Make a note of your current process conditions.

2. Check the configuration of the LRV and URV.

20.13 Check mA Output Fault Action
mA Output Fault Action controls the behavior of the mA output if the transmitter encounters
an internal fault condition. If the mA output is reporting a constant value below 4 mA or
above 20 mA, the transmitter may be in a fault condition.

1. Check the status alarms for active fault conditons.

2. If there are active fault conditions, the transmitter is performing correctly. If you
want to change its behavior, consider the following options:

• Change the setting of mA Output Fault Action.

• For the relevant status alarms, change the setting of Alarm Severity to Ignore.

3. If there are no active fault conditions, continue troubleshooting.
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20.14 Check for radio frequency interference (RFI)
The transmitter's frequency output or discrete output can be affected by radio frequency
interference (RFI). Possible sources of RFI include a source of radio emissions, or a large
transformer, pump, or motor that can generate a strong electromagnetic field. Several
methods to reduce RFI are available. Use one or more of the following suggestions, as
appropriate to your installation.

Procedure

• Eliminate the RFI source.

• Move the transmitter.

• Use shielded cable for the frequency output or discrete output.

- Terminate the shielding at the output device. If this is impossible, terminate the
shielding at the cable gland or conduit fitting.

- Do not terminate the shielding inside the wiring compartment.

- 360-degree termination of shielding is unnecessary.

20.15 Check Frequency Output Maximum Pulse
Width
If Frequency Output Maximum Pulse Width is set incorrectly, the frequency output may report an
incorrect value.

Verify the configuration of Frequency Output Maximum Pulse Width.

For most applications, the default value for Frequency Output Maximum Pulse Width is
appropriate. This corresponds to a 50% duty cycle.

20.16 Check Frequency Output Scaling Method
If Frequency Output Scaling Method is set incorrectly, the frequency output may report an
incorrect value.

1. Verify the configuration of Frequency Output Scaling Method.

2. If you changed the setting of Frequency Output Scaling Method, check the settings of all
other frequency output parameters.

20.17 Check Frequency Output Fault Action
The Frequency Output Fault Action controls the behavior of the frequency output if the
transmitter encounters an internal fault condition. If the frequency output is reporting a
constant value, the transmitter may be in a fault condition.
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1. Check the status alarms for active fault conditons.

2. If there are active fault conditions, the transmitter is performing correctly. If you
want to change its behavior, consider the following options:

• Change the setting of Frequency Output Fault Action.

• For the relevant status alarms, change the setting of Alarm Severity to Ignore.

3. If there are no active fault conditions, continue troubleshooting.

20.18 Check Flow Direction
If Flow Direction is set inappropriately for your process, the transmitter may report
unexpected flow values or totals.
The Flow Direction parameter interacts with actual flow direction to affect flow values, flow
totals and inventories, and output behavior. For the simplest operation, actual process
flow should match the flow arrow that is on the side of the sensor case.

Procedure

1. Verify the actual direction of process flow through the sensor.

2. Verify the configuration of Flow Direction.

20.19 Check the cutoffs
If the transmitter cutoffs are configured incorrectly, the transmitter may report zero flow
when flow is present, or very small amounts of flow under no-flow conditions.

There are separate cutoff parameters for mass flow rate, volume flow rate, gas standard
volume flow rate (if applicable), and density. There is an independent cutoff for each mA
output on your transmitter. The interaction between cutoffs sometimes produces
unexpected results.

Procedure

Verify the configuration of the cutoffs.

Tip
For typical applications, Micro Motion recommends setting Mass Flow Cutoff to the zero stability value
for your sensor, multiplied by 10. Zero stabiliy values can be found in the Product Data Sheet for your
sensor.

20.20 Check for slug flow (two-phase flow)
Slug flow (two-phase flow, entrained gas) can cause spikes in the drive gain. This may
cause the transmitter to report zero flow, or to post several different alarms.

1. Check for slug flow alarms.
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If the transmitter is not generating slug flow alarms, slug flow is not the source of
your problem.

2. Check the process for cavitation, flashing, or leaks.

3. Monitor the density of your process fluid output under normal process conditions.

4. Check the settings of Slug Low Limit, Slug High Limit, and Slug Duration.

Tip
You can reduce the occurrence of slug flow alarms by setting Slug Low Limit to a lower value,
Slug High Limit to a higher value, or Slug Duration to a higher value.

20.21 Check the drive gain
Excessive or erratic drive gain may indicate any of a variety of process conditions, sensor
problems, or configuration problems.

To know whether your drive gain is excessive or erratic, you must collect drive gain data
during the problem condition and compare it to drive gain data from a period of normal
operation.

Excessive (saturated) drive gain

Possible causes and recommended actions for excessive (saturated)
drive gain

Table 20-7:   

Possible cause Recommended actions

Slug flow Check for slug flow. See Section 20.20.

Partially filled flow tube Correct process conditions so that the flow tubes are full.

Plugged flow tube Check the pickoff voltages (see Section 20.22). If either of them are
close to zero (but neither is zero), plugged tubes may be the source
of your problem. Purge the tubes. In extreme cases, you may need
to replace the sensor.

Cavitation, flashing, or air en-
trainment; settling of two- or
three-phase fluids

• Increase the inlet or back pressure at the sensor.
• If a pump is located upstream from the sensor, increase the dis-

tance between the pump and sensor.
• The sensor may need to be reorientated. Consult the installa-

tion manual for your sensor for recommended orientations.

Drive board or module failure Contact Micro Motion.

Bent flow tube Check the pickoff voltages (see Section 20.22). If either of them are
close to zero (but neither is zero), the flow tubes may be bent. The
sensor will need to be replaced.

Cracked flow tube Replace the sensor.

Sensor imbalance Contact Micro Motion.

Mechanical binding at sensor Ensure sensor is free to vibrate.
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Possible causes and recommended actions for excessive (saturated)
drive gain (continued)

Table 20-7:   

Possible cause Recommended actions

Open drive or left pickoff sen-
sor coil

Contact Micro Motion.

Flow rate out of range Ensure that flow rate is within sensor limits.

Incorrect sensor characteriza-
tion

Verify the characterization parameters.

Erratic drive gain

Possible causes and recommended actions for erratic drive gainTable 20-8:   

Possible cause Recommended actions

Wrong K1 characterization constant for sensor Verify the K1 characterization parameter.

Polarity of pick-off reversed or polarity of drive reversed Contact Micro Motion.

Slug flow Check for slug flow. See Section 20.20.

Foreign material caught in flow tubes • Purge the flow tubes.
• Replace the sensor.

20.21.1 Collect drive gain data

ProLink II ProLink > Diagnostic Information

ProLink III Device Tools > Diagnostics > Core Processor Diagnostics

PROFIBUS EDD Service Tools > Maintenance > Diagnostic Variables

PROFIBUS bus pa-

rameters

Block: Diagnostics, Index 32

Overview

Drive gain data can be used to diagnose a variety of process and equipment conditions.
Collect drive gain data from a period of normal operation, and use this data as a baseline
for troubleshooting.

Procedure

1. Navigate to the drive gain data.

2. Observe and record drive gain data over an appropriate period of time, under a
variety of process conditions.
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20.22 Check the pickoff voltage
If the pickoff voltage readings are unusually low, you may have any of a variety of process
or equipment problems.

To know whether your pickoff voltage is unusually low, you must collect pickoff voltage
data during the problem condition and compare it to pickoff voltage data from a period of
normal operation.

Possible causes and recommended actions for low pickoff voltageTable 20-9:   

Possible cause Recommended actions

Air entrainment • Increase the inlet or back pressure at the sensor.
• If a pump is located upstream from the sensor, increase the

distance between the pump and sensor.
• The sensor may need to be reoriented. Consult the installa-

tion manual for your sensor for recommended orientations.

Faulty wiring runs between the
sensor and transmitter

Verify wiring between sensor and transmitter.

Process flow rate beyond the lim-
its of the sensor

Verify that the process flow rate is not out of range of the sen-
sor.

Slug flow Check for slug flow. See Section 20.20.

No tube vibration in sensor • Check for plugging.
• Ensure sensor is free to vibrate (no mechanical binding).
• Verify wiring.

Moisture in the sensor electron-
ics

Eliminate the moisture in the sensor electronics.

The sensor is damaged, or sensor
magnets may have become de-
magnetized

Replace the sensor.

20.22.1 Collect pickoff voltage data

ProLink II ProLink > Diagnostic Information

ProLink III Device Tools > Diagnostics > Core Processor Diagnostics

PROFIBUS EDD Service Tools > Maintenance > Diagnostic Variables

PROFIBUS bus pa-

rameters

Left pickoff voltage: Block: Diagnostics, Index 35

Right pickoff voltage: Block: Diagnostics, Index 36

Overview

Pickoff voltage data can be used to diagnose a variety of process and equipment
conditions. Collect pickoff voltage data from a period of normal operation, and use this
data as a baseline for troubleshooting.
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Procedure

1. Navigate to the pickoff voltage data.

2. Observe and record data for both the left pickoff and the right pickoff, over an
appropriate period of time, under a variety of process conditions.

20.23 Check for electrical shorts
Shorts between sensor terminals or between the sensor terminals and the sensor case can
cause the sensor to stop working.

Possible causes and recommended actions for electrical shortsTable 20-10:   

Possible cause Recommended action

Moisture inside the junction box Ensure that the junction box is dry and no corrosion is
present.

Liquid or moisture inside the sensor
case

Contact Micro Motion.

Internally shorted feedthrough Contact Micro Motion.

Faulty cable Replace the cable.

Improper wire termination Verify wire terminations inside sensor junction box. The
Micro Motion document titled 9-Wire Flowmeter Cable Prepa-
ration and Installation Guide may offer some assistance.
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Appendix A
Default values and ranges

A.1 Default values and ranges
The default values and ranges represent the typical factory transmitter configuration.
Depending on how the transmitter was ordered, certain values may have been configured
at the factory and are not represented in the default values and ranges. These values also
apply to external-valve-control fills. For default values for integrated-valve-control fills, see 
Section 5.2.1.

Transmitter default values and rangesTable A-1:   

Type Parameter Default Range Comments

Flow Flow direction Forward

Flow damping 0.04 sec 0.0 – 40.96 sec User-entered value is corrected
to nearest lower value in list of
preset values. For filling applica-
tions, Micro Motion recom-
mends the default value.

Mass flow units g/s

Mass flow cutoff 0.0 g/s Recommended setting is 5% of
the sensor’s rated maximum
flowrate.

Volume flow units L/s

Volume flow cutoff 0/0 L/s 0.0 – x L/s x is obtained by multiplying the
flow calibration factor by 0.2, us-
ing units of L/s.

Meter factors Mass factor 1

Density factor 1

Volume factor 1

Density Density damping 1.28 sec 0.0 – 40.96 sec User-entered value is corrected
to nearest value in list of preset
values.

Density units g/cm3

Density cutoff 0.2 g/cm3 0.0 – 0.5 g/cm3

D1 0

D2 1

K1 1000

Default values and ranges
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Transmitter default values and ranges (continued)Table A-1:   

Type Parameter Default Range Comments

K2 50,000.00

FD 0

Temp Coefficient 4.44

Slug flow Slug flow low limit 0.0 g/cm3 0.0 – 10.0
g/cm3

Slug flow high limit 5.0 g/cm3 0.0 – 10.0
g/cm3

Slug duration 0.0 sec 0.0 – 60.0 sec

Temperature Temperature damping 4.8 sec 0.0 – 38.4 sec User-entered value is corrected
to nearest lower value in list of
preset values.

Temperature units Deg C

Temperature calibration factor 1.00000T0.00
00

Pressure Pressure units PSI

Flow factor 0

Density factor 0

Cal pressure 0

Special units (1) Base mass unit g

Base mass time sec

Mass flow conversion factor 1

Base volume unit L

Base volume time sec

Volume flow conversion factor 1

mA output Secondary variable Mass flow

LRV –200.00000
g/s

URV 200.00000 g/s

AO cutoff 0.00000 g/s

AO added damping 0.00000 sec

LSL –200 g/s Read-only.

LSL and USL are calculated based
on the sensor size and character-
ization parameters.

USL 200 g/s

MinSpan 0.3 g/s Read-only

Fault action Downscale

AO fault level – downscale 2.0 mA 0.0 – 3.6 mA

(1) Not supported by PROFIBUS-DP.
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Transmitter default values and ranges (continued)Table A-1:   

Type Parameter Default Range Comments

AO fault level – upscale 22 mA 21.0 – 24.0 mA

Last measured value timeout 0.00 sec

LRV Mass flow rate −200.000 g/s

Volume flow rate −0.200 L/s

Density 0.000 g/cm3

Temperature −240.000 °C

Drive gain 0.000%

Gas standard volume flow rate −423.78 SCFM

External temperature −240.000 °C

External pressure 0.000 psi

URV Mass flow rate 200.000 g/s

Volume flow rate 0.200 L/s

Density 10.000 g/cm3

Temperature 450.000 °C

Drive gain 100.000%

Gas standard volume flow rate 423.78 SCFM

External temperature 450.000 °C

External pressure 100.000 psi

Frequency out-
put

Tertiary variable Mass flow

Frequency factor 1,000.00 Hz .00091 –
10,000.00 Hz

Rate factor 16,666.66992
g/s

Frequency pulse width 0 (50% duty cy-
cle)

0.01 – 655.35
millisec

Scaling method Freq=Flow

Frequency fault action Downscale

Frequency fault level – upscale 15,000 Hz 10.0 – 15,000
Hz

Frequency output polarity Active high

Last measured value timeout 0.0 seconds 0.0 – 60.0 sec

Discrete out-
put

Assignment Fault

Fault Indicator None

Power Internal

Polarity Active High

Discrete input Assignment None
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Transmitter default values and ranges (continued)Table A-1:   

Type Parameter Default Range Comments

Polarity Active Low
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Appendix B
Using ProLink II with the transmitter

Topics covered in this appendix:

• Basic information about ProLink II

• Menu maps for ProLink II

B.1 Basic information about ProLink II
ProLink II is a software tool available from Micro Motion. It runs on a Windows platform and
provides complete access to transmitter functions and data.

ProLink II requirements

The transmitter requires ProLink II v2.91 or later.

To install ProLink II, you must have:

• The ProLink II installation media

• The ProLink II installation kit for your connection type

To obtain ProLink II and the appropriate installation kit, contact Micro Motion.

ProLink II documentation

Most of the instructions in this manual assume that you are already familiar with ProLink II
or that you have a general familiarity with Windows programs. If you need more
information than this manual provides, see the ProLink II manual (ProLink® II Software for
Micro Motion® Transmitters: Installation and Use Manual).

In most ProLink II installations, the manual is installed with the ProLink II program.
Additionally, the ProLink II manual is available on the Micro Motion documentation CD or
the Micro Motion web site (www.micromotion.com).

ProLink II features and functions

ProLink II offers complete transmitter configuration and operation functions. ProLink II also
offers a number of additional features and functions, including:

• The ability to save the transmitter configuration set to a file on the PC, and reload it
or propagate it to other transmitters

• The ability to log specific types of data to a file on the PC

• A commissioning wizard

• A proving wizard

• A gas wizard

These features are documented in the ProLink II manual. They are not documented in the
current manual.

Using ProLink II with the transmitter
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ProLink II messages

As you use ProLink II with a Micro Motion transmitter, you will see a number of messages
and notes. This manual does not document all of these messages and notes.

Important
The user is responsible for responding to messages and notes and complying with all safety
messages.

B.2 Menu maps for ProLink II

Main menuFigure B-1:   

File

Preferences
· Use External Temperature
· Enable Inventory Totals Reset
· Enable External Pressure Compensation
· Copper RTD

Installed options

Data LoggingLoad from Xmtr to File
Send to Xmtr from File

License

Connect to Device
Connect to Densitometer/ Viscometer
Disconnect

View Connection

Options
· ProLink II Language
· Error Log On

Tools Plug-insProLink

Configuration
Output Levels
Process Variables
Status
Alarm Log
Diagnostic Information
Calibration
Test
Totalizer Control
Core Processor Diagnostics
Batcher Control
Run Filler

Calibration
· Zero Calibration
· Milliamp 2 Trim
· Density Cal – Point 1
· Density Cal – Point 2
· Density Cal – Flowing Density
· Density Cal – Point 3
· Density Cal – Point 4
· Temp Offset Cal

Test
· Fix Freq Output
· Fix Milliamp 2
· Fix Discrete Output
· Read Discrete Input

See Fill Operation menu map.

Using ProLink II with the transmitter
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Fill configuration menuFigure B-2:   

Filling

Flow Source

Filling Control Options
· Enable Filling Option
· Count Up
· Enable Dual Fill
· Enable AOC
· Enable Purge
· Enable Timed Fill
· Enable Fill Logging
· AOC Change Limit
· AOC Convergence Rate
· Fill Type
· Configure By
· Fill Target
· Max Fill Time
· Purge Mode
· Target Time
· Measured Fill Time
· Pump to Valve Delay
· Purge Delay
· Purge Time
· AOC Algorithm
· AOC Window Length
· Fixed Overshoot Comp

Discrete Valves for 2 Stage Filling
· Open Primary
· Open Secondary
· Close Primary
· Close Secondary

Discrete Output

Discrete Output 1
· DO1 Assignment
· DO1 Polarity
· DO1 Fault Action

Precision Discrete Outputs
· Precision DO1
· Precision DO2
· Precision DO1 Polarity 
· Precision DO2 Polarity

Configuration

ProLink Menu

Using ProLink II with the transmitter
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Fill operation menuFigure B-3:   

Filling

Fill Setup
· Current Total
· Percent Fill
· Current Target
· Reset Fill Total
· AOC Coeff
· Secondary AOC Coeff
· Target Time

Fill Control
· Begin Filling
· Pause Filling
· Resume Filling
· End Filling
· Begin Purge
· End Purge
· Begin Cleaning
· End Cleaning

AOC Calibration
· Start AOC Cal
· Save AOC Cal
· Override Blocked Start
· Reset AOC Flow Rate
· Start Sec AOC Cal
· Save Sec AOC Cal

Fill Statistics

Fill Data

Fill Status

ProLink

Configuration
Output Levels
Process Variables
Status
Alarm Log
Diagnostic Information
Calibration
Test
Totalizer Control
Core Processor Diagnostics
Batcher Control
Run Filler

· Fill Total Average
· Fill Total Variance
· Secondary Fill Total Average
· Secondary Fill Total Variance
· Reset Fill Statistics

· Max Fill Time Exceeded
· Filling In Progress
· Secondary Fill In Progress
· Cleaning In Progress
· Purge In Progress
· Purge Delay Phase
· Primary Valve
· Secondary Valve
· Pump
· Purge Valve
· AOC Flow Rate Too High
· AOC Calibration Active
· Start Not Okay

· Fill Time
· Fill Count
· Reset Fill Count

Using ProLink II with the transmitter
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Configuration menuFigure B-4:   

Configuration

ProLink Menu

Flow

· Flow Direction
· Flow Damp
· Flow Cal
· Mass Flow Cutoff
· Mass Flow Units
· Vol Flow Cutoff
· Vol Flow Units
· Mass Factor
· Dens Factor
· Vol Factor

Density

· Density Units
· Density Damping
· Slug High Limit
· Slug Low Limit
· Slug Duration
· Low Density Cutoff
· K1
· K2
· FD
· D1
· D2
· Temp Coeff (DT)

Temperature

· Temp Units
· Temp Cal Factor
· Temp Damping
· External Temperature

Pressure

· Flow Factor
· Dens Factor
· Cal Pressure
· Pressure Units
· External Pressure

Sensor

· Sensor s/n
· Sensor Model
· Sensor Matl
· Liner Matl
· Flange

Special Units

· Base Mass Unit
· Base Mass Time
· Mass Flow Conv Fact
· Mass Flow Text
· Mass Total Text
· Base Vol Unit
· Base Vol Time
· Vol Flow Conv Fact
· Vol Flow Text
· Vol Total Text

T Series

· FTG
· FFQ
· DTG
· DFQ1
· DFQ2
· K3
· D3
· D4
· K4

Analog Output

· Secondary Variable 
is

· Lower Range Value
· Upper Range Value
· AO Cutoff
· AO Added Damp
· Lower Sensor Limit
· Upper Sensor Limit
· Min Span
· AO Fault Action
· AO Fault Level
· Last Measured 

Value Timeout

Using ProLink II with the transmitter
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Configuration menu (continued)Figure B-5:   

Device

· Model 
· Hardware Rev
· Software Rev
· Option Board
· Manufacturer
· Distributor
· ETO
· Tag
· Date
· Descriptor
· Message
· Sensor Type
· Transmitter Serial
· Floating Pt Ordering
· Add Comm Resp Delay

Digital Comm Settings
· Digital Comm Fault Setting
· Device ID
· Modbus Address
· Response Time

Discrete Events

· Event Name
· Event Type
· Process Variable 
· Low Setpoint
· High Setpoint

Channel

Channel B
· Type Assignment

Alarm

· Alarm 
· Severity

Sensor Simulation

· Enable Simulation 
Mode

· Mass Flow
· Density
· Temperature

Discrete Input

Assignment
· Reset Mass Total
· Reset Volume Total
· Reset All Totals
· Begin Fill
· End Fill
· Resume Fill
· Pause Fill

Polarity

Frequency

· Tertiary Variable
· Freq Factor
· Rate Factor
· Freq Pulse Width
· Last Measured Value 

Timeout
· Scaling Method
· Freq Fault Action
· Freq Output Polarity

Configuration

ProLink Menu

Using ProLink II with the transmitter
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Appendix C
Setting up and using the PROFIBUS interfaces

Topics covered in this appendix:

• PROFIBUS-DP functionality supported by transmitter

• Options for PROFIBUS communications

• Menu maps for the PROFIBUS EDD

• Set up the GSD

• Use PROFIBUS bus parameters

C.1 PROFIBUS-DP functionality supported by
transmitter
The transmitter functions as a standard PROFIBUS-DP node, and can be integrated with all
standard PROFIBUS-DP networks.

The transmitter supports the following PROFIBUS-DP functionality:

• Network speeds: The transmitter automatically detects the network speed and
responds to all standard baud rates between 9.6 kbits/sec and 12.0 Mbits/sec

• I/O slave messaging:

- Cyclic

- Acyclic

• Configuration methods:

- Node address via hardware switches

- Device description (EDD) conforming to the following: Specification for PROFIBUS
Device Description and Device Integration: Volume 2: EDDL V1.2, December 2005

- DP-V1 read and write services with PROFIBUS bus parameters

• Operation methods:

- GSD conforming to the following: Specification for PROFIBUS Device Description
and Device Integration: Volume 1: GSD V5.1, July 2008

- DP-V0 cyclic services

- Device description listed above

- DP-V1 read and write services (MS1 and MS2) with PROFIBUS bus parameters

• Identification and maintenance (I&M) functions as specified in Profile Guidelines Part
1: Identification & Maintenance Functions Version 1.2, October 2009:

- I&M 0

- I&M 1

Setting up and using the PROFIBUS interfaces
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C.2 Options for PROFIBUS communications
The transmitter supports both DP-V0 and DP-V1 services. The parameters supported
through DP-V0 services are a subset of the parameters supported through DP-V1 services.
Typically, DP-V1 services are used for transmitter calibration and troubleshooting.

PROFIBUS communications methodsTable C-1:   

Communications type Interface option Functions

Cyclic GSD (Generic Station De-
scription)

• Retrieving process data and alarms
• Stopping, starting, and resetting totalizers
• Sending external pressure or temperature data to the

transmitter

Acyclic EDD (Enhanced Device De-
scription)

• Viewing process data and alarms
• Stopping, starting, and resetting totalizers
• Configuring the transmitter
• Viewing event status
• Performing zero, density, and temperature calibration

Bus parameters Complete configuration, operation, and maintenance in-
terface

C.3 Menu maps for the PROFIBUS EDD

Main menuFigure C-1:   

Online

Overview Configure Service Tools

Setting up and using the PROFIBUS interfaces
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Overview menuFigure C-2:   

Online > 
    Overview

Device Information
· Identification
· Revisions
· Materials of 

Construction

Variables
· Process Variables
· External Variables
· Outputs

Totalizer Control
· Start
· Stop
· Reset All
· Reset Total (Mass)
· Reset Total (Volume)

Fill Control

Zero Calibration
· Zero Time
· Perform Auto Zero
· Restore Factory Zero

Trends
· Process Variables
· Diagnostics Variables

Setting up and using the PROFIBUS interfaces
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Fill Control menuFigure C-3:   

Online > 
    Overview >
        Fill Control

Fill Variables
· Current Total
· Percent Fill

Setup
· Fill Target
· Target Time

Alerts

Fill Control
· Reset Fill Total
· Begin Filling
· End Filling
· Pause Filling
· Resume Filling
· Begin Cleaning
· End Cleaning
· Begin Secondary Filling
· End Secondary Filling
· Begin Purge
· End Purge
· Override Blocked Start

· View Active Alerts

Fill Statistics
· Fill Count
· Fill Total Average
· Fill Total Variance
· Secondary Fill Totals 

Average
· Secondary Fill Totals 

Variance
· Reset Fill Count
· Reset Fill Statistics

AOC Variables
· Primary AOC Coefficient
· Secondary AOC 

Coefficient

Control
· Start AOC Cal
· Save AOC Cal
· Start Secondary AOC Cal
· Save Secondary AOC Cal
· Reset AOC Flow Rate

Fill Control Fill Statistics AOC Control

Alerts
· AOC Flow Rate Too High
· Cleaning In Progress
· Training Primary AOC
· Filling In Progress
· Training Secondary AOC
· Secondary Fill In Progress
· Purge In Progress
· Automatic Purge Delay State

Setting up and using the PROFIBUS interfaces
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Configure menuFigure C-4:   

Online > 
    Configure

Guided Setup
· Sensor
· Zero Calibration
· Filling
· Inputs/Outputs
· mA Output Trim

Manual Setup Alert Setup

Inputs/Outputs Fault 
Actions

mA Output
· Fault Action
· Fault Level

Frequency Output
· Fault Action
· Fault Level

Digital Communications
· Fault Action

Alert Severity
· Fault Timeout
· Change Alert Severity
· View Alert Severity

Discrete Events
· Setup Event Trigger
· Assign Discrete Action
· Read Discrete Action 

Assignment
· Review All Discrete 

Actions

Setting up and using the PROFIBUS interfaces
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Manual Setup menuFigure C-5:   

Online > 
    Configure >
        Manual Setup

Measurements Informational Parameters

Filling Inputs/Outputs
· Channels
· mA Output
· Discrete Input
· Discrete Output
· Frequency Output

Characterize

Filling Configuration
· Fill Configuration
· Secondary Fill

AOC Configuration Purge Configuration

Setting up and using the PROFIBUS interfaces
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Measurements menuFigure C-6:   

Online > 
    Configure >
        Manual Setup >
            Measurements

Temperature
· Temperature Unit
· Temperature Damping

Advanced Setup
· External Compensation

Flow
· Flow Direction
· Flow Damping
· Mass Flow Cutoff
· Mass Flow Unit
· Mass Factor
· Volume Flow Cutoff
· Volume Flow Unit
· Volume Factor

Density
· Density Unit
· Density Damping
· Density Cutoff
· Density Factor
· Slug Duration
· Slug Low Limit
· Slug High Limit

Setting up and using the PROFIBUS interfaces
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Filling menuFigure C-7:   

Online > 
    Configure >
        Manual Setup >
            Filling

Fill Type
· Enable Dual Fill
· Enable Timed Fill
· Enable Fill Logging

Basic Fill Settings
· Count Direction
· Flow Source
· Max Fill Time
· Pump to Valve Delay
· Configure By
· Fill Target
· Target Time

Advanced Fill Settings
· Measured Fill Time
· Fill Type
· Open Primary
· Open Secondary
· Close Primary
· Close Secondary

· Output

· Discrete Input

Discrete Output
· Assignment
· Polarity
· Fault Action
· Fixed DO
· DO Fixed Value

Precision Output
· Precision DO1
· Precision DO1 Polarity
· Precision DO2
· Precision DO2 Polarity

Discrete Input
· Begin Fill
· End Fill
· Pause Fill
· Resume Fill
· Reset Mass Total
· Reset Volume Total
· Reset All Totals
· DI1 Polarity

Filling Configuration
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AOC and Purge Configuration menusFigure C-8:   

Online > 
    Configure >
        Manual Setup >
            Filling

Setting
· AOC Algorithm
· AOC Change Limit
· AOC Convergence Rate
· Fixed Overshoot Comp
· AOC Window Length
· Primary AOC Coefficient
· Secondary AOC Coefficient

Mode
· Enable AOC

AOC Configuration Purge Configuration

Setting
· Purge Mode
· Purge Purge
· Purge Time

Mode
· Enable Purge

Service Tools menuFigure C-9:   

Online > 
    Service Tools

Alerts
· Acknowledge All 

Alerts
· Alert List

Trends
· Process Variables
· Diagnostic Variables

Variables
· Process Variables
· External Variables
· Outputs

Maintenance

Simulate
· mA Output Loop Test
· Frequency Output Test
· Discrete Output Test
· Precision Discrete Output 1
· Precision Discrete Output 2
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Maintenance menuFigure C-10:   

Online > 
    Service Tools >
        Maintenance

Maintenance
· mA Output Trim

Density Calibrations
· First Point Calibration
· Second Point Calibration
· Third Point Calibration
· Fourth Point Calibration
· Flow Density Calibration

Zero Calibration
· Zero Time
· Perform Auto Zero
· Restore Factory Zero

Diagnostic Variables
· Drive Gain
· Left Pickoff Amplitude
· Right Pickoff Amplitude
· Tube Frequency
· Live Zero Flow Rate
· Board Temperature

C.4 Set up the GSD
The GSD supports cyclic communications (automatic, periodic data exchange) between
the transmitter and a PROFIBUS host, using predefined input and output modules. You can
select a maximum of twenty modules.

1. Download the following file from the Emerson web site: MMI_0C7E.GSD

a. Use your browser to go to http://micromotion.com.

b. In the Quick Links list, click Software Downloads , then navigate to the Device
Drivers page.

c. Drill down to the device install kit for your transmitter, select the GSD, and
download it to your PC.

2. Import the GSD into your PROFIBUS host.

3. Configure the host with the transmitter's node address and any other required data.

Tip
The transmitter's node address was set during transmitter installation. See Micro Motion Filling
Mass Transmitters: Installation Manual for more information.

4. Using the method appropriate to your host, select the input and output modules
you want to use, up to a maximum of twenty.

Setting up and using the PROFIBUS interfaces
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5. Using the method appropriate to your host, initiate cyclic communications.

C.4.1 Input modules in the GSD
Input modules are used to send process or diagnostic data to the host. Each input module
is associated with a process or diagnostic variable on the transmitter. When the host
performs a cyclic read, it acquires the current value of the variable.

Input modules in the GSDTable C-2:   

Module name Size (bytes) Comments

Device Status 1 • Good data
• Bad data

Mass Flow 4

Mass Total 4

Temperature 4

Density 4

Volume Flow 4

Volume Total 4

Drive Gain 4

SNS STATUS WORD1 2 See following table.

SNS STATUS WORD2 2 See following table.

SNS STATUS WORD3 2 See following table.

SNS STATUS WORD4 2 See following table.

SNS STATUS WORD5 2 See following table.

SNS STATUS WORD6 2 See following table.

SNS STATUS WORD7 2 See following table.

Fill Total 4

Fill Time 4

Fill Count 2

Percent Fill Completed 4

Fill Status Word 2

Fill Diagnostics Word 2

Bit descriptions for STATUSWORD1Table C-3:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Not used

0x0008 3 No Sensor Response
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Bit descriptions for STATUSWORD1 (continued)Table C-3:   

Hexadecimal Bit Description

0x0010 4 Not used

0x0020 5 Not used

0x0040 6 Other Failure

0x0080 7 Not used

0x0100 8 Not used

0x0200 9 Not used

0x0400 10 Sensor Simulation Active

0x0800 11 Not used

0x1000 12 Not used

0x2000 13 Not used

0x4000 14 Not used

0x8000 15 Fault

Bit descriptions for STATUSWORD2Table C-4:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Not used

0x0008 3 Not used

0x0010 4 Density Overrange

0x0020 5 Drive Overrange

0x0040 6 PIC/Daughterboard Communications Failure

0x0080 7 Not used

0x0100 8 EEPROM Error (Core Processor)

0x0200 9 RAM Error (Core Processor)

0x0400 10 Not used

0x0800 11 Temperature Overrange

0x1000 12 Mass Flow Rate Overrange

0x2000 13 Not used

0x4000 14 Characterization Required

0x8000 15 Not used
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Bit descriptions for STATUSWORD3Table C-5:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Power Reset Occurred

0x0004 2 Transmitter Initializing/Warming Up

0x0008 3 Not used

0x0010 4 Not used

0x0020 5 Not used

0x0040 6 Not used

0x0080 7 Not used

0x0100 8 Calibration Failure

0x0200 9 Zero Calibration Failed: Low

0x0400 10 Zero Calibration Failed: High

0x0800 11 Zero Calibration Failed: Unstable

0x1000 12 Transmitter Failure

0x2000 13 Not used

0x4000 14 Calibration in Progress

0x8000 15 Slug Flow

Bit descriptions for STATUSWORD4Table C-6:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Sensor RTD Failure

0x0008 3 T-Series RTD Failure

0x0010 4 Reverse Flow

0x0020 5 Factory Configuration Data Is Invalid

0x0040 6 Not used

0x0080 7 Last Measured Value Override Active

0x0100 8 Not used

0x0200 9 No Flow Cal Value

0x0400 10 Not used

0x0800 11 Not used

0x1000 12 No K1 Value

0x2000 13 Not used

0x4000 14 Not used
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Bit descriptions for STATUSWORD4 (continued)Table C-6:   

Hexadecimal Bit Description

0x8000 15 Not used

Bit descriptions for STATUSWORD5Table C-7:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Not used

0x0008 3 Not used

0x0010 4 Discrete Output Status

0x0020 5 Not used

0x0040 6 Density D3 Calibration in Progress

0x0080 7 Density D4 Calibration in Progress

0x0100 8 Not used

0x0200 9 Not used

0x0400 10 Temperature Slope Calibration in Progress

0x0800 11 Temperature Offset Calibration in Progress

0x1000 12 Density FD Calibration in Progress

0x2000 13 Density D2 Calibration in Progress

0x4000 14 Density D1 Calibration in Progress

0x8000 15 Zero Calibration in Progress

Bit descriptions for STATUSWORD6Table C-8:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Not used

0x0008 3 Not used

0x0010 4 Not used

0x0020 5 Not used

0x0040 6 Not used

0x0080 7 Not used

0x0100 8 Enhanced Event 1 Status (index = 0)

0x0200 9 Enhanced Event 2 Status (index = 1)

0x0400 10 Enhanced Event 3 Status (index = 2)
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Bit descriptions for STATUSWORD6 (continued)Table C-8:   

Hexadecimal Bit Description

0x0800 11 Enhanced Event 4 Status (index = 3)

0x1000 12 Enhanced Event 5 Status (index = 4)

0x2000 13 Not used

0x4000 14 Not used

0x8000 15 Incorrect Board Type

Bit descriptions for STATUSWORD7Table C-9:   

Hexadecimal Bit Description

0x0001 0 K1/FCF Combination Unrecognized

0x0002 1 Transmitter Initializing/Warming Up

0x0004 2 Low Power

0x0008 3 Right/Left Pickoff Signal

0x0010 4 Not used

0x0020 5 Not used

0x0040 6 Not used

0x0080 7 Not used

0x0100 8 Not used

0x0200 9 Not used

0x0400 10 Not used

0x0800 11 Not used

0x1000 12 Not used

0x2000 13 Not used

0x4000 14 Not used

0x8000 15 Not used

C.4.2 Output modules in the GSD
Output modules are used to send external data to the transmitter or to initiate transmitter
actions. When the host performs a cyclic write, it writes the current value of the output
module to transmitter memory.

Output modules in the GSDTable C-10:   

Module name Size (bytes) Comments

Start/Stop Totals 1 • 0 = Stop
• 1 = Start
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Output modules in the GSD (continued)Table C-10:   

Module name Size (bytes) Comments

Reset Process Totals 1 • 0 = No action
• 1 = Perform action

Reset Inv Totals 1 • 0 = No action
• 1 = Perform action

Start Fill 1 • 0 = No action
• 1 = Perform action

Pause Fill 1 • 0 = No action
• 1 = Perform action

Resume Fill 1 • 0 = No action
• 1 = Perform action

End Fill 1 • 0 = No action
• 1 = Perform action

Reset Fill Total 1 • 0 = No action
• 1 = Perform action

Start Secondary Fill 1 • 0 = No action
• 1 = Perform action

End Secondary Fill 1 • 0 = No action
• 1 = Perform action

Start Purge 1 • 0 = No action
• 1 = Perform action

End Purge 1 • 0 = No action
• 1 = Perform action

Start Cleaning 1 • 0 = No action
• 1 = Perform action

End Cleaning 1 • 0 = No action
• 1 = Perform action

Reset AOC Flow Rate 1 • 0 = No action
• 1 = Perform action

C.4.3 Contents of Diagnostic Bytes 11 through 24
During cyclic communications, the transmitter sets a flag to indicate that one or more
alarms has occurred. The host reads the diagnostic bytes to determine the specific alarms.
If a bit is set, one or more of the corresponding alarms is active.

Note
Diagnostic Bytes 11 through 24 contain device-specific data. The contents of Diagnostic Bytes 1
through 10 are defined in the PROFIBUS specification. For more information on Diagnostic Bytes 1
through 10, see the PROFIBUS specification.
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Diagnostic Byte 11Table C-11:   

Bit Active alarms (one or more)

24 A014: Transmitter Failure

25 Reserved

26 Reserved

27 Reserved

28 A001: EEPROM Error (Core Processor)

A002: RAM Error (Core Processor)

29 A003: No Sensor Response

A004: Temperature Overrange

A005: Mass Flow Rate Overrange

A008: Density Overrange

A016: Sensor RTD Failure

A017: T-Series RTD Failure

30 A009: Transmitter Initializing/Warming Up

31 Reserved

Diagnostic Byte 12Table C-12:   

Bit Active alarms (one or more)

32 A010: Calibration Failure

A011: Zero Calibration Failed: Low

A012: Zero Calibration Failed: High

A013: Zero Calibration Failed: Unstable

33 Reserved

34 Reserved

35 A107: Power Reset Occurred

36 A107: Power Reset Occurred

37 Reserved

38 A006: Characterization Required

A020: No Flow Cal Value

A021: Incorrect Sensor Type (K1)

39 Reserved

Diagnostic Byte 13Table C-13:   

Bit Active alarms (one or more)

40 Reserved

41 Reserved

42 Reserved
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Diagnostic Byte 13 (continued)Table C-13:   

Bit Active alarms (one or more)

43 Reserved

44 Reserved

45 Reserved

46 Reserved

47 Reserved

Diagnostic Byte 14Table C-14:   

Bit Active alarms (one or more)

48 Reserved

49 Reserved

50 Reserved

51 Reserved

52 Reserved

53 Reserved

54 Reserved

55 Reserved

Diagnostic Byte 15Table C-15:   

Bit Active alarms (one or more)

56 Reserved

57 A001: EEPROM Error (Core Processor)

58 A002: RAM Error (Core Processor)

59 A003: No Sensor Response

60 A004: Temperature Overrange

61 A005: Mass Flow Rate Overrange

62 A006: Characterization Required

63 Reserved

Diagnostic Byte 16Table C-16:   

Bit Active alarms (one or more)

64 A008: Density Overrange

65 A009: Transmitter Initializing/Warming Up

66 A010: Calibration Failure
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Diagnostic Byte 16 (continued)Table C-16:   

Bit Active alarms (one or more)

67 A011: Zero Calibration Failed: Low

68 A012: Zero Calibration Failed: High

69 A013: Zero Calibration Failed: Unstable

70 A014: Transmitter Failure

71 Reserved

Diagnostic Byte 17Table C-17:   

Bit Active alarms (one or more)

72 A016: Sensor RTD Failure

73 A017: T-Series RTD Failure

74 Reserved

75 Reserved

76 A020: No Flow Cal Value

77 A021: Incorrect Sensor Type (K1)

78 Reserved

79 Reserved

Diagnostic Byte 18Table C-18:   

Bit Active alarms (one or more)

80 Reserved

81 Reserved

82 Reserved

83 Reserved

84 Reserved

85 A029: PIC/Daughterboard Communications Failure

86 A030: Incorrect Board Type

87 A031: Low Power

Diagnostic Byte 19Table C-19:   

Bit Active alarms (one or more)

88 Reserved

89 A033: Insufficient Right/Left Pickoff Signal

90 Reserved
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Diagnostic Byte 19 (continued)Table C-19:   

Bit Active alarms (one or more)

91 Reserved

92 Reserved

93 Reserved

94 Reserved

95 Reserved

Diagnostic Byte 20Table C-20:   

Bit Active alarms (one or more)

96 Reserved

97 Reserved

98 A102: Drive Overrange

99 Reserved

100 A105: Slug Flow

101 A105: Slug Flow

102 Reserved

103 A107: Power Reset Occurred

Diagnostic Byte 21Table C-21:   

Bit Active alarms (one or more)

104 Reserved

105 Reserved

106 Reserved

107 Reserved

108 Reserved

109 Reserved

110 Reserved

111 Reserved

Diagnostic Byte 22Table C-22:   

Bit Active alarms (one or more)

112 Reserved

113 Reserved

114 Reserved
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Diagnostic Byte 22 (continued)Table C-22:   

Bit Active alarms (one or more)

115 Reserved

116 Reserved

117 Reserved

118 Reserved

119 Reserved

Diagnostic Byte 23Table C-23:   

Bit Active alarms (one or more)

120 Reserved

121 Reserved

122 Reserved

123 Reserved

124 Reserved

125 Reserved

126 Reserved

127 Reserved

Diagnostic Byte 24Table C-24:   

Bit Active alarms (one or more)

128 A132: Sensor Simulation Active

129 Reserved

130 Reserved

131 Reserved

132 Reserved

133 Reserved

134 Reserved

135 Reserved

C.5 Use PROFIBUS bus parameters
PROFIBUS bus parameters provide a complete interface to all transmitter functionality that
is available through the DP port. You can use bus parameters to configure the transmitter,
operate the transmitter, and perform maintenance activities.
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Prerequisites

Your PROFIBUS host or management environment must be capable of using DP-V1
services.

Procedure

1. Using the method appropriate to your environment, establish a connection with the
transmitter.

Tip
The transmitter's node address was set during transmitter installation. See Micro Motion Filling
Mass Transmitters: Installation Manual for more information.

2. Use DP-V1 services to read and/or write values to specific transmitter parameters.

C.5.1 PROFIBUS data types
The following data types are used in the PROFIBUS bus parameters interface.

PROFIBUS data typesTable C-25:   

Data type Size (bytes) Description Range Code

Boolean 1 True/false 0 = False

1 = True

BOOL

Integer8 1 8-bit signed integer value −128 to +127 INT8

Unsigned8 1 8-bit unsigned integer value 0 to 255 UINT8

Integer16 2 16-bit signed integer value −32768 to +32767 INT16

Unsigned16 2 16-bit unsigned integer value 0 to 65535 UINT16

Integer32 4 32-bit signed integer value −2147483648 to
+2147483647

INT32

Unsigned32 4 32-bit unsigned integer value 0 to 4294967296 UINT32

FLOAT 4 IEEE single-precision floating-
point value

−3.8E38 to +3.8E38 FLOAT

OCTET STRING Up to 128
bytes

Array of ASCII characters N/A STRING

BIT_ENUMER-
ATED

2 Enumerated value in which each
bit represents a different enumer-
ation

N/A B_ENUM

C.5.2 PROFIBUS Measurement block (Slot 1) and related
information
In the following table:
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Index The index of the parameter within the block

Name The name used for the parameter within the block

Data type The data type of the parameter

Memory class The memory class of the parameter:

D Dynamic store (cyclic data, parameter updated periodically)

S Static store (acyclic data, parameter changed on a deliberate
write)

N Nonvolatile parameter (saved across power cycles)

Access The type of access allowed for the parameter:

RO Read-only

RW Read/Write

Default value Value configured at the factory, unless a special configuration was
ordered

Comments A quick definition of the parameter, the name of the parameter in
ProLink II, or information about the parameter

Contents of Measurement blockTable C-26:   

Index Name Data type
Memory
class Access

Default
value Comments

4 SNS_MassFlow FLOAT D RO 0 Current value of mass
flow rate process varia-
ble

5 SNS_MassFlowUnits UINT16 S RW 0x0526
(1318)

Mass flow rate measure-
ment unit (integer code;
see Table C-27)

6 SNS_Temperature FLOAT D RO 0 Current value of temper-
ature process variable

7 SNS_TemperatureUnits UINT16 S RW 0x03E9
(1001)

Temperature measure-
ment unit (integer code;
see Table C-29)

8 SNS_Density FLOAT D RO 0 Current value of density
process variable

9 SNS_DensityUnits UINT16 S RW 0x044C
(1100)

Density measurement
unit (integer code; see 
Table C-30)

10 SNS_VolFlow FLOAT D RO 0 Current value of volume
flow rate process varia-
ble

11 SNS_VolumeFlowUnits UINT16 S RW 0x0547
(1351)

Volume flow rate meas-
urement unit (integer
code; see Table C-31)
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Contents of Measurement block (continued)Table C-26:   

Index Name Data type
Memory
class Access

Default
value Comments

12 SNS_DampingFlowRate FLOAT S RW 0.04 Flow damping value (0.0
to 60.0 sec)

13 SNS_DampingTemp FLOAT S RW 4.8 Temperature damping
value (0.0 to 80.0 sec)

14 SNS_DampingDensity FLOAT S RW 1.6 Density damping value
(0.0 to 60.0 sec)

15 SNS_MassMeterFactor FLOAT S RW 1 Mass flow meter factor
(0.8 to 1.2)

16 SNS_DensMeterFactor FLOAT S RW 1 Density meter factor
(0.8 to 1.2)

17 SNS_VolMeterFactor FLOAT S RW 1 Volume flow meter fac-
tor (0.8 to 1.2)

18 SNS_MassFlowCutoff FLOAT S RW 0 Mass flow cutoff (0 to
sensor limit)

19 SNS_VolumeFlowCutoff FLOAT S RW 0 Volume flow cutoff (0 to
sensor limit)

20 SNS_LowDensityCutoff FLOAT S RW 0 Density cutoff (0.0 to
0.5)

21 SNS_FlowDirection UINT16 S RW 0 Flow direction (integer
code; see Table C-33)

22 SNS_StartStopTotals UINT16 S RW N/A • 0 = Stop totalizers
• 1 = Start totalizers

23 SNS_ResetAllTotal UINT16 S RW N/A • 0 = No action
• 1 = Perform action

24 SNS_ResetAll Inventories UINT16 S RW N/A • 0 = No action
• 1 = Perform action

25 SNS_ResetMassTotal UINT16 S RW N/A • 0 = No action
• 1 = Perform action

26 SNS_ResetLineVolTotal UINT16 S RW N/A • 0 = No action
• 1 = Perform action

27 SNS_MassTotal FLOAT D RO 0 Current value of mass to-
tal

28 SNS_VolTotal FLOAT D RO 0 Current value of volume
total

29 SNS_MassInventory FLOAT D RO 0 Current value of mass in-
ventory

30 SNS_VolInventory FLOAT D RO 0 Current value of volume
inventory
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Contents of Measurement block (continued)Table C-26:   

Index Name Data type
Memory
class Access

Default
value Comments

31 SNS_MassTotalUnits UINT16 S RO 0x0441
(1089)

Measurement unit for
mass total and mass in-
ventory (integer code;
see Table C-28)

32 SNS_VolTotalUnits UINT16 S RO 0x040E
(1038)

Measurement unit for
volume total and volume
inventory (integer code;
see Table C-32)

33 SNS_ResetMassInv UINT16 S RW 0 • 0 = No action
• 1 = Perform action

34 SNS_ResetVolInv UINT16 S RW 0 • 0 = No action
• 1 = Perform action

Integer codes for Mass Flow Rate Measurement UnitTable C-27:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 None

0x0526 1318 Grams/second

0x0527 1319 Grams/minute

0x0528 1320 Grams/hour

0x052A 1322 Kilograms/second

0x052B 1323 Kilograms/minute

0x052C 1324 Kilograms/hour

0x052D 1325 Kilograms/day

0x052F 1327 Metric tons/minute

0x0530 1328 Metric tons/hour

0x0531 1329 Metric tons/day

0x0532 1330 Pounds/second

0x0533 1331 Pounds/minute

0x0534 1332 Pounds/hour

0x0535 1333 Pounds/day

0x0537 1335 Short tons (2000 lbs)/minute

0x0538 1336 Short tons (2000 lbs)/hour

0x0539 1337 Short tons (2000 lbs)/day

0x053C 1340 Long tons (2240 lbs)/hour
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Integer codes for Mass Total Measurement Unit and Mass Inventory
Measurement Unit

Table C-28:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 None

0x0440 1088 Kilograms

0x0441 1089 Grams

0x0444 1092 Metric tons

0x0446 1094 Pounds

0x0447 1095 Short tons (2000 pounds)

0x0448 1096 Long tons (2240 pounds)

Integer codes for Temperature Measurement UnitTable C-29:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 None

0x03E8 1000 Degrees Kelvin

0x03E9 1001 Degrees Celsius

0x03EA 1002 Degrees Fahrenheit

0x03EB 1003 Degrees Rankine

Integer codes for Density Measurement UnitTable C-30:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 None

0x0449 1097 Kilograms per cubic meter

0x044C 1100 Grams per cubic centimeter

0x044F 1103 Kilograms per liter

0x0450 1104 Grams per milliliter

0x0451 1105 Grams per liter

0x0452 1106 Pounds per cubic inch

0x0453 1107 Pounds per cubic foot

0x0454 1108 Pounds per US gallon

0x0455 1109 Short tons (2000 lbs) per cubic yard

0x0459 1113 Degrees API

0x045A 1114 Specific gravity
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Integer codes for Volume Flow Rate Measurement UnitTable C-31:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 None

0x0543 1347 Cubic meters/second

0x0544 1348 Cubic meters/minute

0x0545 1349 Cubic meters/hour

0x0546 1350 Cubic meters/day

0x0547 1351 Liters/second

0x0548 1352 Liters/minute

0x0549 1353 Liters/hour

0x054B 1355 Million liters/day

0x054C 1356 Cubic feet/second

0x054D 1357 Cubic feet/minute

0x054E 1358 Cubic feet/hour

0x054F 1359 Cubic feet/day

0x0552 1362 US gallons/second

0x0553 1363 US gallons/minute

0x0554 1364 US gallons/hour

0x0555 1365 Million US gallons/day

0x0556 1366 Imperial gallons/second

0x0557 1367 Imperial gallons/minute

0x0558 1368 Imperial gallons/hour

0x0559 1369 Imperial gallons/day

0x055A 1370 Barrels/second

0x055B 1371 Barrels/minute

0x055C 1372 Barrels/hour

0x055D 1373 Barrels/day

0x055E 1374 Beer barrels per sec (Beer bbl/s)

0x066A 1642 Beer barrels per min (Beer bbl/m)

0x066B 1643 Beer barrels per hour (Beer bbl/h)

0x066C 1644 Beer barrels per day (Beer bbl/d)

0x066D 1645 US gallons per day

Integer codes for Volume Total Measurement Unit and Volume Inventory
Measurement Unit

Table C-32:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 None
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Integer codes for Volume Total Measurement Unit and Volume Inventory
Measurement Unit (continued)

Table C-32:   

Code (Hexadecimal) Code (Decimal) Description

0x040A 1034 Cubic meters

0x040C 1036 Cubic centimeters

0x040E 1038 Liters

0x0413 1043 Cubic feet

0x0418 1048 US gallons

0x0419 1049 Imperial gallons

0x041B 1051 Barrels

0x0669 1641 Beer barrels

Integer codes for Flow DirectionTable C-33:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 Forward

0x0002 2 Bidirectional

0x0004 4 Negate/Forward

0x0005 5 Negate/Bidirectional

C.5.3 PROFIBUS Calibration block (Slot 2) and related
information
In the following table:

Index The index of the parameter within the block

Name The name used for the parameter within the block

Data type The data type of the parameter

Memory class The memory class of the parameter:

D Dynamic store (cyclic data, parameter updated periodically)

S Static store (acyclic data, parameter changed on a deliberate
write)

N Nonvolatile parameter (saved across power cycles)

Access The type of access allowed for the parameter:

RO Read-only

RW Read/Write

Default value Value configured at the factory, unless a special configuration was
ordered
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Comments A quick definition of the parameter, the name of the parameter in
ProLink II, or information about the parameter

Contents of Calibration blockTable C-34:   

Index Name Data type
Memory
class Access

Default
value Comments

4 SNS_FlowCalGain FLOAT S RW 1 Flow calibration factor
(6-character string)

5 SNS_FlowCalTemp Coeff FLOAT S RW 5.13 Temperature coefficient
for flow (4-character
string)

6 SNS_FlowZeroCal UINT16 S RW N/A • 0 = Abort zero cali-
bration

• 1 = Start zero calibra-
tion

7 SNS_MaxZeroingTime UINT16 S RW 20 Zero Time
Range: 5 to 300 seconds

8 SNS_AutoZeroStdDev FLOAT S RO N/A Standard deviation of
auto zero

9 SNS_AutoZeroValue FLOAT S RW N/A Present flow signal offset
at zero flow, in µsec

10 SNS_FailedCal FLOAT S RO Varies Zero value if calibration
fails

11 SNS_K1Cal UINT16 S RW N/A Start D1 density calibra-
tion:

• 0 = No action
• 1 = Perform action

12 SNS_K2Cal UINT16 S RW N/A Start D2 density calibra-
tion:

• 0 = No action
• 1 = Perform action

13 SNS_FdCal UINT16 S RW N/A Start flowing density cal-
ibration:

• 0 = No action
• 1 = Perform action

14 SNS_TseriesD3Cal UINT16 S RW N/A Start D3 density calibra-
tion:

• 0 = No action
• 1 = Perform action

15 SNS_TseriesD4Cal UINT16 S RW N/A Start D4 density calibra-
tion:

• 0 = No action
• 1 = Perform action
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Contents of Calibration block (continued)Table C-34:   

Index Name Data type
Memory
class Access

Default
value Comments

16 SNS_K1 FLOAT S RW 1000 Density calibration con-
stant 1 (µsec)

17 SNS_K2 FLOAT S RW 50000 Density calibration con-
stant 2 (µsec)

18 SNS_FD FLOAT S RW 0 Flowing density calibra-
tion constant (µsec)

19 SNS_TseriesK3 FLOAT S RW 0 Density calibration con-
stant 3 (µsec)

20 SNS_TseriesK4 FLOAT S RW 0 Density calibration con-
stant 4 (µsec)

21 SNS_D1 FLOAT S RW 0 Density of D1 calibration
fluid

22 SNS_D2 FLOAT S RW 1 Density of D2 calibration
fluid

23 SNS_CalValForFD FLOAT S RW 0 Density of flowing densi-
ty calibration fluid

24 SNS_TseriesD3 FLOAT S RW 0 Density of D3 calibration
fluid

25 SNS_TseriesD4 FLOAT S RW 0 Density of D4 calibration
fluid

26 SNS_DensityTempCoeff FLOAT S RW 4.44 Density temperature co-
efficient

27 SNS_TSeriesFlowTGCO FLOAT S RW 0 T-Series FTG value

28 SNS_TSeriesFlowFQCO FLOAT S RW 0 T-Series FFQ value

29 SNS_TSeriesDensTGCO FLOAT S RW 0 T-Series DTG value

30 SNS_TSeriesDensFQCO1 FLOAT S RW 0 T-Series DFQ1 value

31 SNS_TSeriesDensFQCO2 FLOAT S RW 0 T-Series DFQ2 value

32 SNS_TempCalOffset FLOAT S RW 0 Temperature calibration
offset

33 SNS_TempCalSlope FLOAT S RW 1 Temperature calibration
slope

36 SNS_EnablePresComp ENUM S RW 0 Pressure compensation:

• 0 = Disabled
• 1 = Enabled

37 SNS_ExternalPresInput FLOAT S RW 0 Exernal pressure value

38 SNS_PressureUnits UINT16 S RW 0x0475
(1141)

Pressure measurement
unit (integer code; see 
Table C-35)

39 SNS_FlowPresComp FLOAT S RW 0 Pressure correction fac-
tor for flow
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Contents of Calibration block (continued)Table C-34:   

Index Name Data type
Memory
class Access

Default
value Comments

40 SNS_DensPresComp FLOAT S RW 0 Pressure correction fac-
tor for density

41 SNS_FlowCalPres FLOAT S RW 0 Flow calibration pressure

42 SNS_FlowZeroRestore UINT16 S RW N/A Restore factory zero:

• 0 = No action
• 1 = Perform action

43 SNS_AutoZero Factory FLOAT S RO Varies Factory value for flow
signal offset at zero flow,
in µsec

Integer codes for Pressure Measurement UnitTable C-35:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 None

0x047C 1148 Inches water @ 68 °Fahrenheit

0x047A 1146 Inches water @ 60 °Fahrenheit

0x0484 1156 Inches mercury @ 0 °Celsius

0x0482 1154 Feet water @ 68 °Fahrenheit

0x047F 1151 Millimeters water @ 68 °Fahrenheit

0x0486 1158 Millimeters mercury @ 0 °Celsius

0x0475 1141 Pounds/square inch

0x0471 1137 Bar

0x0472 1138 Millibar

0x0478 1144 Grams/square centimeter

0x0479 1145 Kilograms/square centimeter

0x046A 1130 Pascals

0x046D 1133 Kilopascals

0x0473 1139 Torr @ 0 °Celsius

0x0474 1140 Atmospheres

0x047B 1147 Inches water @ 4 °Celsius

0x047E 1150 Millimeters water @ 4 °Celsius

0x046C 1132 Megapascals

Setting up and using the PROFIBUS interfaces

Configuration and Use Manual 331



C.5.4 PROFIBUS Diagnostic block (Slot 3) and related
information
In the following table:

Index The index of the parameter within the block

Name The name used for the parameter within the block

Data type The data type of the parameter

Memory class The memory class of the parameter:

D Dynamic store (cyclic data, parameter updated periodically)

S Static store (acyclic data, parameter changed on a deliberate
write)

N Nonvolatile parameter (saved across power cycles)

Access The type of access allowed for the parameter:

RO Read-only

RW Read/Write

Default value Value configured at the factory, unless a special configuration was
ordered

Comments A quick definition of the parameter, the name of the parameter in
ProLink II, or information about the parameter

Contents of Diagnostic blockTable C-36:   

Index Name Data type
Memory
class Access

Default
value Comments

1 SNS_SlugDuration FLOAT S RW 1 Slug Duration:

• Unit: seconds
• Range: 0 to

60 seconds

2 SNS_SlugLo FLOAT S RW 0 Slug Low Limit:
• Unit: g/cm3
• Range: 0 to

10 g/cm3

3 SNS_SlugHi FLOAT S RW 5 Slug High Limit:
• Unit: g/cm3
• Range: 0 to

10 g/cm3

4 UNI_PCIndex UINT16 S RW 0 Enhanced Event (dis-
crete event) index (x = 0,
1, 2, 3, 4)

5 SNS_PC_Action UINT16 S RW 0 Enhanced Event Type for
Enhanced Event x (inte-
ger code; see Table C-37)
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Contents of Diagnostic block (continued)Table C-36:   

Index Name Data type
Memory
class Access

Default
value Comments

6 SNS_PC_SetPointA FLOAT S RW 1 Setpoint A for Enhanced
Event x

7 SNS_PC_SetPointB FLOAT S RW 1 Setpoint B for Enhanced
Event x

8 SNS_PC_PVCode UINT16 S RW 0 Process variable for En-
hanced Event x (integer
code; see Table C-38)

9 SNS_PC_Status B_ENUM D RO N/A Enhanced Event status
(integer code; see 
Table C-39)

10 SNS_StatusWords1 B_ENUM D RO N/A See following table.

11 SNS_StatusWords2 B_ENUM D RO N/A See following table.

12 SNS_StatusWords3 B_ENUM D RO N/A See following table.

13 SNS_StatusWords4 B_ENUM D RO N/A See following table.

14 SNS_StatusWords5 B_ENUM D RO N/A See following table.

15 SNS_StatusWords6 B_ENUM D RO N/A See following table.

16 SNS_StatusWords7 B_ENUM D RO N/A See following table.

17 SNS_StatusWords8 B_ENUM D RO N/A Not used

18 SYS_DigCommFault Ac-
tionCode

UINT16 S RW 0 Digital Communications Fault
Action (integer code; see 
Table C-47)

19 DB_SYS_TimeoutVa-
lueLMV

UINT16 S RW 0 Fault Timeout:
• Range: 0 to

60 seconds

20 UNI_Alarm_Index UINT16 S RW 0 Alarm index used to con-
figure or read alarm se-
verity, or to acknowl-
edge alarms

21 SYS_AlarmSeverity UINT16 S RW 0 Alarm Severity for Alarm n
(for n, see alarm index)
(integer code; see 
Table C-48)

22 SYS_AlarmStatus B_ENUM D RW N/A Status of Alarm n (for n,
see alarm index) (integer
code; see Table C-49)

To acknowledge alarm,
write 0.

23 SYS_AlarmCount UINT16 S RO N/A The number of inactive-
to-active transitions of
Alarm n (for n, see alarm
index)
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Contents of Diagnostic block (continued)Table C-36:   

Index Name Data type
Memory
class Access

Default
value Comments

24 SYS_AlarmPosted UINT32 S RO N/A The time that Alarm n
was posted, shown as
the number of seconds
since the power-on time
reset (Index 52) (for n,
see alarm index)

25 SYS_AlarmCleared UINT32 S RO N/A The time that Alarm n
was cleared, shown as
the number of seconds
since the power-on time
reset (Index 52) (for n,
see alarm index)

26 UNI_AlarmHistoryIndex UINT16 S RW N/A Alarm history index

• Range: 0 to 49

27 SYS_AlarmNumber UINT16 S RO N/A Alarm number in record
n in alarm history (for n,
see alarm history index)

28 SYS_AlarmEvent UINT16 S RO N/A Status change in record
n in alarm history (for n,
see alarm history index):

• 1 = Posted
• 2 = Cleared

29 SYS_AlarmTime UINT32 S RO N/A Timestamp of status
change in record n in
alarm history (for n, see
alarm history index)

30 SYS_AckAllAlarms UINT16 S RW N/A Acknowledge all alarms:

• 0 = No action
• 1 = Perform action

31 SYS_ClearAlarmHistory UINT16 S RW N/A The type of status
change for record n in
alarm history (for n, see
alarm history index):

• 1 = Posted
• 2 = Cleared

32 SNS_DriveGain FLOAT D RO 0 Current drive gain:

• Unit: %

33 SNS_RawTubeFreq FLOAT D RO 0 Current tube frequency:

• Unit: Hz
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Contents of Diagnostic block (continued)Table C-36:   

Index Name Data type
Memory
class Access

Default
value Comments

34 SNS_LiveZeroFlow FLOAT D RO 0 Unfiltered value of mass
flow rate:

• Unit: Unit configured
for mass flow rate

35 SNS_LPOamplitude FLOAT D RO 0 Left pickoff voltage:

• Unit: Volts

36 SNS_RPOamplitude FLOAT D RO 0 Right pickoff voltage:

• Unit: Volts

37 SNS_BoardTemp FLOAT D RO 0 Board temperature:

• Unit: °C

38 SNS_MaxBoardTemp FLOAT D RO 0 Electronics maximum re-
corded temperature (re-
settable):

• Unit: °C

39 SNS_MinBoardTemp FLOAT D RO 0 Electronics minimum re-
corded temperature (re-
settable):

• Unit: °C

40 SNS_AveBoardTemp FLOAT D RO 0 Electronics average re-
corded temperature (not
resettable):

• Unit: °C

41 SNS_MaxSensorTemp FLOAT D RO 0 Sensor maximum recor-
ded temperature:

• Unit: °C

42 SNS_MinSensorTemp FLOAT D RO 0 Sensor minimum recor-
ded temperature:

• Unit: °C

43 SNS_AveSensorTemp FLOAT D RO 0 Sensor average recorded
temperature:

• Unit: °C

44 SNS_WireRTDRes FLOAT D RO 0 Resistance of the 9-wire
cable:

• Unit: Ohms

45 SNS_LineRTDRes FLOAT D RO 0 Resistance of the proc-
ess line RTD:

• Unit: Ohms

46 SYS_PowerCycleCount UINT16 D RO 0 Core processor/trans-
mitter power cycle count
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Contents of Diagnostic block (continued)Table C-36:   

Index Name Data type
Memory
class Access

Default
value Comments

47 SYS_PowerOnTimeSec UINT32 D RO N/A The number of seconds
since the last time the
transmitter was reset
(power-cycled)

48 SNS_InputVoltage FLOAT D RO N/A Coriolis supply voltage
(internal measurement),
~12 VDC:

• Unit: Volts

49 SNS_TargetAmplitude FLOAT D RO N/A Amplitude at which the
transmitter is attempt-
ing to drive the sensor:

• Unit: mV/Hz

50 SNS_CaseRTDRes FLOAT D RO N/A Meter RTD resistance:

• Unit: Ohms

51 SYS_RestoreFactoryCon-
fig

UINT16 S RW N/A Restore the factory con-
figuration values:

• 0 = No action
• 1 = Perform action

52 SYS_ResetPowerOnTime UINT16 S RW N/A Reset the power-on
time:

• 0 = No action
• 1 = Perform action

56 SYS_AckAlarm UINT16 S RW N/A Acknowledge alarm
(write alarm index to ac-
knowledge the alarm):

(1 = A001,…, 39 = A039,
40 = A100, …, 75 =
A135, ...)

57 SNS_DriveCurrent FLOAT D RO N/A Current being used to
drive the sensor:

• Unit: mA

Integer codes for Enhanced Event TypeTable C-37:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 HI (Greater than Setpoint A)

0x0001 1 LO (Less than Setpoint A)

0x0002 2 IN HI/LO (Between Setpoint A and Setpoint B, in-
clusive)
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Integer codes for Enhanced Event Type (continued)Table C-37:   

Code (Hexadecimal) Code (Decimal) Description

0x0003 3 OUT HI/LO (Not between Setpoint A and Set-
point B, exclusive)

Integer codes for Enhanced Event Process VariableTable C-38:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 Mass Flow Rate

0x0001 1 Temperature

0x0002 2 Mass Total

0x0003 3 Density

0x0004 4 Mass Inventory

0x0005 5 Volume Flow Rate

0x0006 6 Volume Total

0x0007 7 Volume Inventory

0x002E 46 Raw Tube Frequency

0x002F 47 Drive Gain

0x0030 48 Case Temperature

0x0031 49 LPO Amplitude

0x0032 50 RPO Amplitude

0x0033 51 Board Temperature

0x0035 53 External Pressure

0x0037 55 External Temperature

0x0045 69 Live Zero

0x00FB 251 None

Integer codes for Enhanced Event StatusTable C-39:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 1 Enhanced Event 1 active (index = 0)

0x0002 2 Enhanced Event 2 active (index = 1)

0x0004 4 Enhanced Event 3 active (index = 2)

0x0008 8 Enhanced Event 4 active (index = 3)

0x0010 16 Enhanced Event 5 active (index = 4)

Setting up and using the PROFIBUS interfaces

Configuration and Use Manual 337



Bit descriptions for STATUSWORD1Table C-40:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Not used

0x0008 3 No Sensor Response

0x0010 4 Not used

0x0020 5 Not used

0x0040 6 Other Failure

0x0080 7 Not used

0x0100 8 Not used

0x0200 9 Not used

0x0400 10 Sensor Simulation Active

0x0800 11 Not used

0x1000 12 Not used

0x2000 13 Not used

0x4000 14 Not used

0x8000 15 Fault

Bit descriptions for STATUSWORD2Table C-41:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Not used

0x0008 3 Not used

0x0010 4 Density Overrange

0x0020 5 Drive Overrange

0x0040 6 PIC/Daughterboard Communications Failure

0x0080 7 Not used

0x0100 8 EEPROM Error (Core Processor)

0x0200 9 RAM Error (Core Processor)

0x0400 10 Not used

0x0800 11 Temperature Overrange

0x1000 12 Mass Flow Rate Overrange

0x2000 13 Not used

0x4000 14 Characterization Required

Setting up and using the PROFIBUS interfaces

338  Micro Motion® Filling Mass Transmitters with PROFIBUS-DP



Bit descriptions for STATUSWORD2 (continued)Table C-41:   

Hexadecimal Bit Description

0x8000 15 Not used

Bit descriptions for STATUSWORD3Table C-42:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Power Reset Occurred

0x0004 2 Transmitter Initializing/Warming Up

0x0008 3 Not used

0x0010 4 Not used

0x0020 5 Not used

0x0040 6 Not used

0x0080 7 Not used

0x0100 8 Calibration Failure

0x0200 9 Zero Calibration Failed: Low

0x0400 10 Zero Calibration Failed: High

0x0800 11 Zero Calibration Failed: Unstable

0x1000 12 Transmitter Failure

0x2000 13 Not used

0x4000 14 Calibration in Progress

0x8000 15 Slug Flow

Bit descriptions for STATUSWORD4Table C-43:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Sensor RTD Failure

0x0008 3 T-Series RTD Failure

0x0010 4 Reverse Flow

0x0020 5 Factory Configuration Data Is Invalid

0x0040 6 Not used

0x0080 7 Last Measured Value Override Active

0x0100 8 Not used

0x0200 9 No Flow Cal Value

0x0400 10 Not used
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Bit descriptions for STATUSWORD4 (continued)Table C-43:   

Hexadecimal Bit Description

0x0800 11 Not used

0x1000 12 No K1 Value

0x2000 13 Not used

0x4000 14 Not used

0x8000 15 Not used

Bit descriptions for STATUSWORD5Table C-44:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Not used

0x0008 3 Not used

0x0010 4 Discrete Output Status

0x0020 5 Not used

0x0040 6 Density D3 Calibration in Progress

0x0080 7 Density D4 Calibration in Progress

0x0100 8 Not used

0x0200 9 Not used

0x0400 10 Temperature Slope Calibration in Progress

0x0800 11 Temperature Offset Calibration in Progress

0x1000 12 Density FD Calibration in Progress

0x2000 13 Density D2 Calibration in Progress

0x4000 14 Density D1 Calibration in Progress

0x8000 15 Zero Calibration in Progress

Bit descriptions for STATUSWORD6Table C-45:   

Hexadecimal Bit Description

0x0001 0 Not used

0x0002 1 Not used

0x0004 2 Not used

0x0008 3 Not used

0x0010 4 Not used

0x0020 5 Not used

0x0040 6 Not used
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Bit descriptions for STATUSWORD6 (continued)Table C-45:   

Hexadecimal Bit Description

0x0080 7 Not used

0x0100 8 Enhanced Event 1 Status (index = 0)

0x0200 9 Enhanced Event 2 Status (index = 1)

0x0400 10 Enhanced Event 3 Status (index = 2)

0x0800 11 Enhanced Event 4 Status (index = 3)

0x1000 12 Enhanced Event 5 Status (index = 4)

0x2000 13 Not used

0x4000 14 Not used

0x8000 15 Incorrect Board Type

Bit descriptions for STATUSWORD7Table C-46:   

Hexadecimal Bit Description

0x0001 0 K1/FCF Combination Unrecognized

0x0002 1 Transmitter Initializing/Warming Up

0x0004 2 Low Power

0x0008 3 Right/Left Pickoff Signal

0x0010 4 Not used

0x0020 5 Not used

0x0040 6 Not used

0x0080 7 Not used

0x0100 8 Not used

0x0200 9 Not used

0x0400 10 Not used

0x0800 11 Not used

0x1000 12 Not used

0x2000 13 Not used

0x4000 14 Not used

0x8000 15 Not used

Integer codes for Digital Communications Fault ActionTable C-47:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 Upscale

0x0001 1 Downscale

0x0002 2 Zero
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Integer codes for Digital Communications Fault Action (continued)Table C-47:   

Code (Hexadecimal) Code (Decimal) Description

0x0003 3 NAN

0x0004 4 Flow goes to zero

0x0005 5 None

Integer codes for Alarm SeverityTable C-48:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 Ignore

0x0001 1 Info

0x0002 2 Fault

Integer codes for Alarm StatusTable C-49:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 Cleared and acknowledged

0x0001 1 Active and acknowledged

0x0002 2 Cleared and unacknowledged

0x0003 3 Active and unacknowledged

C.5.5 PROFIBUS Device Information block (Slot 4) and related
information
In the following table:

Index The index of the parameter within the block

Name The name used for the parameter within the block

Data type The data type of the parameter

Memory class The memory class of the parameter:

D Dynamic store (cyclic data, parameter updated periodically)

S Static store (acyclic data, parameter changed on a deliberate
write)

N Nonvolatile parameter (saved across power cycles)

Access The type of access allowed for the parameter:

RO Read-only

RW Read/Write
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Default value Value configured at the factory, unless a special configuration was
ordered

Comments A quick definition of the parameter, the name of the parameter in
ProLink II, or information about the parameter

Contents of Device Information blockTable C-50:   

Index Name Data type
Memory
class Access

Default
value Comments

5 SYS_CEQ_Number UINT16 S RO N/A Engineering To Order
(ETO) number for trans-
mitter

6 SNS_SensorSerialNum UINT32 S RW 0 Sensor Serial Number: 3-
byte integer.

• First register: 00 in
high-order byte; first
8 bits of value in low-
order byte.

• Second register: Last
16 bits of value.

7 SNS_SensorType STRING S RW N/A Sensor Type

8 SNS_SensorTypeCode UINT16 S RW 0 Sensor Type Code:

• 0 = Curved Tube
• 1 = Straight Tube

9 SNS_SensorMaterial UINT16 S RW 0x00FD
(253)

Material used for sensor
case (integer code; see 
Table C-51)

10 SNS_LinerMaterial UINT16 S RW 0x00FD
(253)

Material used for sensor
liner (integer code; see 
Table C-52)

11 SNS_FlangeType UINT16 S RW 0x00FD
(253)

Sensor flange type (inte-
ger code; see Table C-53)

12 SNS_MassFlowHiLim FLOAT S RO N/A High mass flow limit of
sensor

13 SNS_TempFlowHiLim FLOAT S RO N/A High temperature limit
of sensor

14 SNS_DensityHiLim FLOAT S RO N/A High density limit of sen-
sor

15 SNS_VolumeFlowHiLim FLOAT S RO N/A High volume flow limit
of sensor

16 SNS_MassFlowLoLim FLOAT S RO N/A Low mass flow limit of
sensor

17 SNS_TempFlowLoLim FLOAT S RO N/A Low temperature limit of
sensor

Setting up and using the PROFIBUS interfaces

Configuration and Use Manual 343



Contents of Device Information block (continued)Table C-50:   

Index Name Data type
Memory
class Access

Default
value Comments

18 SNS_DensityLoLim FLOAT S RO N/A Low density limit of sen-
sor

19 SNS_VolumeFlowLoLim FLOAT S RO N/A Low volume flow limit of
sensor

20 SNS_MassFlowLoSpan FLOAT S RO N/A Mass flow minimum
range

21 SNS_TempFlowLoSpan FLOAT S RO N/A Temperature minimum
range

22 SNS_DensityLoSpan FLOAT S RO N/A Density minimum range

23 SNS_VolumeFlowLoSpan FLOAT S RO N/A Volume flow minimum
range

24 HART_HartDeviceID UINT32 S RW N/A Transmitter serial num-
ber

25 SYS_SoftwareRev UINT16 S RO N/A Transmitter software
version (xxx.xx: 1353 =
rev13.53)

26 SYS_BoardRevision UINT16 S RO N/A Version number of the
transmitter electronics

Integer codes for Sensor MaterialTable C-51:   

Code (Hexadecimal) Code (Decimal) Description

0x0003 3 Hastelloy C-22

0x0004 4 Monel

0x0005 5 Tantalum

0x0006 6 Titanium

0x0013 19 316L stainless steel

0x0017 23 Inconel

0x0032 50 304 stainless steel

0x00FC 252 Other

0x00FD 253 Special

Integer codes for Sensor Liner MaterialTable C-52:   

Code (Hexadecimal) Code (Decimal) Description

0x000A 10 PTFE (Teflon)

0x000B 11 Halar

0x0010 16 Tefzel
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Integer codes for Sensor Liner Material (continued)Table C-52:   

Code (Hexadecimal) Code (Decimal) Description

0x00FB 251 None

0x00FC 252 Other

0x00FD 253 Special

Integer codes for Sensor Flange TypeTable C-53:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 ANSI 150

0x0001 1 ANSI 300

0x0002 2 ANSI 600

0x0005 5 PN 40

0x0007 7 JIS 10K

0x0008 8 JIS 20K

0x0009 9 ANSI 900

0x000A 10 Sanitary Clamp Fitting

0x000B 11 Union

0x000C 12 PN 100

0x00FB 251 None

0x00FC 252 Other

0x00FD 253 Special

C.5.6 PROFIBUS Filling block and related information
In the following table:

Index The index of the parameter within the block

Name The name used for the parameter within the block

Data type The data type of the parameter

Memory class The memory class of the parameter:

D Dynamic store (cyclic data, parameter updated periodically)

S Static store (acyclic data, parameter changed on a deliberate
write)

N Nonvolatile parameter (saved across power cycles)

Access The type of access allowed for the parameter:

RO Read-only

RW Read/Write
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Default value Value configured at the factory, unless a special configuration was
ordered

Comments A quick definition of the parameter, the name of the parameter in
ProLink II, or information about the parameter

Contents of Filling blockTable C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

4 BAT_EnableBatch UINT16 S RW 1 Enable Filling Option:

• 0 = Disabled
• 1 = Enabled

5 BAT_IncrementalFlowS-
ource

UINT16 S RW 0 Flow Source:

• 0 = Mass Flow Rate
• 5 = Volume Flow Rate

6 BAT_CurrentTarget FLOAT S RW 0 Fill Target

7 BAT_BatchStages UINT16 S RW 1 Fill Type:

• 1 = One Stage Discrete
• 2 = Two Stage Discrete

8 BAT_CountDirection UINT16 S RW 1 Count Up:

• 0 = Disabled
• 1 = Enabled

9 BAT_StagePercentTar-
get

UINT16 S RW 0 Configure By:

• 0 = % Target
• 1 = Quantity

10 BAT_OpenPrimary FLOAT S RW 0 Open Primary

11 BAT_OpenSecondary FLOAT S RW 0 Open Secondary

12 BAT_ClosePrimary FLOAT S RW 100 Close Primary

13 BAT_CloseSecondary FLOAT S RW 100 Close Secondary

14 BAT_MaximumBatch-
Time

FLOAT S RW 0 Max Fill Time

15 BAT_EnableTimedFill UINT16 S RW 0 Enable Timed Fill:
• 0 = Disabled
• 1 = Enabled

16 BAT_TargetTime FLOAT S RW 0 Target Time

17 BAT_EnableDualFill UINT16 S RW 0 Enable Dual Fill:
• 0 = Disabled
• 1 = Enabled

18 Reserved

19 BAT_ActualFillTimeMe-
thod

UINT16 S RW 0 Measured Fill Time:

• 0 = Valve Closes
• 1 = Flow Stops
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Contents of Filling block (continued)Table C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

20 BAT_PumpToValveDelay FLOAT S RW 10 Pump to Valve Delay

21 BAT_EnableAOC UINT16 S RW 1 Enable AOC:

• 0 = Disabled
• 1 = Enabled

22 BAT_AOCAlgorithm UINT16 S RW 0 AOC algorithm type:

• 0 = Underfill
• 1 = Overfill
• 2 = Fixed

23 BAT_LearningCycles UINT16 S RW 10 AOC Window Length

24 BAT_AOCChangeLimit FLOAT S RW 0 Limit on the AOC values
to be included in subse-
quent AOC calculations,
in percent.

25 BAT_AOCConvergen-
ceRate

UINT16 S RW 1 Limit on rate at which
the AOC calculations
converge.

• 1 = Normal
• 2 = Slow

26 BAT_FixedAOCValue FLOAT S RW 0 Fixed Overshoot Comp

27 BAT_AOC_Kave FLOAT S RW 0.2 Unitless coefficient cal-
culated by the AOC algo-
rithms and used to ad-
just the valve closure
time for the primary
valve (or, for two-stage
discrete fills, the last
valve to close).

28 BAT_SecondaryAOCVal-
ue

FLOAT S RW 0.2 Unitless coefficient cal-
culated by the AOC algo-
rithms and used to ad-
just the valve closure
time for the secondary
valve in dual-fillhead fills.

29 BAT_EnableBlowout UINT16 S RW 0 Enable Purge:

• 0 = Disabled
• 1 = Enabled

30 BAT_OperationMode UINT16 S RW 1 Purge Mode:

• 0 = Auto
• 1 = Manual

31 BAT_PrimaryToSecon-
daryTime

FLOAT S RW 2 Purge Delay
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Contents of Filling block (continued)Table C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

32 BAT_SecondaryBatch-
OnTime

FLOAT S RW 1 Purge Time

33 BAT_PrecisionDO_
Source1

UINT16 S RW 0x006E
(110)

Precision DO1:

• 0x006E (110) = Pri-
mary Valve

34 BAT_PrecisionDO_Polar-
ity1

UINT16 S RW 1 Precision DO1 Polarity:

• 0 = Active Low
• 1 = Active High

35 BAT_PrecisionDO_
Source2

UINT16 S RW 0x006F
(111)

Precision DO2:

• 0x006D (109) =
Pump

• 0x006F (111) = Sec-
ondary Valve

36 BAT_PrecisionDO_Polar-
ity2

UINT16 S RW 1 Precision DO2 Polarity:

• 0 = Active Low
• 1 = Active High

37 BAT_EnableFillLogging UINT16 S RW 0 Enable Fill Logging:

• 0 = Disabled
• 1 = Enabled

38 BAT_FillLogIndex UINT16 S RW 0 Index of record in fill log

39 BAT_FillLogValue FLOAT D RO 0 Value of Flow Source in
the indexed record

40 BAT_FillStatusWord UINT16 D RO 0 See Table C-55.

41 BAT_FillDiagnostic-
sWord

UINT16 D RO 0 See Table C-56.

42 MAO_SourceSec UINT16 S RW 0 mA Output Process Variable
(integer code; see 
Table C-57)

43 MAO_mA4VarSec FLOAT S RW −0.2 Lower Range Value (secon-
dary mA output)

44 MAO_mA20VarSec FLOAT S RW 0.2 Upper Range Value (secon-
dary mA output)

45 MAO_CutoffSec FLOAT S RW 0 AO Cutoff (secondary mA
output)

46 MAO_DampingSec FLOAT S RW 0 Added Damping (secon-
dary mA output)

47 MAO_FaultIndicationSec UINT16 S RW 1 mA Output Fault Action
(secondary mA output)
(integer code; see 
Table C-58)
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Contents of Filling block (continued)Table C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

48 MAO_FaultSettingSec FLOAT S RW 2 mA Output Fault Level (sec-
ondary mA output)

49 SYS_TimeoutValueLMV UINT16 S RW N/A Fault Timeout (Last Meas-
ured Value Timeout)

50 MAO_FixOutputSec UINT16 S RW 0 Fix mA Output (secondary
mA output):

• 0 = Disabled
• 1 = Enabled

51 MAO_FixedMilliampSec FLOAT S RW N/A mA Output Fixed Value
(secondary mA output)

52 MAO_ActualMilliampSec FLOAT S RO N/A mA Output Actual Value
(secondary mA output)

53 MAO_Start4mATrimSec UINT16 S RW 0 Begin the trim of the
(secondary) mA output
at 4 mA:

• 0 = No action
• 1 = Perform action

54 MAO_TrimLowSec FLOAT S RW 10835.12 Trim constant for 4 mA
(secondary mA output)

55 MAO_Start20mATrim-
Sec

UINT16 S RW 0 Begin the trim of the
(secondary) mA output
at 20 mA:

• 0 = No action
• 1 = Perform action

56 MAO_TrimHighSec FLOAT S RW 54175.6 Trim constant for 20 mA
(secondary mA output)

57 FO_Source UINT16 S RW 0 Frequency Output Process
Variable:

• 0 = Mass Flow Rate
• 5 = Volume Flow Rate

58 FO_ScalingMethod UINT16 S RW 0 Frequency Output Scaling
Method:

• 0 = Frequency = Flow
• 1 = Pulses Per Unit
• 2 = Units Per Pulse

59 FO_FrequencyFactor FLOAT S RW 1000 Frequency Factor

60 FO_FlowRateFactor FLOAT S RW 16.66667 Rate Factor

61 FO_PulseWidth FLOAT S RW 0 Maximum Pulse Width

62 FO_PulsesPerUnit FLOAT S RW 60 Pulses Per Unit

Setting up and using the PROFIBUS interfaces

Configuration and Use Manual 349



Contents of Filling block (continued)Table C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

63 FO_UnitsPerPulse FLOAT S RW 0.0166666
7

Units Per Pulse

64 FO_FaultIndication UINT16 S RW 1 Frequency Output Fault Ac-
tion (integer code; see 
Table C-59)

65 FO_FaultFrequency FLOAT S RW 15000 Frequency Output Fault Val-
ue

66 FO_Polarity UINT16 S RW 1 Frequency Output Polarity:

• 0 = Active Low
• 1 = Active High

67 FO_FixOutput UINT16 S RW 0 Fix Frequency Output:
• 0 = Disabled
• 1 = Enabled

68 FO_FixedFrequency FLOAT S RW N/A Frequency Output Fixed Val-
ue

69 FO_ActualFrequency FLOAT D RO N/A Frequency Output Actual
Value

70 DO_Source UINT16 S RW 0x00CE
(206)

DO1 Assignment:
• 0x0068 (104) = Fault

Indication
• 0x006A (106) = Fill in

Progress
• 0x00CE (206) = Dis-

crete Batch: Purge Valve

71 DO_Polarity UINT16 S RW 1 DO1 Polarity:

• 0 = Active Low
• 1 = Active High

72 DO_FaultIndication UINT16 S RW 4 Discrete Output Fault Action
(integer code; see fol-
lowing table)

73 DO_FixOutput UINT16 S RW 0 Fix Discrete Output:
• 0 = Disabled
• 1 = Enabled

74 DO_FixedDiscrete UINT16 S RW 0 Discrete Output Fixed Value:

• 0 = Off
• 1 = On

75 SNS_ActionStartBatch UINT16 S RW 251 (Unas-
signed)

Assign Begin Filling as dis-
crete input action:

• 0 = No action
• 1 = Perform action
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Contents of Filling block (continued)Table C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

76 SNS_ActionEndBatch UINT16 S RW 251 (Unas-
signed)

Assign End Filling as dis-
crete input action:

• 0 = No action
• 1 = Perform action

77 SNS_ActionStopBatch UINT16 S RW 251 (Unas-
signed)

Assign Pause Filling as dis-
crete input action:

• 0 = No action
• 1 = Perform action

78 SNS_ActionResume-
Batch

UINT16 S RW 251 (Unas-
signed)

Assign Resume Filling as
discrete input action:

• 0 = No action
• 1 = Perform action

79 SNS_ActionResetMas-
sTotal

UINT16 S RW 251 (Unas-
signed)

Assign Reset Mass Total as
discrete input action:

• 0 = No action
• 1 = Perform action

80 SNS_ActionResetVolTo-
tal

UINT16 S RW 251 (Unas-
signed)

Assign Reset Volume Total
as discrete input action:

• 0 = No action
• 1 = Perform action

81 SNS_ActionResetAllTo-
tals

UINT16 S RW 251 (Unas-
signed)

Assign Reset All Totals as
discrete input action:

• 0 = No action
• 1 = Perform action

82 DI_Polarity UINT16 S RW 0 DI1 Polarity:

• 0 = Active Low
• 1 = Active High

83 IO_ChannelB_Assign-
ment

UINT16 S RW 4 Channel B Channel Type:

• 0 = Frequency Output
• 4 = Discrete Output
• 5 = Discrete Input

84 IO_ChannelB_Power UINT16 S RW 0 Channel B Power Type:

• 0 = External (Passive)

85 BAT_PrecisionDO_Ac-
tual1

UINT16 S RO N/A Precision DO1 Actual Value:

• 0 = Off
• 1 = On

86 BAT_PrecisionDO_Ac-
tual2

UINT16 S RO N/A Precision DO2 Actual Value:

• 0 = Off
• 1 = On
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Contents of Filling block (continued)Table C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

87 BAT_PrecisionDO_Fix-
Output1

UINT16 S RW 0 Fix Precision DO1:

• 0 = Off
• 1 = On

88 BAT_PrecisionDO_Fix-
Value1

UINT16 S RW 0 Precision DO1 Fixed Value:

• 0 = Off
• 1 = On

89 BAT_PrecisionDO_Fix-
Output2

UINT16 S RW 0 Fix Precision DO2:

• 0 = Disabled
• 1 = Enabled

90 BAT_PrecisionDO_Fix-
Value2

UINT16 S RW 0 Precision DO2 Fixed Value:

• 0 = Off
• 1 = On

91 BAT_BatchTotalAverage FLOAT D RO 0 Fill Total Average

92 BAT_BatchTotalVariance FLOAT D RO 0 Fill Total Variance

93 BAT_SecondaryBatchTo-
talAverage

FLOAT D RO 0 Secondary Fill Total Average

94 BAT_SecondaryBatchTo-
talVariance

FLOAT D RO 0 Secondary Fill Total Variance

95 BAT_ResetBatchStatis-
tics

UINT16 S RW 0 Reset Fill Statistics:

• 0 = No action
• 1 = Perform action

96 BAT_OverrideBlocked-
Start

UINT16 S RW 0 Override Blocked Start:
• 0 = No action
• 1 = Perform action

97 BAT_StartPurge UINT16 S RW 0 Begin Purge:

• 0 = No action
• 1 = Perform action

98 BAT_StopPurge UINT16 S RW 0 End Purge:

• 0 = No action
• 1 = Perform action

99 BAT_StartAOCCalibra-
tion

UINT16 S RW 0 Start AOC Cal:
• 0 = No action
• 1 = Perform action

100 BAT_StartSecondar-
yAOCTraining

UINT16 S RW 0 Start Secondary AOC Cal:
• 0 = No action
• 1 = Perform action

101 BAT_SaveAOCCalibra-
tion

UINT16 S RW 0 Save AOC Cal:
• 0 = No action
• 1 = Perform action
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Contents of Filling block (continued)Table C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

102 BAT_SaveSecondar-
yAOCTraining

UINT16 S RW 0 Save Secondary AOC Cal:
• 0 = No action
• 1 = Perform action

103 BAT_BatchCount UINT16 D RO 0 Fill Count

104 BAT_ResetBatchCount UINT16 S RW 0 Reset Fill Count:
• 0 = No action
• 1 = Perform action

105 BAT_PercentFill FLOAT D RO 0 Percent Fill

106 BAT_StartFill UINT16 S RW 0 Begin Filling:

• 0 = No action
• 1 = Perform action

107 BAT_StopFill UINT16 S RW 0 End Filling:

• 0 = No action
• 1 = Perform action

108 BAT_ResumeFill UINT16 S RW 0 Resume Filling:

• 0 = No action
• 1 = Perform action

109 BAT_ResetAocFlowRate UINT16 S RW 0 Reset AOC Flow Rate:

• 0 = No action
• 1 = Perform action

110 BAT_PauseFill UINT16 S RW 0 Pause Filling:

• 0 = No action
• 1 = Perform action

111 BAT_StartClean UINT16 S RW 0 Begin Cleaning:

• 0 = No action
• 1 = Perform action

112 BAT_StopClean UINT16 S RW 0 End Cleaning:

• 0 = No action
• 1 = Perform action

113 BAT_ParamUnits UINT16 D RO N/A Units used for fill meas-
urement. If Configure By is
set to % Target, unit is %.
If Configure By is set to
Quantity, unit is the unit
used for the Flow Source
process variable. See 
Table C-61.

114 BAT_ResetBatch UINT16 S RW 0 Reset Fill Total:
• 0 = No action
• 1 = Perform action
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Contents of Filling block (continued)Table C-54:   

Index Name Data type
Memory
class Access

Default
value Comments

115 BAT_StartSecondaryFill UINT16 S RW 0 Begin Secondary Filling:

• 0 = No action
• 1 = Perform action

116 BAT_StopSecondaryFill UINT16 S RW 0 End Secondary Filling:

• 0 = No action
• 1 = Perform action

117 BAT_CurrentTotal FLOAT D RO 0 Current Total

118 BAT_BatchFillTime FLOAT D RO 0 Fill Time

119 BAT_RotarySwitchSet-
ting

UINT16 S RO 0 Transmitter's node ad-
dress (network address)

120 IO_ChannelC_Assign-
ment

UINT16 S RW 3 Channel C Channel Type:

• 3 = (Secondary) mA
Output

121 IO_ChannelC_Power UINT16 S RW 1 Channel C Power Type:

• 1 = Internal (Active)

Bit definitions for Filling Status WordTable C-55:   

Hexadecimal Bit Description

0x0001 0 Primary fill in progress

0x0002 1 Secondary fill in progress

0x0004 2 Purge delay in progress

0x0008 3 Purge in progress

0x0010 4 Cleaning in progress

0x0020 5 Primary valve open

0x0040 6 Secondary valve open

0x0080 7 Purge valve open

0x0100 8 Pump running

0x0200 9 Primary AOC calibration in progress

0x0400 10 Secondary AOC calibration in progress

0x0800 11 Dual-fillhead filling enabled

0x1000 12 Timed filling enabled

0x2000 13 Reserved

0x4000 14 Fill logging in progress

0x8000 15 Undefined
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Bit definitions for Filling Diagnostics WordTable C-56:   

Bit (Hexadecimal) Bit (#) Description

0x0001 0 Start Not Okay

0x0002 1 AOC Flow Rate Too High

0x0004 2 Max Fill Time Exceeded

0x0008 3 Slug Flow

0x0010 4 No Sensor Response

0x0020 5 Drive Overrange

0x0040 6 Sensor Failure

0x0080 7 Transmitter Failure

0x0100 8 Density Overrange

0x0200 9 Temperature Overrange

0x0400 10 PROFIBUS Address Out of Range

0x0800 11 Undefined

0x1000 12 Undefined

0x2000 13 Undefined

0x4000 14 Undefined

0x8000 15 Undefined

Integer codes for mA Output Process VariableTable C-57:   

Code (Hexadeci-
mal)

Code (Deci-
mal) Description

0x0000 0 Mass flow rate

0x0001 1 Temperature

0x0002 2 Mass total

0x0003 3 Density

0x0004 4 Mass inventory

0x0005 5 Volume flow rate

0x0006 6 Volume total

0x0007 7 Volume inventory

0x000F 15 API: Temperature-corrected density

0x0010 16 API: Temperature-corrected (standard) volume flow

0x0011 17 API: Temperature-corrected (standard) volume total

0x0012 18 API: Temperature-corrected (standard) volume inventory

0x0013 19 API: Batch weighted average density

0x0014 20 API: Batch weighted average temperature

0x0015 21 Enhanced density: Density at reference temperature
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Integer codes for mA Output Process Variable (continued)Table C-57:   

Code (Hexadeci-
mal)

Code (Deci-
mal) Description

0x0016 22 Enhanced density: Density (fixed SG units)

0x0017 23 Enhanced density: Standard volume flow rate

0x0018 24 Enhanced density: Standard volume total

0x0019 25 Enhanced density: Standard volume inventory

0x001A 26 Enhanced density: Net mass flow rate

0x001B 27 Enhanced density: Net mass total

0x001C 28 Enhanced density: Net mass inventory

0x001D 29 Enhanced density: Net volume flow rate

0x001E 30 Enhanced density: Net volume total

0x001F 31 Enhanced density: Net volume inventory

0x0020 32 Enhanced density: Concentration

0x0021 33 API: CTL

0x002E 46 Tube frequency

0x002F 47 Drive gain

0x0030 48 Case temperature

0x0031 49 Left pickoff amplitude

0x0032 50 Right pickoff amplitude

0x0033 51 Board temperature

0x0035 53 External pressure

0x0037 55 External temperature

0x003F 63 Gas standard volume flow rate

0x0040 64 Gas standard volume total

0x0041 65 Gas standard volume inventory

0x0045 69 Live zero

0x00FB 251 None

Integer codes for mA Output Fault Action Table C-58:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 Upscale

0x0001 1 Downscale

0x0003 3 Internal zero

0x0004 4 No fault action
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Integer codes for Frequency Output Fault Action Table C-59:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 Upscale

0x0001 1 Downscale

0x0003 3 Internal zero

0x0004 4 No fault action

Integer codes for Discrete Output Fault Action Table C-60:   

Code (Hexadecimal) Code (Decimal) Description

0x0000 0 Upscale

0x0001 1 Downscale

0x0004 4 No fault action

Integer codes for fill measurement unitsTable C-61:   

Code (Hexadecimal) Code (Decimal) Description

0x0039 57 By percent

0x003C 60 Grams

0x003D 61 Kilograms

0x003E 62 Metric tons

0x003F 63 Pounds

0x0040 64 Short tons (2000 pounds)

0x0041 65 Long tons (2240 pounds)

0x0028 40 Gallons

0x0029 41 Liters

0x002A 42 Imperial gallons

0x002B 43 Cubic meters

0x002E 46 Barrels

0x0070 112 Cubic feet

0x00AA 170 Beer barrels

C.5.7 PROFIBUS Identification and Maintenance Functions
block
In the following table:

Index The index of the parameter within the block

Name The name used for the parameter within the block
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Data type The data type of the parameter

Memory class The memory class of the parameter:

D Dynamic store (cyclic data, parameter updated periodically)

S Static store (acyclic data, parameter changed on a deliberate
write)

N Nonvolatile parameter (saved across power cycles)

Access The type of access allowed for the parameter:

RO Read-only

RW Read/Write

Default value Value configured at the factory, unless a special configuration was
ordered

Comments A quick definition of the parameter, the name of the parameter in
ProLink II, or information about the parameter

Contents of I&M Functions blockTable C-62:   

Index Category Name Data type Size
Memo-
ry class Access

Default
value Description

255 I&M0 HEADER STRING 10 S RO 0x20
0x20
0x20
0x20
0x20
0x20
0x20
0x20

Manufactur-
er-specific
string

MANUFACTURER_
ID

UINT16 2 S RO 0x001F Manufactur-
er ID as-
signed by
PTO

ORDER_ID STRING 20 S RO Filling
Mass
Trans-
mitter

Order ID of
device

SERIAL_NO STRING 16 S RO Varies Production
serial num-
ber of device

HARDWARE_REVI-
SION

UINT16 2 S RO 0 Revision
number of
the hardware
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Contents of I&M Functions block (continued)Table C-62:   

Index Category Name Data type Size
Memo-
ry class Access

Default
value Description

SOFTWARE_REVI-
SION

• Octet 1 =
STRING

• Octet 2 =
UINT8

• Octet 3 =
UINT8

• Octet 4 =
UINT8

4 Octets S RO Type recog-
nition

REV_COUNTER UINT16 2 S RO 0 Marks the
change of
hardware re-
vision or any
of its param-
eters

PROFILE_ID UINT16 2 S RO 0xF600 Profile type
of supporting
profile

PROFILE_SPECIF-
IC_TYPE

UINT16 2 S RO 0xF600 Specific pro-
file type

IM_VERSION_0 UINT8 1 S RO 11 Implemen-
ted version
of I&M0 func-
tions

IM_VERSION_1 UINT8 1 S RO 11 Implemen-
ted version
of I&M1 func-
tions

IM_SUPPORTED UINT16 (1) 2 S RO 0x0003 Indicated
availability of
I&M func-
tions

15 I&M1 HEADER STRING 10 S RO 0x20
0x20
0x20
0x20
0x20
0x20
0x20
0x20

Manufactur-
er-specific
string

16 TAG_FUNCTION STRING 32 S RW Device iden-
tification tag

(1) Implemented as bit array.

Setting up and using the PROFIBUS interfaces

Configuration and Use Manual 359



Contents of I&M Functions block (continued)Table C-62:   

Index Category Name Data type Size
Memo-
ry class Access

Default
value Description

17 TAG_LOCATION STRING 32 S RW Device loca-
tion identifi-
cation tag
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troubleshooting   269

Descriptor   209

Device Information block, See PROFIBUS-DP
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electrical shorts

troubleshooting   290

enhanced events, See events
entrained gas, See density measurement, slug flow
events

configuring enhanced events   232

configuring for fill control
using PROFIBUS bus parameters   143

using ProLink II   51

using the PROFIBUS EDD   95

Enhanced Event Action
configuring   232

options   233

external-valve-control fills
configuring

using PROFIBUS bus parameters   171

using ProLink II   167

using the PROFIBUS EDD   169

definition   3
I/O requirements   5
operation   168, 170, 173

F
Fault Action

affected by Fault Timeout   205

digital communications   234

discrete outputs   228

frequency outputs   224

mA outputs   219

Fault Timeout
configuring   205
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integrated-valve-control fills
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definition   3
I/O requirements   5
operation
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See also fill logging
loop testing

using PROFIBUS bus parameters   279

using ProLink II   274

using ProLink III   276
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AO cutoff
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Fault Action
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configuring   215

default values   216
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scaling   215
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using the PROFIBUS EDD   283
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mass flow measurement
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cutoff
configuring   184
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configuring   181
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options   195
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temperature
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menu maps
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meter validation
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model codes, See transmitter model codes

N
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connecting to the transmitter   14, 18

datatypes   322

Device Information block   342

Diagnostic block   332

Filling Block   345

I&M block   357

Measurement block   322

diagnostic bytes   316

EDD
menu maps   302

setting up   14

GSD
input modules   311

output modules   315

setting up   310

supported functionality   301

transmitter model codes   5
ProLink II

connecting
Modbus/RS-485   8
service port   8

menu maps   296

overview   295, 296

requirements   295

protocols
supported by transmitter   5
supported user interfaces   5

proving, See meter validation
pulse width   223

Pump feature
configuring
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alarms   263

density measurement   286

discrete outputs   285, 286

drive gain   286–288

electrical shorts   290
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using PROFIBUS bus parameters   153

using ProLink II   59

using the PROFIBUS EDD   103

fill doesn't start
using PROFIBUS bus parameters   153

using ProLink II   59

using the PROFIBUS EDD   103
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grounding   274

mA outputs   271, 284, 286

mass flow measurement   267, 286

pickoff voltage   289

radio frequency interference (RFI)   285

restore factory configuration
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using ProLink II   12
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Index

Configuration and Use Manual 367



slug flow (two-phase flow)   286

system testing   273

temperature measurement   270

volume flow measurement   267, 286

wiring   273

two-phase flow, See density measurement, slug flow
two-stage discrete fills

configuring
using PROFIBUS bus parameters   118

using ProLink II   30

using the PROFIBUS EDD   74

definition   3
effect of Configure By on valve opening and

closing   35, 79, 124

effects of Pause and Resume on valve opening and
closing   60, 61, 63, 64, 104, 105, 107, 108, 154, 155,

157, 159

I/O requirements   5
valve opening and closing sequences   33, 77, 123

U
unit, See measurement units
Upper Range Value (URV)   215

user interfaces
for tasks   5
supported by transmitter   5

V
valve opening and closing sequences

effects of Pause and Resume   60, 61, 63, 64, 104, 105,

107, 108, 154, 155, 157, 159

normal operation   33, 77, 123

volume flow measurement
configuring   185

cutoff
configuring   188

configuring for filling applications   187

interaction with AO cutoff   189

effect of density cutoff on   198

effect of density damping on   198

effect of flow damping on   183

effect of mass flow cutoff on   184

measurement units
configuring   186

options   186

meter factor   252, 254

troubleshooting   267

W
water calibration, See calibration, density
wiring

grounding
troubleshooting   274

power supply wiring
troubleshooting   273

Z
zero

procedure
using PROFIBUS bus parameters   251

using ProLink II   247

using ProLink III   248

using the PROFIBUS EDD   250

restore factory zero
using PROFIBUS bus parameters   251

using ProLink II   247

using ProLink III   248

using the PROFIBUS EDD   250

restore prior zero
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