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SECTION 1 – ROCLINK 800 SOFTWARE BASICS 

This section describes how to use the ROCLINK 800 Configuration Software to configure and monitor 
ROC800-Series Remote Operations Controllers, ROC300-Series, FloBoss 407 Flow Managers, and 
FloBoss 100-Series devices.  

The software runs on a personal computer that uses the Windows 98 or higher operating system. This 
user manual covers configuration, calibration, monitoring, database archiving, custom displays, and 
embedded utilities. 

In this Chapter 
Section Page 
1.1 ROCLINK 800 Software Description............................................................................................. 1-1 

1.2 Computer Requirements ................................................................................................................. 1-2 

1.3 Contacting the Flow Computer Division ........................................................................................ 1-2 

1.4 Software Installation ....................................................................................................................... 1-2 

1.5 Starting ROCLINK 800 Software................................................................................................... 1-4 

1.6 User Interface Basics ...................................................................................................................... 1-6 

1.7 Configuration Basics..................................................................................................................... 1-14 

1.8 Creating a New Configuration File............................................................................................... 1-18 

1.1 ROCLINK 800 Software Description 
ROCLINK 800 Configuration Software provides the capability to monitor, configure, and calibrate 
ROC800-Series Remote Operations Controllers, ROC300-Series, FloBoss 407 Flow Managers, and 
FloBoss 100-Series Flow Managers. The software and user documentation are supplied on a CD-ROM. 

ROCLINK 800 software is designed for ease of use. Drop-down menus simplify accessing the functions 
provided by the software. Dialog boxes and drop-down list boxes help to direct selections and data 
entry. You can perform actions with the keyboard or a pointing device, such as a mouse. Refer to User 
Interface Basics for a description of the user interface. 

Help screens are accessed either from the Help menu or in a context-sensitive fashion using <F1>. This 
feature makes it easy to access on-line information for any ROCLINK 800 software topic. 

You can build custom displays for the ROC or FloBoss that combines both graphic and dynamic data 
elements. The displays can monitor the operation of the ROC or FloBoss either locally or remotely. 

The software also provides multiple levels of security for controlling access to ROCLINK 800 software 
functions, as well as the ROC database.  

� Note: If you are using a serial mouse (typically plugs into serial port COM1), be sure to set up 
communications to the ROC or FloBoss through a port that does not share interrupts (typically 
COM2), or a conflict occurs. 
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1.2 Computer Requirements 
ROCLINK 800 software runs on most IBM-compatible personal computers (PCs). The PC can be a 
desktop or a portable computer. In any case, the PC should meet the following minimum requirements: 

♦ Pentium-class processor (233 MHz or greater recommended). 
♦ CD-ROM drive. 
♦ Windows 98, ME, NT 4.0 (Service Pack 6), 2000 (Service Pack 2), or XP. 
♦ 64 MB of RAM (Random Access memory). 
♦ SVGA color monitor, 800 by 600 pixels, small fonts. 
♦ 15 to 50 MB of available hard disk space depending on Operating System and revision level. 
♦ EIA-232 (RS-232) serial connection, a dial-up modem connection, a TCP/IP connection 

(ROC800-Series), or a wireless radio (FloBoss 100-Series). 

1.3 Contacting the Flow Computer Division 
Please contact your local sales representative, or contact the Flow Computer Division directly. 

Emerson Process Management  
Flow Computer Division 
Marshalltown, IA 50158 USA 
Houston, TX 77065 USA 
Pickering, North Yorkshire UK Y018 7JA 

E-mail: fas.tech-support@emersonprocess.com 

Website: www.emersonprocess.com/flow/ 

Technical Support Website: www.emersonprocess.com/flow/Emerson/support/support_index.html 

Telephone: (641) 754-3449 (Monday through Friday 7:30 AM to 4:30 PM Central US Time) 

1.4 Software Installation 
To install ROCLINK 800 software:  

1. Start the installation by one of the two methods described below. 

♦ Method 1 – If you have a CD-ROM that contains the ROCLINK 800 installation files: 
 
A. Place the ROCLINK Software Installation CD-ROM into your drive. 
 
B. If the CD-ROM runs automatically, click the Install a ROCLINK Product button in the 
Main Menu.  
 
C. Click the Install ROCLINK 800 button in the Installation Screen. 
� Note: If the CD-ROM does not run automatically, click Windows Start > Run. 

When the Run dialog box opens, click the Browse button and navigate to the CD-
ROM drive and select Setup.exe. Click the Open button. If the CD-ROM drive is 
drive D, the location will be D:\Installs\ROCLINK800_ W68130\Setup.exe. Click 
OK in the Run dialog box. 
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♦ Method 2 – If you have .zip file that contains the ROCLINK 800 installation files: 
 
A. Extract the .zip file to the local hard drive (for example, in the C:\TEMP\ directory). 
 
B. Run setup.exe from extraction location (for example, run C:\TEMP\SETUP.EXE). 

The Installation Wizard screen appears. 

2. The Installation Wizard determines whether ROCLINK 800 has been installed previously. 

♦ If this is an upgrade, a dialog box appears asking whether to continue with the upgrade. Click 
Yes. Installation begins. Click Next when prompted. 

♦ If this is a new installation, click Next in the ROCLINK 800 Welcome screen. Read the 
License Agreement and click Yes to confirm. Enter your Name and Company name, and 
click Next. 

3. Select a destination folder, if you want to install the software in a folder other than the default, 
C:\Program Files\ROCLINK800. The ROCLINK800 default folder is recommended.  

4. Click Next.  

A confirmation screen appears when you are ready to start copying files. 

5. Click Next in the Setup Status screen. 

6. Click the Finish button in the Wizard Complete screen. 

7. If the installation was performed from the CD-ROM, select View Manual or Exit on the Main 
Menu screen. Once you have exited the Main Menu, remove the installation CD-ROM. 

� Note: A restart may be necessary after installation is complete. 

1.4.1 Manually Creating a Desktop Shortcut 
ROCLINK 800 software installation should automatically create a Desktop Shortcut on your computer. 
If for some reason you need to manually create the Desktop Shortcut, perform the following steps. 

1. Double-click the My Computer icon. 

2. Navigate to the C:\Program Files\ROCLINK800 folder or the folder where you installed 
ROCLINK 800. 

3. Select the ROCLINK.exe file. 

4. Select Create Shortcut from the File menu. 

5. Click and drag the shortcut to your Desktop. 

6. Double-click the shortcut on your desktop to launch ROCLINK 800 software. 
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1.4.2 Launching ROCLINK 800 During Setup 
This procedure launches ROCLINK 800 software every time you start this computer. 

1. Double-click the My Computer icon.  

2. Navigate to the C:\Program Files\ROCLINK800 folder or the folder where you installed 
ROCLINK 800 software. 

3. Select the ROCLINK.exe file. 

4. Select File > Create Shortcut. 

5. Depending on the Operating System of your PC, use the required method to place the shortcut 
file into the startup folder. 

1.4.3 Un-Installing ROCLINK 800 
To remove ROCLINK 800 software from a personal computer, perform the following steps. 

1. Click the Windows Start button. 

2. Select Settings > Control Panel. 

3. Double-click the Add/Remove Programs icon. 

4. Select ROCLINK 800. 

5. Click Add/Remove button. 

6. Follow the instructions. 

1.5 Starting ROCLINK 800 Software 
To use ROCLINK 800 software to configure a hardware device, you must have the ROC or FloBoss 
properly connected to power and I/O. Refer to the appropriate hardware instruction manual. Initially, the 
ROC should also be connected to a personal computer (PC) running ROCLINK 800 using the Local 
Operator Interface (LOI), serial, modem, or Ethernet port. 

To run ROCLINK 800 software, perform one of the following steps: 
♦ Double-click the Desktop shortcut. 
♦ Select Start > Programs > ROCLINK 800 > ROCLINK 800. 
♦ Double-click the file ROCLINK.exe located in C:\Program Files\Roclink800 (the default 

directory), or wherever you installed ROCLINK 800 software. 

The software loads and initializes.  

� Note: You can only run one version of ROCLINK 800 software at a time. 
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1.5.1 Logging On 
To log on to ROCLINK 800 Software: 

1. Connect the ROC or FloBoss to the Local Operator Interface (LOI – Local Port) and launch 
ROCLINK 800. 

  
Figure 1-1. Logon 

2. Type in your assigned 3-character identifier in the User ID field and press <Enter> or <Tab>.  

� Note: This User ID is case sensitive. 

Your initials are typically your User ID. If User IDs have not yet been assigned, try using the 
default User ID. of LOI. User IDs are assigned by using the ROC > Security feature in 
ROCLINK 800 software. 

3. Type in your assigned 4-digit Password and press <Enter> or click OK. For added security, the 
software displays an asterisk for each number that you type. If Passwords have not yet been 
assigned, use the default Password of 1000 (valid with default User ID of LOI).  

ROCLINK 800 software compares the entered User ID and Password to a list of valid ones.  

If the log on is not valid, a dialog box appears. Click OK and re-enter the User ID and Password. You 
can repeat the procedure as many times as needed until you successfully enter a valid User ID and 
Password.  

To exit from the log on screen, press <Esc> or click Cancel. This aborts ROCLINK 800 software and 
returns you to the point where you started ROCLINK 800 software. 
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1.6 User Interface Basics 
Users interact with ROCLINK 800 software using various displays on the computer monitor and the 
computer keyboard and/or pointing device. 

The major components of ROCLINK 800 software user interface are: 
♦ Menu bar and menus. 
♦ Toolbar. 
♦ Function screens. 
♦ Dialog boxes. 
♦ Help system, including the Status bar and message boxes. 
♦ Device Directory or Configuration Tree menu. 

ROCLINK 800 software employs a Graphical User Interface (GUI) with a standard Windows menu 
structure. After logging on to ROCLINK 800 software, available functions display in a menu bar with 
drop-down menus. A Status Line at the bottom left of the display contains pertinent information about 
the highlighted item, such as a menu option or a parameter.  

Buttons display dialog boxes for further configuration details or perform a desired action, such as the 
Update button. To activate the button: 

♦ Click the button with a left click of the mouse. 
♦ When a button is active, press <Enter> or a function key. 

Dialog boxes are areas that “pop up” inside the current screen to allow further selections or values to be 
entered. They can also provide messages or information that is more detailed. 

The menu structure lists choices from which you can select the desired function. Once a function is 
selected, the screen or dialog box for that function displays. This screen or dialog box provides the 
requested information and lets you enter the applicable configuration data. Refer to Table 1-1. 
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Table 1-1. Menu Listing for ROCLINK 800 
 

Menu Menu Options 
File New, Open…, Download…, Close, Save Configuration, Print Configuration, Print1, 3, 4,  

Print Setup1, 3, 4, [List of recent files], Exit 
Edit Undo1, 3, 4, Cut1, 3, 4, Copy1, 3, 4, Paste1, 3, 4 
View Directory, EFM Report, Calibration Report, History, Alarms, Events, Display, I/O Monitor, Toolbar
ROC Direct Connect, Connect, Collect Data, Clock, Security, Comm Ports, Memory2, 3, 4, Information, 

Flags 
Configure I/O, Control, History Segments1, History Points, Opcode Table, MODBUS, LCD User List2, 3, 

LCD4, User Data2, 3, 4 
Meter Setup, Calibration, Values, Plate Change, History3, 4 
Utilities Update Firmware, Update Hardware2, License Key Administrator1, Convert EFM File, User 

Program Administrator, ROCLINK 800 Security, AI Calibration Values, RTD Calibration Values1, 
MVS Calibration Values1, 3, FST Editor, ROC Keypad Display Editor1, Communications Monitor 

Tools Customize, Options 
Window Cascade, Tile, Device Directory, [List of open windows] 
Help Help Topics, About ROCLINK 800 

1. This option applies to ROC800-Series units. 
2. This option applies to FloBoss 100-Series units. 
3. This option applies to FloBoss 407 units. 
4. This option applies to ROC300-Series units. 
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1.6.1 Menu Bar and Menus 
The menu bar appears at the top of the screen. 

From the menu bar, you can use either the keyboard or the mouse to activate a menu and then to select a 
function in that menu. You can also select functions using ToolBar Buttons or the Configuration Tree 
Menu. 

 
Figure 1-2. Menu Bar and ToolBar (ROC800-Series Example) 

1.6.2 Buttons 
Several buttons appear on the majority of ROCLINK 800 screens. 

 Minimize and hide windows.  

 Maximize the size of the windows to fit in the screen area.  

 
Return to Original size of the window.  

 Close a window.  

  Expand options listed in the Device Directory or Configuration Tree Menu. 

 
Hide options listed in the Device Directory or Configuration Tree Menu.  

 Copy contents of window to Clipboard.  
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 Paste contents of the Clipboard to the active window.  

 Update contents of the active window from the device.  

 
Apply changes, if any, on the active window to the device and close the active window. 
A Confirm Save dialog box appears if there are unsaved changes.  

 Cancel all unsaved changes and close the active window.  

 Apply changes on the active window to the device.  

 Save contents of the active window.  

 
Close the active window. A Confirm Save dialog box appears if there are unsaved 
changes. 

 Delete current selection.  

1.6.3 ToolBar 
The following buttons appear in the ROCLINK 800 toolbar. These buttons will be grayed out if not 
applicable to the current screen. 

 

New file creates a New Configuration File. Available configuration parameters can be 
specified using menu selections. Configure the file as if you were connected to the device. 
Functions requiring a live connection are unavailable in this mode.  

 
Open a disk file opens an existing configuration file. Configuration files are created using the 
New Device or Save Configuration functions.  

 
Save file saves the current configuration of the connected Device to a disk file.  

 
Cut deletes currently selected text and places it in the Clipboard.  

 
Copy duplicates currently selected text and places it in the Clipboard.  

 
Paste places text currently in the Clipboard where the cursor is located.  

 
Print prints the configuration file.  

 AI Points views the Analog Input window.  

 
AO Points views the Analog Output window.  

 
DI Points views the Discrete Input window.  

 
DO Points views the Discrete Output window.  
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PI Points views the Pulse Input window.  

 
Clock views the Clock window.  

 
Comm Ports views the Comm Ports Setting window.  

 
Direct Connect connects to a Device locally using the (LOI) Local Operator Interface port.  

 
Connect connects to a Device.  

 
Flags views the Flags window.  

 
Meter Setup views the Meter Setup window.  

 
Configure PID Points views the PID Loop window.  

 
Plate Change views the Plate Change window.  

 
FST Editor launches the Function Sequence Table Editor.  

 
Display Program Information displays program information, version, creation date, and 
copyright of ROCLINK 800 software.  

 
Help launches ROCLINK 800 on-line help system.  

1.6.4 Keystrokes 
If you are using the keyboard, you may use the Alt key plus the letter to activate the menus. For 
example, press <Alt + F> and press <O> to select the Open file dialog. You may also use the Left Arrow 
← and Right Arrow → keys to highlight the menu bar item (the help Status Line at the bottom of the 
screen provides a description of the menu) and press the letter. 

With a menu displayed, you can highlight the desired item by using the Down Arrow ↓ and Up Arrow ↑ 
keys or the mouse. With the desired item highlighted, press the <Enter> key to activate the function.  

To leave a menu or submenu, press the <Esc> key. You can then select another menu. You can also 
access another menu simply by using the Left Arrow and Right Arrow key. 

The text scrolling keys are the <Page Up> and <Page Down> keys. 

To use the keyboard in configuration screens and dialog boxes, press the <Tab> key to move in a 
predetermined sequence from one parameter field or button to the next. The selected field or button 
becomes highlighted. Fields unavailable for changes are automatically skipped. 

When you <Tab> to the last field or button in the screen or dialog box, pressing the <Tab> key again 
jumps back to the first field or button. To go back to a previous field or button, press <Shift + Tab>. 
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In an option field, the currently selected option is highlighted. To select one of the other options, use the 
Up Arrow ↑ and Down Arrow ↓ keys to highlight the desired option, and then press <Enter>.  

In a field that requires a text or numerical entry, type in the required characters or numbers from the 
keyboard. Use the <Backspace> or <Delete> keys to erase unwanted characters. Use the Left Arrow ← 
and Right Arrow → to move the cursor one character at a time and the <Home> and <End> keys to 
place the cursor at the beginning and end of the field, respectively. 

Other keys or key combinations include: 
♦ <F1> – Launches ROCLINK 800 on-line help. 
♦ <Esc> – Cancels the current activity, closes the screen, and returns you to the last-used place in 

the menu structure, screen, or other place from which the dialog box originated. If a menu is 
active, <Esc> closes the last-opened menu, taking you up one level in the menu structure. If the 
menu bar is active, <Esc> de-selects all menu options. Press the <Alt> key or click with the 
mouse to reactivate the menu bar. 

♦ <Ctrl + N> – Creates a new configuration file. 
♦ <Ctrl + O> – Opens a configuration file. 
♦ <Ctrl + S> – Saves the current configuration file. 

1.6.5 Help System 
The Help menu provides detailed on-screen information about getting started with ROCLINK 800 
software and performing keyboard operations, a list of the Help topics, and the ROCLINK 800 software 
version. 

To display context sensitive help on a menu item, a parameter, or a button, press <F1> while the item, 
parameter, or button is highlighted. A help window appears on the screen.  

To view detailed help, select Help > Help Topics. 

Contents – The Contents button displays a list of Help Topics that display based on task oriented 
situations. Each screen, tab, and field has a help topic associated with it. For example: the Modbus 
Scale Values tab is located under Modbus > Modbus Configuration > Scale Values Tab. 

Index – Use the Index to locate specific Help Topics. The Index lists each field individually and by the 
tab or screen in which the field appears. For example: Modbus Scale Values appears in the Index 
under Modbus Configuration > Scale Values Tab and under Scale Values. Each field within the 
Scale Values Tab displays under the Index listing Modbus Configuration – Scale Values Tab and 
individual based on the name of the field. 

Search – Use Search to query on specific word. 

Back – Click to return to the last topic that you viewed. 

Print – Click to Print the currently displayed topic. 

<< and >> – Click the Browse Sequence buttons to navigate forward (>>) and backwards (<<) through 
the help system on a per topic basis. The Browse Sequence follows the order of the topics as 
displayed in the Contents tab. 

See Also – Click to display topics related to the selected topic. 
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1.6.6 About ROCLINK 800 
Select Help > About ROCLINK 800 to view the ROCLINK 800 version number and other information, 
such as Supporting Files Version Information. 

 
Figure 1-3. About ROCLINK 800 (ROC800-Series) 

1.6.7 Basic Navigation 
When you start the ROCLINK 800 software, the Device Directory displays. After you connect to a ROC 
or FloBoss, the Configuration Tree View displays. Refer to Figure 1-7. 

Use the + and – symbols to display or hide various options. Double-click a point to display the 
associated parameter configuration screen. You can also use the menu options and buttons to display the 
associated parameter configuration screen. 

The Status Line at the bottom of the Device Directory and Configuration Tree View serves two 
purposes. First, on the left side of the line, brief information about the device being connected. Second, 
on the right side of the line, the device on-line or off-line status and system time display. 
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1.6.8 TLP Box Selections 
Throughout ROCLINK 800 software, the Select TLP dialog can be accessed by clicking the 
browse button with three dots. The Select TLP dialog allows you to assign specific inputs and 
outputs to parameters. ROCLINK 800 software uses Point Type (T), Logical Number (L), and 
Parameter (P) to define point locations. 

 

  
Figure 1-4. Select TLP 

To use the Select TLP dialog box: 
1. Select the Point Type from the list. This opens a list of logical numbers and parameters that 

belong to that Point Type. 

2. Select the Logical Number. In the configuration screens, the Logical Number is generally 
referred to as Point Number or Number.  

3. Select the specific Parameter. These are usually called by the same term as the Tag on the 
configuration screen. Click OK. 

The display field at the bottom of the Select TLP dialog displays the numeric point location of the TLP 
point or a text abbreviation, depending on the setting in the Tools > Options window. 
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1.6.8.1 Display TLP Options 
Select Tools > Options to set whether TLPs display as text or numbers in TLP display fields throughout 
ROCLINK 800 software, including the FST Editor. For example, the TLP for Register 2 of FST 1 could 
display as either “FST 1,R2” or “96, 0, 3”. 

 
Figure 1-5. TLP Options 

Select Tools > Options to set the time interval, in seconds, at which the AutoScan feature on various 
screens in ROCLINK 800 software will poll the ROC or FloBoss device. Click the AutoScan button to 
cause ROCLINK 800 software to poll the device automatically, until the StopScan button is clicked. 

1.6.9 AutoScan Update Interval Option 
Select Tools > Options to set the time interval, in seconds, at which the AutoScan feature on various 
screens in ROCLINK 800 software will poll the ROC or FloBoss device. Pushing the AutoScan button 
on any screen will cause ROCLINK 800 software to poll the device automatically, until the StopScan 
button is pushed. 

1.7 Configuration Basics 
Configuration of a ROC or FloBoss unit can be performed by altering an existing configuration file or 
by starting a new configuration file. 

The full configuration procedure involves using the menu functions or Configuration Tree Menu to 
access the configuration screens. Some of the configuration screens may not be required for your 
application or may not be available for your type of ROC or FloBoss. 

The following checklists present the order of configuration in a typical application. Omit configuration 
screens for modules and accessories that do not appear in your hardware configuration and for control 
elements (PID, FST, and such) that do not apply to your application. 
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1.7.1 Configuration Checklist (ROC800-Series) 
For a ROC800-Series unit: 

♦ ROC menu > ROCLINK 800 Security (logon) 
♦ Device Directory > Comm Port > Properties (PC communication configurations) 
♦ ROC menu > Security (User List and Comm Port Security) 
♦ ROC menu > Clock 
♦ ROC menu > Information (system variables) 
♦ Utilities menu > License Key Administrator (for user programs, DS800 programs and AGA 

Meter Runs) 
♦ Meter menu > Setup > Station (for English or Metric Unit selection) 
♦ ROC menu > Comm Ports (ROC communication configurations) 
♦ Configure menu > I/O menu > AI, AO, DI, DO, PI, HART, MVS, RTD, and T/C 
♦ Meter menu > Station Configuration 
♦ Meter menu > Orifice or Turbine Meter Setup 
♦ Configure menu > History Segments and History Points (history database) 
♦ Configure menu > Control menu > PID Loop 
♦ Configure menu > Radio Power Control (for communications sleep mode) 
♦ Utilities menu > FST Editor 
♦ View menu > Display > New or from File (for custom PC displays) 
♦ Utilities menu > Keypad Display (for ROC Keypad Display) 
♦ ROC menu > Flags (for saving and system variables to Flash memory) 
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1.7.2 Configuration Checklist (ROC300-Series) 
For a ROC300-Series unit: 

♦ Utilities menu > ROCLINK 800 Security (logon) 
♦ Device Directory > Comm Port > Properties (PC communication configurations) 
♦ ROC menu > Security (User List and Comm Port Security) 
♦ ROC menu > Clock 
♦ ROC menu > Information (system variables) 
♦ ROC menu > Comm Ports (ROC communication configurations) 
♦ Configure menu > I/O menu > AI, AO, DI, DO, and PI 
♦ Meter menu > Setup (Orifice or Turbine meter) 
♦ Meter menu > History (Meter run history setup) 
♦ Configure menu > Control menu > PID Loop 
♦ Configure menu > History Points (history database) 
♦ Configure menu > LCD 
♦ Configure menu > Radio Power Control (communications sleep mode) 
♦ Utilities menu > FST Editor 
♦ ROC menu > Flags (for saving and system variables to Flash memory) 

1.7.3 Configuration Checklist (FloBoss 100-Series) 
For a FloBoss 100-Series unit: 

♦ ROC menu > ROCLINK 800 Security (logon) 
♦ Device Directory > Comm Port > Properties (PC communication configurations) 
♦ ROC menu > Security (User List and Comm Port Security) 
♦ ROC menu > Clock 
♦ ROC menu > Information (system variables) 
♦ ROC menu > Comm Ports (ROC communication configurations) 
♦ Configure menu > I/O menu > AI, AO, DI, DO, and PI 
♦ Meter menu > Setup (orifice or turbine meter) 
♦ Meter menu > History (Meter run history setup) 
♦ Configure menu > Control menu > PID Loop 
♦ Configure menu > History Points (history database) 
♦ Configure menu > LCD User List 
♦ Configure menu > Radio Power Control (for communications sleep mode) 
♦ Utilities menu > FST Editor 
♦ View menu > Display > New or from File (for custom PC displays) 
♦ ROC menu > Flags (for saving and system variables to Flash memory) 



ROCLINK 800 User Manual 

Rev. Dec-05 ROCLINK 800 Software Basics 1-17 

1.7.4 Configuration Checklist (FloBoss 407) 
For a FloBoss 407 unit: 

♦ Utilities menu > ROCLINK 800 Security (logon) 
♦ Device Directory > Comm Port > Properties (PC communication configurations) 
♦ ROC menu > Security (User List and Comm Port Security) 
♦ ROC menu > Clock 
♦ ROC menu > Information (system variables) 
♦ ROC menu > Comm Ports (ROC communication configurations) 
♦ Configure menu > I/O menu > AI, AO, DI, DO, PI, and MVS 
♦ Meter menu > Setup (Orifice or Turbine meter) 
♦ Meter menu > History (Meter run history setup) 
♦ Configure menu > Control menu > PID Loop 
♦ Configure menu > History Points (history database) 
♦ Configure menu > LCD User List 
♦ Configure menu > Radio Power Control (communications sleep mode) 
♦ Utilities menu > FST Editor 
♦ ROC menu > Flags (for saving and system variables to Flash memory) 

1.7.5 Duplicating a Configuration 
You can duplicate the configuration for another ROC or FloBoss unit by using these menu functions in 
the following order: 

1. File > Save Configuration to save the configuration to a specified file. 

2. ROC > Direct Connect (Local Port) or Connect (modem) to connect physically to the second 
unit, and then communicate. 

3. File > Download loads the configuration into the unit. 

After you have loaded configuration data into the second ROC (Step 3) and changed it as needed, you 
can save the configuration to its own disk file by using Step 1. 
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1.8 Creating a New Configuration File 
The new configuration file screen allows you to create a configuration file off-line with the basic 
information about the meters and modules that will be installed on the ROC or FloBoss unit for which 
the new configuration was created. 

1. Select File > New. 

 
Figure 1-6. New File Configuration Example (ROC800-Series) 

2. The Type parameter indicates the type of ROC or FloBoss unit.  

3. For the ROC800-Series, select the type of I/O or Comm 809 Modules that will reside in each of 
the nine module slots of the ROC800-Series unit. 

4. For the FloBoss 100-Series, select the type of termination board (I/O Type). Selections are 4 
point (old style termination board) or 6 point (new style) with or without I/O points. When 6 
point with I/O is selected, External I/O selections appear. Be sure to select the types of I/O for 
which the termination board switches and wiring are configured. 

5. For the ROC800-Series, enter the number of PID loops, FSTs, Stations, Sampler/Odorizers, 
Orifice Meters, and Turbine Meters that will be configured. Only activate the necessary number 
of devices.  

6. For the FloBoss 100-Series, enter the number of PID Loops. 

7. For the FloBoss 100-Series, select the maximum number of History Points in Standard and 
Extended History (103 History Sizing). Be sure to select this carefully, as History Points cannot 
be added later without clearing current history present in the unit. Standard history affects the 
amount of available extended history. 
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8. Save the configuration file. ROCLINK 800 files have the extension .800.  

9. Establish an on-line connection to the ROC or FloBoss unit. 

10. Set the parameters and point assignments, as necessary. 

The Type parameter indicates the type of ROC or FloBoss unit.  

For the FloBoss 100-Series, select the type of termination board (I/O Type). Selections are 4 point (old 
style termination board) or 6 point (new style) with or without I/O points. When 6 point with I/O is 
selected, External I/O selections appear. Be sure to select the types of I/O for which the termination 
board switches and wiring are configured. 

For the ROC800-Series, enter the number of PID loops, FSTs, Stations, Sampler/Odorizers, Orifice 
Meters, and Turbine Meters that will be configured. Only activate the necessary number of devices. For 
the FloBoss 100-Series, enter the number of PID Loops. 

For the ROC800-Series, select the type of I/O or Comm 809 Modules that will reside in each of the nine 
module slots of the ROC800-Series unit. 

For the FloBoss 100-Series, select the maximum number of History Points in Standard and Extended 
History (103 History Sizing). Be sure to select this carefully, as History Points cannot be added later. 

Optionally, the FloBoss 100-Series units have I/O. When 6 point I/O termination board is selected, 
External I/O selections appear. Be sure to select the types of I/O for which the termination board 
switches and wiring are configured. 

1.8.1 Opening a Configuration File 
The Open option allows you to open an existing configuration file either on-line (from a ROC or 
FloBoss unit) or off-line (from the PC hard drive or disk). Configuration files are created using the Save 
Configuration function. To open a configuration file: 

1. Establish an on-line connection to the ROC or FloBoss, if opening a file on-line.  

2. Select File > Open.  

3. Select the configuration file name. ROCLINK 800 files have the extension .800. 

4. Alter the parameters and point assignments as necessary. 

Once the configuration file is opened, it automatically becomes active and you may edit the file off-line. 
The configuration file may also be loaded into a ROC by using the Download function. 
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1.8.2 Configuration Tree Menu 
When you open a configuration file or go on-line with a ROC or FloBoss unit, the Configuration Tree 
appears on the screen. It has a hierarchy tree with the configurable items in the configuration, such as 
I/O, Meter Runs, and History. 

  
Figure 1-7. Configuration Tree 
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SECTION 2 – CONFIGURING COMMUNICATIONS AND 
SECURITY 

This section describes how to configure the communication ports on a PC and on a ROC or FloBoss. It 
also describes how to use the Connect and Direct Connect features in ROCLINK 800 software and 
security controlling access to the ROC or FloBoss and ROCLINK 800 software.  

Security can be controlled in two ways: 

♦ ROCLINK 800 Security – The ROCLINK 800 Security screen allows you to control who can 
log on to ROCLINK 800 software and which screens they can access. Refer to Section 2.2, 
ROCLINK 800 Security, on page 2-5. 

♦ Device Security – Device Security screen controls who has access to the Comm Ports on the 
ROC or FloBoss device. Refer to Section 2.3, Device Security, on page 2-6. 
� Note: Security Access Levels enable you to control which users have access to specific 

ROCLINK 800 functions. Refer to Section 2.1, Security Access Levels, on page 2-2. 

Before attempting to connect to a ROC or FloBoss, configure communication parameters in two places: 

♦ ROCLINK 800 Communications – The Device Directory communication configurations allow 
ROCLINK 800 software to communicate to an individual ROC or FloBoss unit. Refer to Section 
2.6, ROCLINK 800 Communications, on page 2-17. 

♦ Communication Ports on the ROC and FloBoss – Use the ROC > Comm Ports to set up 
communication ports available for incoming or outgoing communications with the ROC or 
FloBoss. Refer to Section 2.7, Communication Ports on the ROC and FloBoss, on page 2-21. 
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2.1 Security Access Levels 
Refer to Table 2-1. The Menu Options focus on the activity while you use the Access Levels to 
increase or decrease responsibility levels within the Menu Options.  

� Note: If security is enabled on any port, at least one user must have the highest level of security 
(level 5).  

� Note: Login requests are rejected when ROCLINK 800 Access Levels are greater than Device 
Security. 

Table 2-1. Security Access Levels 
 

Menu Menu Option Access Level 
ROC Security 5 
Utilities License Key Administrator 5 
Utilities ROCLINK 800 Security 5 
Utilities Update Firmware 4 
Utilities Upgrade Hardware 4 
Utilities Upgrade to FlashPAC 4 
Utilities User Program Administrator 4 
Configure Control > DS800 3 
Configure Control > FST Registers 3 
Configure Control > PID Loop 3 
Configure Control > Radio Power Control 3 
Configure Control > Sampler Odorizer 3 
Configure History Points 3 
Configure History Segments 3 
Configure I/O > AI Points 3 
Configure I/O > AO Points 3 
Configure I/O > DI Points 3 
Configure I/O > DO Points 3 
Configure I/O > MVS Sensor 3 
Configure I/O > PI Points 3 
Configure I/O > RTD Points 3 
Configure I/O > Soft Points 3 
Configure I/O > System AI Points 3 
Configure I/O > T/C Points 3 
Configure LCD User List 3 
Configure Modbus > Configuration 3 
Configure Modbus > History 3 
Configure Modbus > Master Modem 3 
Configure Modbus > Master Table 3 
Configure Modbus > Registers 3 
Configure Opcode Table 3 
Configure User Data 3 
File Download 3 
File New 3 
File Save Configuration 3 
ROC Clock 3 
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Menu Menu Option Access Level 
ROC Comm Ports 3 
ROC ROC Flags 3 
ROC ROC Information 3 
Tools Options 3 
Utilities AI Calibration Values 3 
Utilities Convert EFM File 3 
Utilities FST Editor 3 
Utilities MVS Calibration Values 3 
Utilities RTD Calibration Values 3 
View Display > New 3 
Meter Calibration > Orifice Meter 2 
Meter Calibration > Turbine Meter 2 
Meter History 2 
Meter Plate Change 2 
Meter Setup > Orifice Meter 2 
Meter Setup > Station 2 
Meter Setup > Turbine Meter 2 
Meter Values > Orifice Meter 2 
Meter Values > Turbine Meter 2 
ROC Collect Data 2 
View Calibration Report 2 
View EFM Report 2 
File Close 1 
File Open 1 
File Print Configuration 1 
File Recent Files 1 
ROC Memory 1 
View Alarms > From File 1 
View Alarms > From ROC 1 
View Events > From File 1 
View Events > From ROC 1 
View History > Between Dates 1 
View History > From File 1 
View History > From ROC 1 
View I/O Monitor 1 
Edit Copy 0 
Edit Cut 0 
Edit Paste 0 
Edit Undo 0 
File Exit 0 
File Print 0 
File Print Setup 0 
Help About ROCLINK 0 
Help Help Topics 0 
ROC Connect 0 
ROC Direct Connect 0 
Tools Customize 0 
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Menu Menu Option Access Level 
Utilities Communications Monitor 0 
View Directory 0 
View Display > Display 1 0 
View Display > Display 2 0 
View Display > From File 0 
View Toolbar 0 
Window Cascade 0 
Window Currently Open Files 0 
Window Tile 0 
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2.2 ROCLINK 800 Security 
Select Utilities > ROCLINK 800 Security. The ROCLINK 800 Security screen allows you to control 
who can log on to ROCLINK 800 software and which screens they can access. You may specify up to 
21 different users. The Operator ID is used as the User ID when you login to ROCLINK 800. Refer to 
Section 12, Keypad Display Security. 

� Note: After you initially access ROCLINK 800 software and establish security parameters, 
delete the default Operator ID LOI and default Operator Password 1000 to prevent unauthorized 
users from accessing and changing parameters. 

� Note: To delete an Operator ID, Password or Access Level, highlight the cell and use the 
backspace key or Delete key. 

 
Figure 2-1. ROCLINK 800 Security 

1. Select Utilities > ROCLINK 800 Security.  

2. Enter the three alphanumeric characters for the Operator ID, which is typically the initials of the 
person who operates the device. Each Operator ID must be unique and is case-sensitive.  

� Note: The default Operator ID is LOI and the default Password is 1000. 

3. Enter the four numeric characters between 0000 and 9999 to define the Password. More than 
one user can have the same Password.  

4. Enter the desired Access Level of the user. “0” is the lowest Access Level and allows access to 
the fewest number of screens. “5” is the highest Access Level and permits access to all screens. 
Each Access Level permits access to screens at that level and any inherited from lower access 
levels. For example, the users with Access Level 3, have access to screens with levels 0, 1, 2, and 
3. Refer to Table 2-1, Security Access Levels, on page 2-2. 
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2.3 Device Security 
Select ROC > Security. Device Security screen controls who has access to the Comm Ports on the ROC 
or FloBoss device. Refer to Section 12, Keypad Display Security. 

2.3.1 Device Security – Users (ROC800-Series and FloBoss 100-Series) 
 Select ROC > Security. For the ROC800-Series and the FloBoss 100-Series, the Device Security screen 
controls who has access to the Comm Ports on the ROC or FloBoss device. When Enabled, you must 
login to use the communications port. Each communications port may be Enabled or Disabled 
separately. For the ROC800-Series, the Keypad Display user and group security settings are also 
configured on this screen. 

The default Operator ID is LOI. The default Password is 1000. 

1. Select ROC > Security. 

2. Click an Operator ID field to add, edit, or remove a user. 

  
Figure 2-2. Device Security – Users (ROC800-Series and FloBoss 100-Series) 

3. Enter the Operator ID, Password, Confirmed Password, and user Access Level. Refer to 
Table 2-1, Security Access Levels, on page 2-2. 
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4. Select the Group to which the user belongs. 

 
Figure 2-3. Device Security – Users Maintenance (ROC800-Series and FloBoss 100-Series) 

5. Click OK and click Apply. 
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2.3.2 Device Security – Users (FloBoss 407) 
Select ROC > Security. The Device Security screen controls who has access to the Comm Ports and 
LCD / Keypad on the FloBoss device. When Enabled, you must login to use the communications port. 
Each communications port may be Enabled or Disabled separately. For the FloBoss 407, Device 
Security also controls who has access to the Liquid Crystal Display (LCD) for the unit. Select an 
Operator ID in the table to set each individual’s security, for up to 32 users. 

  
Figure 2-4. Device Security – Users (FloBoss 407) 

User Table – Select an Operator ID in the table to set each individual’s security. If you wish to create a 
user, click on an empty cell in the table. The Device Security dialog box appears.  

To delete an operator entry from the table, highlight a cell in that line. When the Device Security 
dialog box appears, click the Remove button. 

Operator ID – Enter the three alphanumeric characters for the Operator ID, which is typically the 
initials of the person who operates the device through that communications port. Each Operator ID 
must be unique. The Operator ID is case-sensitive. The default Operator ID is LOI. The default 
Password is 1000. 

Password – Enter the four numeric characters between 0000 and 9999 for the Password. Users can 
have the same Password. 

� Note: Login requests are rejected when ROCLINK 800 Access Levels are greater than Device 
Security. Refer to Table 2-1, Security Access Levels, on page 2-2.  

Access Level – Enter the desired Access Level of the user. “0” is the lowest Access Level and allows 
access to the fewest number of screens. “5” is the highest Access Level and permits access to all 
screens. Each Access Level permits access to screens at that level and any inherited from lower 
access levels. For example, the users with Access Level 3, have access to screens with levels 0, 1, 2, 
and 3. Refer to Security Access Levels for a full list of the access levels. Refer to Table 2-1, Security 
Access Levels, on page 2-2. 

� Note: If security is enabled on any port, at least one user must have the highest level of security 
(level 5). 
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LCD ON – Select Enabled to turn the LCD Display Always ON and leave it active, or select Disabled to 
allow the LCD Display to time out and turn itself off. If Enabled, the LCD remains on until the next 
user logs on who has the LCD Disabled.  

LCD Custom User List – Check a radio button to give a user access to the LCD Custom User List 1, 
2, and 3 of an on-line FloBoss 407 for viewing, editing, or both. This includes the keypad functions.  

Security On LOI, Security on COM1, and Security on COM2 – For each communications port, select 
Disabled, User ID Enabled (to require security on a specific communications port), or User Access 
Level Enabled (to require a specific level of security for this user).  

2.3.3 Device Security – Users (ROC300-Series) 
Select ROC > Security. The Device Security screen controls who has access to the Comm Ports and 
optional Liquid Crystal Display (LCD) on the ROC device. When Enabled, you must login to use the 
communications port. Each communications port may be Enabled or Disabled separately and you can 
select the Access Level.  

  
Figure 2-5. Device Security – Users (ROC300-Series) 

User Table – Select an Operator ID in the table to set each individual’s security. If you wish to create a 
user, click on an empty cell in the table. The Device Security dialog box appears. Refer to Device 
Security. 

To delete an operator entry from the table, highlight a cell in that line. When the Device Security 
dialog box appears, click the Remove button. 

Operator ID – Enter the three alphanumeric characters for the Operator ID, which is typically the 
initials of the person who operates the device through that communications port. Each Operator ID 
must be unique. The Operator ID is case-sensitive. 
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Password – Enter the four numeric characters between 0000 and 9999 for the Password. Users can 
have the same Password. 

Access Level – “0” is the lowest Access Level and allows access to the fewest number of screens. “5” is 
the highest Access Level and permits access to all screens. Each Access Level permits access to 
screens at that level and any inherited from lower access levels. For example, the users with Access 
Level 3, have access to screens with levels 0, 1, 2, and 3. Refer to Security Access Levels. 

� Note: Login requests are rejected when ROCLINK 800 Access Levels are greater than Device 
Security. Refer to Table 2-1, Security Access Levels, on page 2-2. 

Security On LOI and Security on COM1 – For each communications port, select one of the following 
options: 
♦ Disabled – All login requests are accepted. 
♦ User ID Enabled – Login requests are accepted if the User ID and Password are valid. Upon 

successful login, full access is allowed. 
♦ User Access Level Enabled – Login requests are accepted if the User ID and Password are 

valid. Upon successful login, the user is restricted by access level. Refer to Security Access 
Levels. Refer to Table 2-1, Security Access Levels, on page 2-2. 

2.3.4 Device Security – Groups  
Select ROC > Security. Click the Groups tab. For ROC800-Series units, with firmware version 1.50 or 
greater, the Group tab establishes the Groups used in Keypad Display security. Enter a name for each 
Group that you are establishing. If your application does not require a Keypad Display, do not create 
Groups. 

  
Figure 2-6. Device Security – Groups (ROC800-Series) 
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2.3.5 Device Security – Comm Ports (ROC800-Series and FloBoss 100-
Series) 

Select ROC > Security. Click the Comm Ports tab. For each communications port, select one of the 
following Security on options: 

♦ Disabled – All login requests are accepted. 

♦ User ID Enabled – Login requests are accepted if the Operator ID and Password are valid. Upon 
successful login, full access is allowed. 

♦ User Access Level Enabled – Login requests are accepted if the Operator ID and Password are 
valid. Upon successful login, the user is restricted by access level. Refer to Table 2-1, Security 
Access Levels, on page 2-2. 

  
Figure 2-7. Device Security – Comm Ports (ROC800-Series and FloBoss 100-Series) 



ROCLINK 800 User Manual 

Rev. Nov-05 Configuring Communications and Security 2-12 

2.3.6 Device Security – Users / Group Summary (ROC800-Series) 
Select ROC > Security. Click the Users / Group Summary tab. For ROC800-Series units, with 
firmware version 1.50 or greater, the User/Group Summary tab displays which users belong to which 
Group. Use the Users and Groups table to quickly make changes to the ROC > Security settings. 

  
Figure 2-8. Device Security – User/Group Summary (ROC800-Series) 
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2.4 License Key Administrator (ROC800-Series) 
Select Utilities > License Key Administrator to access the license information on any license key that 
may currently be installed in the CPU of the ROC800-Series. From this screen, you can view and 
manage the licenses stored on the license key(s).  

AGA Meter Runs and some applications, such as DS800 and user programs, must have a license key 
installed in the ROC800-Series CPU with the appropriate entry to allow execution of the application. 

The Application Code is specific to the application and is defined by the application provider. The 
application code should not be mistaken for license quantity. License Application Code values may not 
be merged or split. 

♦ In a DS800 license, the application code has no meaning and is 0.  
♦ In a User Program license, the application code’s meaning is documented in the user program’s 

manual.  
♦ In an AGA 3/7/8 license, the application code will be 6, which indicates six Meter Runs per 

license. If the quantity of licenses is 2, then 12 Meter Runs can execute. 

  
Figure 2-9. License Key Administrator (ROC800-Series) 

The License Key grids provide a list of the licenses currently on the key in the upper (#1) and lower (#2) 
key slots of the CPU module. Licenses may be moved from one key to another. If both keys are full, the 
Move, Merge, and Split buttons are grayed out. 

Use the Move button to move licenses from one key to another key.  

Use the Merge button to merge the first two similar entries by creating a single license with the 
combined quantities.  

Use the Split button to split a license with a quantity greater than 1. This allows multiple quantity 
licenses to be split and moved between license keys. You cannot split a license with a quantity of 1. 
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2.5 Device Directory 
The Device Directory is the first screen that displays after logging in to ROCLINK 800 software. The 
Device Directory provides a way to create and maintain communications setup configurations for a PC 
running ROCLINK 800 software. The communication ports on the PC can be uniquely configured to 
send data to specified ROC or FloBoss units. 

  
Figure 2-10. Device Directory 

Use the  +  and  –  symbols to display or hide various options. 

� Note: Configuration of the PC Communication Ports to the ROC or FloBoss unit cannot be 
performed within the Configuration Tree screen. You must return to the Device Directory. If you 
are in a configuration, select Window > Device Directory or View > Directory to go to the 
Device Directory. 

The PC communication configurations allow ROCLINK 800 software to communicate to an individual 
ROC or FloBoss unit. You may add, delete, or modify these communications setups and establish a tree 
of Groups and Devices. 

The Device Directory is used to set up the personal computer’s (PC) communications ports (COM 
ports).  
The ROCLINK 800 Communication Parameter Setup screen allows you to change your PC 
communications port, time-out settings, and other variables, used by ROCLINK 800 software when 
establishing a connection to a Device.  

In order for ROCLINK 800 software to communicate with a Device, ROCLINK 800 software must 
know to which device it is communicating. Each Device within a Group is given a unique Device 
Address. 
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2.5.1 Device Root 
The Device Root is the organizational level in the Device Directory. When you open ROCLINK 800 
software, the default Device labels display in the Device Directory. You can modify these 
communications setup configurations, or you can create new configurations.  

 
Figure 2-11. Device Root 

The default Device Root labels include: 
♦ COM1 Device 
♦ COM2 Device 
♦ Modem Device 
♦ Ethernet Device 
♦ New Group1 

♦ New Device1 
♦ New Device2 

The communication configurations allow ROCLINK 800 software to communicate to an individual 
ROC or FloBoss unit. You may add, delete, or modify these communications setups and establish 
Groups of devices. Creating a back-up file of the Device Root settings after you have configured the 
settings is highly suggested. To do so, use Windows Explorer to find the ROC_user.mdb file, then create 
a back-up copy of this file in case your settings should ever be corrupted. 

Devices can be configured for on-line communications using the Local Operator Interface (LOI) port or 
a communication port, such as a modem. 

Each icon represents a different type of communications connection. 
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The devices can be logically organized to form Groups. A Group is typically several units in the same 
geographical area. Each Group contains a list of all the devices contained within that Group.  

Each ROC or FloBoss has a Tag and unique Device Address for differentiation. The Device Address 
must be different from any other host system that may access the network. The Tag and Device Address 
are set by clicking with the right mouse on the Device and selecting Properties.  

2.5.1.1 Adding a Group 
Devices can be organized to form Groups. Groups are typically units in the same geographical area or 
units with something else in common. When you select a Group file, a list of all communication setups 
in the Group appears below the Group.  

To add a new Group under the Device Root directory or add a Subgroup to an existing Group: 

1. Select the Device Root directory icon. 

2. Right-mouse click. 

3. Select Add a Group. 

4. Right mouse click again and Rename the Group or use the default.  

5. You may now wish to add a Device. 

2.5.1.2 Deleting a Group 
To delete a Group under the Device Directory: 

1. Select a Group. 

2. Right-mouse click. 

3. Select Delete Group. 

4. Click Yes in the Confirm Delete Message dialog.  

2.5.1.3 Deleting a Device 
To delete a Device under the Device Directory: 

1. Select a Device by highlighting the Name next to its icon. 

2. Right-mouse click on the Name. 

3. Select Delete Device. 

4. Click Yes in the Confirm Delete Message dialog.  

2.5.1.4 Adding a Device 
To add a new Device under the Device Directory or add to an existing group: 

1. Select the Device Root directory icon. 

2. Right-mouse click. 

3. Select Add a Device. 

4. Configure the communication parameters.  

� Note: You can place a Device connection under a Group by selecting the Group before 
adding the Device connection. 
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2.5.1.5 Deleting All Devices 
To delete all Device communication parameter configurations under the Device Root directory: 

� Note: This deletes all ROC units that you currently have configured. 

1. Select the Device Root directory icon. 

2. Right-mouse click. 

3. Select Delete All Devices. 

4. Click Yes in the Confirm Delete Message dialog box.  

2.5.1.6 Renaming a Group or Device 
To rename a Group or Device in the Device directory: 

1. Select (highlight) the Device Name or Group label. 

2. Right-mouse click on the Device Name or Group label. 

3. Select Properties. 

4. Enter the Tag of the Group label or Device Name. 

5. Press OK or Apply. 

2.6 ROCLINK 800 Communications 
The Device Root is the organizational level in the Device Directory. When you open ROCLINK 800 
software, the default Device labels display in the Device Directory. You can modify these 
communications setup configurations, or you can create new configurations. Refer to 2.3, Device 
Security, on page 2-6. 

2.6.1 ROCLINK 800 Communications – General  
The Device Directory is the first screen that displays after logging in to ROCLINK 800 software. Use 
the ROCLINK 800 Communications General tab to configure basic communications for the PC running 
ROCLINK 800 software.  

1. Select the Device Root directory icon. 

2. Right-mouse click on a communications icon. 

3. Select Properties. 
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Figure 2-12. ROCLINK 800 Communications – General Example (ROC800-Series) 

Tag – Enter the Station Name in the Tag field. 

Connect – Press the Connect button to connect using the configured parameters for this PC 
Communications Port. 

Device Group – The Group in which the ROC or FloBoss is associated. 

Device Address – The Address of the specific ROC or FloBoss with which you desire to communicate. 
If you are connected to a multi-drop series of devices, enter the Device Address and Device Group 
of the specific Device to which you will talk.  

� Note: If the PC that is running ROCLINK 800 software is connected directly to the LOI Local 
Port on the device, ROCLINK 800 makes a request to Device Group of 240 and Device Address 
of 240. The Local Port of a device always responds to a request for Address 240/Group 240, no 
matter what Device Address and Device Group is configured in the device if the LOI Security is 
valid.  

� Note: For communications to any port on the ROC or FloBoss, other than the Local Port, the 
Device Address and Device Group in the ROCLINK Communications Parameters window 
determines which device will be contacted. The Device Address and Group must match the 
Device Address and Group in the ROC > Information screen. Changing the Device Address and 
Group, on the ROCLINK 800 Communications Parameters window, will cause the PC to 
communicate with a different device. 

� Note: When using a FloBoss 100-Series device, the default Device Group of 240 and Device 
Address of 240 allows communications to any Comm Port. 
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Host Address – The PC has a default value of Address 3 and Group 1. If more than one computer 
running ROCLINK 800 software will be communicating with a group of devices, either by radio or 
by other multi-drop communications, the Host Address of each Device Directory setup must be 
unique to avoid multiple responses. The Host Address must also be different from any other host 
system that may access the communications link. 

Host Group – The PC has a default value of “1.” When using ROC Protocol, the Group address must 
match the address setup at the destination device in order for communications to properly transmit. 
In the assignment of the Host Group and Host Address, the following convention should be used: 

Host Group and Host Address limitations: 
0 and 240= Reserved 

Use – Select the connection type: Comm Port, Modem, or TCP/IP. 

� Note: If TCP/IP is selected, the Time Out parameter on the Advanced tab applies, but the other 
parameters do not apply. Firmware updates cannot be transmitted over a TCP/IP connection. 

PC Comm Port – If in the Use portion of the screen, you selected Comm Port, select the PC Comm 
Port on the computer to be used by ROCLINK 800 software for this setup. The device can 
communicate through any configured Comm Port of the PC. Typically, COMM1 or COMM2 is used 
with the Local Port. Before selecting this parameter, check to see which Communications Ports are 
assigned in the PC. 

Baud Rate – The Baud Rate is set in the PC and used by ROCLINK 800 software to communicate with 
the device through a serial port (COM port). For successful communications, the Baud Rate setup 
in the ROC and the Baud Rate set here for the PC must match. If you are having difficulties 
communicating to your device, set the Baud Rate in both the device and the computer to 19200 bps. 

� Note: When using a FloBoss 100-Series, you may need to set the Baud Rate to 9600 bps if you 
are communicating simultaneously with external devices. 

Phone Number – If in the Use portion of the screen, you selected Modem, enter the Phone Number of 
the device to be dialed by ROCLINK 800 software.  

Modem – Use the Modem drop-down list box to choose your modem. Only the modems set up from the 
Modems dialog box in the Window’s Control Panel on your PC display. Ensure that the selected 
modem is properly setup.  

Override Default TAPI Init String –  Enter a value to override your modem’s default Initialization 
String configuration. 

IP Address – If in the Use portion of the screen, you selected TCP/IP, enter the IP Address and Port 
Number so the Ethernet port of a ROC800-Series controller may be accessed by ROCLINK 800 
software. Enter the IP Address of the ROC to be accessed. The default IP Address for a ROC is 
10.0.0.2.  

Port Number – The Port Number of the ROC to be accessed. The default Port Number for a ROC is 
4000. If these default values are changed in the ROC800-Series, all ROC Plus communications over 
TCP/IP connections will be closed and you will have to re-establish a connection. Port Numbers 
1113 and 1131 are reserved. 

If Login to ROCLINK 800 Configuration software fails, then the TCP/IP connection closes. 

� Note: If the number of active ROC Plus Protocol using TCP/IP connections displayed on the 
ROC > Information > Internet tab is 6, then you will not be able to establish a connection. 
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2.6.2 ROCLINK 800 Communications – Advanced  
Use the ROCLINK 800 Communications Advanced tab to configure advanced communications for the 
PC running ROCLINK 800 software. 

1. Select the Device Root directory icon. 

2. Right-mouse click on a communications icon. 

3. Select Properties. 

4. Click the Advanced tab. 

 
Figure 2-13. ROCLINK 800 Communications Example – Advanced (ROC800-Series) 

Number of Retries – Can be set from 0 to 25. Once connected, ROCLINK 800 will attempt to request 
data. This is the number of times to try after the initial attempt to request data from the specified 
device and before reporting a timeout error. Adjust the amount of time between retries using the 
Time Out parameter.  

The Number of Retries parameter does not apply to the dial-up modem, which only tries to establish 
a connection once. 

Tx Delay –  Enables the RTS line for the amount of delay specified before transmitting data. Tx Delay 
is typically used to allow a radio to fully stabilize before data is applied to transmit.  

♦ For EIA-232 (RS-232) and Dial-up Modem communications, the Tx Delay and Key Off Delay 
values should normally be set to 0 (zero) or the default of 0.05 seconds. 

♦ For EIA-485 (RS-485) and Radio communications, the Tx Delay value is typically set to 0.1. 
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Time Out –  The actual amount of time that ROCLINK 800 software waits to receive a valid message 
after it sends a request to a device. Do not enter 0 (zero) in the Time Out field. For Dial-up Modem 
communications, the Time Out value is typically set to 3 seconds. 

Key Off Delay – Defines the amount of time to delay when done transmitting a message before turning 
the RTS signal off. For EIA-232 (RS-232) and Dial-up Modem communications, the Tx Delay and 
Key Off Delay values should normally be set to 0 (zero). 

CRC Check – Select Enabled or Disabled in the ROCLINK CRC Check field for Cyclical Redundancy 
Checking. 

2.7 Communication Ports on the ROC and FloBoss 
While in a configuration and on-line with a ROC or FloBoss unit, select ROC > Comm Ports to display 
the Comm Port settings screen. Each communications port has a unique set of parameters on the screen. 

The ROC > Comm Ports screen is used to setup the communications ports that are available for 
incoming and outgoing communications with the ROC or FloBoss and not the personal computer 
(PC). PC communication ports are setup using the Device Directory. 

The communication ports located on the ROC or FloBoss provide a data link to ROCLINK 800 
software, other ROC or FloBoss units, and host systems. Depending on the type of modules you are 
using, the following types of communications are possible: 

♦ EIA-232 (RS-232) serial communications. 
♦ EIA-422 (RS-422) serial communications (ROC800-Series). 
♦ EIA-485 (RS-485) multi-point serial communications. 
♦ Dial-up modem communications. 
♦ TCP/IP communications (ROC800-Series). 
♦ Spread-Spectrum wireless radio (FloBoss 100-Series). 

Table 2-2. Communication Ports for the ROC800-Series 
 

Port Port Location Default Tag Function/Type 
1 CPU RJ-45 (top) Local Port LOI / RS-232D 
2 CPU RJ-45 (middle) COMM1 Ethernet 
3 CPU 5-pin (bottom) COMM2 Serial / EIA-232 (RS-232) 
4 Module Slot 1 COMM3 EIA-232 (RS-232), EIA-422 (RS-422), EIA-485 (RS-485), 

Modem, or MVS 
5 Module Slot 2 COMM4 EIA-232 (RS-232), EIA-422 (RS-422), EIA-485 (RS-485), 

Modem, or MVS 
6 Module Slot 3 COMM5 EIA-232 (RS-232), EIA-422 (RS-422), EIA-485 (RS-485), 

Modem, or MVS 
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Table 2-3. Communication Ports for the FloBoss 407 
 

Port Default Tag Function/Type 
1 Local Port LOI / RS-232D 
2 COMM1 EIA-232 (RS-232) 
3 COMM2 EIA-232 (RS-232), EIA-485 (RS-485), or Modem 

� Note: COMM1 is built into the termination board of the FloBoss 407, and COMM2 
is located on an optional communications card. 

Table 2-4. Communication Ports for the FloBoss 100-Series 
 

Port Default Tag Function/Type 
1 Local Port LOI / RS-232D 
2 COMM1 Serial / EIA-485 (RS-485) 
3 COMM2 EIA-232 (RS-232), Modem, or Spread-Spectrum Radio 

� Note: COMM2 requires an optional communications card. 

Table 2-5. Communication Ports for the ROC300-Series 
 

Port Default Tag Function/Type 
1 Local Port LOI / RS-232D 
2 COMM1 EIA-232 (RS-232), EIA-485 (RS-485), or Modem 
3 COMM2 EIA-232 (RS-232), EIA-485 (RS-485), or Modem 

� Note: COMM1 and COMM2 are located on an optional communications card. 

The communication ports of the ROC or FloBoss provide a link to computers, such as one running 
ROCLINK 800 software or a host computer. ROC800-Series units can have up to six communication 
ports. FloBoss and ROC300-Series units can have up to three. 

Select ROC > Comm Ports to set up communications ports available for the ROC or FloBoss.  

� Note: For FloBoss 100-Series, the Modem tab only appears after Comm Ports 3 has been 
selected. 

The SRBX or RBX (Spontaneous Report-by-Exception) alarming feature is available for serial 
communication ports. It is not supported on the Ethernet port. This feature allows the device to call in to 
a host computer when a configured alarm occurs. To prevent “nuisance” alarms from being reported to 
the host, configure the parameters correctly. If you wish to configure dial-up SRBX, then a modem must 
be present and appropriately configured. 

When using SRBX Alarming, you must ensure that the alarms are enabled and configured for each point 
you desire to monitor. Configure the alarm parameters so that an alarm occurs only when desired. These 
parameters are configured on the Alarms tabs of the I/O configuration screens.  

Once configured, the configuration of all communications ports should be saved to programmable ROM 
using the Flash Memory Save Configuration function in the ROC > Flags screen. 
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Figure 2-14. Comm Port (ROC800-Series) 

  
Figure 2-15. Comm Port (FloBoss 100-Series) 
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Figure 2-16. Comm Port (FloBoss 407 and ROC300-Series) 
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2.7.1 Comm Ports – General  
Select ROC > Comm Ports to configure the communications ports on the ROC or FloBoss. 

 
Figure 2-17. Comm Port Example (ROC800-Series) 

Select the Communications Port that the device is using to communicate.  

Enter the 10-character Tag name for identification of the communications port. 

Comm Type (ROC800-Series) displays the type of communications port associated to this Comm Port 
number, such as EIA-232 (RS-232).  

Select the transmit and receive data Baud Rate in bits per second. 

If Parity checks are to be performed by the communications controller, select the Parity radio button. 

Select the number of Data Bits contained in an asynchronous byte, or character. This number is 
typically 8.  

Select the number of Stop Bits contained in an asynchronous byte, or character. This number is  
typically 1. 
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Enter the Key On Delay to define the number of seconds to delay after turning the RTS signal on before 
beginning transmission. For some older radios, the Key On Delay may need to be set as high as 0.2 
seconds. For newer radios designed for data transmission, no more than 0.02 second should be required. 
For Dial-up modems and EIA-232 (RS-232) communications, the Key On Delay should normally be set 
at 0 seconds or may be changed to optimize communications. 

Enter the Key Off Delay intervals defining the period to delay before turning the RTS signal off once a 
valid message has been sent. The default of 0.01 seconds should be sufficient for most radios. For Dial-
up modems and EIA-232 (RS-232) communications, the Key Off Delay should normally be set at 0 
seconds or may be changed to optimize communications. 

Select the Port Owner (ROC800-Series). This refers to the communications protocol that will be in use 
on this Port.  

♦ ROC Plus Protocol/Modbus Slave configures the Port to automatically switch between 
Modbus and ROC Plus protocol messages.  

♦ ROC Plus Protocol Only configures the Port to only accept ROC Plus protocol messages 
(Modbus Slave is disabled).  

♦ Modbus Slave Only configures the Port to allow the ROC or FloBoss to act only as a Modbus 
slave device (ROC Plus Protocol is disabled).  

� Note: It is recommended that the “Only” options be used if the messages received will only 
be of this specific protocol. Otherwise, select ROC Plus Protocol/Modbus Slave if this 
Comm Port is going to have both protocols communicate on it. 

♦ Modbus Master configures the Port to allow the ROC or FloBoss to poll Modbus devices (ROC 
Plus Protocol and Modbus Slave are disabled.)  

♦ DS800 configures the Port to download and debug Development Suite 800 projects only. You 
will not be able to connect two ROC800-Series units together with this option. It is exclusively 
configured for DS800/PC communications.  

� Note: Modems are not supported for the DS800 communication type. 

♦ LCD configures the port for communications with a ROC Keypad Display unit. 

♦ I/O Module configures this Port to use the communications protocol residing in the I/O module.  

♦ User Program 1 to 8 configures this Port to use the communications protocol residing in the 
loaded user program. The user program number here will match the user program number in the 
Configuration Tree menu and the User Program Administrator screen. 

♦ Reserved indicates that this Port is reserved and cannot be used for communications. 

For the ROC300-Series and FloBoss 407, enable RTS/CTS Handshaking, if applicable.  

The Valid Receive Ctr (Counter) displays the number of valid messages received by the FloBoss 100-
Series, ROC300-Series, or FloBoss 407 on this communication port. This counter can be preset to a 
value or cleared. 

For the FloBoss 100-Series, Comm Board indicates if the communications port is available. Local Port 
and COMM1 are always present. Comm Board and Board Type indicate an optional communications 
board is installed. 
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2.7.2 Comm Ports – Modbus Host Parameters (FloBoss 407 and ROC300-
Series) 

Select ROC > Comm Ports > Modbus Host Parameters tab to configure the Modbus communications on 
the ROC or FloBoss.  

 
Figure 2-18. Modbus Host Parameters (FloBoss 407 and ROC300-Series) 

� Note: Modbus functionality is not resident in the firmware. The Modbus User Program must be 
loaded and enabled for this tab to be relevant. 

1. Select ROC > Comm Ports. 

2. Select the host Comm Port and click the Modbus Host Parameters tab.  

3. Select the Start Transmission Active radio button to enable Modbus transmission. 

4. Enable Continuous Polling to continuously poll for Modbus messages.  

5. Enter the Starting Host Request line number entry in the host table where you desire the poll to 
begin. The poll request continues through each line, starting at the value entered in this field, 
until it reads a 0 in the Modbus host table. 

6. Enter the Host Poll Delay to specify the amount of time in seconds to wait between poll 
transmissions. 

The Transmission Status displays the current status of the Modbus program. 
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2.7.3 Comm Ports – Modem 
Select ROC > Comm Ports > Modem tab to configure the Modem communications ports on the ROC or 
FloBoss. 

 
Figure 2-19. Comm Port – Advanced Example (ROC800-Series) 

Select Modem Type Internal when an internal modem is detected. Select None when using a Serial 
link to the host or External when using a Modem that is external to the ROC or FloBoss.  

� Note: Internal cannot be selected by the user, it is automatically set.  

Set the Connect Time parameter to determine the amount of time that the ROC or FloBoss waits after 
initiating a call to receive a connect message from a device (typically the modem) before it terminates 
the call. The Connect Time varies from system to system and can take up to 60 seconds to make and 
complete a dial up connection. If a successful connection is made, the Disconnect Time begins. 

Set the Disconnect Time parameter to determine the amount of time that the ROC or FloBoss waits for 
further activity on the line before it hangs up. This timer resets after each valid receive signal. 

Enter the Inactivity Time in seconds that the ROC or FloBoss will wait, without receiving a signal, 
before it resets the modem. The inactivity timer looks at the valid receive counter to determine if the 
signal has been received. 

Enter the Config Command characters required to initialize the modem. For external modems, refer to 
the manufacturer’s literature. For an internal modem, use the default value or the modem card may not 
operate correctly. Refer to your modem’s documentation for default Config Command characters. 
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Enter the Hayes-style Connect Command required to contact the host. Typically, this is the command 
ATDT followed by the telephone number. This parameter is required only for dial-out operations, such 
as for SRBX Alarming.  

For example, ATDT5155551212 

For a ROC800-Series, enter the Hayes-style Disconnect Command required to disconnect the contact 
to the host. Typically, this is the command ATH0.  

The Modem Status numerically displays the result code. 

Result Code Definition 
0 = OK Successfully executed command line 
1 = CONNECT Connection established 
2 = RING Ring signal detected 
3 = NO CARRIER Carrier not detected/lost (Not supported by the FloBoss 100-Series) 
4 = ERROR Error in command line (Not supported by the FloBoss 100-Series) 
6 = NO DIAL TONE No dial tone detected (Not supported by the FloBoss 100-Series) 
7 = BUSY Busy signal detected (Not supported by the FloBoss 100-Series) 
8 = NO ANSWER Line not picked up on the called end (Not supported by the FloBoss 100-Series) 
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2.7.4 Comm Ports – SRBX or RBX  
Select ROC > Comm Ports > SRBX or RBX tab to configure the Spontaneous-Report-by-Exception 
alarming features on the ROC or FloBoss. 

 
Figure 2-20. Comm Port – SRBX Example (ROC800-Series) 

Enables or Disables SRBX Mode or RBX Mode for Spontaneous-Report-by-Exception alarming on this 
Comm Port. 

When using SRBX Alarming, you must ensure that the alarms are enabled and configured for each point 
you desire to monitor. Configure the alarm parameters so that an alarm occurs only when desired. These 
parameters are configured on the Alarms tabs of the I/O, MVS, and Meter Setup configuration screens.  

Enter the SRBX Host Address and SRBX Host Group number of the host to which the SRBX feature 
is communicating.  

Defines the time in seconds between attempts to transmit an SRBX message. There is a Delay parameter 
associated with each Retry Count parameter. 
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The SRBX Attempts #1 to #3 (Retry Count) is the number of attempts a message is repeated if a valid 
response is not obtained on the first attempt. Attempts include the initial message, plus the retries. The 
three Retry Count parameters each have an associated Delay parameter. This allows you to set up 
different length delays for successive retries. Selecting Fixed Number allows you to enter a value for 
how many times a message is retried after the first unsuccessful attempt. Note that a “0” entry causes no 
retries. Selecting Continuous (255) causes continuous retries that can only be stopped when the host 
acknowledges the SRBX alarm. 

For example: If you set  
Retry Count #1 to “2” and Delay #1 to “10”,  
Retry Count #2 to “1” and Delay #2 to “20”,  
then after the first unsuccessful attempt to communicate with the host, the device tries two more 
times (after waiting 10 seconds each time), and once more (after waiting 20 seconds). 

Defines the time in seconds between attempts to transmit an SRBX message. There is a Delay parameter 
associated with each Retry Count parameter. 

Enable Extra Key On Delay (FloBoss 100-Series, ROC300-Series, and FloBoss 407) to add an 
additional amount of time to delay prior to transmitting an RBX message after turning the RTS signal 
on. This parameter may be required for radio communications. 

For the FloBoss 100-Series unit, the RBX Ack Timeout field displays the amount of time that is 
allowed for the host to respond with an ACK (acknowledge) to the SRBX message from the FloBoss 
100-Series unit. If the ACK fails to be received within the timeout period, the FloBoss 100-Series unit 
retries the SRBX messages. 

The SRBX Alarm Index indicates the ROC or FloBoss alarm currently being reported through SRBX.  

The SRBX Status parameter indicates the status of RBX messaging, either Active or Inactive. Active 
indicates that an SRBX alarm is being processed. 
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2.7.5 Comm Ports – Store & Forward (ROC800-Series and FloBoss 407) 
Select ROC > Comm Ports > Store & Forward tab to configure the Store & Forward features on the 
ROC or FloBoss. 

 
Figure 2-21. Comm Ports – Store & Forward (ROC800-Series and FloBoss 407) 

Select Store & Forward Port (FloBoss 407 and ROC300-Series) Same Port to transmit a received 
message out using the same communications port, or select Opposite Port to transmit using an alternate 
communications port.  

� Note: Only COMM1 and COMM2 Ports are supported. 

Enter the Store & Forward Path Address and Group numbers of the devices that need to receive this 
SRBX message and forward it on to the next device to extend the communications path. You may also 
specify addresses for other devices that support the ROC Protocol. The device specified by the last non-
zero Address/Group then sends the message to the host specified by the previous parameter. 

If Store & Forward Mode (ROC800-Series) is Enabled, all Store and Forward messages transmit out 
the Port selected in the General tab. If it is Disabled, none will be sent. 
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2.7.6 Comm Ports – Diagnostics (ROC800-Series) 
Select ROC > Comm Ports > Diagnostics tab to view the communications diagnostic features on the 
ROC. 

 
Figure 2-22. Comm Ports – Diagnostics (ROC800-Series) 

The Valid Receive Counters displays the number of valid messages received by the ROC800-Series 
unit for the ROC Plus Protocol or Modbus protocol.  

The Successful Message Time displays the time and date of the last valid message received for ROC 
Plus protocol or Modbus protocol. 

The Transmit Counter displays the number of messages sent by the ROC800-Series unit.  

Invalid Message Bytes displays the number of ROC Plus or Modbus protocol bytes lost since the last 
time it was cleared.  

Invalid Message Byte Time displays the time and date of the last invalid message. 
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2.7.7 Configuring TCP/IP Communications on the Ethernet Port (ROC800-
Series) 

TCP/IP connections through the ROC800-Series Ethernet port can be used for DS800, Modbus® RTU 
encapsulated in TCP/IP, Modbus TCP/IP, or ROC Plus Protocol communications.  

To configure TCP/IP communications: 
1. Connect to the ROC. 

2. If using ROC Plus, Modbus RTU Encapsulated in TCP/IP, or Modbus TCP/IP, the 
parameters on the Internet tab of the ROC > Information screen must be set. Refer to Section 
3.2.2. 

3. If using DS800, verify the parameters and enable the DS800 communications on the Configure > 
Control > DS800 screen.  

4. If using Modbus RTU Encapsulated using TCP/IP or Modbus TCP/IP, select the 
communications port and configure the parameters on the Configure > Modbus > Configuration 
screen.  

The parameters on the General, Modem, SRBX, and Store and Forward Tabs of the ROC > Comm Ports 
screen do NOT apply to the Ethernet port.  

The Diagnostics tab of the ROC > Comm Ports screen displays the communication statistics available 
for all Modbus and ROC Plus Protocol communications transmitted using TCP/IP connections. Refer to 
Parameters on Comm Ports Diagnostics Tab (ROC800-Series). 

The total number of Modbus and ROC Plus Protocol over TCP/IP connections is limited to 6 of each 
protocol at any given time. The number of active TCP/IP connections is displayed on the Active 
Connections field on the Internet tab of the ROC > Information screen. 

SRBX messaging or firmware updates cannot be transmitted over a TCP/IP connection. 

Once a ROC Plus Protocol, Modbus RTU encapsulated in TCP/IP, or Modbus TCP/IP connection is 
made, the communication session can be closed by a timeout. Three timeouts that can close a connection 
are executed as follows: 

♦ A security timeout is started after a valid Login. If a valid ROC Plus Protocol message is not 
received within 60 minutes, the connection closes. The timeout is reset after each valid message. 

♦ An inactivity timer for each TCP/IP connection has been added in addition to the security 
timeout. The Inactivity Time field on the Internet tab of the ROC Information screen sets this 
parameter in seconds. A value of 0 disables the timer. If a valid ROC Plus Protocol message is 
not received within the Inactivity Time, the connection closes. 

♦ Each connection will be kept alive by periodic transmissions of messages (probes). If the other 
side of the connection fails to respond to 10 repetitive probes, the connection will be considered 
broken and the connection closed. The amount of idle time (in seconds) before the first probe is 
configurable is set in the Keep Alive Time field on the Internet tab of the ROC > Information 
screen. The other 9 probes will be 64 seconds apart. The total time will be: (9*64) + the value of 
the Keep Alive Time parameter. 
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DS800 
DS800 Development Suite Software can be used to develop programs, independently of ROCLINK 800 
software. These programs can be downloaded over the Ethernet port to a ROC800-Series that has the 
optional license key installed. 

Once DS800 is enabled on the Configure > Control > DS800 screen, the Ethernet port for DS800 is 
always available to accept DS800 connections. 

The ROC800-Series unit is capable of distinguishing TCP/IP messages received from DS800, in 
Modbus or in ROC Protocol. The DS800 messages are routed to the correct communications task in the 
ROC800-Series unit’s firmware.  

ROC Plus Protocol 
ROC > Security for the Ethernet port will enable or disable security for all ROC Plus Protocol based 
Ethernet connections. 

The Ethernet port is always available to accept ROC Plus Protocol connections. 

Modbus 
The ROC800-Series (firmware version 1.30 or greater) allows both Modbus RTU encapsulated in 
TCP/IP and Modbus TCP/IP communications on the Ethernet port. Modbus RTU encapsulated in 
TCP/IP is the form of Modbus protocol traditionally supported on serial connections in the ROC800-
Series, which has been or encapsulated in a TCP/IP message. Modbus TCP/IP is the protocol developed 
for use over TCP/IP connections.  

� Note: Both Modbus RTU encapsulated in TCP/IP and Modbus TCP/IP support Slave mode only. 

The Ethernet port is always available to accept Modbus connections. 

The ROC800-Series is capable of supporting Modbus communications on any of the serial ports, at the 
same time as Modbus RTU encapsulated over TCP/IP or Modbus TCP/IP connections. 
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2.8 Connecting to a ROC or FloBoss 
Once ROCLINK 800 communication parameters are configured, you can connect to the ROC or 
FloBoss unit. You can connect in several ways: 

♦ Direct Connect – Connect to the device using the Local Operator Interface Port (LOI) if the 
default communication parameters apply.  

♦ Device Directory – Double-click the Device Name to connect to the device using the parameters 
currently set for that port. 

♦ ROC > Connect – Connect to the Device Name currently selected in the Device Root.  

� Note: Once you are connected (on-line), the Configuration Tree view becomes the active 
screen. 

2.8.1 Direct Connect 
Select Direct Connect to establish a connection with a ROC or FloBoss. ROCLINK 800 
software attempts to establish communications through COM1 of the PC at one of the 
following baud rates: 19200, 9600, 57600, 38400, 4800, 2400, and 1200 bps. If this is 
unsuccessful, the program then attempts to establish communications through the remaining 
COM Ports of the PC, successively, until it receives a valid reply. 

To use Direct Connect: 
1. Physically connect cable to the ROC or FloBoss. 

2. Launch and login to ROCLINK 800 software. 

3. Do one of the following: 
♦ Click on the Direct Connect icon in the Device Directory. 
♦ Click the Direct Connect button on the toolbar. 
♦ Select ROC > Direct Connect. 

4. If this is the first time that you have connected to the ROC or FloBoss, continue to the steps for 
Setting the Clock. 

By default, the Local Port is the Comm Tag in the ROC > Comm Port settings screen. 

For the Direct Connect option to work, security conditions must be met, and the IBM-compatible 
personal computer (PC) must be connected to the Local Port (LOI) of the device with communication 
settings of: 

♦ 8 Data Bits 
♦ 1 Stop Bit 
♦ No Parity  

The Direct Connect command causes ROCLINK 800 software to initiate communications with the ROC 
or FloBoss device by performing a search of the PC communication ports at various baud rates. Direct 
Connect then “locks on” to the first Comm Port and Baud Rate that are successful in communicating 
with a device. 
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2.8.2 Local Operator Interface (LOI – Local Port) 
The PC running ROCLINK 800 software physically connects to the ROC or FloBoss device through a 
cable. For a local connection, this cable is typically a prefabricated local operator interface (LOI) cable 
(available from the Flow Computer Division of Emerson Process Management). One end of the cable (a 
9-pin, D-shell, female connector) plugs into a serial communications port on the PC running ROCLINK 
800 software. The other end of the cable plugs into the ROC or FloBoss operator interface connector 
called the Local Port.  

2.8.3 Connect 
To connect the computer to a remotely located ROC or FloBoss, a serial, dial-up modem, radio, satellite, 
or other communications line should be installed. This connection may be made through the LOI (Local 
Port) or other Communications Port on the ROC or FloBoss.  

Use the Connect command to connect to a serial or dial-up modem. To use Connect: 

1. Physically connect the ROC or FloBoss unit. 

2. Launch and log in to ROCLINK 800 software. 

3. Perform one of the following: 
♦ Select a device from the Device Directory and press the <Enter> key. 
♦ Double-click a device in the Device Directory. 
♦ Select a device from the Device Directory and click the Connect button on the toolbar. 
♦ Select ROC > Connect to connect to the device currently selected in the Device Directory. 

2.8.4 Successful Login 
A successful login produces an on-line connection. The Configuration Tree of the configuration that is 
in the ROC or FloBoss unit displays. Refer to Configuration Tree Menu. 

  
Figure 2-23. Successful Login Example (ROC800-Series) 
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The following Configuration Tree menu options are available: 

I/O – Lists all available inputs and outputs by type. 

Control – Displays the FST, PID, Radio Control, Sampler, and DS800 (ROC800-Series) options 
enabled on the ROC > Information screen. 

Station – Lists all available Stations and Meters (ROC800-Series). 

Meter – Lists all available Meters (FloBoss 100-Series, FloBoss 407, and ROC300-Series). 

System – Displays ROC > Information system folders, Comm Port, Flags, and Opcode Table. 

History – Displays all available History Segments and points. 

User Programs – Displays all installed User Programs (ROC800-Series). 

User Data – Displays all installed user defined points (FloBoss 100-Series, FloBoss 407, and ROC300-
Series). 

From the Configuration Tree, you may change the configuration or monitor current operations. 

Once you are in the Configuration Tree menu, you can use the  +  and  –  symbols to display or hide 
various options. 

Double-click the desired function in the Configuration Tree to display the associated screen. Double-
clicking an icon is the same as selecting the menu bar or Toolbar button option. 

If this is the first time that you have connected to the ROC or FloBoss, continue to the Setting the Clock 
procedure. Refer to Setting the Clock. 

2.9 Troubleshooting Communications  
This section details how to troubleshoot connection and communications. 

2.9.1 Troubleshooting Connection Errors 
Several events can cause a connection problem: 

♦ If the parameters used by ROCLINK 800 when establishing a communications link to your PC 
are incorrect, a Direct Connect connection cannot be made.  

♦ If ROCLINK 800 software stands idle for too long and exceeds the timeout value for a device, a 
communications failure can also occur. In this case, simply log back into ROCLINK 800 and use 
the Direct Connect or Connect features.  

♦ If you do not have security access to the ROC or FloBoss, a connection cannot be made. A valid 
User ID and Password must be configured for each user who can connect to a ROC or FloBoss in 
the ROC > Security options. 

♦ If the PC cannot establish a connection to the ROC800-Series by “pinging” the Device Address 
(ROC Address), a TCP/IP connection through ROCLINK 800 software cannot be made.  
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2.9.2 Troubleshooting ROCLINK 800 Communications 
Occasionally, you may need to alter your PC communications options when you are having problems 
communicating with your ROC or FloBoss. 

1. Select the desired Device in the Device Directory. Right-mouse click and select Properties. 

2. Make sure you have specified the correct Device Address and Device Group of the ROC or 
FloBoss with which you are trying to communicate. If you are communicating through the LOI 
port of the device, the Device Address is 240 and Group Address is 240, which is the universal 
address. 

3. Click the Advanced tab. Try increasing the Time Out and/or Tx Delay.  

4. Click Apply. Return to the General tab, and click Connect. 

5. If you are still having trouble communicating, try increasing the Number of Retries field in the 
Advanced tab screen. Click Apply. Return to the General tab, and click Connect. 

6. If you are still having trouble communicating, try increasing or decreasing the Keyoff Delay 
field in the Advanced tab screen. Click Apply. Return to the General tab, and click Connect. 

2.9.3 Troubleshooting TCP/IP Connections 
If you are unable to establish a connection between ROCLINK 800 software and the ROC800-Series 
unit on the Ethernet port, verify that the PC is able to “ping” the ROC.  

1. Launch the DOS command prompt and write a command to “ping” the ROC at its IP Address. 
For example, C:\>ping 155.177.78.111”. 

2. If the Ping Statistics Reply is similar to “Packets: Sent = 4, Received = 4, Lost = 0 <0% loss>”, 
then the PC and ROC are connecting. You may need to alter the Internet communications setting 
in ROCLINK 800 software. Verify all parameters on the pertinent screens. Refer to Configuring 
TCP/IP Communications on the Ethernet Port (ROC800-Series). 

3. If the Ping Statistics Reply is similar to “Packets: Sent = 4, Received = 0, Lost = 4 <100% 
loss>”, then the PC and ROC are not connecting. You will need to review your network, your 
physical connection, your router, and your PC. 
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2.9.4 Communications Monitor 
Select Utilities > Communications Monitor and perform an operation to displays the data bytes (in 
hexadecimal format) sent and received from the ROCLINK 800 software during that operation. Bytes 
sent are shown in black; bytes received are shown in red. Data received since the last good response 
(and before a request) are shown in aqua.  

Right-click on the display to Copy highlighted data, Clear All data, or Unselect. Copied data can be 
pasted in a file for analyzing.  

  
Figure 2-24. Communications Monitor Example (ROC800-Series) 

2.9.5 Disconnecting from a ROC or FloBoss 
To disconnect an on-line connection, close the screen by clicking the lower of the two 
Close buttons or select File > Close. This automatically closes the connection.  

  
Figure 2-25. Device Directory 
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SECTION 3 – CONFIGURING SYSTEM PARAMETERS 

This section describes how to set system preferences within the ROC or FloBoss, such as the Clock, 
Security, System Information, and License Keys.  

In this Chapter 
Section Page 
3.1 Setting the Clock .............................................................................................................................. 3-1 

3.2 Configuring Device Information ...................................................................................................... 3-2 

3.3 Configuring System Flags .............................................................................................................. 3-15 

3.1 Setting the Clock 
Immediately after connecting to a ROC or FloBoss for the first time, set the Clock to ensure proper 
logging of history. 

The internal real-time clock provides time-stamping and control of the historical databases, Event Log, 
and Alarm Log.  

� Note: The time stamp in the ROC or FloBoss reflects the time at the end of the period, not at the 
beginning. Data collected from 0800 to 0900 is thus time-stamped 0900. This is used for the 
logging of history. 

 
Figure 3-1. Clock 

1. Select ROC > Clock or click the Clock icon in the toolbar. 

2. If the clock in your PC is set correctly, you can use it to set the ROC or FloBoss clock. Click 
Today at the bottom of the calendar and click Apply.  
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3. If the PC clock is not correct: 

♦ Use the arrow buttons to select the correct Month and Year. You can also click the Month to 
select the exact month or the Year and use the arrows to select the desired Year. 

♦ Click on the desired day of the month. 
♦ Click on the time field and type in the desired value (type P or A for the AM/PM field) or use 

the arrows.  

4. The clock can automatically compensate for daylight savings time by enabling this feature 
(ROC800-Series and FloBoss 100-Series). 

5. Click the Apply button. 

6. Click the OK button. 

3.2 Configuring Device Information 
The Device Information screen establishes the Station Name, Address, Group, and other global variables 
that differentiate each individual ROC or FloBoss. Other system variables set in the Device Information 
screen must be established for a particular application.  

Select ROC > Information. The General tab has basic information about the ROC or FloBoss. The 
Points screen allows you to change the number of certain points that you want to be active. The Other 
Information tab and Revision Info tab (FloBoss 100-Series) display information about the firmware and 
boot firmware. The System Configuration tab (ROC800-Series) allows you to specify the four Baud 
Rate Generators (BRG) possible by the ROC800-Series unit at any one given time. 

The Internet tab allows you to set addresses for I/P and other Internet communication options. TCP/IP 
connections can be used for either DS800, Modbus RTU encapsulated in TCP/IP, Modbus TCP/IP, or 
ROC Plus Protocol communications. If the default value of the IP Address, Gateway Address, or Subnet 
Mask parameter is changed, then all ROC Plus Protocol over TCP/IP connections will be closed, and 
you will have to re-establish a connection. 
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Figure 3-2. Device Information (ROC800-Series) 

  
Figure 3-3. Device Information (FloBoss 100-Series) 
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Figure 3-4. Device Information (FloBoss 407 and ROC300-Series) 

3.2.1 Information – General  
Select ROC > Information. The General tab has basic information about the ROC or FloBoss. 

 
Figure 3-5. Device Information Example (ROC300-Series) and FloBoss 407 
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Enter the Station Name to be logged in EFM Reports for easy site identification. 

Enter a unique Address with which to differentiate each individual ROC or FloBoss device among all 
units in a communications group. The Address can be assigned a value from 1 to 255. Do not assign a 
value of 240 for an address. 

Enter a Group to identify a set of ROC or FloBoss units for communication purposes, typically to a host 
that polls the ROC or FloBoss. The Station Group can be assigned a value from 1 to 255. Do not assign 
a value of 240 for a Group. All of the ROCs addressed as an area in the host have the same Station 
Group. 

When using the ROC Protocol, the Group and Address values must match the address setup at the 
destination device in order for communications to properly transmit. 

For a ROC800-Series, TCP/IP connections can be used for Modbus RTU encapsulated in TCP/IP, 
Modbus TCP/IP, and ROC Plus Protocol communications. If the default value of the Address or Group 
parameters is changed, then all Modbus RTU encapsulated in TCP/IP, Modbus TCP/IP, or ROC Plus 
Protocol over TCP/IP connections will be closed, and you will have to re-establish a connection. 

Select either US or Metric Units (FloBoss 100-Series) for calculations. If Metric units are selected, then 
the AGA calculation expects all inputs to be in terms of the indicated units (such as kPa for the static 
pressure input). The calculation results are then in terms of the selected units. 

Enter the Contract Hour (FloBoss 100-Series, ROC300-Series, and FloBoss 407) which is the time 
when values are totaled for a single day of production, accumulators are cleared, and data is logged to 
the Daily History database. The Contract Hour is based on a 24-hour clock with midnight as the "0" 
hour. 

Select Force End of Day (FloBoss 100-Series, ROC300-Series, and FloBoss 407) checkbox, and click 
Apply to cause the current day and its hourly values to be logged into memory for all historical data 
except Station totals. Force End of Day also resets the daily and hourly accumulators. Force End of Day 
uses one of the 35 possible slots for storing daily data. 

The user may specify how many FST instructions will be executed per FST Execution period (FloBoss 
100-Series). Execution period is 1 second. The default number of instructions is 20. When the default is 
used, an FST with 30 sequential instructions will run in 2 execution periods; 20 in the first period and 10 
in the second.  

� Note: Changes to this parameter will take effect in the next execution period. Re-start is not 
required. 

� Note: To reduce the potential risk of loading on the FloBoss unit, the user should monitor the 
MPU loading when changes to this parameter are made. 

The Device Type field displays the type of ROC or FloBoss being configured. 
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3.2.2 Information – Internet (ROC800-Series) 
Select ROC > Information. The Internet tab (ROC800-Series) configures addresses for Internet 
communications. 

 
Figure 3-6. Information – Internet (ROC800-Series) 

View the MAC Address for the ROC unit. The Media Access Control Address (MAC) Address is also 
referred to as the Ethernet address and is set at the factory.  

Enter the desired IP Address for the ROC. The IP Address will identify the ROC device on a TCP/IP 
network.  

Enter a Subnet Mask if required. The Subnet mask is a mask used to determine to which subnet an IP 
address belongs. 

Enter the desired Gateway Address for the ROC800-Series unit. The Gateway address identifies the 
node on a network that serves as an entrance to the network on which the ROC resides. 

Enter the IP Port Number for the Modbus or ROC Plus Protocol communications. The IP Port Number 
determines which port that the ROC unit monitors for Modbus or ROC Plus Protocol connections when 
communicating over a TCP/IP connection. The ROC Plus Protocol default is 4000. The Modbus default 
is 502. Port Numbers 1113 and 1131 are reserved.  

If you change the port number, the change takes effect immediately. If the default value of this 
parameter is changed, then all Modbus or ROC Plus Protocol over TCP/IP connections will be closed, 
and you will have to re-establish a connection. 
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Enter the Inactivity Time in seconds. If a valid Modbus or ROC Plus Protocol message is not received 
within the Inactivity Time, the connection will be closed. This timer is in addition to the security 
timeout. A value of 0 will disable the timer. 

Each connection will be kept alive by periodic transmissions of messages (probes). Enter the amount of 
idle time before the first probe is configurable, in seconds, in the Keep Alive Time field. If the other 
side of the connection fails to respond to ten repetitive probes, the connection will be considered broken 
and the connection closed. The other nine probes will be 64 seconds apart. The total time will be (9 x 
64) + the value of the Keep Alive Time parameter. 

The total number of Modbus or ROC Plus Protocol over TCP/IP connections will be limited to six of 
each type. The Active Connections field displays the number of active Modbus or ROC Plus Protocol 
over TCP/IP connections. 

Use the Reset All Connections button to close all active Modbus or ROC Plus Protocol over TCP/IP 
connections. This button returns to an un-pressed state when connections are successfully closed. 

For Modbus RTU encapsulated in TCP/IP or Modbus TCP/IP connections, select Device Address, 
Slave Address, or Either Device or Slave Address. The ROC800-Series unit will respond to the 
Device Address (ROC Address) configured on the General tab of the Device Information screen, to a 
Slave Address configured in the Slave Address field, or to either address. 

3.2.3 Information – Points 
Select ROC > Information. The Points tab displays the Maximum number points are available and how 
many are currently Active in the ROC or FloBoss units, such as Events, Alarms, PIDs, Stations, 
Samplers, FSTs, and Meter Runs (Orifice and Turbine).  

The Maximum column displays the number of Points available for the option and the Active column 
displays the number of Points that are active. To conserve processor executions, set the Active fields to 
the minimum value required by your application. 

For FloBoss 407 units, the Points tab displays the number of database History Points contained in the 
RAM areas. Base RAM is always 30; RAM1 is always 20; RAM2 is always 0. These fields are Read-
Only and cannot be changed. You can also configure the number of PIDs and AGAs. 

For ROC300-Series units, the Points tab displays the number of database points contained in the RAM 
areas. Base RAM is always 30; RAM1 is always 30; RAM2 is always 27. These fields are Read-Only 
and cannot be changed. You can also configure the number of PIDs and AGAs. 

For a FloBoss 100-Series, the Points tab also displays the number of points allocated for Standard 
History and Extended History on the Configure > History Points screen. You can also configure the 
number of PIDs and AGAs. 
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Figure 3-7. Information – Points (ROC800-Series) 

 
Figure 3-8. Information – Points (FloBoss 407 and ROC300-Series) 
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Figure 3-9. Information – Points (FloBoss 100-Series) 
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3.2.4 Information – Other Information 
Select ROC > Information. The Other Information tab displays information about the firmware, boot 
firmware, processor, and LCD (if pertinent to the type of ROC or FloBoss). The fields are read-only. 

  
Figure 3-10. Information – Other Information Example (ROC800-Series) 
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Figure 3-11. Other Information (FloBoss 407 and FloBoss 100-Series) 

  
Figure 3-12. Other Information (ROC300-Series) 

The Version Name, Part Number, ID, and Time Created of the firmware display. 

The information about the ROM (Customer Name and Serial Number) display. 

The processes in the processor (MPU Loading) display. 

The amount of RAM installed in the ROC or FloBoss display. 
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In a ROC800-Series field display when power was added or removed: Last Power Up Time (connected 
to power) and Last Power Down Time (power was disconnected). 

For the ROC300-Series, the LCD Installed field indicates whether an LCD is connected to the unit. 

3.2.5 Information – System Configuration (ROC800-Series) 
Select ROC > Information. The System Configuration tab allows you to specify the four Baud Rates 
(bps) possible by the ROC unit at any given time. You may use any one of the four baud rates specified 
on the System Configuration tab. A Read Only display on the Comm Ports General screen indicates 
which of the four Baud Rate Generators is in use. 

 
Figure 3-13. Information – System Configuration (ROC800-Series) 
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3.2.6 Information – Revision Info (FloBoss 100-Series) 
 Select ROC > Information. The Revision Info tab displays information about the Application 
Firmware or Accessory software installed in the FloBoss 100-Series unit. For example, the Accessory 
field may say I/O Card, 6 Points, or Turbine Interface. When the Accessory field displays Not Used, 
there are no additional accessories installed. The Part Number and Version control number also display. 

 
Figure 3-14. Information – Revision Info (FloBoss 100-Series) 
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3.2.7 Information – Keypad Display (ROC800-Series) 
Select ROC > Information. The Keypad Display allows you to configure settings for the ROC800-
Series optional Display Keypad. 

 
Figure 3-15. Information – Keypad Display (ROC800-Series) 

LCD Master Switch resets the Keypad/Display task without cycling power or having to perform a 
Warm-Start. 

LCD Status indicates the status of the Keypad Display. OK displays if a Keypad Display unit is 
installed and has a valid configuration file. An error displays if the configuration file is invalid, no 
Keypad Display is installed, or if there is a CRC error. 

Select the default LCD Video Mode for the display (dark text on light background) or invert the LCD 
display (light text on dark background). Click Apply to change the display mode. 

When LCD Backlight Power Saving Mode (ROC800-Series) is enabled, the LCD automatically shuts 
off after the amount of time set in the Inactivity Time field. 

LCD Firmware Version displays the firmware version currently loaded. 
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3.3 Configuring System Flags 
Select ROC > Flags to perform actions that affect the overall operation of the ROC or FloBoss device. 
From this screen, a configuration can be saved to Flash memory and the ROC or FloBoss can be re-
initialized if necessary.  Refer to Table 3-1. 

 
Figure 3-16. Flags (ROC800-Series) 
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Figure 3-17. Flags (FloBoss 100-Series, FloBoss 407, and ROC300-Series) 

� Note: Be very careful when using the System Flags. Certain Flags cause data to be lost, 
parameter values to be changed, and configuration memory to be cleared. Be sure you 
understand the function of the Flags before changing them.  

� Note: A Reset using the Reset switch or a jumper reloads all configuration data from Electrically 
Erasable Program Read-Only Memory (EEPROM) or Flash memory, clears all history, clears the 
Event Log, clears the Alarm Log, and clears all ROC Displays, disables all user program tasks, 
and disables all user data types.  

The Reset switch or a jumper permits a restart from the boot block of the flash memory (Cold 
Start) rather than from RAM (Warm Start). 

The Reset switch or a jumper permits a restart from the boot block of the flash memory (Cold 
Start) rather than from RAM (Warm Start). 

For a FloBoss 100-Series, a Jumper Reset configures all Comm Ports back to their factory 
defaults, shuts off all User Programs and FSTs. All other data remains intact.  

� Note: Cold Start reloads all restart configuration data and may also clear logs, displays, and 
FSTs. In addition, it may cause output changes, load new accumulator values, and disable User 
Program tasks and User Data Types. Generally, a Cold Start should not be used on a ROC or 
FloBoss that is actively gathering data or performing control. Save or document all required 
data and parameter values that could be affected before performing the Cold Start. 
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Table 3-1. ROC > Flag Definitions 
 

Button Device Action 
Clear – Flash Memory All Clears all Flash memory. 
Clear History 
Configuration and Data ROC800-Series Clears all Historical Database files and clears the Historical 

Database configuration. 

Cold Start All 
Restores a configuration from default values stored in Flash 
memory. If the configuration memory is not valid, the factory 
default settings are used. 

Cold Start & Clear 
Alarms ROC800-Series Restores a configuration from default values stored in Flash 

memory and clears the Alarm Log. 

Cold Start & Clear 
Alarms/Events 

FloBoss 100-Series, 
ROC300-Series, 
and FloBoss 407 

Restores a configuration from default values stored in Flash 
memory and clears the Alarm Log and Event Log. 

Cold Start & Clear All All 
Restores a configuration from default values stored in Flash 
memory and clears all History database files, Custom 
Displays, Alarm Log, Event Log, and FSTs. 

Cold Start & Clear 
Displays 

FloBoss 100-Series, 
ROC300-Series, 
and FloBoss 407 

Restores a configuration from default values stored in Flash 
memory and clears the ROC Custom Displays. 

Cold Start & Clear 
Events ROC800-Series Restores a configuration from default values stored in Flash 

memory and clears the Event Log. 

Cold Start & Clear FSTs All Restores a configuration from default values stored in Flash 
memory and clears the FSTs. 

Cold Start & Clear 
History 

FloBoss 100-Series, 
ROC300-Series, 
and FloBoss 407 

Restores a configuration from default values stored in Flash 
memory and clears the History. 

Cold Start & Clear 
History Data ROC800-Series Restores a configuration from default values stored in Flash 

memory and clears the History. 
From Factory Defaults – 
Restore Configuration ROC800-Series Restores a configuration from default factory values. 

History Configuration & 
Data – Clear ROC800-Series Clears all historical configurations and historical data. 

Save Configuration – 
Flash Memory All Saves the current configuration to Flash Memory. 

Warm Start All 

ROC or FloBoss is initialized from SRAM memory. If the 
configuration is valid, databases and FSTs remain intact. If 
the memory is not valid, the configuration last saved to 
Flash is used. User Programs remain on. 
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3.3.1 Returning the Device to Factory Default Settings 
Sometimes it is necessary to return the ROC or FloBoss device to the original factory default settings. 
The following procedure clears all saved restart configuration data contained in Flash memory. Only 
factory defaults are retained.  

ROC800-Series  
To return the device to the original factory default settings using a ROC800-Series unit: 

1. Select ROC > Flags.  

2. Click Flash Memory Clear. 

3. Click Yes and OK. 

4. Click Restore Configuration From Factory Defaults button. 

5. Click Yes and OK. 

� Note: You may need to re-connect as the factory default settings may be altered from the 
stored data. 

FloBoss 100-Series, ROC300-Series, or FloBoss 407 
To return the device to the original factory default settings using a FloBoss 100-Series, ROC300-Series, 
or FloBoss 407 unit: 

1. Select ROC > Flags.  

2. Click Flash Memory Clear. 

3. Click Yes and OK. 

4. Perform a Cold Start using the Cold Start & Clear ALL button. 

5. Click Yes and OK. 

� Note: You may need to re-connect as the factory default settings may be altered from the 
stored data. 
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3.3.2 Flags – Advanced  
Select ROC > Flags. Click the Advanced tab.  

 
Figure 3-18. Flags – Advanced (ROC800-Series) 

 
Figure 3-19. Flags – Advanced (FloBoss 407 and ROC300-Series) 
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Figure 3-20. Flags – Advanced (FloBoss 100-Series) 

Select CRC Check Enabled to perform CRC (Cyclical Redundancy Check) checking on ROC Protocol 
and ROC Plus Protocol communications. 

Select I/O Scanning Enabled so I/O is in normal scan mode. When Disabled, all I/O scanning is stopped 
and the last values are used until scanning is resumed. This includes MVS sensors. 

You can Enable and Disable I/O Scanning on the I/O point displays. 

LEDs (ROC800-Series), with the exception of the LED on the Power module, can be enabled or 
disabled as a power saving feature. This parameter determines how long the LEDs remain on after the 
LED button on the CPU module is pressed.  

For instance, with the default setting of 5 minutes, all LEDs will go off. If you press the LED button, the 
LEDs become active again for 5 minutes. By placing a 0 (zero) in this field, the LEDs always stay 
active. 

For a FloBoss 100-Series, Power Saving Mode when enabled allows the FloBoss unit to enter sleep 
mode when no activity is occurring. When disabled, the FloBoss unit will stay awake (not enter sleep 
mode during no activity periods). Enabled is the default. 

For a FloBoss 100-Series, select a Pass Through Mode communications option to send Pass Through 
messages. By using any of the FloBoss 100-Series communications ports, Pass Through Mode allows 
data to be received by one unit and then passed through to other devices connected on any other 
communications port. For example, the host communicates via a radio on the FloBoss 100-Series COM2 
port. Other FloBoss 100-Series units can then be connected via EIA-485 (RS-485) on the COM1 port of 
the first FloBoss 100-Series unit, and then all the FloBoss 100-Series units can use the one radio to 
communicate to the host. 
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� Note: If COM2 is a Dial-up modem, this port must be used as the receiving port for Pass 
Through messages. It will not transmit to other field devices other than the host. 

� Note: The Group number of the FloBoss 100-Series receiving the data must match the Group 
number of the FloBoss 100-Series unit(s) to which the data will be passed. If the Group number 
does not match, the data will not be forwarded. Refer to ROC > Information to view or change 
the Group number. 

Select the respective port (Local Port, COM1, or COM2) for the Set RTS to High for 30 Sec option 
(FloBoss 100-Series, ROC300-Series, and FloBoss 407) and click Apply to activate the RTS (Request-
to-Send) signal. The RTS signal turns on for 30 seconds. 

For a FloBoss 100-Series, COM1 is not available and COM2 requires an optional EIA-232 (RS-232) 
communications card. 

The Read I/O Flag forces the unit to search for all installed I/O modules. Select the Flag and click 
Apply when an I/O module is added or removed under power.  

For a FloBoss 407, the Transmitter (+T) Flag changes transmitter power to Analog Inputs when 
enabled. 

For the Revision M of the Termination Board with the 12V/24V jumper (P15) set to 24V, selecting 
this Flag maintains the Transmitter Power at 24 volts nominal. De-select the checkbox, to change the 
Transmitter Power to 12 volts nominal. If the jumper is set to 12V, this Flag essentially has no 
effect. 

Revisions A and B of the Termination Board, certain I/O modules (specifically the AI Loop and AO 
Source) route input power back to +T. With +T flag disabled, the +T voltage returns to zero when 
those modules are removed.  

Revisions A and B of the Termination Board did not have a 12/24 jumper, so this feature allows the 
Transmitter Voltage to be selected. 

Revisions A and B of the Termination Board did not have a 12/24 jumper, so this feature allows the 
Transmitter Voltage to be selected. 

Select the A4/A5 Function (ROC300-Series) to determine whether the two built-in DI/PI channels in 
the ROC300-Series are configured. 
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3.3.3 Flags – User Programs (FloBoss 100-Series, ROC300-Series, and 
FloBoss 407) 

Select ROC > Flags. Click the User Programs tab.  

  
Figure 3-21. Flags – User Programs (FloBoss 407 and ROC300-Series) 

 
Figure 3-22. Flags – User Programs (FloBoss 100-Series) 
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LOI User Program (FloBoss 407, FloBoss 100-Series, and ROC300-Series) – If installed, allows a 
User Program for the operator interface Local Port to be run. Select Disable and then click Apply to 
stop the function.  

COM1 User Program (FloBoss 407 and ROC300-Series) – If a user program is installed for the COM1 
task, this Flag allows the User Program associated with the COM1 or COMM port on the ROC to be 
run.  

COM2 User Program (FloBoss 407 and ROC300-Series) – If a user program is installed for the COM2 
task, this Flag allows the User Program associated with the COM2 port on the ROC to be run.  

Calc User Program (FloBoss 407 and ROC300-Series) – If installed, allows the calculation user 
program to be run.  

Calc2 User Program (FloBoss 100-Series) – If installed, allows the second calculation User Program to 
be run. 

LCD User Program – If installed, allows a User Program for the optional Local Display Panel to be 
run.  
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SECTION 4 – CONFIGURING INPUTS AND OUTPUTS (I/O) 

The I/O points in the ROC or FloBoss have many items that can be configured. For more information on 
the types of I/O available and their functions, refer to the appropriate hardware manual. 

In this Chapter 
Section Page 
4.1 I/O Configuration Overview........................................................................................................... 4-1 

4.2 AI – Analog Input Configuration.................................................................................................... 4-2 

4.3 AO – Analog Output Configuration ............................................................................................... 4-9 

4.4 DI – Discrete Input Configuration ................................................................................................ 4-14 

4.5 DO – Discrete Output Configuration............................................................................................ 4-21 

4.6 PI – Pulse Input Configuration ..................................................................................................... 4-29 

4.7 Pulse Interface Module Diagnostic (FloBoss 104) ....................................................................... 4-37 

4.8 RTD – RTD Input Configuration (ROC800-Series)..................................................................... 4-38 

4.9 TC – Thermocouple Input Configuration (ROC800-Series) ........................................................ 4-42 

4.10 System AI – System Analog Input Configuration (ROC800-Series) ........................................... 4-46 

4.11 HART Input Configuration (ROC800-Series).............................................................................. 4-50 

4.12 MVS Sensor (ROC800-Series or FloBoss 407)............................................................................ 4-57 

4.1 I/O Configuration Overview 
Configuring a ROC or FloBoss is a matter of establishing points and then configuring various 
parameters.  

Each Input and Output has a unique Point Number to identify the input or output. The Point Number 
indicates the location of the point at the slot number of the I/O module and channel number in the 
ROC800-Series. For example, DI 2-1 indicates the Point Number for a Discrete Input at module slot 
number two, first channel.  

The Point Number in the FloBoss 100-Series, ROC300-Series, or FloBoss 407 indicates the location of 
the point on the termination board. The Point Number is automatically assigned by the device and 
cannot be edited.  

� Note: When configuring similar point types, use the Copy (F4) and Paste (F5) options to speed 
configuration of similar I/O types. For example, if you have nearly identical Analog Inputs to 
configure, copy the configuration of one AI and paste that configuration into a new AI 
configuration. Make the changes that are required to differentiate the two AI configurations. 

� Note: Each point must be individually configured. If there is more than one point of this type 
available in the device, you can “page” to the other points by using Page Up and Page Down. 
Points are in the same order as the I/O modules installed in the slots. 

� Note: For FloBoss 100-Series units with six points of I/O, select Configure > I/O > Setup to 
select which types of I/O each channel will be assigned before configuring the I/O points. This 
applies to the software-selectable AI/DI, AO/DO, and PI/DI channels. 
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4.2 AI – Analog Input Configuration 
 Analog Inputs are analog signals generated by measurement devices, such as pressure and temperature 
transmitters, including RTD probes and pressure sensors. 

� Note: Use the AI configuration screens to configure a DVS for the FloBoss 100-Series and RTD 
inputs for the FloBoss 100-Series and FloBoss 407. 

� Note: For the FloBoss 407, do not configure the second AI point if the jumper is selected to PI. 
Refer to the FloBoss 407 Flow Manager Instruction Manual (Form A6013). 

Select Configure > I/O > AI Points. Examine the default settings and adjust the parameters to suit your 
application on each of the tabs in the order given below. 

1. The General tab sets the basic parameters for the Analog Input point.  

2. The Advanced tab enables you to configure features, such as filtering, A/D conversions, and 
clipping for the selected Analog Input.  

3. The AI Calibration tab is available to allow for calibration of the AI point while on-line. Refer to 
Section 10, Calibration. 

4. The Alarms tab sets the alarm parameters for this AI point. 

5. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 

4.2.1 AI – General 
Select Configure > I/O > AI Points. The General tab sets the basic parameters for the Analog Input point.  

 
Figure 4-1. AI – General (ROC800-Series) 
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Figure 4-2. AI – General (FloBoss 100-Series, FloBoss 407, and ROC300-Series) 

Select the Analog Input to be configured. The inputs are listed by both Point Number and Tag. 

Each Point is given a Tag, which includes up to 10 characters to identify the Point being defined in the 
I/O screen. Any alphanumeric characters, including spaces, may be used. 

The Point Number identifies the physical location of the input. For the ROC800-Series, the Point 
Number identifies the module slot – channel number.  

If Scanning is set to Disabled, enter a Value to override the input. When Scanning is set to Enable, 
Value displays the last Analog Input scan in engineering units. 

A Units is a user-defined 10-character description for the engineering units assigned to the I/O point. 
For example: PSIG, MCF, degrees F, milliamps, or volts. 

Select a Scanning option. For the input to automatically process the field input, select Enabled 
(Automatic Mode). When Scanning is set to Enabled, the engineering unit (EU) Value displays the last 
Analog Input scan. When Scanning is set to Disabled (Manual Mode), the engineering unit (EU) Value 
is no longer updated by the ROC or FloBoss. If Alarming is Enabled, a Manual Mode alarm generates 
when Scanning is set to Disabled. If Scanning is set to Disabled, enter an override input in the Value 
field.  
Scan Period is the amount of time between updates of the Filter value. All Analog Inputs are updated 
based on their individual Scan Periods. The default value is 1 second. The minimum Scan Period 
allowed is 50 mSec. For a FloBoss 100-Series, the minimum Scan Period is 1 second. 

Low Reading EU (engineering unit) corresponds to zero percent input. For example, if a temperature 
transmitter is connected to the Analog Input with a range of –40 to 160 degrees F, the Low Reading EU 
would be set to –40. 

High Reading EU (engineering unit) corresponds to 100 percent input. For example, if a temperature 
transmitter is connected to the Analog Input with a range of –40 to 160 degrees F, the High Reading EU 
would be set to 160. 
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If you Enable Alarming, the limit alarms thresholds (four levels, Rate, and Deadband) are configured on 
the Alarms tab. If you Disable Alarming, no limit alarms generate for this point. The Point Fail alarm 
may appear in the Active Alarms field, but will not be logged in the Alarms file. Alarm Enable actives 
the limit alarms for the point. If Alarming is set to Enabled, an alarm is generated when Scanning is 
Disabled. 

The Active Alarms field indicates any alarms that are active for this point. When Alarming is set to 
Enabled, the limit alarms (such as Low Alarm and Rate Alarm) that are active appear. Even if Alarming 
is Disabled, the Point Fail (hardware reports a malfunction) alarm and Manual (Scanning Disabled) 
indicators can still appear.  

4.2.2 AI – Advanced 
Select Configure > I/O > AI Points. The Advanced tab enables you to configure features, such as 
filtering, A/D conversions, and clipping for the selected Analog Input.  

 
Figure 4-3. AI – Advanced (ROC800-Series) 
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Figure 4-4. AI – Advanced (ROC300-Series) 

  
Figure 4-5. AI – Advanced (FloBoss 407) 
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Figure 4-6. AI – Advanced (FloBoss 100-Series) 

Filter value is a weighted sample using a percentage of the last value plus a percentage of the new 
value. The entered data is the percentage of the last value used. The Filter is calculated every Scan 
Period by the formula: 

ROC800-Series and FloBoss 100-Series 

(Last Value × Entered %) + [New Value × (100 – Entered %)] = Filtered Value 

ROC300-Series and FloBoss 407 

(Last Value × [75 +(Entered % ÷ 4)]) + (New Value × [25 – (Entered % ÷ 4)]) = Filtered Value 

The Adjusted A/D 0% is the calibrated Analog-to-Digital count corresponding to zero percent input. In 
the Calibrate function, this value is altered to set the zero percent input exactly at the Low Reading EU 
value. 

The Adjusted A/D 100% is the calibrated Analog-to-Digital count corresponding to 100 percent input. 
This value is used to convert the input to engineering units. In the Calibrate function, this value is altered 
to set the 100 percent input exactly at the High Reading EU value. 

Raw A/D Input displays the current digital count directly from the Analog-to-Digital converter.  

Actual Scan displays the actual amount of time in seconds that passes between scans. This number 
should be the same as shown for the Scan Period parameter on the General tab if the system is not 
overloaded. 

When Hold Last Value is selected, the last input value is retained on point fail. If Set to Fault Value is 
selected, then the value entered as the Fault Value is written to the Filtered Value on point fail. 

Enable Average Raw Values to average and calculate the raw readings during the Scan Period and use 
the outcome as the Raw A/D Input during calculations. Disable this function to acquire Instantaneous 
Values. 
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For example, when using a ROC300-Series or FloBoss 407 and Average Raw Values is enabled, an 
Analog Input point configured with a Scan Period of 1.0 seconds obtains a new value from the A/D 
every 50 milliseconds. During the Scan Period, 20 values are obtained from the A/D and summed 
together. At EU Value calculation, the values summed are divided by the number of samples taken 
during the Scan Period and are used as the Raw A/D Input.  

When Clipping is enabled, the ROC or FloBoss forces the Filtered EUs to stay within the range defined 
by the cut off limits. Set the cut off limits by using the LoLo Alarm and HiHi Alarm parameters defined 
on the Alarms tab.  

When Temp Compensation (ROC300-Series or FloBoss 407) is enabled, a temperature compensation 
curve is applied to the Analog Input using the board temperature of the ROC300-Series or FloBoss 407 
as a reference. Use this feature to improve the A/D conversion accuracy at temperature extremes for 
modular Analog Inputs only; built-in Analog Inputs already have temperature compensation. If you use 
this feature, be sure to perform a calibration after it is enabled. 

For a ROC800-Series or FloBoss 100-Series, enter a Zero Shift value if necessary to compensate for the 
zero shift effect on a differential pressure input. 

4.2.3 AI – Alarms 
Select Configure > I/O > AI Points. The Alarms tab sets the alarm parameters for this AI point. 

If you enable Alarming, the limit alarms (four levels, Rate, and Deadband) are configured on the Alarms 
tab. To conserve Alarm Log space, alarms should be enabled only when necessary. Even if you do not 
plan to use all the alarms, check and adjust the value of each one so that no false alarms generate. 

♦ For the ROC800-Series, Alarming is Enabled in the Configure > I/O > AI Points > Alarms tab. 

♦ For the FloBoss 100-Series, ROC300-Series, or FloBoss 407, Alarming is Enabled in the 
Configure > I/O > AI Points > General tab. 
� Note: Refer to Section 10, Calibration. 

 
Figure 4-7. AI – Alarms (ROC800-Series and ROC300-Series) 
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Figure 4-8. AI Alarms (FloBoss 407 and FloBoss 100-Series) 

Enter the High Alarm limit value, in engineering units, to which the input value must rise to generate a 
High Alarm. The HiHi Alarm value is typically set higher than the High Alarm. 

Enter the Low Alarm limit value, in engineering units, to which the input value must fall to generate a 
Low Alarm. The LoLo Alarm value is typically set lower than the Low Alarm. 

The Rate Alarm is the value, in engineering units, that represents the maximum amount of change 
allowed between updates. If the change is equal to or greater than this value, an alarm is generated. To 
disable this Rate Alarm without disabling the other alarms, the Rate Alarm value can be set greater than 
the Span of the Analog Input. 

Alarm Deadband is the value, in engineering units, that is an inactive zone above the Low Alarm limits 
and below the High Alarm limits. The purpose of the Alarm Deadband is to prevent the alarm from 
being set and cleared continuously when the input value is oscillating around the alarm limit. This 
prevents the Alarm Log from being over-filled with data. 

Select the SRBX / RBX Alarming option to configure Spontaneous-Report-By-Exception (SRBX or 
RBX) alarming for this point.  

♦ Disabled – The RBX Alarming is turned OFF. 
♦ On Alarm Set – The point enters an alarm condition, the ROC or FloBoss generates a 

Spontaneous-Report-by-Exception message to the host.  
♦ On Alarm Clear – The point leaves an alarm condition, the ROC or FloBoss generates a 

Spontaneous-Report-by-Exception message to the host. 
♦ On Alarm Set and Clear (FloBoss 100-Series, ROC300-Series, or FloBoss 407). In either 

condition, an RBX message generates to the host.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  



ROCLINK 800 User Manual 

Rev. Dec-05 Configuring Inputs and Outputs (I/O) 4-9 

4.3 AO – Analog Output Configuration 
Analog Outputs are analog signals generated by the ROC or FloBoss to regulate equipment, such as 
control valves or any device requiring proportional control.  

Select Configure > I/O > AO Points. Examine the default settings and adjust the parameters to suit your 
application on each of the tabs in the order given below. 

1. The General tab sets the basic parameters for the Analog Output point.  

2. The Advanced Analog Outputs tab enables you to configure features, such as on a restart and 
RBX Alarming for the Analog Output.  

3. The Alarms tab on a ROC800-Series sets the alarm parameters for the AO point. 

4. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 

4.3.1 AO – General  
Select Configure > I/O > AO Points. The General tab sets the basic parameters for the Analog Output 
point.  

 
Figure 4-9. AO – General (ROC800-Series) 
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Figure 4-10. Analog Outputs (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 

Select the Analog Output to be configured. The outputs are listed by both Point Number and Tag. 

The FloBoss 100-Series only have one AO. 

Each Point is given a Tag, which includes up to 10 characters to identify the Point being defined in the 
I/O screen. Any alphanumeric characters, including spaces, may be used. 

The Point Number identifies the physical location of the input. For the ROC800-Series, the Point 
Number identifies the module slot – channel number. 

Enter the Units, a user-defined 10-character description for the engineering units assigned to the I/O. 
For example: PSIG, MCF, degrees F, milliamps, or volts. 

Select the Scanning option.  
♦ For the input to automatically process the field output, select Enabled or Auto (Automatic 

Mode). When Scanning is set to Enabled or Auto, Value displays the last Analog Output scan in 
engineering unit.  

♦ When Scanning is set to Disabled, the engineering unit (EU) Value is no longer updated by the 
ROC or FloBoss. If Alarming is Enabled, a Manual Mode alarm generates when Scanning is set 
to Disabled.  

For a ROC300-Series or FloBoss 407 and Scanning is set to Disabled, the output holds the current value 
regardless of any Value entered. 

For a ROC300-Series, FloBoss 100-Series, or FloBoss 407 and Scanning is set to Enabled, the Value 
displays the current output Value. 

For a ROC800-Series or FloBoss 100-Series and Scanning is set to Disabled, enter a Value to override 
the output. 

For a ROC800-Series, when the Scanning is set to Manual, use the Auto Value field to override the 
output. 
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For the ROC800-Series, when Scanning Mode is set to Auto or Enabled, Auto Value displays the last 
Analog Output scan in engineering units.  

For the ROC800-Series, when the Scanning Mode is set to Manual, use Manual Value to enter the 
value instead of the Auto Value field. 

For a ROC800-Series, Physical Value indicates the current state of the AO. When the AO is in Manual 
Mode, this should reflect the Manual Value. When the AO is in Auto mode, this should reflect the Auto 
Value. 

Enter the Low Reading EU value corresponding to a zero percent output (the low end of the EU range). 
Based on the EU range determined in part by this parameter, the EU Value is converted to a 
corresponding analog signal. 

Enter the High Reading EU value corresponding to a 100 percent output (the high end of the EU 
range). Based on the EU range determined in part by this parameter, the EU Value is converted to a 
corresponding analog signal. 

If you Enable Alarming, alarms will be generated on point failure or Manual Mode. If you Disable 
Alarming, the Point Fail or Manual Mode alarm appear in the Active Alarms field, but will not be 
written to the Alarm log.  

The Active Alarms field indicates any alarms that are active for this point. When Alarming is set to 
Enabled, the active alarms appear. Even if Alarming is Disabled, the Point Fail (hardware reports a 
malfunction) alarm and Manual (Scanning Disabled) indicators can still appear. If Alarming is set to 
Enabled, an alarm is generated when Scanning is Disabled. 

4.3.2 AO – Advanced  
Select Configure > I/O > AO Points. The Advanced Analog Outputs tab enables you to configure 
features, such as resetting and RBX Alarming for the Analog Output.  

  
Figure 4-11. AO – Advanced (ROC800-Series) 
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Figure 4-12. AO Advanced (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 

Displays the Raw D/A Output current reading (in counts) written to the Digital-to-Analog converter. 
The D/A value sent to the AO is the Raw D/A Output. 

Enter the Adjusted D/A 0% count used by the Digital-to-Analog converter for zero percent output. This 
value is also used to scale the output to engineering units. 

Enter the Adjusted D/A 100% count decoded by the Digital-to-Analog converter for 100 percent 
output. This value is also used to scale the output to engineering units. 

Select Value on Power Reset, such as a power restart or a Warm Start. When Low EU is selected 
(FloBoss 407, FloBoss 100-Series, and ROC300-Series), the Value parameter is set to the Low EU 
Value in the General tab upon a restart of the ROC or FloBoss. If Retain Last Value is selected, the last 
output value is maintained. If Value on Reset is selected, enter a value to be set in the Failsafe Value 
field for a ROC800-Series.  

For a FloBoss 100-Series, ROC300-Series, or FloBoss 407, select the RBX Alarming option to 
configure Spontaneous-Report-By-Exception (SRBX or RBX) alarming for this point.  

♦ Disabled – The RBX Alarming is turned OFF. 
♦ On Alarm Set – The point enters an alarm condition, the ROC or FloBoss generates a 

Spontaneous-Report-by-Exception message to the host.  
♦ On Alarm Clear – The point leaves an alarm condition, the ROC or FloBoss generates a 

Spontaneous-Report-by-Exception message to the host. 
♦ On Alarm Set and Clear – In either condition, an RBX message generates to the host.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  
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4.3.3 AO – Alarms (ROC800-Series) 
Select Configure > I/O > AO Points. The Alarms tab sets the alarm parameters for the AO point. 

If you Enable Alarming, the limit alarms (four levels, Rate, and Deadband) are configured on the 
Alarms tab. To conserve Alarm Log space, alarms should be enabled only when necessary. Even if you 
do not plan to use all the alarms, check and adjust the value of each one so that no false alarms generate. 

  
Figure 4-13. AO – Alarms (ROC800-Series) 

For a ROC800-Series, select the SRBX / RBX Alarming option to configure Spontaneous-Report-by-
Exception (SRBX or RBX) alarming for this point.  

♦ On Alarm Set – The point enters an alarm condition, the ROC generates a Spontaneous-Report-
by-Exception message to the host.  

♦ On Alarm Clear – The point leaves an alarm condition, the ROC generates a Spontaneous-
Report-by-Exception message to the host. 
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  
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4.4 DI – Discrete Input Configuration 
The DI modules monitor the status of relays, open collector /open drain type solid-state switches, and 
other two-state devices. Each DI channel can also be software configured to function as a latched DI. A 
latched DI remains in the active state until reset. Other parameters can invert the field signal and gather 
statistical information on the number of transitions and the time accumulated in the on or off state. 

Select Configure > I/O > DI Points. Examine the default settings and adjust the parameters to suit your 
application on each of the tabs in the order given below. 

1. The General tab sets the basic parameters for the DI point.  

2. The Advanced tab lets you configure features, such as filtering, input inversion, and counter 
values for the Discrete Input.  

3. The TDI Parameters tab (FloBoss 407 and ROC300-Series) provides additional parameters to 
specify scaling and engineering unit conversion. 

4. The Alarms tab sets the alarm parameters for this DI point. 

5. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 

4.4.1 DI – General  
Select Configure > I/O > DI Points. The General tab sets the basic parameters for the DI point.  

 
Figure 4-14. Discrete Inputs – General (ROC800-Series) 
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Figure 4-15. Discrete Inputs – General (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 

Select the Discrete Input to be configured. The inputs are listed by both number and tag. 

Enter a 10-character string Tag for identification of this Point Number. Any alphanumeric characters, 
including spaces, may be used. 

The Point Number identifies the physical location of the input. For the ROC800-Series, the Point 
Number identifies the module slot – channel number. 

Select the Scanning option. 
♦ For the input to automatically process the field input, select Enabled (Automatic Mode).  
♦ When Scanning is set to Disabled (Manual Mode), Status is no longer automatically updated by 

the ROC or FloBoss. If Alarming is Enabled, an alarm generates when Scanning is set to 
Disabled. 

Enter the Module Scan Period as the amount of time between scans of the physical hardware and 
updates of the Status Value in seconds. The default value is 1 second. All Discrete Inputs are updated 
based on their individual Scan Periods, and all Discrete Inputs are scanned on a per module basis. 

For a ROC300-Series or a FloBoss 407, the minimum Scan Period is 0.05 (50 milliseconds). 

Status indicates the state of the Discrete Input: Off normally indicates that the input is Off or that a 
switch is open; On normally indicates that the input is On or that a switch is closed.  

For a ROC800-Series, Physical Status indicates the state of the hardware. Off normally indicates that a 
switch is open; On normally indicates that a switch is closed. This may be different from the Status if 
Inverting or Latching is in effect. 
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Select the DIN Type as Standard, Time Duration (TDI) or Latched. 

♦ Select Standard if you want the Discrete Input status to follow the actual field input.  

♦ Select Latched if you want the Discrete Input status, on an active transition of the input (from 
Off to On), to change to On and remain in that state until it is cleared. To be cleared, the Status 
parameter must be changed to the Off state, either by the software or manually. If the DI has the 
Input Inverted field set, the field input is inverted in the Status field (Status latches on a physical 
change from On to Off). 

♦ Select Time Duration (TDI) (FloBoss 407 or ROC300-Series), if you want the Discrete Input to 
function as a Timed Discrete Input. For Timed Discrete Inputs, the time that the Discrete Input is 
active versus the time it is inactive is converted into a quantitative value, similar to an Analog 
Input. The TDI tab provides additional parameters to specify scaling and engineering unit 
conversion.  

The Active Alarms field indicates any alarms that are active for this point. When Alarming is set to 
Enabled, the active alarms appear. Even if Alarming is Disabled, the Point Fail (hardware reports a 
malfunction) alarm and Manual (Scanning Disabled) indicators can still appear. If Alarming is set to 
Enabled, an alarm is generated when Scanning is Disabled. 

4.4.2 DI – Advanced  
Select Configure > I/O > DI Points. The Advanced tab lets you configure features, such as filtering, 
input inversion, and counter values for the Discrete Input.  

 
Figure 4-16. Discrete Inputs – Advanced (ROC800-Series) 
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Figure 4-17. Discrete Inputs – Advanced (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 

In the Input field, select Normal to signify the field input as on, when wired through a set of closed 
contacts. Select Inverted to cause the field input to be inverted in the Status field (On becomes Off and 
vice-versa). An open circuit in the field would then be indicated as On in the Status parameter, and 
closed contacts would be indicated as Off in the Status. 

Enter the Filter to determine the amount of time that the Discrete Input must remain in the On (high) 
state before it is recognized as such. The Filter value is entered as a number of Filter Intervals. Valid 
entries are 0 to 255. The Discrete Input returns to the Off state immediately upon detection of the On to 
Off transition; there is no filtering for this transition. 

For the FloBoss 100-Series, ROC300-Series, or FloBoss 407, Filter Intervals is used with the Filter 
parameter to determine the amount of time that the Discrete Input must remain in the On (high) state 
before it is recognized as such. The Filter value is entered as a number from 0 to 255, and the Filter 
Interval selection determines the time basis. The Discrete Input returns to the Off state immediately 
upon detection of the On to Off transition; there is no filtering for this transition. 

For the FloBoss 407 and ROC300-Series, when 0.25 seconds is selected as the Filter Interval, the Filter 
is defined as the number of 250-millisecond intervals before the change from Off to On is recognized. 

For the FloBoss 100-Series, when 0.1 seconds is selected as the Filter Interval, the Filter is defined as 
the number of 100-milliseconds intervals before the change from Off to On is recognized. The FloBoss 
100-Series has a 1 second resolution. The ROC or FloBoss round the Filter Time to the nearest second. 

For a FloBoss 100-Series, ROC300-Series or FloBoss 407, when 15.0 seconds is selected as the Filter 
Interval, the Filter is defined as the number of 15-second intervals before the input is recognized on the 
Off to On transition. 

Accumulated Value indicates the number of times the Discrete Input goes from Off to On. The 
accumulator is a 32-bit number with a maximum count of 4,294,967,295. The accumulator can be preset 
by entering the desired value or can be cleared by entering 0. 
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For the FloBoss 100-Series, FloBoss 407 and ROC300-Series, On Counter indicates the number of 50 
millisecond periods when the Status parameter is in the On state. The On Counter, which does not 
operate if Scanning is set to Disabled, is a 32-bit number that automatically “rolls over” when it reaches 
its maximum value. The On Counter can be preset by entering the desired value or cleared by entering 0. 

For the FloBoss 100-Series, FloBoss 407 and ROC300-Series, Off Counter indicates the number of 50 
millisecond periods when the Status parameter is in the Off state. The Off Counter, which does not 
operate if Scanning is set to Disabled, is a 32-bit number that automatically “rolls over” when it reaches 
its maximum value. The Off Counter can be preset by entering the desired value or cleared by entering 0. 

For the ROC800-Series, Actual Scan displays the actual amount of time in seconds that passes between 
scans. This number should be the same as shown for the Scan Period parameter if the system is not 
overloaded. 

4.4.3 DI – TDI Parameters (FloBoss 407 and ROC300-Series) 
Select Configure > I/O > DI Points. The TDI Parameters tab (FloBoss 407 and ROC300-Series) 
provides additional parameters to specify scaling and engineering unit conversion. 

 
Figure 4-18. Discrete Inputs – TDI Parameters (FloBoss 407 and ROC300-Series) 

Enter the 0% Pulse Width, the width of a 0% input pulse in seconds.  

Enter the 100% Pulse Width, the width of a 100% input pulse in seconds. 

Indicates Actual Pulse Width of the input signal, measured in seconds. The pulse width is the time that 
the input signal is in the ON state. This parameter can be affected by the Max Time Between Pulses 
parameter.  
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Enter the Maximum Time Between Pulses as the number of seconds within which the input must make 
a transition to the ON state. If a new signal is not received in the number of seconds specified, then the 
actual value of the Actual Pulse Width parameter is set to 0. The Max Time Between Pulses parameter 
is disabled by entering 0. 

Enter the Zero EU value corresponding to the 0% Pulse Width. This is the low reading EU.  

Enter the Span EU value corresponding to the 100% Pulse Width. This is the high reading EU. 

Enter the EU Value. At intervals determined by the Scan Period parameter, the EU Value is calculated 
using the 0% Pulse Width, 100% Pulse Width, and Actual Pulse Width parameters. If Scanning was set 
to disabled, the normal TDI calculation is suspended, and a value can be manually entered. 

Enter the engineering Units assigned to the TDI input. For example, MCF or CFM. 

4.4.4 DI – Alarms  
Select Configure > I/O > DI Points. The Alarms tab sets the alarm parameters for this DI point. 

 
Figure 4-19. Discrete Inputs – Alarms (ROC800-Series) 
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Figure 4-20. Discrete Inputs – Alarms (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 

When Alarming is Enabled, alarms generate on point status change. When Alarming is Disabled, the 
Status Change alarm appears in the Active Alarms field, but will not be written to the Alarm Log. 

To conserve Alarm Log space, alarms should be enabled only when necessary. Even if you do not plan 
to use all the alarms, check and adjust the value of each one so that no false alarms generate. 

If the host computer is configured to receive field-initiated calls, you can select a Report-by-Exception 
(RBX) option to send a Spontaneous-Report-by-Exception message. 

♦ Disabled – (FloBoss 100-Series, FloBoss 407, or ROC300-Series). Select Disabled to turn RBX 
Alarming Off for this point. 

♦ On Alarm Set – When the point enters an alarm condition, the ROC or FloBoss generates a 
SRBX message. 

♦ On Alarm Clear – When the point leaves an alarm condition, the ROC or FloBoss generates a 
SRBX message.  

♦ On Alarm Set & Clear – (FloBoss 100-Series, FloBoss 407, or ROC300-Series). In either 
condition, an RBX message generates.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  

For the ROC300-Series, FloBoss 100-Series, or FloBoss 407, Alarm Deadband, Rate Alarm, and alarm 
limits parameters apply when in TDI Mode. Rate Alarm is the value, in engineering units, that 
represents the maximum calculated EU value change allowed between updates. If the change is equal to, 
or greater than this value, an alarm is generated.  
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Alarm Deadband is the value, in engineering units, that is an inactive zone above the Low Alarm and 
below the High Alarm and is used to prevent the alarm from being set and cleared continuously when 
the TDI EU value is oscillating around the alarm limit. The four level alarms are the limit value, in 
engineering units, to which the EU Value must fall to generate a Low, High, LoLo, or HiHi Alarm. 
The LoLo Alarm value is typically set lower than the Low Alarm. The HiHi Alarm value is typically set 
higher than the High Alarm. 

To disable this alarm without disabling the other alarms, the Rate Alarm EU value must be set greater 
than the Span of the TDI. 

4.5 DO – Discrete Output Configuration 
A Discrete Output may be set to send a pulse to a specified device. DOs are high/low outputs used to 
turn equipment On and Off. A Discrete Output can be configured in one of several different modes: 
Latched, Momentary, Toggle, Timed Duration Output (TDO), and TDO Toggle.  

Select Configure > I/O > DO Points. Examine the default settings and adjust the parameters to suit your 
application on each of the tabs in the order given below. 

1. The General tab sets the basic parameters for the DO point.  

2. The Advanced tab enables you to configure accumulated value and state for reset for the selected 
DO.  

3. The TDO Parameters tab allows configuration of TDO parameters when one of the DOUT Types 
TDO (Timed Duration) or TDO Toggle is selected in the Discrete Outputs screen.  

4. The Alarms tab sets the alarm parameters for this DO point for a ROC800-Series. 

5. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 



ROCLINK 800 User Manual 

Rev. Dec-05 Configuring Inputs and Outputs (I/O) 4-22 

4.5.1 DO – General  
Select Configure > I/O > DO Points. The General tab sets the basic parameters for the DO point.  

 
Figure 4-21. Discrete Outputs – General (ROC800-Series) 

 
Figure 4-22. Discrete Outputs – General (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 
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Select the Discrete Output to be configured. The outputs are listed by both number and tag. 

Enter the 10-character string Tag for identification of the Point Number. Any alphanumeric characters, 
including spaces, may be used. 

The Point Number identifies the physical location of the input. For the ROC800-Series, the Point 
Number identifies the module slot – channel number.  

Select the Scanning Mode.  
♦ For the output to automatically process the field output, select Enabled (Automatic Mode). 

When the Scanning mode is set to Auto Output On, enter an Auto Output to drive the physical 
output of the Discrete Output (ROC800-Series). 

♦ When the Scanning Mode is set to Disabled, the Auto Output (ROC800-Series), Manual Output 
(ROC800-Series), or State (FloBoss 100-Series, ROC300-Series, and FloBoss 407) is no longer 
updated by the ROC or FloBoss. When Alarming moves from enabled to disabled, an alarm 
generates.  

♦ When the Scanning Mode is set to Manual (ROC800-Series), use the Manual Output field to 
override the output. 

Auto Output (ROC800-Series), Manual Output (ROC800-Series), and State (FloBoss 100-Series, 
ROC300-Series, and FloBoss 407) indicate the State of the Discrete Output. Off normally indicates that 
the output is Off or that a switch is open; On normally indicates that the output is On or that a switch is 
closed.  

Set the Momentary parameter. When set to On, the Discrete Output (regardless of its configured DOUT 
Type) is placed into the one-shot Momentary mode. Immediately after setting On and clicking Apply, 
the Discrete Output is activated for the amount of time defined in the Time On parameter. The 
Momentary radio button automatically resets to Off at the end of the time period. 

For a ROC800-Series, Physical Output indicates the actual status of the output channel at the field 
terminations. 

Select the DOUT Type to specify the function of this Discrete Output:  
♦ Select Latched if you want the Discrete Output status, on an active transition of the output (from 

Off to On), to change to On and remain in that State until it is cleared. To be cleared, the Auto 
Output or Manual Output parameter must be changed to the Off state, either by the software or 
manually in a ROC800-Series. For a FloBoss 100-Series, ROC300-Series, and FloBoss 407, 
change the State to Off to clear the output. 

♦ Select Momentary to place the DO in Momentary mode (ROC800-Series). 
♦ Select Toggle if you want the Discrete Output to enter the Toggle mode. Toggle mode enables a 

square-wave output for which both the Time On and Time Off are defined by the Time On 
parameter. Time On and Time Off will be equal. 

♦ Select TDO for a timed duration output. TDO Parameters tab provides additional parameters to 
specify scaling and engineering unit conversion. For a TDO, the quantitative value calculated by 
a PID loop or FST is converted into a time that the Discrete Output is active versus the time it is 
inactive, similar to an Analog Output. 
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♦ Select TDO Toggle if you want the Discrete Output to enter the TDO Toggle mode. In the TDO 
Toggle mode, the DO continuously repeats in a cycle defined by the Cycle Time parameter with 
the on-time duration being controlled by the EU Value parameter. When the TDO mode is 
enabled, the TDO parameters tab becomes available. Select TDO Parameters tab to set the Cycle 
Time and EU Value parameters. 

Enter the Time On value for momentary operation. The Time On default value is 1 second. Time On 
indicates the following: In Momentary mode, this is the amount of time (in seconds) that the momentary 
contact is energized. In the Toggle mode, this value is the time (in seconds) between switching On or 
Off. In the TDO and TDO Toggle modes, this value is calculated in the software by the TDO 
configuration. 

The Active Alarms field indicates any alarms that are active for this point. When Alarming is set to 
Enabled (ROC800-Series), the active alarms appear. Even if Alarming is Disabled, the Point Fail 
(hardware reports a malfunction) alarm and Manual (Scanning Disabled) indicators can still appear. If 
Alarming is set to Enabled, an alarm is generated when Scanning is Disabled. 

4.5.2 DO – Advanced 
Select Configure > I/O > DO Points. The Advanced tab enables you to configure accumulated value and 
state for reset for the selected DO.  

 
Figure 4-23. Discrete Outputs – Advanced (ROC800-Series) 
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Figure 4-24. Discrete Outputs – Advanced (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 

Indicates Accumulated Value as the number of Off to On transitions of the Discrete Output. The 
accumulator is a 32-bit number with a maximum count of 4,294,967,295. The accumulator can be preset 
by entering the desired value or cleared by entering zero. 

For a FloBoss 407, FloBoss 100-Series, and ROC300-Series, select the Status on Power Reset to 
determine the Accumulated Value used after a power reset. When Off is selected, the Accumulated 
Value parameter is cleared upon a reset of the ROC or FloBoss, such as a power restart or a Warm Start 
and the Low Reading EU is used as the new Accumulated Value. If Retain Last Status is selected, the 
last output value is used after a reset. If the AO is set to Manual Mode (Scanning Disabled), no changes 
occur unless manually entered. 

For a ROC800-Series, select the State on Reset parameter to determine the Accumulated Value after a 
reset of the ROC, such as a power restart or a Warm Start. If Retain Last State is selected, the last 
output value is used after a reset. If the AO is set to Scanning Mode Manual, no changes occur unless 
manually entered. If you select Use Failsafe State, the Low Reading EU is used as the new 
Accumulated Value. 

For a ROC800-Series and Use Failsafe State is selected, specify whether the Scanning Mode Auto or 
Scanning Mode Manual is set to On or Off  
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4.5.3 DO – TDO Parameters  
Select Configure > I/O > DO Points. The TDO Parameters tab allows configuration of TDO 
parameters when one of the DOUT Types TDO (Timed Duration) or TDO Toggle is selected in the 
Discrete Outputs screen.  

 
Figure 4-25. Discrete Outputs – TDO Parameters (FloBoss 407, ROC300-Series, ROC800-Series) 

Enter the Low Reading Time (0% Count) in seconds that represents a zero percent output pulse width. 
The default is 3 seconds. This is the minimum amount of time that the TDO can be energized to move 
the motor. Set to a value that allows movement, but also provides good resolution of control. 

Enter the High Reading Time (100% Count) in seconds that represents a 100 percent output pulse 
width. The default is 12 seconds. This is the maximum amount of time that the TDO can be energized to 
move the motor. Normally, this is the amount of time it takes for the actuator to move the valve from 
fully open to fully closed. 

Enter the Low Reading EU (engineering units) value corresponding to the Low Reading Time.  

Enter the High Reading EU (engineering units) value corresponding to the High Reading Time. 

Enter the EU Value when using TDO or TDO Toggle mode. When a value is saved, the Discrete Output 
is activated according to the magnitude of the value. The amount of on-time that a given value 
represents is determined by the scaling from Low Reading Time, High Reading Time, Low Reading EU, 
and High Reading EU. The EU Value is typically written by a PID Loop or an FST. 

Enter the Units as a 10-character name for the engineering units assigned to the TDO output. For 
example, MCF or CFM might be typical entries for this field. 

Enter the Cycle Time when using TDO Toggle mode. Cycle Time defines the total time of one cycle 
(the sum of the On time and Off time) in seconds. After a cycle has been completed, a new cycle is 
initiated. The default is 15 seconds. 
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The Cycle Time entry is used to define the OFF time in the TDO Toggle mode. The OFF time is 
calculated by the formula: 

Off Time = Cycle Time – On Time 

Example: 
A TDO is used to emulate a field instrument measuring flow. The TDO outputs a pulse width of 3 
seconds for no flow and a pulse width of 12 seconds for 1000 MCF per day flow. The output is 
repeated every 15 seconds.  

If the Cycle Time is less than, or equal to the On Time, the OFF time is set to one. Care must be 
taken in configuration (including other places, such as FSTs) to ensure that the Cycle Time remains 
greater than the calculated On Time for proper operation. 

Select Configure > I/O > DO Points. The TDO Parameters tab allows configuration of TDO parameters 
when one of the DOUT Types TDO (Timed Duration) or TDO Toggle is selected in the Discrete 
Outputs screen. The Time On field is calculated from the entered EU Value and the previous definitions 
of Low Reading Time, High Reading Time, Low Reading EU, and High Reading EU entered in the 
TDO Parameters screen. The calculation formulas are: 

EU Span = High Reading EU Value – Low Reading EU 

Count Span = High Reading Time (100% Count) – Low Reading Time (0% Count) 

On Time = (Entered EU Value × Count Span) + Low Reading Time (0% Count) 

  EU Span   

4.5.3.1 DO – TDO (Defining the Output Pulse) 
To define the TDO Output Pulse:  

1. Select Configure > I/O > DO Points. 

2. Select a DOUT Type of TDO or TDO Toggle in the Discrete Outputs dialog. 

♦ TDO (Timed Duration). The single-pulse output can be triggered by writing to the Status or 
the EU Value parameter of the DO point. This can be accomplished directly, by a PID point, 
or by an FST. 

♦ TDO Toggle. A continuous pulse is generated with the pulse length being controlled by 
writing to the EU Value parameter in the DO point. This can be accomplished directly or by 
an FST.  

3. Click the TDO Parameters tab. 

The output pulse from the TDO function must be defined for proper engineering unit (EU) conversion. 
The minimum pulse width (Low Reading Time / 0% Count) and the maximum pulse width (High 
Reading Time / 100% Count) define the minimum and maximum ON time of the output pulse. The 
values entered in the Low Reading Time and High Reading Time are the number of seconds the output 
is ON. 
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Example: 
A TDO is used to emulate a field instrument measuring flow. The TDO outputs a pulse width of 3 
seconds for no flow and a pulse width of 12 seconds for 1000 MCF per day flow. 

Low Reading Time (0% Count) = 3 seconds 

High Reading Time (100% Count) = 12 seconds 

Low Reading EU = 0 

High Reading EU = 1000 

4.5.4 DO – Alarms (ROC800-Series) 
Select Configure > I/O > DO Points. The Alarms tab sets the alarm parameters for this DO point. 

 
Figure 4-26. Discrete Outputs – Alarms (ROC800-Series) 

When Alarming is Enabled, alarms will be generated on point failure. When Alarming is Disabled, the 
Point Fail alarm appears in the Active Alarms field, but will not be written to the Alarm Log. 

To conserve Alarm Log space, alarms should be enabled only when necessary. Even if you do not plan 
to use all the alarms, check and adjust the value of each one so that no false alarms generate. 

If the host computer is configured to receive field-initiated calls, you can select a Report-by-Exception 
(RBX) option to send a Spontaneous-Report-by-Exception message. 

♦ On Alarm Set – When the point enters an alarm condition, the ROC or FloBoss generates a 
SRBX message. 

♦ On Alarm Clear – When the point leaves an alarm condition, the ROC or FloBoss generates a 
SRBX message.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  
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4.6 PI – Pulse Input Configuration 
Pulse Inputs (PI) accept pulse trains (square wave signals) generated by measurement devices, such as 
turbine meters. The Pulse Input accepts digital level On/Off signals from an external device and 
accumulates the changes over a configured period of time. The PI can also determine a rate from the 
accumulated pulses over a configured period of time.  

Select Configure > I/O > PI Points. Examine the default settings and adjust the parameters to suit your 
application on each of the tabs in the order given below. 

1. The General tab sets the basic parameters for the PI point.  

2. The Advanced tab lets you configure features, such as EU Options, Rate Period, Rollover value, 
and Conversion for the Pulse Input. 

3. The Alarms tab sets the alarm parameters for this PI point. 

4. When Alarming is Enabled, the limit alarms (four levels, Rate, and Deadband) are configured on 
the Alarms tab. When Alarming is Disabled, no limit alarms generate for this point. The Point 
Fail and Manual Mode alarm appears in the Active Alarms field, but will not be logged in the 
Alarms Log. 

5. To conserve Alarms Log space, alarms should be enabled only when necessary. Even if you do 
not plan to use all the alarms, check and adjust the value of each one so that no false alarms 
generate. 

6. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 

4.6.1 PI – General 
Select Configure > I/O > PI Points. The General tab sets the basic parameters for the PI point.  

 
Figure 4-27. Pulse Inputs – General (ROC800-Series) 
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Figure 4-28. Pulse Inputs – General (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 

Select the Pulse Input to be configured. 

Enter a 10-character string Tag for identification of the Point Number. Any alphanumeric characters, 
including spaces, may be used. 

The Point Number identifies the physical location of the input. For the ROC800-Series, the Point 
Number identifies the module slot – channel number. 

Enter the Units, a user-defined 10-character description for the engineering units (EU) assigned to the 
I/O, such as Counts or Pulses.  

The EU Value is dependent on how the EU Options are set in the PI Advanced tab. If the PI is set up for 
a Rate (Max Rollover) then the Current Rate is assigned to the EU Value. If the PI is set up as an 
accumulator using Today’s Total (Max Rollover), then Today’s Total is assigned to the EU Value.  

If the PI is set up for accumulator using Running Total (Entered Rollover), then the EU Value 
corresponds to the accumulated pulses times the Conversion. The EU Value is compared to the value 
entered for the Rollover Value. If it is greater than or equal to this entered value, the EU Value here is 
reset to zero.  

Select the Scanning option.  
♦ For the input to automatically process the field input, select Enabled (Automatic Mode). When 

Scanning is set to Enabled, EU Value displays the last Pulse Input scan in engineering units. 
♦ When Scanning is set to Disabled (Manual Mode), the engineering unit (EU) Value is no longer 

updated by the ROC or FloBoss. If Scanning is set to Disabled, a value may be entered in the EU 
Value to override the input.  
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Enter the Scan Period as the amount of time between scans of the EU Value in seconds. The default 
value is 1 second for the ROC800-Series and 5 seconds for the other devices. The rate calculation is 
performed based on the number of pulses counted during the scan interval divided by the time interval. 
To avoid highly fluctuating calculation results, there should typically be at least 10 pulses occurring 
between scans at low flow conditions. For example, if a flow meter produces one pulse per second at 
low flow, then the Scan Period should be set to a minimum of 10 seconds. 

For a Pulse Input implemented in a PI module for a ROC300-Series or FloBoss 407, the input signal 
must be scanned often enough such that rollover in the module’s 16-bit counter, which occurs at 65535, 
is not missed. For example, a 10 kHz input signal must be scanned at least every 6.5 seconds to register 
the value before rollover occurs. 

Once the Scan Period is reached, the Accum’d Pulses, Pulses Today, Today’s Total, Yesterday’s Total, 
and Current Rate values update. 

Enter the Accum’d Pulses as the value of the raw counts (accumulated pulses) as stored in an 
accumulated value counter that resides in the firmware. For each Scan Period, the ROC or FloBoss 
determines the number of raw counts that have occurred since the last Scan Period and adds them to the 
accumulated value counter. The accumulated value rolls over to zero after reaching 16,777,216 for the 
ROC800-Series and FloBoss 100-Series. The FloBoss 407 and ROC300-Series rolls over to zero after 
reaching 8,388,608. 

Enter the Conversion (ROC800-Series). This value is multiplied by the number of pulses to determine 
the Units as configured. This parameter is sometimes referred to as the “K Factor” for turbine meters. 
The value entered here is taken times the number of pulses to convert the pulses into the Units of 
measurement configured on this screen.  

Enter the Contract Hour (ROC800-Series). This will set the beginning of the day for the daily counted 
parameters listed above. 

If you Enable Alarming, the limit alarms (four levels, Rate, and Deadband) are configured on the 
Alarms tab. If you disable Alarming, no limit alarms generate for this point. The Point Fail and Manual 
Mode alarm may appear in the Active Alarms field, but will not be logged in the Alarms log. 

Alarms should be enabled only when necessary. Even if you do not plan to use all the alarms, check and 
adjust the values so that no false alarms generate.  

For the ROC800-Series, Alarming is Enabled in the Configure > I/O > PI Points > Alarms tab. 

For the FloBoss 100-Series, ROC300-Series, and FloBoss 407, Alarming is Enabled in the Configure > 
I/O > PI Points > General tab. 

Frequency (ROC800-Series version 1.24 and greater) displays the frequency, in pulses/second, of 
incoming pulses. 

Pulses For Day (ROC800-Series) displays the total number of pulses that the PI has received for the 
contract day. The Contract Hour is specified on this screen. At the end of the contract day, it zeros and 
starts over, only if being totalized in History. 

Today’s Total displays the total EU Values accumulated for the current contract day. Today’s Total is 
reset to zero at Contract Hour.  

Today’s Total = Accumulated Pulses x the Conversion Value 

Yesterday’s Total displays the total EU Value accumulated the previous contract day.  

Yesterday’s Total = Previous day’s Today’s Total at Contract Hour before being cleared 
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Current Rate is the value of the calculated rate as of the most recent scan expressed in EUs per unit of 
time. Time units are selected by the Rate Period parameter on the Advanced tab. Rate is calculated at the 
end of each Scan Period. 

Current Rate = Number of pulses received x Conversion Value ÷ Rate Period 

The Active Alarms field indicates any alarms that are active for this point. When Alarming is set to 
Enabled, the limit alarms (such as Low Alarm and Rate Alarm) that are active appear. Even if Alarming 
is Disabled, the Point Fail (hardware reports a malfunction) alarm indicator can still appear. If Alarming 
is set to Enabled, an alarm is generated when Scanning is Disabled. 

4.6.2 PI – Advanced  
Select Configure > I/O > PI Points. The Advanced tab lets you configure features, such as EU Options, 
Rate Period, Rollover value, and Conversion for the Pulse Input.  

 
Figure 4-29. Pulse Input – Advanced (ROC800-Series) 
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Figure 4-30. Pulse Inputs – Advanced (FloBoss 407 and ROC300-Series) 

 
Figure 4-31. Pulse Inputs – Advanced (FloBoss 100-Series) 
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Select the type of EU Option: 
♦ Rate (Max Rollover) – EU Value is assigned the values of the Current Rate parameter. 
♦ Today’s Total (Max Rollover) – EU Value is assigned the value of the Today’s Total 

parameter. 
♦ Running Total (Entered Rollover) – EU Value corresponds to the accumulated pulses 

multiplied by the Conversion factor. If the EU Value exceeds the Rollover value, it is cleared and 
starts to accumulate from 0 again. In this mode, EU Values are not cleared at Contract Hour.  

Enter the Rollover Value (EUs) when Running Total (Entered Rollover) is selected in the EU Options 
field. Enter a number in EUs (not pulses) to specify when the rollover should occur. 

This field is not used when Rate or Today’s Total is selected as the EU Option type. 

The Filter Time (Seconds) (FloBoss 100-Series) determines the amount of time (in seconds) between 
start of pulse and recognition of pulse. The user should estimate the amount of signal “bounce” time so 
that the FloBoss will not count noise as actual pulses. If none (the default) is selected, the FloBoss will 
recognize all pulse signal movement as actual pulses. 

Enter the Rate Period if Rate was selected under EU Options. Four time periods can be selected to 
perform the rate calculation: 

♦ EU/Sec – Calculation based on EU second totals (ROC800-Series). 
♦ EU/Min – Calculation based on EU minute totals. 
♦ EU/Hour – Calculation based on EU hourly totals. 
♦ EU/Day – Calculation based on EU day totals. 

The following shows the calculation of the Current Rate in two different ways: 

If Conversion Mode is EUs per pulse, and Rate Period is EU per minute, then 

Current Rate = (accumulated pulses × Conversion) ÷ (Scan Period × conversion from 
seconds to minutes) 

If Conversion Mode is pulses per EU, and Rate Period is EU per hour, then  

Current Rate = (accumulated pulses ÷ Conversion) ÷ (Scan Period × conversion from 
seconds to hours) 

Select the Conversion if Rate was selected under EU Options.  
♦ EUs/Pulse – The specified number of engineering units (typically fractional parts, such as 0.01) 

associated with a single pulse. 
♦ Pulses/EU – This is the inverse of EUs/Pulse. Here, the specified number of pulses (such as 100) 

is required to equal one engineering unit. 

For the ROC800-Series, this parameter specifies how the number entered in the Conversion field on the 
main PI screen is used. 

For the FloBoss 100-Series, ROC300-Series, and FloBoss 407, enter the Conversion/K-Factor. This 
parameter is sometimes called the K-Factor for turbine meters. 

For the ROC300-Series and FloBoss 100-Series, if the PI is used as an input to AGA7 calculations, then 
the Conversion value should be set to produce the EU Value in MCF or kM3. 
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For a FloBoss 407, the Conversion/K-Factor value should be set to produce a EU value in the units 
select for the EU Units. 

Define the EU Units (FloBoss 407) represented by the EU Value. The EU selections of values CF/m3, 
10CF/10m3, CCF/100m3, and MCF/kM3 affect the weight of each pulse received by the Pulse Input.  

For example, if the PI is configured so that 50 pulses = 1 EU and the EU Units is set to EU=CF/m3, 
then 100 pulses = 2 CF or 2 m3. If the PI is configured so that 50 pulses = 1 EU and the EU Units is 
set to EU=MCF or kM3, then 100 pulses = 2 MCF or 2 kM3. 

This selection will also have an effect on the uncorrected volume totals input to an AGA7 calculation. 
The AGA 7 calculation converts the Pulse Input rate to MCF/kM3 per day for the uncorrected meter 
input.  

4.6.3 PI – Alarms 
Select Configure > I/O > PI Points. The Alarms tab sets the alarm parameters for this PI point. 

When Alarming is Enabled, the limit alarms (four levels, Rate, and Deadband) are configured on the 
Alarms tab. When Alarming is Disabled, no limit alarms generate for this point. The Point Fail alarm 
appears in the Active Alarms field, but will not be logged in the Alarms Log. 

To conserve Alarms Log space, alarms should be enabled only when necessary. Even if you do not plan 
to use all the alarms, check and adjust the value of each one so that no false alarms generate. 

 
Figure 4-32. Pulse Inputs – Alarms (ROC800-Series) 
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Figure 4-33. Pulse Inputs – Alarms (FloBoss 407, FloBoss 100-Series, and ROC300-Series) 

The Rate Alarm is the value, in engineering units, that represents the maximum amount of change in 
the calculated rate allowed between updates. If the change is equal to, or greater than this value, an 
alarm is generated. To disable this Rate Alarm without disabling the other alarms, the Rate Alarm value 
can be set to a value greater than the maximum rate. 

The two high level alarms are the limit values, in engineering units, to which the EU Value must rise to 
generate a High or HiHi Alarm. The HiHi Alarm value is typically set higher than the High Alarm. 

The two low level alarms are the limit values, in engineering units, to which the EU Value must fall to 
generate a Low or LoLo Alarm. The LoLo Alarm value is typically set lower than the Low Alarm.  

The Alarm Deadband value, in engineering units, is an inactive zone above the Low Alarm and below 
the High Alarm. The purpose of the Alarm Deadband is to prevent the alarm from being set and cleared 
continuously when the input value is oscillating around the alarm limit. This also prevents the Alarm 
Log from being overfilled with data. 

If the host computer is configured to receive field-initiated calls, you can select a Report-by-Exception 
(RBX) option to send a Spontaneous-Report-by-Exception message. 

♦ Disabled – Select Disabled to turn RBX Alarming Off. 
♦ On Alarm Set – When the point enters an alarm condition, the ROC or FloBoss generates a 

SRBX message. 
♦ On Alarm Clear – When the point leaves an alarm condition, the ROC or FloBoss generates a 

SRBX message.  
♦ On Alarm Set & Clear – (FloBoss 100-Series, ROC300-Series, and FloBoss 407). In either 

condition, an RBX message generates.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  
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4.7 Pulse Interface Module Diagnostic (FloBoss 104) 
When on-line with a FloBoss 104 unit, select Utilities > Pulse Input Module Diagnostic to monitor the 
operation of the Pulse Interface Module. These Read-Only fields display information about the module 
firmware and hardware, as well as data from the last scan of the module.  

 
Figure 4-34. Pulse Interface Module Data (FloBoss 104) 

Revision and Build Date refer to the firmware in the module.  

Direction refers to the direction that the magnet will move. P1 Installed and P2 Installed refer to the 
Auxiliary Pulse Inputs. 

Last Rotation Time is the amount of time, in seconds, required to complete a rotation at the last Update 
or last scan in AutoScan mode. Rotation Deviation is the amount of change between the last rotation 
and the current rotation, in %. Unexpected Switch Counts is a diagnostic tool. If this value in this field 
rises while the FloBoss 104 is installed and operating, please contact your local sales representative. 

The Rotation Position graphic at the bottom of the screen is a visual representation of the counter’s 
position. Rotation position is the indicator that the magnet is turning on the Roots or Rotary meter. If 
this position does not change while the FloBoss is in operation and this screen is in AutoScan mode, 
please contact your local sales representative. 

After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in the 
ROC > Flags screen to save I/O configuration to permanent memory in case you perform a Cold Start. 
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Figure 4-35. Pulse Interface Module View (FloBoss 104) 

If the meter is turning the magnet clockwise direction while looking down on the magnet after it is 
installed then PI 1 of the PIM PI Points #1, PI 1 – PIM indicates pulses. 

If the magnet is turning counter-clockwise while looking at it form the top down after being installed on 
the meter, then Pulse Input #2, PI 2 – PIM indicate pulses. 

4.8 RTD – RTD Input Configuration (ROC800-Series) 
RTD Inputs are analog signals generated by RTD (Resistance Temperature Detector) probes, a device to 
measure temperature.  

For the ROC800-Series, select Configure > I/O > RTD Points. Examine the default settings and adjust 
the parameters to suit your application on each of the tabs in the order given below. 

� Note: The RTD point for the FloBoss 100-Series or FloBoss 407 is configured as a type of AI 
Point. Refer to AI – Analog Input Configuration. 

1. Select Configure > I/O > RTD Points.  

2. The General tab sets the basic parameters for the RTD Input point. 

3. The Advanced tab enables you to configure features, such as filtering, A/D conversions, and 
clipping for the selected RTD Input.  

4. The RTD Calibration tab is available on-line for calibration of the RTD point. Refer to Section 
10, Calibration. 

5. The Alarms tab sets the alarm parameters for this RTD point. 

6. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 
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4.8.1 RTD – General  
Select Configure > I/O > RTD Points. The General tab sets the basic parameters for the RTD Input 
point. 

 
Figure 4-36. RTD – General (ROC800-Series) 

Select the RTD Input to be configured. The inputs are listed by both number and tag. 

Enter a 10-character string Tag for identification of the Point Number. Any alphanumeric characters, 
including spaces, may be used. 

The Point Number identifies the physical location of the input. For the ROC800-Series, the Point 
Number identifies the module slot – channel number.  

If Scanning is set to Disabled, enter a Value to override the RTD Input. When Scanning is set to 
Enabled, Value displays the last RTD Input scan in engineering unit. 

Select one of the Units radio buttons. This determines in which EU the temperature will be calculated. 

Enter a Units Tag to display in configuration screens, reports and custom displays. This should be the 
same unit of measure as is chosen in the Units radio buttons. If this field is blank, then configuration 
screens, reports, and custom displays will show a blank where the unit of measure should be. 

Select the Scanning option.  
♦ For the input to automatically process the field input, select Enabled (Automatic Mode). When 

Scanning is set to Enabled, Value displays the last RTD Input scan in engineering units. 
♦ When Scanning is set to Disabled (Manual Mode), the engineering unit (EU) Value is no longer 

updated by the ROC. If Alarming is Enabled, a Scanning Disabled alarm generates when 
Scanning is set to Disabled. If Scanning is set to Disabled, enter a Value to override the input.  
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Enter the Scan Period as the amount of time between updates of the Filter value. All RTD Inputs are 
updated based on their individual Scan Periods. The default value is 1 second. The minimum scan period 
allowed is 64 mSec. ROCLINK 800 software will not allow a value less than 64 mSec in this field. The 
scan occurs in multiples of 64 mSec (i.e. if you enter 0.20 sec, it will scan every 0.192 sec). 

The Low Reading EU corresponds to a 0% input. 

The High Reading EU corresponds to a 100% input. 

The Active Alarms field indicates any alarms that are active for this point. When Alarming is set to 
Enabled, the limit alarms (such as Low Alarm and Rate Alarm) that are active appear. Even if Alarming 
is Disabled, the Point Fail (hardware reports a malfunction) alarm indicator can still appear. If Alarming 
is set to Enabled, an alarm is generated when Scanning is Disabled. 

4.8.2 RTD – Advanced  
Select Configure > I/O > RTD Points. The Advanced tab enables you to configure features, such as 
filtering, A/D conversions, and clipping for the selected RTD Input.  

 
Figure 4-37. RTD – Advanced (ROC800-Series) 

Enter a Filter value, which is a weighted sample using a percentage of the last value, plus a percentage 
of the new value. The entered data is the percentage of the last value used. The filter is calculated every 
Scan Period by the formula:  

(Last Value × Entered %) + (New Value × (100 – Entered %)) = Filtered Value 

Enable Average Raw Values to average and calculate the raw readings during the Scan Period and use 
the outcome as the Raw A/D Input during EU calculations. For example, when enabled, an RTD Input 
point configured with a Scan Period of 1.0 seconds obtains a new value from the A/D every 50 
milliseconds. During the Scan Period, 20 values are obtained from the A/D and summed together. At EU 
calculation, the values summed are divided by the Actual Scan Period display and are used as the Raw 
A/D Input. Disable this function to acquire instantaneous values. 
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Select the RTD Alpha of the RTD being used 0.00385 or 0.00392. 

When Clipping is enabled, the software forces the Filtered EUs to stay within the range defined by the 
cut off limits. Set the cut off limits by using the LoLo Alarm and HiHi Alarm parameters. 

The Adjusted A/D 0% is the calibrated Analog-to-Digital (A/D) reading corresponding to zero percent 
input. In the Calibrate function, this value is altered to set the zero percent input exactly at the Low 
Reading EU value to eliminate transmitter and system errors. 

The Adjusted A/D 100% is the calibrated A/D reading corresponding to 100 percent input. This value 
is used to convert the input to engineering units. In the Calibrate function, this value is altered to set the 
100 percent input exactly at the High Reading EU value. 

Raw A/D Input displays the current reading directly from the Analog-to-Digital converter.  

Actual Scan displays the actual amount of time in seconds that passes between scans. This number 
should be the same as shown for the Scan Period parameter if the system is not overloaded. 

4.8.3 RTD – Alarms 
Select Configure > I/O > RTD Points. The Alarms tab sets the alarm parameters for this RTD point. 

 
Figure 4-38. RTD – Alarms (ROC800-Series) 

When Alarming is Enabled, the limit alarms (four levels, Rate, and Deadband) are configured on the 
Alarms tab. When Alarming is Disabled, no limit alarms generate for this point. The Point Fail alarm 
appears in the Active Alarms field, but will not be logged in the Alarms Log. 

To conserve log space, alarms should be enabled only when necessary. Even if you do not plan to use all 
the alarms, check and adjust the value of each one so that no false alarms generate. 

The Rate Alarm is the value, in engineering units, that represents the maximum amount of change 
allowed between updates. If the change is equal to or greater than this value, an alarm is generated. To 
disable this Rate Alarm without disabling the other alarms, the Rate Alarm value can be set greater than 
the Span of the Analog Input. 
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Enter the High Alarm limit value, in engineering units, to which the input value must rise to generate a 
High Alarm. The HiHi Alarm value is typically set higher than the High Alarm. 

Enter the Low Alarm limit value, in engineering units, to which the input value must fall to generate a 
Low Alarm. The LoLo Alarm value is typically set lower than the Low Alarm. 

Alarm Deadband is the value, in engineering units, that is an inactive zone above the Low Alarm limits 
and below the High Alarm limits. The purpose of the Alarm Deadband is to prevent the alarm from 
being set and cleared continuously when the input value is oscillating around the alarm limit. This also 
prevents the Alarm Log from being over-filled with data. 

If the host computer is configured to receive field-initiated calls, you can select a Report-by-Exception 
(RBX) option to send a Spontaneous-Report-by-Exception message. 

♦ On Alarm Set – When the point enters an alarm condition, the ROC generates a SRBX message. 
♦ On Alarm Clear – When the point leaves an alarm condition, the ROC generates a SRBX 

message.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  

4.9 TC – Thermocouple Input Configuration (ROC800-Series) 
Thermocouple (TC) Inputs are used to monitor the extremely small voltage generated by a thermocouple 
sensor. These small voltages are converted to temperature values.  

� Note: Thermocouple modules are only available with ROC800-Series units. 

Select Configure > I/O > TC Points. Examine the default settings and adjust the parameters to suit your 
application on each of the tabs in the order given below. 

1. Select Configure > I/O > TC Points.  

2. The General tab sets the basic parameters for the TC Input point.  

3. The Advanced tab enables you to configure features, such as filtering and averaging for the 
selected TC Input.  

4. The Alarms tab sets the alarm parameters for this TC point. 

5. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 
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4.9.1 Thermocouple – General  
Select Configure > I/O > TC Points. The General tab sets the basic parameters for the TC Input point.  

 
Figure 4-39. Thermocouple – General (ROC800-Series) 

Select the Thermocouple Input to be configured. The inputs are listed by both Point Number and Tag. 

Enter a 10-character string Tag for identification of the Point Number. 

The Point Number identifies the physical location of the input. For the ROC800-Series, the Point 
Number identifies the module slot – channel number. 

When Scanning is set to Enable, Value displays the last TC Input scan in engineering unit. If Scanning 
is set to Disabled, enter a Value to override the input.  

Select the Type of Thermocouple sensor in use. 

Input Temperature Range: 
♦ J Type: –200 to 1200°C (–328 to 2192°F). 
♦ K Type: –100 to 1372°C (–121 to 2500°F). 

Select one of the Units radio buttons. This determines in which EU the temperature will be calculated. 

Enter a Units Tag to display in configuration screens, reports and custom displays. This should be the 
same unit of measure as is chosen in the Units radio buttons. If this field is blank, then configuration 
screens, reports, and custom displays will show a blank where the unit of measure should be. 

Select the Scanning option.  
♦ For the input to automatically process the field input, select Enabled (Automatic Mode). When 

Scanning is set to Enabled, Value displays the last TC Input scan in engineering units. 
♦ When Scanning is set to Disabled (Manual Mode), the engineering unit (EU) Value is no longer 

updated by the ROC. If Scanning is set to Disabled, enter a Value to override the input.  
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Enter the Scan Period as the amount of time between updates of the Filter value. All TC Inputs are 
updated based on their individual Scan Periods. The default value is 1 second. The minimum scan period 
allowed is 100 mSec. 

The Active Alarms field indicates any alarms that are active for this point. When Alarming is set to 
Enabled, the limit alarms (such as Low Alarm and Rate Alarm) that are active appear. Even if Alarming 
is Disabled, the Point Fail (hardware reports a malfunction) alarm and Manual (Scanning Disabled) 
indicators can still appear. If Alarming is set to Enabled, an alarm is generated when Scanning is 
disabled.  

4.9.2 Thermocouple – Advanced  
Select Configure > I/O > TC Points. The Advanced tab enables you to configure features, such as 
filtering and averaging for the selected TC Input.  

 
Figure 4-40. Thermocouple – Advanced (ROC800-Series) 

Enter a Filter value, which is a weighted sample using a percentage of the last value, plus a percentage 
of the new value. The entered data is the percentage of the last value used. The filter is calculated every 
Scan Period by the formula:  

 (Last Value × Entered %) + [New Value × (100 – Entered %)] = Filtered Value 

Enable Average Raw Values to average and calculate the raw readings during the Scan Period and use 
the outcome as the Raw A/D Input during EU calculations. For example: When Enabled, a TC Input 
point configured with a Scan Period of 1.5 seconds obtains a new value from the A/D every 100 
milliseconds. During the Scan Period, 10 values are obtained from the A/D and summed together. At EU 
calculation, the values summed are divided by the Actual Scan Period display and are used as the Raw 
A/D Input. Disable this function to acquire instantaneous values. 

Actual Scan displays the actual amount of time in seconds that passes between scans. This number 
should be the same as shown for the Scan Period parameter if the system is not overloaded. 
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4.9.3 Thermocouple – Alarms  
Select Configure > I/O > TC Points. The Alarms tab sets the alarm parameters for this TC point. 

 
Figure 4-41. Thermocouple – Alarms (ROC800-Series) 

When Alarming is Enabled, the limit alarms (four levels, Rate, and Deadband) are configured on the 
Alarms tab. When Alarming is Disabled, no limit alarms generate for this point. The Point Fail alarm 
appears in the Active Alarms field, but will not be logged in the Alarms Log. 

To conserve Alarm Log space, alarms should be enabled only when necessary. Even if you do not plan 
to use all the alarms, check and adjust the value of each one so that no false alarms generate. 

The Rate Alarm is the value, in engineering units, that represents the maximum amount of change 
allowed between updates. If the change is equal to, or greater than this value, an alarm is generated. To 
disable this Rate Alarm without disabling the other alarms, the Rate Alarm value must be set greater 
than the Span (Range) of the TC Input. 

Input Temperature Range: 
♦ J Type: –200 to 1200°C (–328 to 2192°F). 
♦ K Type: –100 to 1372°C (–121 to 2500°F). 

The four level alarms are the limit value, in engineering units, to which the EU Value must fall to 
generate a Low, High, LoLo, or HiHi Alarm. The HiHi Alarm value is typically set higher than the High 
Alarm. 

The four level alarms are the limit value, in engineering units, to which the EU Value must fall to 
generate a Low, High, LoLo, or HiHi Alarm. The LoLo Alarm value is typically set lower than the Low 
Alarm.  

The Alarm Deadband value, in engineering units, is an inactive zone above the Low Alarm and below 
the High Alarm. The purpose of the Alarm Deadband is to prevent the alarm from being set and cleared 
continuously when the input value is oscillating around the alarm limit. This also prevents the Alarm 
Log from being filled with nuisance alarm trips. 
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If the host computer is configured to receive field-initiated calls, you can select a Report-by-Exception 
(RBX) option to send a Spontaneous-Report-by-Exception message. 

♦ On Alarm Set – When the point enters an alarm condition, the ROC generates a SRBX message. 
♦ On Alarm Clear – When the point leaves an alarm condition, the ROC generates a SRBX 

message.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  

4.10 System AI – System Analog Input Configuration (ROC800-Series) 
Select Configure > I/O > System AI Points. System Analog Inputs are analog signals generated by 
sources within the ROC unit.  

For the ROC800-Series, select Configure > I/O > System AI Points. Examine the default settings and 
adjust the parameters to suit your application on each of the tabs. 

The ROC800-Series has five System Analog Inputs: 
♦ System AI #1 = Battery. 
♦ System AI #2 = Charge Voltage. 
♦ System AI #3 = Module Voltage. 
♦ System AI #4 = AI Default. 
♦ System AI #5 = Board Temperature. 
� Note: For the FloBoss 100-Series, ROC300-Series, or FloBoss 407, select Configure > I/O > 

Analog Input. The System Analog Inputs are treated as Analog Inputs. Refer to AI – Analog 
Input Configuration. 

1. Select Configure > I/O > System AI Points General tab sets the basic parameters for the AI 
Input point.  

2. The Advanced tab enables you to configure features, such as filtering, averaging, and clipping 
for the selected Input.  

3. The Alarms tab sets the alarm parameters for this AI point. 

4. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 
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4.10.1 System AI – General (ROC800-Series) 
Select Configure > I/O > System AI Points > General to set the basic parameters for the AI Input point.  

 
Figure 4-42. System AI – General (ROC800-Series) 

System AI Number  
In the ROC800-Series: 

♦ System AI #1 = Battery. 
♦ System AI #2 = Charge Voltage. 
♦ System AI #3 = Module Voltage. 
♦ System AT #4 = AI Default. 
♦ System AI #5 = Board Temperature. 
� Note: For the FloBoss 100-Series or FloBoss 407, select Configure > I/O > Analog Input. 

The System AI are treated as Analog Inputs. 

Because this type of input has no physical location, the portion of the Point Number that refers to 
module location is 0. The portion that refers to channel number is 1 to 5 for the input numbers.  

Enter a 10-character string Tag for identification of the point. 

When Scanning is set to Enable, Value displays the last Analog Input scan in engineering units. If 
Scanning is set to Disabled, enter a Value to override the input.  

Enter the Units value. Inputs #1, 2, and 3 are in Volts. Input #5 is in Degree C. 

Select the Scanning option.  
♦ For the input to automatically process the field input, select Enabled (Automatic Mode). When 

Scanning is set to Enabled, Value displays the last System AI scan in engineering units. 
♦ When Scanning is set to Disabled (Manual Mode), the engineering unit (EU) Value is no longer 

updated by the ROC or FloBoss. If Scanning is set to Disabled, enter a Value to override the 
input.  
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Enter the Scan Period as the amount of time between updates of the Filter value. The default value is 1 
second. All System Analog Inputs are updated based on their individual Scan Periods. 

The Low Reading EU (engineering unit) corresponds to zero percent input.  

The High Reading EU corresponds to 100 percent input. 

The Active Alarms field indicates any alarms that are active for this point. When Alarming is set to 
Enabled, the limit alarms (such as Low Alarm and Rate Alarm) that are active appear. Even if Alarming 
is Disabled, the Point Fail (hardware reports a malfunction) alarm indicator can still appear. If Alarming 
is set to Enabled, an alarm is generated when Scanning is Disabled. 

4.10.2 System AI – Advanced (ROC800-Series) 
Select Configure > I/O > System AI Points. The Advanced tab enables you to configure features, such 
as filtering, averaging, and clipping for the selected Input.  

 
Figure 4-43. System AI – Advanced (ROC800-Series) 

Enter a Filter value, which is a weighted sample using a percentage of the last value plus a percentage 
of the new value. The entered data is the percentage of the last value used. The Filter is calculated every 
Scan Period by the formula:  

(Last Value × Entered %) + (New Value × (100 – Entered %)) = Filtered Value 

Enable Average Raw Values to average and calculate the raw readings during the Scan Period and use 
the outcome as the Raw A/D Input during EU calculations. For example, when enabled, an Analog Input 
point configured with a Scan Period of 5 seconds obtains a new value from the A/D every second. 
During the Scan Period, five values are obtained from the A/D and summed together. At EU calculation, 
the values summed are divided by the number of samples and are used as the Raw A/D Input. Disable 
this function to acquire instantaneous values. 

When Clipping is Enabled, the software forces the Filtered EUs to stay within the range defined by the 
cut off limits. Set the cut off limits by using the LoLo Alarm and HiHi Alarm parameters. 
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Adjusted A/D 0% is the calibrated Analog-to-Digital (A/D) reading corresponding to zero percent 
input.  

Adjusted A/D 100% is the calibrated A/D reading corresponding to 100 percent input.  

Raw A/D Input displays the current reading directly from the Analog-to-Digital converter. 

Actual Scan displays the actual amount of time in seconds that passes between scans. This number 
should be the same as shown for the Scan Period parameter if the system is not overloaded. 

4.10.3 System AI – Alarms (ROC800-Series) 
Select Configure > I/O > System AI Points. The Alarms tab sets the alarm parameters for this AI point. 

 
Figure 4-44. System AI – Alarms (ROC800-Series) 

If you Enable Alarming, the limit alarms (four levels, Rate, and Deadband) are configured on the 
Alarms tab. If you Disable Alarming, no limit alarms generate for this point. The Point Fail alarm 
appears in the Active Alarms field, but will not be logged in the Alarms Log. 

To conserve Alarm Log space, alarms should be enabled only when necessary. Even if you do not plan 
to use all the alarms, check and adjust the value of each one so that no false alarms generate. 

The Rate Alarm is the value, in engineering units, that represents the maximum amount of change 
allowed between updates. If the change is equal to or greater than this value, an alarm is generated. To 
disable this Rate Alarm without disabling the other alarms, the Rate Alarm value can be set greater than 
the Span of the Analog Input. 

Enter the High Alarm limit value, in engineering units, to which the input value must rise to generate a 
High Alarm. The HiHi Alarm value is typically set higher than the High Alarm. 

Enter the Low Alarm limit value, in engineering units, to which the input value must fall to generate a 
Low Alarm. The LoLo Alarm value is typically set lower than the Low Alarm. 
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Alarm Deadband is the value, in engineering units, that is an inactive zone above the Low Alarm limits 
and below the High Alarm limits. The purpose of the Alarm Deadband is to prevent the alarm from 
being set and cleared continuously when the input value is oscillating around the alarm limit. This also 
prevents the Alarm Log from being over-filled with data. 

If the host computer is configured to receive field-initiated calls, you can select a Report-by-Exception 
(RBX) option to send a Spontaneous-Report-by-Exception message. 

♦ On Alarm Set – When the point enters an alarm condition, the ROC generates a SRBX message. 
♦ On Alarm Clear – When the point leaves an alarm condition, the ROC generates a SRBX 

message.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  

4.11 HART Input Configuration (ROC800-Series) 
Select Configure > I/O > HART. Examine the default settings and adjust the parameters to suit your 
application on each of the tabs. 

1. Select Configure > I/O > HART (Highway Addressable Remote Transducer). 
2. The General and Advanced tabs set parameters for the channel. Each ROC800-Series HART 

module can support up to four channels.  
3. The Calibration tab enables you to calibrate the HART Analog Input. Refer to Section 10, 

Calibration. 
4. The Device tabs set parameters specific to the devices in that channel. Each channel in Analog 

Output mode can support one device. Each channel in Analog Input mode can support up to five 
devices. 

5. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 
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4.11.1 HART – General (ROC800-Series) 
Select Configure > I/O > HART. The General tabs sets parameter for the channel. Each ROC800-Series 
HART module can support up to four channels. Select the HART Point Number you desire to configure. 

 
Figure 4-45. HART – General (ROC800-Series) 

Channel Version indicates the version of firmware present in the HART card for this channel. 

Comm Status indicates the status of the communications channel. Scanning indicates the channel is 
currently scanning the device(s). Not Scanning indicates the device(s) is currently off-line or not 
communicating. Dual Master indicates that the channel has another master connected. Examples of 
other masters include a Hand-Held Communicator and a device that is configured to be in Burst 
mode. When in Dual Master, the ROC is not scanning the device, which allows communications 
between the other master and the device(s). When the Hand-Held Communicator finishes 
communicating with the HART device (or Burst mode was turned off in the device), normal HART 
module scanning will automatically resume.  
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� Note: Burst mode is not supported by the ROC800-Series HART module. The device should not 
be configured in Burst mode when connected to the ROC. If a device is in Burst mode, use a 
Hand-Held Communicator to turn off Burst mode. 

I/O Type indicates whether the jumper on the HART module is configured as an Analog Input or 
Analog Output. 

When Communication Mode is disabled, all HART communication stops. No changes will occur, 
unless manually entered. When in Point to Point mode, the channel will allow communications with one 
device. When in Multi-drop mode, the channel will allow communications with the specified number of 
devices (maximum of five). 

EU Value is the value in Engineering Units of the Analog Input or Analog Output. 

Low Reading EU is the value in Engineering Units that corresponds to zero percent input. 

High Reading EU is the value in Engineering Units that corresponds to 100 percent input. 

Output Mode / Analog Scanning  
When the Channel I/O displays Analog Input, select an Analog Scanning option:  

♦ For the input to automatically process the field input, select Enabled (Automatic Mode).  
♦ For the engineering unit (EU) Value to be no longer updated by the ROC, select Disabled 

(Manual Mode).  

When the Channel I/O displays Analog Output, select an Output Mode option:  
♦ For the output to automatically process the field input and use the Auto Value, select Automatic 

(Enabled Mode). 
♦ For the output to use the Manual Value, select Manual. 

For the engineering unit (EU) Value to be no longer updated by the ROC, select Disabled.  

� Note: Even in Manual Mode, the HART device may change. 

When the Channel I/O displays Analog Output and Automatic Output mode has been selected, the Auto 
Value, in Engineering Units, will be used as an output. 

When the Channel I/O displays Analog Output and Manual Output mode has been selected, the Manual 
Value, in Engineering Units, will be used as an output. 

Physical Value displays the current value of the output in Engineering Units. 
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4.11.2 HART – Advanced (ROC800-Series) 
Select Configure > I/O > HART. The Advanced tab sets parameters for the channel. Each ROC800-
Series HART module can support up to four channels. 

  
Figure 4-46. HART – Advanced (ROC800-Series) 

Adjusted A/D 0% is the calibrated Analog-to-Digital (A/D) reading corresponding to zero percent 
input. In the Calibrate function, this value is altered to set the zero percent input exactly at the Low 
Reading EU value to eliminate transmitter and system errors. 

Adjusted A/D 100% is the calibrated A/D reading corresponding to 100 percent input. This value is 
used to convert the input to engineering units. In the Calibrate function, this value is altered to set the 
100 percent input exactly at the High Reading EU value. 

Raw A/D Input displays the current reading directly from the Analog-to-Digital converter.  

When Retain Last Value is selected as the EU Value on Reset, the last EU value for the channel is used 
after a reset or a Warm Start. If Use Failsafe Value is selected, then the value entered as the Failsafe 
Value here is used after a reset or Warm Start. 
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Pass Through enables pass through communications from a host device through the ROC800-Series 
unit and on to the HART devices. The communications must be in ROC Plus protocol (typically for 
Opcode 120 requests). You may either enable it to strip all preamble bytes (in HART protocol) or leave 
the entire message intact. If Enabled, enter the Timeout, the amount of time (in milliseconds) to pause 
between the end of the pass through communication and the restarting of polling of the HART device. 

4.11.3 HART – Device (ROC800-Series) 
Select Configure > I/O > HART. The Device tabs set parameters specific to the devices in that channel. 
Each channel in Analog Output mode can support one device. Each channel in Analog Input mode can 
support up to five devices. 

When Point to Point Communications Mode is selected from the General tab, the device information is 
presented via the Device 1 tab. When Multidrop Communications Mode is selected, each Device tab 
corresponds to the HART Tag (Point Number) defined for the ROC to Poll. 

  
Figure 4-47. HART – Device (ROC800-Series) 
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Poll Mode determines the polling behavior for this device. 

♦ Skip this Device removes this device from the polling sequence. 
♦ PV Only signifies that only the Primary Variable value is to be polled. 
♦ Dynamic Variables signifies that the values for all of the Dynamic Variables (primary, 

secondary, tertiary, and fourth) are to be polled. 
♦ Slot Variables signifies that only the values for the three Slot Variables are to be polled. 
♦ Update polls for a full update of all values. 

PV is the value of the Primary Dynamic Variable. 

If Value on Reset is set to Use Failsafe Value, PV Fail Safe is the value to be used as the Primary 
Variable, after a reset or Warm Start.  

SV is the value of the Secondary Dynamic Variable. 

If Value on Reset is set to Use Failsafe Value, SV Fail Safe is the value to be used as the Secondary 
Variable, after a reset or Warm Start. 

TV is the value of the Tertiary Dynamic Variable. 

If Value on Reset is set to Use Failsafe Value, TV Fail Safe is the value to be used as the Tertiary 
Variable, after a reset or Warm Start. 

FV is the value of the Fourth Dynamic Variable. 

If Value on Reset is set to Use Failsafe Value, FV Fail Safe is the value to be used as the Fourth 
Variable, after a reset or Warm Start. 

Slot Assignment (0, 1, 2, or 3) determines which variable in that slot to request. 

Slot Value (0, 1, 2 or 3) is the value of the variable requested from that slot. The Read-Only units 
defined in the device is displayed to the right of this field. 

Actual Scan Period displays the actual amount of time in seconds that passes between scans.  

Current displays the current, in milliamps, reported by the device. 

% of Range displays the percentage of the range currently being reported by the device. 

Status displays the state of the device. This field will display either No Device or Communicating. 

Response Code displays the response status of the device. Refer to the documentation from the 
transmitter manufacturer for more information. 

ID Number displays a 3-byte globally unique address of the device. 

The Active Alarms field indicates any alarms that are being sent from the device. These are not entered 
in the Alarm Log. 

When Retain Last Value is selected as the Value on Reset, the last EU values for the Dynamic 
Variables are used after a reset or a Warm Start. If Use Failsafe Value is selected, then the values 
entered as the Failsafe Value are used after a reset or Warm Start. 

Enter a Tag for the HART device. This will identify this device throughout the configuration. The Tag 
should be 10 characters or less. When in Multi-drop mode, the Tag must be unique for every device. 

The Poll Address displays the address used for this HART device. When in Point to point mode, the 
Poll Address will be 0. When in Multi-drop mode, the addresses of 1 to 5 will be used. 
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Device ID displays the coded ID that reflects the manufacturer of the device, the device type, and the 
device ID. 

PV Sensor Serial Number displays the serial number of the sensor. 

PV Upper Sensor Limit (USL) displays the upper limit on the sensor. 

PV Lower Sensor Limit (LSL) displays the lower limit on the sensor. 

Sensor Units displays the units of measure for the upper and lower sensor limits. 

PV Damping Value displays the damping value reported by the device for the Primary Variable. 

PV Range Units displays the units of measure for the Analog Output minimum span and upper and 
lower range limits. 

PV Upper Range Limit (URV) displays the maximum value in the Analog Output range. 

PV Lower Range Limit (LRV) displays the minimum value in the Analog Output range. 

PV Minimum Span displays the minimum sensor span. 

Enter a Descriptor to identify this device. This may be 24 characters in length. This is intended as a 
more specific identifier than the tag. 

Enter a Message that will be sent to the device and stored there. 



ROCLINK 800 User Manual 

Rev. Dec-05 Configuring Inputs and Outputs (I/O) 4-57 

4.12 MVS Sensor (ROC800-Series or FloBoss 407) 
Select Configure > I/O > MVS Sensor. The MVS Sensor screen provides you with an interface to a 
Multi-Variable Sensor. The MVS sensor is a smart device that can measure temperature, static pressure, 
and differential pressure.  

� Note: Refer to Section 10, Calibration. 

� Note: The DVS sensor for the FloBoss 100-Series is configured using Analog Inputs.  

  
Figure 4-48. Multi-Variable Sensor (ROC800-Series or FloBoss 407) 

Select Configure > I/O > MVS Sensor. 

Select the MVS Sensor to configure. Each MVS has a unique Address number to differentiate it from 
other MVS units, because MVS sensors can be multi-dropped.  

Sensor Interface Version displays the version of the sensor interface firmware for the sensor. 

Enter the ten-character Tag that resides in the MVS. Click the Write button to write the Tag to the MVS 
Sensor. 

Enter the Address of the MVS interface used with the device communications protocol. The default 
Address is 1. If the MVS is used in the multi-drop mode, each MVS must have a unique Address. 
Address 240 can be used to poll the sensor to determine the address of the connected sensor. This is 
similar to polling a ROC or FloBoss using Address and Group 240. When Address 240 is used, the 
sensor will respond with its address by updating the Address field. Click the Write button to write the 
Address to the MVS Sensor. 
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Displays the Voltage input to the sensor. If the MVS interface version is 6 or greater, this field should 
read approximately “5”, which is the voltage to the microcontroller in the sensor. If the MVS interface 
version is less than 6, this field shows the input voltage to the sensor. The input voltage to the sensor, in 
versions less than 6, must be at least 10.5 volts dc for proper operation. 

For a ROC800-Series unit, enter the DP Zero Shift value to be used as the Zero Shift Differential 
Pressure value during calibration. During a calibration procedure, the ROC may modify this value. The 
user may also modify this value after a calibration is performed, as needed. 

The Pressure / Temperature Values display the scaled Differential Pressure (Diff Pressure) reading 
from the sensor. The units display as either In H2O or kPa. The scaled Differential Pressure (Reverse 
DP) reading is from the sensor times a negative “1” for flow in the reverse direction. The scaled 
absolute Pressure (Static Pressure) reading from the sensor displays in either PSI or kPa. The scaled 
process Temperature reading from the sensor displays in either degrees Fahrenheit or degrees Celsius.  

Enable Scanning for the input to enable communications to the MVS sensor. An alarm generates when 
Scanning is Disabled.  

If Scanning is Disabled, no values are updated from the MVS sensor. 

Select either US or Metric Units for the Process Variable. If Metric units are selected, then the AGA 
calculation expects all inputs to be in the indicated units, such as kPa for the Static Pressure input. Note 
that US Units are included in the factory defaults for the MVS101, but not for the MVS205. For an 
MVS205, if you change Units, use the Set Back to Factory Defaults button in Utilities > MVS 
Calibration screen to match the default calibration values. For an MVS101, the default calibration values 
automatically match Units. If you change the Units, a Sensor Configuration Write is required. 

Click to enable or disable Differential Pressure Alarms, Pressure Alarms, Temperature Alarms, and 
RBX Alarms for the MVS Sensor. 

Select either Upstream or Downstream to indicate the location of the static pressure tap in relation to 
the orifice and normal flow. By default, the MVS sensor is set as an Upstream device. The Report 
Pressure As parameter allows the pressure to be reported as either Upstream or Downstream pressure. 
If Downstream is selected, then the Diff Pressure (DP) is subtracted (in PSI) from the Static Pressure 
(SP) reading to obtain a Downstream Pressure measurement for archiving. For Downstream operation, 
adjustments to the calibration procedure may be required when setting the Span value. 

Enable or disable Sensor Alarms. Status displays the alarm conditions of the sensor or any alarms that 
are active for this point. When Sensor Alarms are Enabled, the failed alarms (such as point fail alarms, 
485 comm fail, and sensor fail) that are active appear.  

Click the Write button, in the Sensor Configuration field, to update the sensor with the current values 
on the screen or click the Read button to read the sensor’s current configuration data and Process 
Variables. 

Select the Action on Failure to set the sensor to retain the last values (Hold Last Value) before the 
failure, or you can set the sensor to return to the configured fault values (Set To Fault Value) when the 
sensor fails, an input point fails, or comm fail. 
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Select to enable or disable Differential Pressure Alarms, Pressure Alarms, and/or Temperature 
Alarms. If Enabled, configure the alarms using the Modify Limits buttons. Alarms are logged to the 
Alarm Log. To conserve log space, enable alarms only when necessary. Even if all alarms are Disabled, 
the Point Fail alarm indicator can still appear. The status of the alarm is indicated in the read-only Status 
field.  

♦ Low Alarm – The limit value, in engineering units, to which the value must fall to generate a 
Low Alarm. 

♦ High Alarm – The limit value, in engineering units, to which the value must rise to generate a 
High Alarm. 

♦ Alarm Deadband – The value, in engineering units, that is an inactive zone above and below the 
Low Alarm and High Alarm limits. The purpose of the Alarm Deadband is to prevent the alarm 
from being set and cleared continuously when the DP, SP, and Temp values are oscillating 
around the alarm limit. This also prevents the Alarm Log from being overfilled with data. 

♦ Fault Value – If a point fails and Action on Failure is configured to Set to Fault Value, the EU 
value for that point is set to the number entered in the Fault Value field. Fault Values are only 
used in Modify Limits. 

Select the Reference Temperature to determine how the DP is reported. The default value is 15.6°C 
(60°F). This value is only used when the Units selection is changed or the Downstream option is 
selected. 

If the host computer is configured to receive field-initiated calls, you can select a Report-by-Exception 
(RBX) option to send a Spontaneous-Report-by-Exception message. 

♦ Disabled – (FloBoss 407) Select Disabled to turn RBX Alarming Off. 
♦ On Alarm Set – When the point enters an alarm condition, the ROC or FloBoss generates a 

RBX message. 
♦ On Alarm Clear – When the point leaves an alarm condition, the ROC or FloBoss generates a 

RBX message.  
♦ On Alarm Set and Clear – (FloBoss 407) When the point enters or leaves an alarm condition, 

the ROC or FloBoss generates a RBX message. 
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  

After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in the 
ROC > Flags screen to save I/O configuration to permanent memory in case you perform a Cold Start. 

� Note: Click the Write button, in the Sensor Configuration field, to update the sensor with the 
current values on the screen or click the Read button to read the sensor’s current configuration 
data and Process Variables. 
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SECTION 5 – CONFIGURING THE METER SETUP 

Use Meter Setup to configure Meter Runs (all devices) and Stations (ROC800-Series). The Meter and 
Station configuration screens contain the functions directly associated with measuring and logging flow, 
including setup of American Gas Association (AGA) or International Standards Organization (ISO) 
(ROC800-Series) calculation configuration parameters, and calibrating the meter. 

In this Chapter 
Section Page 
5.1 Meter Setup Basics........................................................................................................................... 5-1 

5.2 Station Configuration (ROC800-Series) .......................................................................................... 5-2 

5.3 Meter Setup Configuration............................................................................................................. 5-11 

5.1 Meter Setup Basics 
The ROC800-Series organizes Meter Runs into Stations. The 12 Meter Runs can be grouped among the 
12 Stations (maximum) in any combination. Meters are assigned to Stations in the Meter > Setup > 
Orifice or Turbine screens. Meter runs belong in the same Station when they have the same gas data, 
calculation methods, and base / contract conditions. If using constant gas quality data from a lab analysis 
report, then all 12 Stations can be employed. If using live Gas Quality data from a Gas Chromatograph, 
no more than ten Stations are recommended. 

� Note: Contract hours can be set differently for each Station in the History Segment 
Configuration screen. 

Configuration screens for the Station and the individual meters are accessible by clicking on the Station 
or meter icon in the Configuration Tree. Each Station may be given a unique Tag, and each Meter may 
be given a unique Tag and Meter Description. 

The FloBoss 103 has a single orifice meter and does not support Stations.  

The FloBoss 104 has a single turbine or rotary meter and does not support Stations.  

The FloBoss 407 has up to four orifice or turbine meters and does not support Stations.  

The ROC306 and ROC312 have up to three orifice or turbine meters and does not support Stations. 

The ROC364 has up to five orifice or turbine meters and does not support Stations. 

Table 5-1 displays the defaults for Metric and US Engineering Units. 



ROCLINK 800 User Manual 

Rev. Dec-05 Configuring the Meter Setup 5-2 

Table 5-1. Default Engineering Units (EU) 
  

Flow Parameter U.S. Units Metric Units 
Meter Input (AGA3) Inches H2O kPa  
Meter Input (AGA7) – Volume MCF/Day kM3/Day 
Meter Input (AGA7) – Mass lb/Hr kg/Hr 
Static Pres PSIG or PSIA kPaG or kPaA 
Temp °F °C 
Inst Volume/Day MCF/Day kM3/Day 
Inst Energy/Day MMBTU/Day GJoules/Day 
Flow Today/Yesterday MCF kM3 
Energy Today/Y’day MMBTU GJoules 
Viscosity Lb/ft-sec cP 
Diameters inches mm 
Elevation Ft M 
Inst Mass .lb/Hr kg/Hr 

 

5.2 Station Configuration (ROC800-Series) 
To configure a Station, select a Station icon in the Configuration Tree menu or select Meter > Setup > 
Stations. Configure the parameters on each tab as pertains to your application. 

Configure the Station before configuring the Meter Runs.  

1. The Station Configuration General tab sets basic parameters that all the Meter Runs in the 
Station have in common.  

2. The Gas Quality tab sets the parameters for the gas information. The Gas Quality tab defines the 
mole percentages of twenty-one gas components, as well as the Heating Value Basis, the Heating 
Value, and the Specific Gravity. If other Stations have similar characteristics, use Copy and 
Paste to create Gas Quality configurations.  

� Note: For information on the Gas Quality tab on the Meter Setup screens for the FloBoss 
100-Series and FloBoss 407, refer to Parameters on Meter Gas Quality Tab (FloBoss 100-
Series and FloBoss 407). 

3. The Advanced tab of the Station Configuration contains a number of additional parameters that 
affect the flow calculation.  

4. The Alarms tab allows you to configure alarming parameters for Station flow rates. 

5. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 
the ROC > Flags screen to save I/O configuration to permanent memory in case you perform a 
Cold Start. 
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5.2.1 Station – General (ROC800-Series) 
To configure a Station, select a Station icon in the Configuration Tree menu or select Meter > Setup > 
Stations. The Station Configuration General tab sets basic parameters that all the Meter Runs in the 
Station have in common.  

  
Figure 5-1. Station – General (ROC800-Series) 

Select the active Station to be configured. This lists all active Stations.  

Enter a unique Tag for the Station of up to 10 characters. 

Select the History Segment in the Historical Database that will be used to configure history points for 
the Meters in this Station. 

Select the Contract Hour for the meters in this Station. 

� Note: The Contract Hour for the Station may also be set in the Configure > History Segment 
screen. 
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Select the set of Calculation Standards that are to be used for orifice, gas linear meters, and mass linear 
meters in this Station. There is only one edition of AGA and ISO flow calculations for the ROC800-
series. Calculation standards include: 

♦ Gas, AGA3-92 / AGA7-96 / AGA11-2003 – American Gas Association (AGS) standard for gas 
flow through an orifice, a linear meter, and a mass (Coriolis) meter. 

♦ Gas, ISO5167-98 / ISO9951-93 / ISO10790-2003 – International Standard Organization (ISO) 
standard for gas flow through an orifice, a linear meter, and a mass (Coriolis) meter.  

♦ Liquid, ISO5167-98 / API 12-95 / ISO10790-1999 – ISO and API (American Petroleum 
Institute) standards for liquid flow through an orifice, a linear meter, and a mass (Coriolis) meter. 

Select Gas, AGA3-92 / AGA7-96 / AGA11-2003 for the Station when you want AGA 3 calculations for 
all orifice meters in the Station and AGA 7 calculations for all turbine meters and all mass (Coriolis) 
meters in a Station.  

Select Gas, ISO5167-98 / ISO9951-93 / ISO10790-2003 for the Station when you want one of these 
calculations for all orifice meters in the Station and ISO9951 calculations for all turbine meters and all 
mass (Coriolis) meters in a Station. 

� Note: ISO9951 calculations are identical to AGA 7 calculations. 

Select Liquid, ISO5167-98 / API 12-95 / ISO10790-1999 for the Station when you want one of these 
calculations for all orifice meters with an expansion factor set to 1.0. Linear volumetric meters will 
calculate a corrected volume using user-entered / calculated pressure and temperature correction factors. 
Mass (Coriolis) meters calculate a corrected volume form the Mass Flow Rate and the Base Density. 

� Note: For linear volumetric meters using API 12, the user-entered / calculated pressure and 
temperature correction factors, as well as the Base Density and Flowing Density values, will 
need to be supplied by a FST, User C program, a host computer, a DS800 program, or manually 
entered from a custom display. The FPV Method parameter must be set to User so that the 
density values can be entered.  

The Station Values displays flow rates and accumulations that represent the summation of all the Meter 
Runs in the Station.  
Flow Rate: Volume flow rate at base condition in MCF/day or kM3/day.  
Energy Rate: Energy rate at base conditions in mmBtu/day or GJ/day.  
Mass Rate: Mass rate conditions in Mlb/day or Tonnes/day.  
Flow Today: Total accumulation of flow for the current contract day in MCF or kM3.  
Energy Today: Total accumulation of energy for the current contract day in mmBtu or GJ.  
Mass Today: Total mass for the day in Mlb or Tonnes.  
Zs: Represents the compressibility at standard conditions (~).  
Zb: Represents the compressibility at base conditions (~).  
Base Density: Represents the density of the measured fluid at base conditions in lbm/ft3 or kg/m3.  
Flow Yesterday: Total accumulation of flow for the previous contract day in MMCF or kM3.  
Energy Yesterday: Total accumulation of energy for the previous contract day in MMBTU or GJ.  
Mass Yesterday: Total accumulation of mass for the previous contract day in Mlb or Tonnes. 
Current alarm conditions display in the Active Alarms fields located at the bottom of the General tab. 
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5.2.2 Station – Gas Quality (ROC800-Series) 
To configure a Station, select a Station icon in the Configuration Tree menu or select Meter > Setup > 
Stations. 

The Gas Quality tab sets the parameters for the gas information. The Gas Quality tab defines the mole 
percentages of twenty gas components, as well as the Heating Value Basis, the Heating Value, and the 
Specific Gravity. If other Stations have similar characteristics, use Copy and Paste to create Gas Quality 
configurations.  

� Note: For information on the Gas Quality tab on the Meter Setup screens for the FloBoss 100-
Series and 407, refer to Parameters on Meter Gas Quality Tab (FloBoss 100-Series and 407). 

  
Figure 5-2. Station – Gas Quality (ROC800-Series) 

Enter the mole percent of each Gas Component present in the gas for this Station. This value is 
required to calculate the compressibility of gas using the AGA 8 detailed method.  

If the AGA 8 detailed method is selected, the Total Mole % should equal 100% after all the component 
mole percentages have been entered. 

Select the Heavy Gas Option to separate the heavy gas percentage (C6+) into individual components in 
the mole percentages for n-Hexane, n-Heptane, n-Octane, n-Nonane, and n-Decane. To enter Heavy 
gases, enable the Heavy Gas option, and enter the percentage of Heavy Gases under Hexane+. Then go 
to the Advanced tab, and enter the amount of each Heavy Gas. 
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The mole percentages in the Heavy Gas Distribution fields on the Advanced tab must equal 100%. If 
the total % of the distribution among the five heavier components is less than 100%, hexane is increased 
to make the total add up to 100%. If the total % of the distribution is greater than 100%, Decane is 
reduced first, then Nonane, then octane, then Heptane, then hexane until the total is equal to 100%. 

The Gas Quality field determines where to get Gas Quality readings. Live indicates readings come from 
a gas chromatograph and changes to the gas composition, specific gravity, and hearing value will not be 
logged to the Event Log or force a historical event. Constant indicates the readings will be entered in the 
Event Log. 

Select the Normalization Type to determine what action is taken if the Total of the gas mole 
percentages do not add up to 100%.  

♦ Select Methane Adjust to have the Methane component automatically adjusted up or down to 
compensate for the difference if the Total does not equal 100%.  

♦ Select Full Normalization to have each component adjusted if the Total does not equal 100%. 

Select between Dry (no water vapor present in the gas), Wet (saturated water vapor present in the gas), 
or As Delivered (may contain some water vapor) for the Heating Value Basis. This selection indicates 
on what basis the entered Heating Value was determined and is for accounting purposes only and does 
not affect the flow or energy calculations. 

Enter the gross volumetric Heating Value of the measured fluid at base conditions in lb/ft3 or kg/m3. 
For gas, this value represents the real Heating Value, rather than the ideal Heating Value. 

For gas, enter the Spec Gravity as the real gas relative density that is defined as the ratio of the real 
density of the gas to the real density of dry air a the same reference conditions of pressure and 
temperature. 

For liquids, enter the Spec Gravity as the ratio of the density of the liquid to the density of water at the 
same reference conditions of pressure and temperature. 
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5.2.3 Station – Advanced (ROC800-Series) 
To configure a Station, select a Station icon in the Configuration Tree menu or select Meter > Setup > 
Stations. 

The Advanced tab of the Station Configuration contains a number of additional parameters that affect 
the flow calculation.  

  
Figure 5-3. Station – Advanced (ROC800-Series) 

For flow calculations, select FPV Method of Detailed, Gross I, Gross II, or User methods of calculating 
the compressibility factor. The Detailed method provides the highest accuracy in a broader range of 
measurement conditions; however, one of the Gross methods can be used when: 

♦ Temperature is between 0 and 54°C (32 and 130°F). 
♦ Pressure is between 0 and 8274 kPa (0 and 1200 psia). 
♦ Gas composition is within the normal range as defined in the 1992 AGA8 report.  



ROCLINK 800 User Manual 

Rev. Dec-05 Configuring the Meter Setup 5-8 

Briefly, the three FPV Methods are: 

Detailed – Requires the natural gas composition in mole percent to be entered for all components.  

Gross I  
♦ Specific Gravity (relative density). 
♦ Real gas gross heating value per unit volume. 
♦ The mole % of CO2. 

Gross II  
♦ Specific Gravity (relative density). 
♦ The mole % of CO2. 
♦ The mole % of N2. 
� Note: If either Gross Method is chosen, manually enter the Specific Gravity and Heating 

Value in the Gas Quality screen. For Gross Method II, the Heating Value is required only for 
calculating the gas energy flow. 

User – Requires the base compressibility, standard compressibility, flowing compressibility, base 
density, and flowing density values to be entered. These values become Read/Writable and may be 
obtained from a non-calculated source. The values may come from a User C program, FST, host 
computer, DS800 program, or a custom display. If none of these sources provide values, the last 
value will be held. 

Select either US (English) or Metric Units for calculations. If Metric units are selected, then the AGA 
calculation expects all inputs to be in the indicated units (such as kPa for the static pressure input); keep 
in mind that any existing entered values are not converted.  

Select either Calculate or Enter Atmospheric Pressure for the value of the atmospheric pressure 
(absolute) at the metering location. If Calculate is selected, the value is calculated based on the 
Elevation. If Enter is selected, type a value for the pressure. The units of measurement are in PSIA or 
kPa for Metric. If entered, the value must be greater than zero. 

Select Calculate or Enter Local Gravitational Acceleration for the gravitational acceleration at the 
metering location. If Calculate is selected, the value is calculated from the Elevation and Latitude. If 
Enter is selected, type a value for the acceleration. The units of measurement are in ft/sec2 or M/sec2. If 
entered, the value must be greater than zero. 

Enter the flow measurement Base Pressure specified in the gas contract. The pressure units are in PSIA, 
or kPa for Metric. 

Enter the flow measurement Base Temperature specified in the gas contract. The temperature units are 
in degrees Fahrenheit or degrees Celsius. 

Enter the Elevation or altitude of the metering location. The units are in feet or meters. 

Enter the geographic Latitude of the metering location. The units are in degrees and minutes, separated 
by a decimal point. For example: 46.15. 
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If Heavy Gas Option was enabled on the Gas Quality tab, the mole percentages of Heavy Gas 
Distribution (hydrocarbons Hexane and heavier) should be entered here. The mole percentages in the 
Heavy Gas Distribution fields must equal 100%. If the Total % of the distribution among the 5 heavier 
components is less than 100%, hexane is increased to make the total add up to 100%. If the Total % of 
the distribution is greater than 100%, Decane is reduced first, then Nonane, then octane, then Heptane, 
and then hexane, until the total is equal to 100%. 

5.2.4 Station – Alarms (ROC800-Series) 
To configure a Station, select a Station icon in the Configuration Tree menu or select Meter > Setup > 
Stations.  

The Alarms tab allows you to configure Station-wide alarming parameters. 

You can either enable or disable alarming for each Station. Alarms can be configured for the individual 
Meter Runs and/or the Stations, generating meter-specific and/or Station-wide alarm conditions.  

If you enable alarms, the alarms can be configured using the Alarms tab and are logged to the Alarm 
Log. To conserve log space, alarms should be enabled only when necessary. If you disable alarms, no 
alarm generates for this point, regardless of the Alarm configuration. Alarm conditions display in the 
Active Alarms fields located in the Station Configuration General tab. 

Even if you do not plan to use all the alarms, check and adjust the value of each one so that no false 
alarms generate. 

  
Figure 5-4. Station – Alarms (ROC800-Series) 
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Select Alarming as: 
♦ Disabled – No alarms occur for this Station. 
♦ Alarm on Volume / Day – Alarm values occur based on volumetric flow rate per day. 
♦ Alarm on Mass / Day – Alarm values occur based on mass flow rate per day. 

Enter the High Alarm limit value, in engineering units, to which the Volumetric or Mass Flow Rate 
value must rise to generate a High Alarm. The Mass units assumed for the input are MCF per day (1000 
ft3/day) or cubic meters per day (m3/day). The Volumetric units assumed for the input are MLb per day 
(1000 lb/day) or tonnes per day (100kg/day). 

Enter the Low Alarm limit value, in engineering units, to which the Volumetric or Mass Flow Rate 
value must fall to generate a Low Alarm. The units assumed for the input are MCF per day (1000 
ft3/day) or cubic meters per day (m3/day). The Volumetric units assumed for the input are MLb per day 
(1000 lb/day) or tonnes per day (100kg/day). 

Alarm Deadband is the value, in engineering units that the flow value must be above the Low Alarm 
limit and below the High Alarm limit before the alarm clears. The purpose of the Alarm Deadband is to 
prevent the alarm from being set and cleared continuously when the input value is oscillating around the 
alarm limit.  

Select the RBX Alarming option to configure Spontaneous-Report-by-Exception (SRBX) alarming for 
this point.  

♦ On Alarm Set – The point enters an alarm condition, the ROC generates a Spontaneous-Report-
by-Exception message to the host.  

♦ On Alarm Clear – The point leaves an alarm condition, the ROC generates a Spontaneous-
Report-by-Exception message to the host. 
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured.  
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5.3 Meter Setup Configuration 
For ROC800-Series units, once the Station has been configured, the individual Meter Runs that are a 
part of the Station should be configured. Select Meter > Setup > Orifice Meter or Turbine Meter. You 
may also click on the meter in the Configuration Tree to open the Meter Setup screen that sets 
parameters unique to that meter. 

For FloBoss 100-Series, ROC300-Series, and FloBoss 407 units, select Meter > Setup or click on the 
meter in the Configuration Tree to open the screen that sets parameters unique to that meter. 

� Note: For the FloBoss 104, Rotary Meter configuration is identical to Turbine Meter configuration. 

Configure the parameters on each tab as pertains to your application. 

1. Select: 
♦ Meter > Setup > Orifice Meter or Turbine Meter or click on the meter in the Configuration 

Tree, for a ROC800-Series device. 
♦ Meter > Setup or click on the meter in the Configuration Tree, for FloBoss 100-Series, 

ROC300-Series, and FloBoss 407 units. 
2. The General tab sets the basic parameters for the meter.  
3. The Inputs tab lets you define the field inputs for differential pressure (AGA3), uncorrected 

volume or mass (AGA7), static pressure, and temperature to be used in the flow calculation.  
4. For FloBoss 100-Series, ROC300-Series, and FloBoss 407, the Gas Quality tab defines the mole 

percentages of twenty gas components, as well as the Heating Value Basis, the Heating Value, 
and the Specific Gravity. If other Stations have similar characteristics, use Copy and Paste to 
create Gas Quality configurations.  
� Note: For information on the Gas Quality tab in the Station Setup for a ROC800-Series, refer 

to the Station Gas Quality Tab (ROC800-Series). 
5. The Advanced tab specifies additional parameters for the meter.  
6. The FloBoss 100-Series uses the fields in the Sampler tab to enable you to set up the Discrete 

Output (DO2) of the FloBoss to send a pulse output to another device, such as an odorizer, and 
control a gas sampler for a Meter Run. To use this feature, select the Enabled option under 
Sampler Control. 

7. The FloBoss 100-Series use the Instrument Calibration tab to calibrated devices. 
8. The Calibration Factors tab displays a dialog box containing a number of parameters that allow 

select and calculation of optional flow adjustment factor to compensate for the difference in 
condition between the meter location and the location where the calibration instruments were 
certified. 
Selecting the Meter > Setup Orifice or Turbine > Calibration Factors tab (ROC800-Series) 
displays a dialog box containing a number of parameters that allow select and calculation of 
optional flow adjustment factor to compensate for the difference in condition between the meter 
location and the location where the calibration instruments were certified. 

9. The Alarms tab sets Alarm parameters for the meter.  
10. If the Turbine Meter Input Type on the General tab was configured to Mass, the Mass Meter 

Press Effect tab appears. 
11. After configuring all point parameters, click Apply. Use Flash Memory Save Configuration in 

the ROC > Flags to save configuration to permanent memory in case you perform a Cold Start. 
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5.3.1 Meter – General 
The General tab sets the basic parameters for the meter.  

Select: 
♦ Meter > Setup > Orifice Meter or Turbine Meter or click on the meter in the Configuration Tree, 

for a ROC800-Series device. 
♦ Meter > Setup or click on the meter in the Configuration Tree, for FloBoss 100-Series, ROC300-

Series, and FloBoss 407 units. 

  
Figure 5-5. Meter – General (Orifice – ROC800-Series) 
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Figure 5-6. Meter – General (Turbine – ROC800-Series) 

  
Figure 5-7. Meter – General (FloBoss 100-Series, FloBoss 407, and ROC300-Series)  
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Select the number of the Meter Run (Point Number) to be configured.  

Enter a unique Tag (Meter ID or Meter Tag) for the meter of up to 10 characters.  

Select the Station (ROC800-Series) in which this meter belongs.  

Enter a unique Meter Description, up to 30 characters, to further identify this meter, or to provide 
information about the meter. 

Select the Meter Type. For the FloBoss 100-Series, ROC300-Series, or FloBoss 407, select Orifice or 
Turbine. Select Orifice when measuring flow through an Orifice Plate and select Turbine when 
measuring flow through a turbine, Positive Displacement (PD), or other linear meter. 

For the ROC800-Series with an orifice meter type, the selections are Flange Tapped Orifice or User 
Defined Device.  

For a ROC800-Series with a turbine meter type, the selections are Volume (volume metering device like 
a turbine meter) or Mass (Micro Motion Coriolis Mass Meter or similar mass meter). 

The Calculation Standard is used for calculations. The calculation of flow in a Meter Run depends on 
the type of FloBoss or ROC being configured. Calculation methods include:  

♦ AGA3 (1992) – Orifice metering. 
♦ AGA7 (1996) – Turbine, Rotary, or other linear meters. AGA8 compressibility method. 
♦ ISO (1992) – Turbine, Rotary, or other linear meters. AGA8 compressibility method. 

You can either enable or disable Alarming for this point.  
♦ For the ROC800-Series, Alarming is Enabled or Disabled in the Meter > Setup > Orifice or 

Turbine > Alarms tab. 
♦ For the FloBoss 100-Series, ROC300-Series, or FloBoss 407, Alarming is Enabled or Disabled 

in the Meter > Setup > General tab. 

If you enable alarms, the alarms can be configured using the Alarms tab in the Meter Setup screen. If 
Enabled, alarms are also logged to the Alarm Log. If you disable alarms, no alarm generates for this 
point, regardless of the Alarm configuration. Alarm conditions display in the Active Alarms field. 

Enter the Scan Period (FloBoss 407 and ROC300-Series) value in seconds to determine how often the 
orifice or turbine meter flow calculation is to be performed. 

Enter the inside Pipe Diameter of the pipe near the orifice plate in this Meter Run. The units are inches 
or millimeters. 

Enter the Orifice Diameter of the orifice plate in this Meter Run. The units are inches or millimeters. 

Enter the Low Flow Cutoff when the differential pressure value of the metering device is less than the 
Low Flow Cutoff value, the calculated flow rate is set to zero. A No Flow alarm is recorded in the 
Alarm Log if Alarming is Enabled. For the AGA3 calculation method, this value is in terms of inches of 
water column or kPa. 

Enter the Integral Multiplier Period (IMP) (FloBoss 103) to indicate the frequency of calculation in 
minutes of the Integral Multiplier Value (IMV) in the flow orifice equation. Note that the Integral Value 
(IV) portion of the flow equation is calculated once per second.  

The Integral Multiplier Period is the amount of time in minutes between calculations of the combined 
correctional factors, called the Integral Multiplier Value (IMV) in the API measurement standard 
Section 21, Section 1. 
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The IMP can be no more than 60 minutes in length; the default is 15 minutes and cannot be less than 1 
minute. 

For a FloBoss 100-Series unit, enter the Base Multiplier Period (BMP) to indicate the frequency of 
calculations. The Base Multiplier Period is the amount of time in minutes between turbine calculations 
of the combined correctional factors, called the Base Multiplier Value (BMV) in the API measurement 
standard Section 21, Section 1. The BMV is multiplied by the actual (uncorrected) volume to arrive at 
the quantity accumulated for the period.  

To determine if flow was occurring over the Base Multiplier Period, the number of counts over the 
period is viewed. If there is an absence of counts or the BMP is set shorter than the normal time it takes 
to get a pulse, the following occurs: 

♦ Meter run is defined in a No Flow condition. 
♦ Accumulated flow is stored as zero for historical data over that time period. 
♦ Accumulated Energy is stored as zero for historical data over that time period.  

The BMP can be no more than 60 minutes in length; the default is 15 minutes and cannot be less than 1 
minute. 

Enter the Static K Factor (FloBoss 100-Series) for the Turbine linear meter constant in counts/pulses 
per unit volume, such as 4 pulses per cubic foot or 235 pulses/ft3. The English measurement is in ft3 and 
the cubic meter is in m3. The K factor is used in AGA 7 calculations and may be specified by the user 
for various low/high flow conditions, as received from a specified input. The K Factor cannot be less 
than zero. If the Variable K Factor is disabled, a static factor will be used. 

The Variable K Factor (FloBoss 100-Series), if enabled, allows the user to enter the K Factor values 
over a range to be measured. If the Variable K Factor is disabled, a static factor will be used. 

The K factor is used in AGA 7 calculations, and the Variable K Factor may be specified by the user to 
keep the K Factor value more linear by equating them to an EU value, as received from a specified 
Input. The K Factor values cannot be less than zero. Up to five K Factor and EU values can be entered. 

The Active Alarms field indicates any alarm currently activated. For example, Low indicates that the 
calculated flow is below the Low Alarm limit. Other alarms can include High, No Flow, and Manual 
Mode. 
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5.3.2 Meter – Inputs 
The Inputs tab lets you define the field inputs for differential pressure (AGA3), uncorrected volume 
(AGA7), static pressure, and temperature to be used in the flow calculation. 

Select: 
♦ Meter > Setup > Orifice Meter or Turbine Meter or click on the meter in the Configuration Tree, 

for a ROC800-Series device. 
♦ Meter > Setup or click on the meter in the Configuration Tree, for FloBoss 100-Series, ROC300-

Series, and FloBoss 407 units. 

  
Figure 5-8. Meter – Inputs (Orifice – ROC800-Series) 



ROCLINK 800 User Manual 

Rev. Dec-05 Configuring the Meter Setup 5-17 

  
Figure 5-9. Meter – Inputs (Turbine – ROC800-Series) 

For Orifice: Click the Differential Pressure TLP button to assign the input that senses the differential 
pressure (high differential pressure, if Stacked Dp is Enabled). The units assumed for the input are 
inches of water column (In. H2O) or kPa. If Manual appears, the Values field can be used to enter an 
engineering units value for the meter input. Otherwise, the Values field indicates the current input value. 

For Turbine: Click the Uncorrected Volume TLP button to assign the input that senses the input from a 
turbine meter (typically pulses). The units assumed for the input are MCF per day (1000 ft3/day) or 1000 
cubic meters per day (kM3/day). The Values field indicates the current input value, based on non-
adjusted pulses from the turbine meter. If Manual appears, the Values field can be used to enter an 
engineering units value for the meter input. 

Click the Static Pressure TLP button to assign the input that senses the static pressure. The units 
assumed for the input are PSIG / PSIA or kPaG / kPaA. If Manual appears, the Values field can be used 
to enter an engineering units value for the Static Pressure input. Otherwise, the Values field indicates the 
current input value. 

Click the Temperature TLP button to assign the input that senses the temperature of the flowing gas. 
The units assumed for the input are degrees Fahrenheit or degrees Celsius. If Manual appears, the 
Values field can be used to enter an engineering units value for the Temperature input. Otherwise, the 
Values field indicates the current input value. 

Enable Stacked DP to use stacked differential pressure transmitters used for low and high pressure 
ranges. 
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Click the Low DP Input TLP button to assign the input for monitoring low differential pressure. The 
Stacked DP parameter must be Enabled for this input to be used. This input may be left in Manual Mode 
when Stacked DP is disabled. 

Enter the Low DP SetPoint to determine when switchover to the low differential pressure input occurs. 
When High DP input is active and the High DP reading drops below this value, the Low DP input 
becomes the active input. The units assumed for the input are inches of water column (In H2O) or kPa. 

Enter the High DP SetPoint to determine when switchover to the high differential pressure input occurs. 
When the Low DP input is active and the Low DP reading rises above this Setpoint, the High DP input 
becomes the active input. The units assumed for the input are inches of water column (In. H2O) or kPa. 

Select an Averaging Technique (FloBoss 100-Series) for the Meter Run.  

♦ Flow Dependant Linear – This is the simplest and most commonly used method. This method 
discards samples for periods when there is no measurable flow, and performs a straightforward 
(linear) average of the remaining samples to compute the minute and hour values. The value 
specified in the Low Flow Cutoff of the Meter setup determines the values. When no flow 
occurs, all values are sampled. 

♦ Flow Dependant Formulaic – This method discards samples for periods when there is no flow. 
However, in calculating the average, this method typically takes the square root of each sample 
before averaging the samples together, and then squares the result. This formulaic method 
produces a slightly lower value than the linear method. 

♦ Flow Weighted Linear – This method does not discard any samples; instead, it "weights" each 
sample by multiplying it by a flow value (square root of the differential pressure measured 
during the sample period). Next, a linear average is calculated by dividing the sum of the flow-
weighted sample by the sum of the flow values. This result includes minute and hourly values 
that are more reflective of short periods of high flow. 

♦ Flow Weighted Formulaic – This method combines the flow-weighting action with the 
formulaic averaging technique, both of which were described previously. 
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5.3.3 Meter – Gas Quality (FloBoss 100-Series, ROC300-Series, and 
FloBoss 407) 

For FloBoss 100-Series, ROC300-Series, and FloBoss 407, the Gas Quality tab defines the mole 
percentages of twenty gas components, as well as the Heating Value Basis, the Heating Value, and the 
Specific Gravity. If other meter runs have similar characteristics, use Copy and Paste to create Gas 
Quality configurations.  

Select Meter > Setup or click on the meter in the Configuration Tree, for FloBoss 100-Series, ROC300-
Series, and FloBoss 407 units. 

 
Figure 5-10. Gas Quality (FloBoss 100-Series, ROC300-Series, and FloBoss 407) 

Enter the mole percent of each Gas Component, or use the default values of 96% Methane, 3% Ethane, 
and 1% Nitrogen. This value is required to calculate the compressibility of gas using the AGA 8 detailed 
method. If the AGA 8 detailed method is selected, the Total Mole % should equal 100% after all the 
component mole percentages have been entered. 

The Gas Quality field (FloBoss 100-Series) determines where to get Gas Quality readings. Live 
indicates readings come from a gas chromatograph or periodically downloaded from a host and will not 
be entered in the Event Log. Constant indicates that the readings will be entered in the Event Log. 

This field indicates the total (sum) of all gas component mole percentages. The ROC or FloBoss will 
adjust the Methane level and ensure this value is 100%. 
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If the percentages are automatically adjusted to total 100 and you would like to log this adjustment, 
select Enabled in the Log Methane Adjust field. If you select Disable, this does not prevent the ROC or 
FloBoss from automatically adjusting the Methane, but does prevent an Event Log entry. 

Select between Dry (no water vapor present in the gas), Wet (saturated water vapor present in the gas), 
or As Delivered (may contain some water vapor) for the Heating Value Basis. This selection indicates 
on what basis the entered Heating Value was determined and affects the flow or energy calculations. 

When the Wet Gas option is selected, the ROC or FloBoss calculates the mole percentage of water based 
on the algorithm from IAPWS – IF97 standards and adjusts the other mole percentages accordingly. 

 Select either Calculate or Enter for the Heating Value of a specified quantity of gas. If you choose 
Calculate, then the Heating Value is calculated from the gas composition data. If you choose Enter, the 
value entered will be used in the energy calculation. Use the Units parameter on the Advanced tab to 
toggle between volume or mass measurement of English units represented as BTU/Cf or BTU/Lb and 
the metric unit values as MJ/M3 or MJ/Kg. 

Select either Calculate or Enter for the Spec Gravity ratio of the molar mass of the gas to the molar 
mass of air. The value entered for standard conditions is used in the flow calculation. The Specific 
Gravity value cannot be less than 0.07.  

If Calculate, the ROC or FloBoss calculate the Specific Gravity value to be used in the flow 
calculations.  

If Enter, the value entered is used in the flow calculation. The Specific Gravity should be entered for the 
gas at standard conditions and cannot be less than 0.07. 
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5.3.4 Meter – Advanced 
The Advanced tab specifies additional parameters for the meter. 

Select: 
♦ Meter > Setup > Orifice Meter or Turbine Meter or click on the meter in the Configuration Tree, 

for a ROC800-Series device. 
♦ Meter > Setup or click on the meter in the Configuration Tree, for FloBoss 100-Series, ROC300-

Series, and FloBoss 407 units. 

  
Figure 5-11. Meter – Advanced (Orifice – ROC800-Series) 
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Figure 5-12. Meter – Advanced (Turbine – ROC800-Series) 
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Figure 5-13. Meter – Advanced (Orifice – FloBoss 100-Series) 
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Figure 5-14. Meter – Advanced (Turbine – FloBoss 100-Series) 
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Figure 5-15. Meter – Advanced (Orifice – ROC300-Series) 
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Figure 5-16. Meter – Advanced (Turbine – ROC300-Series) 



ROCLINK 800 User Manual 

Rev. Dec-05 Configuring the Meter Setup 5-27 

 
Figure 5-17. Meter – Advanced (Orifice – FloBoss 407) 
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Figure 5-18. Meter – Advanced (Turbine – FloBoss 407) 

For AGA calculations, select FPV Method (FloBoss 100-Series, ROC300-Series, and FloBoss 407) 
Detailed, Gross I, and Gross II (methods of calculating the compressibility factor). The Detailed method 
provides the highest accuracy in a broader range of measurement conditions; however, one of the Gross 
methods can be used when: 

♦ Temperature is between 0 and 54°C (32 and 130°F). 
♦ Pressure is between 0 and 8274 kPa (0 and 1200 psia). 
♦ Gas composition is within the normal range as defined in the 1992 AGA8 report.  

Briefly, the three FPV Methods are: 

Detailed – Requires the natural gas composition in mole percent to be entered for all components. Refer 
to the information on the Gas Quality. 

Gross I – Uses the Specific Gravity of the natural gas, its heating value, and the quantity of non-
hydrocarbon components as follows: 
♦ Specific Gravity. 
♦ Real gas gross heating value per unit volume. 
♦ The mole % of CO2. 



ROCLINK 800 User Manual 

Rev. Dec-05 Configuring the Meter Setup 5-29 

Gross II – Uses the Specific Gravity of the natural gas, as well as the quantity of non-hydrocarbon 
components as follows: 
♦ Specific Gravity. 
♦ The mole % of CO2. 
♦ The mole % of N2 
� Note: If either Gross Method is chosen, manually enter the Specific Gravity and Heating 

Value in the Gas Quality screen. For Gross Method II, the Heating Value is required only for 
calculating the gas energy flow. 

Select either US or Metric Units for calculations (ROC300-Series and FloBoss 407). If Metric units are 
selected, then the AGA calculation expects all inputs to be in the indicated units (such as kPa for the 
static pressure input); keep in mind that any existing entered values are not converted.  

For the FloBoss 407, select the Units to be output by the flow calculation. This also defines the Units 
archived in history. The US Units selections are CCF/MBTU, MCF/MMBTU, and 10MCF/MMMBTU. 
The cubic Metric Units selections are 100M3/MJoules, kM3/GJoules, and 10kM3/TJoules. The default 
value is MCF/MMBTU and kM3/Gjoules. 

For the FloBoss 100-Series, units are selected on the ROC > Information screen. 

Select either Calculate or Enter Atmospheric Pressure (FloBoss 100-Series, ROC300-Series, and 
FloBoss 407) for the value of the atmospheric pressure (absolute) at the metering location. If Calculate 
is selected, the value is calculated from Elevation. If Enter is selected, type a value for the pressure. The 
units of measurement are in PSIA or kPaA. If entered, the value must be greater than zero. 

Select Calculate or Enter Gravitational Acceleration (FloBoss 100-Series) for the value at the metering 
location. If Calculate is selected, the value is calculated from Elevation and Latitude. If Enter is selected, 
type a value for the acceleration. The units of measurement are in ft/sec2 or M/sec2. If entered, the value 
must be greater than zero. 

Enter the flow measurement Base Pressure (FloBoss 100-Series, ROC300-Series, and FloBoss 407) 
specified in the gas contract. The pressure units are in PSIA or kPaA. 

Enter the flow measurement Base Temperature (FloBoss 100-Series, ROC300-Series, and FloBoss 
407) specified in the gas contract. The temperature units are in degrees Fahrenheit or degrees Celsius. 

Enter the Elevation (FloBoss 100-Series, ROC300-Series, and FloBoss 407)of the metering location. 
The units are in feet or meters. Elevation is required for the calculation of atmospheric pressure and 
gravitational acceleration. 

Enter the geographic Latitude (FloBoss 100-Series, ROC300-Series, and FloBoss 407)of the metering 
location. Latitude is required for calculation of gravitational acceleration. The units are in degrees and 
minutes, separated by a decimal point. For example: 46.15. 

Specify the User Correction Factor as desired. This need not be limited to gravitational adjustments.  

� Note: For a FloBoss 100-Series or ROC800-Series, the Gravity Correction factor may be 
calculated. A manually entered User Correction Factor is available on the Calibration Factors 
tab. 

Enter the dynamic Viscosity of the flowing gas. The units of measure for the ROC800-Series and the 
FloBoss 407 and ROC300-Series will be either lb/ft-sec for US Units or cP for Metric units and for the 
FloBoss 100-Series will always be cP (centipoise).  
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Enter the Specific Heat Ratio (Sp Heat Ratio) of the gas (defined as the specific heat of the gas at 
constant pressure divided by the specific heat of the gas at constant volume). Accepted practice for 
natural gas applications is to use a value of 1.3, which was used to develop the expansion factor tables in 
the AGA 3 Report – Part 3. If entered, the value must be greater than zero. 

For turbine meters, enter a Meter Factor (FloBoss 407) value to adjust for inaccuracies associated with 
the meter’s performance as determined at the time of proving. 

For orifice meters, select the Orifice Material: Stainless Steel, Monel, or Carbon Steel. Nearly all 
natural gas applications use stainless steel orifice plates. 

For orifice meters, enter a value for the Reference Temp of the orifice plate. This is the temperature at 
which the bore diameter of the orifice plate was measured. The units of measurement are in degrees 
Fahrenheit or degrees Celsius. 

For orifice meters, select the meter tube material (Pipe Material): Stainless Steel, Monel, or Carbon 
Steel. Nearly all natural gas applications use carbon steel meter tubes. 

For orifice meters, enter a value for the Reference Temp of the pipe. This is the temperature at which 
the internal diameter of the pipe was measured. The units of measurement are in degrees Fahrenheit or 
degrees Celsius. 

Enter the Static K Factor (ROC800-Series) for the Turbine linear meter constant in counts/pulses per 
unit volume or mass, such as 4 pulses per cubic foot or 235 pulses/ft3. The volume units are in pulses ft3 
or pulses m3. The mass units are pulses lb or pulses kg. The Static K Factor cannot be less than zero. 

The Variable K Factor (ROC800-Series), if enabled, allows the user to enter the K Factor values at 
multiple input frequencies. If the Variable K Factor is disabled, a static factor will be used. 

The K factor is used in the flow calculations to convert raw pulses to either Volume or Mass. This 
conversion may vary with flow rate and Variable K Factors allow you to specify flow rates as indicated 
by Frequency. The K Factor values cannot be less than zero. Up to twelve K Factor and Frequency 
values can be entered. 

When the value of the uncorrected volume input is less than or equal to the Low Flow Cutoff value 
(ROC800-Series), the calculated flow is set equal to zero. A No Flow alarm is recorded in the Alarm 
Log if Alarming is Enabled. The units are MCF/Day (1000 cubic feet per day) and the Metric units are 
kM3/Day (1000 cubic meters per day). This parameter is only used if the uncorrected volume input 
selected is NOT a pulse input point type. 

Enter the No Flow Time (ROC800-Series). This is the amount of time without a pulse after which the 
ROC declares a No Flow condition. The flow cutoff is the analog signal lower limit; below this limit a 
no flow condition exists. 

When the Speed of Sound (ROC800-Series) calculation is Enabled, the Speed of Sound is calculated 
per AGA10 feet per second or meter per second based on the Pressure, Temperature, and Gas 
Composition. AGA8 Detail Method must be selected and a full Gas Composition entered to calculate the 
Speed of Sound.  

For diagnostic purposes, the measures Speed of Sound may be read through a serial connection to an 
ultrasonic flow meter and stored under the measured Speed of Sound to be compared to the calculated 
value. 
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Enable the AGA Limit Events (FloBoss 100-Series) if the FloBoss unit is to log AGA events. An AGA 
limit event is logged when an input to the AGA calculation is outside the specified limits or the 
calculation fails. Disable this parameter if the FloBoss should ignore AGA calculation related events. 
Disabling this parameter will prevent the Event Log from filling with AGA limit type events. 

Select Force Recalculation (FloBoss 100-Series) and click Apply to cause a full recalculation of the 
flow without waiting for the next normal recalculation. Normal recalculation periods are established in 
Meter Setup screen using the Integral Multiplier Period or the Base Multiplier Period. Upon forcing a 
recalculation, the accumulations are zeroed and the flow value is logged as a new entry. The Force 
Recalculation parameter is automatically set to Clear after the recalculation completes.  

Up to three selections can be made for the Pressure Tap used in this Meter Run. 
♦ Gauge or Absolute – Select either Gauge or Absolute as the pressure tap type. This choice must 

match the static pressure type is actually measured by the sensor. The MVS sensor, DVS sensor, 
or other pressure transmitter can be ordered to provide either absolute or gauge measurements. 

♦ Upstream or Downstream – For an orifice run, select either Upstream or Downstream to 
indicate the location of the static pressure tap in relation to the orifice and normal flow. 
Upstream is the default.  

♦ Flange or Pipe – (ROC300-Series) For an orifice run, this indicates either Flange or Pipe type of 
pressure taps in this Meter Run. For a 1992 AGA calculation, only Flange is selected.  
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5.3.5 Meter – Sampler (FloBoss 100-Series) 
The FloBoss 100-Series uses the fields in the Sampler tab to enable you to set up the Discrete Output 
(DO) of the FloBoss to send a pulse output to another device, such as an odorizer, and control a gas 
sampler for a Meter Run. To use this feature, select the Enabled option under Sampler Control.  

Select Meter > Setup or click on the meter in the Configuration Tree for FloBoss 100-Series. 

  
Figure 5-19. Meter – Sampler (FloBoss 100-Series) 

Select Enabled in the Sampler Control field for the Sampler to override the built-in DO located at Point 
Number B4 (for 4 point I/O) or at Point Number B5 DO-2 (for 6 point I/O). 

Enter the Sampler Volume Accum (number of cubic feet) of gas to be metered between pulses. For 
example, if an odorizer needs to track every 100 cubic feet of gas being metered, enter 100. The units 
are cubic meters m3 (Ft3). The Sampler Volume Accum value is based upon the instantaneous flowrate. 

Enter the Sampler Duration to specify how long (in seconds) the pulse to the device needs to be. This 
is how long it stays ON. The Discrete Output (DO2 on termination board) is turned on for the amount of 
time set in the Sampler Duration every time the Sampler Volume Accum value is exceeded. 
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5.3.6 Meter – Instrument Calibration (FloBoss 100-Series) 
Select Meter > Setup > Instrument Calibration tab to calibrated devices. 

  
Figure 5-20. Meter – Instrument Calibration (FloBoss 100-Series) 

Select the Dead Weight Calibration option (FloBoss 100-Series). If a deadweight tester is used to 
calibrate the Differential Pressure or the Static Pressure, select the respective Yes option. Enter the 
Calibrated Grav. Accel. value.  

Select the Mercury Manometer Instrument Used option (FloBoss 103). If a mercury manometer is 
used, select the Yes option.  

Enter the Ambient Hg Temp option (FloBoss 103). If the Ambient or Calibrated temperature of the 
mercury is different from the indicated values, enter the correct values. The default is 60 degrees 
Fahrenheit or 60 degrees Celsius. 

Enter the Calibrated Hg Temp option (FloBoss 103). If the Ambient or Calibrated temperature of the 
mercury is different from the indicated values, enter the correct values. The default is 60 degrees 
Fahrenheit or 60 degrees Celsius. 

Select the Water Manometer Calibration option (FloBoss 103). If a water manometer is used to 
calibrate the differential pressure (Diff Press), select the Yes option.  

Enter the Calibrated H2O Temp option (FloBoss 103). If the calibrated temperature of the water is 
different from the indicated values, enter the correct values. The default is 60 degrees Fahrenheit or 60 
degrees Celsius. 
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Enter the Calibrated Air Temp option (FloBoss 103). If the calibrated temperature of the air is 
different from the indicated values, enter the correct values. The default is 60 degrees Fahrenheit or 60 
degrees Celsius. 

Enter the User Correction Factor value that is multiplied by the base volume flow equation, allowing 
you to make any desired adjustment to the flow. If you use the default value of 1, no correction is 
applied. 

5.3.7 Meter – Calibration Factors (ROC800-Series) 
The Calibration Factors tab displays a dialog box containing a number of instrument-specific parameters 
that can affect calibration of the meter inputs.  

Selecting the Meter > Setup Orifice or Turbine > Calibration Factors tab (ROC800-Series) displays a 
dialog box containing a number of instrument-specific parameters that can affect calibration of the meter 
inputs. The options allow you to set calibration parameters for the Analog Inputs for this flow 
calculation. 

 
Figure 5-21. Meter – Calibration Factors (Orifice – ROC800-Series) 

Select whether or not to correct for local gravity effect on deadweight calibration for Static Pressure 
and/or Differential Pressure. The factor Fpwl is multiplied by the base volume flow equation once for 
each selection. 
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The factor Fpwl is used to correct for the effect of local gravity on the weights of a deadweight 
calibrator. The calibrator weights are usually sized for use at a standard gravitational force or at some 
specified gravitational force. A correction factor must then be applied to correct the calibrations to the 
local gravitational force. When a deadweight calibrator is used for the differential pressure and the static 
pressure, both must be corrected for local gravity. This involves using Fpwl twice. 

Enter the Calibrated Grav. Accel. (Calibrated Gravitational Acceleration) used to calibrate the weights 
of the deadweight tester being used. The units assumed for the input are Ft/Sec2 or m/Sec2. 

Enter the User Correction Factor value that is multiplied by the base volume flow equation, allowing 
you to make any desired adjustment to the flow. If you use the default value of 1, no correction is 
applied. 

5.3.8 Meter – Alarms  
The Alarms tab allows you to configure Station-wide alarming parameters. 

For the ROC800-Series, Alarming is Enabled or Disabled for each meter in the Meter > Setup > Orifice 
or Turbine > Alarms tab. Enabled Alarms can be based on either the Corrected Volume Flow Rate per 
Day, the Corrected Volume Flow Rater per Hour, the Mass Flow Rate per Day, or the Mass Flow Rate 
per Hour. 

Meter > Setup or click on the meter in the Configuration Tree, for FloBoss 100-Series, ROC300-Series, 
and FloBoss 407 units. 

   
Figure 5-22. Meter – Alarms (ROC800-Series) 
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Figure 5-23. Meter – Alarms (FloBoss 100-Series, FloBoss 407, ROC300-Series) 

You can either enable or disable alarming for each meter run or Station in a ROC800-Series. Alarms can 
be configured for the individual Meter Runs and/or the Stations, generating meter-specific and/or 
Station-wide alarm conditions.  

If you enable alarms, the alarms can be configured using the Alarms tab and are logged to the Alarm 
Log. To conserve log space, alarms should be enabled only when necessary. If you disable alarms, no 
alarm generates for this point, regardless of the Alarm configuration. Alarm conditions display in the 
Active Alarms fields located in the Meter Setup General tab or the ROC800-Series Station 
Configuration General tab. 

Even if you do not plan to use all the alarms, check and adjust the value of each one so that no false 
alarms generate. 

For a ROC800-Series, select the Alarming option: 
♦ Disabled – No alarms occur for this Station. 
♦ Alarm on Volume / Day – Alarm values occur based on volume per day. 
♦ Alarm on Mass / Day – Alarm values occur based on mass per day. 
♦ Alarm on Volume / Hour – Alarm values occur based on volume per hour. 
♦ Alarm on Mass / Hour – Alarm values occur based on mass per hour. 
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For the ROC800-Series, Alarming is Enabled or Disabled for each meter in the Meter > Setup > Orifice 
or Turbine > Alarms tab. Enabled Alarms can be based on either the Corrected Volume Flow Rate per 
Day, the Corrected Volume Flow Rater per Hour, the Mass Flow Rate per Day, or the Mass Flow Rate 
per Hour. 

For the FloBoss 100-Series, ROC300-Series, or FloBoss 407, Alarming is Enabled or Disabled in the 
Meter > Setup > General tab. 

Enter the High Alarm limit value, in engineering units, to which the calculated Flow Rate value must 
rise to generate a High Alarm. For the ROC300-Series, FloBoss 100-Series or FloBoss 407, units 
assumed for the input are MCF per day (1000 ft3/day) or cubic meters per day (m3/day). For a ROC800-
Series, the units are depended upon the alarm selected.  

Enter the Low Alarm limit value, in engineering units, to which the calculated Flow Rate value must 
fall to generate a Low Alarm. For the ROC300-Series, FloBoss 100-Series or FloBoss 407, units 
assumed for the input are MCF per day (1000 ft3/day) or cubic meters per day (m3/day). For a ROC800-
Series, the units are depended upon the alarm selected.  

For a ROC800-Series, the Low Alarm and High Alarm units are depended upon the alarm selected.  

Units US Metric 

Vol/Day MCF/Day km3/Day 
Vol/Hour Ft3/Hr m3/Hr 
Mass/Day Mlb/Day Tones/Day 
Mass/Hour Lb/Hr Kg/Hr 

Alarm Deadband (ROC800-Series) is the value, in engineering units, that is an inactive zone above the 
Low Alarm limits and below the High Alarm limits. The purpose of the Alarm Deadband is to prevent 
the alarm from being set and cleared continuously when the input value is oscillating around the alarm 
limit. This also prevents the Alarm Log from being over-filled with data. 

The Alarm Deadband Time (ROC800-Series) is the amount of time, in seconds, that is an inactive 
zone before and after the sensor alarm is triggered. The purpose of the Alarm Deadband Time is to 
prevent the alarm from being set and cleared continuously when the input value is oscillating around the 
alarm limit. This also prevents the Alarm Log from being over-filled with data. 

Select the SRBX Alarming or RBX Alarming option to configure Spontaneous-Report-by-Exception 
(SRBX or RBX) alarming for this point.  

♦ Disabled – The RBX Alarming is turned OFF. 
♦ On Alarm Set – When the point enters an alarm condition, the ROC or FloBoss generates a 

Spontaneous-Report-by-Exception message to the host.  
♦ On Alarm Clear – When the point leaves an alarm condition, the ROC or FloBoss generates a 

Spontaneous-Report-by-Exception message to the host. 
♦ On Alarm Set and Clear (FloBoss 100-Series, ROC300-Series, and FloBoss 407) – In either 

condition, an RBX message generates to the host.  
� Note: SRBX Alarming requires the ROC > Comm Ports > RBX or SRBX to be properly 

configured. 
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5.3.9 Meter – Mass Meter Pressure Effect (ROC800-Series) 
If the Turbine Meter Input Type on the General tab was configured to Mass, the Mass Meter Press 
Effect tab appears.  

Meter > Setup > Orifice Meter or Turbine Meter or click on the meter in the Configuration Tree, for a 
ROC800-Series device. 

  
Figure 5-24. Meter – Mass Meter Pressure Effect (Turbine – ROC800-Series) 

Enable Mass Pressure Compensation when the mass input requires compensation for pressure effect 
on the Coriolis tube. If enabled, enter a pressure correction Coefficient in percent per PSI. This value is 
supplied by the manufacturer of the mass meter. 

The pressure of the mass meter as calibrated in PSI. 
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SECTION 6 – CONFIGURING AND VIEWING HISTORY 

This section describes the history databases in the ROC and FloBoss flow computers. It also describes 
the history collection configuration process for the ROC and FloBoss units and associated reports. 

In this Chapter 
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6.1 History............................................................................................................................................. 6-1 
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6.1 History 
The Configure > History Points option allows you to setup the History Points for any numeric 
Parameter in the ROC or FloBoss to archive and to select which archiving method to use for each 
Parameter.  

The Meter > History (ROC300-Series and FloBoss 407) option allows you to setup History Points for 
meter Parameters. 

For the ROC300-Series, FloBoss 100-Series, and FloBoss 407, 35 days of hourly and daily data are 
stored for each point. For a ROC800-Series, you can configure the amount of storage.  

The historical database can be configured to log only the values that need to be logged. The values are 
logged in the standard (minute-hourly-periodic-daily) time base of the ROC or FloBoss, unless FST 
control is used. By using the FST Editor utility, the period at which the data is logged can be placed 
under FST program control. The ROC800-Series Periodic history can be configured for 1 to 6 minutes, 
10 minutes, 15 minutes, 30 minutes, or in 60-minute frequencies. 

The ROC and FloBoss maintains several types of historical databases: 
♦ Minimum/Maximum (Min/Max) Database. 
♦ Minute Database. 
♦ Periodic Database (ROC800-Series). 
♦ Hourly Database. 
♦ Daily Database.  
♦ Extended History (FloBoss 100-Series). 

The Min/Max Database is for viewing only and cannot be saved to a disk file.  
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� Note: The time stamp used for standard logging of historical values reflects the time at the end 
of the period, not at the beginning. For example, data collected from 8:00 to 9:00 is time-
stamped 9:00. 

History values can be collected from the ROC or FloBoss via ROCLINK 800 or other third-party host 
systems. From the View > History selection the user can view history directly from the device or from a 
previously saved disk file. 

FloBoss 100-Series, ROC300-Series, and FloBoss 407 units have several History Points that are pre-
configured (defaults). In the ROC300-Series, and FloBoss 407, these may be changed by the user to suit 
the application. 

For ROC800-Series, the required History Points for AGA3 and AGA7 calculation methods are not pre-
configured. You should begin the configuration of an AGA calculated Meter Run by configuring those 
points. Make sure that the History Points for each Meter Run are configured to allow the EFM Report 
utility to properly access data. Refer to Configuring History for EFM Reporting. 

� Note: In the ROC300-Series and FloBoss 407, History Points configured in the Meter > History 
screen overwrite History Points configured in Configure > History Point screen. 

Several options are available for the type of history values archived (Archive Type). Linear averaging is 
available for all Parameters. Meter run and Station Parameters may be averaged using one of the four 
averaging techniques recommended in API Section 21.1 (flow dependent linear, flow dependent 
formulaic, flow weighted linear, and flow weighted formulaic). Parameters that represent a rate 
(engineering units/time period) may be accumulated (integrated) to give total values when the time 
period of the rate is specified. Parameters that represent an accumulated total can be totalized to give 
total values by taking the difference between the value at the end of the current logging period and the 
value at the end of the previous logging period. Finally, the current value of any Parameter can be 
logged at the end of each logging period. 

� Note: In previous products, the totalize Archive Type was intended to be used for Parameters 
that return to zero at contract hour. In the ROC800-Series, the Totalize Archive Type is intended 
to be used for Parameters that represent on-going accumulators. 
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6.2 History Setup (FloBoss 100-Series) 
Select Configure > History Points. History is saved to two databases: Standard and Extended History. 
Historical Configuration for the FloBoss 100-Series units occurs on three tabs: Setup, Standard History, 
and Extended History. The number of entries/logs available to Standard and Extended History is 
configurable within boundaries. The first eight Standard History Points are pre-configured. Refer to 
Figure 6-1. 

 
Figure 6-1. History Memory (FloBoss 100-Series) 

Standard History 
The first eight Standard History Points are pre-configured. This is the minimum number of Standard 
History Points. The maximum number of Standard History Points is 35. The default number of Standard 
History Points is 35. Refer to Figure 6-1. 

The Standard History database logs entries for each point at three intervals: minute, hour, day. Every 
day at the contract hour, a min/max entry is also logged. 

 
Figure 6-2. History Setup – Standard History (FloBoss 100-Series) 
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Extended History 
The minimum number of Extended History Points is 0. The maximum number of Extended History 
Points is 15. The default number of Extended History Points is 4. The default interval for Extended 
History is 10 minutes. Refer to Figure 6-1. 

The Extended History database creates 1 entry for each point at the user-specified interval. The intervals 
are 1, 2, 3, 4, 5, 10, 12, 15, 20, 30, and 60 minutes. All the points in the Extended History will be logged 
at the same interval.  

 
Figure 6-3. History Setup – Extended History (FloBoss 100-Series) 
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6.2.1 Configuring FloBoss 100-Series History 
Select Configure > History Points. History is saved to two databases: Standard and Extended History. 
Historical Configuration for the FloBoss 100-Series units occurs on three tabs: Setup, Standard History, 
and Extended History. The number of entries/logs available to Standard and Extended History is 
configurable within boundaries.  

1. Verify that you are on-line with the FloBoss 100-Series unit. 

2. Select Configure > History Points > Setup tab.  

 
Figure 6-4. History Setup – Points Setup (FloBoss 100-Series) 

3. Enter the number of Standard History Points required.  

� Note: Be sure to specify enough points in history to accommodate your present application 
and any foreseeable changes. Changing the number of points later will cause a Cold Start & 
Clear History function. If you must change the number of points later, make a back-up of the 
history log before making changes. 

4. Enter the number of Extended History Points needed. The Note above also applies to this step. 

� Note: The Extended History has a maximum number of 5040 entries per point. The total is 
divided by the Extended History Points. 

5. Enter the Sample Interval for the Extended History Points.  

� Note: The Sample Interval drop-down list box for Extended History Points permits various 
rates of historical sampling. The more frequent the samples, the smaller the number of days.  

� Note: If replacing a chart recorder, select a 10 minute interval for 4 points. 
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6. Determine whether the Number of Days are adequate for your application. If not, adjust the 
Extended History Number of Points and Sample Interval. 

7. Enter the Sample Interval for the Extended History Points.  

� Note: The Sample Interval drop-down list box permits various rates of historical sampling. 
The more frequent the samples, the smaller the number of days.  

8. Click the Standard History tab, select Archive Types, and assign Archive Points, if you are 
configuring more than the eight pre-configured points.  

9. Click Apply. Changes in Standard History cause ROCLINK 800 to prompt to save changes. This 
saves the changes to Flash Memory. Saving at this point is recommended. 

10. Click the Extended History tab, select Archive Types, and assign Archive Points.  

11. Click the Apply button. 

6.3 History Setup (ROC300-Series and FloBoss 407) 
For the ROC300-Series and FloBoss 407, configure Meter > History and then Configure > History 
Points.  

Meter History – Use Meter History (Meter > History) to associate History Points with a Meter Run 
(meter inputs or flow rates).  

Standard History – History Points not associated with a specific Meter Run (input voltage or MPU 
loading) should be defined in Standard History (Configure > History Points).  

Meter History and Standard History share a common database. The ROC300-Series has 87 Historical 
Points and the FloBoss 407 has 50 Historical Points. A History Point cannot be defined in both Meter 
History and Standard History. 

� Note: History Points configured in the Meter > History screen overwrite History Points 
configured in the Configure > History Point screen. 

Use the screens to setup the History Points by selecting which Parameters in the ROC or FloBoss to 
archive and which archiving method to use for each Parameter. In Meter History, each meter run can 
have up to ten History Points configured for a FloBoss 407 and up to sixteen History Points can be 
configured for a ROC300-Series. 

� Note: The first eight (Orifice) or six (Turbine) History Points or the first flow run are pre-
configured with the default values used in EFM Reporting. Do not change these values except 
for the Averaging Type or Accumulation Basis or your EFM Reporting may not be complete.  

The historical database can be configured to log only the required values. The values are logged in the 
standard (minute, hourly / periodic, daily) time base of the FloBoss or ROC, unless FST control is used. 
By using the FST Editor utility, the period in which the data is logged can be placed under FST program 
control. 

� Note: Make sure that the History Points for each Meter Run are configured to allow the EFM 
Report utility to properly access data. 
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Figure 6-5. Meter > History Setup (FloBoss 407 and ROC300-Series – Meter) 

 
Figure 6-6. Configure > History Points (FloBoss 407 and ROC300-Series – Standard) 
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6.4 Configuring History Segments (ROC800-Series) 
Select Configure > History Segments. The number of History Points available in each Segment 
(ROC800-Series) is determined by the History Segment Configuration screen. Once the History 
Segment has been configured, you may configure the History Points in each Segment. 

For the ROC800-Series, History Points can be distributed among History Segments 1 through 10 and the 
General History Segment. For each History Segment, you can configure the number of periodic history 
values archived, the frequency of archiving the periodic values, the number of daily values archived, and 
the contract hour. The number of minute values is fixed at 60. Additionally, you can enable or disable 
logging and force the logging of daily values on a per Segment basis.  

In History Segments 1 through 10, the number of points in the Segment is configurable. The maximum 
total number of points available for all History Points in all Segments is 200, but may be less depending 
on the number of periodic and daily values configured. The number of points in the general History 
Segment will be determined by the system, based on remaining memory. All History Points in a 
Segment share the same time stamps, with one time stamp allotted for each of the minute, periodic, and 
daily logs available in that Segment. 

The History Segments 1 through 10 can be tied to meter Stations by configuring the History Segment 
under Meter > Setup > Station. This allows the History Segment to inform the Station, when the 
contract hour has occurred so that the Station can maintain daily and monthly accumulations, and to 
retrieve the appropriate flow dependency and flow weighting factors. This also allows the Station to 
inform the History Segment that a configuration Parameter has changed, and therefore periodic values 
need to be logged, per API Section 21.1. 

The maximum number of 200 points is based on 60 minute values, 840 periodic values logged hourly 
(35 days x 24 hours per day) and 35 daily values for a total of 187,000 history values. Each Segment 
also has storage allotted for the time stamp values with a default of 935 time stamps per Segment (60 
minute times stamps + 840 periodic time stamps + 35 daily time stamps) x 11 Segments for a total of 10, 
285 time stamp values.  

The 197,285 Available Space shown on the ROCLINK 800 History Segment Configuration screen 
indicates the total of history and time stamp values.  

Space Allocated = (Number of Points + 1) x (Minute Entries + Periodic Entries + Daily Entries) 

The Configure > History Segments option allows you to setup the division of points among the History 
Segments 1 through 10 and the general History Segment. It also allows you to assign the number and 
frequency of periodic logs, the number of daily logs, and the contract hour for each Segment. In 
addition, you can enable or disable logging and force the logging of a daily value on a per Segment 
basis. 

Once the History Segment has been configured, you may configure the points in each Segment. 

� Note: In the ROC800-Series, the required points for AGA3 and AGA7 calculation methods are 
not pre-configured. You should begin the configuration of an AGA calculated Meter Run by 
configuring those points. Refer to Configuring History for EFM Reporting. 
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Figure 6-7. History Segment Configuration (ROC800-Series) 

Enter a Tag for each Segment that will identify the group of historical points that will be archived there. 

For Segments 1 through 10, enter the Number of Points (history) required in that Segment. 

Enter the desired number of Periodic Entries in the Periodic log. The Number of Entries (in the 
Periodic log) multiplied by the Periodic Sample Rate (listed in minutes) will give the number of minutes 
before the periodic log begins to write over itself. 

Enter the desired number of Daily Entries in the Daily log. 

Enter the Periodic Sample Rate (listed in minutes). This indicates how often a time-stamped value will 
be written to the periodic log. If this Segment is tied to a meter Station, an entry will also be written 
whenever a configuration change is made to a Station or meter that is part of that Station. All options for 
Periodic Sample Rates are evenly distributed into 60, and logging will be synchronized with the top of 
the hour. 

Enter the Contract Hour. At this time, the daily values are logged. If this Segment is tied to a meter 
Station, this will also be the contract hour for the Station and will be the time that daily and monthly (if 
it is the first of the month) accumulations will be reset. Additional entries will be made if the Force End 
of Day option is exercised for this Segment. 

For each Segment, an option is available to Enable Logging for all History Points in the Segment. De-
select the checkbox do disable logging. 

For each Segment, a Force End of Day option is available to force logging of entries in the daily log for 
all History Points in the Segment. 

The Minute Entries read-only field defines the number of entries in the minute log for this Segment. 
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The Space Allocated read-only field displays how many history and time stamp entries are currently 
allocated by this Segment. 

The Available Space read-only field displays the total number of history and time stamp entries 
possible. Factory default is 197,285. 

The Total Space Allocated read-only field displays the number of history and time stamp entries 
allocated to all the Segments. 

The Available Space to Allocate read-only field displays the number of entries unallocated. This 
number is the Available Space minus the Space Allocated. 

6.5 Configuring History Points 
The History options allow data values and calculated variables stored in the current value database to be 
copied and stored for up to a month in the historical database. The historical database can be configured 
to log only the values that need to be logged. The values are logged in the standard (minute, hourly / 
periodic, daily) time base of the FloBoss or ROC, unless FST control is used. By using the FST Editor 
utility, the period in which the data is logged can be placed under FST program control. 

� Note: Make sure that the History Points for each Meter Run are configured to allow the EFM 
Report utility to properly access data.  

 
Figure 6-8. Configure > History Points (FloBoss 100-Series) 
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Figure 6-9. Configure > History Points (FloBoss 407 and ROC300-Series) 

 
Figure 6-10. Configure > History Points (ROC800-Series) 
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Choose the Archive Type to specify how the logged value is calculated; included are some special 
purpose types for FST control. 

♦ Disabled – Point not configured. 
♦ Avg – Flow Dependant Linear – This is the default method for calculating the average for the 

flow input. It is the simplest and most commonly used method. This method discards samples 
when there is no measurable flow and performs a straightforward (linear) average of the 
remaining samples to compute the minute and hour values.  
For orifice or turbine meters with Analog Input values, no flow conditions are defined as the 
differential pressure meter input less than or equal to the Low Flow Cutoff.  

For turbine meters with a Pulse Input values, no flow conditions are defined as the no flow time 
elapsing without receiving a pulse. A linear average of all samples is performed if there is no 
flow during the logging period. 

� Note: In the FloBoss 100-Series, Flow Dependent and Flow Weighted Averaging 
Techniques are located in Meter > Setup > Inputs tab. The first eight History Points are 
archived appropriately and should not be changed or your EFM Reports will be inaccurate. 

� Note: The Average Flow Archive Types can be changed; however, the History Points cannot 
be changed. 

♦ Avg – Flow Dependant Formulaic – Like the Flow-Dependent Linear method, this method 
discards samples for periods when there is no flow. However, in calculating the average, this 
method typically takes the square root of each sample before averaging the samples together and 
then squares the result. This formulaic method typically produces a slightly lower value than the 
linear method. 

♦ Avg – Flow Weighted Linear – This method does not discard any samples. Instead, it “weights” 
each sample by multiplying it by a flow value (square root of the differential pressure measured 
during the sample period), and then performs a linear average by dividing the sum of the flow-
weighted sample by the sum of the flow values. This results in minute and hourly values that are 
more reflective of short periods of high flow. 

♦ Avg – Flow Weighted Formulaic – This method combines the flow-weighting action with the 
formulaic averaging technique, both of which were described previously. 

♦ Avg – Linear – One second samples are averaged to compute minute, periodic, and daily values.  
♦ Accumulate/Second – The one second samples of a per second rate value are summed over the 

logging interval to compute the archived value. This Archive Type should be selected when the 
History Point being archived is a rate in EUs / second. 

♦ Accumulate/Minute – The one second samples of a per minute rate value are converted to a per 
second rate and summed over the logging interval to compute the archived value. This Archive 
Type should be selected when the History Point being archived is a rate in EUs / minute. 

♦ Accumulate/Hour – The one second samples of a per hour rate value are converted to a per 
second rate and summed over the logging interval to compute the archived value. This Archive 
Type should be selected when the History Point being archived is a rate in EUs / hour. 

♦ Accumulate/Day – The one second samples of a per day rate value are converted to a per second 
rate and summed over the logging interval to compute the archived value. This Archive Type 
should be selected when the History Point being archived is a rate in EUs / day. 

♦ Current Value – A snapshot of the current sampled value is logged. 
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♦ Totalize – The difference between the current value at the end of the period and the current 
value at the last logging interval is logged.  

♦ FST Time – This Archive Type allocates space for the FST to write time-stamps to the periodic 
archive using the WTM command. The number of time-stamps that can be written is determined 
by the number of periodic entries in the Segment. The format of the value will be 
MM:DD:HH:MM or DD:HH:MM:SS. The FST determines which index in the periodic archive 
to write to independently of the current index for the Segment. 

♦ FST Data – This Archive Type allocates space for the FST to write values to the periodic 
archive using the WDB command. The number of values that can be written is determined by the 
number of periodic entries in the Segment. The FST determines, which index in the periodic 
archive to write to, independently of the current index for the Segment. 

♦ User Program Time – This Archive Type should only be used as instructed in the respective 
user program documentation. (ROC800-Series) 

♦ User Program Data – This Archive Type should only be used as instructed in the respective 
user program documentation. (ROC800-Series) 

For a FloBoss 407 or ROC300-Series, select the Meter History Point to reserve space for history 
archival. The ROC300-Series has 1 to 87 Historical Points and the FloBoss 407 has 1 to 50 Historical 
Points. A History Point cannot be defined in both Meter History (Meter > History) and Standard History 
(Configure > History). 

For a FloBoss 407 or ROC300-Series, select the Exponent used in formulaic averaging techniques. This 
value is set by the unit and is typically 0.5 for orifice applications and 1.0 for turbine applications. 

This displays the Point Tag for the Archive Point selected. 

You may enter a User Description (ROC800-Series) of the selected archive point for identification 
purposes. 

Current and Last Daily Value display the values for the Archive Point selected for a ROC800-Series. 

Specify the Archive Point. Click the TLP button to specify a Point Type, Logical Number, and 
Parameter to be archived. 

6.6 Configuring History for EFM Reporting 
ROCLINK 800 software has the ability to create an EFM (Electronic Flow Measurement) Report file 
that contains all the configuration, alarms, events, and history logs associated with the Stations and 
Meter Runs in the ROC or FloBoss device. This file then becomes the custody transfer audit trail. In 
order to collect the periodic and daily history logs required for the EFM Report file, a specific list of 
Station and Meter Run Parameters must be configured for historical archiving. The History Points must 
be configured for each Meter Run. The required Parameters to archive vary depending on the type of 
meter run (orifice or turbine).  

� Note: The first eight History Points are pre-configured (defaults) in the FloBoss 100-Series, 
FloBoss 407, and ROC300-Series with FlashPAC units for Meter Run #1 only. When using a 
FloBoss 407 and ROC300-Series, the History Points can be changed if required. A ROC300-
Series with a FlashPAC always defaults to AGA3. 

� Note: ROC800-Series units do not have any flow Parameters factory-configured into History 
Points. 
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For a ROC800-Series Station that has live inputs for gas quality data, the heating value, specific gravity, 
and the gas composition of any components that are being updated should be configured as History 
Points. The Archive Type should be any of the four meter averaging techniques: Flow Weighted Linear, 
Flow Weighted Formulaic, Flow Dependent Linear, or Flow Weighted Formulaic. For a ROC300-Series 
and FloBoss 407, additional gas chromatograph History Points can be configured for detailed EFM 
Reporting. Refer Table 6-1, Optional History Configuration per Meter Run, on page 6-14. 

For a ROC800-Series, all History Points for a Station and the Meter Runs that belong in that Station 
must reside in the same History Segment. The order or database number of these History Points is not 
critical; the EFM Reports utility will search for them.  

The following table shows how the History Points must be configured for each Meter Run, 
depending on whether it is AGA3 or AGA7 metered.  

Table 6-1. Optional History Configuration per Meter Run 
 

Description Parameter Description Parameter Description Parameter 

Specific Gravity SPGR C2H6 Ethane ETHANE C7H16 n-Heptane NHEPTA 
Heating Value GASHV C3H8 Propane PROPAN C8H18 n-Octane NOCTAN 
N2 Nitrogen NITROG C4H10 n-Butane NBUTAN C9H20 n-Nonane NNONAN 
CO2 Car. Diox CARBDI C4H10 i-Butane IBUTAN C10H22 n-Decane NDECAN 
H2S Hyd Sf HYDSUL C5H12 n-Pentane NPENTA O2 Oxygen OXYGEN 
H2O Water WATER C5H12 i-Pentane IPENTA CO Car Monoxide CARBMO 
He Helium HELIUM C6H14 n-Hexane NHEXAN H2 Hydrogen HYDROG 
CH4 Methane METHAN – – – – 
*All points in this table are for both AGA3 and AGA7, AGA Flow Parameters type, and Average Archive Type. 
 

Table 6-2. Orifice EFM History Point for ROC800-Series 
 

Archive Type Point Type Parameter Description 

Totalize ORFV (Orifice Meter Run 
Values) 

MINACC (Minutes 
Accumulated) Flowing Minutes 

Avg (Flow Dependent Linear) 

Avg (Flow Dependent Formulaic)  

Avg (Flow Weighted Linear)  

Avg (Flow Weighted Formulaic)  

ORF (Orifice Meter Run 
Configuration) CURDP (DP) Differential 

Pressure 

Avg (Flow Weighted Linear) 

Avg (Flow Weighted Formulaic)  

Avg (Flow Dependent Linear)  

Avg (Flow Dependent Formulaic)  

ORF (Orifice Meter Run 
Configuration) CURSP (SP) Static Pressure 

Avg (Flow Weighted Linear) 

Avg (Flow Weighted Formulaic)  

ORF (Orifice Meter Run 
Configuration) 

CURTMP (TMP) Temperature 
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Archive Type Point Type Parameter Description 

Avg (Flow Dependent Linear)  

Avg (Flow Dependent Formulaic)  

   

Avg (Flow Weighted Linear) 

Avg (Flow Weighted Formulaic)  

Avg (Flow Dependent Linear)  

Avg (Flow Dependent Formulaic)  

ORFV (Orifice Meter Run 
Values) 

HWPF (Pressure 
Extension) 

Pressure 
Extension 

Avg (Flow Weighted Linear) 

Avg (Flow Weighted Formulaic)  

Avg (Flow Dependent Linear)  

Avg (Flow Dependent Formulaic)  

ORFV (Orifice Meter Run 
Values) MULVAL (Multiplier Value) Multiplier Value 

Totalize ORFV (Orifice Meter Run 
Values) 

FLOACC (Flow 
Accumulated) Volume 

Totalize ORFV (Orifice Meter Run 
Values) 

ENGACC (Energy 
Accumulated) Energy 

� Note: For a ROC800-Series Orifice Meter Run, the following History Points must be 
configured for EFM Reports. For each of the eight Parameters listed, select one Archive 
Type and Point Type. 

Table 6-3. Turbine EFM History Points for ROC800-Series 
 

Archive Type Point Type Parameter Description 

Totalize TRBV (Turbine Meter 
Run Values) 

MINACC (Minutes 
Accumulated) Flowing Minutes 

Totalize TRBV (Turbine Meter 
Run Values) 

PULSETDY (Pulses 
Accumulated) Raw Pulses 

Avg (Flow Weighted Linear) 

Avg (Flow Weighted Formulaic)  

Avg (Flow Dependent Linear)  

Avg (Flow Dependent Formulaic)  

TRB (Turbine Meter 
Run Configuration) CURSP (SP) Static Pressure 

Avg (Flow Weighted Linear) 

Avg (Flow Weighted Formulaic)  

Avg (Flow Dependent Linear)  

Avg (Flow Dependent Formulaic)  

TRB (Turbine Meter 
Run Configuration) CURTMP(TMP) Temperature 

Avg (Flow Weighted Linear) 

Avg (Flow Weighted Formulaic)  

Avg (Flow Dependent Linear)  

Avg (Flow Dependent Formulaic)  

TRBV (Turbine Meter 
Run Values) MULTVAL (Multiplier Value) Multiplier Value 
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Archive Type Point Type Parameter Description 

Totalize TRBV (Turbine Meter 
Run Values) 

UNACC (Uncorrected 
Accumulated) 

Uncorrected 
Volume 

Totalize TRBV (Turbine Meter 
Run Values) FLOACC (Flow Accumulated) Volume 

Totalize TRBV (Turbine Meter 
Run Values) 

ENGACC (Energy 
Accumulated) Energy 

� Note: For a ROC800-Series Turbine Meter Run, the following History Points must be 
configured for EFM Reports. For each of the eight Parameters listed, select one Archive Type 
and Point Type. 

Table 6-4. EFM History Points for a FloBoss 100-Series, ROC300-Series, or FloBoss 407 
 

AGA3 AGA7 History Point Description Point Type1 Parameter Archive Type 

Yes Yes Minutes Today (Flowing Minutes) ERN MINTDY FlowMinAccum 
Yes No Meter Input (Differential Pressure) FLW CURDP Average 
Yes Yes Static Pressure FLW CURFP Average 
Yes Yes Temperature FLW CURTMP Average 
Yes Yes C Prime (C´) (IMV or BMV) FLW CPRIME Average 
Yes No hwPf (Pressure Extension) FLW HWPF Average 
Yes Yes Instantaneous Flow FLW FLOW Accumulate 
Yes Yes Instantaneous Energy FLW ENERGY Accumulate 
No Yes2 Accumulated Value (Raw Pulses) PIN ACCUM Totalize 
No Yes2 Today’s Total (Uncorrected Flow) PIN TDYTOT Totalize 

1. ERN stands for the Extra Run Parameters Point Type; FLW stands for the Flow Calculation Point Type; PIN 
stands for Pulse Input Point. 

2. For the FloBoss 407 and ROC300-Series, this point is set in Standard History (Configure > History). All 
others are set in the Meter History (Meter > History). 

3. For a FloBoss 100-Series, ROC300-Series, or FloBoss 407, the points indicated by a “Yes” are pre-
configured. The ROC300-Series and FloBoss 407 allow you to change the default history point to suit the 
application. 
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6.7 EFM Reports 
You can generate printed and on-screen reports of the configuration, alarms, events, and historical flow 
data for a meter point. EFM (Electronic Flow Measurement) Reports is used in conjunction with the 
AGA flow calculation capabilities of the ROC or FloBoss to display or print previously collected flow 
data. This flow data is contained in an EFM Report file, which includes the operational characteristics of 
all the configured Meter Runs. The operational characteristics consist of Configuration Parameters, 
History, Events, and Alarms associated with each measured Meter Run. 

� Note: In order for the EFM Reports utility to work, the historical database in the ROC or 
FloBoss must be configured so that certain flow calculation values can be retrieved from 
memory.  

6.7.1 Collecting ROC Data 
Select ROC > Collect Data to save various ROC and FloBoss data to disk files. Data includes: 

♦ Configuration data. 
♦ Hourly (Periodic) volume data. 
♦ Daily volume data. 
♦ Alarm Log data. 
♦ Event Log data. 

This screen may only be accessed when you are on-line with the already configured ROC from which 
you will be gathering data.  

Use the Save As field and Browse button to either accept the default File name or enter a new File name. 

 
Figure 6-11. Collect Device Data 

When you select EFM Report Data, the Collect Data function saves all the values for EFM Parameters. 
The file has the .efm extension. 

� Note: You can create an EFM Report from this data by selecting View > EFM Report. The file 
has the .EFM extension. 
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6.7.2 Displaying EFM Reports 
You can choose to view the report or print the report.  

1. Select View > EFM Reports. 

  
Figure 6-12. View EFM Report 

2. Navigate to the files that have the .EFM extension (created by using the Collect Data function). 
Select the desired file and click Open. 

3. Select the Meter Run from drop-down list box to select the Meter Run on which you desire to 
report. 

4. Enter the Start Date.  

5. Enter the End Date. These are the dates for the period of the report you desire to cover.  

� Note: Click the drop-down list arrow to view a calendar and select the report dates. 

6. Select the Report Sections on which you desire to report.  

7. Click Print Preview to see a copy of the report. 

� Note: Select Utilities > Convert EFM File to convert the data to PGAS, Coastal Flow, AGA 
or DET data formats. 
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6.7.3 Converting EFM Files  
Select Utilities > Convert EFM File to convert a EFM Report files (.EFM database file) to the report 
file format you select. ROCLINK 800 version 1.60 or greater supports batch conversion of EFM files to 
PGAS and Flow-Cal formats. 

1. Select Utilities > Convert EFM File. 

 
Figure 6-13. Convert EFM File 

2. Select a Device Type the ROC809 or ROC306/312/364, FB103/104/407/503/504 radio button. 

3. Select the Convert to format: PGAS, Flow-Cal, or AGA / DET. 
♦ .EVT, .ANA, .ARM, and .VOL are ROC800-Series device files available for PGAS (EMS 

Pipeline Services). 
♦ .CFX is the ROC800-Series device file available for Flow-Cal (Coastal Flow Measurement, 

Inc.).  
♦ .AGA are FloBoss 100-Series files and contain only the eight standard History Points for the 

Meter Run.  
♦ .DET are ROC300-Series and FloBoss 407 files are formatted to contain gas composition, 

specific gravity (relative density), and heating value averages. 

4. Click the Browse button next to the Select Efm File(s) to Convert field. 
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5. Navigate to the path where the EFM files are located.  

6. Select the EFM files you desire to convert. You can individually select files using the 
checkboxes or you can click Select All to select all of the EFM files in the folder. Click Deselect 
All to deselect all files in the folder. Click OK. 

 
Figure 6-14. Select EFM Files(s) to Convert 

An internal verification of each file is performed very if that file type is valid. If any of the files 
are invalid, a notification displays. Refer to Figure 6-15. 

7. Click OK. If this error message displays, the invalid files are automatically removed and display 
in the Log frame. Refer to Figure 6-16. 

 
Figure 6-15. Invalid EFM File Alert 
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8. Select the files from the Select Meter Runs(s) to Convert list that you desire to convert. You 
can individually select files using the checkboxes or you can click Select All to select all of the 
EFM files in the folder. Click Deselect All to deselect all files in the folder. Refer to Figure 6-16. 

 
Figure 6-16. EFM Files Select for Conversion and Invalid Files  
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10. Click the Browse button next to the Select Folder for Converted File(s) field, select the path 
where you desire the converted files to be stored, and click OK. 

 
Figure 6-17. Select Folder for Converted Files 

11. Select the Converted File Name(s) Prefix options to determine the converted file name format. 
Refer to Figure 6-16. 

♦ Use Station Address & Group – Includes the Station Address and Group in the file name. 
♦ Use Current Data & Time – Includes the current data and time in the file name. 

12. Select the Period Start Date and End Date to define the time frame for which the conversion of 
data is performed. The Start Date is automatically post dated thirty-five days prior to the end 
date. The End Date is defaults to the current date. You can manually enter a date or click the 
drop-down arrow box to display a calendar and make your date selections. Refer to Figure 6-16. 

13. Click Start Conversion. 

14. Click OK when the conversion is complete. 

� Note: If you click Cancel any time during the conversion, click OK to acknowledge that the 
conversion process has been canceled.  
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6.7.4 PGAS Conversions 
The PGAS exports the EFM file data to four files. The PGAS event file (.EVT) lists all of the events in 
the Event Log that are related in any way to a Meter Run. The exception is Gas Quality events that are 
included in the PGAS quality file (.ANA)  

6.7.4.1 PGAS Event Files (.EVT) 
# Column Name Data Type Description  
1 METER_ID char(16) Identification number for the measurement point in the 

field. This must be the tag id of the orifice or turbine 
point associated with the event. 

2 EVENT_DATE Datetime Date and time the event occurred in mm/dd/yyyy 
hh:mm:ss format. 

3 METER_CALC_COLUMN_NAME char(32) Actual column name within the METER_CALC table. 
This information is only required for events that are to 
trigger record insertion into the METER_CALC table. 

4 NEW_VALUE char(16) New value to be used in the METER_CALC record. 
This is the ASCII representation of the number. 

5 OLD_VALUE char(16) Old value to be used in the METER_CALC record. This 
is the ASCII representation of the number. The event 
name, new value, and old value appear in the 
Comment for the new METER_CALC record. 

6 PRIORITY_LEVEL U8 This represents the importance of the event:  
0 = Alarm will not affect volume calculations.  
1 = Alarm will affect volume calculations. 

This is redundant. If METER_CALC_COLUMN_NAME 
exists for the event, the PRIORITY_LEVEL will be a 1, 
if not, it will be a 0. 

7 DESCRIPTION varchar(64) Text description of the event. 
8 COMMENT varchar(100) Comment (optional) 
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6.7.4.2 Meter Related Events 
Meter related events include changes to Meter and Station Points, Parameters, and Calibration 
Verification events for points configured as inputs to meter points, changes to the number of active 
Stations, orifice, or turbine points, changes to the clock, system events, and Parameter change events for 
history points when the old or new point being archived is a Meter or Station point.  

Events such as Warm Starts, Cold Starts, system initializations, and clock changes duplicate for every 
Meter Run in the unit. Station Parameter change events duplicate for every Meter Run in that Station. 
Events used by the PGAS system to recalculate meter values are indicated by including a 
METER_CALC_COLUMN_NAME in the PGAS event record. The Point Types and Parameters map to 
PGAS METER_CALC events. 

Description METER_CALC_COLUMN_NAME Data 
Type Point Types Parameters 

Orifice Diameter ORIFICE_SIZE Float Orifice Config (113) 15 
Pipe Diameter TUBE_DIAMETER Float Orifice Config (113) 12 

Base Temperature TEMP_BASE Float Station (112) 14 
Base Pressure CONTRACT_PRES_BASE Float Station (112) 13 
Atm Pressure SITE_ATMOS_PRES Float Station (112) 16 

Orifice Material PLATE_MATERIAL U8 Orifice Config (113) 17 
Pipe Material TUBE_MATERIAL U8 Orifice Config (113) 14 
Tap Location STAT_TAP_LOCA U8 Orifice Config (113) 3 

Diff Press Span1 DIFF_HI_RANGE Float Orifice Config (113) 25 

Static Press Span2 STATIC_HI_RANGE Float Orifice Config (113) or 
Turbine Config (115) 27 or 15 

Temp 0% EU3 TEMP_LO_RANGE Float Orifice Config (113) or 
Turbine Config (115) 29 or 17 

Temp Span3 TEMP_HI_RANGE Float Orifice Config (113) or 
Turbine Config (115) 29 or 17 

1 The ROC Point Type and Parameter listed for this entry contains a 3-byte value that is the Point Type, Point Number, and 
Parameter to use for the differential pressure value. If the Point Type of the differential pressure input is MVS (108) or 
Analog Input (103), the differential pressure span will be the same Point Type and Point Number as the differential pressure 
value and (coincidentally) the Parameter will be 17 for both of these Point Types. If the Point Type is any other type, a span 
will not be available. 

2 The ROC Point Type and Parameter listed for this entry contains a 3-byte value that is the Point Type, Point Number, and 
Parameter to use for the static pressure value. If the Point Type of the static pressure input is MVS (108), the static pressure 
span will be the same Point Type and Point Number as the static pressure value and the Parameter will be 33. If the Point 
Type of the static pressure input is Analog Input (103), the static pressure span will be the same Point Type and Point 
Number as the static pressure value and the Parameter will be 17. If the Point Type is any other type, a span will not be 
available. 

3 The ROC Point Type and Parameter listed for this entry contains a 3-byte value that is the Point Type, Point Number, and 
Parameter to use for the temperature value. If the Point Type of the temperature input is MVS (108), Analog Input (103), or 
RTD (106), the temperature zero and span will be the same Point Type and Point Number as the temperature value and the 
Parameters will be as follows: 

Point 
Type 

Zero 
Parameter 

Span 
Parameter 

MVS (108) 44 48 
AIN (103) 13 17 
RTD (106) 9 13 
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6.7.4.3 PGAS Alarm Files (.ARM) 
All alarms in the Alarm Log that are related in anyway to a Meter Run are included in the PGAS .ARM 
file. These alarms include High, Low, and No Flow alarms for Meter Run and Station Flows, Low, Low 
Low, High, High High, Rate, Manual Mode, and Point Fail alarms for points configured as inputs to 
meter points, including communication alarms for an MVS points configured as inputs to a meter point. 
Station alarms duplicate for each Meter included in the Station. 

# Column Name Data Type Description  
1 METER_ID char(16) Identification number for the measurement point in the field. Tag of 

the orifice or turbine point associated with the alarm. 
2 ALARM_DATE datetime Date and time the alarm occurred in mm/dd/yyyy hh:mm:ss format. 
3 PRIORITY_LEVEL U8 This represents the importance of the event:  

0 = Alarm will not affect volume calculations.  
1 = Alarm will affect volume calculations.  

4 ALARM_TEXT varchar(64) Text description of the alarm.  
5 TRIGGER_VALUE char(16) Value that triggered the alarm. 
6 ALARM_VALUE  char(16) Alarm Value. 

 

6.7.4.4 PGAS Gas Quality Files (.ANA) 
All Gas Quality data converts to an .ANA file. The Gas Quality data is retrieved from the ROC or 
FloBoss in the form of Parameter change events to the Gas Quality Parameters if the Gas Quality type 
(Point Type 112, Parameter 24) is configured for entered values (0). The Event Log scans for Gas 
Quality events and any group of unique Gas Quality events that occur within a five minute period appear 
as one record. Use the date and time stamp for the latest event for the SAMPLE_DATE.  

The Gas Quality data is retrieved from the ROC or FloBoss in the form of hourly historical averages of 
the Gas Quality Parameters if the Gas Quality (Point Type 112, Parameter 24) is configured for live 
values (1).  

# Column Name Data Type Description  
1 METER_ID char(16) Identification number for the measurement point in the field. Tag of 

the orifice or turbine point associated with the alarm. 
2 SAMPLE_DATE datetime Actual date and time of the sample in mm/dd/yyyy hh:mm format and 

is the date and time of the event excluding the seconds. 
3 EFFECTIVE_DATE datetime Optional date and time for which the sample should be considered 

“effective” in mm/dd/yyyy hh:mm format. Not used for the Gas Quality 
events. 

4 GAS_SAMPLE_TYP
E 

char(2) Sample Type:  
CO = Continuous if the Gas Quality type in the ROC (Point Type 112, 

Parameter 24) is equal to 1 for live Gas Quality values.  
SP = Spot if the Gas Quality type is equal to 0 for entered Gas 

Quality values.  
5 SAMPLE_ID char(2) Not used by PGAS or ROC (informational only). 
6 METHANE_MOL float ROC Point Type 112 (Station), Parameter 28 
7 ETHANE_MOL float ROC Point Type 112 (Station), Parameter 29 
8 PROPANE_MOL float ROC Point Type 112 (Station), Parameter 30 
9 IBUTANE_MOL float ROC Point Type 112 (Station), Parameter 32 

10 NBUTANE_MOL float ROC Point Type 112 (Station), Parameter 31 
11 IPENTANE_MOL float ROC Point Type 112 (Station), Parameter 34 
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# Column Name Data Type Description  
12 NPENTANE_MOL float ROC Point Type 112 (Station), Parameter 33 
13 NHEXANE_MOL float ROC Point Type 112 (Station), Parameter 35 
14 NHEPTANE_MOL float ROC Point Type 112 (Station), Parameter 36 
15 NOCTANE_MOL float ROC Point Type 112 (Station), Parameter 37 
16 NNONANE_MOL float ROC Point Type 112 (Station), Parameter 38 
17 NDECANE_MOL float ROC Point Type 112 (Station), Parameter 39 
18 N2_MOL float ROC Point Type 112 (Station), Parameter 26 
19 CO2_MOL float ROC Point Type 112 (Station), Parameter 27 
20 H2O_MOL float ROC Point Type 112 (Station), Parameter 41 
21 H2S_MOL float ROC Point Type 112 (Station), Parameter 40 
22 H2_MOL float ROC Point Type 112 (Station), Parameter 45 
23 CO_MOL float ROC Point Type 112 (Station), Parameter 44 
24 O2_MOL float ROC Point Type 112 (Station), Parameter 43 
25 HE_MOL float ROC Point Type 112 (Station), Parameter 42 
26 AR_MOL float ROC Point Type 112 (Station), Parameter 62 
27 GRAVITY float ROC Point Type 112 (Station), Parameter 23 
28 SAMPLE_PRESSU

RE_BASE 
float Pressure base at which the BTU value was measured. This is left 

blank as the ROC does not have a Parameter for this. 
29 DRY_ENERGY_FA

CTOR 
float This field is for heating value (ROC Point Type 112, Parameter 22) if 

“Dry” (0) is selected for the Heating Value Basis (ROC Point Type 
112, Parameter 21). 

30 SAT_ENERGY_FAC
TOR 

float This field is for heating value (ROC Point Type 112, Parameter 22) if 
“Wet” (1) is selected for the Heating Value Basis (ROC Point Type 
112, Parameter 21). 

31 AS_DELIVERED_E
NERGY_FACTOR 

float This field is for heating value (ROC Point Type 112, Parameter 22) if 
“As Delivered” (2) is selected for the Heating Value Basis ROC Point 
Type 112, Parameter 21). 

32 
to 
53 

N/A N/A These fields are not used by the ROC and will be left blank. 

 

The PGAS system does not support Stations. All Gas Quality data is part of the Station point in the 
ROC, all .ANA files duplicate for each Meter Run in the Station, the only difference being the 
METER_IDs. 
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6.7.4.5 PGAS Volume Files (.VOL) 
The PGAS .VOL file contains the hourly volume data related to a Meter Run including the Meter Run 
ID, report information, general Meter Flow Parameters, and Calculated Factors. 

The Archive Type and TLP of the History Points expected for the hourly volume report display. 

History Configuration for Orifice Meter 
Description Archive Type Averaging / Rate Type Point Type Parameter 

Flowing Minutes Totalize (134) None (0) Orifice Values (114) Minutes Accumulated (28) 
Differential 
Pressure 

Average (128) Flow Dependent Linear 
(1) 

Orifice Configuration 
(113) 

DP (26) 

 Average (128) Flow Dependent 
Formulaic (2) 

Orifice Configuration 
(113) 

DP (26) 

 Average (128) Flow Weighted Linear (3) Orifice Configuration 
(113) 

DP (26) 

 Average (128) Flow Weighted Formulaic 
(4) 

Orifice Configuration 
(113) 

DP (26) 

Static Pressure Average (128) Flow Dependent Linear 
(1) 

Orifice Configuration 
(113) 

SP (28) 

 Average (128) Flow Dependent 
Formulaic (2) 

Orifice Configuration 
(113) 

SP (28) 

 Average (128) Flow Weighted Linear (3) Orifice Configuration 
(113) 

SP (28) 

 Average (128) Flow Weighted Formulaic 
(4) 

Orifice Configuration 
(113) 

SP (28) 

Temperature Average (128) Flow Dependent Linear 
(1) 

Orifice Configuration 
(113) 

TMP (30) 

 Average (128) Flow Dependent 
Formulaic (2) 

Orifice Configuration 
(113) 

TMP (30) 

 Average (128) Flow Weighted Linear (3) Orifice Configuration 
(113) 

TMP (30) 

 Average (128) Flow Weighted Formulaic 
(4) 

Orifice Configuration 
(113) 

TMP (30) 

Pressure 
Extension 

Average (128) Flow Dependent Linear 
(1) 

Orifice Values (114) Pressure Extension (4) 

 Average (128) Flow Dependent 
Formulaic (2) 

Orifice Values (114) Pressure Extension (4) 

 Average (128) Flow Weighted Linear (3) Orifice Values (114) Pressure Extension (4) 
 Average (128) Flow Weighted Formulaic 

(4) 
Orifice Values (114) Pressure Extension (4) 

C Prime Average (128) Flow Dependent Linear 
(1) 

Orifice Values (114) Multiplier Value (12) 

 Average (128) Flow Dependent 
Formulaic (2) 

Orifice Values (114) Multiplier Value (12) 

 Average (128) Flow Weighted Linear (3) Orifice Values (114) Multiplier Value (12) 
 Average (128) Flow Weighted Formulaic 

(4) 
Orifice Values (114) Multiplier Value (12) 
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History Configuration for Orifice Meter 
Description Archive Type Averaging / Rate Type Point Type Parameter 

Volume Totalize (134) None (0) Orifice Values (114) Flow Accumulated (23) 
 Accumulate 

(129) 
Per Day (13) Orifice Values (114) Flow Rate Per Day (0) 

 Accumulate 
(129) 

Per Hour (12) Orifice Values (114) Flow Rate Per Hour (2) 

Energy Totalize (134) None (0) Orifice Values (114) Energy Accumulated (33) 
 Accumulate 

(129) 
Per Day (13) Orifice Values (114) Energy Rate Per Day (1) 

 Accumulate 
(129) 

Per Hour (12) Orifice Values (114) Energy Rate Per Hour (3) 

 

History Configuration for Turbine Meter 
Description Archive Type Averaging / Rate Type Point Type Parameter 

Flowing Minutes Totalize (134) None (0) Turbine Values (116) Minutes Accumulated (21) 
Raw Pulses Totalize (134) None (0) Turbine Values (116) Pulses Accumulated (9) 
Static Pressure Average (128) Flow Dependent Linear 

(1) 
Turbine Configuration 
(113) 

SP (16) 

 Average (128) Flow Dependent 
Formulaic (2) 

Turbine Configuration 
(113) 

SP (16) 

 Average (128) Flow Weighted Linear 
(3) 

Turbine Configuration 
(113) 

SP (16) 

 Average (128) Flow Weighted 
Formulaic (4) 

Turbine Configuration 
(113) 

SP (16) 

Temperature Average (128) Flow Dependent Linear 
(1) 

Turbine Configuration 
(113) 

TMP (18) 

 Average (128) Flow Dependent 
Formulaic (2) 

Turbine Configuration 
(113) 

TMP (18) 

 Average (128) Flow Weighted Linear 
(3) 

Turbine Configuration 
(113) 

TMP (18) 

 Average (128) Flow Weighted 
Formulaic (4) 

Turbine Configuration 
(113) 

TMP (18) 

C Prime Average (128) Flow Dependent Linear 
(1) 

Turbine Values (114) Multiplier Value (12) 

 Average (128) Flow Dependent 
Formulaic (2) 

Turbine Values (114) Multiplier Value (12) 

 Average (128) Flow Weighted Linear 
(3) 

Turbine Values (114) Multiplier Value (12) 

 Average (128) Flow Weighted 
Formulaic (4) 

Turbine Values (114) Multiplier Value (12) 

Uncorrected 
Volume 

Totalize (134) None (0) Turbine Values (114) Uncorrected Accumulated 
(31) 

 Accumulate (129) Per Hour (12) Turbine Configuration 
(113) 

Uncorrected Flow Rate (14)

Volume Totalize (134) None (0) Turbine Values (114) Flow Accumulated (16) 
 Accumulate (129) Per Day (13) Turbine Values (114) Flow Rate Per Day (0) 
 Accumulate (129) Per Hour (12) Turbine Values (114) Flow Rate Per Hour (2) 
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History Configuration for Turbine Meter 
Description Archive Type Averaging / Rate Type Point Type Parameter 

Energy Totalize (134) None (0) Turbine Values (114) Energy Accumulated (26) 
 Accumulate (129) Per Day (13) Turbine Values (114) Energy Rate Per Day (1) 
 Accumulate (129) Per Hour (12) Turbine Values (114) Energy Rate Per Hour (3) 
 

The format of a PGAS volume file is:  

# Column Name Data Type Description 
1 METER_ID char(16) Identification number for the measurement point in the field. 

Tag of the orifice or turbine point associated with the alarm.
2 PRODUCATION_DATE_START datetime Start date and time of the record in mm/dd/yyyy hh:mm 

format. Since date and time stamps of ROC history are for 
the end of the record, this will be the date and time stamp 
of the previous record. 

3 PRODUCTION_DATE_END datetime Ending date and time of the record in mm/dd/yyyy hh:mm 
format. This will be the history date and time stamp from 
the ROC. 

4 FLOW_TIME_MINUTES float Hourly value for the meter run flow minutes.  
5 EFM_VOLUME float Hourly accumulation of volume for the meter run in MCF. 
6 EFM_ENERGY  float Hourly accumulation of energy for the meter run in MMBTU.

7 FLOW_EXTN float Hourly value for hwpf (Orifice only). 
8 DIFF_PRESS float Hourly average of differential pressure in Inches H2O 

(Orifice only). 
9 STAT_PRESS float Hourly average of static pressure in PSI. 

10 FLOW_TEMP float Hourly average of the flowing temperature in Deg F. 
11 ROTARY_CURR_UNCO_VOL float Hourly accumulation of uncorrected volume at flowing 

conditions in MCF (Turbine only). 
12 ROTARY_PREV_UNCO_VOL float N/A 
13 ROTARY_AVG_FREQ float Hourly accumulation of raw pulses (Turbine only). 
14 C_PRIME float Hourly average of the multiplier value (Orifice or Turbine). 
15 FA float N/A 
16 FB float N/A 
17 FG float N/A 
18 FPB float N/A 
19 FPM float N/A 
20 FPV float N/A 
21 FR float N/A 
22 FTB float N/A 
23 FTF float N/A 
24 Y float N/A 
25 F_MASS float N/A 
26 C_D_FT float N/A 
27 RHO_T_P float N/A 
28 RHO_B_GAS float N/A 
29 EFM_N2_MOL float N/A 
30 EFM_CO2_MOL float N/A 
31 EFM_GRAVITY float N/A 
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# Column Name Data Type Description 
32 EFM_ENERGY_FACTOR float N/A 
33 DP_MAN_OVR U8 N/A 
34 DP_LO_ALM U8 N/A 
35 DP_HI_ALM U8 N/A 
36 DP_TX_FAIL U8 N/A 
37 SP_MAN_OVR U8 N/A 
38 SP_LO_ALM U8 N/A 
39 SP_HI_ALM U8 N/A 
40 SP_TX_FAIL U8 N/A 
41 TEMP_MAN_OVR U8 N/A 
42 TEMP_LO_ALM U8 N/A 
43 TEMP_HI_ALM U8 N/A 
44 TEMP_TX_FAIL U8 N/A 
45 VOL_MAN_OVR U8 N/A 
46 VOL_LO_ALM U8 N/A 
47 VOL_HI_ALM U8 N/A 
48 VOL_TX_FAIL U8 N/A 
49 N/A float N/A 
50 N/A float N/A 
51 COMMENT char(100) N/A 
52 EFM_PRESSURE_BASE float N/A 
53 BACK_FLOW float N/A 
54 LITHIUM_ALARM_FLAG U8 N/A 
55 BATTERY_VOLTAGE U8 N/A 
56 AVG_METHANE float N/A 
57 AVG_ETHANE float N/A 
58 AVG_PROPANE float N/A 
59 AVG_H2O float N/A 
60 AVG_H2S float N/A 
61 AVG_H2 float N/A 
62 AVG_CO float N/A 
63 AVG_O2 float N/A 
64 AVG_IBUTANE float N/A 
65 AVG_NBUTANE float N/A 
66 AVG_IPENTANE float N/A 
67 AVG_NPENTANE float N/A 
68 AVG_NHEXANE float N/A 
69 AVG_NHEPTANE float N/A 
70 AVG_NOCTANE float N/A 
71 AVG_NNONANE float N/A 
72 AVG_NDECANE float N/A 
73 AVG_HELIUM float N/A 
74 AVG_ARGON float N/A 

 

� Note: For additional information on the PGAS and the .EVT, .ANA, .ARM, .VOL file formats, 
refer to the documentation provided with your PGAS and the web site www.pgas.com 
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6.7.5 Flow-Cal (.CFX) Conversions 
Selecting Flow-Cal performs conversion of EFM files to the Flow-Cal (Coastal Flow) .CFX format. For 
additional information on the Flow-Cal and the .CFX file format, refer to the documentation provided 
with your Flow-Cal product and the web site www.flowcal.com.  

6.8 History, Alarm, and Event Log Reports 
Use the View menu to display the History, Alarm, and Event Log Reports. 

6.8.1 Viewing the History Log 
Select View > History to display the Minute, Hourly (Periodic), and Daily History Log reports. History 
to be viewed can be retrieved either from the device, if ROCLINK 800 is currently connected to a 
device, or from a previously saved disk file.  

Once the History to View has been selected, the history log will be displayed. Perform one of the 
following: 

♦ Plot – Click the Plot button to view a graphical display of the report. Refer to Plot. 
♦ Select New – Return to the Select History Points screen and make a new selection.  
♦ Save – Save the history archives to a file. 
♦ Print Preview – Show a preview of what will be sent to the printer and allow printing of the 

history log. 
♦ Close – Close the screen. 

6.8.2 Viewing the Alarm Log 
Select View > Alarms to view the Alarm Logs. Alarms to be viewed can be retrieved either from the 
device, if ROCLINK 800 is currently connected to a ROC or FloBoss, or from a previously saved disk 
file.  

Once the alarms are displayed, the following options are available: 
♦ Save – Save the Alarm Log to a file. 
♦ Print Preview – Show a preview of what will be sent to the printer and allow printing of the 

Alarm Log. 
♦ Close – Close the screen. 

6.8.3 Viewing the Event Log 
Select View > Events to view the Event Logs. Events to be viewed can be retrieved either from the 
device (if ROCLINK 800 is currently connected to a ROC or FloBoss) or from a previously saved disk 
file.  

Once the events are displayed, the following options are available: 
♦ Save – Save the Event Log to a file. 
♦ Print Preview – Show a preview of what will be sent to the printer and allow printing of the 

Event Log. 
♦ Close – Close the screen. 
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6.8.4 Viewing Report Logs From the Device 
A report is generated based on your Search Criteria from the currently connected ROC or FloBoss 
device.  

1. Select View menu > History, Alarm, or Event > From Device.  

2. Select or de-select the History Points (History only). Deselect All and Select All allow you to 
mass select or deselect History Points. The Search Criteria selections change depending on the 
Frequency. 

3. Select the History Type frequency at which you desire to view the report. You can view Minute, 
Hourly (Hour or Periodic), Daily (Day), Minimum/Maximum, or Extended History (FloBoss 
100-Series) values. 

4. Click OK.  

  
Figure 6-18. History From Device Example (FloBoss 407) 
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Figure 6-19. Select History to View (ROC800-Series) 

6.8.5 Viewing Report Logs From a File 
A report is generated based on your Search Criteria from a disk file.  

1. Select View menu > History, Alarm, or Event Log > From File.  

2. Select the file and click Open.  

3. Perform one of the following: 

♦ Select New – Return to the Select History Points to be shown screen and perform a new 
search.  

♦ Invert – View the log in reverse order (default is newest to oldest). This changes the time 
order of the Alarm, or Event Log.  

♦ Plot – View a graphical display of the report. 
♦ Save – Save the report to a file. 
♦ Print Preview – Print the report. 
♦ Close – Close the screen. 
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6.8.6 Viewing the History Log Report Graphically (Plot) 
After selecting View > History > From ROC or From File, the history report displays. Click the Plot 
button to view a graphical display the first four points of the History Report. The plot chart displays 
each series of lines as connected points of data, based on the time the data was archived and the current 
value at that time. 

The Plot chart displays the type of history, device type, date, time, and the Operator ID name in the 
header. The left Y-axis displays the value and the bottom X axis displays the date and time the value 
was read. A legend at the bottom of the graph corresponds with the lines within the graph. 

Use the scroll bar to the left of the graph to change the Y-axis. 

Graphics zoom enlarges the selected area of a chart, while not necessarily showing the axes. 

Axis zoom changes the minimum and maximum data values to those selected and redraws only that data 
with the axes. 

To Scale the Chart: 
1. <Ctrl>, and press down both mouse buttons (or middle button on 3-button mouse). 

2. Move the mouse down to increase chart size, or move the mouse up to decrease chart size. 

To Move the Chart: 
1. Press <Shift>, and press down both mouse buttons (or the middle button on 3-button mouse). 

2. Move the mouse to change the positioning of the chart. 

To Graphics Zoom an Area of the Chart: 
1. Press <Ctrl>, and hold down left mouse button. 

2. Drag the mouse to select zoom area and release the mouse button. 

To Axis Zoom the Chart: 
1. <Shift>, and hold down left mouse button. 

2. Drag the mouse to select the zoom area and release the mouse button. 

To Reset Scale and Position: 
1. Press <r> to remove all effects. 
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6.9 Device Memory 
Select ROC > Memory. A display appears that allows you to specify the memory address as Segment, 
and Offset for FloBoss 407 and ROC300-Series units or as a single hexadecimal Address for FloBoss 
100-Series units. When you enter numbers within the valid ranges of memory location and use the 
Update button, the display updates to show the contents of 240 bytes of memory. The hexadecimal 
values are shown on the left and the ASCII character equivalents are shown on the right. 

Use the Prev Block and Next Block buttons to view the previous or next block (240 bytes) of memory. 
If you are viewing data that may be changing, click the Update button to refresh the screen with the 
most recent values from the FloBoss or ROC.  

Click Close to exit the Device Memory screen. 

  
Figure 6-20. Device Memory (ROC300-Series and FloBoss 407) 
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Figure 6-21. Device Memory (FloBoss 100-Series) 
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SECTION 7 – EXTENDED FUNCTIONS 

This section describes how to configure a ROC or FloBoss to perform extended functions: Softpoints, 
Opcodes, Samplers, Odorizers, PID, Radio Power Control, DS800 Development Suite programs, and 
User Programs. 

In this Chapter 
Section Page 
7.1 Soft Points....................................................................................................................................... 7-1 

7.2 Opcode Table .................................................................................................................................. 7-3 

7.3 Sampler/Odorizer (ROC800-Series)............................................................................................... 7-4 

7.4 Proportional, Integral, and Derivative (PID) .................................................................................. 7-5 

7.5 Radio Power Control..................................................................................................................... 7-18 

7.6 DS800 Development Suite Software (ROC800-Series) ............................................................... 7-21 

7.7 User Program Administrator......................................................................................................... 7-22 

7.8 User Data ...................................................................................................................................... 7-25 

7.1 Soft Points 
Select Configure > I/O > Soft Points. Softpoints are global storage areas for data that can be used by 
any ROC or FloBoss application. For example, a Softpoint may store the results of a specified 
calculation by an FST or store an intermediate result of a specified value acquired by an FST. Softpoints 
consist of a Tag identifier, one integer value, and twenty floating values. For the ROC800-Series, thirty-
two Softpoints provide storage for over 1200 variables.  

Softpoints consist of: 

ROC800-Series: 
♦ 1 tag (10 character string) 
♦ 20 floats (floating point values) 
♦ 2 longs (32-bit) 
♦ 10 shorts (16-bit) 
♦ 10 bytes (8-bit) 

FloBoss 100-Series, ROC300-Series, and FloBoss 407: 
♦ 1 tag (10 character string) 
♦ 20 floats (floating point values) 
♦ 1 Unassigned Integer (16-Bit) 
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Figure 7-1. Soft Points (FloBoss 100-Series, ROC300-Series, and FloBoss 407) 

 
Figure 7-2. Soft Points (ROC800-Series) 

1. Select the Softpoint you desire to configure or view.  

2. Enter the Tag as a 10-character identification name for the Softpoint. 

3. Enter Float or Data #1 to Data #20 parameters to provide storage for IEEE floating point 
values.  

4. Enter Long (ROC800-Series) parameters to provide storage for 32-bit unsigned integer values.  

5. Enter Short (ROC800-Series) parameters to provide storage for 16-bit unsigned integers.  

6. Enter Byte (ROC800-Series) parameters to provide storage for 8-bit unsigned values.  
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7. When finished, configuring all parameters click Apply. Save the Softpoint configuration to Flash 
memory, using the Flash Memory Save Configuration function in the ROC > Flags screen. 

The Integer Flag (FloBoss 100-Series, ROC300-Series, and FloBoss 407) is a 16-bit unsigned integer 
value used as a flag to denote the validity of the floating point data or as a counter. The value may be 
under the control of an FST or a User Program. 

7.2 Opcode Table 
Use the Opcode Table to group data being polled for more efficient communications. Parameters from 
different point types can be assigned to the Opcode Table data points, which can substantially reduce the 
number of polls from a host computer. 

� Note: Use of the term Opcode in this context does not refer to the operator identification codes 
in ROC and ROC Plus protocols. 

Select Configure > Opcode Table. 

 
Figure 7-3. Opcode Table Settings 

Select the Table No. for the Opcode screen. For the FloBoss 100-Series, four tables are available. For 
the FloBoss 407, eight tables are available. For the ROC800-Series, sixteen tables are available. 

The Version No. field attaches a version number to an Opcode table configuration. If the configuration 
of data points is changed, update the version number. The version number is a floating point number. 

Each Opcode Data point has a TLP box for mapping TLP values into the Opcode Table Data point. If a 
host computer asks for a specific Opcode Data point, the ROC or FloBoss returns the value that is 
referred by the mapped TLP.  
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7.3 Sampler/Odorizer (ROC800-Series) 
Use the Sampler/Odorizer to set up a Discrete Output (DO) channel of the ROC800-Series to send and 
control the timing and duration of a pulse output to another device, such as an odorizer (odor injector). It 
can also control a gas sampler.  

♦ For the ROC800-Series, select Configure > Control > Sampler/Odorizer. 
♦ For the FloBoss 100-Series, select Meter > Setup > Sampler tab.  

 
Figure 7-4. Sampler / Odorizer (ROC800-Series) 

Select the specific number of the Sampler or Odorizer (Sampler/Odorizer) to configure. This field will 
be grayed out, if the number of Sampler points on the ROC > Information screen is zero. (ROC800-
Series). 

If Mode is Enabled, the DO sends a signal when the specified flow conditions are met (ROC800-Series).  

Use the Input Rate Point TLP box to select an input point from which to get the rate (ROC800-Series).  

Input Rate Value displays the current value of the Input Rate Point selected. The unit of measure for 
the Input Rate Value and Unit Accumulation will be the same as the unit of the input point selected for 
Input Rate Point (ROC800-Series).  

The Time Basis determines the time base for which the Input Rate Point is integrated: every second, 
minute, hour, or day. (ROC800-Series) 

The Unit Accumulation field determines when an output pulse generates. The Input Rate Value is 
integrated over the Time Basis. When the total matches the Unit Accumulation value, a pulse is 
generated for the duration specified in the duration field (ROC800-Series).  

The Duration is how long (in seconds) the output pulse will be on. This is how long the DO stays ON. 
The DO is turned on for the amount of time set in the Duration field every time the Unit Accumulation 
value is exceeded (ROC800-Series). 

Use the Output Point TLP box to select which DO point is to be used (ROC800-Series). 
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7.4 Proportional, Integral, and Derivative (PID) 
Select Configure > Control > PID Loop. Closed-loop Proportional, Integral, and Derivative (PID) 
control is used to provide smooth and stable operation of the feedback control loops employing a 
regulating device, such as a control valve or a motor. The typical use for PID is to control a Process 
Variable to a Setpoint.  

� Note: To enable PIDs, select ROC > Information > Points. Enter the number of PIDs you desire 
in the Point PIDs Active field and click Apply. The maximum number of PID loops is sixteen 
for the ROC800-Series, one for the FloBoss 100-Series, four for the FloBoss 407, six for a 
ROC306/ROC312, and sixteen for a ROC364. 

In a given PID point, two separate PID loops are available: Primary and Override. In Primary Only 
mode, the Override Control loop is disabled, leaving only the Primary Control loop active.  

In Override Only mode (ROC800-Series), the Primary loop is disabled, leaving only the Override loop 
active.  

In Override Control mode (ROC800-Series and FloBoss 100-Series), both loops are active, and a change 
in output is selected based on either a low or high limit selection, as configured by you.  

In a FloBoss 407 and ROC300-Series, on the selected loop is active. The selected lop is determined by 
the switch parameter setting. Each of the maximum PID loops can have Override Control. 

Each active PID loop acquires the Process Variable input and calculates the change in output required to 
maintain its Setpoint. The change output of the selected loop is applied to the appropriate output. 

The PID control loop can use either one Analog Output or two Discrete Outputs to control the regulating 
device. If Discrete Output control is to be used, one DO will provide open/forward control and the other 
DO provides close/reverse control. 

If the Output Type is Analog, the selected change in output is added to the current value of the output. If 
the Output Type is Discrete, the change in output is sent to one of the two Discrete Outputs. The 
magnitude of the correction determines the amount of time that an output is energized. If the correction 
is positive, it is routed to the open/forward DO. If the correction is negative, it is sent to the close/reverse 
DO. 

To set up a PID loop, configure the input for the Process Variable. Then configure the one AO or the 
two DO points, each of which must be configured as TDO (Timed Duration Output) points. Then, select 
Configure > Control > PID to configure the parameters associated with PID Control Loops.  

1. To enable PIDs in a ROC or FloBoss, select ROC > Information > Points.  

2. Enter the number of PIDs you desire in the Point PIDs Active field. The maximum number of 
PID loops is sixteen for the ROC800-Series, one for the FloBoss 100-Series, four for the FloBoss 
407, six for a ROC306/ROC312, and sixteen for a ROC364. 

3. Click Apply.  

4. Select Configure > Control > PID Loop. 
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7.4.1 PID (ROC800-Series and FloBoss 100-Series) 
Select Configure > Control > PID Loop. In a given PID point, two separate PID loops are available: 
Primary and Override. In Primary Only mode, the Override Control loop is disabled, leaving only the 
Primary Control loop active.  

In Override Only mode(ROC800-Series), the primary loop is disabled, leaving only the override loop 
active.  

In Override Control mode (ROC800-Series and FloBoss 100-Series), both loops are active, and a change 
in output is selected based on either a low or high limit selection, as configured by you. Each of the 
maximum PID loops can have Override Control (in which both primary and Override Control 
algorithms are active). 

The PID control loop can use either one Analog Output or two Discrete Outputs to control the regulating 
device. If Discrete Output control is to be used, one DO will provide open/forward control and the other 
DO provides close/reverse control. 

Each active PID loop acquires the Process Variable input and calculates the change in output required to 
maintain its Setpoint. If Override Control is enabled, the calculation result that is applied to the output 
depends upon whether the High or Low Override Type Select is chosen for a ROC800-Series or FloBoss 
100-Series.  

If the Output Type is Analog, the selected change in output is added to the current value of the output. If 
the Output Type is Discrete, the change in output is sent to one of the two Discrete Outputs. The 
magnitude of the correction determines the amount of time that an output is energized. If the correction 
is positive, it is routed to the open/forward DO. If the correction is negative, it is sent to the close/reverse 
DO. 

One application of Override PID control allows pressure control to override flow control when the 
pressure exceeds a Setpoint value. For example: The output of the primary flow control loop would be 
selected until the pressure input approaches the Override Setpoint of 700 psig. As the pressure input 
approaches its Setpoint, the pressure loop tries to close the valve and take over control at the point when 
the output calculated by the pressure loop is less than the output calculated by the flow loop. Control 
returns to the primary flow control loop, when the change in output required to maintain the override 
Setpoint no longer outweighs the flow loop’s attempts to maintain its Setpoint. 

Through the use of an FST, you may implement a switchover algorithm. When the input exceeds a 
predetermined switchover value, the FST can switch the mode to Override only. When the FST 
determines that the input value is no longer in a critical range, the PID mode can be switched back to 
Primary only. 
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Figure 7-5. PID Loop (ROC800-Series) 

1. To enable PIDs in a ROC or FloBoss, select ROC > Information > Points.  

2. Enter the number of PIDs you desire in the Point PIDs Active field.  

3. Click Apply.  

4. To set up a PID loop, configure the input for the Process Variable.  

5. Configure the one AO or the two DO points, each of which must be configured as TDO (Timed 
Duration Output) points. 

6. Select Configure > Control > PID to configure the parameters associated with PID Control 
Loops.  
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7.4.2 PID (ROC300-Series and FloBoss 407) 
Select Configure > Control > PID Loop. Closed-loop Proportional, Integral, and Derivative (PID) 
control is used to provide smooth and stable operation of the feedback control loops employing a 
regulating device, such as a control valve or a motor. The typical use for PID is to control a Process 
Variable to a Setpoint.  

In a given PID point, two separate PID loops are available: Primary and Override. In Primary Only 
mode, the Override Control loop is disabled, leaving only the Primary Control loop active.  

The ROC300-Series and FloBoss 407 units implement Override PID as a switchover algorithm. At any 
given point in time, only the selected loop (Primary or Override) is active. The loop selected is based on 
comparison of an input to a configured Switch Setpoint. Both the Primary and Override Control Loop 
have independent Switch Inputs, Switch Setpoints, Switch Modes, and Outputs. 

One application of Override PID Control allows pressure control to Override flow control when the 
pressure exceeds a Switch Setpoint.  

For example: The flow control loop is active until the pressure (Switch Input) exceeds the Switch 
Setpoint of 700 Psig. At that pint, the pressure control loop (Override Loop) becomes active and begins 
controlling the pressure to the Override Setpoint. 

Through the use of an FST, you can implement an Override algorithm by configuring flow and pressure 
control loops as two separate Primary Control Loops and writing the outputs to the Softpoints or FST 
Registers. The FST then manages the high / low selection. 

 
Figure 7-6. PID Loop (ROC300-Series) 
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1. To enable PIDs in a ROC or FloBoss, select ROC > Information > Points.  

2. Enter the number of PIDs you desire in the Point PIDs Active field.  

3. Click Apply.  

4. To set up a PID loop, configure the input for the Process Variable.  

5. Configure the one AO or the two DO points, each of which must be configured as TDO (Timed 
Duration Output) points. If Override Control is selected, Discrete Control will not be available. 

6. Select Configure > Control > PID to configure the parameters associated with PID Control 
Loops. 

7.4.3 PID – General  
Select Configure > Control > PID Loop. 

 
Figure 7-7. PID – General (ROC800-Series) 
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Select the PID control loop point to be configured.  

Enter a unique 10-character alphanumeric Tag for this PID point.  

Select the Control Type: 
♦ Primary Only – The Primary loop is the only loop active and the output calculated by the 

Primary loop is used to adjust the control output. 
♦ Override Only – (ROC800-Series) The Override loop is the only loop active and the output 

calculated by the Override loop is used to adjust the control output. This Control Type is used 
mainly for tuning the Override loop or when loop selection is controlled by an FST or other logic 
external to the PID algorithm. 

♦ Override Control – (ROC800-Series) Both the Primary and Override loops are active and the 
outputs from the two loops are compared and either the lesser or greater of the two outputs is 
used to adjust the control Output. 

Select the type of Output: 
♦ Analog – The PID output is written to the assigned Analog Output point EU value.  
♦ Discrete – The PID output is written to the assigned DO Open point EU value if the change in 

output is positive and is written to the assigned DO Close Point EU value if the change in output 
is negative. The Discrete Outputs must be configured as Timed Duration Outputs (DOUT). 

Set Scanning (FloBoss 100-Series, ROC300-Series, and FloBoss 407 units) to Enabled or Disabled to 
control the ON and OFF status for scanning the PID loop. If Off, no new output is calculated and no 
update is sent to the output point. 

Select the PID Mode: 
♦ Disabled – (ROC800-Series) No loops are active and the PID output parameter is not written to 

the assigned control output.  
♦ Manual – No loops are active and the PID output parameter is written to the assigned control 

output, allowing you to adjust the output as required.  
♦ Auto – PID loops are active as configured under Control Type. You enter the Setpoint of the 

loops. Any change in the calculated output is automatically sent to the configured output point. 
♦ Remote SP – (ROC800-Series) PID loops are active as configured under Control Type. The 

Setpoint of the loops are read from the Setpoint I/O Definition.  

Loop Status displays Primary or Override to indicate which loop is currently selected or disabled, if the 
loop is in Disabled or in Manual Mode. (ROC800-Series or FloBoss 100-Series) 

For a ROC300-Series or FloBoss 407: 
♦ 0 – Disabled. 
♦ 1 – Primary. 
♦ 2 – Override. 

Enter the Calc Time (ROC300-Series and FloBoss 407) to indicate the actual period of time (in 
seconds) between executions of the PID algorithm. This is the amount of time measured between 
executions from the beginning of one execution to the beginning of the next and should equal the value 
entered for the Loop Period on the Tuning screen when the unit is not overloaded. 
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Enter the Loop Period (ROC800-Series and FloBoss 100-Series) to set the period of time (in seconds) 
between executions of the PID algorithm. This is the amount of time between executions from the 
beginning of one execution to the beginning of the next. If Override Control is selected, both loops will 
be executed in this time period.  

The Actual Period (ROC800-Series and FloBoss 100-Series) read-only field displays the actual amount 
of time (in seconds) from the beginning of the last execution of the loop to the beginning of the current 
execution of the loop. 

Use the PID Loop Primary fields to setup the Primary PID Loop’s configuration. 
♦ For a ROC800-Series or FloBoss 100-Series, select an input or enter a Setpoint around which 

the Primary Process Variable is controlled.  
♦ For a ROC300-Series and FloBoss 407, enter a Setpoint around which the Primary Process 

Variable is controlled. 

Select the input point defined as the Process Variable for the Primary loop of the PID algorithm. 

The Value is used for comparison to the Setpoint.  

Select the Primary Switch PV (ROC300-Series and FloBoss 407) input point assigned for comparison 
with the Primary Variable. This value determines when switchover to the Override Control loop occurs. 

Enter a Switch to Override if: (ROC300-Series and FloBoss 407) Direction entered to be compared 
with the assigned input (Override Switch PV) to determine when switchover to the Primary Control loop 
occurs. The type of comparison is: (>) greater than or (<) less than. 

Use the PID Loop Override fields to setup the Override PID Loop’s configuration. 

♦ For a ROC800-Series or FloBoss 100-Series, select an input or enter a Setpoint around which 
the Override Process Variable is controlled.  

♦ For a ROC300-Series and FloBoss 407, enter a Setpoint around which the Override Process 
Variable is controlled. 

Select the input point defined as the Process Variable for the Override loop of the PID algorithm. 

The Process Variable is used for comparison to the Setpoint.  

Select the Override Primary PV (ROC300-Series and FloBoss 407) input point assigned for 
comparison with the Override Switch Setpoint. This value determines when switchover to the Primary 
Control loop occurs. 

Enter a Switch to Override if (ROC300-Series and FloBoss 407) as the direction the entered Switch to 
Primary Setpoint is to be compared with the assigned input (Override Switch PV) to determine when 
switchover to the Primary Control loop occurs. The type of comparison is (>) greater than or (<) less 
than. 
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Use the PID Loop’s Output fields to set the point and limits for the Analog Output or Discrete Output. 

♦ If Control Type is set to Analog, select the Output Point (ROC800-Series or FloBoss 100-
Series) to be assigned as the PID control output.  

♦ Enter an Output Low Limit (ROC800-Series or FloBoss 100-Series). If the change in output 
calculated by the loop causes the current value of the output to go below this value, the output is 
set to the value entered here. 

♦ Enter an Output High Limit (ROC800-Series or FloBoss 100-Series). If the change in output 
calculated by the loop causes the current value of the output to go above this value, the output is 
set to the value entered here. 

♦ Enter a Primary Output (FloBoss 407 or ROC300-Series). This is the output that will be 
assigned as the control output for the Primary Control loop of the PID algorithm. 

♦ Enter a Override Output (FloBoss 407 or ROC300-Series). This is the output that will be 
assigned as the control output for the Override Control loop of the PID algorithm. 

♦ If Control Type is set to Discrete, select the Discrete Output point (DO Open Point) to open the 
valve or other device and the Discrete Output point (DO Close Point) to close the valve or other 
device.  
� Note: These Discrete Output points must be configured as TDO (Time Duration Output) 

Discrete Output Mode. 
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7.4.4 PID – Tuning 
Select Configure > Control > PID Loop. 

 
Figure 7-8. PID Tuning (ROC800-Series) 
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Figure 7-9. PID Loop (ROC300-Series and FloBoss 407) 

For a FloBoss 407 or ROC300-Series, set the Loop Period time in seconds between execution of the 
PID algorithm. 

Enter the Proportional Gain as the ratio of the change in output to the change in the error (Process 
Variable – Setpoint). 

Enter the Reset (Integral Gain) as the ratio of the change in output to the change in the integral of the 
error (Process Variable – Setpoint) with respect to time. This value is in terms of repeats per minute. 

Enter the Rate (Derivative Gain) as the ratio of the change in output to the change in the error (Process 
Variable ÷ Setpoint) with respect to time. This value is in terms of minutes. 

Enter the Scale Factor number representing the ratio of the output span to input (Process Variable) 
span. The sign of the number specifies the action of the loop: negative for reverse action (the default), or 
positive for direct action. Reverse action causes the PID loop point to produce a “decrease” in output (to 
close a valve, for example) when the Process Variable exceeds the Setpoint. 

Enter the Integral Deadband as a “window” around the Setpoint. When the Process Variable is within 
this window, no change in output is calculated. For example, if you enter “5,” there is a region of 5 units 
above and 5 units below the Setpoint in which the Process Variable can move without affecting the 
output. 

Enter the SP Ramp Rate as the maximum rate at which the Setpoint is allowed to ramp to a new value. 
Maximum rate is in EU per minute where engineering units are the units of the Process Variable. 

For a ROC800-Series, enter the SP Low Limit as the lowest allowed value for the Setpoint.  

For a ROC800-Series, enter the SP High Limit as the highest allowed value for the Setpoint. 
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For a ROC800-Series, the Change in Output displays the calculated change in output from the 
associated loop. 

Select Manual Tracking Enabled to have the primary loop Setpoint set equal to the Primary Process 
Variable when the PID point is in Manual Mode. This is typically used to eliminate a “bump” when 
transferring back to the Automatic Mode. 

Select Halt PID On Reset Enabled to have the PID control loop mode set to disabled upon a reset of the 
ROC or FloBoss, such as a power restart or a Warm Start. 

For a FloBoss 407 and ROC300-Series, enter the Min Control Time as the minimum amount of time 
that the Primary or Override Control loop must maintain control before switching occurs back to the 
other control loop. 

For the ROC800-Series and FloBoss 100-Series, set the Override Type Select to Low or High 
(Override Control only). If Low Override Type is selected, the lesser of the primary change in output 
and the override change in output will be selected as the control output. If High Override Type is 
selected, the greater of the primary change in output and the override change in output will be selected 
as the control output. 



ROCLINK 800 User Manual 

Rev. Dec-05 Extended Functions 7-16 

7.4.5 PID – Status (ROC800-Series) 
Select Configure > Control > PID Loop. 

 
Figure 7-10. PID Loop Status (ROC800-Series)  

When a PID loop is enabled, the Output Low Limit Status field indicates whether the output of the 
primary PID loop has been clipped by the low output limit. Either Limited or Not Limited displays.  

When a PID loop is enabled, the Output High Limit Status field indicates whether the output of the 
primary PID loop has been clipped by the high output limit. Either Limited or Not Limited displays. 

When a PID loop has been enabled, the Primary PV Status field indicates the status of the primary 
loop’s Process Variable data. Either OK, Questionable Data, or Invalid TLP displays.  

The Primary SP Low Limit Status field indicates whether the Setpoint of the primary PID loop has 
been clipped by the low Setpoint limit. Either Limited or Not Limited displays.  

The Primary SP High Limit Status field indicates whether the Setpoint of the primary PID loop has 
been clipped by the high Setpoint limit. Either Limited or Not Limited displays.  
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The Primary SP Rate Limited Status field indicates whether the Setpoint of the primary PID loop is 
currently being limited by the maximum Setpoint change rate (SP Ramp Rate on Tuning tab). 

When a PID loop has been enabled, the Override PV Status field indicates the status of the override 
loop’s Process Variable data. Either OK, Questionable Data, or Invalid TLP displays.  

The Override SP Low Limit Status field indicates whether the Setpoint of the override PID loop has 
been clipped by the low Setpoint limit. Either Limited or Not Limited displays.  

The Override SP High Limit Status field indicates whether the Setpoint of the override PID loop has 
been clipped by the high Setpoint limit. Either Limited or Not Limited displays.  

The Override SP Rate Limited field indicates whether the Setpoint of the override PID loop is 
currently being limited by the maximum Setpoint change rate (SP Ramp Rate on Tuning tab). 

7.4.6 PID – Example 
Select Configure > Control > PID Loop. 

The following configuration example describes how to configure a PID point and associated inputs and 
outputs to implement flow control with pressure override to protect against over-pressuring the line. 

In this example, the Primary Process Variable (Primary PV) is obtained from an orifice Meter Run point, 
specifically, the volumetric flow rate per day. The Override Process Variable (Override PV) is obtained 
from the pressure value on an MVS point. Setpoints for both the primary and override loops are entered 
by you. A description is given for setting up either discrete or analog control for the control output. 

See MVS Sensor (ROC800-Series or FloBoss 407) for properly configuring the orifice Meter Run point 
and the MVS point. 

If the control valve is controlled by a 4 to 20 mA signal to an I/P converter, configure an Analog Output 
with the appropriate Low and High Reading EU (engineering units). The units can either be in terms of 
the valve position (0 to 100%) or in terms of flow capacity (0 to 1000 MCF/Day). Set the Output type on 
the PID screen to Analog. Under Output Point, select a TLP: Point Type of Analog Outputs, the desired 
Logical Number, and EU Value parameter. 

If the control valve is controlled by a motorized actuator on the valve, configure two Discrete Output 
points for the open and close contacts. Each of these Discrete Output points must be configured as TDO 
(time duration output) DOUT types. Set the Low Reading Time to the minimum amount of time (in 
seconds) the TDO can be energized to move the motor. Set the High Reading Time to the amount of 
time (in seconds) the TDO must be energized for full travel. Set the Low and High Reading EU values. 
The units can either be in terms of the valve position (0 to 100%) or in terms of flow capacity (0 to 1000 
MCF/Day). Set the Output type on the PID screen to Discrete. Under DO Open Point and DO Close 
Point, select a TLP: Point Type of Discrete Outputs, the desired logical number, and EU Value 
parameter. 

� Note: The FloBoss 407 and ROC300-Series cannot perform Override Control and Discrete 
Output Control at the same time. 
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Configure the PID point with a Control Type of Override Control. This causes available fields to appear 
on the PID screen to enter the I/O definition of the Process Variable and Setpoint for both the Primary 
and Override loops. Select a TLP: Point Type of “Orifice Meter Run Values”, the desired Logical 
Number, and a Parameter of “Flow Rate Per Day” for the Primary Process Variable. Select a TLP: Point 
Type of “MVS”, the desired Logical Number, and a Parameter of “SP Reading” for the Override Process 
Variable. The Setpoint I/O Definition (ROC800-Series only) remains undefined, because you enter the 
values. The Setpoint for the Primary loop will be the desired amount of flow per day. The Setpoint for 
the Override loop will be the pressure value where control should switch to the override loop. Set the 
Loop Period in seconds. This is typically set to one-fourth of the time required for the actuator to move 
the valve from fully open to fully closed.  

On the Tuning tab, select the Override Type Select of “Low”. This causes the lower of the change in 
outputs from the primary and secondary loops to be selected. As the pressure approaches the Override 
Setpoint, the pressure (Override) loop will pinch back the output. At the point that the pressure loop 
requests an output change less than the flow (primary) loop, the output from the pressure loop will be 
selected and control the valve. Set the Scale Factor for each of the Primary and Override loops as (span 
of output) / (span of input).  

Both loops have negative scale factors, in order to have the control action close the valve when the 
Process Variable is above the Setpoint. With the scale factor set per the above formula, the initial 
settings for gain, reset, and rate will, under most circumstances, produce stable control. The gain 
controls the magnitude of the initial change in output for a given change in the Process Variable (or 
Setpoint). The reset controls the magnitude of the change in output based on the continuing difference 
between the Process Variable and the Setpoint over time. Then these may be then adjusted to give the 
desired control actions. 

7.5 Radio Power Control 
Select Configure > Control > Radio Power Control to conserve battery power to a radio or any other 
communicating device.  

Radio power is controlled either by the DTR signal or by a Discrete Output. Because there are separate 
Radio Control points for COM1 and COM2, radio power cycling for COM1 can be configured 
differently from that for COM2, including independent timer values and separate output controls using 
the Output Definitions options.  

When using a FloBoss 100-Series, ROC300-Series, or FloBoss 407, two modes of Power Control are 
possible: Seconds and Minutes. In Seconds mode, the time base for the timers is in 0.1 second (1.0 
seconds for a FloBoss 100-Series) increments, primarily used with radios. In Minutes mode, the time 
base for the timers is in one-minute increments, primarily used with cellular telephones.  

For each Radio Power Control point, the power cycling can be configured to automatically change three 
times a day. During each of these three periods, called Zone 1, Zone 2, and Zone 3, the ON and OFF 
times can be set up to operate at various intervals to conserve battery power. The figure below is a 
graphical depiction of how the power control operates within each time “zone.” 
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Figure 7-11. Radio Power Control (ROC-800-Series) 

During the ON time: 
♦ The power output DO is switched to ON. DTR signal for the Comm Port is activated. 
♦ Communications may occur. 
♦ During the OFF time: 
♦ The power output DO is set to OFF. DTR signal for the Comm Port is in-activated. 
♦ Communications may not occur. 

If communications occur during the ON time, the ON time is extended by the Hold Time. The DO and 
DTR single remains ON and receive interrupts remain enabled for the duration of the Hold Time. 

� Note: The FloBoss 100-Series units use the Power on the terminal block using LOI Power (3.3 
volts) and COM2 Power (6.2 volts). 

When the Radio Power Control parameter is Enabled, radio power cycling is activated. The Low Battery 
Shutoff parameter allows power cycling to be automatically disabled whenever the input voltage to the 
ROC or FloBoss falls below the specified threshold. 

To use Radio Power Control, select Configure > Radio Power Control.  

After configuring the Radio Control points, click Apply. Save the configuration to programmable 
memory using the Flash Memory Save Configuration function in the ROC > Flags screen.  

Select the Radio Power Control point you desire to configure.  

Enter the Tag as a 10-character name to identify this point with its respective Comm Port. 

Set Radio Power Control to Enabled to activate the Radio Power Control function. 
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Use the Time Units to switch between Seconds and Minutes. In Seconds mode, the time base for the 
timers is in 0.1 second increments, primarily used with radios. In Minutes mode, the time base for the 
timers is in one-minute increments, primarily used with cellular telephones. 

Enter the Zone parameters to indicate when Radio Power Control is active and inactive for various 
Zones. 

Start Time in hours and minutes (HHMM) that the respective Zone begins. Time is expressed in local 
time, 24-hour clock. For example: “1500” under Zone 2 means that the associated On Time and Off 
Time are used beginning at 3:00 p.m. The Zone is active unit the start time for the next zone is 
encountered. 

On Time during a control cycle when the output is in the ON state. 

Off Time during a control cycle that the output is in the OFF state. 

� Note: The On Time and Off Time alternate throughout the period the zone is active. 

Enter the Hold Time that the output remains ON after detection of communications activity in Seconds 
or Minutes depending on the Time Units mode. This value applies to all Zones. When communications 
occur during the On Time, the On Time is extended by the Hold Time. The DTR signal and Discrete 
Output remain in the ON state. 

If a Spontaneous-Report-by-Exception (SRBX) message needs to be sent to the host computer, the radio 
power will be turned on for the Hold Time allowing the SRBX message to be transmitted. The Hold 
Time should be configured for a length of time long enough to allow the ROC or FloBoss to receive a 
response back from the host.  

Enter the Low Battery Deadband for the ROC800-Series. The Low Battery Deadband value is added to 
the Low Battery Shutoff to determines when the Radio Power Control function is enabled again and 
allows the DO to turn on when needed.  

Enter a Low Battery Shutoff value that specifies the voltage at which Power Control is automatically 
disabled. The voltage being sensed is the System AI Battery Input voltage (0 to 1 for the ROC800-Series 
and E2 for the FloBoss 100-Series). The Low Battery Shutoff parameter allows power cycling to be 
automatically disabled whenever the input voltage to the ROC or FloBoss falls below the specified 
threshold. The default value is 11 volts. 

Radio Power Control is automatically enabled again when the input voltage rises up to this value. 

Select which Discrete Output point used to power the radio. 

Not available for the FloBoss 100-Series. 

Select Inverted (Inverted / Normal) to define the action of Discrete Output value. Normal output is 
energized in On Time and Inverted output is energized in Off Time. 

Not available for the FloBoss 100-Series. 

The Power Timer counts down the amount of time (On Time, Off Time, or Hold Time) that the Radio 
Control is currently using. The value is the number of seconds or minutes remaining. 

The On Counter value indicates the cumulative time that the Power Control has been in the ON state in 
seconds or minutes.  

The Off Counter value indicates the cumulative time that the Power Control has been in the OFF state 
in seconds or minutes. 
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The Radio Power Status indicates the current status of the Power Control function of ON, OFF, or 
RBX. 

The Active Zone indicates which zone is currently activated for determining the Start Time, On Time, 
and Off Time. 

Some of the On Time is also used by the radio during power-up initialization of the receiver, causing 
part of the On Time to be unavailable for receiving requests.  

7.6 DS800 Development Suite Software (ROC800-Series) 
This screen provides parameters related to the DS800 application. It is good practice to check these 
settings prior to downloading a DS800 application. For more information on DS800 programs, refer to 
the DS800 Development Suite on-line help or the DS800 Development Suite User Manual. 

Select Configure > Control > DS800. 

 
Figure 7-12. DS800 Development Suite Software (ROC800-Series) 

The Points number is always set to 1, the number of DS800 programs allowed. 

The Mode enables the execution of all DS800 resources loaded into the ROC. 

Enable RSI Task if you will be communicating via serial communications for downloading and 
debugging DS800 applications. Distributed applications (multiple resource projects) are not supported 
over serial links.  

Enable TCP/IP Task if you will be communicating via Ethernet. 

The IXD Task parameter must be Enabled to download resources to a ROC. This would only be 
Disabled to save processor time, if there were NO bindings between resources using the HSD network. 

The Clear Resources button removes all downloaded resources from the ROC800-Series unit’s 
permanent storage. This, however, does not affect or stop a currently executing resource, because this 
resource is copied to RAM before it is started. The resources will be resident in RAM until a restart is 
performed or until a Warm Start occurs at the ROC800-Series, or the Mode radio button on the DS800 
window is set to Off. When the Mode radio button is set back to On or the ROC800-Series is restarted, 
only resources downloaded to the ROC after the Clear Resources button was pressed will attempt to 
start. 
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7.7 User Program Administrator 
The User Program Administrator allows you to download extended functions and applications to a ROC 
or FloBoss. Select Utilities > User Program Administrator. 

 
Figure 7-13. User Program Administrator (ROC800-Series) 
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Figure 7-14. User Program Administrator (FloBoss 100-Series)  
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Figure 7-15. User Program Administrator (FloBoss 407 and ROC300-Series) 

7.7.1 User Program Download Steps 
To download a User Program: 

1. Select Utilities > User Program Administrator.  

2. Determine the amount of memory available in Memory Usage (FloBoss 100-Series, ROC300-
Series, and FloBoss 407) or Device User Program Environment (ROC800-Series). The memory 
location must be available for the specific User Program that you are loading.  

3. When using a ROC800-Series, click Reset Counter to clear the value that indicates how many 
times the User Program has been restarted. 

4. Click Browse and select the User Program file to download from the CD-ROM or PC. User 
Program files are typically located in the Program Files folder. The Open File dialog displays the 
names of all the files that have the .tar (ROC800-Series), .bin (FloBoss 100-Series), or .H00 
(FloBoss 407 and ROC300-Series) extension.  

5. Select the File name you desire to load and click Open. 

6. Click Download & Start to download the selected User Program and automatically start the 
program. Click Download to download the User Program, but not start the program. 
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7. When using a FloBoss 100-Series, FloBoss 407, and ROC300-Series, select System > Flags. 
Click Flash Memory Save Configuration and click Yes. This ensures that the program 
automatically restarts after a Cold Start.  

8. Click OK.  

� Note: User Program information displays under the Configuration Tree. For the FloBoss 
units, User Program information also displays under select Configure > User Data. 

The Status field (in User Programs Installed in Device area) displays ON or OFF indicating the status of 
the User Program selected in the User Programs Installed in Device field. 

The Status field at the bottom of the screen displays the status of the Download User Program File. 

Determine the amount of memory available in Memory Usage (FloBoss 100-Series and FloBoss 407) or 
Device User Program Environment (ROC800-Series). The memory location must be available for the 
specific User Program that you are loading. 

When using a ROC800-Series, click Reset Counter to clear the value that indicates how many time the 
User Program has been restarted. 

Select the User Program in the User Program Installed in Device field, click Start or Enable. 

The Status field displays ON or OFF indicating the status of the User Program selected in the User 
Programs Installed in Device field. 

Click Browse and select the User Program file to download from the CD-ROM. Program files are 
typically located in the Program Files/ROCLINK Files folder. The Open File dialog displays the names 
of all the files that have the .tar (ROC800-Series), .bin (FloBoss 100-Series), or .H00 (FloBoss 407 and 
ROC300-Series) extension. 

Select the File name you desire to load and click Open. Click Download to download the selected User 
Program. Only install one User Program. 

7.8 User Data 
Configure > User Data lists User Program configuration screens for User Programs loaded. These User 
Data screens are used to configure the parameters needed for each User Program. After you install a 
User Program, the User Data drop-down menu then lists the menu options associated with the program. 
Refer to the user manual supplied with your User Program for details concerning these configuration 
screens.  
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Figure 7-16. User Data Example (ROC300-Series) 

After you select a User Program option from the User Data drop-down menu, the screen associated with 
that option displays. You can then proceed to configure the parameters shown on the screen. 
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SECTION 8 – MODBUS COMMUNICATIONS 

Select Configure > Modbus > Configuration. This section describes how to configure a ROC800-Series 
and FloBoss 100-Series to communicate using the Modbus protocol for integration of the ROC and 
Modbus devices into the same Host / Slave system.  

In this Chapter 
Section Page 
8.1 Modbus Configuration (ROC800-Series and FloBoss 100-Series) ................................................ 8-2 

8.2 Modbus Configuration – History .................................................................................................... 8-8 

8.3 Modbus Events and Alarms Functionality.................................................................................... 8-13 

8.4 Modbus Registers (ROC800-Series and FloBoss 100-Series) ..................................................... 8-18 

8.5 Modbus Master Table (ROC800-Series) ...................................................................................... 8-29 

8.6 Modbus Master Modem (ROC800-Series)................................................................................... 8-31 

8.7 Modbus Host Parameters (FloBoss 407 and ROC300-Series) ..................................................... 8-32 

 

FloBoss 100-Series 
The FloBoss 100-Series can act as a Slave device. Modbus Master (host) functionality is only available 
through the use of a User Program. 

The Local Port, COMM1, and COMM2 ports all support Modbus communications. The Modbus 
mapping on the Modbus Registers screen and Modbus History Access Registers screen defines access to 
Modbus Registers on any communication port on which Modbus Host or Slave is enabled.  

When a communications port is set up as a slave, the FloBoss 100-Series can automatically detect 
whether the incoming communication request is in ROC protocol or Modbus protocol. If the Modbus 
User Program is installed, and a communications port is configured as a host, the communications port 
can only support Modbus host functionality. 

ROC800-Series 
The ROC800-Series can act as a Slave or a Host device and does not require a User Program. 

The Modbus Master mode of operation, which is enabled by selecting the correct port owner designation 
in the ROC > Comm Ports screen, allows the ROC800-Series to simulate a master device that can poll 
other Modbus devices for data and stores the data in TLP locations within the ROC800-Series. The 
TLPs can be virtually any location with in the ROC, such as Softpoints, FST Registers, User Program 
TLPs, and point types (AGA or I/O).  

You can map Modbus Registers to any TLP with the correct data types and conversions configurations. 
The ROC800-Series can also send commands to set outputs and write data to a slave device. Modbus 
Host in the ROC800-Series is only supported by COMM2, COMM3, COMM4, and COMM5. Modbus 
Host is not supported on the Ethernet port (COMM1) or on the LOI (Local Port).  

In slave mode, the data link between the host device and the ROC800-Series can use any of the 
communications ports. Serial ports and a communications port with a dialup modem card installed can 
only be designated to switch between ROC or Modbus slave. The Ethernet port can always recognize 
Modbus messages.  
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� Note: For more information about Modbus communications on the Ethernet port, refer to 
Configuring TCP/IP Communications on the Ethernet Port (ROC800-Series). 

Any serial or modem communications port configured with a Port Owner of ROC Plus Protocol/Modbus 
Slave will automatically determine if the incoming communication request is in ROC protocol or 
Modbus protocol. The ROC responds using the same protocol as the incoming request. 

The Ethernet communications port will automatically determine if the incoming communications 
request is in ROC protocol, Modbus RTU encapsulated in TCP/IP, or Modbus TCP/IP protocol. The 
ROC responds using the same protocol as the incoming request. 

ROC300-Series and FloBoss 407 
The ROC300-Series and FloBoss 407 require the Modbus Protocol Emulation User Program to provide 
Modbus communications. 

8.1 Modbus Configuration (ROC800-Series and FloBoss 100-Series) 
The General tab sets the basic communication parameters. The Scale Values tab allows you to enter 
eight low and high floating point scale values and one low and high integer values for converting 
floating point numbers to a scaled integer. The History Access Registers tab (FloBoss 100-Series) 
allows a single register to contain one or more History Points for retrieval of Periodic and Daily 
Historical Archives, as well as the Register number for retrieving the Event Log and Alarm Log. 

8.1.1 Configuring a ROC800-Series or FloBoss 100-Series as a Modbus Slave 
1. Set up the ROC > Comm Port. Refer to Section 2, Communication Ports on the ROC and 

FloBoss. 
2. Define the Modbus Registers. Refer to Section 8.4, Modbus Registers (ROC800-Series and 

FloBoss 100-Series), on page 8-18. 
3. Configure all Conversion Codes. Refer to Table 8-9, Modbus Convert Codes, on page 8-23. 
4. Select Configure > Modbus > Configuration and configure the Modbus to format the data 

correctly. Refer to Section 8.1.3, Modbus Configuration – General, on page 8-3. 

8.1.2 Configuring a ROC800-Series as a Modbus Host 
1. Set up the ROC > Comm Port. Refer to Section 2, Communication Ports on the ROC and 

FloBoss. 
2. Define the Modbus Registers within the Host by mapping them to TLPs. Define Modbus 

Registers that will “hold” the information that will be transmitted and received by the Host. 
Refer to Section 8.4, Modbus Registers (ROC800-Series and FloBoss 100-Series), on page 8-18. 

3. Define the polling sequence to designate with which Modbus devices (RTU Addresses) are 
communicated and what Slave Registers will be read to and which Master Registers (Host) will 
be written out by the Host. Refer to Section 8.5, Modbus Master Table (ROC800-Series), on 
page 8-29. 

4. Select Configure > Modbus > Configuration and configure the Modbus to format the data 
correctly. Refer to Section 8.1.3, Modbus Configuration – General, on page 8-3. 

5. Initiate the polling by setting the Modbus Master Modem parameters. Refer to Section 8.6, 
Modbus Master Modem (ROC800-Series), on page 8-31. 
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8.1.3 Modbus Configuration – General  
Select Configure > Modbus > Configuration. The General tab sets the basic communication 
parameters.  

 
Figure 8-1. Modbus Configuration – General (ROC800-Series) 

 
Figure 8-2. Modbus Configuration – General (FloBoss 100-Series) 
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Select the Comm Port (ROC800-Series) that you desire to configure. 

Select the Comm Mode or Modbus Type. The Modbus protocol supports two modes of transmission: 
ASCII and RTU. All devices in the same communications network must be configured with the same 
mode of transmission. 

♦ ASCII (American Standard Code for Information Interchange) mode represents each 8-bit byte 
of data as two ASCII characters that are the hexadecimal representation of the value. This allows 
the messages to be read with the use of a dumb terminal, but uses twice as many characters as the 
RTU mode. Each character sent is composed of a Start bit, 7 or 8 Data bits, and one or two Stop 
bits with Even, Odd, or No parity. ASCII mode uses Longitudinal Redundancy Checking (LRC) 
error checking.  

♦ RTU (Remote Terminal Unit) mode allows for greater character density and better data 
throughput than ASCII for the same baud rate. Each message is transmitted in a continuous 
stream. Data is sent in 8-bit binary characters. RTU mode uses Cyclic Redundancy Check (CRC) 
error checking. By default, RTU is enabled. 

In either mode, ASCII or RTU, a Modbus message is placed by the transmitting device into a frame that 
has a known beginning and ending point. 

ASCII Message Framing 
Begin of Frame Address Function Data LRC Error Check End 

: 2 Characters 2 Characters N Characters 2 Characters CRLF 
  

RTU Message Framing 
Begin of Frame Address Function Data CRC Error Check End 

T1-T2-T3-T4 1 Byte 1 Byte N * 1 Byte 2 Bytes T1-T2-T3-T4 
 
Byte Order of data bytes in a transmission or requests can be reversed. This only affects the Data field 
of a Modbus message and has no effect on the data bytes for Function Codes 01, 02, and 05. 

♦ Least Significant Byte First – Selecting this check box places the Least Significant Byte first. 
This is the default value. 

♦ Most Significant Byte First – Selecting this check box places the Most Significant Byte first. 

Select Event Logging or Log Modbus Events Enabled to log all parameter changes made via Modbus 
to the Event Log or select Disabled to allow parameters to be changed via Modbus without being 
logged. By default, Event Logging or Log Modbus Events is Enabled. 

The Exception Status field (FloBoss 100-Series) displays the status codes returned from the modem. 

For a FloBoss 100-Series, enter the Date Register and Time Register for the time period in which you 
would like to acquire the data. 

Enable EFM Modbus to use the FloBoss 100-Series EFM Reporting option for date and time format. 
When disabled, standard Modbus reporting will be used. 
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The Slave Mode Exception Status field (ROC800-Series) displays the error code for the last Modbus 
message received. This field is applicable only in slave mode. 

0 = No error 
1 = Illegal function 
2 = Illegal data address 
3 = Illegal data value 

If Modbus Master has been selected as the Port Owner on the General tab of the ROC > Comm Ports 
screen, Start Polling (ROC800-Series) controls the initiation of a Modbus Master polling sequence. It 
will begin polling at the Starting Request entry from the Modbus Master Table and then proceed through 
the entries in the table. The checkbox will be reset when the polling sequence is complete. 

Enter a Starting Request (ROC800-Series) value to enable a Modbus Master polling sequence to begin 
polling with the request number (entry), which represents the line entry, from the Modbus Master Table 
and then proceed through the entries in the table.  

Enter the total Number of Requests (ROC800-Series) of Modbus Master requests to be made in this 
polling sequence. This represents the lines in the polling table on which to execute the polls. 

Enable Continuous Polling (ROC800-Series) to control whether the Modbus Master polling sequence is 
executed on a continuous basis. The sequence is defined in the Modbus Master Table. 

When Continuous Polling has been enabled, the Request Delay (ROC800-Series) sets a delay time, in 
seconds, between polling request sequences. Each line in the Modbus Master Table is considered a 
request. 

The Retries parameter can be set from “0” to “25” to control the number of times after the initial try that 
the Master ROC800-Series attempts to establish communications with the specified device before 
reporting a timeout error. Adjust the amount of time between retries using the Timeout parameter.  

The Timeout parameter defines the amount of time that the Master ROC800-Series waits to receive a 
valid message after it sends a request to a device. Do not enter 0 (zero) in the Timeout field. 

8.1.4 Modbus Configuration – Scale Values  
Select Configure > Modbus > Configuration. The Scale Values tab allows you to enter eight low and 
high floating point scale values and one low and high integer values for converting floating point 
numbers to a scaled integer.  

For a ROC800-Series, the Integer Scale values and the Float scale values are used in conjunction with 
one another whenever you use the Convert Code 1 through 8. In older Modbus devices, data was 
exchanged with no scaling applied, just raw A/D counts were sent between devices. These scaling 
factors allow values to be exchanged between Modbus emulating raw, unscaled values.  

As an example, a 4 to 20 mA loop might have a raw A/D value where 4 mA = 800 counts and 20 mA = 
4095 counts. At midrange, or 12 mA, the raw A/D count would be 2448. If this AI signal was 
representative of a 0 to 250 pound pressure, 4 mA = 800 counts = 0 PISG and 20 mA = 4095 counts = 
20 mA and midrange would be 12 mA = 2448 counts = 125 PSIG. 
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In older Modbus Programmable Logic Controllers (PLCs), it was typical to send and receive the A/D 
counts and the conversion was performed by host systems. The Scaling Values allow you to emulate this 
functionality. For instance, if a host system required information contained in a Softpoint that 
represented a level between 20 and 120 inches and the host required the same value scaled between 
1000 and 7000, (where the host would convert it back into a engineering scale of 20 to 120). In this 
example, the Integer Scale would be set to 1000 and 7000, the Float Scale would be set up for 20.0 and 
120.0. Thus, if the Conversion Code 1 was used, and the actual value in the Softpoint was 70, the host 
would actually be presented with the Integer Scaled Value of 4000. If the Softpoint was 20, the host 
would receive 1000. If the Softpoint was 120, the host would receive a value of 7000. 

In the ROC800-Series, this is supported for both reads and writes. For the FloBoss 100-Series, Convert 
Codes 1 to 8 are for reads and 17 to 24 are for writes. 

 
Figure 8-3. Modbus Configuration – Scale Values (ROC800-Series) 

Enter the Integer Scale values. The Low Value determines the Low Integer Scaling that represents the 
data and the High Value represents the Highest Integer Valued used to scale the date. 

Enter the Low Value and the High Value. The High Value and Low Value fields are signed integers, 
so they can range from –32768 to 32767. These data fields can also be used to scale the Analog I/O to 
integer values with an implied decimal point. 

Enter the Float Scale # in the Low Value Float Scale and High Value Float Scale fields. This is use by 
the ROC to scale the data in conjunction with the Low and High Integer Values.  
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In host systems that do not accept floating point numbers, eight sets of floating point ranges for values 
can be specified. This allows floating point values, such as PID Setpoints, Softpoint values, and flow 
values, to be read and set by the host as integer values. The floating point values are converted to 
integers by configuring a register or range of registers with the Conversion field set in the Modbus 
Registers definition configuration to a Convert Code from 1 to 8.  

The equations used to convert floating point values to integers to enable the reading of floating point 
values are: 

Float Range = High Value Float Scale – Low Value Float Scale 

100.0 = 120.0 – 20.0 

Integer Range = High Value Integer Scale – Low Value Integer Scale 

6000 = 7000 – 1000 

Adjusted Reading = Float Reading – Low Value Float Scale 

50.0 = 70.0 – 20.0 

Integer = Integer Range × Adjusted Reading + Low Value Integer Scale 
Float Range 

3500 = (6000 x 50.0) ÷ 100.0 + 1000 

The equations used to convert integers to floating point values are: 

Float Range = High Value Float Scale – Low Value Float Scale 

100.0 = 120.0 – 20.0 

Integer Range = High Value Integer Scale – Low Value Integer Scale 

6000 = 7000 – 1000 

Adjusted Integer = Integer Sent – Low Value Integer Scale 

3000 = 4000 – 1000 

Float Value = Adjusted Integer × Float Range + Low Value Float Scale 
Integer Range 

70.0 = (3000 x 100) ÷ 6000 + 20 
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8.2 Modbus Configuration – History 
Select Configure > Modbus > Modbus Configuration and select the History Access Registers tab. 
Communications functionality in the ROC800-Series and FloBoss 100-Series allows the 
Periodic/Hourly and Daily history values and Event/Alarm records to be retrieved through Modbus 
Protocol using Function Code 03. FloBoss 100-Series units can also send the Extended History.  

  
Figure 8-4. Modbus History Example (ROC800-Series) 

Each historical record contains a time and date stamp and all of the history archives or values for which 
the Register Number is configured.  

The Modbus Function Code 03 and the History Archive Register are used to collect the archived data. 
Two separate Modbus registers indicate the current Hourly and Daily history index. These can be 
configured on the Modbus Registers screen as the Hourly History Index Register and the Daily History 
Index Register for the Segment being referenced (subtract 1 to get the last archived values). These 
indexes identify the current history archive at which data is about to be logged.  

When the ROC or FloBoss unit receives a Function Code 03 request referencing the Periodic History 
Index (commonly register 7161) or Daily History Index (commonly register 7160), the value returned is 
interpreted as an index into the specified history log. The Host reads the indexes and then compares the 
index to the last polled history index that the host maintains and decides whether to request history. 
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If the Host decides to request history, the reply message contains the date and time stamp and historical 
values configured for the specified register for that index. 

For the ROC800-Series and FloBoss 100-Series, the response message contains two floating point 
values for the time and date stamp of the history archive (FloBoss 100-Series time stamp = HHMMSS 
and date stamp = MMDDYY) (ROC800-Series time stamp = HHMM and date stamp = MMDDYY) and 
floating point values for each of the defined History Points for that History Archive Register. The date 
stamp for history uses the current year and does not figure the number of years since 1980. For example, 
if the current year is 2007, the year (YY) for the date stamp would be 07. 

� Note: For the FloBoss 100-Series, when in Modbus with EFM extensions mode, two changes 
occur. The time stamp is in the HHMM format, and the date stamp is returned before the time 
stamp. The ROC800-Series is always in this format. 

For the ROC800-Series, History collection is mapped on the Modbus History Table. 

For the FloBoss 100-Series, History collection is mapped on the Modbus History Access Registers tab 
of the Modbus Configuration screen. 

Table 8-1 summarizes the function calls and their associated register and data fields. 

Table 8-1. Modbus History, Event, and Alarm Functionality 
 
Function 

Code Register Field Data Field Description 

03 7160 – Daily 
Index 

Ignored1 FloBoss 100-Series only. Response contains current daily 
index. 

03 7161 – Hourly 
Index 

Ignored1 FloBoss 100-Series only. Response contains current hourly 
index. 

03 32 – 
Event/Alarm 

Register 

Ignored1 Response contains Event and Alarm records2. Maximum 
number of bytes returned is 240 (12 records of 20 bytes 
each). Events are returned before Alarms are returned. The 
format is displayed in the Modbus Events and Alarms Log 
Contents table. 

05 32 – 
Event/Alarm 

Register 

Ignored After Events and Alarms have been returned, there must be 
an acknowledgment made so that the same Events and 
Alarms are not returned on the next request. 

03 703 – Daily 
History 

Daily History 
Archive Register 
Index (0 to 34) 

Response contains two floating point values for the time and 
date stamp of the history archive (time stamp = HHMMSS 
and date stamp = MMDDYY) and floating point values for 
each of the defined History Points for that History Archive 
Register. 

03 704 – Hourly 
History 

Hourly or Periodic 
History Archive 

Register Index (0 
to 839) 

Response contains two floating point values for the time and 
date stamp of the history archive (time stamp = HHMMSS 
and date stamp = MMDDYY) and floating point values for 
each of the defined History Points for that History Archive 
Register. 

1. The Periodic Index, Daily Index, and Event/Alarm data fields are used to address a history index number. 
2. The Event and Alarm Log record consists of the bytes shown in Table. Modbus Events and Alarms Log 

Contents. A breakdown of the bit map in Byte 1-2 is given in Table. Event & Alarm Change Bit Map 
Contents. 



ROCLINK 800 User Manual 

Rev. Dec-05 Modbus Communications 8-10 

8.2.1 Modbus Configuration – History Access Registers (FloBoss 100-
Series) 

The History Archive Registers tab (FloBoss 100-Series) allows a single register to contain one or more 
History Points for retrieval of the Historical Archives using Function Code 03. Up to 15 Hourly, Daily, 
or Extended registers can be defined. The FloBoss 100-Series can store up to 35 days of hourly data for 
each of its History Points. The Points mapped on this tab are configured on the Configure > History 
Points screen. Refer to the Configure > History Points screen if you are unsure of the point numbers. 

The Register Number field is used to address the individual History Archive Register. The Daily Index, 
Hourly Index, and Event/Alarm data fields are used to address a history index number.  

Select Configure > Modbus > Modbus Configuration and select the History Access Registers tab. 

 
Figure 8-5. Modbus History Access Registers (FloBoss 100-Series) 

Enter the Modbus Register Number used to acquire the Daily Index values. 

Enter the Modbus Register Number used to acquire the Hourly Index values. 

Enter the Modbus Register Number used to acquire the Extended Index for Extended History values. 

Enter the Modbus Register Number used to acquire the Events \ Alarms logs. Refer to Modbus Events 
& Alarms Functionality. 

Enter the Modbus Register Number used to acquire the group of History Points defined in the Starting 
History Point and Ending History Point fields without having to define each history point separately.  
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Enter the Starting History Point to acquire a group of History Points without having to define each 
history point separately. Enter values in both the Starting History Point and Ending History Point fields. 
The Starting History Point and Ending History Point values must be different, with the Starting History 
Point value being the smaller of the two. The group of History Points is specified by the Modbus register 
value set in the Register Number field. The Starting History Point value is the first history point to be 
retrieved. 

Enter the Ending History Point to acquire a group of History Points without having to define each 
history point separately. Enter values in both the Starting History Point and Ending History Point fields. 
The Starting History Point and Ending History Point values must be different with the Starting History 
Point value being the smaller of the two. The group of History Points is specified by the Modbus register 
value set in the Register Number field. The Ending History Point is the last history point to be retrieved. 

Select the Archive Type to indicate or return Hourly, Daily or Extended values. Hourly and Daily will 
return values from Standard History Points. Extended will return values from Extended History Points. 

Select the Conversion field to specify the type of conversion required, if any, on the data before it is 
sent to the host or before it is written to the FloBoss. The conversions are used to allow integer values 
instead of floating point values to be transmitted and received. Refer to Table 8-9, Modbus Convert 
Codes, on page 8-23. 

8.2.1.1 Modbus History Table (ROC800-Series) 
To configure the Modbus History, select Configure > Modbus > History. The Modbus History Table 
allows the Periodic and Daily history values and Event/Alarm records to be configured for retrieval 
through Modbus Protocol, using Function Code 03. Three registers are defined to retrieve the current 
date in the ROC, the current time in the ROC, and the Event/Alarm records. The Modbus History Table 
also allows the Periodic and Daily registers to be defined for up to twenty groups of History Points. 

Before configuring the Modbus History, be sure the History Segment and History Point configuration is 
complete. 
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Figure 8-6. Modbus History Table (ROC800-Series) 

The Event/Alarm Registers are Modbus Register Numbers used to acquire the Current Date value, 
Current Time value, and Event/Alarm Logs. You may enter registers or use the defaults. Using the 
defaults is highly recommended. The Current Date and Current Time values identify the current date and 
time from the unit and may be most useful to users who want the date and time as floating point 
numbers in the format of DDMMYY and HHMM. For more information on the Modbus retrieval of the 
Event/Alarms log, refer to Modbus Events and Alarms Functionality. 

In the Modbus History Table, each Group defines a contiguous group of History Points from a single 
Segment whose values can be accessed through a Modbus Function Code 03 request for a user-defined 
Modbus register. Twenty groups are available. 

Enter the Modbus Register Number, in either the Periodic History Register or Daily History Register 
fields, used to acquire the group of History Points defined in the Start History Point and End History 
Point fields. One register (commonly register 704) can retrieve periodic data and another register 
(commonly register 703) can retrieve daily data for the group of History Points. The time Period for the 
Periodic history is set on the History Segment configuration screen (if the Period is set as 60, this will be 
Hourly history).  

Select a History Segment from which the history is to be acquired. Make sure this Segment is 
configured through the Configure > History Segments screen. The General Segment is listed on this 
table as 0. 
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Enter the Start History Point for this group of history point values. The Starting History Point value is 
the first history point to be retrieved. Refer to the Configure > History Segments screen for a full list of 
the points assigned to this History Segment. The first history point in the Segment is listed on this table 
as 0. 

Enter the End History Point for this group of history point values. The Ending History Point number 
should be greater than or equal to the Starting History Point number. The Ending History Point is the 
last history point to be retrieved. Refer to the Configure > History Segments screen for a full list of the 
points assigned to this History Segment. The first history point in the Segment is listed on this table as 0. 

Select the Conversion field to specify the type of conversion required, if any, on the data. The values 
will be returned as floating point numbers by default. Refer to the Event & Alarm Change Bit Map 
Contents table. 

The Event/Alarm Registers are Modbus Register Numbers used to acquire the Current Date value, 
Current Time value, and Event/Alarm Logs. You may enter registers or use the defaults. Using the 
defaults is highly recommended. The Current Date and Current Time values identify the current date and 
time from the unit and may be most useful to users who want the date and time as floating point 
numbers in the format of DDMMYY and HHMM. For more information on the Modbus retrieval of the 
Event/Alarms log, refer to Modbus Events & Alarms Functionality. 

8.3 Modbus Events and Alarms Functionality 
To view the Modbus Event Log and Alarm Log, select Configure > Modbus > History. 

The record formats for the Event Log and Alarm Log are the same size and have similar contents. The 
first word in a record is a bit map in which bit 9 indicates if the log record is an Event (1) or an Alarm 
(0). The meanings of the other bits are specific to either the Event or the Alarm Log records. Refer to 
Table 8-6, Event and Alarm Change Bit Map Contents, on page, 8-17.  

The ROC800-Series and FloBoss 100-Series support the Modbus with EFM extensions method for 
retrieving alarms and events. When the ROC or FloBoss receives a Function Code 03 request 
referencing defined Events/Alarms Register (usually 32), the ROC or FloBoss begins to collect records 
from first the Event Log and then the Alarm Log, starting where the last poll left off. The ROC or 
FloBoss will collect records, until either there are not any more new events/alarms or the maximum of 
twelve records have been collected. The ROC or FloBoss unit sends the information back to the host, 
which in return replies with Function Code 05, referencing the same Events/Alarms Register, indicating 
that the points have been received and that the Host is ready for the next twelve records. 
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8.3.1 Modbus Events and Alarms (ROC800-Series) 
The following details how the Event Log and Alarms Log information is placed in Modbus Event and 
Alarm messages and how or what is generated upon the Event or Alarm condition. 

Normal Event Record 
A normal Event record format: 

System Text Events 
When you set the System Command Change Bit (bit 7) in the Operator Change Bit Map of the Event, 
the Register number for all System Command Change events will be set to the Event/Alarm Register 
number (default is 32). 

The above format will be used for the following event codes: 
♦ 144 Initialization Sequence 
♦ 146 Initialize From Defaults 
♦ 147 ROM CRC Error 
♦ 148 Database Initialization 
♦ 150 Program Flash 
♦ 248 Text Message 
♦ 249 Download Configuration 
♦ 250 Upload Configuration 
♦ 251 Calibration Timeout 
♦ 252 Calibration Cancel 
♦ 253 Calibration Success 

FST Events 
For FST Events, the Code will be the FST number (1 to 6). Unused will be set to zero. 

Time Related System Events  
The time is the number of seconds since January 1, 1970. Unused will be set to zero. 

Events are formatted as: 
♦ 145 All Power Removed 
♦ 200 Clock Set 



ROCLINK 800 User Manual 

Rev. Dec-05 Modbus Communications 8-15 

Alarms 
Use the Alarms table to determine the alarming source. The Register number for all unmapped Alarms 
will be set to the Event/Alarm Register number (default is 32). 

A normal Alarm record format: 

Unmapped Parameter Alarms 
If the alarming point is not mapped to a Modbus Register, identifying the point using the following 
table. The TLP will be the source TLP of the alarm. The type will be set to 1. 

FST Alarms 
If the Alarm is an FST Alarm, the above following will be used. The FST # will be the source FST 
Number that generated the alarm. Unused will be set to zero and the type will be set to 2. 

User Text Alarms 
If the Alarm is a User Text Alarm, the following format will be used. Text is filled in with seven bytes 
of User Text and the Type will be set to 3. 

 
User Value Alarms 
If the alarm is a User Value Alarm, the following format will be used. Unused will be set to zero and the 
Type will be set to 4. 

 

8.3.2 Reading Modbus Events and Alarms Register 
The Modbus request to read the Event Log and Alarm Log uses the standard read Function Codes 03 or 
04 and the Register Number defined in the History Access configuration. In this request, the number of 
Registers is included to maintain format compatibility, but is ignored by the receiving ROC or FloBoss 
unit. 

Twenty bytes are returned for each event/alarm in the response. Up to 12 Events and Alarms can be 
returned in a single response. If no events/alarms have occurred since the last collection, the response 
contains zero data bytes. 

For the date stamp in the events and alarms returned, the year (YY) is really the number of years since 
1980 (for example, if the current year is 2007, the year (YY) for the date stamp would be 27). 
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Following is an example of a request for Events and Alarms with the history access event/alarm register 
defined as 32 (0x0020 hex). 

Table 8-2. Host Events and Alarms Request Example Message 
 

Message 
Field 

Device 
Address 

Function 
Code 

Register 
Offset Num Reads (ignored) Error Check 

Bytes 1 1 2 2 2 

TX Order     MS LS MS LS LS MS 

Value 01H 03H 00H 20H 00H 01H CRC-16 

  

The following example shows a response returning three events/alarms.  

Table 8-3. Events and Alarms Response Example Message 
 

Message 
Field 

Device 
Address 

Function  
Code 

Byte 
Count Data Error Check 

Bytes 1 1 1 (20 bytes per event/alarm) 2 

Integers — MS LS 
TX Order    

Floats — Selectable  
LS MS 

Value 01H 03H 3CH   CRC-16 

  

8.3.3 Acknowledging Modbus Events and Alarms 
After the host has correctly received event/alarms data, it transmits an acknowledgement message to the 
ROC to clear these Events and Alarms from the Modbus buffer. Until acknowledged, the ROC 
continues to send the same Event and Alarm records to the host. The Modbus acknowledgement (to 
clear the event/alarm log buffer) uses Function Code 05 and the register number defined in the history 
access configuration. In this request the data value is always one (1). 

Table 8-4. Events and Alarms Acknowledgement Response Example Message 
 

Message Field Device Address Function Code Register Data Error 
Check 

Bytes 1 1 2 2 2 

TX Order   MS LS MS LS MS LS   

Value 01H 05H 00H 20H FFH 00H CRC-16   
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Table 8-5. Modbus Events and Alarms Log Contents 
 

Byte Contents of Event Log Record Contents of Alarm Log Record 

1 to 2 Operator change (Event Log) bit map (16-bit 
integer) – Refer to Table. Event & Alarm Change 
Bit Map Contents. 

Alarm change bit map (16-bit integer) – Refer 
to Table. Event & Alarm Change Bit Map 
Contents. 

3 to 4 Modbus Register number of variable (16-bit 
integer) 

Modbus Register number of variable (16-bit 
integer) 

5 to 8 Time Stamp (HHMMSS; 32-bit floating point) Time Stamp (HHMMSS; 32-bit floating point) 
9 to 12 Date Stamp (MMDDYY; 32-bit floating point) Date Stamp (MMDDYY; 32-bit floating point) 

13 to 16 Previous value of variable (32-bit floating point) Current (alarmed) value of variable (32-bit 
floating point) 

17 to 20 Current (New) value of variable (32-bit floating 
point) 

Unused at the current time (zero filled when 
transmitted to the master) 

 

Table 8-6. Event and Alarm Change Bit Map Contents 
 
Bit Operator Change Bit Map Alarm Change Bit Map

0 Fixed value – change to an EU value on an I/O point in Manual Mode Not Used 
1 Zero scale – change to the 0% Adjusted on an AO or AI Not Used 
2 Full scale – change to the 100% Adjusted on an AO or AI Not Used 
3 Operator entry work value – change to any parameter other than those described Not Used 
4 Boolean fixed bit – change to Status in DO or DI Not Used 
5 Fixed/variable flag – change to Manual Mode for an I/O point Manual Alarm 
6 Table entry change – change to Modbus Function Tables Status Change Alarm 
7 System command change – events logged by system (Power up) No Flow Alarm 
8 Not Used Point Fail Alarm 
9 Operator change (Event Log) identifier bit 0 for Alarm 

10 Low Low Limit – change to Low Low Alarm parameter Low Low Alarm 
11 Low Limit – change to Low Alarm parameter Low Alarm 
12 High Limit – change to High Alarm parameter High Alarm 
13 High High Limit – change to High High Alarm parameter High High Alarm 
14 Rate of Change Limit – change to Rate Alarm parameter Rate Alarm 
15 Not Used Set/Clear Alarm 

(1 = Set or 0 = Clear) 
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8.4 Modbus Registers (ROC800-Series and FloBoss 100-Series) 
Select Configure > Modbus > Registers. Modbus Register tables allow you to map Modbus Registers to 
Point Type, Logical, and Parameter (TLP) numbers. One line in the Modbus Register table can be used 
to map more than one register to TLP pair by using either Point Indexing or Parameter Indexing.  

♦ Point Indexing means that the Start Register is mapped to the selected TLP. Subsequent 
registers, through the End Register, are mapped to the same point type and parameter and 
increment the point logical number.  

♦ Parameter Indexing means that the Start Register is mapped to the selected TLP. Subsequent 
registers, through the End Register, are mapped to the same point type and point logical number, 
and increment the parameter number.  

Example: 
When using Point Indexing the configuration of 

Starting Register Ending Register Device Parameter(s) Indexing Conversion 
100 103 AIN, 4-1, EU Point 0 

specifies four Registers (100, 101, 102, and 103) that are mapped to a group of Analog Input (AIN) 
values in engineering units (EU) starting at the Analog Input in the fourth module location, first position 
(4-1).  

♦ Register 100 = EU of AIN point in location 4-1. 
♦ Register 101 = EU of AIN point in location 4-2. 
♦ Register 102 = EU of AIN point in location 4-3. 
♦ Register 103 = EU of AIN point in location 4-4. 

Example: 
When using Parameter Indexing the configuration of 

Starting Register Ending Register Device Parameter(s) Indexing Conversion 
109 114 FST 1, R1 Parameter 1 

specifies six Registers (109, 110, 111, 112, 113, and 114) that are mapped to a group of FST 1 
parameters starting at FST Register 1.  

♦ Modbus Register 109 = Register 1 of FST Point Number 1. 
♦ Modbus Register 110 = Register 2 of FST Point Number 1. 
♦ Modbus Register 111 = Register 3 of FST Point Number 1. 
♦ Modbus Register 112 = Register 4 of FST Point Number 1. 
♦ Modbus Register 113 = Register 5 of FST Point Number 1. 
♦ Modbus Register 114 = Register 6 of FST Point Number 1.  

Conversion Code 1 (Float to Integer, Float Scale 1) is used to convert the floating point value to an 
integer before the response message is returned to the Host. Once a register is mapped, it can be 
referenced by any Modbus request, providing the data type of the TLP is appropriate for the Function 
Code.  
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� Note: If the native ROC or FloBoss data type does not meet the requirements of the Modbus host 
device, Conversion Codes are available to convert the data to the required data type. For more 
information, refer to Modbus Conversion (ROC800-Series and FloBoss 100-Series). 

� Note: For the ROC800-Series, you can select to have the mapping apply to all ROC 
communication ports or on a selected port only. 

When a Modbus request is received, a search is performed for the referenced register(s). If a register 
number match is found, a response is built based on the device point type and parameter configured in 
the table. If no register number match is located, an error message is returned. 

  
Figure 8-7. Modbus Registers (ROC800-Series) 
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Figure 8-8. Modbus Registers (FloBoss 100-Series) 

For a ROC800-Series, twenty-four register tables are available, each containing fifteen table entries. 
Each table entry can define multiple registers by using either point indexing or parameter indexing. By 
making the registers continuous (when the Start Register address of a new line is one greater than the 
End Register address of the previous line) a continuous data table can be created up for Modbus 
Function 3, 4, or 16 up to the limit of 240 bytes. This type of data table allows access to all its data with 
one request.  

� Note: The ROC800-Series has no Modbus Register definition defaults.  

Periodic or Daily History index registers should be mapped to the TLP for the Periodic Index (Point 
Type 124, Parameter 5) or Daily Index (Point Type 124, Parameter 6). In this TLP, the Logical number 
is the History Segment number. Remember to create an index for each History Segment from which you 
need to request history. 

For a FloBoss 100-Series, up to fifteen different lines can be configured for Modbus Functions 1, 2, 4, 
5, 6, 15, and 16. Up to thirty different lines can be configured for Modbus Function 3, split into tables 
3A and 3B.  

By making the registers continuous (when the Starting Register address of a new line is one greater than 
the Ending Register address of the previous line) a continuous data table can be created up for Modbus 
Function 03, 04, or 16 up to the limit of 240 bytes. This type of data table allows access to all its data 
with one request. 

For Function Codes 01, 02, 05, and 15, the parameter specified should be a single-byte parameter type, 
preferably a status parameter (only bit 0 is used), because this function packs the data into a binary 
format for transmission. Each address span must be unique within the function for proper operation. If 
not, the first valid address is used. 
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Refer to Table 8-7, Modbus Register Definition Defaults (FloBoss 100-Series), concerning Modbus 
Register Definition defaults for the FloBoss 100-Series.  

Table 8-7. Modbus Register Definition Defaults (FloBoss 100-Series) 
  

Function 
Code Row Starting 

Register 
Ending 

Register Device Parameter Indexing Conversion

1 1 1070 1070 2, 19, 3 (DOU, STATUS) Point 0 
2 1 0 0 0, 0, 0  Point 0 
3 1 7052 7060 3, 0, 14 (AIN, EU) Point 0 
  2 7100 7102 46, 0, 51 (AGANEW1, CURDP) Param 0 
  3 7103 7107 47, 0, 0 (FLWNEW1, FLOWDY) Param 0 
  4 7108 7127 47, 0, 36 (FLWNEW1, FLOTDY) Param 0 
  5 7262 7288 46, 0, 15 (AGANEW1, ATMPRS) Param 0 
4 1 0 0 0, 0, 0 Point 0 
5 1 1070 1070 2, 19, 3 (DOU, STATUS) Point 0 
6 1 7052 7060 3, 0, 14 (AIN, EU) Point 0 
  2 7100 7102 46, 0, 51 (AGANEW1, CURDP) Param 0 
  3 7103 7107 47, 0, 0 (FLWNEW1, FLOWDY) Param 0 
  4 7108 7127 47, 0, 36 (FLWNEW1, FLOTDY) Param 0 
  5 7262 7288 46, 0, 15 (AGANEW1, ATMPRS) Param 0 

15 1 0 0 0, 0, 0  Point 0 
16 1 8000 8053 46, 0, 0 (AGANEW1, TAG) Param 0 
  2 8054 8063 45, 0, 0 (SMP1, OPTION) Param 0 

 

Select the Table to which you wish to map registers. The ROC800-Series has 24 register tables 
available. 

Select the Function Index to which you wish to map registers. The FloBoss 100-Series has 9 Function 
Indexes available, each corresponding to a Function Code displayed in the Function name field. 

Enter a 10-character alphanumeric Tag (ROC800-Series) to identify this table. 

Function Name is by default the Function Code that corresponds to the Function Index selected. 
Changing the Function Name is not recommended. 
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 Table 8-8. Modbus Function Codes 
 
Code Meaning Action 

01 Read Logic Coil Status Obtain current status (ON/OFF) of a group of logic coils (outputs). 

02 Read Discrete Input Status Obtain current status (ON/OFF) of a group of Discrete Inputs. 

03 Read Output Registers 
(Holding) 

Obtain current binary value in one or more holding registers. 

04 Read Input Registers Obtain current binary value in one or more input registers. 

05 Force Single Logic Coil Force logic coil to a state of ON or OFF. Acknowledge Alarm or Event 
request. 

06 Preset Single Holding Register Place a specific binary value into a holding register. 

15 Force Multiple Logic Coils Force a series of consecutive logic output coils to defined ON or OFF 
states. 

16 Preset Multiple Holding 
Registers 

Place specific binary values into a series of consecutive holding 
registers. 

Enter a Start Register or Starting Register to represent the first data register in the address span. 

A Start Register of 0 is a valid address. Any number from 0 to 65535 is valid. Register numbers can be 
duplicated as long as they are assigned to separate communication ports. The tables should be numbered 
from smallest to largest. 

In certain Modbus Host devices, the register 40101 is actually transmitted as “100.” The value “100” 
should be placed in the Start address field because the ROC or FloBoss uses the actual number sent by 
the Host.  

For example, the host device requests the Starting Register 500 through Ending Register 700. The 
Starting Register is 400 and the Ending Register is 700. All register numbers requested by the host (500 
through 700) are valid and would be responded to because the requested register numbers match or fall 
in between the Start Register and Ending Register numbers (400 through 700). 

Specify the End Register or Ending Register to represent the last register in the address span. The 
value for this number is computed by: 

End Register address = (Start Register address + Number of Registers) – 1. 

Select the type of Indexing to define the block of Register values as successive Logical Point Numbers 
or Parameters without having to define each separately.  

♦ Point Indexing means that the Start Register is mapped to the selected Device Parameter. 
Subsequent registers, through the End Register, are mapped to the same Point Type and 
Parameter and increment the point Logical Number.  

♦ Parameter Indexing means that the Start Register is mapped to the selected Device Parameter. 
Subsequent registers, through the End Register, are mapped to the same Point Type and point 
Logical Number, and increment the Parameter number. 

Select the Device Parameter to specify the parameter of the Point Types you desire to set or acquire 
data. Be aware of the different data types (Character, Integer, Long, Float) and the size of the data types. 
Use the TLP button to select parameters. 
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The Device Parameter field denotes the type of data associated with an address (Starting Register 
through Ending Register). When the Host requests a valid range of register numbers, the Function Code 
tells the Slave what to do and between which registers (Starting Register through Ending Register). The 
Device Parameter defines what data is collected or which parameter is set. 

Specify the type of Conversion required, if any, on the data before it is sent to the host or before it is 
written to the ROC or FloBoss device. The conversions are used to allow for differences in data types 
between the master and slave devices. Refer to the Modbus Register Definition Defaults (FloBoss 100-
Series) table. 

Conversion codes affect Function Codes 3, 4, 6, 8, and 16. 

Select the Communication Port (ROC800-Series) for use with this entry. 

Register numbers should be unique for any given communications port. Registers may be duplicated, as 
long as they are assigned to separate ports. If a register number is duplicated within the port, the first 
occurrence is used. 

8.4.1 Modbus Conversion (ROC800-Series and FloBoss 100-Series) 
Conversion codes convert the data into a format that is compatible to a Modbus device. 

Select the Conversion field, on the Modbus Registers or Modbus History screen, to specify the type of 
conversion required, if any, on the data before it is sent to the host or before it is written to the ROC or 
FloBoss device. The conversions are used to account for differences in data types between the master 
and slave devices.  

Conversion Codes 65 to 72 allows a four-byte IEEE formatted floating point number to be sent or 
received in two Modbus registers with the byte orders configurable. A check is made to ensure that an 
even number of registers is requested, that the Start Register number does not begin in the middle of a 
register pair, and that the number of registers does not exceed the number of registers configured. 

Table 8-9. Modbus Convert Codes 
 
Convert 

Code Description Slave 
Function Definition 

0 No Conversion N/A N/A 

1 Float to integer, 
Float Scale 1 3,4 

2 Float to integer, 
Float Scale 2 3,4 

3 Float to integer, 
Float Scale 3 3,4 

4 Float to integer, 
Float Scale 4 3,4 

5 Float to integer, 
Float Scale 5 3,4 

6 Float to integer, 
Float Scale 6 3,4 

7 Float to integer, 
Float Scale 7 3,4 

The Float to Integer conversion changes ROC or FloBoss floating point 
data to an integer for transmission to the host. The number of the 
Convert Code specifies which floating point scaling value is to be used 
for the conversion. 
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Convert 
Code Description Slave 

Function Definition 

8 Float to integer, 
Float Scale 8 3,4 

 

9 

Any type to 
signed long with 1 
implied decimal 

place 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10.0 and 
converted to a signed 32 bit integer. (A value of –1.234567 would be 
sent as –12). 

10 

Any type to 
signed long with 2 
implied decimal 

places 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100.0 and 
converted to a signed 32 bit integer. (A value of –1.234567 would be 
sent as –123). 

11 

Any type to 
signed long with 3 
implied decimal 

places 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 1000.0 and 
converted to a signed 32 bit integer. (A value of –1.234567 would be 
sent as –1234). 

12 

Any type to 
signed long with 4 
implied decimal 

places 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10000.0 and 
converted to a signed 32 bit integer. (A value of –1.234567 would be 
sent as –12345). 

13 

Any type to 
signed long with 5 
implied decimal 

places 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100000.0 and 
converted to a signed 32 bit integer. (A value of –1.234567 would be 
sent as –123456). 

14 

Any type to 
signed long with 6 
implied decimal 

places 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 1000000.0 and 
converted to a signed 32 bit integer. (A value of –1.234567 would be 
sent as –1234567). 

15 

Any type to 
signed long with 7 
implied decimal 

places 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10000000.0 and 
converted to a signed 32 bit integer. (A value of –1.234567 would be 
sent as –12345670). 

16 

Any type to 
signed long with 8 
implied decimal 

places 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100000000.0 
and converted to a signed 32 bit integer. (A value of –1.234567 would be 
sent as –123456700). 

17 Integer to Float, 
Float Scale 1 6,16 

18 Integer to Float, 
Float Scale 2 

6,16 
 

19 Integer to Float, 
Float Scale 3 

6,16 
 

20 Integer to Float, 
Float Scale 4 

6,16 
 

21 Integer to Float, 
Float Scale 5 

6,16 
 

22 Integer to Float, 
Float Scale 6 

6,16 
 

17 to 24 are for the FloBoss 100-Series only. The Integer to Float 
conversion changes a transmitted integer value to a floating point value 
for the FloBoss. The number of the Convert Code specifies which 
floating point scaling value is to be used for the conversion. If no 
fractional part is coming through on conversion from integer to float, use 
a float conversion that more closely fits the range of integer to be 
converted, such as float range 0 to 10 instead of 0 to 1000. 
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Convert 
Code Description Slave 

Function Definition 

23 Integer to Float, 
Float Scale 7 

6,16 
 

24 Integer to Float, 
Float Scale 8 

6,16 
 

 

17 
Any Type to 

Unsigned Long 
Implied 1 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10.0 and 
converted to an unsigned 32 bit integer. (A value of 1.234567 would be 
sent as 12). 

18 
Any Type to 

Unsigned Long 
Implied 2 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100.0 and 
converted to an unsigned 32 bit integer. (A value of 1.234567 would be 
sent as 123). 

19 
Any Type to 

Unsigned Long 
Implied 3 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 1000.0 and 
converted to an unsigned 32 bit integer. (A value of 1.234567 would be 
sent as 1234). 

20 
Any Type to 

Unsigned Long 
Implied 4 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10000.0 and 
converted to an unsigned 32 bit integer. (A value of 1.234567 would be 
sent as 12345). 

21 
Any Type to 

Unsigned Long 
Implied 5 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100000.0 and 
converted to an unsigned 32 bit integer. (A value of 1.234567 would be 
sent as 123456). 

22 
Any Type to 

Unsigned Long 
Implied 6 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 1000000.0 and 
converted to an unsigned 32 bit integer. (A value of 1.234567 would be 
sent as 1234567). 

23 
Any Type to 

Unsigned Long 
Implied 7 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10000000.0 and 
converted to an unsigned 32 bit integer. (A value of 1.234567 would be 
sent as 12345670). 

24 
Any Type to 

Unsigned Long 
Implied 8 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100000000.0 
and converted to an unsigned 32 bit integer. (A value of 1.234567 would 
be sent as 123456700). 

25 Any type to Float, 
No Scaling 3,4,6,16 

26 
Any type to 

Signed Short 
Integer 

3,4,6,16 

27 
Any type to 

Signed Long 
Integer 

3,4,6,16 

28 
Any type to 

Unsigned Short 
Integer 

3,4,6,16 

29 
Any type to 

Unsigned Long 
Integer 

3,4,6,16 

ROC800-Series only. When using Function Code 03 or 04, this 
conversion changes any data type (unsigned or signed Character, 
Integer, or Long) in the ROC to a specific point value for transmission to 
the Host. When using Function Code 6 or 16, this conversion changes a 
transmitted floating point value to the correct data type for the ROC TLP.

30 to 32 No Conversion N/A N/A 

33 Character to 
Integer 3,4 FloBoss 100-Series only. The Character to Integer conversion changes a 

FloBoss character data type to an integer for transmission to the host. 

34 Integer to 
Character 6,16 FloBoss 100-Series only. The Integer to Character conversion changes a 

transmitted integer value to a character data type for the FloBoss.  
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Convert 
Code Description Slave 

Function Definition 

35 Long to Integer 3,4 FloBoss 100-Series only. The Long to Integer conversion changes a 
FloBoss long data type to an integer for transmission to the host. 

36 Integer to Long 6,16 FloBoss 100-Series only. The Integer to Long conversion changes a 
transmitted integer value to a long data type for the FloBoss. 

37 Unsigned Byte to 
Packed Bit 3,4,6,16 

ROC800-Series only. Response is identical that for a function 1 or 2 
request. All registers in the range requested must be unsigned integer 8 
values and have a conversion code of 37. 

38 No Conversion N/A N/A 

39 Float to Integer, 
No Scaling 3,4 

FloBoss 100-Series only. The Float to Integer conversion changes a 
FloBoss floating point data type to an integer for transmission to the 
Host. 

40 Integer to Float, 
No Scaling 3,4,6,16 FloBoss 100-Series only. The Integer to Float conversion changes a 

transmitted integer value to a floating point data type for the FloBoss.  

41 
Any Type to 
Signed Short 

Implied 1 
3,4,6,16 

ROC800-Series only. Value within ROC is multiplied by 10.0 and 
converted to a signed 16 bit integer. (A value of –0.12345 would be sent 
as –1). 

41 Float to Byte, No 
Scaling 3,4 FloBoss 100-Series only. The Float to Byte conversion changes a 

FloBoss floating point data type to a byte for transmission to the Host. 

42 
Any Type to 
Signed Short 

Implied 2 
3,4,6,16 

ROC800-Series only. Value within ROC is multiplied by 100.0 and 
converted to a signed 16 bit integer. (A value of –0.12345 would be sent 
as –12). 

42 Byte to Float, No 
Scaling 3,4,6,16 FloBoss 100-Series only. The Byte to Float conversion changes a 

transmitted byte value to floating point data type for the FloBoss. 

43 
Any Type to 
Signed Short 

Implied 3 
3,4,6,16 

ROC800-Series only. Value within ROC is multiplied by 1000.0 and 
converted to a signed 16 bit integer. (A value of –0.12345 would be sent 
as –123). 

43 Float to Long, No 
Scaling 3,4 

FloBoss 100-Series only. The Float to Long conversion changes a 
FloBoss floating point data type to a Long Integer for transmission to the 
Host. 

44 
Any Type to 
Signed Short 

Implied 4 
3,4,6,16 

ROC800-Series only. Value within ROC is multiplied by 10000.0 and 
converted to a signed 16 bit integer. (A value of –0.12345 would be sent 
as –1234). 

44 Long to Float, No 
Scaling 3,4,6,16 

FloBoss 100-Series only. The Long to Float conversion changes a 
transmitted Long Integer value to a floating point data type for the 
FloBoss. 

45 
Any Type to 
Signed Short 

Implied 5 
3,4,6,16 

ROC800-Series only. Value within ROC is multiplied by 100000.0 and 
converted to a signed 16 bit integer. (A value of –0.12345 would be sent 
as –12345). 

45 Float to Byte 6,16 
FloBoss 100-Series only. The Float to Byte Unsigned Character 
conversion changes a transmitted floating point value to an unsigned 
character data type for the FloBoss. 

46 
Any Type to 
Signed Short 

Implied 6 
3,4,6,16 

ROC800-Series only. Value within ROC is multiplied by 1000000.0 and 
converted to a signed 16 bit integer. (A value of –0.01234567 would be 
sent as –12345). 

46 Float to Unsigned 
Integer 6,16 

FloBoss 100-Series only. The Float to Unsigned Integer conversion 
changes a transmitted floating point value to an unsigned integer data 
type for the FloBoss. 
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Convert 
Code Description Slave 

Function Definition 

47 
Any Type to 
Signed Short 

Implied 7 
3,4,6,16 

ROC800-Series only. Value within ROC is multiplied by 100000.0 and 
converted to a signed 16 bit integer. (A value of –0.0012345 would be 
sent as –12345). 

47 Float to Unsigned 
Long 6,16 

FloBoss 100-Series only. The Float to Unsigned Long conversion 
changes a transmitted floating point value to an unsigned long data type 
for the FloBoss. 

48 
Any Type to 
Signed Short 

Implied 8 
3,4,6,16 

ROC800-Series only. Value within ROC is multiplied by 1000000.0 and 
converted to a signed 16 bit integer. (A value of –0.0001234567 would 
be sent as –12345). 

49 Deadband, Float 
Scale 1 3,4,6,16 

50 Deadband, Float 
Scale 2 3,4,6,16 

51 Deadband, Float 
Scale 3 3,4,6,16 

52 Deadband, Float 
Scale 4 3,4,6,16 

53 Deadband, Float 
Scale 5 3,4,6,16 

54 Deadband, Float 
Scale 6 3,4,6,16 

55 Deadband, Float 
Scale 7 3,4,6,16 

56 Deadband, Float 
Scale 8 3,4,6,16 

FloBoss 100-Series only. The Deadband to Float Scale conversion 
changes FloBoss Deadband point data to an integer for transmission to 
the host. The number of the Convert Code specifies which floating point 
scaling value is to be used for the conversion. 

49 
Any Type to 

Unsigned Short 
Implied 1 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10.0 and 
converted to an unsigned 16 bit integer. (A value of 0.1234567 would be 
sent as 1). 

50 
Any Type to 

Unsigned Short 
Implied 2 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100.0 and 
converted to an unsigned 16 bit integer. (A value of 0.1234567 would be 
sent as 12). 

51 
Any Type to 

Unsigned Short 
Implied 3 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 1000.0 and 
converted to an unsigned 16 bit integer. (A value of 0.1234567 would be 
sent as 123). 

52 
Any Type to 

Unsigned Short 
Implied 4 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10000.0 and 
converted to an unsigned 16 bit integer. (A value of 0.1234567 would be 
sent as 1234). 

53 
Any Type to 

Unsigned Short 
Implied 5 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100000.0 and 
converted to an unsigned 16 bit integer. (A value of 0.1234567 would be 
sent as 12345). 

54 
Any Type to 

Unsigned Short 
Implied 6 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 1000000.0 and 
converted to an unsigned 16 bit integer. (A value of 0.01234567 would 
be sent as 12345). 

55 
Any Type to 

Unsigned Short 
Implied 7 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 10000000.0 and 
converted to an unsigned 16 bit integer. (A value of 0.001234567 would 
be sent as 12345). 
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Convert 
Code Description Slave 

Function Definition 

56 
Any Type to 

Unsigned Short 
Implied 8 

3,4,6,16 
ROC800-Series only. Value within ROC is multiplied by 100000000.0 
and converted to an unsigned 16 bit integer. (A value of 0.0001234567 
would be sent as 12345). 

57 
Any type to 

signed long 0, 1, 
2, 3 

3,4,6,16 
ROC800-Series only. Response is similar to dual register floating point 
conversions. Dual register – byte order 0-1-2-3. 

Note: 0 = Byte MSB and Byte 3 = LSB 

58 
Any type to 

signed long 0, 1, 
2, 3 

3,4,6,16 
ROC800-Series only. Response is similar to dual register floating point 
conversions. Dual register – byte order 1-0-3-2. 

Note: 0 = Byte MSB and Byte 3 = LSB 

59 
Any type to 

signed long 0, 1, 
2, 3 

3,4,6,16 
ROC800-Series only. Response is similar to dual register floating point 
conversions. Dual register – byte order 2-3-0-1. 

Note: 0 = Byte MSB and Byte 3 = LSB 

60 
Any type to 

signed long 0, 1, 
2, 3 

3,4,6,16 
ROC800-Series only. Response is similar to dual register floating point 
conversions. Dual register – byte order 3-2-1-0. 

Note: 0 = Byte MSB and Byte 3 = LSB 

61 
Any type to 

signed long 0, 1, 
2, 3 

3,4,6,16 
ROC800-Series only. Response is similar to dual register floating point 
conversions. Dual register – byte order 0-1-2-3. 

Note: 0 = Byte MSB and Byte 3 = LSB 

62 
Any type to 

signed long 0, 1, 
2, 3 

3,4,6,16 
ROC800-Series only. Response is similar to dual register floating point 
conversions. Dual register – byte order 1-0-3-2. 

Note: 0 = Byte MSB and Byte 3 = LSB 

63 Any type to 
unsigned long 3,4,6,16 

ROC800-Series only. Response is similar to dual register floating point 
conversions. Dual register – byte order 2-3-0-1. 

Note: 0 = Byte MSB and Byte 3 = LSB 

64 
Any type to 

signed long 0, 1, 
2, 3 

3,4,6,16 
ROC800-Series only. Response is similar to dual register floating point 
conversions. Dual register – byte order 3-2-1-0. 

Note: 0 = Byte MSB and Byte 3 = LSB 

65 IEEE Floating 
Point Number 3,4,16 

66 IEEE Floating 
Point Number 3,4,16 

Code 65 places byte 0 and byte 1 in register xxxxx; byte 2 and byte 3 
are placed in register xxxxx + 1. This places a 4-byte floating point value 
into two, 2-byte registers to allow integer values to be transmitted. Code 
66 does the same as Code 65 regardless of the Byte Order field in the 
Modbus Configuration screen. 

Register xxxxx byte 0, byte 1 
Register xxxxx + 1 byte 2, byte 3 

67 IEEE Floating 
Point Number 3,4,16 

68 IEEE Floating 
Point Number 3,4,16 

Code 67 reverses byte 0 and byte 1 order in register xxxxx; reverses 
byte 2 and byte 3 order in register xxxxx + 1. This places a 4-byte 
floating point value into two, 2-byte registers to allow integer values to be 
transmitted. Code 68 does the same as Code 67 regardless of the Byte 
Order field in the Modbus Configuration screen. 

Register xxxxx byte 1, byte 0 
Register xxxxx + 1 byte 3, byte 2 

69 IEEE Floating 
Point Number 3,4,16 

70 IEEE Floating 
Point Number 3,4,16 

Code 69 places byte 2 and byte 3 in register xxxxx; byte 0 and byte 1 are 
placed in register xxxxx + 1. This places a 4-byte floating point value into 
two, 2-byte registers to allow integer values to be transmitted. Code 70 
does the same as Code 69 regardless of the Byte Order field in the 
Modbus Configuration screen. 

Register xxxxx byte 2, byte 3 
Register xxxxx + 1 byte 0, byte 1 
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Convert 
Code Description Slave 

Function Definition 

71 IEEE Floating 
Point Number 3,4,16 

72 IEEE Floating 
Point Number 3,4,16 

Code 71 reverses byte 2 and byte 3 order in register xxxxx; reverses 
byte 0 and byte 1 order in register xxxxx + 1. This places a 4-byte 
floating point value into two, 2-byte registers to allow integer values to be 
transmitted. Code 72 does the same as Code 71 regardless of the Byte 
Order field in the Modbus Configuration screen. 

Register xxxxx byte 3, byte 2 
Register xxxxx + 1 byte 1, byte 0 

73 IEEE Floating 
Point Number 3,4.6,16 

74 IEEE Floating 
Point Number 3,4,6,16 

FloBoss 100-Series Only. Convert Codes 73 and 74 send the IEEE 
formatted floating point number as four bytes with a single register 
request. Only the byte order is changed: Function Code 73 loads register 
xxxxx in byte 2, byte 3, byte 0, byte 1 order. Function Code 74 does the 
same as Function Code 73 regardless of the Byte Order field in the 
Modbus Configuration screen. 

75 to 
255 No Conversion N/A N/A 

8.5 Modbus Master Table (ROC800-Series) 
Select Configure > Modbus > Master Table. The Modbus Master mode of operation allows the 
ROC800-Series to simulate a master device that can poll other devices for data and to store that data 
within the ROC in any valid TLP. The ROC800-Series can also send commands to set outputs and write 
data to a slave device. 

� Note: The Modbus Master Table only applies to the ROC800-Series. When the FloBoss 100-
Series has the special User Program installed to act as a host device, the Modbus Master 
parameters are configured on the user data screen. 

The Modbus Master functionality can be configured on the EIA-232 (RS-232), EIA-485 (RS-485) 
and modem communications ports (COMM2 to COMM5). The LOI and Ethernet (COMM1) ports 
will not support Modbus Master communications. Up to 200 different master requests/commands can be 
configured across communication ports COMM2 to COMM5. Each command can transmit or receive up 
to 240 bytes of data. Modbus Function Codes 1, 2, 3, 4, 5, 6, 15, and 16 are supported. Function Codes 1 
to 4 request data from slaves, while 5, 6, 15, and 16 transmit data to a slave device. 

Each master request configured uses data read from or written to registers defined in the Modbus 
Registers table. When using Modbus Function Codes 1 to 4, the ROC800-Series will be reading data 
from a slave device and writing it to the TLP specified in the Modbus Registers table. When using 
Modbus Function Codes 5, 6, 15, and 16, the ROC800-Series will be reading data from the TLP 
specified in the Modbus Registers table and write it to the slave device. 

As a Modbus Master, the ROC800-Series may have to communicate to multiple slave devices through 
modems and phone lines. The Modbus Master Modem screen will provide the necessary parameters to 
configure the modems and map RTU Addresses to phone numbers. One Communication Port will have 
the ability to dial-up 6 different Modbus slaves. The ROC800-Series will retry three times to establish a 
connection with a slave. 

An FST, User C Program, or DS800 application can be used to schedule Modbus Master requests. The 
Master Activity status parameter may be used to determine if the communication port is available for 
use. The Start Polling checkbox (Configure > Modus > Configuration) will need to be set by you if 
continuous polling will be enabled or master polling can be managed, enabled, and disabled by a control 
application. Using FSTs, the ROC800-Series can dial other Modbus Slave devices at regular intervals. 
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Figure 8-9. Modbus Master Table (ROC800-Series) 

Select the Logical Point of the communication port location that you desire to host. The Modbus Master 
functionality can be configured on the EIA-232 (RS-232), EIA-485 (RS-485) and modem 
communications ports (COMM2 to COMM5).  

Enter a 10-character identification Tag for the Master Table. 

Enter the RTU Address of the slave device to be queried. 

Enter the Modbus Function Code to be sent to the slave device. 

Enter the starting Modbus Slave Register number for this query on the slave device. 

Enter the starting Master Register number where the queried data will be stored on the master 
ROC800-Series device. 

Enter the Number of Registers for the master ROC800-Series device to either read or write. 

Comm Status displays the status of the query. 

Table 8-10. Status of Host Request or Command 
 

Status Description 

0 Inactive or start of transmission 
1 Receive timeout error 
2 Received Address check 
3 Received Function Number check 
4 Number of expected bytes check 
5 Receiving slave response 
6 CRC or LRC check 
7 CRC or LRC check 
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Status Description 

8 Valid slave response 
128 Write Device Data error 
129 Access Device Data error 
130 Host Function Table error 
131 Transmit Timeout error 
144 Transmit or Receive buffer overflow 
145 Invalid Function Number in request 

8.6 Modbus Master Modem (ROC800-Series) 
Select Configure > Modbus > Master Modem. As a Modbus Master, the ROC800-Series may have to 
communicate to multiple slave devices through modems and phone lines. The Modbus Master Modem 
screen provides the necessary parameters to configure the modems and map RTU Addresses to phone 
numbers.  

Only COMM2 to COMM5 support Modbus functionality, the Local Port and COMM1 (Ethernet) port 
will not. Each communications port can access to six RTU addresses. This point associates Modbus 
Slave RTU Addresses to their respective phone numbers. Up to six different Modbus Slaves can be 
dialed up through one communication port. The ROC800-Series will retry three times to establish a 
connection with a slave. 

 
Figure 8-10. Modbus Master Modem (ROC800-Series) 

Select the Comm port location that you desire to host. The Modbus Master functionality can be 
configured on the EIA-232 (RS-232), EIA-485 (RS-485), and modem communications ports. Only 
COMM2 to COMM5 support Modbus functionality; the Local Port and COMM1 (Ethernet) port will not.  

Enter a 10-character identification Tag for the Master Modem. 

Enter the RTU Address of the slave device to be associated with the Connect Command. Up to six 
different Modbus Slaves can be dialed up through one communication port.  

Enter the Connect Command (telephone number) to be sent to the slave device. 
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8.7 Modbus Host Parameters (FloBoss 407 and ROC300-Series) 
Select ROC > Comm Ports. Click the Modbus Host Parameters tab. 

 
Figure 8-11. Modbus Host Parameters (FloBoss 407 and ROC300-Series) 

� Note: Modbus functionality is not resident in the FloBoss 407 or ROC300-Series firmware. The 
Modbus user program must be loaded and enabled in the FloBoss 407 or ROC300-Series for this 
tab to be available. 

� Note: Modbus Registers functions are available for the FloBoss 407 or ROC300-Series through 
the use of a user program. Refer to the Modbus Protocol Emulation Program Manual (Form 
A4606). 

To enable Modbus transmission, select Active for the Start Transmission. 

Enable Continuous Polling to control whether the Modbus Master polling sequence is executed on a 
continuous basis. 

Enter the Starting Host Request number defining where in the Host Config table to begin the 
transmission. The default is 0, which tells the Host to start at message 0. If another value is entered, the 
Host begins at that number and skips prior messages defined in the host table. For example, if you enter 
10 as a Starting Register, the transmission begins at Request Number 10. 

The messages that are transmitted begin with the Request Number set in the Starting Register. 
Subsequent Request Numbers are transmitted until a Function Code 0 or Address 0 is encountered or the 
last Request Number (39) has been transmitted. If Continuous Polling is Enabled, the Host starts the 
transmission sequence over again. 
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In certain Modbus Host devices, the register 40101 is actually transmitted as “100”. The value “100” 
should be placed in the Starting Register field because the FloBoss uses the actual number sent by the 
Host. 

Any number from 0 to 65535 is valid. A Starting Register of 0 is a valid address. Register numbers can 
be duplicated as long as they are in separate Modbus Function configuration tables. The tables should be 
numbered from smallest to largest. 

When Continuous Polling has been enabled, the Host Poll Delay sets a delay time, in seconds, between 
polling request sequences. 

Transmission Status displays the current status of the Modbus program. 
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SECTION 9 – SAVING AND RETRIEVING 
CONFIGURATIONS 

 This section describes how to save configurations, download configurations to the ROC or FloBoss and 
save ROC or FloBoss data to files for reports. 

In this Chapter 
Section Page 
9.1 Saving a ROC User File ................................................................................................................... 9-1 

9.2 Saving a Configuration..................................................................................................................... 9-2 

9.3 Downloading a Configuration .......................................................................................................... 9-3 

9.1 Saving a ROC User File 
In addition to keeping backup copies of the configuration file, it is also good practice to keep a backup 
copy of the ROC_USER.mdb file. This file contains the communications, security, and password 
settings for the ROC. 

To create a backup copy of the file: 

1. Open Windows Explorer and navigate to the folder where ROCLINK 800 software is located. 
Typically, this folder is C:\Program Files\ROCLINK800. 

2. Create a Copy of the ROC_USER.mdb file. 

3. Paste the Copy into another folder on the PC or a disk. 
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9.2 Saving a Configuration 
The Save option saves the current configuration of a connected device to a disk file. This feature is 
useful when creating a backup, when configuring similar ROC or FloBoss units for the first time, or 
when making configuration changes off-line. Once a backup configuration file is created, it can be 
loaded into a device by using the Download function. 

1. Select File > Save Configuration. The Save As dialog box appears.  

2. Type the desired File name of the backup file. 

3. Click Save.  

 
Figure 9-1. Saving Configuration 

ROCLINK 800 configuration files have the extension .800. 

 
Figure 9-2. Saving Configuration Complete 
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9.3 Downloading a Configuration 
Use the Download option in the File menu to download a saved configuration to a ROC or FloBoss 
device. Configuration files are created using the New Configuration function. To download a saved 
configuration, do the following: 

1. Connect to the ROC or FloBoss unit. 

2. Select File > Download. 

3. Select the configuration File name. ROCLINK 800 files have the extension .800. 

4. Click Open. 

5. Select only the Configuration Points you desire to download. The items that are not configured 
in your configuration will be grayed out.  

 
Figure 9-3. Download Configuration 

6. Click Download. The Configuration Points automatically begin to download. 

The Status, Point Type, and Point Number will display how the download is progressing. 

7. Click OK when the download is complete. 

8. Select ROC > Flags and click the Save Configuration for Flash Memory button. 

9. Select only the Configuration Points you desire to download. The items that are not configured 
in your configuration will be grayed out.  
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9.3.1 Opening a Configuration 
The Open option allows you to open an existing configuration file. Configuration files are created using 
the Save Configuration function. To open a configuration file: 

1. Select File > Open.  

2. Select the configuration File name. 

3. Click Open. 

Once the configuration file is opened, it automatically becomes active and you may edit the file off-line. 
The configuration file may also be downloaded into a ROC or FloBoss. Refer to Downloading a 
Configuration. 
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SECTION 10 – CALIBRATION 

This section describes how to calibrate Analog Inputs, RTD Inputs, and Sensor Inputs for orifice meters 
and turbine meters. 

In this Chapter 
Section Page 
10.1 Calibration Basics ......................................................................................................................... 10-1 

10.2 Starting Calibration....................................................................................................................... 10-3 

10.3 Analog Input Calibration Values ................................................................................................ 10-16 

10.4 RTD Input Calibration Values .................................................................................................... 10-17 

10.5 MVS Input Calibration Values (ROC800-Series and FloBoss 407) .......................................... 10-19 

10.1 Calibration Basics 
The Calibration routine provides Verify, Calibrate, and Zero Shift functions for AI, MVS, DVS, and 
RTD inputs. You can calibrate Differential Pressure (orifice metering may be High or Low Differential 
Pressure, depending on the device), Static Pressure, or Temperature readings are available for each 
Meter Run.  

� Note: During calibration, the ROC or FloBoss times out and resumes normal processing if it is 
left idle for an extended period. Calibration values are restored to their previous values, an event 
is logged, and you must reconnect to start calibration from the beginning. 

Calibration parameters include Set Zero, Set Span, and Set Midpoint 1, 2, and 3. 

All new calibration values are automatically logged in the Event Log. 

� Note: Click Cancel to exit the calibration without saving the changes. The previous calibration 
settings are retained. An event is also logged. 

For a ROC800-Series, Meter calibration-related parameters (Gravitational Acceleration and User Factor) 
are configured on the Calibration Factors tab of the Meter > Setup Orifice or Turbine screen. 

For a FloBoss 100-Series, calibration-related parameters (Calibrated Gravitational Acceleration and 
User Correction Factor) are configured on the Instrument Factors tab of the Meter Setup screen. 

 
If you have an MVS sensor, refer to the Sensor Calibration section in the ROC or FloBoss 
Accessories Instruction Manual (Form A4637) for the recommended way to remove/restore the 
MVS from/to working pressure during calibration. Failure to follow recommendations may cause 
sensor damage. 

 
If you have a DVS Sensor, refer to the Calibration section of the appropriate FloBoss hardware 
manual for the recommended way to remove/restore the DVS from/to working pressure during 
calibration. Failure to follow recommendations may cause sensor damage. 
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10.1.1 Calibration Report 
If required, create a Calibration Report to record the calibration procedure. 

10.1.1.1 Creating a Calibration Report 
1. Click Freeze to stop the values of the Analog, MVS, HART, and Temperature (RTD) inputs 

from being updated during verification or calibration. 

2. Click Yes in the confirmation dialog to create a Calibration Report. 

3. Enter the File name of the Calibration Report and use the default extension of .800 or .cal to 
represent calibration. Click Save. 

4. The Calibration Report File is created in the default directory C:/Program Files/ROCLINK 800, 
unless you specify another Directory/Drive.  

Once the calibration is complete, the report can be viewed using a text editor or View > Calibration 
Report. 

10.1.1.2 Viewing a Calibration Report 
1. Select View > Calibration Report from the menu.  

2. Select the Calibration Report you desire to view. 

  
Figure 10-1. View Calibration Report 
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3. Click Print Preview. The Report opens. 

  
Figure 10-2. Calibration Report Print Preview 

10.2 Starting Calibration 
Click Freeze to stop the values of the Analog, MVS, HART, and Temperature (RTD) inputs from being 
updated during verification or calibration.  

This creates the Freeze Value used in ongoing processing, such as flow calculations and history 
logging, while calibration is being performed. The Calibration Freeze Value field displays the value 
received from the Analog, HART, MVS, or RTD input when the Update button was last pressed. 

10.2.1 Verify – Calibration 
If the run has been calibrated before, click Verify to begin a verification of the last calibration or 
immediately after a new calibration. Click Log Verify to write the data to the Event Log and calibration 
report.  

Verify proceeds with verification of the calibration at a point in the operating range, such as at 0, 25, 50, 
75, or 100 percent. 

The Point field displays the Point you are calibrating or verifying. 

Enter the Dead Weight or Tester Value. This is the input desired for the test value and is the actual 
value expected by the test equipment being calibrated against. For example: When calibrating 
temperature for an RTD input, enter the degrees value associated with the resistance set up in the decade 
box. 

The Live Reading field displays actual (Live Reading) value read from the sensor or AI point. 
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ROC300-Series and FloBoss 407 devices display: 
♦ Action – Describes the type of Action. Possible Actions are: Verify, Set Zero, Set Span, Set Mid 

1, Set Mid 2, and Set Mid 3. 
♦ Entry –Expected or desired value. This is the entered Dead Weight/Tester value for point being 

verified/calibrated. 
♦ Reading – The actual (Live Reading) value read from the sensor or AI point. 
♦ Deviation – Difference between expected or entered value and live reading  

     (Deviation = Entry – Reading). 
♦ %Deviation – Deviation as percent of range  

     (%Deviation = Deviation ÷ (Span EU – Zero EU) x 100%). 

  
Figure 10-3. Verify Calibration (ROC800-Series) 

  
Figure 10-4. Verify Calibration (ROC300-Series and FloBoss 407) 
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10.2.2 Set Zero – Calibration 
After Verifying Calibration, calibrate the Zero value (0% of range) for the in Differential Pressure 
(orifice only), Static Pressure, or Temperature. This should correspond with the Low Reading EU (0% 
Count) and is the low value for the Meter input.  

1. Enter the Dead Weight or Tester Value (in engineering units). This is the input desired for the 
test value and is the actual value expected by the test equipment being calibrated against. For 
example: When calibrating temperature for an RTD input, enter the degree value associated with 
the resistance set up in the decade box or other equipment.  

  
Figure 10-5. Set Zero Calibration (ROC800-Series) 

The Point field displays the Point you are calibrating or verifying. 

 
Figure 10-6. Set Zero Calibration (FloBoss 100-Series) 
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Figure 10-7. Set Zero Calibration (ROC300-Series and FloBoss 407) 

2. Compare the Dead Weight or Tester Value with the Live Reading. If the value is too far out of 
tolerance, perform calibration for the input.  

3. Click the Set Zero button. 

ROC300-Series and FloBoss 407 devices display: 
♦ Action – Describes the type of Action. Possible Actions are: Verify, Set Zero, Set Span, Set 

Mid 1, Set Mid 2, and Set Mid 3. 
♦ Entry –Expected or desired value. This is the entered Dead Weight/Tester value for point 

being verified/calibrated. 
♦ Reading – The actual (Live Reading) value read from the sensor or AI point. 
♦ Deviation – Difference between expected or entered value and live reading  

     (Deviation = Entry – Reading). 
♦ %Deviation – Deviation as percent of range  

     (%Deviation = Deviation ÷ (Span EU – Zero EU) x 100%). 



ROCLINK 800 User Manual 

Rev. Dec-05 Calibration 10-7 

10.2.3 Set Span – Calibration 
Calibrate the Span value (100% of range) for Differential Pressure (orifice only), Static Pressure, or 
Temperature. The Point field displays the Point you are calibrating or verifying. This corresponds with 
the High Reading EU (100% Count) and is the high value to the input (the top end of the expected 
operating range). 

For Static Pressure on an absolute-pressure device, remember to add in the actual atmospheric pressure, 
for example, 300 + 14.73. 

 
Figure 10-8. Set Span Calibration 

  
Figure 10-9. Set Span Calibration (ROC300-Series and FloBoss 407) 

The Live Reading field displays actual value read from the sensor or I/O point. 

1. Enter the Dead Weight/Tester Value (in engineering units). This should correspond with 
the High Reading EU (100% Count) and is the high value to the input (the top end of the 
expected operating range). 

2. Click Set Span.  
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ROC300-Series and FloBoss 407 devices display: 
♦ Action – Describes the type of Action. Possible Actions are: Verify, Set Zero, Set Span, Set 

Mid 1, Set Mid 2, and Set Mid 3. 
♦ Entry –Expected or desired value. This is the entered Dead Weight/Tester value for point 

being verified/calibrated. 
♦ Reading – The actual (Live Reading) value read from the sensor or AI point. 
♦ Deviation – Difference between expected or entered value and the Live Reading. This is the 

Deviation from the actual versus the expected value in percent of range. 
     (Deviation = Entry – Reading).  

♦ %Deviation – Deviation as percent of range  
     (%Deviation = Deviation ÷ (Span EU – Zero EU) x 100%). 

10.2.4 Set Midpoints – Calibration 
If desired, calibrate Midpoint 1 (such as 25% of range) for the Differential Pressure (orifice only), Static 
Pressure, or Temperature, otherwise click the Done button. Midpoints allow you to specify the points 
between the Zero and Span endpoints.  

� Note: You can calibrate Midpoints in any order from low to high or high to low.  

The Point field displays the Point you are calibrating or verifying. 

The Live Reading field displays actual (Live Reading) value read from the sensor or AI point. 

 
Figure 10-10. Set Midpoints Calibration (ROC800-Series) 
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Figure 10-11. Set Midpoints Calibration (ROC300-Series and FloBoss 407) 

ROC300-Series and FloBoss 407 devices display: 
♦ Action – Describes the type of Action. Possible Actions are: Verify, Set Zero, Set Span, Set Mid 

1, Set Mid 2, and Set Mid 3. 
♦ Entry –Expected or desired value. This is the entered Dead Weight/Tester value for point being 

verified/calibrated. 
♦ Reading – The actual (Live Reading) value read from the sensor or AI point. 
♦ Deviation – Difference between expected or entered value and live reading  

     (Deviation = Entry – Reading). 
♦ %Deviation – Deviation as percent of range  

     (%Deviation = Deviation ÷ (Span EU – Zero EU) x 100%). 

To set the Midpoints: 

1. Click the Set Mid 1 button. 

If desired, calibrate Midpoint 2 (such as 50% of range) for the Differential Pressure (orifice 
only), Static Pressure, or Temperature. Set Midpoint 2 allows you to specify the middle 
calibration point between the Zero and Span endpoints. Enter the Dead Weight/Tester Value (in 
engineering units). 

2. Click the Set Mid 2 button. 

If desired, calibrate Midpoint 3 (such as 75% of range) for the Differential Pressure (orifice 
only), Static Pressure, or Temperature. Set Midpoint 3 allows you to specify a third point 
between the Zero and Span endpoints. Enter the Dead Weight/Tester Value (in engineering 
units). 

3. Click the Set Mid 3 button. 
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10.2.5 Zero Shift / Offset / RTD Bias – Calibration 
Zero Shift enables you to zero the static pressure effect for the Differential Pressure input 

 
Figure 10-12. Set Zero Shift (Offset) (ROC800-Series) 

1. If desired, after you have calibrated Differential Pressure, click Zero Shift to zero the static 
pressure effect for the Differential Pressure input. 

The Point field displays the Point you are calibrating or verifying. 

The Live Reading field displays actual (Live Reading) value read from the sensor or point. 

2. Apply the typical line pressure to both the high and low side of the sensor. 

3. Click Set Offset to send the value to the live reading to get the reading as close to zero as 
possible. 

4. Click the Done or Cancel button to close the dialog box. 

5. For a FloBoss 407 static pressure input, click Offset to calibrate the offset (shift) of static 
pressure, if desired. Enter a value for the Measured Pressure Reading. Click Set Offset to send 
the value to the live reading to get the reading as close to the measured reading as possible. Click 
the Done button to close the dialog box. 

6. For a FloBoss 407 temperature input, click RTD Bias to calibrate the offset (shift) of 
temperature throughout the RTD curve, if desired. Enter a value for the Temperature Standard 
Reading. Click Set Bias to send the value to the live reading to get the live reading as close as 
possible to the standard reading. Click the Done button to close the dialog box. 

10.2.6 Orifice Meter Calibration 
The Differential Pressure, Static Pressure, and Temperature inputs from an orifice meter can be 
calibrated. When calibrating Stacked Differential Pressure, you may calibrate either the low differential 
pressure (Low DP) input or the high differential pressure (Diff Pressure) input. 

 
If you have an MVS sensor, refer to the Sensor Calibration section in the ROC or FloBoss 
Accessories Instruction Manual (Form A4637) for the recommended way to remove/restore the 
MVS from/to working pressure during calibration. Failure to follow recommendations may cause 
sensor damage. 
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If you have a DVS Sensor, refer to the Calibration section of the appropriate FloBoss hardware 
manual for the recommended way to remove/restore the DVS from/to working pressure during 
calibration. Failure to follow recommendations may cause sensor damage. 

  
Figure 10-13. Orifice Meter Calibration Example (ROC800-Series) 

To calibrate a ROC800-Series unit input, select Meter > Calibration > Orifice. 

To calibrate a FloBoss 100-Series, ROC300-Series, or FloBoss 407 unit input, select Meter > 
Calibration. 

1. If you are calibrating a meter, select a specific Orifice Meter Run to verify and calibrate. Use 
the Meter Tag to verify the identity of the Meter Run. 

2. Click AutoScan or Update. AutoScan requests values from the meter until the Freeze or 
StopScan button is pressed. Update requests a single update of new values from the meter. 

3. Click Freeze to stop the values of the Differential Pressure, Low Differential Pressure (labeled 
Low DP), Static Pressure, and Temperature (RTD) from being updated during verification or 
calibration. 

4. Click the AutoScan or Update and then the Freeze buttons to create the Freeze Value used in 
ongoing processing, such as flow calculations and history logging, while calibration is being 
performed. The Calibration Freeze Values field displays the values received from the AI, MVS, 
DVS, or RTD when the Update button was last pressed. 
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Open the by-pass valve on the valve manifold prior to isolating the sensor from the process, 
to protect the differential cell of the Dual-Variable Sensor. This keeps one side of the 
differential sensor from being subjected to high pressure while the other side has no 
pressure applied. This is required when calibrating either differential or static pressure. 

5. If you are calibrating a pressure input, isolate the Sensor from the process. Set up the pressure 
calibrator and make the necessary connections to the Sensor.  

6. If you are calibrating a temperature input, disconnect the RTD sensor and connect a decade 
box (or comparable equipment) to the RTD terminals of the ROC or FloBoss. 

7. Click Calibrate. 

8. If desired during a meter calibration, select and specify a Calibration Report File. Select Yes to 
create a report text file containing calibration and verification details. Select No to continue 
without creating a report. If you select Yes, another dialog box appears. Refer to Calibration 
Report. 

9. Enter a value for Set Zero. 

10. Enter a value for Set Span. 

11. Enter values for up to three Midpoints. You will now return to the main Calibration screen. 

12. If calibrating a Differential Pressure input, click Zero Shift. 

13. For a FloBoss 407 static pressure input, click Offset. 

14. For a FloBoss 407 temperature input, click RTD Bias. 

15. Click the OK button to close the main calibration window and unfreeze the associated inputs. To 
calibrate the inputs for another Meter Run (if available), return to Step 1 to calibrate another 
input for the same Meter Run. 
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10.2.7 Turbine Meter Calibration 
The Static Pressure and Temperature inputs from a turbine meter can be calibrated. 

To calibrate a ROC800-Series unit, select Meter > Calibration > Turbine. 

To calibrate a FloBoss 100-Series, ROC300-Series, or FloBoss 407 unit, select Meter > Calibration. 

1. If you are calibrating a meter, select a specific Meter Run (Meter or Turbine Meter) to verify 
and calibrate. Use the Meter Tag to verify the identity of the Meter Run. 

  
Figure 10-14. Turbine Meter Calibration Example (ROC800-Series) 

2. Click AutoScan or Update. AutoScan requests values from the meter. It will continue to request 
values until the Freeze or StopScan button is pressed. Update requests a single update of new 
values from the meter. 

3. Click Freeze to stop the values of the Static Pressure, and Temperature (RTD) from being 
updated during verification or calibration. 

Press the AutoScan or Update and then the Freeze button to create the Freeze Values used in 
ongoing processing, such as flow calculations and history logging, while calibration is being 
performed. The Calibration Freeze Value field displays the value received from the AI, MVS, 
DVS, or RTD when the Update button was last pressed. 

4. If you are calibrating a pressure input, isolate the Sensor from the process. Set up the pressure 
calibrator and make the necessary connections to the Sensor.  

5. If you are calibrating a temperature input, disconnect the RTD sensor and connect a decade 
box (or comparable equipment) to the RTD terminals of the ROC or FloBoss. 

6. If desired during a meter calibration, select and specify a Calibration Report File. Select Yes to 
create a report text file containing calibration and verification details. Select No to continue 
without creating a report. If you select Yes, another dialog box appears.  
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7. Click the Calibrate button. 

8. Enter a value for Set Zero. 

9. Enter a value for Set Span. 

10. Enter values for up to three Midpoints. You will now return to the main calibration screen. 

11. Click the OK button to close the main calibration screen and unfreeze the associated inputs. To 
calibrate the inputs for another Meter Run (if available), return to Step 1. 

10.2.8 AI and RTD Calibration 
For FloBoss 100-Series, ROC300-Series, and FloBoss 407 RTD Input calibration, select Configure > 
I/O > AI Points > Calibration tab. 

For ROC800-Series RTD Input calibration, select Configure > I/O > RTD Points > Calibration tab. 

1. Select an RTD Input or Analog Input. 

2. Click Update to request one value update from the input. 

3. Click Freeze to stop the values of the input from being updated during verification or calibration. 

Click Update and the Freeze button to create the Freeze Value used in ongoing processing, such 
as flow calculations and history logging, while calibration is being performed. The Calibration 
Freeze Value field displays the value received from the AI or RTD input when the Update 
button was last pressed. 

Scan Mode indicates Normal or Manual. Normal indicates that the point scanning is enabled and 
is being updated each scan period. Manual indicates that the point is not in scanning mode. 

4. If you are calibrating a temperature input, disconnect the RTD sensor and connect a decade box 
(or comparable equipment) to the RTD terminals of the ROC or FloBoss. 

5. Press the Calibrate button. 

6. Enter a value for Set Zero after stabilization. 

7. Enter a value for Set Span after stabilization. 

8. Enter values for up to three Midpoints one at a time or click Done if you are not configuring 
Midpoints. 

9. Click the OK button to close the main calibration window and unfreeze the associated inputs. To 
calibrate the inputs for another AI or RTD, return to Step 1. 
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10.2.9 HART Calibration 
Select Configure > I/O > HART Points. A two point calibration routine can be run on HART inputs. 
The Calibration routine may only be run on devices when the channel is in Point to Point mode and 
when the device is in Skip this Device mode. 

  
Figure 10-15. HART Calibration 

Verify that the Communication Mode on the General tab is set to Point-to-Point. Open the Device tab 
and verify that the Poll Mode is set to Skip This Device. 

1. Select the Point Number to calibrate. 

2. Select the Calibration tab. 

3. Click Calibrate. 

4. Enter a value for Set Zero. 

5. Enter a value for Set Span. 

When returned to the Calibration tab, the calibration routine is complete. 
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10.3 Analog Input Calibration Values 
Select Utilities > AI Calibration Values to view all the calibration values for a specific Analog Input 
point, such as the Diff Pres (differential pressure).  

  
Figure 10-16. AI Calibration Values Example (ROC800-Series) 

Use the drop-down list box to select the AI Point you desire to view.  

The Tag for that point displays. 

Raw Value #1 is the lowest calibrated Raw A/D input, Raw Value #5 is the highest calibrated Raw A/D 
input. 

EU Value #1 to 5 are the five calibration settings in Engineering Units Values, converted from the Raw 
Values, based on the Low Reading EU and High Reading EU defined for the point. EU Value #1 is the 
Zero value, EU Value #5 is the Span value, and the rest are Midpoint values. 

Press Effect is the Zero Shift adjustment value; it is used as an offset to the calibrated EU Values to 
compensate for the working Static Pressure effect on a DP transmitter that was calibrated at atmospheric 
pressure. 

For the FloBoss 407, this field represents the static pressure offset for the Static input point and the RTD 
Bias value for the Temperature input. 

Set EU Value is the Tester Value specified for the last calibration value that was set.  

Manual EU is the Live Reading for the last calibration value that was set. 

The Timer field shows the last inactivity count-down in seconds (typically starting from 3600 seconds) 
that occurred during the last calibration session. Had the countdown reached 0, time-out would have 
taken place, causing the calibration mode to be automatically ended. 
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Calibration Mode indicates:  
0 = Use Current Calibration 
1 = Start Calibration 
2 = Calibrate 
3 = Restore Previous Calibration 
4 = Stop Calibration. 

Type indicates which calibration value is currently being set: 
0 = Inactive (no value) 
1 = Zero 
2 = Span 
3 = Midpoint 1 
4 = Midpoint 2 
5 = Midpoint 3 
6 = Zero Shift. 

10.4 RTD Input Calibration Values 
For a ROC800-Series, select Utilities > RTD Calibration Values to view all the calibration values for a 
specific RTD input point 

Not available for the FloBoss 100-Series. 

 
Figure 10-17. RTD Input Calibration Values 

Use the drop-down list box to select the RTD Point you desire to view.  

The Tag for that point displays. 

Raw Value #1 to 5 – Raw Value 1 is the lowest calibrated Raw A/D input, Raw Value 5 is the highest 
calibrated Raw A/D input. 
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EU Value #1 to 5 – The five calibration settings in Engineering Units values, converted from the Raw 
Values, based on the Low Reading EU and High Reading EU defined for the point. EU Value 1 is the 
Zero value, EU Value 5 is the Span value, and the rest are Midpoint values. 

Press Effect is the Zero Shift or RTD Bias adjustment value (applies only to points configured as the 
Differential Pressure input to a Meter Run) or temperature input (FloBoss 407). 

Set EU Value is the Tester Value specified for the last calibration value that was set. 

Manual EU is the Live Reading for the last calibration value that was set. 

The Timer field shows the last inactivity count-down in seconds (typically starting from 3600 seconds) 
that occurred during the last calibration session. Had the countdown reached 0, time-out would have 
taken place, causing the calibration mode to be automatically ended. 

Calibration Mode indicates:  
0 = Use Current Calibration 
1 = Start Calibration 
2 = Calibrate 
3 = Restore Previous Calibration 
4 = Stop Calibration. 

Type indicates which calibration value is currently being set:  
0 = Inactive (no value) 
1 = Zero 
2 = Span 
3 = Midpoint 1 
4 = Midpoint 2 
5 = Midpoint 3 
6 = Unused. 
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10.5 MVS Input Calibration Values (ROC800-Series and FloBoss 407) 
Select Utilities > MVS Calibration Values to view all the current calibration values for MVS Sensor 
points.  

  
Figure 10-18. MVS Input Calibration Values 

Click the Set To Factory Defaults button if you desire to return MVS Calibration values to their 
original values and reset the MVS.  

� Note: The MVS Address will be set to the default value of “1” and “MV Sensor” as the Sensor 
Tag. 

Use the drop-down list box to select the MVS Calibration or MVS Sensor point (sensor number) you 
desire to view. The Tag for the selected point displays. 

Differential Pressure is a display of the Differential Pressure calibration values currently used by the 
MVS Sensor. Manual Value is the value of the input at the time of the last meter “Freeze.” 

Static Pressure is a display of the Static Pressure calibration values currently used by the MVS Sensor. 
Manual Value is the value of the input at the time of the last meter “Freeze.” 

Temperature is a display of the Temperature calibration values currently used by the MVS Sensor. 
Manual Value is the value of the input at the time of the last meter “Freeze.” 
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SECTION 11 – UPDATES AND CHANGES 

This section describes how to update firmware, upgrade hardware, and change the size of an orifice 
plate. 

To upgrade or re-install ROCLINK 800 software, refer to Software Installation. 

In this Chapter 
Section Page 
11.1 Update Firmware .......................................................................................................................... 11-1 

11.2 Upgrade Hardware (FloBoss 100-Series) ..................................................................................... 11-5 

11.3 Plate Change ................................................................................................................................. 11-6 

11.1  Update Firmware 
The Update Firmware option updates the internal software (stored in Flash ROM) of a ROC or FloBoss 
unit by loading it from a file. This option does not update ROCLINK 800 software. Firmware cannot be 
updated over an Ethernet connection. 

� Note: Use caution as the Update Firmware procedure clears the configuration of the ROC or 
FloBoss unit and reloads data when the Restore functions are selected. The Event Log, Alarm 
Log, and History logs are cleared. If you want to preserve the contents of the Event and Alarm 
Logs, be sure to save them to a file (Collect Data procedure) before starting. Note that the Event 
and Alarm Logs cannot be reloaded. 

1. Create a backup copy of the firmware update disk or download the firmware file from the 
Emerson website. 

2. Read the README text file included with the firmware update.  

3. Select Utilities > Update Firmware.  

4. Select the Save Device Configuration Before Firmware Update checkbox to save the current 
configuration, calibration, and communication settings, and FSTs to the specified directory.  

5. Select the Restore Device Configuration After Firmware Update checkbox to restore the 
configuration file after the update. Use the Browse button to define the path and file name in the 
Config File or File Name field. 

� Note: The configuration may also be saved during an update by saving the configuration to 
Flash memory on the ROC > Flags screen before performing the update. 

6. Navigate to the File Name or Image File using the Browse button to select the location where 
you desire to store the Device Configuration. 
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Figure 11-1. Update Firmware Example (ROC300-Series and FloBoss 407) 

7. Use the Browse button to locate and select the proper Image File that will be used as the new 
firmware code in the ROC or FloBoss unit.  

� Note: The ROC800-Series displays a file extension .dli, the FloBoss 100-Series displays a 
file extension .bin, and the FloBoss 407 and ROC300-Series displays a file extension .lst. 

8. Click the Start button and verify the version number and file name of the firmware file to be 
replaced and the file to replace it. 

9. Click OK. 

10. For a ROC300-Series, FloBoss 100-Series, or FloBoss 407, click Yes to confirm the update. 

The loading process typically takes several minutes; do not disturb it during this time. When 
loading of the firmware is complete, the configuration files are automatically loaded into the 
ROC or FloBoss (if the restore configuration option was selected) and the actions are recorded in 
the Event Log.  

When re-loading of backups is complete, a message appears saying “Reconnect to Device 
Completed.” You can verify the upgrade on the Other Information or Revision Info tab of the 
ROC > Information screen. 

11. Perform a Cold Start to reload the configuration from Flash memory, if it was saved to Flash 
memory. Check the configuration and FSTs; and if they are not correct, reload them from the 
disk files created in Step 4. 
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11.1.1 Update Firmware – I/O Termination Board 
I/O Termination Board allows you to view the currently installed firmware version and download a new 
Firmware Image. 

 
Figure 11-2. I/O Termination Board 

Firmware Currently Installed – Displays the currently installed firmware information. 

Firmware Image to Download (I/O Termination Board Tab) – The path and name of the Firmware 
Image to Download. Click the Browse button to locate the Firmware Image. 
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11.1.2 Update Firmware – Keypad Display (ROC800-Series) 
Select Utilities > Update Firmware. Click the Keypad Display tab to upgrade the Firmware associated 
with the ROC800-Series Keypad Display. 

 
Figure 11-3. Update Firmware – Keypad Display (ROC800-Series) 

Firmware Currently Installed – Displays a Description and Current Version of the Firmware stored in 
the Keypad Display. 

Flash File System – Displays the total Space Remaining in Bytes for Firmware storage. 

File Name – Click Browse to locate the Firmware Image to Download. 

File Information – Display information about the file selected to be downloaded. 

Status – Current Status of the download. 
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11.2 Upgrade Hardware (FloBoss 100-Series) 
When you replace the Termination Board in a FloBoss 100-Series unit, you should select Utilities > 
Upgrade Hardware and follow the procedure to save configuration, remove power, remove hardware, 
install new hardware, connect power, and download configuration. 

Check the configuration for that device and the Point Numbers in the FSTs, PID loops, and historical, 
EFM, Event and Alarm Logs that may be affected. 

 
Figure 11-4. Upgrade Hardware 

� Note: The I/O Setup screen (FloBoss 100-Series) will display whether the termination board is 
detected as the 4 point I/O or the 6 point I/O. 
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11.3 Plate Change 
The Plate Change option allows you to change the size of an orifice plate under flowing or non-flowing 
conditions. 

1. Select Meter > Plate Change to record an orifice plate change.  

2. Select the correct Meter Number for the Meter Run you are changing.  

3. Select Yes if the Plate Change occurs during flowing conditions. You will be allowed to freeze 
the inputs for the duration of the Plate Change process. Click No for non-flowing conditions. 

4. Click Freeze if you are performing the Plate Change under flowing conditions, the dialog box 
shows you the Freeze Value of each meter input (for the purpose of calculating gas flow) while 
the change is being made. All I/O values are held in Manual Mode at the current value. The 
values are returned to an active state after clicking OK in the Plate Change dialog box.  

 
Figure 11-5. Plate Change 

Pipe Diameter displays the size of the pipe diameter for the meter selected. 

5. Enter the exact size of the Orifice Diameter (inches or millimeters) of the new plate. 

6. Click Apply to record the change creating a record in the Event Log and restart the flow 
calculation using the new orifice size data. 

7. Click OK. 
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SECTION 12 – DISPLAYS, DIAGNOSTICS, AND 
MONITORING 

This section describes the various methods in ROCLINK 800 software to monitor and run diagnostics 
on the ROC or FloBoss in your application. The user can configure the LCD on a FloBoss 100-Series, 
ROC300-Series, or FloBoss 407 unit for routine monitoring, print a copy of the configuration to check 
for error in the configuration file, view a Meter Run Values screen to check parameter values for the 
meter, view an I/O Monitor screen to check I/O and other operations, view the Pulse Interface Module 
Data screen to monitor the Pulse Interface Module of a FloBoss 104, or create a custom display to 
monitor routine or user program operations. 

In this Chapter 
Section Page 
12.1 Print Configuration ....................................................................................................................... 12-2 

12.2 I/O Monitor ................................................................................................................................... 12-3 

12.3 LCD Display Configuration (ROC300-Series)............................................................................. 12-5 

12.4 LCD User List (FloBoss 100-Series and FloBoss 407) ................................................................ 12-6 

12.5 Meter Run Values ......................................................................................................................... 12-7 

12.6 Custom Displays ........................................................................................................................... 12-9 

12.7 Keypad Display Editor Configuration ........................................................................................ 12-16 
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12.1 Print Configuration 
The Print Configuration option allows you to specify the Point Types that you desire to Print. 

1. Select File > Print Configuration. 

2. Select the Point Types you desire to print. You may either use the Select All or Deselect All 
buttons for multiple Point Types or select/deselect individual Point Types by clicking with the 
mouse on the Point Type in the left hand column and selecting specific Parameters in the right 
hand column. 

 
Figure 12-1. Print Configuration 

3. Click OK. Wait for the information to preview on the screen. 

4. When the Print Preview screen appears, you may choose one of the following buttons: 
♦ Print to send to a local printer. 
♦ PDF to create a .pdf (Portable Document File). 
♦ Excel to create an .xls spreadsheet file. 
♦ RTF to create an .rtf (Rich Text Format) file. 
♦ TXT to create a .txt text file. 
♦ HTML to create an .htm Internet browser file. (ROC800-Series) 

The Device Group, Device Address, Station Name, Field, and Value information displays in the Print 
Configuration results window. 
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12.2 I/O Monitor 
Select View > I/O Monitor. Use I/O Monitor to view all installed and active I/O points, MVS values, 
and flow calculations that provide information configured in the ROC or FloBoss and its operating 
environment.  

Select the checkboxes that you desire to monitor. 
♦ Select All – Selects all checkboxes. 
♦ Deselect All – Deselects all checkboxes. 

After selecting the monitor functions and clicking OK, a screen appears that shows the requested point 
information, such as field I/O values or calculated flow values. These on-screen values are automatically 
updated by ROCLINK 800 software.  

  
Figure 12-2. I/O Monitor 
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Figure 12-3. I/O Monitor Values 
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12.3 LCD Display Configuration (ROC300-Series) 
Select Configure > LCD. The LCD Display Configuration is used to configure the LCD for a 
ROC300-Series unit with a FlashPAC that has an optional Local Display Panel (LDP) connected to it. 
The configured parameters may also be changed from the LCD. 

When setting up a LCD point, only the top three lines of the display area are configurable. The bottom 
line is reserved for the function key definition. The first ten characters (columns) of each line are used 
for text identifiers of the data contained on the rest of the line. The specified data displays, starting at 
character position (column 12 in the format “n.nn”). 

As many as eight displays can be configured to display a variety of function and database parameters. 

  
Figure 12-4. LCD Display Configuration (ROC300-Series) 

1. Select Configure > LCD and select the Display Number. 

2. Click on the Line Value TLP button. Select the parameter for the Value field. Because text 
characters cannot display in the Value field, select only parameters that return a numeric value. 

3. Enter the Text (up to ten characters) to appear on the Local Display Panel. The Text should 
describe the Value selected for this line. 
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12.4 LCD User List (FloBoss 100-Series and FloBoss 407) 
LCD User List Setup allows you to assign up to 16 parameters for viewing on the optional FloBoss 
display, which shows each parameter for several seconds before continuing on to the next parameter in 
the sequence. 

� Note: This function is not available for the ROC800-Series. 

1. Select Configure > LCD User List. 

  
Figure 12-5. LCD User List  

2. Select the LCD User List Number that you desire to configure. 

3. Enter the Text to describe the Parameter to be viewed on the LCD. The description has a 10-
character limit. Only 1 through 5 display on a FloBoss 100-Series unit. 

4. Select the Device Parameter that you desire to view on the LCD. “Undefined” indicates that no 
parameter has been specified. The Device Parameter must be numeric only. For example, System 
Variables > SYS 1 > Station Name is not supported. 

5. When using a ROC300-Series unit, select the Line Value you desire to view on the LCD. 
“Undefined” indicates that no parameter has been specified. 
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12.5 Meter Run Values 
The Meter Run Values screens display the values from the orifice or turbine meter upon update. These 
may be used for diagnostics or monitoring. 

For the ROC800-Series, select either Meter > Values > Orifice or Meter > Values > Turbine. 

For the FloBoss 100-Series, ROC300-Series, or FloBoss 407, select Meter > Values. 

 
Figure 12-6. Meter Run Values Example (ROC800-Series – Orifice) 
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Figure 12-7. Meter Run Values Example (ROC800-Series – Turbine) 

Select the number of the Meter Run that you wish to monitor. You can verify the choice in the meter 
Tag and Description fields. This information was entered in the meter configuration screen. 

The current values of the Differential Pressure (orifice), Uncorrected Volume (turbine), Static 
Pressure, and Temperature for the meter selected will display. 

Current Values displays the current Flow Rate, Energy Rate, and Mass Rate.  

Accumulation displays accumulated flow, energy, flowing minute, and mass values.  

Factors displays current status of calculated and entered parameters of the meter. These values are 
calculated by the firmware. 
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12.6 Custom Displays 
Select View > Display. The custom display option in ROCLINK 800 software allows you to create 
customized PC displays or load a display from a disk file. You can add fields to monitor flow, I/O 
points, and other TLPs.  

The display can incorporate “live” data, as well as images and other information you may wish to 
convey. One use of custom displays is to graphically represent the application that a ROC or FloBoss is 
monitoring and controlling. A second use is to monitor the ROC or FloBoss and to allow the user to 
change commonly used parameters from a single screen.  

Each Custom Display has parameters specific to the entire Display that you are creating. By default, the 
Object Properties box displays at the right of the screen in a pop-up window. 

Drag and drop the menu Option buttons from the tool button bar to the Custom Display screen and set 
the associated parameters. Each Option has parameters associated with it depending on the type of 
option you have selected and you can customize the parameters in the Object Properties box.  

� Note: Custom Displays are not compatible between ROCLINK for Windows and ROCLINK 
800 Configuration Software. 

 
Figure 12-8. Display Editor 
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12.6.1 Custom Displays – New Display 
To create a new display:  

1. Select View > Display > New. The Display editor will open. 

2. Specify the Custom Display properties:  

♦ Display Name – Enter text describing the entire display. 
♦ Logical Point List – If Disabled, only one iteration (logical) of the display is created. When 

Enabled, multiple logicals of the display are created. The number of logicals is based on the 
number of logicals in the first point selected in the Point Type(s) field. 

♦ Point Type List – When a Logical Point List is Enabled, select the Point Type whose logical 
will track the iteration of the display. 

♦ Picture – Select a graphic to be used for the background of the display. 

Advanced Features 
♦ Menu Location – Replace, Rename, or Hide the menu selection in the ROCLINK 800 menu. 

This applies only to displays that are resident in the ROC or FloBoss and not for displays on 
disk. 

♦ Hide – Hide a menu selection in the Meter, View, or ROC menu.  
Syntax – H:menuname.submenuname 

Example – H:Meter.Plate Change 

♦ Replace – Replace a current screen in the Meter menu with the Custom Display.  
Syntax – R:menuname.submenuname 

Example – R:Meter.Setup 

♦ Rename – Replace a current screen with the Custom Display and rename the menu selection.  
Syntax – N:menuname.submenuname:newsubmenuname 

Example – N:Meter.Calibration:Coriolis Cal 

� Note: To Hide, Replace, or Rename multiple features, separate features with a comma.  
Example – N:Meter.Calibration:Coriolis Cal, N:Meter.Calibration:Central Cal 

♦ Tree Location – Currently unavailable. 
♦ Update Mode – Select Normal for the display to remain in the current state when displayed. 

Select Auto Scan to allow the display to automatically update when viewed. 
3. Drag and drop Objects from the toolbar to the Custom Display. For details on the elements, refer 

to Custom Display – Objects. 

Create as many Objects as you desire. Objects may be placed anywhere on the Display Editor 
screen. Certain Option should be placed within a Frame, such as for Option Buttons or Check 
Boxes to logically group them with a label so the user knows what the Option means.  

4. For each Object, enter or select the desired data in the Object Properties box. The items in the 
Object Properties box depend on the Object you have added. You may edit the Object Properties 
of each Object at any time.  
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5. Move and re-shape Objects within the display. To modify Object placement or shape: 

♦ Click and drag on the control squares to change the size of the Object. 
♦ Press the <Shift + Arrow Keys> to change the size of the Objector <Shift +Alt + Arrow 

Keys> for smaller changes. 
♦ Press the <Ctrl + Arrow Keys> to move the Object to the desired position or <Ctrl + Alt + 

Arrow Keys> for smaller moves. 
♦ From the Icon bar, select Align lefts to align all selected Objects to the furthest left point in 

the group. 
♦ From the Icon bar, select Size to widest to change the width of all selected Objects to the 

width of the widest element. 
♦ From the Icon bar, select Make Vertical Spacing Equal to evenly adjust the vertical spacing 

between all the selected Objects. 
♦ From the Icon bar, select Make Horizontal Spacing Equal to evenly adjust the horizontal 

spacing between all the selected Objects. 
6. Objects can be removed, by selecting the Object and pressing the <Delete> key. 

7. Click the Test button to verify that the Custom Display works correctly. 

8. Click the Save Display to File button. 

12.6.2 Custom Displays – Objects 
Select View > Display. Objects can be added in one of two ways.  

♦ Select an Object from the icon bar and drag it to the area of the display where you want the 
display Object to appear. 

♦ Place the cursor where you want the display Object to appear. Right-click on the mouse, and 
select an Object. 

 
Figure 12-9. Display Editor Objects 
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The Objects selections are: 
♦ Tab Control – Separate a large number of elements with a Tab to group user selections onto the 

appropriate tab. Once a Tab is in place, drag and drop Objects onto the Tab. 
♦ Add Frame – Place like Objects within a Frame to group user selections. Once a Frame is in 

place, drag and drop Objects onto the Frame. 
♦ Add Label – Use labels to mark other Objects. 
♦ Add Text Box – Creates data entry fields. 
♦ Add Check Box – Creates boxes for multiple selections. 
♦ Add Option Button – Create radio buttons to limit input to a single selection. 
♦ Add Combo Box – Create a list of options that limit input to a single selection. 
♦ Add Line – Use lines to mark borders between Objects. 
♦ Add Rectangle – Use rectangles to mark borders between Objects. 
♦ Add Oval – Use ovals to mark borders between Objects. 
♦ Add Picture – Add an image from a file. 
♦ Add Chart – Create a chart to represent data graphically. 
♦ Add Pushbutton – Create a button to write data to the ROC or FloBoss. 

12.6.3 Custom Displays – Object Properties 
Select View > Display. The items in the Object Properties box depend on the Object you have added. 
You may edit the Object Properties of each Object at any time.  

The Object Properties box allows you to: 

♦ Enter a Caption for the item. This applies to tabs, frames, labels, option buttons, and check 
boxes. When used in tabs, the captions will appear at the top tab edge. 

♦ Enter the number of Tabs to appear in this tabs element. The minimum is 1, and maximum is 8. 
♦ Enter the Text you desire to appear in a Text box Object. 
♦ Enter a Header to run at the top of the chart. This applies only to charts. 
♦ Select a TLP whose value will show in the display. This applies to labels, text boxes, option 

buttons, checkboxes, combo boxes, and charts. 
♦ Enable the Allow Data Entry. This creates a R/W field that will allow the user to write 

parameters/values to the ROC or FloBoss. This applies to frames, text boxes, option buttons, 
checkboxes, and combo boxes.  

♦ If you select Expression, refer to Adding an Expression to a Display Element. 
♦ Select the Alignment of text: left, right and center. This applies only to labels. 
♦ Enter a Mask Value. The default is 255. This applies to option buttons and checkboxes. 
♦ Select a Picture to add to your Custom Display. 
♦ Enter a value in the Selected When = field. It allows you to create a radio button that will be 

selected when a specified value for that specific TLP is read from the ROC or FloBoss. This 
applies only to Option radio buttons. 
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♦ Enter a value in the Checked When = field. It allows you to create a Check Box that will be 
selected when a specified value for that specific TLP is read from the ROC or FloBoss. This 
applies only to Check Box buttons. 

♦ Select the Action to be performed by the Pushbutton. 
♦ Enter the Value to be written when the Pushbutton is clicked. 
♦ Click the button in the Item List field to enter Item Values and List Items. This applies only to 

combo boxes. 
♦ Enter a Line Width to increase or decrease the thickness of the line. 
♦ Select the Color. Click on the button in the Color field to open a color palette. This applies to 

lines, rectangles, and ovals. 
♦ Enable Visible when the element is to appear to the user in the final version of the display. This 

applies to frames, labels, text boxes, option buttons, checkboxes, combo boxes, and pictures. If 
you select Expression, refer to Adding an Expression to a Display Element. 

♦ Set the Tab Order of this element after all objects have been created. When the user is 
navigating the display, the Tab key on their PC follows the order entered. This applies to frames, 
labels, text boxes, option buttons, check boxes, and combo boxes.  

12.6.4 Editing a Custom Display From a File 
Select View > Display > From File. The From File option reads a display from a previously saved .DSP 
file, translates the data fields, and updates the data.  

1. Select View > Display > From File. 

2. Select the display File name. Display files have the .DSP extension. 

3. Click Open. 

4. Click Update to update data for the existing display elements. 

5. Click Edit to add, edit or remove elements from the display. Follow the element steps in New 
Display. Be sure to Save changes to the display after editing. 

12.6.5 Adding an Expression to a Custom Display Object 
Some of the Custom Display Objects allow Visual Basic Expressions to be built that will cause the 
display to change under specific conditions. Users creating display element expressions should have 
experience with Visual Basic programming. 

Expressions may be added to the following elements: tab, label, text box, option button, pushbutton, 
checkbox, combo box, line, circle, square, and image. 

If the Allow Data Entry or Visible property of an element is set to Expression, click on the button with 
three dots in the property box. The Expression Builder screen will appear. 

To create an Expression: 

1. Select View > Display > From File. 

2. Select the display File name. Display files have the .DSP extension. 

3. Click Open. 

4. Click Update to update data for the existing display elements. 



ROCLINK 800 User Manual 

Rev. Dec-05 Displays, Diagnostics, and Monitoring 12-14 

5. From the three list boxes in the center of the screen, select a category from the left box.  

6. Select a subcategory from the center box.  

7. Select an item from the right box.  

As you select from the list boxes, definitions of the categories and items will appear below the 
list boxes. 

8. Click the Add button. 

You may select items from the list boxes as many times as your expression requires. 

9. From the buttons below the Expression preview pane, select the TLP... button to configure a 
specific TLP to this expression. 

10. From the buttons below the Expression preview pane, select the logical operations that your 
expression requires. 

11. When the expression is complete, click Apply. 

12. Click OK to approve and return to the Display Editor. Saving the display file at this point is 
highly recommended so that you save the expression. 

 
Figure 12-10. Custom Display Example 
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12.6.6 Display Administrator 
Select View > Display > From Device > Display Administrator to access Custom Displays stored in 
the ROC800-Series unit (with firmware version 1.20 or greater). The ROC800-Series can store a 
maximum of 246 Displays (Custom User Displays and User Program Displays).  

  
Figure 12-11. Display Administrator (ROC800-Series) 

To access a display file stored in the ROC unit, select a display from the list of Custom User Displays 
Installed in the ROC.  

This screen will also download user-designed displays to the ROC. To download a display file once a 
display has been created and saved to disk file, use the Browse button to search for the display file and 
download it. 

The Flash File System information may be used to determine how much space is available before 
downloading displays. 
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12.7 Keypad Display Editor Configuration 
Select Utilities > Keypad Display Editor to create and edit Keypad Display files for the ROC800-
Series unit. These files may be stored on the PC or downloaded to the ROC unit. While in use on the 
ROC Keypad Display, the display file resides in the configuration memory of the ROC unit. 

� Note: Keypad Display files have the extension .dcfg.  

The Keypad Display editor is available while on-line with a ROC800-Series unit that has a ROC Keypad 
Display connected. 

The Keypad Display is intended to display and allow interaction with TLPs in the ROC database. An 
understanding of TLPs is crucial to configuring a Keypad Display file. TLP refers to Point Type, 
Logical number (Instance), and Parameter. For example, TLP DIN 4-2, ACC is the Accumulated Value 
parameter of channel 2 of the Discrete Input module in slot 4. This TLP can also be expressed 
numerically as 101, 4-2, 6. 

12.7.1 Creating a New Keypad Display File (ROC800-Series) 
Display files may be created in one of two ways: by editing an existing file or by creating one in the 
editor. When you create a new display file in the editor, you should follow the steps below. 

1. Select Utilities > Keypad Display Editor.  

 
Figure 12-12. Keypad Display Editor 
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2. Right-click on the Main Menu in the Hierarchy Menu in the left pane of the editor.  

3. Select Add Menu as many times as your display requires. 

The Hierarchy Menu determines the navigation for the display. Each level in the Hierarchy 
Menu represents a screen with menu choices. Add menus and screens to each level in the 
Hierarchy Menu to suit your application. 

4. Right-click on a menu in the Hierarchy Menu and select Add Screen. Then select the type of 
screen. 

♦ User scrollable – This screen displays and interaction with TLP names and values. 
♦ Events – This screen displays the Events log. This type of screen can only be inserted in a 

display file once. 
♦ Alarms – This screen displays the Alarms log. This type of screen can only be inserted in a 

display file once. 
♦ Screen Saver – This screen provides a scrolling list of parameters that will appear when no 

user is logged on. The function of the screen saver is the same, no matter where in the 
Hierarchy Menu it is placed. This type of screen can only be inserted in a display file once. 

♦ Calibration – This screen allows the user to perform a deadweight calibration of the I/O 
channels for which calibration is appropriate. This type of screen can only be inserted in a 
display file once. 

5. When the required number of menus and screens have been added, it is good practice to save the 
file to the PC. Use the Save As button in the right pane of the editor. ROC Keypad Display files 
save with the extension .dcfg. A display file be saved in a.800 configuration file using the 
Download button (on-line) or the Save button (off-line). 

6. The screens will now require editing to select TLPs and assign security. Refer to the steps in 
Editing a Display File. You will save the file again and download it to the ROC unit after editing. 

12.7.2 Update Keypad Display Firmware (ROC800-Series) 
The firmware in the Keypad Display can be updated while connected by a serial or TCP/IP (Ethernet) 
communications connection. 

1. The updated firmware files are typically supplied on in a .zip file. It is recommended that you 
create a backup copy of the firmware update file after you unzip the file. 

2. Read the README text file included with the firmware update.  

3. Select Utilities > Update Firmware and select the Keypad Display tab.  

4. Click the Browse button and navigate to the new firmware file on the PC. 

5. Once the file is found, click the Start button. The update may take a while, do not interrupt the 
update while it is in progress. 

6. Click the OK button when the Firmware Update Completed dialog box appears. 
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12.7.3 Editing a Keypad Display File 
You may edit an existing Keypad Display file using the Keypad Display Editor. A default file (typically 
named display_config.dcfg) may be used in its current state or customized to suit your application. The 
default file is available with ROCLINK 800 software (version 1.50 or greater). To modify a display file: 

1. Select Utilities > Keypad Display Editor. 

2. Click the Read Device button in the right pane of the editor (if file is stored in the ROC unit) or 
the Open File button (if file is saved on the PC) to open the Display. 

3. Rename menus by right clicking on the menu title in Hierarchy Menu and selecting Rename. 

4. Rename User Scrollable screens and the Screen Saver by clicking once on the screen name in 
the Hierarchy Menu and typing the new Title that will appear both in the editor and on the ROC 
Keypad Display screen. 

5. Edit the TLPs, display parameters, and security settings for the User Scrollable screens. 

6. Enter the Title for this configuration file. Use of all uppercase letters is recommended. 

7. When the Keypad Display is in use (logged on), the value listed for On Open TLP will be written 
to the TLP selected here. When the Keypad Display is no longer in use (logged off), the value 
listed for On Close TLP will be written to the TLP selected here. 

8. You can scroll through the logical instances of the point types assigned in the Point Types field. 

9. Line Entries can be added, deleted, or moved. Each line represents one line on the display. Each 
field of the entry is configured separately. However, a command to add, move, or delete the entry 
will add, move or delete the entire line. 

10. Once an entry has been created, the parameters in the Field section become available, if 
appropriate to that entry. 

11. If the field highlighted in the entry is to have manually entered text or numbers, select a Value of 
Manual Value. If the field is to have a parameter name in full, select Parameter Name. If the 
field is to have an abbreviation of the Parameter Name, select Parameter Abbreviation. If the 
field is to have the value of the parameter, select Parameter Value. 

12. If the Value selected was Manual Value, then enter the text or number in the Text field. 

13. If the Value selected was Parameter Name, Parameter Abbreviation, or Parameter Value, then 
select the TLP to be displayed. 

14. Select Read-Only if the TLP selected is to be a display only on the Keypad Display. If not 
selected, the TLP will be Read-Write if the keypad user has Read-write privileges to TLPs in that 
access group. Note that only one field in an entry line can be R/W.  

15. For the Line Entry highlighted, Justify determines whether the text or numbers in the entry field 
will be right or left justified. Length determines the maximum length of the text or numbers in 
the entry field. 

16. In some circumstances, when the Value selected was Parameter Value, the user will be allowed 
to provide text to go before or after the value. Leading and Trailing Text will allow units of 
measurement or some other text to appear on the screen. 

17. In some circumstances, when the Value selected was Parameter Value, the user will be allowed 
to specify whether the Data Format will be the default that has a precision of two characters or 
another manually entered precision. 
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18. Edit the security settings for the Events, Alarms, and Calibration screens. The checkboxes will 
determine the type of access (Read/Write or Read/Only) and types of data available for each 
user. 

19. The Group Access checkboxes determine the type of access (Read/Write or Read/Only) and 
types of data available for each user. 

20. The User Access checkboxes determine the type of access (Read/Write or Read/Only) and types 
of data available for each user. 

21. If a Screen Saver is appropriate to your application, edit the screen saver TLPs and display 
parameters. The parameter definitions are given in Step 5. 

22. Once you have completed your modifications to the display file, it is good practice to save it to 
the PC. Click the Save As button and save it with a new name or write over an existing file. ROC 
Keypad Display files have the extension .dcfg. The display files are also saved in the .800 
configuration file. 

23. Once the file has been saved, download it to the ROC unit by clicking the Download button. Be 
sure to let the file download without interruption. Before downloading the file, verify that the 
ROC comm port has been assigned to LCD (Comm Port Owner field on ROC > Comm Ports).  

12.7.4 Keypad Display Security (ROC800-Series) 
Select Utilities > Keypad Display Editor. Security is provided by the Keypad Display to control user 
access to information. Users are placed in “groups” having an assigned access level. Within each group, 
individuals can be assigned an additional level of access that overrides the group access level. Display 
screens can be customized to allow users to view and edit parameters, view parameters only, or have no 
display access based on their group or individual access level. Typically, group or individual access is 
assigned based on job function. Each user within a group assumes the group’s access level. However, an 
individual user can be granted or denied access to a specific display based on their individual access 
level.  

For example, consider John, Joe, and Pat to be members of a “Technicians” group that is allowed to 
view and edit the PID display. Joe can be prevented from changing the set point of a PID loop if he is 
assigned individual access that restricts him to viewing only. The rest of the group members are 
unaffected by Joe’s individual restriction. 

If a user is assigned to more than one group, each with different access levels, the user assumes the 
access level of the highest group for all of their assigned groups.  

For example, if John is in the Technician group, which is given access to edit and view, and he is also 
assigned to the Meter Setup group, which only has view access, he automatically has edit access in the 
Meter Setup group because of his membership in the Technician group. However, if the he is assigned 
individual access, he may be restricted to viewing only in the Meter Setup group.  

� Note: The User Access and Group Access lists are established on the Configure > ROC Security 
screen. For more information on security in the ROC unit, refer to Device Security. 

The Group Access checkboxes determine the type of access (Read/Write or Read/Only) and types of 
data available for each user. 

The User Access checkboxes determine the type of access (Read/Write or Read/Only) and types of data 
available for each user. 
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APPENDIX A – FST EDITOR 

A.1 FST Editor 
This section describes the Function Sequence Table functionality in ROCLINK 800. 

In this Chapter 
Section  Page 
A.1 FST Editor...................................................................................................................................... A-1 

A.2 Function Sequence Table Introduction .......................................................................................... A-1 

A.3 FST Registers................................................................................................................................. A-3 

A.4 FST Editor...................................................................................................................................... A-5 

A.5 Working with FSTs...................................................................................................................... A-10 

A.6 Monitor Mode .............................................................................................................................. A-13 

A.7 FST Command Library ................................................................................................................ A-16 

A.2 Function Sequence Table Introduction 
The Function Sequence Table (FST) capability is provided as an instruction list programming language 
that allows you to define and perform a set of specific actions when a set of conditions exists. FSTs can 
be written specifically for applications that require special control features, such as logic sequencing 
capability. For example, you can use an FST for emergency shutdown control when a parameter exceeds 
a low or high limit or in any application that requires logic sequencing capability. FSTs are programmed 
and configured using the FST Editor, which is embedded in the ROCLINK 800 configuration software.  

An FST defines the Input-to-Output (I/O) relationships in the Remote Operations Controller (ROC) or 
FloBoss through a set of user-selected instructions, called Functions. Functions, which define the 
specific actions to be performed, are executed in their specified sequence. The Functions are normally 
executed in top-to-bottom order; however, the sequence may be altered by certain decision-making 
functions. Functions consist of a Command, Argument, and optional Label. 

An FST is built from a library of Commands that provide mathematical and logical operations, database 
access operations, historical commands, testing, and branching operations, and control-related 
operations.  

The Devices, Software, and FST Functionality table displays the ROC and FloBoss devices and their 
FST capabilities.  

Each FST may consist of as many functions as can fit into the memory reserved for the FSTs. Reserved 
memory is pre-determined by the ROC or FloBoss with a set amount of Steps allocated for each FST. 
The byte size of an FST displays in the Code Size field on the FST Registers > Advanced tab.  

Each individual FST in a ROC800-Series unit executes up to Steps in any given 100 mSec interval. 
However, it does not guarantee that 10 instructions will execute for a given FST within a 100 mSec 
interval. Factors that affect this include processor load (during the interval), instruction, and argument 
type (constant or value from other tasks, such as Meter Runs). When six FSTs are running, the 
maximum number of steps executed would be 60. 



ROCLINK 800 User Manual 

Rev. Dec-05 FST Editor A-2 

Each FST in a FloBoss 100-Series unit executes a configurable number of instructions per second. By 
default, the FST executes 20 Steps per execution period. If an FST has 30 sequential Steps, the first 20 
Steps execute during the current execution period and remaining 10 Steps execute during the next 
execution period. To configure the number of Steps executed, select ROC > Information. In the Device 
Information screen, enter a value between 1 and 100 in the FST Execution Instructions per Cycle field 
and click Apply. Cycle is the execution period, which is 1 second in a FloBoss 100-Series. 

The new number of Steps to execute takes effect the next execution period. Restart is not required. 

Each FST in a FloBoss 407 and ROC300-Series unit executes as many Steps of FST code as processor 
free time allows every 100 mSec. When a time slice completes, another task is given the opportunity to 
execute. If the FST task does not complete in the allotted time, the FST task uses whatever time is left 
over from other tasks to attempt to complete the sequence of functions. If the FST task executes in less 
than the time allotted, the remaining time can be used by the operating system to perform other tasks.  

Because of the potential loading increase on the system, it is recommended that you monitor the Master 
Processor Unit (MPU) loading to ensure that the FST is not consuming too much of the MPU’s 
resources. 

� Note: It is good practice to insert WAIT (WT) commands or make sure an END command is 
encountered to reduce processor loading. 

As the sequence of functions executes, two memory locations store intermediate results from one 
function to the next.  

♦ One location, called the Results Register (RR), stores a floating-point value referred to as the 
Signal Value Analog (SVA).  

♦ The other location, called the Compare Flag (CF), stores a discrete value called the Signal 
Value Discrete (SVD).  

Depending on the Command, the Results Register (RR) and the Compare Flag (CF) may be loaded, 
stored, tested, modified, or left unchanged.  

� Note: FST Registers, including the Run Flag, are always cleared upon restart; therefore, use 
Softpoints to load initial values for the FST. 

Table A-1. Devices, Software, and FST Functionality 
 

ROC or FloBoss Maximum Number 
of FSTs Maximum Byte Size per FST Maximum Line Length*

FloBoss 100-Series 2 3000 300 
FloBoss 407 and ROC300-Series 4 8000** 300 

ROC800-Series 6 3000 500 

* Maximum number of Steps is a limit of the FST Editor. 

** Total FST space in ROC300-series and FloBoss 407 units is 8000 bytes. Individual FST size is not limited, 
but the sum of all FSTs cannot exceed 8000 bytes. 
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A.3 FST Registers 
The FST Registers screen allows you to control and View the FST operation without opening the FST 
Editor. 

 
Figure A-1. FST Registers – General (ROC800-Series) 

1. Select Configure > Control > FST Registers.  

2. Click the Advanced tab. 

 
Figure A-2. FST Registers – Advanced (ROC800-Series) 
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Use the FST drop-down list box to select the FST. 

Enter the FST Tag as a 10-character name identifying the FST Register point (optional). 

The Version number and Description of the FST displays entered when the FST is downloaded. 

FST Status shows the current state and allows for the starting and stopping of the FST. This turns the 
associated FST on or off by selecting or deselecting the correct radio button and clicking Apply.  

Registers R1 to R10 may be used to store floating-point values. The ROC or FloBoss allows you to 
assign a Tag to each Register. 

The FST Registers can store calculated or manually-entered values and can pass data from one FST to 
another. That is, the FST can write values to the Registers and the FST can also read the values stored in 
the FST Register storage points. These Registers may be read from, or written to, any FST configured 
for the ROC or FloBoss 

The Timer #1 to #4 are countdown timers used to signal that a certain period or time has elapsed. You 
set the time, and the time is then updated by the FST. These four timers, when set greater than “0,” 
decrement by 1 every cycle time: Cycle times are: 

♦ FloBoss 100-Series – 1 second. 
♦ FloBoss 407 and ROC300-Series – 100 millisecond. 
♦ ROC800 – 100 millisecond. 

Set the Misc #1 to #4 unsigned 8-bit integers (with valid decimal values of 0 to 255) that are used for 
global storage by the FST.  

Set the Execution Delay between the executions of successive FST command steps. The default is 0 
seconds. The minimum delay is 1 second for a FloBoss 100-Series and 0.1 for other ROC and FloBoss 
devices. 

The Results Register (RR), or Signal Value Analog (SVA), is a special-purpose register that stores the 
floating point result from the most current command executed.  

The Compare Flag (CF), or Signal Value Discrete (SVD), is a special-purpose 8-bit register that stores 
an integer representing the numbers 0 through 255. The Compare Flag is manipulated by the logic 
Commands 

The Mesg #1 and Mesg #2 is a 30-character field for storing a message that will display in the FST 
Message area. Msg Data #1 and Msg Data #2 display any values associated with the messages. 

The Code Size Bytes is the number of bytes used by the FST. The Code Size is read-only device-
specific parameter. Refer to the Devices, Software, and FST Functionality table. 

The Code Pointer Byte field is the display of the offset of the next function to be executed from the 
beginning of its memory Segment. Values are device specific. This value normally changes rapidly, 
unless the FST is at a Wait (WT) statement, an FST Execution Delay is used or in Trace mode. It is used 
for debugging purposes. 

� Note: Use FST Monitor within the FST Editor to monitor these operations. 
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A.4 FST Editor 
Using the FST Editor, FSTs are created, compiled, debugged, and downloaded to the device. 
The FST Editor consists primarily of a Workspace and menus, similar in structure to 
spreadsheet programs. The FST Editor also allows monitoring and tracing of an FST while it is 
running. 

 

Select Utilities > FST Editor or click the FST Editor button to launch the FST Editor. 

 
Figure A-3. FST Editor 

The FST Editor provides a Workspace, menus, and buttons for creating a Function Sequence Table. The 
Title Bar at the top of the Workspace window identifies the FST being created or edited.  

The Workspace area is a table, divided into rows and columns with the intersection called a Cell. You 
can use <Tab> and the arrow keys to move between cells, or you can go directly to a cell by clicking it 
with the mouse. Cells are denoted by a box containing the cursor and a gray line around the cell.  

The Header Line of the Workspace contains the function structure column names. The STEP column 
contains the numbers that correspond to the number of rows or Steps available in the Workspace.  

The LABEL, CMD, ARGUMENT1, and ARGUMENT2 columns correspond to the structure of the 
functions. The Comment column allows the user to insert comments about the FST. The comments will 
not be downloaded (sent) to the ROC or FloBoss unit, and they are only included in the FST when it is 
saved to a file. 
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Table A-2. Workspace and Output Keystrokes 
 

Key Action 

→ Move cursor to the right cell or character. 

← Move cursor to the left cell or character. 

↑ Move cursor to the cell above it. 

↓ Move cursor to the cell below it. 

Backspace Delete the previous character. 
Ctrl + Home Move cursor to top left cell of Workspace. 
Ctrl + End Move cursor to bottom right cell of Workspace. 

Delete Delete character in front of the cursor position. 
End Within a cell, move cursor to the right-most position within the cell. 

Within a row, move cursor to the right-most position in the row 
Enter Process saves contents of cell entry and moves to the next cell. 
Esc Undo entry and display original or prior contents of the cell. 
F1 Help. 

Home Within a cell, move cursor to the left-most position within the cell. 
Within a row, move cursor to the left-most position within the row. 

Page Down Display next page of Workspace. 
Page Up Display previous page of Workspace. 

Tab Move to the next cell. 
 

A.4.1 FST Function Structure 
Each function consists of a STEP number, a LABEL (optional), a command (CMD), and up to two 
Arguments (ARGUMENT1 and ARGUMENT2).  

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2 

0         

The FST program provides the STEP numbers for each FST. You complete the other fields in the 
structure to build a function. 

� Note: Do not skip any Steps. The FST program treats a blank STEP as the END of a program 
and will not compile correctly. 
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A.4.2 FST Label Field 
The LABEL field allows you to uniquely identify a function and consists of up to six alphanumeric 
characters in any combination. A common practice is for the LABEL to identify the action being 
performed by the function. For example, the LABEL “PUMPON” describes a function that activates a 
pump. 

LABELs enable branching, the ability to direct the execution to a function other than the next function 
in the sequence. For example, after completion of a given program STEP 0, a GO command that has a 
LABEL provided in ARGUMENT1 directs the program to advance to the branch identified by the 
LABEL and to perform the functions defined there. 

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2 

0   GO PMPOFF   
1 PUMPON DO DOU 4-1 1 
2 PMPOFF DO DOU 4-2 0 

In the example above, the program is instructed to GO to the LABEL PMPOFF as established by 
ARGUMENT 1 in STEP 0. STEP 0 jumps to STEP 2, where the LABEL PMPOFF is located. 

A.4.3 FST Command Field – CMD 
The FST command (CMD) field specifies the action to be taken by a function. A drop-down list is 
available in each Command cell that shows the function commands and provides a brief description of 
how they operate on the RR, CF, and Argument values. Commands may also be typed in directly. This 
example shows the use of the command (CMD) GO. Refer to Command Library for a definition of each 
command. 

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2 

0   GO PMPOFF   
  .       
  .       

12 PMPOFF VAL 3   
  

A.4.4 FST Argument Fields – ARG 
Depending on the Command, Arguments can be unused, references to parameters in the ROC or 
FloBoss (TLPs), numerical constants, or ASCII characters. 

Once the Command has been selected, the Argument cell requires either typing a numerical constant or 
ASCII text or clicking the TLP button for data selection.  

Depending on whether you have selected TLP as number or as text in the Tools > Options dialog box of 
the main ROCLINK 800 application, the TLP appears in the argument structure as the TLP numbers or a 
text abbreviation of the Type, Point number and Parameter. For example, the text abbreviation of the 
status parameter of Discrete Input module 4 channel 1 would be DIN4-1,STATUS. The Data #3 
parameter for Softpoint 3 would be SFP 3,DATA3. 
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A.4.5 FST Comment Fields 
The Comment field is used to enhance readability and provide a place to document the purpose of an 
FST, Step, group of Steps, and save information within the FST. Comments are discarded when an FST 
is compiled and downloaded to the device. Comments remain with the FST when it is saved to a disk 
file. 

A.4.6 FST Function Examples 
The command, its associated arguments, and a Label (optional) make up a function. In this example, the 
Value (VAL) command in Step 0 writes the current process value of Analog Input (module 3, channel 1) 
in EUs to the Result Register (RR), which is implied. The Label in this example serves as a comment 
only, as no other function branches to it. 

STEP LABEL CMD ARGUMENT1 ARGUMENT2 

0 CKHIAL VAL AIN 3-1,EU   
1   >= AIN 3-1,HIAL PUMPON 

In the example above, when the value RR from Step 1 equals or exceeds (>=) the High Alarm value 
(VAL) in Step 2 and the High Alarm limit (HIAL) condition is met, the FST branches to the PUMPON 
Label to turn the pump on. 

� Note: Refer to the FST User Manual (Form A4625) for additional examples. 

A.4.7 Basic Rules for Creating FSTs 
Several rules should be followed when creating FSTs.  

♦ An END command is required at the end of every FST. The END command tells the FST to 
return to the top of the first STEP and begin to run from the first line at STEP 0. However, you 
can use a branching function to force the FST to immediately return to STEP 0 if you do not 
desire to wait for the next execution cycle to begin. If not present, the FST Editor will 
automatically add the END Command when compiling. 

♦ The first blank line found in an FST is automatically converted to the END command. Any 
commands following a blank line are lost.  

♦ Only one END command can be present in an FST. 
♦ Avoid internal loops and direct the program flow to the End Command. Use Wait states (WT 

command) to suspend operation of the FST whenever possible to reduce MPU processor 
overload, especially in a loop in which a condition is being repeatedly checked. 

♦ Be sure to configure the I/O parameters before referencing them in an FST. 
♦ When using any branching command (GO, <, >, <=, >=, ==), make sure that you have defined 

the LABEL that you are referencing with the command. 
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A.4.8 FST Storage and Restart 
This section details what FST configuration data is stored when a write to Internal Configuration 
Memory (EEPROM) is performed, and what happens to the FST after a Cold Start, Warm Start, or after 
upgrading the ROC or FloBoss firmware. 

� Note: A Warm Start occurs when a ROC or FloBoss is powered on. 

For a FloBoss 100-Series: 
♦ Flash Memory Save Configuration – FSTs are permanently saved to memory. 
♦ Stop / Start – If you disable an FST and restart it, the FST begins executing from where it left 

off. 
♦ Warm Start – If an FST is saved to memory and it is active (running) when a Warm Start 

occurs, FSTs automatically restart at the beginning STEP. 
♦ Cold Start – On a Cold Start, FST Registers will be cleared, but will be restored from Internal 

Config Memory if valid. However, if you perform a “Cold Start & Clear FSTs” or a “Cold Start 
& Clear ALL” type of Cold Start, FSTs are permanently deleted from Internal Config Memory. 

♦ Upgrading Firmware – If an FST is saved to memory and it is active (running) when a 
firmware upgrade occurs, FSTs automatically restart after the upgrade completes. 

For a ROC300-Series (Version 2.20 or greater) or FloBoss 407 (Version 1.04 or greater): 

If you disable an FST and then restart it, the FST will start executing from where it left off. The FST can 
be forced to restart from the beginning by setting the Run Flag to a value of 2. 

♦ Write to Config Memory – FST point parameters (Registers and Run Flag) are permanently 
saved to memory. FST executable code is not saved to Config Memory. 

♦ Stop / Start – If you disable an FST and restart it, the FST begins executing from the first Step. 
♦ Warm Start – If a FST Point Type is saved to memory and it is active (running) when a Warm 

Start occurs, FSTs automatically restart at the beginning STEP.  
♦ Cold Start – On a Cold Start, FST Registers will be cleared, but will be restored from Internal 

Config Memory if valid. However, if you perform a “Cold Start & Clear FSTs” or a “Cold Start 
& Clear ALL” type of Cold Start, the FSTs are permanently cleared from memory. 

♦ Upgrading Firmware – If a FST Point Type is saved to memory and it is active (running) when 
a firmware upgrade occurs, FSTs automatically restart at the beginning STEP after the upgrade 
completes. 

For a ROC800-Series: 
♦ Write to Internal Config Memory – FSTs are permanently saved to memory. 
♦ Warm Start – If an FST is saved to memory and it is active (running) when a restart occurs, 

FSTs automatically restart at the beginning STEP.  
♦ Cold Start – On a Cold Start, FST Registers will be cleared, but will be restored from Internal 

Config Memory if valid. However, if you perform a “Cold Start & Clear FSTs” or a “Cold Start 
& Clear ALL” type of Cold Start, the FSTs are permanently cleared from Internal Config 
Memory. 

♦ Upgrading Firmware – If an FST is saved to memory and it is active (running) when a 
firmware upgrade occurs, FSTs will be turned off and need to be MANUALLY restarted. 
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A.5 Working with FSTs 
This section details how to work with FSTs. 

A.5.1 Creating an FST 
An FST can be created directly (by entering the steps in a blank workspace) or by editing an existing file 
from a device or from a disk file.  

Use the following steps to create an FST while on-line with a ROC or FloBoss: 

1. Start the ROCLINK 800 software and connect to the ROC or FloBoss. 

2. Select Utilities > FST Editor. 

3. Select the tab of the FST you wish to create (FST 1, FST 2, FST 3, FST 4, FST 5, or FST 6). 
The number of FSTs available is device dependent. 

4. Fill in each STEP with the appropriate Labels, Commands, Tags, and Arguments.  

♦ When you select the field for the Command, the select  button appears. If you click the 
button, a display of commands from which to choose appears. You may type in the 3-
character command.  

♦ Depending upon which Command was chosen, the Argument fields prompt you to type in a 
Label, choose a TLP, or enter some other data. 

♦ The Label field is optional, but are may be required if you are using the Label within a 
Command. Enter all required Labels or a compile error may occur. 

♦ Enter the END command at the end of your FST. 

A.5.1.1 Creating an FST from an Existing File 
Use the following steps to create an FST by editing an existing FST. You may use either a FST from the 
device or a FST file on your PC.  

If you are using a file from the device, connect the ROC or FloBoss to the computer running ROCLINK 
800 software. 

1. Select Utilities > FST Editor. 

2. Select File > Read > From File or File > Read > From Device. 

3. Open an existing FST file with the .FST extension. 

4. Edit each STEP with the appropriate Command, Tag, and Arguments.  

♦ The Label field is optional, but are may be required if you are using the Label within a 
Command. Enter all required Labels or a compile error may occur. 

♦ When you select the field for the Command, the select  button appears. If you click the 
button, a display of commands from which to choose appears. You may also type in the 3-
character command.  

♦ Depending upon which Command was chosen, the Argument fields prompt you to type in a 
Label, choose a TLP, or enter some other data. 

♦ Verify that the END command is at the end of your FST. 
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A.5.1.2 Compiling (Build) and Viewing an FST 
When you perform a Compile, the contents of the Workspace are encoded into the proper format 
for use by the ROC or FloBoss. The FST code can than be downloaded to ROC memory.  
To build and compile an FST: 

Select FST Build > Compile or click the Build button to encode the FST into the proper format for use 
by the ROC or FloBoss memory.  

The compiled file displays in the Output FST field. If invalid points exist in the FST during 
compilation, you receive an error indicating which Point Number is missing. The Output compiled FST 
field displays the errors so that the error can be corrected before the FST is downloaded. 

� Note: If an error occurs during the compile process, the Output field lists the error type and the 
cell in question turns red. 

Compile errors are indicated when: 
♦ Invalid Arguments or Commands are entered during the writing of the FST.  
♦ You perform a Compile. The error displays in the Output field. 
♦ You open an FST from a ROC, FloBoss, or disk file. 

A.5.1.3 Downloading the FST to the ROC or FloBoss 
To download the FST to ROC or FloBoss memory: 

1. Click the Download button on the toolbar or select File > Download.  

If the FST currently loaded is operating, you will be prompted to stop the FST and continue with 
the download or to stop the FST without downloading. 

2. Enter the Version number and Description of the FST, for later identification, and click OK.  

Following the download, you will be prompted to start the FST or you can start the FST in Monitor Mode 
or the FST Register screen. To verify the FST logic, you may desire to start the FST in Trace Mode. 

A.5.1.4 Saving an FST 
To save the FST as an individual disk file: 

1. Select FST > Save as or click the Write to file button in the FST Editor. 

2. Enter the File name and click Save. The FST file will be saved with an .fst extension. 

 

A.5.1.5 Starting the FST 
Once an FST is compiled (Build > Compile) without errors and is downloaded to the ROC or FloBoss, 
the FST must be started in order to run.  

1. Connect the ROC or FloBoss to the computer running ROCLINK 800 software. 

2. Select Configure > Control > FST Register. 

3. Select the desired FST from the drop-down list box.  

4. Select the Status Enabled radio button. 

5. Click Apply. 

6. Click OK. 
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A.5.1.6 Stopping an FST 
To stop the execution of an FST:  

1. Connect the ROC or FloBoss to the computer running ROCLINK 800 software. 

2. Select Configure > Control > FST Register. 

3. Select the desired FST from the drop-down list box.  

4. Select the FST Status Disabled radio button. 

5. Click Apply. 

6. Click OK. 

A.5.1.7 Deleting an FST (Clear) 
To permanently delete an FST: 

1. Select FST > Clear. 

2. Select the desired FST (FST1 to FST6). 

Not supported by a FloBoss 100-Series. 

A.5.1.8 Reading, Writing, Selecting, and Closing an FST 
The FST menu allows you to select FSTs to Read, Write, Select, Close, and Print. 

 
Select FST > Read > From Device to retrieve the contents of the ROC or FloBoss memory 
and load the FST in the selected Workspace. 

 
Select FST > Read > From File to retrieve the contents of a disk file and display the FST in 
the selected Workspace. 

  � Note: If invalid points exist in the FST, you receive an error indicating which Point 
Number is missing. 

� Note: The Output view is populated with data when a Compile operation is performed 
or when an FST is read from the ROC or FloBoss.  

 
Select FST > Save as to save the current Workspace contents to a disk file (saves one FST at 
a time). 

  Select FST > Close to exit the FST Editor or Monitor screen.  

A.5.1.9 Printing an FST 
In the FST Editor, select FST > Print Preview to print an FST or export it to a file.  

When the Print Preview screen appears, click the Print button to send the FST to a printer. You may also 
select the PDF, Excel, or RTF buttons to export the FST as a file in those formats. 

A printed FST can help you in troubleshooting. 
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A.5.2 Altering an FST – Edit Menu 
The FST Editor Edit menu provides options for altering a FST.  

 
Select Edit > Insert Step to place a blank line in the Workspace before the current line. Use this 
option to add a function between two existing functions. 

 
Select Edit > Delete Step to delete the current line from the Workspace. 

 
Select Edit > Erase Workspace to erase the contents of the current Workspace permanently. You 
can save the FST to a file before you erase the Workspace. 

Cut, Copy, and Paste function are available using <Ctrl + X>, <Ctrl + C>, and <Ctrl + V>. You can 
copy fields, entire Steps, or blocks of Steps. The FST Editor will not insert, but will override existing 
fields. 

Two other modes of operation are available for the FST Editor: Monitor and Trace. Monitor mode 
allows for continual viewing of the present contents of the FST structure in the device as it is modified. 
Trace mode allows you to examine execution of an FST one STEP at a time for debugging purposes. 

A.5.2.1 Troubleshooting an FST 
An execution error is an error that will cause the stopping of an FST by the ROC or FloBoss. An 
execution error occurs when the FST references a Point Number that has been removed or changed.  

If a compile error occurs during the compile process (Build > Compile), the Output field lists the error 
type and the cell in question turns red. Execution errors are caused by changes in the ROC or FloBoss 
configuration after the download of an FST. This may include removal of I/O or other logical points 
used by the FST. 

In Monitor mode, execution errors are indicated through the Run Flag Status (RF). 
0 = FST is not running – All devices. 
1 = FST is running – All devices. 
2 = Restart from beginning – ROC300-Series and FloBoss 407 only. 
5 = Indicates FST has shut down due to an invalid point reference All devices. 
8 = FST Editor initiates the Trace mode – ROC800-Series and FloBoss 100-Series only. 
9 = Indicates that the FST in the ROC or FloBoss is processing – ROC300-Series and FloBoss 407 
only. 

When an FST fails as indicated by an RF value of 5, you can view at which Instruction Pointer (IP) the 
FST failed. 

A.6 Monitor Mode 
When on-line, use FST Monitor menu to select which FST to monitor, turn Trace mode on and off, 
Close the FST, Pause or Resume an FST and Monitor Registers, Timers, Miscellaneous Registers, 
Messages, and Compare Flag options. 

To start Monitor mode to display the selected FST, select the desired FST from the Monitor menu while 
on-line with the ROC or FloBoss unit or click the Monitor button from within the open workspace to 
monitor that FST. FST fields located on the right side of the Monitor screen may be edited by 
highlighting the field, typing the value, and pressing <Enter>. The new value is written to the FST and 
read back on the next update. 
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The Help Status Line at the top of the Monitor indicates the status of the Monitor and Trace Modes. 

The Parameter and Data fields include: 

CF – Compare Flag, often referred to as the Signal Value Discrete (SVD), is an 8-bit integer 
representing the numbers 0 through 255. 

CF Bny – The Compare Flag displays as both the integer value and the binary value (bit 7 to the left and 
bit 0 to the right). 

RF – Run Flag.  

0 = FST is not running – All devices. 
1 = FST is running – All devices. 
2 = Restart from beginning – ROC300-Series and FloBoss 407 only. 
5 = Indicates FST has shut down due to an invalid point reference All devices. 
8 = FST Editor initiates the Trace mode – ROC800-Series and FloBoss 100-Series only. 
9 = Indicates that the FST in the ROC or FloBoss is processing – ROC300-Series and FloBoss 407 
only. 

When an FST fails as indicated by an RF value of 5, you can view at which Instruction Pointer (IP) 
the FST failed. 

IP – Instruction Pointer. Indicates the storage location in the FST of the next function to be executed. 
One storage location is used for each byte that stores the function.  

Size – The number of bytes reserved for the FST program in bytes. Equivalent to the end pointer value 
minus the start pointer value. 

Brk – The delay, in 100 millisecond intervals, between the execution of successive FST Commands or 
functions. The FloBoss 100-Series Break interval is 1 second. 

RR – The Results Register or accumulator, sometimes referred to as the Signal Value Analog (SVA), is 
a floating-point value passed between functions or FSTs. 

R1 through R10 – Ten floating-point registers for each FST. The floating-point registers are used for 
global storage, and register contents can be called into any of the FSTs configured for a ROC or 
FloBoss.  

Timer 1 through Timer 4 – Four timers. When set greater than “0”, they decrement by “1” every 100 
milliseconds for a ROC800-Series, ROC300-Series, or FloBoss 407. The FloBoss 100-Series 
decrements by 1 second. A timer can be set using the Set Timer (ST) Command or by saving the RR 
(Results Register) directly to the timer parameter using the SAV Command. The Check Timer (CT) 
Command is used to compare the timer to “0”. When greater than “0”, it branches to the desired 
LABEL. 

MSG1 – Character field for storing a message.  

MSG2 – Not used by the FST. A value can be written to MSG2 using the FST Registers point or a ROC 
Display field and viewed while monitoring or tracing the FST. 

MSG Data – Displays any values associated with MSG1. 

MISC 1 through MISC 4 – Single-byte registers that can be written to and the value can be used by the 
FST. Valid value is 0 to 255. 



ROCLINK 800 User Manual 

Rev. Dec-05 FST Editor A-15 

Table A-3. Monitor and Trace Mode Keystrokes 
 

Key Action Key Action 

↑ Move cursor to the cell above it. End Move cursor to the right-most cell. 

↓ Move cursor to the cell below it. F1 Help. 

Ctrl + End Display last entry in Workspace. F6 Execute current FST command. 
Ctrl + Home Display beginning of Workspace. Home Move cursor to the left-most cell. 
Page Down Display next page of Workspace. Page Up Display previous page of Workspace. 

A.6.1 FST – Trace Mode 
In Trace mode, you can view at which Instruction Pointer (IP) the FST failed. Print the FST to assist in 
troubleshooting. 

When on-line, the FST Editor uses a Trace mechanism that provides the ability to debug FST program 
logic. Trace executes the FST function indicated by the Instruction Pointer (IP), moves the Instruction 
Pointer to the next FST function to be executed, and then stops. You are given the opportunity to 
examine the results of the FST function and determine the next FST function to be executed. The 
location of the action depends on the nature of the command. The action may be traced to the history 
log, I/O value, Point Numbers, Softpoint, and so on. 

The command executed is determined by comparing the Instruction Pointer (IP) shown on the Monitor 
screen to a list of all Instruction Pointers and their corresponding commands. Trace thereby verifies 
proper execution and sequencing of the FST functions. 

� Note: Before entering Trace mode, print out an Instruction Pointer listing of the FST. 

After entering Trace mode from a newly compiled FST, the FST starts at the first STEP. After entering 
Trace mode from an executing FST, the FST starts at the STEP being executed. When using a FloBoss 
407, ROC300-Series, FloBoss 100-Series, a value can be entered into the Instruction Pointer (IP) field to 
manually jump to another STEP. 

Press <F6> to execute the next command.  

� Note: When you attempt to Trace an FST that contains WT, BRK, ST, or CT commands, a pause 
in the sequencing can occur until the command conditions are met. 

Other Trace commands include: 
♦ Select Monitor > Trace On to turn on Trace mode. 
♦ Select Monitor > Pause to stop the FST at the current command. 
♦ Select Monitor > Resume to start the FST at the current command. 
♦ Select Monitor > Trace Off to turn off Trace mode. 
♦ Select Monitor > Next Step to turn off Trace mode. 
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A.7 FST Command Library 
Commands are identified by a name that consists of one or more characters or mathematical symbols. In 
the FST Editor, select the CMD field and perform one of the following: 

♦ Type the Command. 

♦ Click the  button.  

This opens a list of commands, the command names, and their descriptions (actions).Command Library 
Conventions Table describes the terms RR and CF used in the command descriptions (actions). 

In FST Command Summary Table, each command name is given along with a brief description (action), 
the Arguments (ARGUMENT1 or ARGUMENT2) required, and the effect each operation has on the 
RR and CF. In the explanation of the operation, if RR or CF is not mentioned, then the current content is 
not affected and remains unchanged. In general, the CF is affected only by logical commands. 

Table A-4. FST Command Library Conventions 
 
Convention Description 

RR (in) The value or contents of the Results Register (RR), Signal Value Analog (SVA) prior to execution 
of the function (command). 

RR (out) Output value from Results Register (RR). 
CF (in) The value or contents of the Compare Flag (CF), Signal Value Discrete (SVD), prior to execution 

of a function (command). 
CF (out) The contents of the Compare Flag (CF), following execution of the function (command). 

 

Table A-5. FST Command Summary 
 

Category Command Action 
FloBoss 100-Series, 
ROC300-Series, and 

FloBoss 407 
ROC800-

Series 

Math + RR = RR + ARGUMENT1 (add) X X 
  – RR = RR – ARGUMENT1 (subtract) X X 
  * RR = RR * ARGUMENT1 (multiply) X X 
  / RR = RR / ARGUMENT1 (divide) X X 
  ** RR = RR raised to power of ARGUMENT1 X X 
  ABS RR = Absolute value of RR X X 
  EXP RR = “e” (2.71828) raised to power of RR X X 
  INT RR = Integer value of RR X X 
  LOG RR = Log (base 10) of RR X X 
  LN RR = Natural Log of RR X X 
  SQR RR = Square root of RR X X 
  P3 RR = 3rd-order polynomial (R1, R2, R3, R4) X X 

Logical NOT SVD = NOT SVD (0 ≥ 1; > 0 ≥ 0) X X 

  AND SVD = SVD AND ARGUMENT1 X X 
  OR SVD = SVD OR ARGUMENT1 X X 
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Category Command Action 
FloBoss 100-Series, 
ROC300-Series, and 

FloBoss 407 
ROC800-

Series 

  XOR SVD = SVD XOR ARGUMENT1 X X 
Comparison == If RR = ARGUMENT1, go to ARGUMENT2 

LABEL 
X X 

  != If RR <> ARGUMENT1, go to ARGUMENT2 
LABEL 

X X 

  < If RR < ARGUMENT1, go to ARGUMENT2 
LABEL 

X X 

  <= If RR <= ARGUMENT1, go to ARGUMENT2 
LABEL 

X X 

  > If RR > ARGUMENT1, go to ARGUMENT2 
LABEL 

X X 

  >= If RR >= ARGUMENT1, go to ARGUMENT2 
LABEL 

X X 

Time ST Set Timer # ARGUMENT1 to ARGUMENT2 
100 mSec intervals or 1 second for FloBoss 
100-series 

X X 

  CT If Timer # ARGUMENT1 > 0, go to LABEL 
ARGUMENT2 

X X 

  WT Suspend FST execution for ARGUMENT1 
secs 

X X 

  DWK RR = Day of Week (1=Sunday, 7=Saturday) X X 
  MND RR = Minutes since midnight X X 

Control AO Set AO# ARGUMENT1 output = 
ARGUMENT2 EUs 

X X 

  DO Set DO# ARGUMENT1 status = 
ARGUMENT2 

X X 

  TDO Force Discrete Output Recalculation X X 
Database VAL RR = Value specified in ARGUMENT1 X X 

  SAV Write RR to variable specified in 
ARGUMENT1 

X X 

  RDB Read History Value into RR X X 
  WDB Write RR Value to History X X 
  WTM Write Current Time to History X X 
  DHV Read Daily History Value into RR – X 
  DHT Read Daily History Time Stamp into RR – X 
  PHV Read Periodic History Value into RR – X 
  PHT Read Periodic History Time Stamp into – X 
  MHV Read Minute History Value into RR – X 
  DIS Read Starting Daily History Index into RR – X 
  DIN Read Number of Daily History Indexes into RR – X 
  PIS Read Starting Periodic History Index into RR – X 
  PIN Read Number of Periodic History Indexes into 

RR 
– X 
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Category Command Action 
FloBoss 100-Series, 
ROC300-Series, and 

FloBoss 407 
ROC800-

Series 

  GTE Extract Time Element from Time Stamp into 
RR 

– X 

Miscellaneous GO Jump to STEP pointed to by ARGUMENT1 
LABEL 

X X 

  MSG MSG String #1 = ARG1; MSG Data = ARG2 – X 
  END End of FST...restart at beginning X X 
  BRK Delay ARGUMENT1 100 mSec intervals (1 

second for FloBoss 100-Series) 
X X 

  ALM Log 10-character message and a current value X X 
  EVT Log 10-character message and a current value X X 

� Note: MSG not supported by the FloBoss 100-Series. 

A.7.1 FST Mathematical Commands 
The mathematical commands provide simple arithmetic or mathematical operations. Such operations 
include addition (+), subtraction (–), multiplication (*), division (/), raise to power (**), absolute value 
(ABS), “e” raised to a power (EXP), truncate to integer (INT), base 10 logarithm (LOG), natural 
logarithm (LN), square root (SQR), and 3rd-order polynomial (P3). 

� Note: No operation occurs with the LOG, LN, power (**), and SQR commands if the Results 
Register is less than or equal to zero.  

Name Description Arguments Results 

+ Add value to 
RR(in) 

1. Database or 
Constant Value 

RR(out) = RR(in) + ARG1 
SVD(out) = SVD(in) 

– Subtract value 
from RR(in) 

1. Database or 
Constant Value 

RR(out) = RR(in):ARG1 
SVD(out) = SVD(in) 

* Multiply RR(in) by 
value 

1. Database or 
Constant Value 

RR(out) = RR(in) * ARG1 
SVD(out) = SVD(in) 

/ Divide RR(in) by 
value 

1. Database or 
Constant Value 

If ARG1 = 0.0: 
RR(out) = RR(in), SVD(out) = SVD(in) 

      Otherwise:  
RR(out) = RR(in) / ARG1 
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Name Description Arguments Results 

** Raise RR(in) to a 
power 

1. Database or 
Constant Value 

ROC800-Series and FloBoss 100-Series: 
RR(out) = RR(in) ** ARG1 

FloBoss 500-Series: 
RR(in) ≥ 0 and ARG1 ≥ 0 
RR(out) = RR(in) ** ARG1 
RR(in) = 0 and ARG1 = 0 
RR(out) = NAN 
RR(in) = 0 and ARG1 = 0 
RR(out) = 0 

ROC300-Series and FloBoss 407: 
ARG1 = 0 and RR(in) = 0 
RR(out) = RR(in) 

In all other cases: 
RR(out) = RR(in) ** ARG1 
SVD(out) = SVD(in) 

ABS Absolute Value of 
RR(in) 

None RR(out) = |RR(in)| 
SVD(out) = SVD(in) 

EXP “e” to the power of 
RR(in) 

None RR(out) = e ** RR(in) 
SVD(out) = SVD(in) 

INT Integer part of 
RR(in) 

None RR(out) = (int) RR(in) 
SVD(out) = SVD(in) 

LOG Logarithm (base 
10) of RR(in) 

None If RR(in) > 0.0: 
RR(out) = LOG[RR(in)], SVD(out) = SVD(in) 
Otherwise: 
RR(out) = RR(in), SVD(out) = SVD(in) 

LN Natural Logarithm 
of RR(in) 

None If RR(in) > 0.0: 
RR(out) = LN[RR(in)], 
SVD(out) = SVD(in) 
Otherwise: 
RR(out) = RR(in), 
SVD(out) = SVD(in) 

SQR Square Root of 
RR(in) 

None If RR(in) >= 0.0: 
RR(out) = SQRT[RR(in)], 
SVD(out) = SVD(in) 
Otherwise: 
RR(out) = RR(in), 
SVD(out) = SVD(in) 

P3 3rd-Order 
Polynomial 

None RR(out) = [reg1 * (RR(in) ** 3)] 
+ [reg2 * [RR(in) ** 2)] 
+ [reg3 * [RR(in) ** 1)] 
+ reg4 
where reg1 through reg4 are the current constant 
values of Register1 through Register4 of the 
respective FST 
SVD(out) = SVD(in) 
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A.7.2 FST Logical Commands 
You can store a discrete value called the Signal Value Discrete (SVD) in the Compare Flag (CF). The 
SVD is stored as an 8-bit byte. The CF is true whenever non-zero, and the CF is false when zero.  

Logical commands operate upon the Compare Flag (CF). Prior to execution of a logical command, the 
CF must be loaded with an 8-bit value by using the SAV command. 

The bit-wise logical commands (AND, OR, NOT, and XOR) apply Boolean operations on two 8-bit 
integers, bit-by-bit. The two 8-bit integers are the CF and the value defined by ARGUMENT1 of the 
logical command. Note that this value is then converted by the software into an 8-bit unsigned integer. 
This value is used as a binary number 8 bits long as described next. 

Each bit is weighted as a power of two, and the bit position determines which power of two. The bit, 
either 0 or 1, is multiplied by the respective bit weight. The resulting binary number is read from right to 
left, with the right-most bit representing bit 0, and the left-most bit representing bit 7. 

For example, the integer 42 is equivalent to the binary number 00101010 as shown next, where bit 0 is 
the right-most bit: 

Bit Binary # x Weight = 

Bit 7 0 x 27 = 0 x 128 = 0 
Bit 6 0 x 26 = 0 x 64 = 0 
Bit 5 1 x 25 = 1 x 32 = 32 
Bit 4 0 x 24 = 0 x 16 = 0 
Bit 3 1 x 23 = 1 x 8 = 8 
Bit 2 0 x 22 = 0 x 4 = 0 
Bit 1 1 x 21 = 1 x 2 = 2 
Bit 0 0 x 20 = 0 x 1 = 0 

Total = 42 

The following table summarizes the bit-wise AND operation. 
AND  0 1 

 0 0 0 

 1 0 1 

 

The following example ANDs the two integers 37 and 42, giving a result of 32. 
 37 00100101 

AND 42 00101010 

 32 00100000 

 

The following table summarizes the bit-wise Inclusive OR operation. 
OR  0 1 

 0 0 1 

 1 1 1 
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The following example ORs the two integers 37 and 42, giving a result of 47. 
 37 00100101 

OR 42 00101010 

 47 00101111 

  

The following table summarizes the bit-wise Exclusive OR operation. 
XOR  0 1 

 0 0 1 

 1 1 0 

 

The following example Exclusive ORs the two integers 37 and 42, giving a result of 15. 
 37 00100101 

XOR 42 00101010 

 15 00001111 

  

Name Description Arguments Results 

NOT Logical NOT of SVD(in) None If SVD(in) > 0, SVD(out) = 0 
Otherwise: SVD(out) = 1 
RR(out) = RR(in) 

AND Logical AND ARG1 with SVD(in) 1. Database or Constant Value RR(out) = RR(in), 
SVD(out) = [SVD(in) AND ARG1] 

OR Logical OR ARG1 with SVD(in) 1. Database or Constant Value RR(out) = RR(in), 
      SVD(out) = [SVD(in) OR ARG1] 

XOR Logical XOR ARG1 with SVD(in) 1. Database or Constant Value RR(out) = RR(in), 
      SVD(out) = [SVD(in) XOR ARG1] 
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A.7.3 FST Comparison Commands 
Use comparison commands to compare values. Comparison commands conditionally compare two 
values, and branch to a different sequence of commands if the comparison is determined to be true. 
Otherwise, if the comparison is determined to be false, no branching occurs and the next command in 
sequence is executed. Comparison commands test values for equivalence (==), non-equivalence (!=), 
less than (<), less than or equal to (<=), greater than (>) , and greater than or equal to (>=). 

Name Description Arguments Results 

== Test If RR(in) equals 
ARG1. Note that this 
command performs in a bit-
wise fashion, so two 
floating Point Numbers 
displayed as equal may not 
match. 

1. Database or Constant Value 
2. LABEL 

If RR(in) = ARG1, Goto ARG2 
Otherwise: continue to next command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

!= 1. Database or Constant Value If RR(in) != ARG1, Goto ARG2 
  

Test If RR(in) Not Equal to 
ARG1. 2. LABEL Otherwise: continue to next command 

      RR(out) = RR(in) 
      SVD(out) = SVD(in) 
< 1. Database or Constant Value If RR(in) < ARG1, Go to ARG2 
  

Test If RR(in) less than 
ARG1. 2. LABEL Otherwise: continue to next command 

      RR(out) = RR(in) 
      SVD(out) = SVD(in) 

<= 1. Database or Constant Value If RR(in) <= ARG1, Go to ARG2  
  

Test If RR(in) less than or 
equal to ARG1. 2. LABEL Otherwise: continue to next command 

      RR(out) = RR(in) 
      SVD(out) = SVD(in) 
> 1. Database or Constant Value If RR(in) > ARG1, Go to ARG2 
  

Test If RR(in) greater than 
ARG1. 2. LABEL  Otherwise: continue to next command 

      RR(out) = RR(in) 
      SVD(out) = SVD(in) 

>= 1. Database or Constant Value If RR(in) >= ARG1, go to ARG2  
  

Test if RR(in) greater than 
or equal to ARG1. 2. LABEL Otherwise: continue to next command 

      RR(out) = RR(in) 
      SVD(out) = SVD(in) 
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A.7.4 FST Time-Related Commands 
Use time-related commands (FST Timers) to implement simple time-related operations, such as setting 
Timers, checking Timers, determining if Timers have elapsed, wait time before continuing, and 
imposing a delay upon each command executed.  

Timers are used to branch the FST to a specific Label after a specified period of time following an 
action. Up to four Timers are available for use in an FST and each Timer has a time interval of 100 
milliseconds or seconds for a FloBoss 100-Series. Each FST Timer decrements by 1 interval if the 
Timer value is greater than 0. 

Set Timer (ST) – The ST command sets any one of the four available Timers for any of the available 
FSTs. ARGUMENT1 specifies the number of the Timer to set and ARGUMENT2 specifies the 
number of intervals to which the Timer is set.  

Check Timer (CT) – When executing a loop repeatedly in an FST, it is recommended a timer (CT) be 
included so the loop executes only once every time interval. This prevents the loop from executing 
several times within the allotted task period, eliminating unnecessary calculations that could deprive 
time from other tasks. 

Wait (WT) – The Wait command imposes a delay, entered in seconds and tenths of seconds, before 
executing the next command. For example, entering a value of 0.1 implies a 100-millisecond delay 
and a value of 1.0 implies a one-second delay. This is entered in seconds for a FloBoss 100-Series. 

Day of Week (DWK) and Minutes Since Midnight (MND) – These commands are written to the 
Results Register. For DWK, 1=Sunday through 7=Saturday. 

Name Description Arguments Results 

ST Set Timer for specified FST with value in 100 mSec intervals. 
1 second for FloBoss 100-Series. 

1. FST Point 
Database 
Value 
2. Database or 
Constant Value 

FST Timer (ARG1) = 
ARG2 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

CT Check Timer for specified FST with value in 100 mSec 
intervals. 1 second for FloBoss 100-Series. 

1. FST Point 
Database 
Value 
  

If FST Timer (ARG1) 
= 0, continue to next 
command.  

    2. LABEL Otherwise, Goto 
ARG2. 

      RR(out) = RR(in) 
      SVD(out) = SVD(in) 

WT Wait – suspend FST until specified number of seconds 
(ARG1) have elapsed. The number of seconds can be from 
0.1 to 999,999. 1 to 999,999 for a FloBoss 100-Series, which 
only accepts whole numbers. 

1. Database or 
Constant Value 

Delay ARG1 seconds 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

DWK Day of Week – sets RR (out) to the day of the week 
(1=Sunday, 7=Saturday). 

None RR(out) = Day of 
Week 
SVD(out) = SVD(in) 

Note: The DWK function requires that the real-time clock be set correctly. 
MND Minutes Since Midnight – sets RR (out) to the number of 

minutes past midnight. 
None RR(out) = Minutes 

SVD(out) = SVD(in) 
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A.7.5 FST Control-Related Commands 
Use Analog Output (AO), Discrete Output (DO), and Timed Duration Output (TDO) control-related 
commands to control outputs.  

� Note: The FloBoss 407 and ROC300-Series units must use the AO, DO, and TDO commands to 
drive outputs from an FST. SAV and other commands will not affect the Output. 

Name Description Arguments Results 

AO Analog Output. Sets the Analog Output 
point EUs to the argument value. If the 
Analog Output is in Manual, no output 
is sent. 

1. AO Point Database 
Value 

2. Database or 
Constant Value 

AO Output(ARG1) = ARG2 
  
RR(out) = RR(in) 
SVD(out) = SVD(in) 

DO Discrete Output. Sets the Discrete 
Output point status to the argument 
value. If the Discrete Output is in 
Manual, no output is sent. 

1. DO Point Database 
Value 

2. Database or 
Constant Value 

DO Output(ARG1) = ARG2 
  
RR(out) = RR(in) 
SVD(out) = SVD(in) 

TDO* Timed Duration Output. Activates a DO 
point configured as a TDO or TDO 
Toggle. This command requires that 
you write a value to the EU Value 
parameter prior to TDO command. 
*TDO command is only used in the 
FloBoss 407 and ROC300-Series units. 
As the required SAV command is 
performs the same function, using it on 
other units will only duplicate the 
action. 

1. DO Point Database 
Value 

DO Output(ARG1) 
  
RR(out) = RR(in) 
SVD(out) = SVD(in) 

� Note: To trigger outputs, use the corresponding output command (previous table). These 
commands trigger the mechanism that changes the output value. 

� Note: The FloBoss 407 and ROC300-Series units must use the AO, DO, and TDO commands to 
drive outputs from an FST. SAV and other commands will not affect the Output. 

The Analog Output (AO) command sends the analog value specified in ARGUMENT2 to the 
analog Point Number specified in ARGUMENT1. The analog value is not sent if the analog 
Point Number is in Manual Mode. The check for Manual Mode is included as a safety feature 
and permits the FST to continue operation if the device connected to the Analog Output is being 
serviced.  

If a PID loop is controlling the Analog Output, placing the PID loop into Manual Tracking Mode 
allows the FST to send a value to the output parameter of the PID. For other active PID modes, 
the FST and PID will be in conflict. 
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A.7.6 FST Miscellaneous Commands 
Use the miscellaneous commands to move around FSTs and end FSTs. 

Miscellaneous commands provide operations, such as an unconditional go to (GO), message to local 
display panel (MSG), alarms (ALM), and event (EVT) generation, end of the FST (END), and delay 
(BRK).  

GO – The GO command executes an unconditional branch to the LABEL in ARGUMENT1. Branching 
can direct the FST to a step before or after the current step. 

Message – The Message (MSG) command provides a 30-character message and value for viewing on 
the local display panel. Not supported by FloBoss 100-Series units. 

Break – The BRK command imposes a delay (Break period), in 100-millisecond (1 second for a 
FloBoss 100-Series) intervals, before executing the next command. Once the break period is set to a 
value other than zero, a delay in 100-millisecond or 1 second intervals occurs between the 
executions of each subsequent command. 

End – The END command completes execution of the FST and waits for the next FST execution cycle 
before returning to the first STEP of the FST. The END command can only be used once in an FST. 
If omitted, End is appended to the FST by the FST Editor at compile time following the first empty 
Command field. 

Alarm and Event Log – The ALM and EVT commands log a 10-character message and the current 
value of the selected parameter to the respective log. 

Name Description Arguments Results 

GO Go to specified LABEL. 1. LABEL Goto ARG1 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

BRK Break delays execution of each command after this one 
for the number of 100 millisecond (1 second for a FloBoss 
100-Series) intervals defined by ARGUMENT1. 

1. Database or 
Constant Value 

FST break time = 
ARG1 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

END End of FST returns to first command. None Execute FST 
starting with first 
command. 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

MSG 
  

LCD Message sends message (ARGUMENT1) and value 
(ARGUMENT2) to local display panel. One 30 character 
message can be sent by each FST as shown next: 
xxxxxxxxxxxxxxxxxx 
xxxxxxxx Arg2 val 
yyyyyyyy zzzzz.zz 
SCAN NEXT PREV MENU 
  
xxxx ...message 
yyyy ...FST Tag name 
zzzz ...ARGUMENT2 value 

1. Message 
2. Database or 

Constant Value 
  

FST Message 
String(ARG1)  
FST Message 
Value(ARG2) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 
  

ALM Log Alarm records message (ARGUMENT1) and value 
(ARGUMENT2) in the Alarm Log. Only the first 10 
characters of the 30 character messages are used. 

1. Message 
2. Database or 

Constant Value 

Log Alarm(ARG1, 
ARG2) 
RR(out) = RR(in) 
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Name Description Arguments Results 
SVD(out) = SVD(in) 

EVT Log Event records message (ARGUMENT1) and value 
(ARGUMENT2) in the Event Log. Only the first 10 
characters of the 30 character message are used.  

1. Message 
2. Database or 

Constant Value 

Log 
Event(ARG1,ARG2
) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

Note: The ALM and EVT functions can quickly overfill the allotted log space of alarms and events. It is important 
to assure that these two functions do not operate continuously. 

A.7.7 FST Database Commands 
Database commands provide access to the configuration and historical databases. Operations include 
reading and writing configuration parameters and reading, writing, storing values from historical 
databases, and time stamping values to a History Point. 

VAL – The Value (VAL) command loads the Results Register (RR) with the value defined in 
ARGUMENT1. ARGUMENT1 can be a constant or any database parameter available to the FST. 
The value defined in ARGUMENT1 is converted to floating point data type and written to the 
Results Register. 

SAV – The Save (SAV) command writes the Results Register (RR) value to any database parameter 
available to the FST as defined in ARGUMENT1. 

WDB, WTM, and RDB – The historical database commands, Write to Historical Database (WDB), 
Write Time to Historical Database (WTM), and Read Historical Database (RDB), allow you to 
establish a non-periodic history database (one that has no specific time interval), a periodic history 
database (one that has a specific time interval), or a storage array for data (similar to a Softpoint).  

For the FST historical database commands to work, a History Point has to be configured correctly for a 
FST History Point as either FST Time Archive Type or FST Data Archive Type. Refer to Defining a 
FST History Point. 

The FST for a History Point uses one of the historical database commands and two Arguments. 
ARGUMENT1 contains the history database point number. ARGUMENT1 can be a constant or a 
parameter with a value between: 

♦ 1 through 35 (FloBoss 100-Series). 
♦ 1 through 87 (ROC300-Series). 
♦ 1 through 50 (FloBoss 407). 
♦ History Segment (General Segment 0 or Segment 1 through 10) and History Point (1 through 

200) (ROC800-Series). 

ARGUMENT2, for a ROC800-Series, the historical database commands is the index or pointer to the 
history storage array. The history storage array holds entries taken at either set intervals (typically daily, 
hourly, and each minute) or user-configurable intervals. For information on the intervals and number of 
entries, refer to the history database specifications instruction manual for the ROC800-Series. 
Argument2 should be a Soft point or FST register. The history point defined by Argument1 will be 
logged at the index location defined by Argument2. 



ROCLINK 800 User Manual 

Rev. Dec-05 FST Editor A-27 

ARGUMENT2, for FloBoss 100-Series, ROC300-Series, and FloBoss 407, can be a constant or a 
database parameter that contains the history log pointer. If ARGUMENT2 is a floating-point database 
parameter, the historical database commands check for rollover by comparing the pointer against the 
number of archived periods per history database point. Following the write or read, the floating point 
database parameter is incremented by 1 and then compared against the number of archived periods. If 
the floating point database parameter is equal to or greater than the number of archived periods, the 
floating point database parameter is set to “0” and the data writes over the stored data. 

� Note: For ROC800-Series, when viewing the data or time in history, it will be under Periodic 
History, not Minute History. 

Name Description Arguments Results 

VAL Load RR sets the RR(out) to the argument value. 1. Database or 
Constant 
Value 

RR(out) = ARG1 
SVD(out) = SVD(in) 

SAV Store RR sets the argument to the RR(in). 1. Database 
Value 

ARG1 = RR(in) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

RDB Read Historical Database sets the RR(out) to the 
historical database value of the specified 
database point (ARGUMENT1) and the specified 
pointer (ARGUMENT2) to the historical database 
value. Applies to historical database points 
defined for the FST only.  
If ARGUMENT2* is a floating database value (for 
example: @FST1, FST SEQ# 1, R8), the 
command increments ARGUMENT2 to the next 
historical database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
*Note: The ROC800-Series increments any Data 
Type. 

1. Database or 
Constant 
Value 

2. Database or 
Constant 
Value 

For FST History Point: 
RR(out) = History 
Value(ARG1,ARG2) 
For floating database 
value ARG2: 
If ARG1 >= No. of 
archived periods 
(ARG1), then ARG2 = 0 
Otherwise, ARG2 = 
ARG2 + 1 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

WDB Write To Historical Database sets the RR(in) to 
the value of the database point (ARGUMENT1) 
and the pointer (ARGUMENT2). Applies to 
historical database points defined for the FST 
only.  
If ARGUMENT2* is a floating database value (for 
example: @FST1, FST SEQ# 1, R8), the 
command increments ARGUMENT2 to the next 
historical database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
*Note: The ROC800-Series increments any Data 
Type. 

1. Database or 
Constant 
Value 

2. Database or 
Constant 
Value 

For FST History Point: 
History Value (ARG1, 
ARG2) = RR(in).  
For floating database 
value ARG2: 
If ARG2 >= No. of 
archived periods 
(ARG1), then  
ARG2 = 0. 
Otherwise, ARG2 = 
ARG2 + 1. 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 
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WTM Write Time To Historical Database sets the value 
of the database point (ARGUMENT1) and the 
pointer (ARGUMENT2) to the historical database 
time string with either minutes or seconds 
resolution. The time format for minute’s resolution 
is [min,hr,day,mon] and for seconds resolution is 
[sec,min,hr,day]. Applies to historical database 
points defined for the FST only. 
If ARGUMENT2* is a floating database value (for 
example: @FST1, FST SEQ# 1, R8), the 
command increments ARGUMENT2 to the next 
historical database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
*Note: The ROC800-Series increments any Data 
Type. 

1. Database or 
Constant 
Value 

2. Database or 
Constant 
Value 

For FST History Point: 
If minute resolution, 
then 
History Value (ARG1, 
ARG2 = minute format.  
Otherwise: History 
Value (ARG1,ARG2) = 
second format.  
For floating database 
value ARG2: 
If ARG2 >= number of 
archived periods 
(ARG1), then  
ARG2 = 0.  
Otherwise: ARG2 = 
ARG2 + 1. 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

  

A.7.7.1 Defining a FST History Point 
When defining history database points for WDB, WTM, and RDB, define at least one History Point as 
an FST Time type (minute or second) to provide a time stamp for the values logged. The time stamps 
represent what time each portion of the accumulated data was logged. 

To define an FST History Point: 
1. Select Configure > History Points. 
2. For the ROC800-Series, select the desired History Segment. 
3. Select the desired History Point. 
4. Click the Archive Type TLP button and select FST Time or FST Data. 
5. Click the Archive Point TLP button and select any TLP, such as FST Register 2 to contain the 

data or time stamp. The Archive Point selection is ignored by the FST. 
6. Click OK. 

The FST for a History Point uses one of the historical database commands and two Arguments. 
ARGUMENT1 typically contains the history database History Segment and History Point number with 
a value between: 

♦ For History Segment, General Segment 0 or Segment 1 through 10. 
♦ For History Point, 1 through 200. 

ARGUMENT2 is the History Index or database pointer to the history storage array. The history storage 
array holds entries taken at either set intervals (typically daily, hourly, and each minute) or user-
configurable intervals. 

For the DHV, DHT, PHV, PHT, and MHV commands, select the History Segment and the 
corresponding History Point that you desire to log in Argument 1. In Argument 2, select either a 
database point or a constant value, which is the actual History Index where the data resides in the 
historical database. 

The Minute History Value (MHV) History Index is the same as the minute of the hour. Read the clock’s 
minutes to get the last History Index value. For example, if it is 8:10 then the History Index is 10. 
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For the Extract Time Element (GTE) command, select the database point or a constant value, which is 
the actual History Index value where the data resides in the historical database. In Argument 2, select the 
Time Element to log the exact time of the database point or History Index value. The GTE command is 
used to extract the time element from the time stamp received back from the CHT and PHT commands. 

For DIS, DIN, PIS, and PIN commands, select the History Segment and the corresponding History 
Point that you desire to log in Argument 1. In Argument 2, select the Month and Date on which to log 
the History Index value. 

To acquire the Daily History Value (DHV), perform a Starting Daily Index (DIS) command to locate the 
starting History Index value for a specific day. Using the DIS History Index value, use the DHV 
command to locate the Daily History Value. 

To find specific data in history, such as the data entered at 9:00 AM yesterday, first use the Starting 
Periodic Index (PIS) command to find the starting History Index value for yesterday’s date and then 
count forward nine to acquire the History Index value for 9:00 AM. Use this new History Index with the 
Periodic History Value (PHV) command to locate the data.  

Name Description Arguments Results 

DHV Daily History Value 1. History Segment, History Point 
2. DB Point or Constant (History 

Index) 

Stores value in RR.  
Halts on invalid History Index. 

DHT Daily History Time Stamp 1. History Segment, History Point 
2. DB Point or Constant (History 

Index) 

Stores value in RR. 
Halts on invalid History Index. 

PHV Periodic History Value 1. History Segment, History Point 
2. DB Point or Constant (History 

Index) 

Stores value in RR. 
Halts on invalid History Index. 

PHT Periodic History Time 
Stamp 

1. History Segment, History Point 
2. DB Point or Constant (History 

Index) 

Stores value in RR. 
Halts on invalid History Index. 

MHV Minute History Value 1. History Segment, History Point 
2. DB Point or Constant (History 

Index) 

Stores value in RR. 
Halts on invalid History Index. 

DIS Starting Daily Index 1. History Segment, History Point 
2. Month/Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

DIN Number of Daily Indexes 1. History Segment, History Point 
2. Month / Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

PIS Starting Periodic Index 1. History Segment, History Point 
2. Month / Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

PIN Number of Periodic Indexes 1. History Segment, History Point 
2. Month / Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 
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Name Description Arguments Results 

GTE Extract Time Element 1. DB Point or Constant (History 
Index) 
(Time in Seconds since 1/1/1970) 

2. Time Element 

Stores value in RR. 
Valid Time Elements: 
0 – Month 
1 – Day 
2 – Year 
3 – Hour 
4 – Minute 
5 – Second 
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GLOSSARY 

A 
A/D: Analog to Digital signal conversion. 

AGA: American Gas Association. Association that oversees the AGA 3 (orifice), AGA 5 (heating 
value), AGA 7 (turbine), AGA 8 (compressibility) and AGA 11 (ultrasonic) gas flow calculations 
standards. For more information, refer to the AGA website: http://www.aga.org. 

AI: Analog Input. 

AO: Analog Output. 

Attribute: A parameter that provides information about an aspect of a database point. For example, the 
alarm attribute is an attribute that uniquely identifies the configured value of an alarm. 

B 
BMV: Base Multiplier Value. Used in AGA7 (turbine) calculations. 

BPS: Bits Per Second. Typically associated with baud rate. 

Built-in I/O: I/O channels that are fabricated into the ROC or FloBoss and do not require a separate 
option. Also called on-board I/O. 

C 
Comm: Abbreviation for communications. Most commonly used as comm port, referring to the 

communications port on the ROC. 

Comm Module: Module that plugs into the ROC or FloBoss unit to provide a channel for 
communications via a specified communications protocol, such as EIA-422 (RS-422) or HART. 

Compare Flag (CF): Compare Flag. Stores the SVD. 

Configuration: Refers either to the process of setting up the software for a given system or the result of 
performing this process. The configuration activity includes editing the database, building schematic 
displays and reports, and defining user calculations. Typically, the software setup of a device that 
can often be defined and changed. Can also mean the hardware assembly scheme. 

Configuration Tree: When a configuration file is open in ROCLINK 800 software, the Configuration 
Tree View menu appears. It is a hierarchy tree style means of navigating within the configuration 
screens. 

CRC: Cyclical Redundancy Check error checking. 

CTS: Clear to Send modem communications signal. 

D 
D/A: Digital to Analog signal conversion. 

DCD: Data Carrier Detect modem communications signal. Also, Discrete Control Device - A discrete 
control device energizes a set of discrete outputs for a given Setpoint and matches the desired result 
against a set of discrete inputs. 
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Deadband: A value that is a zone above the low limits and below the high limits. The purpose of the 
Deadband is to prevent a value such as an alarm from being set and cleared continuously when the 
input value is oscillating around the specified limit. This also prevents the logs or data storage 
location from being over-filled with data. 

Device: Instrument for a specific purpose and generally refers to a ROC or FloBoss unit. 

Device Directory: When ROCLINK 800 software opens, the Device Directory appears. Also referred to 
as the Communication Directory Tree, it provides a hierarchy tree style means of navigating through 
the PC Comm Ports and the ROC Comm Ports setup screens. 

DI: Discrete Input. 

DO: Discrete Output. 

Download: To send data, a file, or a program to the ROC or FloBoss unit. 

DP: Differential Pressure. 

Duty Cycle: Proportion of time during a cycle that a device is activated. A short duty cycle conserves 
power for I/O channels, radios, and such. 

DVS: Dual-Variable Sensor. The DVS provides differential pressure and static pressure inputs to the 
FloBoss 100-Series for orifice flow calculation. 

E 
EFM: Electronic Flow Metering or Measurement. 

EIA-232: Serial Communications Protocol using three or more signal lines, intended for short distances. 
Also referred to as the RS-232 standard. 

EIA-422: Serial Communications Protocol using four signal lines. Also referred to as the RS-422 
standard. 

EIA-485: Serial Communications Protocol requiring only two signal lines. Can allow up to 32 devices 
to be connected together in a daisy-chained fashion. Also referred to as the RS-485 standard. 

EU: Engineering Units. Units of measure, such as MCF/DAY. 

F 
Firmware: Internal software that is factory-loaded into a form of ROM or flash memory. In the ROC or 

FloBoss, the firmware supplies the software used for gathering input data, converting raw input data 
calculated values, storing values, and providing control signals. 

Flash ROM: A type of Read-Only memory that can be electrically re-programmed. It is a form of 
permanent memory and requires no backup power. 

FloBoss: A microprocessor-based unit that provides flow calculations, remote monitoring, and remote 
control. 

FST: Function Sequence Table, a type of program that can be written by the user in a language designed 
by Emerson Process Management. 

G 
GND: Electrical ground, such as used by the ROC or FloBoss power supply. 
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H 
HART: Highway Addressable Remote Transducer protocol. 

Holding Register: Analog output number value to be read. 

Hw: Differential pressure. 

I, J, K 
I/O: Inputs and Outputs. 

I/O Module: Module that plugs into a ROC or FloBoss unit to provide an input or output channel. 

IEC: Industrial Electric Code or International Electrotechnical Commission. For more information 
about the International Electrotechnical Commission, refer to their website: http://www.iec.ch 

IEEE: Institute of Electrical and Electronic Engineers. The Open System Interconnection (OSI) 
reference model and an international standard for the organization of local area networks (LANs) 
established by the International Standards Organization (ISO) and the IEEE. For more information, 
refer to the IEEE website: http://www.ieee.org 

IMV: Integral Multiplier Value. Used in AGA3 calculations. 

Input: Analog or Digital input, a bit to be read. 

Input Register: Input numeric value to be read. 

IRQ: Interrupt Request. Hardware address oriented. 

ISO: International Standards Organization. For more information, refer to the ISO website: 
http://www.iso.ch 

IV: Integral Value. 

L 
LCD: Liquid Crystal Display. Display only device used for reading data. 

LED: Light-emitting diode. 

Logical Number: The Point Numbers used by ROC and ROC Plus Protocol for I/O Point Types are 
based on a physical input or output with a terminal location; the point numbers for all other Point 
Types are “logical” and are simply numbered in sequence. 

LOI: Local Operator Interface (Local Port). Refers to the serial [EIA-232 (RS-232)] port on the ROC or 
FloBoss through which local communications are established, typically for configuration software 
running on a PC. 

LRC: Longitudinal Redundancy Check error checking. 

M, N 
MAC – Media Access Control Address is a hardware address that uniquely identifies each node of a 

network. In IEEE 802 networks, the Data Link Control (DLC) layer of the OSI Reference Model is 
divided into two sublayers: the Logical Link Control (LLC) layer and the Media Access Control 
(MAC) layer. The MAC layer interfaces directly with the network medium. Consequently, each 
different type of network medium requires a different MAC layer. 
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Manual Mode: In a ROC or FloBoss configuration, Manual Mode generally refers to I/O Scanning set 
to Disabled mode. 

Modbus: A popular device communications protocol developed by Gould-Modicon. 

MVS: Multi-Variable Sensor. The MVS provides differential pressure, static pressure, and temperature 
inputs to the FloBoss 407 and ROC800-Series for orifice flow calculation. 

O 
Off-line: Accomplished while the target device is not connected (by a communications link). For 

example, off-line configuration is configuring a ROC in a electronic file that is later loaded into the 
ROC. 

On-line: Accomplished while connected (by a communications link) to the target device. For example, 
on-line configuration is configuring a ROC while connected to it, so that current parameter values 
are viewed and new values can be loaded immediately. 

Opcode: Type of message protocol used by the ROC to communicate with the configuration software, 
as well as host computers with ROC driver software. 

Orifice Meter: A meter that records the flow rate of gas through a pipeline. The flow rate is calculated 
from the pressure differential created by the fluid passing through an orifice of a particular size and 
other parameters. 

P, Q 
P/DP: Pressure/Differential Pressure. 

Parameter: A property of a point that typically can be configured or set. For example, the Point Tag ID 
is a parameter of an Analog Input point. Parameters are normally edited by using configuration 
software running on a PC. 

PC: Personal Computer. 

PI: Pulse Input. 

PID: Proportional, Integral, and Derivative control feedback action. 

PLC: Programmable Logic Controller. 

Point: Software-oriented term for an I/O channel or some other function, such as a flow calculation. 
Points are defined by a collection of parameters. 

Point Number: In ROC800-Series, the physical location of an I/O point as installed in the ROC system 
(module slot and channel). In FloBoss 100-Series, ROC300-Series, and FloBoss 407, the number of 
an I/O point as installed in the FloBoss system. 

Point Type: The point type attribute defines the database point to be one of the possible types of points 
available to the system. The point type determines the basic functions of a point. 

Preset: Number value previously determined for an register. 

Pulse: Transient variation of a signal whose value is normally constant. 

PV: Process Variable or Process Value. 



ROCLINK 800 User Manual 

Rev. Dec-05 Glossary G-5 

R 
RAM: Random Access Memory. In a FloBoss, it is used to store history, data, most user programs, and 

additional configuration data. 

RBX: Report-by-Exception. In a ROC or FloBoss, it always refers to Spontaneous RBX in which the 
ROC or FloBoss contacts the host to report an alarm condition. 

Results Register (RR): Results Register. Stores the SVA. 

ROC: Remote Operations Controller, a microprocessor-based unit that provides remote monitoring and 
control. 

ROM: Read-Only Memory. Typically used to store firmware. 

Rotary Meter: A positive displacement meter to measure flow rate. Also referred to a Roots meter. 

RS-232: Serial Communications Protocol using three or more signal lines, intended for short distances. 
Also referred to as the EIA-232 standard. 

RS-485: Serial Communications Protocol requiring only two signal lines. Can allow up to 32 devices to 
be connected together in a daisy-chained fashion. Also referred to as the EIA-485 standard. 

RTC: Real-time clock. 

RTD: Resistance Temperature Detector. 

RTS: Ready to Send modem communications signal. 

RTU: Remote Terminal Unit. 

RXD: Received data communications signal. 

S 
Soft Point: A type of ROC point with generic parameters that can be configured to hold data as desired 

by the user. 

SP: Setpoint or Static Pressure. 

SPI: Slow Pulse Input. 

SRAM: Static Random Access Memory. Stores data as long as power is applied; typically backed up by 
a lithium battery or super capacitor. 

SRBX: Spontaneous-Report-by-Exception in which the ROC or FloBoss contacts the host to report an 
alarm condition. 

SVA: Signal Value Analog. Stored in the Results Register, it is the analog value that is passed between 
functions in an FST. 

SVD: Signal Value Discrete. Stored in the Compare Flag, it is the discrete value that is passed down the 
sequence of functions in an FST. 

System Variables: Parameters configured that describe the ROC or FloBoss unit. These parameters are 
set in the ROC > Information screen of ROCLINK software. 
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T 
TCP/IP: Transmission Control Protocol / Internet Protocol. 

TDI: Timed Discrete Input, or Time Duration Input. 

TDO: Timed Discrete Output, or Time Duration Output. 

TLP: Type (of point), Logical (or point) number, and Parameter number. 

Turbine Meter: A turbine device to measure flow rate and other parameters. 

TXD: Transmitted data communications signal. 

U – Z 
Upload: To send data, a file, or a program from the ROC or FloBoss unit to a configuration PC or the 

Host. 
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