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System Training 
A well-trained workforce is critical to the success of your operation. Knowing how to correctly install, 
configure, program, calibrate, and trouble-shoot your Emerson equipment provides your engineers 
and technicians with the skills and confidence to optimize your investment. Energy and 
Transportation Solutions offers a variety of ways for your personnel to acquire essential system 
expertise. Our full-time professional instructors can conduct classroom training at several of our 
corporate offices, at your site, or even at your regional Emerson office. You can also receive the 
same quality training via our live, interactive Emerson Virtual Classroom and save on travel costs. 
For our complete schedule and further information, contact the Energy and Transportation Solutions 
Training Department at 800-338-8158 or email us at education@emerson.com.  
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Chapter 1 – Introduction  

In This Chapter 
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1.6.2 Standard Buttons ............................................................... 1-29 
1.6.3 Toolbar Buttons .................................................................. 1-30 
1.6.4 Configuration Tree Menu ................................................... 1-32 
1.6.5 Keystrokes ......................................................................... 1-32 
1.6.6 Help System ....................................................................... 1-33 
1.6.7 Basic Navigation ................................................................ 1-34 
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This chapter describes the ROCLINK™ 800 Configuration software 
(ROCLINK 800) you use to configure and monitor the ROC800-Series 
Remote Operations Controllers (ROCs) and the dynamic user interface.  

1.1 ROCLINK 800 Software Basics 
ROCLINK 800 Configuration software enables you to monitor, 
configure, and calibrate Remote Operations Controllers (ROCs). Remote 
Automation Solutions provides the software and user documentation on a 
DVD-ROM. 
ROCLINK 800 is designed for ease of use. Drop-down menus simplify 
accessing the functions provided by the software. Dialog boxes and drop-
down list boxes (▼) help to direct selections and data entry. You can 
perform actions with the keyboard or a pointing device, such as a mouse. 
Refer to User Interface Basics (located in this chapter) for a description 
of the user interface. 
You access help screens either from the Help menu or in a context-
sensitive fashion pressing the F1 key when your cursor is in a field. This 
feature makes it easy to access on-line information for any ROCLINK 
800 topic. 
You can build custom displays for the ROC that combine both graphic 
and dynamic data elements, and then use these displays to monitor the 
operation of the ROC either locally or remotely. 
The software also provides multiple levels of security for controlling 
access to ROCLINK 800 functions, as well as the ROC database.  
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1.2 Computer Requirements 
ROCLINK 800 runs on most IBM-compatible personal computers (PCs). 
The PC can be a desktop or a portable computer, but must meet the 
following minimum requirements: 
 Pentium-class processor (233 MHz or greater recommended). 
 DVD-ROM drive. 
 Windows 7 (32-bit and 64-bit). 
 Windows 8 (32-bit and 64-bit). 
 Windows 10 (32-bit and 64-bit). 
 Windows Server 2012 
 64 MB of RAM (random access memory). 
 SVGA color monitor, 800 by 600 pixels, small fonts. 
 105 MB of available hard disk space depending on operating system 

and revision level. 
 EIA-232 (RS-232) serial connection or USB-to-serial adaptor, a 

TCP/IP connection, or a dial-up modem connection. 

1.3 Contacting Technical Support 
For technical support, please contact your local sales representative. You 
may also contact Remote Automation Solutions directly. 
Emerson Automation Solutions  

Energy and Transportation Solutions 
Marshalltown, IA 50158 USA  
Houston, TX 77065 USA 
Pickering, North Yorkshire UK Y018 7JA  

Website: http://www.emersonprocess.com/remote/  
Technical Support Website:  

http://www2.emersonprocess.com/en-
US/brands/remote/systems_and_software/supportnet/support_contacts/
Pages/support_contacts.aspx 

Toll Free: (US and Canada) 800.537.9313  
Hours: 24x5 during normal business days 
SupportNet Login: 
www3.emersonprocess.com/remote/support/v2/login.html  

1.4 Software Installation 
Note: The device requires version 1.88 or later of ROCLINK 800. If you 

are using Windows 8 or Windows 7 operating system, refer to 
Installing ROCLINK 800 under Microsoft Windows 10, Windows 8 
or Windows 7 (located in this chapter). 
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To install ROCLINK 800:  
1. Extract the .zip file to the local hard drive (for example, in the 

C:\TEMP\directory) or place the DVD-ROM into the drive.   
2. Double-click the setup.exe file if the Installation Wizard does not 

automatically launch. The Installation Wizard screen appears 
3. Click Next in the ROCLINK 800 Welcome screen. Read the License 

Agreement and click Yes to accept it. Enter your Name and 
Company name, and click Next.   
The program installs the software in the default recommended 
directory C:\Program Files\ROCLINK800 or C:\Program Files (x86) 
\ROCLINK800. Select an alternative destination folder if you want to 
install the software in a folder other than the default. 

4. Follow the setup installation instructions. 
5. Click Finish in the Wizard Complete screen.  

Note: You may need to restart your PC to complete the installation. 

1.4.1 Installing ROCLINK 800 under Microsoft Windows 10, 
Windows 8 or Windows 7 

To install or upgrade ROCLINK 800 on the Microsoft Windows 10, 
Windows 8 or Windows 7 platform, you must temporarily disable User 
Account Control before performing the installation and change your PC’s 
Regional Settings.  
Disabling User Account Control ensures that all files copy and are not  
limited by Windows’ security enhancements. Refer to Disabling User 
Account Control (Windows 10), Disabling User Account Control 
(Windows 8) and Disabling User Account Control (Windows7) (located in 
this chapter). 
Changing your PC’s Region Settings prevents you from potentially 
encountering configuration file errors. Refer to Changing Region Settings 
(Windows 10), Changing Region Settings (Windows 8) and Changing 
Region Settings (Windows 7) (located in this chapter).  

Disabling User Account Control (Windows 10) 
Note:  User Account Control must remain disabled in order to run 

ROCLINK 800. 

To disable User Account Control:  
1. Right-click the Start menu and select Search from the pop-up menu. 
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Figure 1-1. Pop-Up Menu 

2. Type UAC into the Search field. 
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Figure 1-2. Search 

3. Click Change User Account Control settings in the results list. 
4. Move the User Account Control slider to Never Notify. 
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Figure 1-3. User Account Control Settings (Windows 10) 

5. Click OK to save your changes and close the User Account Control 
Settings window. 

Note:  You must have Administrator rights to make this change. 
Click Yes (and enter Administrator password if necessary) if 
Windows asks if you want to allow the changes.   

6. Reboot the computer for your changes to take effect. 
7. Start ROCLINK 800. Refer to Starting ROCLINK 800 Software 

(located in this chapter). 
Disabling User Account Control (Windows 8) 

Note:  User Account Control must remain disabled in order to run 
ROCLINK 800. 

To disable User Account Control:  
1. Select Search and type UAC into the Search field. 
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. 
Figure 1-4. Search 

2. Select Settings and click Change User Account Control settings. 

 
Figure 1-5. Settings – Results for “uac” 

3. Move the User Account Control slider to Never Notify. 
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Figure 1-6. User Account Control Settings 

4. Click OK to save your changes and close the User Account Control 
Settings window. 

Note:  You must have Administrator rights to make this change. 
Click Yes (and enter Administrator password if necessary) if 
Windows asks if you want to allow the changes. 

 
5. Reboot the computer for your changes to take effect. 
6. Start ROCLINK 800. Refer to Starting ROCLINK 800 Software 

(located in this chapter). 
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Disabling User Account Control (Windows 7) 
Note:  User Account Control must remain disabled in order to run 

ROCLINK 800. 

To disable User Account Control:  
1. Select Start and type MSCONFIG  in the Search field.  
2. Click the program file msconfig.exe. The System Configuration 

screen displays.  

  
Figure 1-7. System Configuration  

3. Click the Tools tab. 
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Figure 1-8. Change UAC Settings  

4. Select Change UAC Settings. 
5. Click Launch. The User Account Control Settings window displays.  

 
Figure 1-9. User Account Control Settings 

6. Move the User Account Control slider to Never Notify. 
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7. Click OK to save your changes and close the User Account Control 
Settings window.  

Note: You must have Administrator rights to make this change. 
Click Yes (and enter the Administrator password if necessary) 
if Windows asks if you want to allow the changes. 
 

.   

8. Reboot the computer to apply the changes. 
9. Start ROCLINK 800. Refer to Starting ROCLINK 800 Software 

(located in this chapter). 
Changing Region Settings (Windows 10) 

To avoid potential error when opening configuration files, we recommend 
that you change your PC’s location to United States. 
To change your PC’s location: 
1. Right-click the Start menu and select Search from the pop-up menu. 
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Figure 1-10. Pop-Up Menu 
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2. Type region into the search field. 

 
Figure 1-11. Search 

3. Click Region settings in the results list. 
4. Change or verify that the Regional format field is set to English 

(United States). 

 
Figure 1-12. Regional Format 

Changing Region Settings (Windows 8) 
To avoid potential errors when opening configuration files, we 
recommend that you change your PC’s location to United States. 
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To change your PC’s location: 
1. Select Search and type region into search field. 

 
Figure 1-13. Search 

2. Select Settings and click Region in the results list. 

 
Figure 1-14. Search Results 

3. Change or verify that the current location is set to United States. 
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Figure 1-15. Home Location 

4. Click OK to save changes and close the Region window. 

Changing Region Settings (Windows 7) 
To avoid potential errors when opening configuration files, we 
recommend that you change your PC’s location to United States. 
To change your PC’s location: 
1. Select Start > Control Panel. The Control Panel displays: 
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Figure 1-16. Control Panel 

2. Select Clock, Language, and Region. The Clock, Language, and 
Region screen displays: 

 
Figure 1-17. Clock, Language, and Region 

3. Click Change location. The Region and Language screen displays 
showing the Location tab. 
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Figure 1-18. Region and Language 

4. Change or verify that the current location is set to United States. 
5. Click OK to save your changes and close the Region and Language 

window. 
Enabling User Account Control (Windows 10) 

Note:  User Account Control must remain disabled in order to run 
ROCLINK800. 

To enable User Account Control:  
1. Right-click the Start menu and select Search and from the pop-menu. 
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Figure 1-19. Pop-Up Menu 
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2. Type UAC into the search field. 

 
Figure 1-20. Search 

3. Click Change User Account Control settings in the results list. 
4. Move the User Account Control slider to the default position. 
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Figure 1-21. User Account Control Settings 
5. Click OK to save your changes and close the User Account Control 

Settings window. 

Note:  You must have Administrator rights to make this change. 
Click Yes (and enter Administrator password if necessary) if 
Windows asks if you want to allow the changes.   

6. Reboot the computer for your changes to take effect. 
7. Start ROCLINK 800. Refer to Starting ROCLINK 800 Software 

(located in this chapter). 
Enabling User Account Control (Windows 8) 

Note:  User Account Control must remain disabled in order to run 
ROCLINK800. 

To disable User Account Control:  
1. Select Search and type UAC into the search field. 
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Figure 1-22. Search 

2. Select Settings and click Change User Account Control settings. 

 
Figure 1-23. Setting, Results for “uac” 

3. Move the User Account Control slider to the default position. 
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Figure 1-24. User Account Control Settings 
4. Click OK to save your changes and close the User Account Control 

Settings window. 

Note:  You must have Administrator rights to make this change. 
Click Yes (and enter the Administrator password if necessary) 
if Windows asks if you want to allow the changes. 

 
5. Reboot the computer for your changes to take effect. 
6. Start ROCLINK 800. Refer to Starting ROCLINK 800 Software 

(located in this chapter). 
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Enabling User Account Control (Windows 7) 
Note: User Account Control must remain disabled in order to run 

ROCLINK 800. 

To enable User Account Control:  
1. Select Start and type MSCONFIG in the Search field.  
2. Click the program msconfig.exe. The System Configuration screen 

displays:  

 
Figure 1-25.  System Configuration 

3. Click the Tools tabs. 

 
Figure 1-26. Change UAC Settings  
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4. Select Change UAC Settings.  
5. Click Launch. The User Account Control Settings screen displays.   

 
Figure 1-27. User Account Control Settings  

6. Move the User Account Control slider to the default position.  
7. Click OK to save your changes and close the User Account Control 

Settings window.   

Note: You must have Administrator rights to make this change. 
Click Yes (and enter the Administrator password if necessary) 
if Windows asks if you want to allow the changes. 
 

.   

8. Reboot the computer to apply your changes.   
9. Start ROCLINK 800. Refer to Starting ROCLINK 800 Software. 

1.4.2 Un-installing ROCLINK 800 
To remove ROCLINK 800 from your PC:  
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1. Click the Windows Start button. 
2. Select Settings > Control Panel. 
3. Double-click the Add/Remove Programs icon. 
4. Select ROCLINK 800. 
5. Click Add/Remove. 
6. Follow the instructions. 

1.5 Starting ROCLINK 800 Software 
To use ROCLINK 800 to configure a hardware device, you must have the 
ROC properly connected to power. Refer to the appropriate hardware 
instruction manual. You must also connect the PC to the device’s Local 
Operator Interface (LOI), Ethernet, serial, or modem port.  
To run ROCLINK 800, perform one of the following: 
 Double-click the Desktop Shortcut. 
 Select Start > Programs > ROCLINK 800 > ROCLINK 800. 
The software loads and initializes. 

Note: You can only run one version of ROCLINK 800 at a time. 

1.5.1 Logging On 
To log on to ROCLINK 800:  
1. Connect the ROC to the Local Operator Interface (LOI – Local Port) 

and launch ROCLINK 800. 

  
Figure 1-28. Logon 
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2. Type your assigned User ID. If User IDs have not yet been assigned, 
try using the default User ID of LOI. You assign User IDs using the 
ROC > Security features of ROCLINK 800.  

Note:  The requirements for the User ID field differ based on if you 
have selected Enable Enhanced Security Features (ROC > 
Security). For more information, refer to Section 3.7.3 
Enhanced Security. 

3. Type your assigned Password and click OK.  
For added security, the software displays an asterisk for each number 
that you type. If passwords have not yet been assigned, use the default 
password of 1000 (valid with default User ID of LOI). 

Note:  The requirements for the Password field differ based on if 
you have selected Enable Enhanced Security Features 
(ROC > Security). For more information, refer to Section 
3.7.3 Enhanced Security. 

ROCLINK 800 validates the User ID and Password you enter against 
a predefined list.  
If the log on is not valid, a dialog box appears. Click OK and re-enter 
the User ID and Password. You can repeat the procedure as many 
times as needed until you successfully enter a valid User ID and 
Password. If the log on is valid, ROCLINK 800 displays the Device 
Directory screen. 

To exit from the log on screen, press Esc or click Cancel. This closes 
ROCLINK 800 and returns you to the point where you started ROCLINK 
800. 
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1.6 User Interface Basics 
You interact with ROCLINK 800 using various displays on the computer 
monitor, keyboard, and pointing device.  
The major components of ROCLINK 800 user interface are: 
 Graphical interface. 
 Menu bar and menus. 
 Toolbar. 
 Function screens. 
 Dialog boxes. 
 Help system, including the Status bar and message boxes. 
 Device Directory or Configuration Tree menu. 
ROCLINK 800 employs a graphical user interface (GUI) with a standard 
Windows menu structure. After logging on to ROCLINK 800, available 
functions display in a menu bar with drop-down menus:  

 
Figure 1-29. ROCLINK 800 Menu 

A Status Line at the bottom left of the display contains pertinent 
information about the highlighted item, such as a menu option or a 
parameter. 
Buttons display dialog boxes for further configuration details or perform 
a desired action, such as the Update button. To activate the button: 
1. Click the button with a left click of the mouse.  
2. When a button is active, press Enter or a function key. 
Dialog boxes are areas that "pop up" inside the current screen to allow 
further selections or enter values. Dialog boxes also provide messages or 
more detailed information. 
The menu structure lists choices from which you can set the desired 
function. Once a function is selected, the screen or dialog box for that 
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function displays. This screen or dialog box provides the requested 
information and lets you enter the applicable configuration data. 

Table 1-1. Menu Listing for ROCLINK 800 (ROC800-Series)  

Menu Options 
File New, Open, Download, Close, Save Configuration, Print 

Configuration, Print, Print Setup, [List of recent files], Exit 
View Directory, EFM Report, Calibration Report, History, Alarms, 

Events, Weights & Measure Events, Display, I/O Monitor, 
Toolbar, Refresh User Program Tree 

ROC Direct Connect, Connect, Disconnect, Collect Data, Clock, 
Security, Comm Ports, Information, Flags 
Note: The Direct Connect menu option is the default; it 

directs ROCLINK 800 to connect with any available 
valid connection. The Connect menu option becomes 
available when you select a connection option (COM1, 
COM2, Ethernet, and such.) from the Device Root. By 
clicking Connect, you tell ROCLINK 800 to use that 
specific communications connection.  

Configure I/O, Control, History Segments, History Points, Opcode 
Table, MODBUS 

Utilities Update Firmware, License Key Administrator, Convert EFM 
File, User Program Administrator, ROCLINK 800 Security, AI 
Calibration Values, RTD Calibration Values, MVS Calibration 
Values, FST Editor, Custom Display Editor, Custom EFM 
Report Editor, Read File From Device, Communications 
Monitor 

User 
Programs 

(Located under the Configuration Tree) LiquidCalcs, 
Transaction History, Printer, Additives, Batching, Keypad 
Display  

Tools Options 
Window Cascade, Tile, Device Directory, [List of open windows] 
Help Help Topics, About ROCLINK 800 

1.6.1 Device Dynamic Interface 
You can navigate the device options either by using the ROCLINK menu 
structure or by clicking on the ROC graphical dynamic interface and 
selecting a tab or button. The dynamic interface display shows the current 
settings of the point including alarms and integrity.  
The system displays a white line around objects that are links when you 
hover your cursor over them. A link descriptor displays indicating the 
links definition. 
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Figure 1-30. Device User Interface 

1.6.2 Standard Buttons 
Several buttons appear on the majority of ROCLINK 800 screens.  

Button Description 

 
Minimizes and hides windows.  

 
Maximizes the size of the windows to fit in the screen 
area.   

 
Restores window to original size.   

 
Closes a window.   

 
Expands options listed in the Device Directory or 
Configuration Tree Menu.  

 
Hides options listed in the Device Directory or 
Configuration Tree Menu.  

 
Prints the active display.   

 
Click to Browse for a selection.  

 
Updates contents of the active window from the device.   

 
Copies the contents of window to Clipboard.   
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Pastes the contents of the Clipboard to the active 
window.   

 
Applies changes on the active window to the device 
and close the active window. A Confirm Save dialog 
box appears if there are unsaved changes.   

 
Cancels without saving changes and closes the active 
window.   

 
Applies changes on the active window to the device. 
Clicking Apply does not close the active window.   

 
Saves the contents of the active window to the 
configuration file.   

 
Closes the active window. A Confirm Save dialog box 
appears if there are unsaved changes.   

 
Deletes the current selection.   

 
Starts automatic device polling.   

 
Stops automatic device polling.   

1.6.3 Toolbar Buttons 
The following buttons appear in the ROCLINK 800 toolbar.  

 
Figure 1-31. ROCLINK 800 Toolbar 

ROCLINK 800 grays out a button if it is not applicable to the current 
screen.  

Button Description  

 

Creates a new configuration file. You specify available 
configuration parameters using menu selections. Configure the 
file as if you were connected to the device. Functions requiring a 
live connection are unavailable in this mode.  

 
Opens an existing configuration file. You create configuration 
files using the New Device or Save Configuration functions.  

 
Saves the current configuration of the connected device to a 
disk file.  

 
Deletes currently selected text and place it in the Clipboard. 
Note: Currently not available.  

 
Copies currently selected text and places it in the Clipboard. 
Note: Currently not available. 
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Button Description  

 
Pastes text currently in the Clipboard at the cursor’s current 
location. 
Note: Currently not available. 

 
Prints the configuration file. 
Note: Currently not available.  

 
Connects to a device locally using the (LOI) Local Operator 
Interface port. 

 
Disconnects from a device. 

 
Displays the first of two .DSP files loaded on the device.  
Note:  Not currently functional on the ROC800-Series platform.  

 
Displays the second of two .DSP files loaded on the device. 
Note:  Not currently functional on the ROC800-Series platform. 

 
Displays the Analog Input (AI) screen. 

 

Displays the Discrete Input (DI) screen. 

 
Displays the Pulse Input (PI) screen. 

 

Displays the Analog Output (AO) screen. 

 

Displays the Discrete Output (DO) screen. 

 
Displays the Comm Port screen. 

 
Displays the Flags screen.  

 
Displays the Clock screen. 

 
Displays the Meter Setup screen.  

 
Displays the Plate Change screen.  

 
Displays the PID Loop screen.  

 
Opens the Function Sequence Table (FST) Editor.  

 
Displays an About ROCLINK 800 screen providing program 
information, version, creation date, and copyright for ROCLINK 
800.  
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Button Description  

 
Launches the ROCLINK 800 on-line help system.  

1.6.4 Configuration Tree Menu 
When you open a configuration file or go on-line with a ROC, the 
Configuration Tree appears on the left-hand side of the screen. The tree 
hierarchically displays the parts of a configuration (such as I/O, Meter 
Runs, and History) that you can change.  

   
Figure 1-32. Configuration Tree Menu 

From the Configuration Tree, you may change the configuration or 
monitor current operations. Once you are in the Configuration Tree menu, 
you can use the + and – symbols to display or hide various options.  
Double-click the desired function in the Configuration Tree to display the 
associated screen. Double-clicking an icon is the same as selecting the 
option in the menu bar or clicking a Toolbar button. 
If this is the first time that you have connected to the ROC, refer to 
Setting the Clock (located in Chapter 6). 

1.6.5 Keystrokes 
If you are using the keyboard, you may use the Alt key plus one or more 
letters to access menus. Windows underlines the appropriate letter in the 
menus. For example, to access the Open File dialog box, press Alt + F 
and press O. You may also use the Left Arrow () and Right Arrow () 
keys to highlight a menu bar item (the help Status Line at the bottom of 
the screen provides a description of the menu) and press the letter.  
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With a menu displayed, you can highlight the desired item by using the 
Down Arrow () and Up Arrow () keys or the mouse. Once you have 
highlighted an item, press Enter to activate the function. 
To leave a menu or submenu, press Esc. You can then select another 
menu. You can also access another menu using  and . 
The text scrolling keys are Page Up and Page Down. 
To use the keyboard in configuration screens and dialog boxes, press Tab 
to move in a predetermined sequence from one parameter field or button 
to the next. The selected field or button becomes highlighted. Fields 
unavailable for changes are automatically skipped. 
When you Tab to the last field or button in the screen or dialog box, 
pressing Tab again jumps back to the first field or button. To go back to a 
previous field or button, press Shift + Tab. 
In an option field, the currently selected option is highlighted. To select 
one of the other options, use  or  to highlight the desired option and 
then press Enter. 
In a field that requires a text or numerical entry, type in the required 
characters or numbers from the keyboard. Use Backspace or Delete to 
erase unwanted characters. Use  and  to move the cursor one 
character at a time and Home and End to place the cursor at the 
beginning and end of the field, respectively. 
Other keys or key combinations include: 
 F1 – Launches ROCLINK 800 on-line help. 
 Esc – Cancels the current activity, closes the screen, and returns you 

to the last-used place in the menu structure, screen, or other place 
from which the dialog box originated. If a menu is active, Esc closes 
the last-opened menu, taking you up one level in the menu structure. 
If the menu bar is active, Esc de-selects all menu options. Press Alt or 
click with the mouse to reactivate the menu bar. 

 Ctrl + N – Creates a new configuration file. 
 Ctrl + O – Opens a configuration file. 
 Ctrl + S – Saves the current configuration file. 

1.6.6 Help System 
The Help menu provides detailed on-screen information about getting 
started with ROCLINK 800 and performing keyboard operations, a list of 
the Help topics, and the ROCLINK 800 version. 
To display context sensitive help on a field, a parameter, or a button, 
press F1 while the field, parameter, or button is highlighted. A help 
window appears on the screen. 
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To view detailed help, select Help > Help Topics from the menu bar. 
Table 1-2. Help System 

Option Description 
Contents Presents a list of Help Topics that display based on task-

oriented situations. Each screen, tab, and field has a help 
topic associated with it. For example: the MODBUS Scale 
Values tab is located under Modbus > Modbus 
Configuration > Scale Values tab. 

Index Locates specific Help Topics. The Index lists each field by the 
tab or screen in which the field appears. 

Search Activates a search function on a specific word. 
Back Returns to the last topic that you viewed. 
Print Sends the currently displayed topic to the PC’s default 

printer. 
See Also Displays topics related to the currently selected topic. 
<< / >> Navigates forward (>>) or backwards (<<) through the help 

system on a per topic basis. The Browse Sequence follows 
the order of the topics as displayed in the Contents tab. 

1.6.7 Basic Navigation 
When you start the ROCLINK 800, the Device Directory displays. After 
you connect to a ROC, the Configuration Tree View displays.  
Use the + and – symbols to display or hide various options. Double-click 
a point to display the associated parameter configuration screen. You can 
also use the menu options and buttons to display the associated parameter 
configuration screen. 
The Status Line at the bottom of the Device Directory and Configuration 
Tree provides critical information. The left side displays brief information 
about the device being connected. The right side displays the device 
status (on-line or off-line) and system time. 

TLP Selections 

 

In many locations in ROCLINK 800, you can click the TLP Browse 
button (a button with three dots) to view the Select TLP dialog. The 
Select TLP dialog allows you to assign specific inputs and outputs to 
parameters. ROCLINK 800 uses Point Type (T), Logical Number (L), 
and Parameter (P) to define point locations.  
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Figure 1-33. Select TLP 

To use the Select TLP dialog box: 
1. Select the Point Type from the list. This opens a list of logical 

numbers and parameters that belong to that Point Type. 
2. Select the Logical Number. In the configuration screens, the Logical 

Number is generally referred to as Point Number or Number. 
3. Select the specific Parameter. These are usually called by the same 

term as the Tag on the configuration screen. 
The field at the bottom of the Select TLP dialog displays the numeric 
point location of the TLP point or a text abbreviation, depending on 
the setting in the Tools > Options window. 

4. Select the Show All Point Types and Parameters checkbox to view 
all points and parameters regardless of their validity. By default, 
ROCLINK only displays points and parameters that are valid for the 
current configuration you are performing. 

5. Click OK.  

Display TLP Displays values on the Select TLP screen as either text or numbers. For 
example, the TLP for Register 2 of FST 1 could display as either "FST 
1,R2" or "96, 0, 3". 

Auto Scan Update 
Interval  

Select Tools > Options to set the time interval, in seconds, at which the 
Auto Scan feature on various screens in ROCLINK 800 polls the ROC. 
Clicking Auto Scan causes ROCLINK 800 to poll the device 
automatically until you click Stop Scan.  
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1.6.8 Text Boxes 
Text boxes appear in various places throughout ROCLINK 800. You can 
enter alphanumeric character (A through Z and 0-9) into text boxes. For 
example, you can enter name (tag) for a device or a short description for 
an I/O point.
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Chapter 2 – Device Directory and Device Root 

In This Chapter 

2.1 Device Directory .................................................................................... 2-1 
2.1.1 Communication Parameter Setup Screen .................................. 2-2 

2.2 Device Root ........................................................................................... 2-4 
2.2.1 Backing Up Configurations ......................................................... 2-4 
2.2.2 Adding a Group .......................................................................... 2-5 
2.2.3 Deleting a Group ........................................................................ 2-5 
2.2.4 Adding a Device ......................................................................... 2-5 
2.2.5 Deleting a Device ....................................................................... 2-6 
2.2.6 Deleting All Devices ................................................................... 2-6 
2.2.7 Renaming a Group or Device ..................................................... 2-7 

 
This chapter describes the Device Directory screen and the Device Root, 
the graphical representation of all devices, which appears on that screen.   

2.1 Device Directory 
The Device Directory is the first screen that displays after you 
successfully log onto ROCLINK 800 but before you connect to a 
device.  

 
Figure 2-1. Device Directory and Device Root 

Note: Once you connect to a device, ROCLINK 800 replaces the 
Device Directory screen with a device-specific configuration 
tree screen (see Figure 2-2).  
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Figure 2-2. Configuration Tree 

You use the Device Directory screen to create and maintain 
communications setup configurations for a PC running ROCLINK 800. 
You can uniquely configure the communication ports on the PC to send 
data to a specified ROC. You may add, delete, or modify these 
communications setups and establish a tree of groups and devices. 
Use the + and – symbols to display or hide various options. 

Note: You can only configure a PC’s communications ports from the 
Device Directory screen. To re-display the Device Directory 
screen at any time, select Window > Device Directory or View 
> Directory. 

2.1.1 Communication Parameters Setup Screen 
The ROCLINK 800 Communication Parameter Setup screen allows you 
to change your PC communications port, time-out settings, and other 
variables ROCLINK 800 uses when establishing a connection to a 
device.  
In order for ROCLINK 800 to communicate with a device, ROCLINK 
800 must know to which device it is communicating. Each device 
within a group is given a unique device address. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Device Directory and Device  2-3 

To set the PC communication parameters: 
1. Right-click the label in the Device Directory that corresponds to the 

PC port you want to use.   

 
Figure 2-3. Device Pop-up Menu Tree 

2. Select Properties. The ROCLINK 800 Communications Parameters 
screen displays.  

  
Figure 2-4. Communication Parameters 
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3. Configure the ROCLINK 800 communications parameters (refer to 
Chapter 3, Communications and Security for a complete discussion 
of this screen).  

4. Click Apply. You are ready to connect to the ROC. 

2.2 Device Root 
The device root graphically represents the devices and their 
organizational structure on the Device Directory screen. When you open 
ROCLINK 800, the device root displays the default device labels. Using 
the Communication Parameters screen, you can modify the 
communications setup configurations for these devices or add new 
devices with new configurations. Each icon on the device root 
represents a different type of communications connection.  

 
Figure 2-5. Device Root 

The default device labels, which correspond to available communication 
ports, include: 
 COM1 Device. 
 COM2 Device. 
 Modem Device. 
 Ethernet Device. 
 New Group1 > New Device1. 
 New Group1 > New Device2. 
You may add, delete, or modify the communication configurations for 
each of these devices. You can also define device groups.   

2.2.1 Backing Up Configurations 
After you configure your device settings, we strongly recommend that 
you create a back-up file of those settings. ROCLINK 800 stores these 
values in the file ROC_USER.mdb. Use Windows Explorer to find the 
ROC_USER.mdb file, then copy the file and store it in a safe place. 
This backup file enables you to restore your settings in case they ever 
become corrupted.  
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You can configure devices on-line communications using the Local 
Operator Interface (LOI) Port (also known as the "local port") or a 
communication port, such as a modem. 

2.2.2 Adding a Group 
You can organize devices into groups. Typically, groups contain devices 
in the same geographical area or with another common feature. When 
you double-click a group icon, ROCLINK 800 displays all devices or 
subgroups associated with that group.  
To add a new group to the device root directory:  
1. Right-click the Device Root icon. A pop-up menu displays. 
2. Select Add a Group. ROCLINK 800 adds the new group icon to the 

device root graphic. 

To add a subgroup to an existing group: 
1. Right-click the Group icon. A pop-up menu displays. 
2. Select Add a Group. ROCLINK 800 adds the new group icon to the 

selected group. 

2.2.3 Deleting a Group 
To delete a group:  
1. Right-click a group icon. A pop-up menu displays.  
2. Select Delete Group. A Confirm Delete dialog box displays.  

 
Figure 2-6. Delete Group 

3. Click Yes to delete the group and all subordinate groups and devices 
in that group.  

2.2.4 Adding a Device 
To add a new device to the device root:  
1. Right-click the device root icon. A pop-up menu displays. 
2. Select Add a Device. ROCLINK 800 adds a device icon to the 

device root. 
3. Configure the new device’s communication parameters (see Chapter 

3, Communications and Security). 
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To add a device to an existing group: 
1. Right-click the group icon. A pop-up menu displays. 
2. Select Add a Device. ROCLINK 800 adds a device icon in the 

selected group. 
3. Configure the new device’s communication parameters (see Chapter 

3, Communications and Security). 

2.2.5 Deleting a Device 
To delete a device:  
1. Right-click a device icon. A pop-up menu displays.  
2. Select Delete Device. A Confirm Delete dialog displays.   

  
Figure 2-7. Delete Device 

3. Click Yes to delete the device.  

2.2.6 Deleting All Devices 
To delete all device communication parameter configurations in the 
device root directory:  

Note: This deletes all ROC units that you currently have configured. 

1. Right-click the device root icon. A pop-up menu displays. 
2. Select Delete All Devices. A Confirm Delete dialog displays. 

  
Figure 2-8. Delete All Devices 

3. Click Yes. ROCLINK 800 deletes all devices in the device root.  
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2.2.7 Renaming a Group or Device 
You can easily replace the ROCLINK 800-provided default group or 
device names with names you choose. To rename a group or device in 
the Device directory:  
1. Right-click the device or group icon. A pop-up menu displays. 
2. Select Rename.  
3. Enter a name. 

Note: Although your label can be up to 72 characters in length, keep 
the label short for easy recognition. 

4. Press Enter when finished. ROCLINK 800 adds the new label to the 
device or group. 
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Chapter 3 – Communications and Security 
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This chapter describes how to configure the communication ports on a 
PC and on a ROC. It also describes how to use the Connect and Direct 
Connect features in ROCLINK 800 and how to define security to 
control access to the ROC800-Series and ROCLINK 800.  

3.1 Communications 
Before you attempt to connect to a ROC, you must configure 
communication parameters in two places:  
 ROCLINK 800 Communications 

Configure device communications on the Device Directory screen 
(Device Directory and Device Root). This sets the PC’s comm ports 
to communicate with a specific device. 

 Communication Ports on the ROC800-Series 
Select ROC > Comm Ports to access the Comm Port screen and 
configure the device communication ports for incoming or outgoing 
communications. Refer to the Communication Ports section. 

3.2 ROCLINK 800 Communications 
The Device Directory communication configurations allow ROCLINK 
800 to communicate to an individual ROC800-Series.  
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To set the PC communication parameters: 
1. Right-click the label in the Device Directory that corresponds to the 

PC port you want to use. 
2. Select Properties. The ROCLINK 800 Communication Parameters 

screen displays. 
3. Configure the ROCLINK 800 communications parameters. Refer to 

Communications and Security. 
4. Click Apply. You are ready to connect to the ROC. 

3.2.1 ROCLINK 800 Communications General Tab 
The Device Directory is the first screen that displays after you 
successfully log onto ROCLINK 800 but before you connect to a 
device.  
To display the ROCLINK 800 Communication Parameters screen, right-
click on a device icon in the device root and select Properties. The 
ROCLINK 800 Communication Parameters screen displays, showing 
the General tab.  
Use the General tab to configure basic communications for the PC 
running ROCLINK 800. 

  
Figure 3-1. ROCLINK 800 Communication Parameters, General tab 
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Field Description 
Tag Sets a unique name for the ROC800-Series. Enter 

up to 50 alphanumeric characters to identify the 
device.  

Connect Click to communicate with the PC using the 
parameters you configure for this PC’s 
communications port.  

Device Address  Sets the address of the specific ROC800-Series 
with which you desire to communicate. If you 
connect to a multi-drop series of devices, enter the 
Device Address and Device Group of the specific 
device.  
Note: The default values for the Device Address 
and Device Group are both 240.  . 

Device Group  Associates the ROC with a specific group. The 
default Device Group is 240.  
Note:  If you connect a PC running ROCLINK 800 

directly to the device’s LOI (Local Port), 
ROCLINK 800 makes a request to Device 
Group of 240 and Device Address of 240. 
The Local Port of a device always responds 
to a request for Address 240 and Group 
240, no matter what Device Address and 
Device Group is configured in the device if 
the LOI Security is valid.  

Host Address  Identifies the PC’s host address, which by default is 
Address 3. If more than one computer running 
ROCLINK 800 communicates with a group of 
devices (either by radio or by other multi-drop 
communications), you must define unique host 
address for each device to avoid multiple 
responses. The host address must also be different 
from any other host system that may access the 
communications link.  
Use the following host group and host address 
conventions: 0 and 240 are reserved  

Host Group  Identifies the PC’s host group, which by default is 
1. When using ROC Protocol, the group address 
must match the address defined at the destination 
device in order for communications to properly 
transmit.  
Use the following host group and host address 
convention: 0 and 240 are reserved  

Use  Sets the type of connection. Valid values are 
Comm Port, Modem, or TCP/IP.  
Note:  If you select TCP/IP, ROCLINK 800 applies 

only the Time Out parameter you define on 
the Advanced tab. No other parameters 
defined on that tab apply.  
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Field Description 
PC Comm Port  Sets the PC comm port ROCLINK 800 uses for this 

setup. The ROC can communicate through any of 
the PC’s configured comm ports. The default comm 
port is 1.  
Note:  This field is available only if you set the 

Comm Port option. Before you select this 
parameter, check to see which 
communications ports are assigned in the 
PC. 

PC Baud Rate  Sets the baud rate ROCLINK 800 uses to 
communicate with the device through a serial port 
(COM port). For successful communications, the 
baud rate you set here must match the baud rate 
on the PC. The default value is 19200. If you have 
difficulties communicating to your device, set the 
baud rate in both the device and the computer to 
the default baud rate.  
Note:  This field is available only if you select the 

Comm Port option. 
Modem  Indicates the modem ROCLINK 800 uses. Click ▼ 

to list all available modems. Only the modems 
defined in the Windows Control Panel display. 
Ensure that the modem you select is properly set 
up.  
Note:  This field is available only if you select the 

Modem option. 
Phone Number Sets the telephone number for the device 

ROCLINK 800 dials.  
Note:  This field is available only if you select the 

Modem option. 
Override Default 
TAPI Init String 

Indicates that ROCLINK 800 should use an 
override initialization string configuration. When 
you select this option, you must provide an override 
initialization string.  
Note:  This field is available only if you select the 

Modem option. 
IP Address  Indicates the IP address for the TCP/IP connection.  

Note:  This field is available only if you select the 
TCP/IP option.  

Port Number  Indicates the port for the TCP/IP connection.  
Note:  This field is available only if you select the 

TCP/IP option.  
Refresh Comm Port 
List 

Click to enable ROCLINK 800 to refresh the listing 
of the displayed comm ports for the PC.  

3.2.2 ROCLINK 800 Communications Advanced tab 
Use the Advanced tab on the ROCLINK 800 Communication 
Parameters screen to configure advanced communications features.  
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Figure 3-2. ROCLINK 800 Communication Parameters, Advanced tab  

Field Description 
Number of Retries  Sets the number of times (after the initial attempt) 

ROCLINK 800 tries to request data from the 
specified device before reporting a timeout error. 
Valid values are between 0 and 25. The default is 
3. Use the Time Out parameter to adjust the 
amount of time between retries.  
Note:  This parameter does not apply to the dial-

up modem, which only tries to establish a 
connection once.  

Tx Delay  Sets, in seconds, the amount of time ROCLINK 
800 waits before transmitting data. This delay 
enables the request-to-send (RTS) line for the 
amount of delay specified before transmitting data. 
The default is 0.05.  
Typically, this value allows a radio to fully stabilize 
before the system applies data for transmission. 
 For EIA-232 (RS-232) and dial-up modem 

communications, set this value (and the value 
in the Key Off Delay field) to 0 (zero) or the 
default of 0.05 seconds. 

 For EIA-485 (RS-485) and radio 
communications, set this value to 0.1. 

Note:  These variables may change, based on 
your situation. These are general values 
that you need to assess for each 
circumstance. 
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Time Out  Sets, in seconds, the actual amount of time that 
ROCLINK 800 waits to receive a valid message 
after it sends a request to a device. The default is 
3. Modem users typically accept the default value.  
Do not set this field to 0 (zero). This prevents 
ROCLINK 800 from timing out, and quickly 
exhausts the retries.  
Note:  If you select TCP/IP as the communications 

method on the General tab, ROCLINK 800 
applies only the Time Out parameter. No 
other parameters defined on that tab apply. 

Key Off Delay  Sets, in seconds, the amount of time ROCLINK 
800 waits after transmitting a message before 
turning off the ready to send (RTS) signal. The 
default is 0. You can change this value to optimize 
communications.  
The default value should be sufficient for dial-up 
modems and EIA-232 (RS-232) connections. For 
radios, a value of 0.01 may be appropriate. 

Host CRC Check  Indicates whether ROCLINK 800 uses cyclical 
redundancy checking. The default value is 
Enabled.  

3.3 Communication Ports  
In addition to configuring the communications ports on the PC, you also 
configure the device-specific communication parameters.  
While in a configuration and on-line with a device, select ROC > 
Comm Ports to display the Comm Port screen. Each communications 
port has a unique set of parameters on the screen. 
Use the Comm Port screen to set up the communications ports that are 
available for incoming and outgoing communications with the ROC. 

Note:  Use the Device Directory to define PC communication ports. 

The communication ports located on the ROC provide a data link to 
ROCLINK 800, other devices, and host systems. The type of module 
enables the following communications: 
 EIA-232 (RS-232) serial communications. 
 EIA-422 (RS-422) serial communications. 
 EIA-485 (RS-485) multi-point serial communications. 
 Dial-up modem communications. 
 TCP/IP communications. 

Table 3-1. Communication Ports for the ROC800-Series 

Port Port Location Default Tag Function/Type 
1 CPU RJ-45 (top) Local Port LOI / RS-232D 
2 CPU RJ-45 (middle) COMM1 Ethernet 
3 CPU 5-pin (bottom) COMM2 Serial / EIA-232 (RS-232) 
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Port Port Location Default Tag Function/Type 
4 Module Slot 1 COMM3 EIA-232 (RS-232), EIA-485 (RS-485), or Modem 
5 Module Slot 2 COMM4 EIA-232 (RS-232), EIA-485 (RS-485), or Modem 
6 Module Slot 3 COMM5 EIA-232 (RS-232), EIA-485 (RS-485), or Modem 

3.4 Configuring Communications Ports 
The ROC comm. ports provide a link to computers, such as one running 
ROCLINK 800 or a host computer.  
Select ROC > Comm Ports to set up communication ports available for 
the ROC. 
The SRBX or RBX (Spontaneous Report-by-Exception) alarming 
feature is available for serial communication ports. It is not supported 
on the Ethernet port. This feature allows the device to call in to a host 
computer when a configured alarm occurs. To prevent "nuisance" 
alarms from being reported to the host, configure the parameters 
correctly. If you wish to configure dial-up RBX, a modem must be 
present with the correct configuration. 
When using RBX Alarming, you must ensure that the alarms are 
enabled and configured for each point you desire to monitor. Configure 
the alarm parameters so that an alarm occurs only when desired. 
Configure the parameters on the Alarms tabs of the I/O configuration 
screens. 
After you configure the alarms, save the configuration of all 
communications ports to programmable ROM using ROC > Flags > 
Flash Memory Save Configuration.  

 
Note:  You also access the Comm Port screen by selecting ROC > 

Comm Ports from the ROCLINK 800 menu bar and then 
selecting the appropriate comm port from the drop-down menu 
or by selecting the Comm Ports icon from the menu bar.    

 

3.4.1 Configuring TCP/IP Communications on the Ethernet Port  
Use TCP/IP connections through the Ethernet port for DS800, Modbus® 
RTU encapsulated in TCP/IP, Modbus TCP/IP, or ROC Plus Protocol 
communications.  
To configure TCP/IP communications: 
1. Connect to the ROC800-Series. 
2.  If using ROC Plus, Modbus RTU Encapsulated in TCP/IP, or 

Modbus TCP/IP, set the parameters on the ROC > Information > 
Internet tab. 

3. If using DS800, set the parameters and enable the DS800 
communications on the Configure > Control > DS800 screen. 
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4. If using Modbus RTU Encapsulated using TCP/IP or Modbus 
TCP/IP, set the communications port and configure the parameters 
on the Configure > Modbus > Configuration screen. 

Note: The parameters on the General, Modem, SRBX, and Store and 
Forward Tabs of the ROC > Comm Ports screen do not apply to 
the Ethernet port. 

The ROC > Comm Ports Diagnostics tab displays the communication 
statistics available for all Modbus and ROC Plus Protocol 
communications transmitted using TCP/IP connections. Refer to the 
discussion of the Comm Ports Diagnostics tab. 
The Ethernet port supports up to six ROC Plus connections, six Modbus 
slave connections, and one Modbus Master connection all at the same 
time. The number of active TCP/IP connections displays on the Active 
Connections field on the ROC > Information > Internet tab. 
You cannot transmit SRBX messages or firmware updates over a 
TCP/IP connection. 
Once a ROC Plus Protocol, Modbus RTU encapsulated in TCP/IP, or 
Modbus TCP/IP connection occurs, the communication session can be 
closed via a timeout. The three timeouts that can close a connection 
include:  
 A security timeout starts after a valid login. If a valid ROC Plus 

Protocol message is not received within 60 minutes, the connection 
closes. The timeout is reset after each valid message. 

 An inactivity timer starts after a valid login for each TCP/IP 
connection. The ROC > Information > Internet tab> Inactivity 
Time field sets this parameter in seconds. A value of 0 disables the 
timer. If the ROC800-Series does not receive a valid ROC Plus 
Protocol message within the Inactivity Time, the connection closes. 

 Each connection remains alive by periodic transmissions of 
messages (probes). If the other side of the connection fails to 
respond to ten repetitive probes, the connection closes. You 
configure the amount of idle time (in seconds) before the first probe 
is configurable is set in the ROC > Information > Internet tab > 
Keep Alive Time field. The other nine probes will be 64 seconds 
apart. The total time will be [(9*64) + the value of the Keep Alive 
Time parameter]. 

DS800 Use the DS800 Development Suite Software to develop programs, 
independently of ROCLINK 800. You can download these programs 
over the Ethernet port to a ROC800-Series that has the optional license 
key installed. 
Once you enable DS800 on the Configure > Control > DS800 screen, 
the Ethernet port for DS800 is always available to accept DS800 
connections. 
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The ROC800-Series is capable of distinguishing TCP/IP messages 
received from DS800, in Modbus, or in ROC Protocol. The firmware 
routes the DS800 messages to the correct communications task. 

ROC Plus 
Protocol 

ROC > Security for the Ethernet port enables or disables security for 
all ROC Plus Protocol based Ethernet connections. 
The Ethernet port is always available to accept ROC Plus Protocol 
connections. 

Modbus The ROC800-Series allows both Modbus RTU encapsulated in TCP/IP 
and Modbus TCP/IP communications on the Ethernet port. Modbus 
RTU encapsulated in TCP/IP is the form of Modbus protocol 
traditionally supported on serial connections in the ROC800-Series, 
which is encapsulated in a TCP/IP message. Modbus TCP/IP is the 
protocol developed for use over TCP/IP connections. 
The Ethernet port is always available to accept Modbus connections. 
The ROC800-Series supports Modbus communications on any of the 
serial ports, at the same time as Modbus RTU encapsulated over TCP/IP 
or Modbus TCP/IP connections. 

3.4.2 Comm Ports General Tab 
Select ROC > Comm Ports to configure the communications ports on 
the ROC. The Comm Port screen displays, showing the General tab.  

  
Figure 3-3. Comm Port, General tab 

Field Description 
Comm Ports Sets the specific comm port to be configured. Click 

▼ to display all valid selections.  
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Field Description 
Tag Sets a 10-character name (“tag”) to help identify 

the comm port.  
Comm Type This read-only field displays the type of 

communications port, such as EIA-232 (RS-232) 
or Ethernet.   
Note:  The message “No Module” appears in this 

field when no communication module is 
present in slots 1, 2, or 3.  

Baud Rate Sets, in bits per second, the transmit and receive 
data baud rate for the comm port. The default is 
19.2K.   

Parity Sets whether the communications controller 
performs parity checks and, if selected, sets the 
parity value (odd or even). The default value is 
None.  

Data Bits Sets the number of data bits contained in an 
asynchronous byte, or character. The default is 8.  

Stop Bits Sets the number of stop bits contained in an 
asynchronous byte, or character. The default is 1.  

Key On Delay Sets, in seconds, the amount of time the 
ROCLINK 800 waits after turning on the ready to 
send (RTS) signal before beginning transmission. 
The default is 0. You can change this value to 
optimize communications.  
The default value should be sufficient for dial-up 
modems and EIA-232 (RS-232) connections. For 
older radios, you may need to set this value to 0.2 
seconds. For newer radios, 0.02 seconds should 
be sufficient. 

Key Off Delay Sets, in seconds, the amount of time ROCLINK 
800 waits after transmitting a message before 
turning off the ready to send (RTS) signal. The 
default is 0. You can change this value to optimize 
communications.  
The default value should be sufficient for dial-up 
modems and EIA-232 (RS-232) connections. For 
radios, a value of 0.01 may be appropriate. 
Note:  These variables may change, based on 

your situation. These are general values 
that you need to assess for each 
circumstance. 
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Field Description 
Port Owner Sets the communication protocol this port uses  

 ROC Plus Protocol/Modbus Slave 
configures the port to automatically switch 
between Modbus and ROC Plus Protocol 
messages. 

 ROC Plus Protocol Only configures the port 
to only accept ROC Plus protocol messages 
(Modbus Slave is disabled). 

 Modbus Slave Only configures the port to 
allow the ROC to act only as a Modbus slave 
device (ROC Plus Protocol is disabled). 
Note:  Use the "Only" options only if the 

messages received use this specific 
protocol. Otherwise, select ROC Plus 
Protocol/Modbus Slave if this comm 
port is going to have both protocols 
communicate on it. 

 Modbus Master configures the port to allow 
the ROC800-Series to poll Modbus devices.  

 DS800 configures the port to download and 
debug Development Suite 800 projects only. 
You will not be able to connect two ROC units 
together with this option. It is exclusively 
configured for DS800/PC communications. 
Note:  Modems are not supported for the 

DS800 communication type. 
 LCD configures the port for communications 

with a ROC800-Series Keypad Display. 
 I/O Module configures this port to use the 

communications protocol residing in the I/O 
module. 

 Reserved indicates that this port is reserved 
and cannot be used for communications. 

 User Program configures this port to use the 
communications protocol residing in the 
loaded user program. The user program 
number here matches the user program 
number in the Configuration Tree menu and 
the User Program Administrator screen. 

3.4.3 Comm Ports Modem Tab 
Use the Modem tab on the Comm Ports screen to configure the device’s 
modem communication ports.  
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Figure 3-4. Comm Port, Modem tab 

Field Description 
Modem Type Sets the modem type. Valid values are None 

(using a serial link to the host), External (using an 
external modem), and Internal (using an internal 
modem). The default is None.  

Connect Time Sets, in seconds, the amount of time that 
ROCLINK 800 waits after initiating a call to 
receive a connect message from a device 
(typically the modem) before it terminates the call. 
The default is 60 seconds.  
The Connect Time varies from system to system 
and can take up to 60 seconds to make and 
complete a dial up connection. If a successful 
connection is made, the Disconnect Time begins. 

Disconnect Time Sets, in seconds, the amount of time that 
ROCLINK 800 waits for further activity on the line 
before it hangs up. ROCLINK 800 resets this 
timer after each valid receive signal.  

Inactivity Time Sets, in seconds, how long ROCLINK 800 waits 
without receiving a signal before resetting the 
modem. ROCLINK 800 must receive a valid 
receive counter to remain active. The default is 
900.0 seconds.  

Config Command Sets the string of characters the device requires 
to initialize the modem. For external modems, 
refer to the manufacturer’s literature. For an 
internal modem, use the default value or the 
modem card may not operate correctly. Refer to 
your modem’s documentation for default Config 
Command characters.  
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Field Description 
Connect Command Sets the Hayes-style connect command the 

device requires to contact the host. Typically, this 
is the command ATDT followed by the telephone 
number (for example, ATDT5155551212). The 
unit requires this parameter for dial-out 
operations, such as SRBX Alarming.  

Disconnect 
Command 

Sets the Hayes-style disconnect command 
required to disconnect the contact to the host. 
Typically, this is the command ATH0.  

Modem Status This read-only field shows the modem’s current 
status result code. Valid values are:  
Result Code Definition 
0 = OK Successfully executed 

command line 
1 = CONNECT Connection established 
2 = RING Ring signal detected 
3 = NO CARRIER Carrier not detected/lost  
4 = ERROR Error in command line  
6 = NO DIAL 
TONE 

No dial tone detected  

7 = BUSY Busy signal detected  
8 = NO ANSWER Line not picked up on the 

called end  

3.4.4 Comm Ports SRBX Tab 
Use the SRBX tab to configure the Spontaneous-Report-by-Exception 
alarming features.  
The SRBX (Spontaneous Report-by-Exception) alarming feature is 
available for serial communication ports. This feature allows the device 
to call in to a host computer when a configured alarm occurs. If you 
wish to configure dial-up RBX, then a modem must be present and 
appropriately configured. 
When you use RBX alarming, ensure that you enable and configure 
alarms for each point you desire to monitor. Configure the alarm 
parameters so that an alarm occurs only when desired. This prevents 
"nuisance" alarms. You configure RBX alarm parameters on the 
Alarms tab on the I/O, MVS, and Meter Setup configuration screens. 
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Figure 3-5. Comm Port, SRBX tab 

Field Description 
SRBX Mode  Sets the SRBX Mode for Spontaneous-Report-by-

Exception alarming on this comm port. The default 
is Disabled.  

SRBX Host Address Sets the address of the host to which the SRBX 
feature communicates. The default value is 1.  

SRBX Host Group  Sets the group of the host to which the SRBX 
feature communicates. The default value is 0. 

Delay Sets, in seconds, the time the device waits 
between attempts to transmit an SRBX or RBX 
message. Each SRBX or RBX Attempts parameter 
has an associated delay parameter. The default 
for Delay #1 is 20 seconds, the default for Delay 
#2 is 30 seconds, and the default for Delay #3 is 
45 seconds.  
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Field Description 
SRBX Attempts  Sets the number of times the device attempts to 

resend a message if it does not obtain a valid 
response on the first try. "Attempt" refers to the 
initial message plus any retries.  
ROCLINK 800 provides three parameters. The 
default for all parameters is Fixed Number. The 
default value for SRBX Attempt #1 is 1. The 
default value for SRBX Attempt #2 is 2. The 
default value for SRBX Attempt #3 is 3. 
Select Fixed Number to set how many times 
ROCLINK 800 retries sending a message after the 
first unsuccessful attempt. If you enter 0, no retries 
occur. Select Continuous (255) to start 
continuous retries that stop only when the host 
acknowledges the SRBX alarm. 

 Fixed Number Sets the number of times 
ROCLINK 800 retries sending a 
message after the first 
unsuccessful attempt. Enter 0 to 
prevent retries.  

 Continuous Starts continuous retries that stop 
only when the host acknowledges 
the SRBX alarm.  

SRBX Alarm Index  This read-only field shows the current SRBX 
alarm.  

SRBX Status  This read-only field shows the status of SRBX 
messaging. Valid values are Active (SRBX alarm 
is processing) or Inactive.  

3.4.5 Comm Ports Store & Forward Tab  
Select ROC > Comm Ports > Store & Forward tab to configure the 
Store & Forward features on the ROC.  
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Figure 3-6. Comm Port - Store & Forward tab  

Field Description 
Store & Forward  Indicates whether the port transmits messages 

(Store & Forward). Valid values are Enabled 
(transmit messages out of the port) and Disabled 
(do not transmit messages). 

Store & Forward 
Path 

Sets the path and group numbers of the devices 
that need to receive this SRBX message and 
forward it on to the next device to extend the 
communications path. You may also specify 
addresses for other devices that support the ROC 
Protocol. The device you specify by the last non-
zero Address or then sends the message to the 
host from by the previous parameter.  

3.4.6 Comm Ports Diagnostics Tab  
Select ROC > Comm Ports > Diagnostics tab to view the 
communications diagnostic features on the ROC.  
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Figure 3-7. Comm Port – Diagnostics tab  

Field Description 
Valid Receive 
Counters 

Indicates the number of valid ROC Plus protocol 
or Modbus protocol messages the ROC800 has 
received. Although these are incrementing values, 
you can zero them out if necessary.   

Successful 
Message Time 

This read-only field Indicates the time and date of 
the last valid ROC Plus protocol or Modbus 
protocol message received.  

Transmit Counter Indicates the number of messages sent by the 
ROC. This is an incrementing value that you can 
zero out if necessary.  

Invalid Message 
Bytes 

Indicates the number of ROC Plus protocol or 
Modbus protocol bytes lost. This is an 
incrementing value that you can zero out if 
necessary.  

Invalid Message 
Byte Time 

This read-only field shows the time and date of 
the last invalid message.  

3.5 Connecting to a ROC 
To connect the computer to a remotely located ROC a serial, dial-up 
modem, radio, satellite, or other communications line should be 
installed. This connection may be made through the LOI (Local Port) or 
other Communications Port on the ROC.  
Use the Connect command to connect to a serial or dial-up modem. To 
use Connect: 
1. Physically connect the ROC. 
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2. Launch and log in to ROCLINK 800. 
3. Perform one of the following: 
 Select a device from the Device Directory and press the Enter 

key. 
 Double-click a device in the Device Directory. 
 Select a device from the Device Directory and click the Connect 

button on the toolbar. 
 Select ROC > Connect to connect to the device currently 

selected in the Device Directory. 

3.5.1 Direct Connect 

 
Click the Direct Connect icon to establish a connection with a ROC. 
ROCLINK 800 attempts to establish communications through all PC 
comm ports at various baud rates, until it receives a valid reply.  
By default, ROCLINK 800 tags the LOI Port as the local port (comm 1), 
as shown on the Comm Port screen (ROC > Comm Ports). 
For the Direct Connect option to work, security conditions must be met, 
and the PC must be connected to the Local Operator (LOI) port of the 
device with communication settings of: 
 8 Data Bits. 
 1 Stop Bit. 
 No Parity. 
When you click Direct Connect, ROCLINK tries to initiate 
communications with the device by performing a search of the PC 
communication ports at various baud rates. ROCLINK then "locks on" 
to the first comm port and baud rate that are successful in 
communicating with a device. 
To use Direct Connect: 
1. Physically connect a cable to the ROC. 
2. Launch and log into ROCLINK 800. 
3. Do one of the following: 
 Click on the Direct Connect icon in the Device Directory. 
 Click the Direct Connect button on the toolbar. 
 Select ROC > Direct Connect. 

4. If this is the first time that you have connected to the ROC, continue 
to the steps for Setting the Clock. 

3.5.2 Local Port (LOI)  
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The PC running ROCLINK 800 physically connects to the device 
through a cable. For a local connection, this cable is typically a 
prefabricated local operator interface (LOI) cable (available from 
Remote Automation Solutions). One end of the cable (a 9-pin, D-shell, 
female connector) plugs into a serial communications port on the PC 
running ROCLINK 800. The other end of the cable plugs into the ROC 
operator interface connector called the Local Port.  

Note: If your PC does not have a serial port, you may use a USB-to-
serial connector for the LOI connection.  

3.5.3 Connect to a ROC 
To connect the computer to a remotely located ROC, install a serial, 
dial-up modem, radio, satellite, or other communications line. This 
connection may be made through the LOI (Local Port) or other 
communications port on the ROC.  
Use the Connect command to connect to a serial or dial-up modem. To 
use Connect: 
1. Physically connect the ROC. 
2. Launch and log in to ROCLINK 800. 
3. Perform one of the following: 
 Select a device from the Device Directory and press the Enter 

key. 
 Double-click a device in the Device Directory. 
 Select a device from the Device Directory and click the Connect 

button on the toolbar. 
 Select ROC > Connect to connect to the device currently 

selected in the Device Directory. 

3.5.4 Successful Login 
A successful login produces an on-line connection and displays a tree 
representing the configuration in the ROC. Refer to Configuration Tree 
Menu. 
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Figure 3-8. Successful Logon 

3.5.5 Disconnecting from a ROC 
To disconnect an online connection:  

 
 Close the screen by clicking the lower of the two Close buttons 

located in the upper-right corner of the device screen. 

 
 Click the Disconnect button located on the Toolbar.  

  Select File > Close. This automatically closes the connection. 

3.6 Troubleshooting Connection Errors 
Several events can cause a connection problem:  
 If the parameters ROCLINK 800 uses when establishing a 

communications link to your PC are incorrect, it cannot make a 
direct connection. Refer to Troubleshooting ROCLINK 800 
Communications. 

 If ROCLINK 800 stands idle for too long and exceeds the timeout 
value for a device, a communications failure can also occur. In this 
case, simply log back into ROCLINK 800 and use the Direct 
Connect or Connect features. 

 If you do not have security access to the ROC, you cannot make a 
connection. You must configure a valid User ID and Password 
(using the ROC > Security option) for each user who can connect to 
a ROC. 
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 If the PC cannot establish a connection to the ROC by "pinging" the 
Device Address (ROC Address), ROCLINK 800 cannot make a 
TCP/IP connection. Refer to Troubleshooting a TCP/IP Connection. 

3.6.1 Troubleshooting ROCLINK 800 Communications 
Occasionally, you may need to alter your PC communications options 
when you are having problems communicating with your ROC.  
1. Select the desired Device in the Device Directory. Right-click and 

select Properties. 
2. Make sure you have specified the correct Device Address and 

Device Group of the ROC or with which you are trying to 
communicate. If you are communicating through the LOI port of the 
device, the universal address is Device Address is 240 and Group 
Address is 240. 

3. Click the Advanced tab. Try increasing the Time Out and/or Tx 
Delay. 

4. Click Apply. Return to the General tab, and click Connect. 
5. If you are still having trouble communicating, try increasing the 

Number of Retries field in the Advanced tab. Click Apply. Return 
to the General tab, and click Connect. 

6. If you are still having trouble communicating, try increasing or 
decreasing the Key Off Delay field in the Advanced tab. Click 
Apply. Return to the General tab, and click Connect. 

7. Check the security settings of ROCLINK 800. 

3.6.2 Troubleshooting TCP/IP Connections 
If you are unable to establish a connection between ROCLINK 800 and 
the ROC on the Ethernet port, verify that the PC is able to "ping" the 
ROC.  
1. Launch the DOS command prompt and write a command to "ping" 

the ROC at its IP address (for example, C:\>ping 155.177.78.111). 
2. If the Ping Statistics Reply is similar to "Packets: Sent = 4, Received 

= 4, Lost = 0 <0% loss>", then the PC and ROC are connecting. You 
may need to alter the Internet communications setting in ROCLINK 
800 software. Verify all parameters on the pertinent screens. Refer 
to Configuring TCP/IP Communications on the Ethernet Port 
(ROC800-Series). 

3. If the Ping Statistics Reply is similar to "Packets: Sent = 4, Received 
= 0, Lost = 4 <100% loss>", then the PC and ROC are not 
connecting. Review your network, your physical connection, your 
router, and your PC. 
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3.7 Security 
You control security in two ways:  
 ROCLINK 800 Security: – Enables who can access (log on) 

ROCLINK 800 software and the Access Level assigned to a user. 
 Device Security – Enables who has access to the ROC Comm Ports 

and the LCD. 
Note: Security Access Levels enable you to control which users have 

access to specific ROCLINK 800 functions. 

 

3.7.1 ROCLINK 800 Security 
Use the ROCLINK 800 Security screen to set access to ROCLINK 800.  

Note:  
 Refer to Device Security for instructions on securing the ROC. 
 The requirements for the Operator ID and Password fields are 

dependent on your selection in the Enable Enhanced Security 
Features field on the Device Security screen (ROC > Security). 
For more information, refer to Section 3.7.3 Enhanced Security. 

To access this screen, select Utilities > ROCLINK 800 Security. The 
ROCLINK 800 Security screen displays. Its table format enables you to 
define, by operator ID, password, and security level, who can log on to 
ROCLINK 800 and the screens which those IDs can access. You may 
define up to 64 different users. 

Note: Utilities > ROCLINK 800 Security must match ROC > 
Security (Device Security) in order for users to log into 
ROCLINK 800. 

  
Figure 3-9. ROCLINK 800 Security 

Note:  The default Operator ID is LOI. The default Password is 1000. 
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1. Select Utilities > ROCLINK 800 Security. 
2. Enter an Operator ID. The requirements for the Operator ID field 

differ based on if you have selected Enable Enhanced Security 
Features (ROC > Security). For more information, refer to Section 
3.7.3 Enhanced Security: 
 If you have not selected Enable Enhanced Security Features, 

enter three alphanumeric characters for the Operator ID. 
Typically these are the initials of the person who operates the 
device.  

Note:  Each Operator ID must be unique and is case-sensitive 
(that is, ABC is different from Abc). 

 If you have selected Enable Enhanced Security Features, 
enter between three and 30 alphanumeric characters for the 
Operator ID.  

Note:  The Operator ID is not case-sensitive. 

3. Enter a Password for the Operator ID. The requirements for the 
Password field differ based on if you have selected Enable 
Enhanced Security Features (ROC > Security). For more 
information, refer to Section 3.7.3 Enhanced Security: 
 If you have not selected Enable Enhanced Security Features, 

enter four numeric characters (between 0000 and 9999) to define 
the operator Password. More than one user can have the same 
password.  

Note:  If you precede a password value with zeroes (such as 
0006), ROCLINK 800 saves that password as 6. 

 If you have selected Enable Enhanced Security Features, 
enter between eight and 32 alphanumeric characters to define the 
operator Password. More than one user can have the same 
password.  

4. Enter the desired Access Level for the user. 0 is the lowest (least 
inclusive) access level and allows access to the fewest number of 
screens. 5 is the highest (most inclusive) access level and allows 
access to all screens. Each access level permits access to screens at 
that level and any inherited from lower access levels. For example, 
an operator ID with Access Level 3 can access screens with levels 0, 
1, 2, and 3. Refer to Security Access Levels. 

Note: Click the User Access Levels button to globally all access 
levels. 

5. Click the Save button. 
Security Access 

Levels 
Table 3-2 lists the system screens and their system-assigned security 
access levels. The Menu Options focus on the activity while you use 
the Access Levels to increase or decrease responsibility levels within 
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the Menu Options.  
To access this screen, select Utilities > ROCLINK 800 Security > 
User Access Levels.  

Notes: 
 If you enable security on any port, at least one operator ID must 

have the highest level of security (level 5). 
 ROCLINK 800 rejects login requests if access levels are greater 

than device security.  

Table 3-2. Security Access Levels 

 Menu Menu Option Access Level 

1 Configure Transaction History 5 

15 View Display New 5 

24 ROC Security 5 

71 Utilities License Key Admin 107 5 

72 Utilities License Key Administrator 800 5 

80 Utilities Custom Display Editor 5 

81 Utilities Custom EFM Report Editor 4 

20 ROC Display Administrator 4 

69 Utilities Update Firmware 4 

70 Utilities Upgrade Hardware 4 

74 Utilities User Program Administrator 3 

2 File New 3 

4 File Download 3 

5 File Save Configuration 3 

18 View Display From File 3 

19 View Display From Device 3 

23 ROC Clock 3 

25 ROC Comm Ports 3 

27 ROC Information 3 

28 ROC Flags 3 

29 Configure IO AI Points 3 

30 Configure IO AO Points 3 

31 Configure IO DI Points 3 

32 Configure IO DO Points 3 

33 Configure IO PI Points 3 

34 Configure IO TC Points 3 
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 Menu Menu Option Access Level 

35 Configure IO RTD Points 3 

36 Configure IO System AI Points 3 

37 Configure IO Soft Points 3 

38 Configure IO Extended Soft Point 3 

39 Configure IO MVS Sensor 3 

40 Configure IO HART Points 3 

41 Configure IO Setup 3 

42 Configure IO Advanced Pulse Module 3 

43 Configure IO ACIO Module 3 

44 Configure IO Virtual Discrete Output 3 

45 Configure Control FST Registers 3 

46 Configure Control PID Loop 3 

47 Configure Control Radio Power Control 3 

48 Configure Control Sampler/Odorizer 3 

49 Configure Control DS800 3 

50 Configure History Segments 3 

51 Configure HistoryPoints 3 

52 Configure Opcode Table 3 

53 Configure Modbus 3 

54 Configure Rtu Network 3 

55 Configure LCD User List 3 

56 Configure User Data UD1 3 

73 Utilities Convert EFM File 3 

75 Utilities AI Calibration Values 3 

76 Utilities MVS Calibration Values 3 

77 Utilities FST Editor 3 

78 Utilities Keypad Display Editor 3 

79 Utilities Read File From Device 3 

82 Utilities Options 3 

84 Tools Data Logger 3 

7 View EFM Report 2 

8 View Calibration Report 2 

22 ROC Collect Data 2 

57 Meter Setup 2 

58 Meter Setup 800 Station 2 
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 Menu Menu Option Access Level 

59 Meter Setup 800 Orifice meter 2 

60 Meter Setup 800 Linear meter 2 

61 Meter Calibration 2 

62 Meter Calibration 800 Orifice meter 2 

63 Meter Calibration 800 Linear Meter 2 

64 Meter Values 2 

65 Meter Values 800 Orifice meter 2 

66 Meter Values 800 Linear Meter 2 

67 Meter Plate Change 2 

68 Meter History 2 

3 File open 1 

6 File Print Configuration 1 

9 View History From Device 1 

10 View History From File 1 

11 View Alarms From Device 1 

12 View Alarms From File 1 

13 View Events From Device 1 

14 View Events From File 1 

21 View I/O Monitor 1 

26 ROC Memory 1 

16 View Display Display 1 0 

17 View Display Display 2 0 

83 Utilities Communications Monitor 0 

3.7.2 Device Security  
Use the Device Security screen to control who has access to the Comm 
Ports on a specific device. When you enable this feature, you must log 
in to ROCLINK 800 to use the communications port. You can enable 
this feature on each communications port separately.  
To access the Device Security screen, select ROC > Security. The 
Device Security screen displays. Refer to Adding and Deleting Users in 
Device Security. 

Note:  
 Any operator ID you define in ROC >Security (which defines 

access to a device) must match an operator ID you also must define 
in Utilities > ROCLINK 800 Security (which defines access to the 
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software). Without both components, an ID cannot log onto 
ROCLINK 800 and gain access to a ROC.  

 The Failed Login Counter field displays the number of failed 
attempts to log in to the device. 

 The Device Security screen changes based on in you have selected 
Enable Enhanced Security Features. For more information, refer to 
Section 3.7.3 Enhanced Security. 

  

Figure 3-10. Device Security Figure 3-11. Enhanced Device Security 

The default Operator ID is LOI; the default Password is 1000. 
1. Select ROC > Security. 
2. Click an Operator ID field to add, edit, or remove a user. Refer to 

Security Access Levels for a full list of the access levels. 

3.7.2.1 Adding and Deleting Users  
This section details how to add and delete users in Device Security.   

Adding a User To add an operator ID:     
1. Select ROC > Security. 
2. Click on an empty cell in the table. The Device Security dialog 

displays.  
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Figure 3-12. Device Security – User Table Figure 3-13. Enhanced Device Security – User Table 

3. Complete the dialog as described.  
Field Description 

Operator ID Sets an Operator ID used to log into the device. 
The requirements for the Operator ID field differ 
based on if you have selected Enable Enhanced 
Security Features (ROC > Security): 
 If you have not selected Enable Enhanced 

Security Features, enter three alphanumeric 
characters for the Operator ID. Typically these 
are the initials of the person who operates the 
device.  
Note:  Each Operator ID must be unique and 

is case-sensitive (that is, ABC is 
different from Abc). 

 If you have selected Enable Enhanced 
Security Features, enter between three and 
30 alphanumeric/special characters for the 
Operator ID.  
Note:  The Operator ID is not case-sensitive. 

Password Sets a Password for the Operator ID. The 
requirements for the Password field differ based 
on if you have selected Enable Enhanced Security 
Features (ROC > Security): 
 If you have not selected Enable Enhanced 

Security Features, enter four numeric 
characters (between 0000 and 9999) to define 
the operator Password. More than one user 
can have the same password.  
Note:  If you precede a password value with 

zeroes (such as 0006), ROCLINK 800 
saves that password as 6. 

 If you have selected Enable Enhanced 
Security Features, enter between eight and 
32 alphanumeric/special characters to define 
the operator Password. More than one user 
can have the same password. 

Confirm Password Validates the password you entered in the 
Password field.  
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Field Description 
Access Levels Sets the access level for this operator ID. 0 is the 

lowest access level and allows access to the 
fewest number of screens. 5 is the highest access 
level and permits access to all screens. Each 
access level permits access to screens at that 
level and any inherited from lower access levels.  
This feature requires the  
For example, the IDs with access level 3 can 
access screens with levels 0, 1, 2, and 3. Refer to 
Table 3-2. 

Keypad PIN Sets an eight-digit numeric code for users to log 
into the device using the keypad. 
Note:   
 This feature requires ROC Keypad Display 

user program version 1.05 or higher. 
 This field appears only if you have selected 

Enable Enhanced Security Features. 
 The Keypad PIN must be eight-digits long. 

Member of Groups Sets the groups to which this user belongs. This 
field corresponds to the groups the Keypad 
Display uses for security.  

4. Click OK to add the user and close the dialog. The Device Security 
screen displays, showing the user you have just added.  

Deleting a User To delete an operator ID:     
1. Select ROC > Security. 
2. Click an Operator ID to delete. 
3. Click Remove. 
4. Click Yes to the confirmation dialog. The Device Security screen 

displays, showing that the operator ID has been removed.  

3.7.2.2 Groups Tab 
Select ROC > Security > Groups tab to establish up to 20 unique 
groups that Keypad Display security uses.  

Note: If your application does not require a keypad display, you do not 
need to create groups.   

To create a group: 
1. Select ROC > Security. 
2. Select the Groups tab. The Groups screen displays.  
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Figure 3-14. Device Security – Groups tab 

3. Enter a group name (such as Operators, Technicians, or 
Supervisors) in each line.  

4. Click Apply to save your groups.  

Note: You then use the Keypad Display Editor (Utilities > Keypad 
Display Editor) to indicate which displays those particular 
groups may access.  If your application does not require a 
keypad display, you do not need to create groups.   

3.7.2.3 Comm Ports Tab 
When you select the Comm Ports tab, the Comm Ports screen displays:  
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Figure 3-15. Device Security – Comm Ports tab 

For each communications port, select one of the following Security 
options: 
 Disabled – All login requests are accepted. 
 User ID Enabled – Login requests are accepted if the Operator ID 

and password are valid. Upon successful login, full access is 
allowed. 

 User Access Level Enabled – Login requests are accepted if the 
Operator ID and password are valid. Upon successful login, the user 
is restricted by access level. See Security Access Levels.  

Note: If you enable security on any port, at least one user must have the 
highest level of security (level 5). 

3.7.2.4 User/Group Summary Tab 
The Device Security > User/Group Summary tab displays a table that 
summarizes the defined associations between users and groups. It 
reflects the users you defined on the Users tab and the groups you 
defined on the Groups tab.  
You can also use this table to modify those associations. Click in a box 
to add (or remove) a user ID from a group. Click Apply to save any 
changes.   
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Figure 3-16. Device Security – User/Group Summary tab 

3.7.3 Enhanced Security 

 Caution Before opting into the new feature, confirm support in all software and 
devices communicating with the RTU or flow computer.  

Opting into the new complex usernames/password format occurs at the 
device.  

Note: 

 You must run ROCLINK 800 as an administrator in Windows. 
 You must log into ROCLINK 800 using an administrator-level 

ID. 
 Once you opt into the complex usernames/passwords format, you 

cannot change back to the previous security format.  

1. Select Utilities > ROCLINK 800 Security. The ROCLINK 800 
Security screen displays:  
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Figure 3-17.  Device Security – Enable Enhanced Security Features  

2. Select the Enable Enhanced Security Features option and click 
Apply. A warning dialog displays: 

   
Figure 3-18.  Warning Dialog  

Note: Click Cancel (the default value) to exit this dialog and retain 
your current security table. 

3. Click OK to opt into the new security enhancement. The Update 
ROC Security Logon dialog displays:  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

3-34 Communications and Security Revised February 2024 

 

 
Figure 3-19.  Update ROC Security Logon Dialog   

Note: Click Cancel to exit this dialog and retain your current 
security table. 

4. Define a new User ID and Password. This becomes is the new 
administrative User ID. Select the Add User to RL800 Security 
option to automatically add this administrative user ID to the 
ROCLINK 800 Security table.   

Note: If the contents of the Password and Confirm Password fields 
do not exactly match (remember case-sensitivity), ROCLINK 
displays an error message:  

 
Click OK to clear the message and re-enter the contents of 
both fields.   

5. Click OK. When ROCLINK accepts the new administrative ID and 
password, ROCLINK displays a verification message:  

  
Figure 3-20.  Verification Message   

6. Click OK to close the message and exit ROCLINK 800.  

3.7.3.1 After Opting In: ROCLINK 800 Security   
1. Log into ROCLINK using the new administrator operator ID and 

password (defined in step 4 of the previous section).  
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2. Access the ROCLINK 800 Security screen (Utilities > ROCLINK 
800 Security).  

 
Figure 3-21.  Enhanced ROCLINK 800 Security Screen 

3. Define any additional operator IDs/passwords for ROCLINK 800 
users.   

Note: When connecting to a device that still uses the older security 
format, you need to close ROCLINK and reconnect to that 
device using the corresponding operator ID/password.  

3.7.3.2 After Opting In: Device Security (ID/Password/Keypad PIN)  
Once you implement the new enhanced security, you then need to 
modify the device security table for each device. 

Note: Once you configure a device to use the longer operator 
IDs/passwords, you cannot log into that device using the old 
(short) operator IDs/passwords.   

1. Log onto a device and access its security table (ROC > Security):  
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Figure 3-22.  Enhanced Device Security Screen  

2. Define new operator IDs (of at least 3 and no more than 30 
alphanumeric/special characters) and passwords (of at least 8 and no 
more than 32 alphanumeric/special characters).  

Note: Ensure that you define IDs and password for individual users in 
ROCLINK 800 security to enable them to easily log onto their 
device. 

3. In the Keypad/Keypad PIN field, set a numeric code for users to log 
into a device using the keypad.  

Note: 
 Failure to enter a Keypad PIN will prevent the user from logging in 

to the device through the keypad. 
 This feature requires ROC Keypad Display user program version 

1.05 or higher. 
 The Keypad PIN must be eight-digits long. 

3.7.3.3 After Opting In: Device Security (Comm Ports)  
This feature is unchanged from previous versions of ROCLINK 800, but 
to comply with the security directive you must enable security (either 
by User ID or User Access Level) for each comm port.   
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Figure 3-23.  Enhanced Device Security Screen – Comm Ports tab 
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Chapter 4 – The File Menu 

In This Chapter 
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4.11 Exit ...................................................................................................... 4-15 
 

 
Use the File Menu to print, open, close, and save configuration files. 
Configuration files contain all hardware and software settings for your 
ROC800-Series.   

  
Figure 4-1. File Menu 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

4-2 The File Menu Revised February 2024 

4.1 New Configuration 
You configure a ROC800-Series either by modifying an existing 
configuration file or by starting a new configuration file.  
The full configuration procedure involves using the menu functions or 
Configuration Tree Menu to access the configuration screens. Some of 
the configuration screens may not be required for your application or 
may not be available for your type of ROC800-Series. 
The following checklists present the order of configuration in a typical 
application. Omit configuration screens for modules and accessories that 
do not appear in your hardware configuration and for control elements 
(PID, FST, and such) that do not apply to your application. 

4.1.1 Configuration Checklist 
For a ROC800-Series:  
 ROC menu > ROCLINK 800 Security (logon) 
 Device Directory > Comm Port > Properties (PC communication 

configurations) 
 ROC menu > Security (User List and Comm Port Security) 
 ROC menu > Clock 
 ROC menu > Information (system variables) 
 ROC menu > Comm Ports (FloBoss device communication 

configurations) 
 Configure menu > I/O menu > AI, AO, DI, DO, DOR, PI, TC, RTD, 

MVS, HART, APM, ACIO, VDO and IEC62591 
 Meter > Setup > Station 
 Meter > Setup > Orifice Meter 
 Meter > Setup > Linear Meter 
 Configure menu > Control menu > PID Loop 
 Configure menu > Control menu > FST Registers 
 Configure menu > History Segments 
 Utilities menu > FST Editor 
 View menu > Display > New or from File (for custom PC displays) 
 ROC menu > Flags (for saving and system variables to Flash 

memory) 

4.1.2 Duplicating a Configuration 
You can duplicate the configuration for another ROC800-Series by 
using these menu functions in the following order:  
1. File > Save Configuration to save a device’s configuration to a 

specified file. 
2. ROC > Direct Connect (Local Port) or Connect (modem) to 

connect physically to the second unit, and then communicate. 
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3. File > Download loads the configuration into the unit. 
After you have loaded configuration data into the second FloBoss (Step 
3) and changed it as needed, you can save the configuration to its own 
disk file by using Step 1. 

4.1.3 Creating a New Configuration File 
The New Configuration File screen allows you to create a configuration 
file off-line with the basic information about the meters and modules 
that will be installed on the ROC800-Series for which the new 
configuration was created.  
1. Select File > New. The New Configuration File screen displays.  

 
Figure 4-2. New File Configuration  

2. Select ROC809 Version 1.XX or ROC800-Series Version 2.xx, or 
RCO800-Series Version 3.xx from the File Type frame. The lower 
portion of the New File Configuration screen changes to reflect the 
ROC800-Series.  

Note:  As you define the modules and place them in slots on the 
ROC800-Series, additional fields appear on the New 
Configuration File. Figure 4-3 shows a sample completed 
configuration.   
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Figure 4-3. New File Configuration (completed)  

3. Review and complete the following fields: 

Field Description 
File Type Associates the file type with a specific device.  
Control 
Configuration 

Indicates the number of FSTs, Stations, 
Sampler/Odorizers, Meter Runs, Virtual DOs, and 
PID loops for the configuration.  
Note:  Activate only the necessary number of 

devices for your device.  
Modules Sets the type of I/O, CPU, or Comm Modules that 

will reside in each of the module slots of the ROC. 
Click  to select the module type.   

Points/ Modules & 
Backplanes 

Sets the number of Expanded Backplanes and the 
number of Points per Module for the type of device 
for which you are creating the configuration file. 

 
4. Once you have completed the configuration, click Start. The Save 

As dialog box displays.   
5. Enter a file name for the configuration file. Configuration files for 

ROCLINK 800 use the extension .800. 
6. Click Save. ROCLINK 800 saves the new configuration file, and 

displays the following dialog.   
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7. Click No to save the new configuration file and return to the New 

Configuration File screen.   

4.2 Opening a Configuration File 
Use the Open option to open a configuration file stored on a PC’s hard 
drive. Once you open the configuration file, it automatically becomes 
the active configuration file and you may edit the file offline. You can 
also load the configuration file into the device using the Download 
function. 
To open a configuration file: 
1. Start ROCLINK 800.  
2. Select File > Open. The Open dialog box displays. 
3. Select a configuration file name and click Open. The configuration 

file displays. 

Notes:   
 ROCLINK 800 files have the .800 extension. 
 If you receive an error when opening a configuration file, ensure 

that your PC’s Regional Settings are configured correctly. Refer 
to Installing ROCKLINK 800 under Microsoft 10, 8 or Windows 
7 (located in Chapter 1). 
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Figure 4-4. Open File Configuration  

4.2.1 Configuration Tree Menu 
When you open a configuration file, the Configuration Tree appears on 
the left-hand side of the screen. The tree hierarchically displays the parts 
of a configuration (such as I/O, Meter Runs, and History) that you can 
change.  

  
Figure 4-5. Configuration Tree Menu 
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Option Description 
I/O Lists all available inputs and outputs by type.  
Control Displays the FST Registers, PID Loop, Radio Power 

Control, Sampler/Odorizer, and DS800 options enabled 
on the ROC > Information screen.  

System Displays Comm Port, Device Flags, and Opcode Table 
information.  

Meter Lists all available gas meters and all stations.  
History Displays all available History Segments and History 

Points.  
User Program Displays all user programs. 
User Display Accesses custom displays stored in the configuration 

file. The file can store a maximum of 246 displays (both 
custom user displays and user program displays).  

 
From the Configuration Tree, you may change the configuration or 
monitor current operations. Once you are in the Configuration Tree 
menu, you can use the + and – symbols to display or hide various 
options.  
Double-click the desired function in the Configuration Tree to display 
the associated screen. Double-clicking an icon is the same as selecting 
the option in the menu bar or clicking a Toolbar button. 

4.2.2 Modifying an Existing Configuration File 
You can make modifications to an existing configuration file offline. 
This allows you to share configuration files between multiple devices 
and customize each configuration file to account for device differences. 
  
To modify an existing configuration file: 
1. Start ROCLINK 800.  
2. Select File > Open. The Open dialog box displays. 
3. Select a configuration file name and click Open. The configuration 

file displays. 

Note:  ROCLINK 800 files have the .800 extension. 
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Figure 4-6. Modifying Configuration File 

4.2.3 Adding Modules to an Existing Configuration File (ROC800-
Series) 

You can add modules to an existing ROC800-Series configuration file.  
To modify an existing configuration file: 
1. Start ROCLINK 800.  
2. Select File > Open. The Open dialog box displays. 
3. Select a configuration file name and click Open. The configuration 

file displays. 

Note:  ROCLINK 800 files have the .800 extension. 

4. Right-click an empty slot to display a pop-up menu of available 
modules. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 The File Menu 4-9 

 
5. Select the appropriate module from the pop-up menu. An Add New 

Module dialog displays. 

 
Figure 4-7. Add New Module 

6. Click Start to add the new module TLPs to the configuration file. 

 
Figure 4-8. Add New Network Radio Module 
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7. Click Finish. A dialog displays warning you that all offline and 
online connections must be closed to complete the operation. 

 Caution Any unsaved changes to other configuration files are lost when the 
connections are closed. 

 

 
Figure 4-9. Connection Must Be Closed 

8. Click OK to close all online and offline connections and add the 
new module to the configuration. 

 
Figure 4-10. New Module Added 

4.3 Downloading a Configuration 
Use the Download option to download a saved configuration to a ROC.   
1. Connect to the ROC.  
2. Select File > Download. The Select Configuration File to Download 

dialog displays. 
3. Select a configuration file. ROCLINK 800 configuration files have 

the extension .800.  
4. Click Open. The Download Configuration screen displays. 
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Figure 4-11. Download Configuration-Base Firmware Tab  

5. Select only the configuration points you desire to download. 
ROCLINK 800 grays out any items not configured in your 
configuration.  

6. Select the User Defined Points tab. The User Defined screen 
displays. 

 
Figure 4-12. Download Configuration-User Defined Points Tab 

 
7. Select only the User Defined Points you desire to download. 
8. Click Download. ROCLINK 800 begins to download the 

configuration points you have chosen, and displays the status, point 
type, and point number information as the download progresses. 
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9. Click OK when the download completes. 
10. Select ROC > Flags and click the Save Configuration for Flash 

Memory button. 

4.4 Saving a ROC User File 
In addition to keeping backup copies of the configuration file, it is also 
good practice to keep a backup copy of the ROC_USER.mdb file. This 
file contains the communications, security, and password settings for the 
FloBoss. 
To create a backup copy of the file: 
Open Windows Explorer and navigate to the folder where ROCLINK 
800 software is located. Typically, this folder is C:\Program 
Files\ROCLINK800. 
Create a copy of the ROC_USER.mdb file. 
Paste the copy into another folder on the PC or a disk. 

4.5 Saving a Configuration 
The Save Configuration option saves the current configuration of a 
connected device to a disk file. This feature is useful when creating a 
backup, when configuring similar ROC for the first time, or when 
making configuration changes off-line. Once a backup configuration file 
is created, it can be loaded into a device using File > Download.  
1. Select File > Save Configuration. The Save As dialog box appears. 
2. Type the desired File name of the backup file. 
3. Click Save. 
ROCLINK 800 configuration files have the extension .800. 

4.6 Printing a Configuration 
Use the Print Configuration option to specify the point types that you 
want to print.  
1. Select File > Print Configuration. The Print Configuration Setup 

screen displays. 
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Figure 4-13. Print Configuration 

2. Select the specific Point Types to print. 

Note: Click Select All or Deselect All to select multiple point 
types, point numbers, or parameters. Use your mouse to 
select/deselect individual point types, point numbers, or 
parameters. 

3. Select the Point Numbers to print. 
4. Select the Parameters to print. 

Note: Click the Certified Print button to automatically print all 
point types, point numbers, and parameters in the device. 
This option does not allow you to deselect any point types, 
point numbers, or parameters. 

5. Click OK. ROCLINK 800 reads the configuration from the device 
and displays the Print Preview screen. 
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Figure 4-14. Print Preview-Certified Print 

6. Use screen option buttons (located on the toolbar) to either directly 
print the preview or export the preview (with a file name you 
specify) to your PC’s hard drive in one of the following formats: 

Button Result 
Print Sends file to a local printer 
PDF Converts the content to the format of an Adobe® Acrobat® 

file 
Excel Converts the content to the format of a Microsoft® Excel™ 

spreadsheet file  
RTF Converts the content to the format of a Microsoft Rich Text 

Format (RTF®) file  
TXT Converts the file to the format of an ASCII-compatible text 

file  
HTML Converts the file to the format of a hypertext markup 

language file.  
 

4.7 Print 
Click Print or select Print from the File menu to print ROCLINK 800-
generated historical, event, and alarm log reports.  

4.8 Print Setup 
Use Print Setup to change the default printer for ROCLINK 800 
information.  
To change printers:  
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Select File > Print Setup. 
Select the printer you desire to print to from the Name drop-down list.  

4.9 Recent Files 
The File menu displays the configuration files that you have recently 
opened or saved.  

  
Figure 4-15. Recent Files  

4.10 Close  
Select File > Close to close the active screen.  

Note: Because the graphic display is an active screen, selecting Close 
can terminate the online connection.  

4.11 Exit  
Select File > Exit to exit the ROCLINK 800 program. The following 
may occur:  
 If you are currently editing a configuration file, ROCLINK 800 

closes the file. 
 If you are currently connected to a dial-up ROC, ROCLINK 800 

issues the hang-up command to the modem.  
 If you are currently online with a ROC, the connection automatically 

terminates. 
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Chapter 5 – The View Menu 

In This Chapter 
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5.7.1 Viewing a Custom Display ...................................................... 5-16 
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Use the View menu options to view the Device Directory; electronic 
flow measurement (EFM) reports; calibration logs; history, alarms, 
weights and measures, and events logs; create, view, and manage 
custom displays, monitor I/O; view the toolbar; and update point tags on 
the User Program configuration tree.  

  
Figure 5-1. View Menu 
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5.1 Directory 
Select View > Directory to replace the ROC800-Series graphic image 
or Configuration Tree with the Device Directory. The Device Directory 
displays the root level of all devices and groups configured in 
ROCLINK 800.  

Note:  You can also switch displays between the Device Directory and 
the online device using the Windows option on the ROCLINK 
800 menu bar. 

5.2 EFM Reports 
Select View > EFM Report to generate printed and on-screen reports of 
the configuration, alarms, events, and historical flow data for a gas 
meter point and to the EFM reports to other formats.  ROCLINK 800 
uses EFM (Electronic Flow Measurement) reports in conjunction with 
the ROC's AGA flow calculation capabilities to display or print 
previously collected flow data. An EFM report file contains all flow 
data, which includes the operational characteristics (configuration 
parameters, history, events, and alarms) of each measured meter run 
configured in the ROC.  

Note: If a communication failure occurs during the EFM Report 
process, the initial data collected before the comm failure 
remains in the report. 

5.2.1 Creating the EFM File 
Before you can view the EFM report data, you must first create the 
report file. Refer to Chapter 6, Section 6.3, Collect ROC Data, for this 
process.  

5.2.2 Viewing EFM Reports 
“Viewing” an EFM report requires you to identify the EFM data you 
want to use, selecting a report format file, and then indicating the kinds 
of data to include in the report. To view the EFM report:  
1. Select View > EFM Report. An Open dialog displays, listing all the 

.EFM files.  
2. Select an .EFM file and click Open. The View EFM Report screen 

displays. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 View Menu 5-3 

  
Figure 5-2. View EFM Report 

3. Select Custom as the Report Type. This activates the Browse 
button.  

4. Click Browse to display a Select Custom Report screen. 

 
Figure 5-3. Select Custom Report 
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5. Select a report file and click Open. The View EFM Report screen 
displays, indicating the selected report file.  

  
Figure 5-4. Selected Custom Report File 

6. Define the report content:  
Field Description 

Meter Run Click ▼ to select the meter run for the report.  

Start Date Indicates a starting date for the report. Click ▼ to 
display a calendar to assist in date selection.  

End Date Indicates an ending date for the report. Click ▼ to 
display a calendar to assist in date selection.  

Report Sections  Specifies the report contents. By default, all 
sections are selected; you can de-select sections 
based on your needs.  

 
7. Select a meter. Click ▼ in the Meter Run field to display all 

available meter runs.   
8. Click Print Preview to display a preview of the printed report. 
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Figure 5-5. Preview of EFM Report 

9. Use the options on the menu bar to print the report to a local printer 
or convert the report file to another format. Figure 5-6 shows a page 
of an example printed report.  

Note: Select Utilities > Convert EFM File (from the menu bar) to 
convert the report data to the PGAS or Coastal Flow data 
format. See Chapter 9, Section 9.3, Converting EFM Report 
Files for further information.  
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Figure 5-6. Sample Page of EFM Report 
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5.3 Calibration Reports 
ROCLINK 800 enables you to create a calibration report to record the 
calibration procedure.  

Creating Calibration 
Report Data 

Before you can view a calibration report, you must create calibration 
report data. Refer to Chapter 7, Configure, for instructions on creating 
AI and RTD calibration data.  

5.3.1 Viewing a Calibration Report 
To view a calibration report:  
1. Select View > Calibration Report. An Open dialog displays, listing 

available calibration reports.  
2. Select a Calibration Report to view.  
3. Click Open. The View Calibration Report screen displays. 

  

Figure 5-7. View Calibration Report 

4. Click Print Preview. The Print Preview screen displays. 
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Figure 5-8. Calibration Report Print Preview  

5. Click Print to print the report. ROCLINK 800 displays a Print 
window that allows you select the printer, number of copies, and 
other options. 

You can also export the report to different formats using the PDF, 
Excel, RTF, TXT, and HTML buttons on the toolbar. 

5.4 History Logs 
The History option on the View menu option enables you to access and 
display the Minute, Hourly (Periodic), and Daily History logs either 
directly from a ROC800 to which you are connected (From Device) or 
from a previously saved file (From File).  

Note: You must configure history points before you can view them. 
Refer to Configure History Points in Chapter 7, Configure.   

Once you select the view, the system displays the log (see Figure 5-4):  
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Figure 5-9. Log Viewer  

ROCLINK 800 provides several option buttons you can use to manage 
report data:  
Button Description 

Plot  Graphically displays history data based on criteria you 
select. Refer to the Plotting History section for further 
information.  

Select New  Re-displays the Select History Points screen, which you 
can use to select new history values.  
Note:  This option is available only if you are viewing 

data from the device. 
Save  Saves the log as a file on your PC, using one of the 

following file name extensions based on the kind of 
data.  
 .MDB – Minute-based history log file. 
 .PDB – Hourly/Periodic-based history file. 
 .DAY – Daily-based history log file. 
 
Note:  This option is available only if you are viewing 

data from the device. 
Print Preview  Displays a preview of the report data as it would appear 

if printed. Refer to Print Configuration for information on 
managing the print preview.  

Close  Closes the display.   

 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

5-10 View Menu Revised February 2024 

5.4.1 Viewing Logs from a Device 
When you choose to view history logs from a connected device, 
ROCLINK 800 displays a dialog box. You use this dialog to specify the 
report contents.  
1. Select View > History > From Device. The Select History to View 

screen displays:  

  
Figure 5-10. Select History to View 

2. Select or de-select the History Points to include on the view.  
3. For History views, select the History Type and indicate a log 

frequency. You can view Minute, Hourly (Hour or Periodic), or 
Daily (Day). 

4. Click OK. ROCLINK 800 retrieves the data you have selected and 
displays it on a preview screen.  
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Figure 5-11. History (from device)  

5. Review the report.  

Note: Click Save to save the data to a file on your PC. You can 
then view history logs without being connected to the device.  

6. Click Close to close the preview.  

5.4.2 Viewing History Logs from a File 
During the course of operation, the ROC creates a history log. You can 
save this log to a file on your PC for off-line viewing and analysis. 
ROCLINK 800 provides additional tools you can use to manipulate the 
data.  

Note:  You must first retrieve the history file from the device and then 
save the file before you can view a history log from a file. 

1. Select View > History > From File. An Open dialog displays.  
2. Select the file and click Open. A preview screen displays. Refer to 

History, Alarm, and Event Log Reports for valid history file name 
extensions. 
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Figure 5-12. History (from file)  

3. Review the file. 

Note: Click Print Preview to print the report contents (see Print 
Configuration) or Plot to create a graphic display of the 
report contents (see Plotting History).  

4. Click Close. 

5.4.3 Plotting History 
For history data you obtain from either a connected device or a file and 
display on a print preview, ROCLINK 800 provides an option that 
enables you to graphically display the report results.  
After you select the report data, click Plot. ROCLINK 800 displays a 
graphical version of the selected data.  
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Figure 5-13. Plotting History 

5.4.4 Managing Plotted History 
The plot displays each series of lines as connected points of data, based 
on the time the data was archived and the current value at that time. The 
plot chart displays the type of history, device type, date, time, and the 
Operator ID in the header. The left (Y) axis displays the value and the 
bottom (X) axis displays the date and time the value was read. A legend 
at the bottom of the graph corresponds with the lines within the graph. 
Use the scroll bar to the left of the graph to change the Y-axis. 
Graphics zoom enlarges the selected area of a chart, while not 
necessarily showing the axes. 
Axis zoom changes the minimum and maximum data values to those 
selected and redraws only that data with the axes. 

Graphics Zoom To zoom an area of the plot:  
1. Press Ctrl and hold down the left mouse button. 
2. Drag the mouse to select zoom area and release the mouse button. 
3. Press r to remove the effect and restore the original plot. 

Axis Zoom To zoom into a particular axis of the plot:  
1. Press Shift and hold down the left mouse button. 
2. Drag the mouse to sets the zoom area and release the mouse button. 
3. Press r to remove the effect and restore the original plot. 
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Scaling To scale the chart to a specific size: : 
1. Press Ctrl and hold down both mouse buttons (or middle button on 

a 3-button mouse). 
2. Move the mouse down to increase chart size or move the mouse up 

to decrease chart size. 
3. Press r to remove the effect and restore the original plot. 

Moving To move the chart:: 
1. Press Shift, and press down both mouse buttons (or the middle 

button on a 3-button mouse). 
2. Move the mouse to change the positioning of the chart. 
3. Press r to remove the effect and restore the original plot. 

5.5 Alarm and Events Logs  
The View menu option enables you to access and display the Alarm 
logs and the Event logs either from the connected ROC or from a file.  
Once you select the view, the system displays the log. ROCLINK 800 
provides several option buttons you can use to manage report data: 

5.5.1 Viewing Alarm Logs 
You can view a log of all alarms on your connected ROC or from a disk 
file.  
1. Select View > Alarms > From Device or From File. A viewer 

displays, showing the log:  

  
Figure 5-14. Alarm Log 

2. Review the alarms preview and select an option:  

Save Saves the log as an .ALM file. 
Note:  This option is available only if you are 

viewing data from the device. 
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Print Preview Shows a preview of the printed version which you 
can send directly to a printer or convert to one of 
five file formats.   

Close Closes the log viewer.  

 
3. Click Close to close the viewer.  

5.5.2 Viewing Event Logs 
You can view a log of all events on your connected ROC or from a disk 
file.  
1. Select View > Events > From Device or From File. A viewer 

displays, showing the log:  

 
Figure 5-15. Events Log 

2. Review the events preview and select an option:   

Save Saves the log as an .EVT file.  
Note:  This option is available only if you are 

viewing data from the device. 
Print Preview Shows a preview of the printed version which you 

can send directly to a printer or convert to one of 
five file formats.   

Close Closes the log viewer.  

 
3. Click Close to close the viewer.  

5.6 Display Editor 
You can create custom displays using ROCLINK 800’s Display Editor 
(View > Display > New). Custom displays enable you to group 
significant data on a single screen for monitoring or control or to 
otherwise streamline system use.  
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For a complete discussion on using the Display Editor to create custom 
displays, refer to Appendix B, The Display Editor.  

5.7 Display Administrator 
You create and store custom displays as .DSP files on your PC. You can 
also download custom displays for use on your ROC. How you view 
these custom displays depends on where you have stored them. 

5.7.1 Viewing a Custom Display  
To view a custom display stored as a disk file on your PC: 
1. Select View > Display > From File. An Open dialog displays.  
2. Navigate to the folder in which you store custom displays (typically, 

this is the Displays folder in ROCLINK 800).  
3. Select a display file (*.DSP) and click Open. ROCLINK 800 loads 

the file into the Display Editor.    

5.7.2 Downloading a Custom Display  
Once you have created a custom display (see Appendix B), you use the 
Display Administrator utility to download the display to your ROC.     
The ROC can store a maximum of 246 displays, which includes both 
custom user displays (that your organization may create) and user 
program displays (that accompany User C programs).  
To access the Display Administrator:  
1. Select View > Display > From Device > Administrator. The 

Display Administrator screen displays, showing all displays 
currently loaded in the ROC800. 
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Figure 5-16. Display Administrator 

2. Click an empty slot to highlight it.   
3. Click Browse to open the Select User Display File dialog.  
4. Double-click the display file you want to download. The Display 

Administrator screen re-displays with the Download button now 
active. 

5. Click Download to add the user display to the ROC. 
6. ROCLINK 800 displays a verification dialog.  
7. Click Yes. ROCLINK 800 loads the display in the designated 

location and displays a completion dialog.  
8. Click OK to close the dialog. The Display Administrator screen 

displays, showing the display you have just added. . 

Note: Use the Flash File System frame on this screen to monitor 
the number of bytes you have used and the number of bytes 
remaining.  

9. Click Close. 

5.7.3 Deleting a Custom Display  
You can also remove custom display you no longer require from the 
ROC.  
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1. Select the custom display to highlight it.  
2. Click Remove. ROCLINK 800 displays a verification dialog.   
3. Click Yes. ROCLINK 800 displays a completion dialog.  
4. Click OK to close the dialog.  

5.8 I/O Monitor 
Use I/O Monitor to view all installed and active I/O points, MVS 
values, and flow calculations that provide information configured in the 
ROC and its operating environment.   
1. Select View > I/O Monitor. The Select Points to Monitor screen 

displays.  

 
Figure 5-17. Select Points to Monitor 

2. Select the points you want to monitor. Click the plus sign next to 
each item to expand the selection. Click Select All or Deselect All 
to select or deselect all points. 
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3. Click OK. ROCLINK 800 displays a screen showing the point 
information you have requested and automatically updates the on-
screen values. 

 
Figure 5-18. I/O Monitor 

Note: Use the Select New button to redisplay the Select Points to 
Monitor screen and select other I/O points to monitor.   

5.9 Toolbar 
Select View > Toolbar to display or hide the ROCLINK 800 toolbar. A 
check mark appears next to the menu option when the toolbar is 
available.  
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Figure 5-19. Toolbar Selected 

5.10 Refresh User Program Tree  
Select View > Refresh User Program Tree (or press the F5 key on 
your keyboard) to refresh the listing of user programs ROCLINK 800 
displays on the program tree.  
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Chapter 6 – The ROC Menu 
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Use the ROC menu options to set system information for the ROC.  

 
Figure 6-1. ROC Menu 

6.1 Direct Connect 

 
Use this option (ROC > Direct Connect) to connect to the ROC via the 
LOI (local) port. When you select this option, ROCLINK 800 proceeds 
through all available connection options (ports and connection speeds) 
until it locates a connection that works.  
You can also directly connect to the ROC by clicking the Direct 
Connect icon on the ROCLINK 800 menu bar.  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

6-2 ROC Menu Revised February 2024 

6.2 Connect/Disconnect 

 
Use this option (which displays as Connect when you are not 
connected and Disconnect when you are connected) to connect to the 
ROC using a specific port and connection speed. You select the 
preferred connection using the Device Directory. 
You can also directly connect to the ROC by clicking the Connect icon 
on the ROCLINK 800 menu bar.  
Use this option to disconnect from the ROC. You can also disconnect by 
clicking the Disconnect icon on the ROCLINK 800 menu bar. 

6.3 Collect ROC Data 
Note: This option is available only for AGA gas measurement data.  

Use this option to save ROC electronic flow management (EFM) data to 
disk files. Data includes:  
 Configuration data. 
 Hourly volume history data. 
 Daily volume history data. 
 Alarm Log data. 
 Event Log data. 
 User defined point data. 
Once you select ROC > Collect Data, the Collect Device Data screen 
displays. 
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Figure 6-2 Collect Device Data 

Field Description 
Collect Data for 
Selected Meters 
and/or Stations 

Selects the meters and/or stations from which data 
is to be collected. 

Collect  This read-only check box allows the Collect Data 
function to save all values for EFM parameters in 
an .EFM file.  

Collect User 
Program and User 
Defined Point Data 

Sets if the program collects user program and user 
defined point data from the device to include in the 
report. Valid values are: 

 Yes The program collects all user program 
and user defined point data from 
the device to include in the report. 
 
Note:  This option may substantially 

increase the collection time 
based on the amount of user 
program and user defined point 
data. 

 No The program does not collect user 
program or user defined point data 
from the device. 
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Field Description 
Collect History Sets to report on all historical data or only data 

collected between dates you specify. Valid values 
are: 

 All 
Archived 

Data 

Select to report on all historic data 
collected. 
Note:   This is the default value. 

 Specify 
Start & End 

Times 

Select to only collect data between 
the Start Time and End Time dates 
you specify. 

Save Data  Sets a file name (other than the default 
C:\Program Files\ROCLINK800\Station 
Name_address group_yyyy-mm-dd.efm) to which 
the ROC saves .EFM information.  
 
Select Save to New File to create a new report or 
Append to Existing File to append the report to 
an existing file. Click Browse to search for a file to 
receive the appended data.  

Convert  Launches the EFM file conversion utility. After the 
system collects EFM data, you can convert the 
data to an .AGA, .CFX, or .DET file for subsequent 
import into the PGAS or Flow-Cal metering report 
applications.  
Note:  You can also access this utility by selecting 

Utilities > Convert EFM File. 
Conversion Type Sets the format for .EFM file conversion. Valid 

values are:   
Note:  This field displays only if you select 

Convert EFM File.  
 PGAS EVT, .ANA, .ARM, and .VOL are 

ROC800-Series files available for 
PGAS (EMS Pipeline Services). 

 Flow-Cal .CFX is the ROC800-Series file 
available for Flow-Cal (Coastal Flow 
Measurement, Inc.). This is the 
default.  

 .AGA FloBoss files and contain the History 
Points for the Meter Run. 

 .DET ROC300-Series and FloBoss 407 files 
are formatted to contain gas 
composition, specific gravity (relative 
density), and heating value averages. 

 

Note: If a communication failure occurs during the collection of EFM 
data, any data collected before the comm failure remains in the 
report data.   
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6.3.1 Collecting EFM Report Data 
Before you can view the EFM report data, you must first create the data 
file. A single EMF data file can contain information for one or multiple 
meters/stations. To create this file: 
 
1. Select ROC > Collect Data. A Collect Device Data dialog box 

displays. 

 
Figure 6-3. Collective Device Data (initial) 

2. Select EFM Report Data in the Collect field. 
3. Select the meter and/or station from which data is to be collected 

or click Select All to select all available meters/stations. 
4. In the Collect User Program and User Defined Point Data, select 

Yes to collect user program and user defined point data or No to 
not collect user program and user defined point data. 

Note: Selecting Yes may substantially increase the collection time 
based on the amount of user program and user defined point 
data in the device.   

5. In the Collect History field, select to report on all historical data 
(All Archived Data) or only data collected between dates you 
specify (Start Time and End Time). 
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6. Select to Save to New File or Append to Existing File in the 
Save Data field. If you select Append to Existing File, click 
Browse to search for a file to receive the appended data. 

7. If you want to convert the EFM file to a different file type, select 
Convert EFM File and then select your desired data format. 

8. Click Collect. ROCLINK 800 collects information about the 
device to the designated .EFM file. When the collection 
completes, the system displays a message at the bottom of the 
screen. 

 
Figure 6-4. Collective Device Data (complete) 

9. Click Close. 
Once you create this file, you can generate a report at any time (such 
as in the office) and a connection with the device is no longer 
necessary. The EFM Reports utility retrieves the data associated 
with the requested meter run and time period from the *.EFM file 
and formats this report for each meter run covering a specified 
period of time. 
Note: For the EFM Reports utility to function correctly, you must 

configure the historical database in the device so that the 
system can retrieve flow values from memory. Refer to 
Configuring History Points (located in Chapter 7).     
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6.4 Clock 
The internal real-time clock provides time-stamping and control of the 
historical databases, Event Log, and Alarm Log.  
 

 Caution Immediately after connecting to a ROC for the first time, set the clock to 
ensure proper logging of history.    

 

Note: The user-selectable time stamp in the ROC reflects the time 
either at the beginning or at the end of the period. Select 
Configure > History Points > Setup tab to adjust this 
preference in the History Time Stamp field.  

 
1. Select ROC > Clock or click the Clock icon in the toolbar. The 

Clock screen displays.  

  

Figure 6-5. Clock 

2. Set the clock.  
 If the clock in your PC is correct, click the circled area next to 

Today at the bottom of the calendar and click Apply. 
ROCLINK 800 uses the date and time in your PC to set the ROC 
clock.  

 If the PC clock is not correct, use a combination of the calendar 
(for year, month, and day) and the time (for hour, minute, and 
seconds) to set the time and date and click Apply.   

If the displayed 
Device Date 
and Time is 

correct, click 
Today.  

If the displayed 
Device Date and Time 
is not correct, use a 
combination of the 
date, day, and time 
fields to set the value.  
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3. Click Auto Scan to enable ROCLINK 800 to poll the device 
automatically. Auto scanning continues until you click Stop Scan.  

Note: Select Tools > Options to set the time interval, in seconds, at 
which the Auto Scan feature polls the ROC.   

4. Click Apply. 
5. Click OK to close the screen. 

6.4.1 Daylight Savings Time Tab 
The Daylight Savings Time tab sets the clock to automatically 
compensate for daylight savings time. 
Select ROC > Clock. The Device Information screen displays, showing 

the Daylight Savings Time tab. 

 
Figure 6-6. Clock, Daylight Savings Time tab 

Review the following fields for your organization’s values: 

Field Description 
DST   Sets the clock to automatically compensate for 

Daylight Savings Time by enabling this feature. 
Current DST 
Configuration  

This read-only field shows the currently configured 
daylight savings time start and end times. 

Set DST 
Configuration 

Sets the hour, day, week, and month that the 
daylight savings time adjustment starts and ends. 
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6.5 ROC Security 
For a complete discussion of device security, refer to the Device 
Security section in Communications and Security (located in Chapter 3).  

6.6 ROC Comm Ports 
For a complete discussion on configuring communications ports, refer 
to Communications and Security (located in Chapter 3).  

6.7 Configuring Device Information 
Use this option to set a number of variables — including station name, 
address, group, active PIDs and associated history points, and other 
global variables — as well as review device information that 
differentiates individual ROC units.  
When you select ROC > Information, the Device Information screen 
displays with the following tabs:   
Tab Description 

General Provides basic information about the ROC.  

Internet Enables you to define Internet communication 
parameters.  

Points Displays maximum point information and enables 
you to define the number of active points.  

Other Information Displays technical ROC information such as 
firmware versions and boot versions.  

System 
Configuration 

Specifies the four baud rates the ROC can use at 
any given time. 

Module Information Displays information on programmable modules 
(such as the MVS I/O or APM) installed in the 
ROC.  
Note: This tab displays only if you have one of 

these modules installed.  
Keypad Display Provides configuration options for the ROC800-

Series external keypad.  
Note: This tab displays only if you have an 

external keypad installed.  
Expanded I/O Provides information on the expanded provides 

information detailing the CPU backplane and how 
many expanded backplanes are installed, their 
status, and version information.  
Note: This tab displays only if you have expanded 

backplanes. 

6.7.1 General Tab 
The General tab provides basic information about the ROC.  
1. Select ROC > Information. The Device Information screen 

displays, showing the General tab.  
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Figure 6-7. Device Information – General tab  

2. Review the information on this screen.    
Field Description 

Station Name  Indicates the Station Name to be logged in EFM 
Reports.  You can change this value to any 
meaningful 20 alphanumeric string.  

Device Type  This read-only field shows the currently attached 
ROC.  

Address  Sets a unique address for this ROC that 
differentiates it from all other devices in a 
communication group. Valid values are 1 to 255.  
Note:  To avoid communications problems, do not 

use 240. 
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Field Description 
Group  Sets a number that identifies a group of ROCs for 

communication purposes. All ROCs defined as an 
area in the host must have the same group. Valid 
values are 1 to 255.  
Note:  To avoid communications problems, do not 

use 240. With ROC Protocol, the values in 
the Address and Group fields must match 
the address defined in the destination 
device for communications to work.  

You can use TCP/IP connections for Modbus RTU 
encapsulated in TCP/IP, Modbus TCP/IP, and 
ROC Plus Protocol communications. If you change 
the default value of the Address or Group 
parameters, then all Modbus RTU encapsulated in 
TCP/IP, Modbus TCP/IP, or ROC Plus Protocol 
over TCP/IP connections close, and you must re-
establish a connection. 

Logical 
Compatibility Mode  

Indicates whether the ROC uses 16 or 8 logical 
points per module.   The default for a Series 2 
CPU is 8 points.  

Double Precision 
Accumulators  

Indicates the value at which the double precision 
accumulators roll over. The default value is 
1,000,000,000,000.0.  

Weight & Measures 
Parameters 

Displays the current status of the system 
regarding the weights & measures parameters. All 
parameters (TLPs) in the ROC800-Series device 
have an associated access type. For most 
parameters, that access type is either Read/Only 
or Read/Write. For the ROC800-Series, there is an 
additional access type, named Read/Write 
Conditional. Parameters of this access type are 
considered to be significant, meaning they deal 
with the configuration of the measurement 
features. When the system is unlocked (as it is by 
default), then parameters of this type may be 
written to. When the system is locked by the user 
(this can only be done by a user with the highest 
level of security), then these parameters can no 
longer be written to. They essentially become 
Read/Only. To lock and unlock the system, see 
Utilties > W&M Lock/Unlock. 

Measurement 
related events are 
logged to 

Determines where changes to parameters will be 
stored. By default, this is the Weights & 
Measures Log. Some legacy systems are not 
capable of reading the weights & measures event 
log, and require events to be placed in the 
standard event log. When this is necessary, select 
Standard Event Log to record all events in the 
standard event log. 

 
3. Click Apply if you change any parameters on this screen. 
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6.7.2 Internet Tab  
The Internet tab configures addresses for Internet communications.  
1. Select ROC > Information > Internet tab. The Internet screen 

displays.  

 
Figure 6-8. Device Information – Internet tab  

2. Review the information on the screen.  
Field Description 
Addressing 

MAC Address This display-only field shows the Media Access 
Control (MAC) address for the ROC. The MAC 
address is factory-set.   

IP Address Sets the Internet Protocol address for this ROC. 
The factory-set default address is 10.0.0.2.  

Subnet Mask Sets, if required, a value for the subnet mask 
portion of the IP address. The subnet mask 
indicates the subnet to which an IP address 
belongs. The factory-set default is 255.255.255.0.   

Gateway Address Sets the gateway address for the ROC. This value 
identifies the network node that serves as an 
entrance to the network on which the ROC 
resides. The factory-set default is 10.0.0.1.   
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Field Description 
Modbus or ROC Plus Protocol 

IP Port Number Sets the IP Port Number for the Modbus or ROC 
Plus Protocol communications. The IP Port 
Number identifies the port that the ROC monitors 
for Modbus or ROC Plus protocol connections 
when communicating over a TCP/IP connection. 
The ROC Plus protocol default is 4000. The 
Modbus default is 502. Port numbers 1113 and 
1131 are reserved.  

If you change the IP Port Number, the change 
takes effect immediately. If you change the default 
value of this parameter, all Modbus or ROC Plus 
communications over TCP/IP connections close, 
and you have to re-establish a connection. 

Inactivity Time Sets the time, in seconds, ROCLINK 800 waits for 
a valid Modbus or ROC Plus protocol message 
before closing the connection.  The default value 
is 3600. This timer is in addition to the security 
timeout. Set this field to zero (0) to disable the 
timer. 

Keep Alive Time Keeps a connection “alive” by periodically 
transmitting of messages (probes). Indicate, in 
seconds, the amount of idle time before the first 
probe occurs. If the other side of the connection 
fails to respond after ten consecutive probes, the 
connection is considered broken and the 
connection closes. The default is 0 (no messages 
are sent).  

After the first probe, ROCLINK 800 sends nine 
other probes, 64 seconds apart. The total Keep 
Alive Time is 486 seconds (9 x 64) plus the value 
you enter in the Keep Alive Time field.  

Active Connections This read-only field displays the total number of 
active TCP/IP connections.  
Note:  This field is active only if you enable ARP 

Protection. The Ethernet port supports up 
to six ROC Plus connections, six Modbus 
slave connections, and one Modbus Master 
connection all at the same time. 

Reset All 
Connections 

Click to close all active Modbus or ROC Plus 
Protocol over TCP/IP connections. This button 
returns to an un-pressed state when connections 
are successfully closed.  

ARP Protection Enables Address Resolution Protection (ARP) 
storm protection, which limits the number of 
incoming messages to the value you enter in the 
Packet Queue Limit field and ignores the 
remainder until the number of messages drops 
below the value you enter. The default is 
Disabled.  

Packet Queue List Indicates a limit of incoming messages.  
Note:  This field is active only if you enable ARP 

Protection.  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

6-14 ROC Menu Revised February 2024 

Field Description 
Address to Use Indicates the protocol address to use. Valid values 

are Device Address, Slave Address, or Either 
Device or Slave Address.  

Slave Address Indicates, a specific address if you have chosen 
Slave Address in the Address to Use frame.   

Gratuitous ARP Enables the Gratuitous ARP functionality. A 
Gratuitous ARP is a broadcast to every device on 
the network, and enables each device to pre-
update its device listings. 

GARP Init Timer Sets, in seconds, the amount of time the ROC 
waits after the Gratuitous ARP is activated to 
begin ARPing at the user-configured frequency. 
Note:  This field is active only if you enable 

Gratuitous ARP. 
Reset Init Timer Click to reset the GARP Init Timer to the 

configured value. No ARPing will occur if you click 
this button (or SCADA writes to this parameter as 
a part of its normal polling sequence) before the 
GARP Init Timer expires. 
Note:  This field is active only if you enable 

Gratuitous ARP. 
GARP Frequency Sets, in seconds, the ARP interval. The ROC 

repeats at this interval (frequency) until it the 
GARP Init Timer field is reset. 
Note:  This field is active only if you enable 

Gratuitous ARP. 
 
3. Click Apply if you change any parameters on this screen. 

6.7.3 Points Tab 
The Points tab displays history point information.  
1. Select the ROC > Information > Points tab. The Points screen 

displays. 
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Figure 6-9. Device Information – Points tab  

2. Review the information on this screen.  
Field Description 

Maximum  This read-only field shows the maximum number 
of Events, Alarms, PIDs, Stations, Samplers, 
FSTs, and AGA meter runs (Orifice and Linear) 
allowed in the ROC.   

Active  Sets the number of active Events, Alarms, PIDs, 
Stations, Samplers, FSTs, and AGA meter runs 
(Orifice and Turbine) points on the currently 
attached device.  
Note:  This value cannot exceed the value shown 

in the Maximum number field. To conserve 
processor executions, set this value to the 
minimum value your application requires. 

Meter Runs  This read-only field indicates the maximum 
number of active meter runs (orifice and linear) for 
this ROC.   

Orifice and Linear  Sets the number of currently active orifice and 
linear runs in the ROC.  
Note:  This value cannot exceed the value shown 

in the Maximum Meter Runs field. To 
conserve processor executions, set this 
value to the minimum value your 
application requires. 

3. Click Apply if you change any parameters on this screen. 
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6.7.4 Other Information Tab 
The Other Information tab displays customer information.  
1. Select ROC > Information > Other Information tab. The Other 

Information screen displays.  

 
Figure 6-10. Device Information – Other Information tab  

2. Review the information on this screen.   
Field Description 

Version Name  This read-only field shows the version number for 
this device.  

Time Created  This read-only field shows the date and time the 
firmware was created.  

Vendor ID  This read-only field shows the vendor associated 
with this device.  

MPU Loading  This read-only field shows the processes in the 
processor (MPU Loading).  

Boot Version  This read-only field shows the version of the main 
startup firmware currently installed in the ROC.  

Time Created (Boot) This read-only field shows the date and time the 
boot firmware was created.  
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Field Description 
Last Power Down 
Time/Last Power Up 
Time  

These read-only fields show the date and time 
when the ROC was last connected to power (Last 
Power Up Time) and when the ROC was last 
disconnected from power (Last Power Down 
Time).   

 

6.7.5 System Configuration Tab 
The System Configuration tab allows you to specify four baud rates 
(BPS) the ROC can use at any given time.  
1. Select ROC > Information > System Configuration tab. The 

System Configuration screen displays.  
 

 
Figure 6-11. Device Information – System Configuration tab  

2. Review the information on this screen.  
Field Description 

Baud Rate  Sets the four baud rates the ROC can use at any 
given time. A read-only display on the Comm 
Ports General screen indicates which of the four 
baud rate generators is currently in use.  
Note:   Do not change these baud rates unless 

directed to do so by Technical Support 
personnel.  
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3. Click Apply if you change any parameters on this screen. 

6.7.6 Keypad Display Tab  
The Keypad Display tab allows you to configure settings for the 
ROC800-Series optional Display Keypad.  You can also view the 
current LCD Firmware Version installed. 
1. Select ROC > Information > Keypad Display tab. The Keypad 

Display screen displays.  

  
Figure 6-12. Information – Keypad Display  

2. Review the information on this screen.  
Field Description 

LCD Master Switch  Enables you to reset the Keypad/Display without 
cycling power or performing a warm start.  

LCD Status  This read-only field shows the status of the ROC 
Keypad Display. OK displays if a keypad display is 
installed and has a valid configuration file. An error 
displays if the configuration file is invalid, no 
keypad display is installed, or if there is a CRC 
error. 

LCD Video Mode  Sets the mode for the display. Dark Text on Light 
Background is the default. Click Apply to 
change the display mode.  

LCD Backlight 
Power Saving Mode  

Shuts off the LCD automatically after a defined 
amount of inactivity. The default is Disabled.  

Inactivity Time  Indicates, in seconds, how long the LCD backlight 
remains on without activity before automatically 
shutting off.  
Note: This field is active only if you enable the 

LCD Backlight Power Saving Mode.  
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Field Description 
LCD Firmware 
Version  

This read-only field shows the currently installed 
version of firmware for the Keypad Display.  

Auto Logout Period  Indicates, in minutes, how long the display waits 
inactive before automatically timing out and 
logging out the current user.  

Logout Scroll Time  Indicates, in seconds, how long the display pauses 
between parameter displays. For example, if you 
configure 10 parameters, the LCD displays 
parameters 1 through 5 and then parameters 6 
through 10 after the amount of time set in this 
field. The default value is 5 seconds. 

 
3. Click Apply if you change any parameters on this screen. 

6.7.7 Expanded I/O Tab (ROC827) 
The Expanded I/O tab provides information detailing the CPU 
backplane, including the number of installed expanded backplanes, their 
status, and version information. You can install up to four expanded I/O 
backplanes to expand the I/O capabilities of a ROC827.  

Note: This tab displays only if you are connected to a ROC with 
expanded backplanes.  

1. Select ROC > Information > Expanded I/O tab. The Expanded 
I/O screen displays.  

  
Figure 6-13. Device Information – Expanded I/O tab  

2. Review the information on this screen. 
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Field Description 
Backplane  Identifies the backplane you want to view. Click ▼ 

to display all available backplanes.  
System Mode  This read-only field shows the current mode of the 

ROC.  
Board Status  This read-only field shows the current status of the 

backplane. Valid values are:  
 Connected and 

Communicating 
Board is functioning correctly.  

 Module not 
installed 

No module is currently installed.  

 Communications 
lost 

ROC has lost communications 
with the backplane.  

Software Version  This read-only field shows the part number and 
version of the internal software (firmware).  

 
3. Click Apply if you change any parameters on this screen. 

6.7.8 Module Information Tab 
The Module Information tab displays information about programmable 
modules (such as the HART-2, MVS I/O, or ACIO) installed in the 
ROC.  
1. Select ROC > Information > Module Information tab. The 

Module Information screen displays.   

 
Figure 6-14. Device Information – Module Information tab  

2. Review the information on this screen.   
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Field Description 
Module  Selects the module to view. Click ▼ to display all 

available slots.  
Note: To populate this screen, you must select a 

programmable module.  
Module Type  This read-only field shows the type of module 

installed in the selected slot.  
Description This read-only field describes the currently 

installed module.  
Flash Part Number  This read-only field shows the part number 

associated with the selected module.   
Flash Revision  This read-only field shows the firmware version 

number for the selected module.  
Flash Build Date  This read-only field shows the date the firmware 

was produced for the selected module.  
Serial Number This read-only field shows the serial number for 

the selected module.  
System Mode  This read-only field shows the module’s system 

mode. Valid values are:  
 Run Mode Module is functioning 

correctly.  
 Boot Mode  No module is currently 

installed or module has no 
firmware.  

 Communications 
lost 

Module is not functioning 
correctly, is not running, or 
communications may have 
been lost.  

Board Health  This read-only field shows the module’s health. 
Valid values are:  

 OK Board is functioning correctly.  

 Module Not 
installed 

No module is currently 
installed.  

 Communications 
lost 

ROC has lost communications 
with the expanded backplane.  

Boot Part Number  This read-only field shows the part number of the 
main startup (boot)  firmware currently installed in 
the module.  

Boot Revision This read-only field shows the revision number for 
the main startup (boot) firmware currently installed 
in the module.  
Note:  This field is not valid for communications 

modules. 
Boot Build Date This read-only field shows the build date for the 

main startup (boot) firmware currently installed in 
the module.  
Note:  This field is not valid for communications 

modules. 
Data  This read-only field shows additional module-

specific information.  
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6.7.9 MPU Loading Tab 
Use the MPU Loading tab to monitor the average MPU load (system 
utilization) over a user-configurable amount of time. You can run two 
MPU load diagnostics simultaneously, and set alarming for each 
instance separately. This allows you to obtain averages from two 
different time periods (such as a 10 second average and a 180 second 
average), and set different thresholds and alarming for each instance. 
To access this screen: 
1. Select ROC > Information > MPU Loading tab. The MPU 

Loading screen displays.  

 
Figure 6-15. Device Information – MPU Loading tab 

2. Review the information on this screen.   
Field Description 

Instant MPU Load This read-only field shows the current percentage 
of system utilization. This value is updated each 
time the screen is refreshed. 

Enable Enables the MPU load diagnostic to run. 

Period Sets, in seconds, the length of time on which to 
base averages. 
Note:  This value applies to both the Current 

Average and Maximum Average fields. 
Current Average This read-only field shows the MPU load 

averaged over the length of time specified in the 
Period field. 
Note:  This field updates every time you select the 

Update button. 
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Field Description 
Maximum Average This read-only field shows the maximum MPU 

load average that occurred since the MPU 
diagnostic was started or reset. 

Reset (Averages) Click to clear the values in the Current Average 
and Maximum Average fields. 

Threshold Sets, in percent, a maximum MPU load value to 
monitor. If a sample is greater than the value in 
this field, the system updates the Over Threshold 
% field and raises an alarm (if alarming is 
enabled). 

Over Threshold % This read-only field shows the percentage of 
samples that have exceeded the value set in the 
Threshold field. 
Note:  This value will not clear until the Reset 

button next to it is pressed. 
Reset (Threshold) Click to clear the value in the Over Threshold % 

field. 
Alarming Enable Place a check mark to enable the system to log an 

alarm when the current load sample exceeds the 
value in the Threshold field. 

6.8 Flags 
Use the selections on the Flags screen to perform actions that affect the 
overall operation of the ROC. From this screen, you can save a 
configuration to Flash memory and, if necessary, re-initialize the ROC.  
 

 Caution Be very careful when using system flags. Selecting certain flags can 
lose data, change parameter values, and clear configuration memory. 
Be sure you understand the function of any flag before changing it.  

 

When you select ROC > Flags, ROCLINK 800 displays the Flags 
screen and defaults to the Flags tab (see Figure 6-15).  

6.8.1 Flags Tab 
Use the Flags tab to restart the ROC or save your configuration to flash 
memory.  
1. Select ROC > Flags. The Flags screen displays.  
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Figure 6-16. Flags – Flags tab  

2. Select one of these options:  
Button Description 

Warm Start  Click to begin a warm start.   
Following a warm start, ROCLINK 800 initializes 
SRAM memory. If the configuration is valid, 
databases and FSTs remain intact. If the 
configuration is not valid, ROCLINK 800 uses the 
last configuration saved to flash memory.  
To save a valid configuration, click Save 
Configuration. A user program remains on after a 
warm start. 
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Button Description 
Cold Start  

  
Click to begin a cold start.  
A cold start initializes the ROC from the last valid 
restart configuration saved in flash memory. If the 
configuration memory does not have a valid 
configuration written to it, the process uses the 
factory defaults.  
Use a cold start if a ROC is performing erratically, 
when the memory appears to be corrupted, or 
when resetting the unit to the last saved 
configuration.  
Note:   A cold start reloads all restart configuration 
data and may also clear logs, displays, and FSTs. 
Additionally, it may change outputs, load new 
accumulator values, and disable user program 
tasks and user data types. Generally, do not use 
Cold Start on a ROC that is actively gathering 
data or performing control. Save or document 
all required data and parameter values that could 
be affected before you perform a cold start. 
A cold star may clear logs and FSTs. If you 
performed a Save Configuration (which includes 
the FST and FST point in flash memory) before 
the cold start, the system reloads the saved FST 
in place of the cleared one. 

Cold Start & Clear 
Alarms  

Click to restore a configuration from default values 
stored in flash memory and clears the Alarm Log.  

Cold Start & Clear 
Events  

Click to restore a configuration from default values 
stored in flash memory and clears the Event Log.  

Cold Start & Clear 
FSTs  

Click to restore a configuration from default values 
stored in flash memory and clears all FSTs.  

Cold Start & Clear 
History Data  

Restores a configuration from default values 
stored in flash memory and clears all history 
database files.  

Cold Start & Clear 
ALL  

Click to restore a configuration from default values 
stored in flash memory and clears all history 
database files, alarm logs, event logs, and FSTs.  

From Factory 
Defaults 

See Section 6.8.2, Returning the Device to 
Factory Default Settings.  

History 
Configuration & 
Data  

Click to clear all history configuration and 
database files.  

Save Configuration  Click to save the current configuration to flash 
memory.  
When using a ROC800-Series, most configuration 
settings (including calibration values and loads) 
are stored into flash memory as the new 
configuration after a cold start. All user flags are 
maintained at their current status during this 
process. Clicking Save Configuration temporarily 
suspends all incoming communications. A running 
FST is temporarily suspended, but restarts where 
it was suspended. 
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Button Description 
Clear  Clears flash memory.  

Flash Write Status  
 

This read-only field shows the status of the 
selected activity.  

 

Reset (RST) Switch The ROC’s CPU module provides a Reset (RST) switch that you can 
use to restart the ROC from the boot block of flash memory 
(essentially a cold start) rather than from RAM (a warm start).   
For further information, refer to Central Processing Unit (CPU) in 
Chapter 2 of the ROC800-Series Remote Operations Controller 
Instruction Manual (Part D301217X012). 

6.8.2 Returning the Device to Factory Default Settings 
Sometimes it is necessary to return the ROC to the original factory 
default settings. The following procedure clears all saved restart 
configuration data contained in Flash memory. Only factory defaults are 
retained.  
To return the device to the original factory default settings: 
1. Select ROC > Flags. 
2. Click Flash Memory Clear. 
3. Click Yes and OK. 
4. Click From Factory Defaults (in the Restore Configuration frame). 
5. Click Yes and OK. 

Note: You may need to re-connect as the factory default settings may 
be altered from the stored data. 

6.8.3 Flags Advanced Tab 
Use the Advanced tab to perform actions that affect the CRC checking 
and the I/O scanning.  
1. Select the Advanced tab. The Flags Advanced screen displays. 
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Figure 6-17. Flags – Advanced tab  

2. Review the following fields.  
Field Description 

CRC Check  Activates Cyclical Redundancy Checking (CRC) on 
ROC protocol communications. Valid values are 
Enabled or Disabled. The default is Enabled. 
Note:   The ROC800-Series does not perform CRC 

checks on Ethernet communications. 
I/O Scanning  Enables I/O scanning on the I/O point displays. The 

default value is Enabled.  
LEDs  Enables a power-saving feature for LEDs (with the 

exception of the LED on the Power module). This 
parameter controls how long the LEDs remain on 
after you press the LED button on the CPU module.  
For instance, with the default setting of 5 minutes, 
all LEDs will go off. If you press the LED button, the 
LEDs become active again for 5 minutes. Enter 0 
(zero) in this field to allow the LEDs to always stay 
active. 

 
3. Click Apply if you change any parameters on this screen. 
4. Click OK to close this screen 
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Chapter 7 – The Configure Menu 

In This Chapter 

7.1 Configuring I/O ................................................................................. 7-2 
7.1.1 Analog Input (AI) Configuration ............................................ 7-2 
7.1.2 Analog Output (AO) Configuration ..................................... 7-17 
7.1.3 Discrete Input (DI) Configuration ........................................ 7-21 
7.1.4 Discrete Output (DO) Configuration ................................... 7-26 
7.1.5 Discrete Output Relay (DOR) Configuration ...................... 7-35 
7.1.6 Pulse Input (PI) Configuration ............................................ 7-35 
7.1.7 Thermocouple (TC) Input Configuration ............................. 7-42 
7.1.8 Resistance Temperature Detector (RTD) Input Configuration   

 .......................................................................................... 7-48 
7.1.9 System Analog Input (AI) Configuration ............................. 7-62 
7.1.10 Soft Points .......................................................................... 7-67 
7.1.11 Multi-Variable Sensor (MVS) Configuration ....................... 7-69 
7.1.12 HART Input Configuration .................................................. 7-87 
7.1.13 Advanced Pulse Module (APM) Configuration ................. 7-101 
7.1.14 Alternating Current I/O (ACIO) Configuration ................... 7-120 
7.1.15 Virtual Discrete Output (VDO) Configuration ................... 7-131 
7.1.16 IEC62591 Module ............................................................. 7-139 

7.2 Control Menu ............................................................................... 7-149 
7.2.1 FST Registers................................................................... 7-149 
7.2.2 Proportional, Integral, and Derivative (PID) ..................... 7-152 
7.2.3 Radio Power Control ........................................................ 7-164 
7.2.4 Sampler/Odorizer ............................................................. 7-167 
7.2.5 DS800 Development Suite Software ................................ 7-169 

7.3 History Segment Configuration .................................................... 7-171 
7.4 History Point Configuration .......................................................... 7-175 

7.4.1 History .............................................................................. 7-178 
7.4.2 History Wizard .................................................................. 7-183 
7.4.3 Undefining a Gas History Point ........................................ 7-185 

7.5 Opcode Table .............................................................................. 7-185 
7.6 Modbus Communications ............................................................ 7-186 

7.6.1 Modbus Configuration ...................................................... 7-187 
7.6.2 Modbus Conversion Codes .............................................. 7-210 
7.6.3 Modbus Events and Alarms ............................................. 7-217 

 

Use the Configure menu options to define points for inputs/outputs, 
control functions, Opcode points, history points, LCD user lists, user 
programs, and Modbus.  

  
Figure 7-1. Configure Menu  
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7.1 Configuring I/O 
The input/output (I/O) points in the ROC800-Series have many items 
that can be configured. For more information on the types of I/O 
available and their functions, refer to Chapter 3 of the ROC800-Series 
Remote Operations Controller Instruction Manual (part 
D301217X012).   

 

Note:  Options that are “grayed out” on the menu (such as AO Points) 
indicate modules which are not currently installed in the 
connected ROC800-Series and therefore not configurable.  

Configuring a ROC800-Series is a matter of establishing points and then 
configuring various parameters.  
Each input and output has a unique point number to identify the input or 
output. The point number indicates the location of the point at the slot 
number of the I/O module and channel number in the ROC800-Series. 
For example, DI 2-1 indicates the point number for a discrete input at 
module slot number two, first channel.  

7.1.1 Analog Input (AI) Configuration 
Analog inputs are analog signals that measurement devices (such as 
pressure and temperature transmitters, including RTD probes and 
pressure sensors) generate.  
Select Configure > I/O > AI Points. The Analog Input screen displays. 
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The Analog Input screen has four tabs. Use each tab to configure a 
component of the input. 
 Use the General tab to set the basic parameters for the analog input 

point. 
 Use the Advanced tab to configure features, such as filtering, A/D 

conversions, and clipping for the selected analog input. 
 Use the AI Calibration tab to calibrate the AI point while on-line. 
 Use the Alarms tab to set the alarm parameters for this AI point. 

Note:  You enable alarming on the Alarms tab. If you enable 
alarming, the limit alarms (four levels, Rate, and Deadband) 
are configured on the Alarms tab. To conserve Alarm Log 
space, alarms should be enabled only when necessary. Even 
if you do not plan to use all the alarms, check and adjust the 
value of each one so that no false alarms generate. 

Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start. 

AI: General Tab 
Select Configure > I/O > AI Points. The Analog Input screen displays 
with the General tab active. Use this tab to set the basic parameters for 
the analog input point.  
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Figure 7-2. AI – General tab  

Field Description 
Analog Inputs Selects the analog input to be configured. Click ▼ 

to display all available analog inputs.  
Note:  The selection in this field applies to each 

tab on this screen. 
Tag  Provides a 10-alphanumeric character identifier 

associated with each point type.  
Note:  The selection in this field applies to each 

tab on this screen. 
Point Number  The read-only field shows the rack location for 

this point.  
Value  This read-only field shows the value from the 

field device. When scanning is disabled, you can 
write to the failsafe or download value and then 
choose either the User Failsafe or User Download 
option in the Off Scan Mode frame on the 
Advanced tab.  

Units  Shows the engineering for the I/O (such as IN 
H2O, PSIG, MCF, degrees F, milliamps, or volts).  

Scan Period  Sets, in seconds, how frequently the system 
scans the input to acquire the Value when you 
enable scanning. Each AI updates based on its 
individual scan period.  

Low Reading EU  Sets the engineering unit (EU) for the low reading 
to zero percent input. For example, if a 
temperature transmitter is connected to the 
analog input with a range of – 40 to 160 degrees 
F, the Low Reading EU would be set to – 40.  
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Field Description 
High Reading EU  Sets the engineering unit (EU) for the high 

reading to 100 percent input.  
For example, if a temperature transmitter is 
connected to the analog input with a range of – 40 
to 160 degrees F, set this value to 160.  

Active Alarms  This read-only field shows any alarms that are 
active for this point. If you enable alarming, any 
active limit alarms (such as Low Alarm and Rate 
Alarm) display. Even if you disable alarming, the 
Point Fail alarm (hardware reports a malfunction) 
and Manual (Scanning Disabled) indicators can 
still appear.  

Scanning  Sets the scanning option for this point. Valid 
values are Enabled (automatically process the 
field input and display the last analog input scan in 
the Value field) or Disabled (permit only manual 
updates of the Value field).  
Note:  If you enable alarming, the ROC generates 

a Manual Mode alarm when scanning is 
disabled. If you disable scanning, you must 
manually enter a value to override the 
input. 

AI: Advanced Tab 
Use the Advanced tab to configure features such as filtering, A/D 
conversions, and clipping for the selected analog input.  
Select Configure > I/O > AI Points > Advanced tab. The Advanced 
screen displays. 

 
Figure 7-3. AI – Advanced tab  
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Field Description 
Filter Sets the Filter percent (ENTERED_DATA) as a 

weighted sample using a percentage of the last 
value plus a percentage of the new value. 

 
The system calculates the Filtered EU Value (on 
the General tab) once every second, regardless of 
the scan period, using the formula:  

Filtered EU Value =  
(last_value x ENTERED_DATA) +  
(new_value x (100 - (ENTERED_DATA / 100)) 

Adjusted A/D 0%  Sets the calibrated Analog-to-Digital count 
corresponding to zero percent input. In the 
Calibrate function, this value is altered to set the 
zero percent input exactly at the Low Reading EU 
value.  

Adjusted A/D 100 %  Sets the calibrated Analog-to-Digital count 
corresponding to 100 percent input. Use this value 
to convert the input to engineering units. In the 
Calibrate function, this value is altered to set the 
100 percent input exactly at the High Reading EU 
value.  

Raw A/D Input  This read-only field shows the current digital 
count directly from the Analog-to-Digital converter.  

Actual Scan  This read-only field shows the actual amount of 
time, in seconds, taken to complete the entire list 
of tasks. This value should be the same as the 
value in the Scan Period field on the General tab 
if the system is not overloaded.  

Average Raw 
Values  

Sets whether the system averages raw values 
during the scan period. Valid values are Enabled 
(average and calculate the raw readings during 
the scan period and use the results as the Raw 
A/D Input during calculations) or Disabled 
(acquire instantaneous values).  

Clipping  Forces the filtered EUs within a defined limit set on 
the Alarms tab. Valid values are Enabled (forces 
the filtered EUs to stay within a range defined by 
the cut off limits, set by using the LoLo Alarm and 
HiHi Alarm parameters defined on the Alarms tab) 
or Disabled (do not force clipping).  

Zero Shift  Sets a value (if necessary) to compensate for the 
zero shift effect on an input.  

Action on Failure Sets the action the system performs upon alarm 
detection. Valid values are Use Failsafe Value 
(use the value in the Failsafe Value field) and Use 
Live Value (use the value at which the input is 
currently set)..  
Note:  If you select Use Failsave Value, you must 

also enter a value in the Failsafe Value 
field the system uses if a restart occurs.   

Failsafe Value Indicates a value to use after a restart.   
Note:  This field activates only if you select Use 

Failsafe Value.  
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AI:AI Calibration Tab 
Use this tab to verify or calibrate an analog input.  
The calibration routine provides Verify, Calibrate, and Zero Shift 
functions for AI inputs. You can calibrate differential pressure (orifice 
metering may be High or Low Differential Pressure, depending on the 
device), static pressure, or temperature readings for each meter run. 
Select the Configure > I/O > AI Points > AI Calibration tab. The AI 
Calibration screen displays:  

 
Figure 7-4. AI – Calibration tab  

Notes: 
 You can calibrate inputs for up to five points (zero, span, and up to 

three mid-points). You must define at least two points (zero and 
span) for calibration. 

 If you leave the ROC idle during calibration, the ROC times out and 
resumes normal processing. Calibration values are restored to the 
previous values, an event is logged, and you must reconnect to start 
calibration from the beginning. 

 Click Cancel to exit the calibration without saving the changes. The 
ROC retains the previous calibration settings and logs an event. 

 

 Caution If you have an MVS transmitter, refer to Chapter 6, Sensor/Transmitter 
Accessories, in the ROC/FloBoss Accessories Instruction Manual (Form 
A4637) for the recommended way to remove or restore the device from 
or to working pressure during calibration. Failure to follow 
recommendations may damage the device.  
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Field Description 
Freeze  Click to stop the system from updating analog, 

MVS, DVS, HART, or temperature (RTD) inputs 
during verification or calibration. Once you click 
Freeze, the input is frozen at the current Freeze 
Value.  

Scan Mode  This read-only field displays the current input 
status. Valid values are:   

 Manual The system is in manual mode.  

 Normal Poll The system is functioning 
normally 

 Input Freeze After you click Freeze, input is 
frozen and activates Verify and 
Calibrate.  

 Poll Mode Sends an initial communication 
to a sensor to gather all the 
configuration data stored on that 
sensor.  

 Off Scan The sensor is disabled 

Freeze Value  This read-only field shows the value received 
from the analog input, DVS, HART, MVS, RTD, or 
meter inputs when the Update button was last 
clicked. The system uses these values in ongoing 
processing (such as flow calculations, history 
logging, or control) while calibration occurs.  

Verify  Click to start the verification process.  

Calibrate  Click to begin calibration and display the Set Zero 
dialog.  

Update  Click to request a value update from the input to 
be used as the Freeze Values.  

Zero 
Shift/Offset/RTD 
Bias 

Click to set adjustment factors for the input. The 
value is sent to the device for:  
 Zero Shift – Zeros the static pressure effect 

for the differential pressure input (Set Offset).  
 Offset – Sends the value of the live reading to 

set the reading as close to zero as possible for 
a static pressure inputs (Measured Pressure 
Reading).  

 RTD Bias – Calibrates the offset (shift) of 
temperature throughout the RTD curve 
(Temperature Standard Reading).  

 
Verifying an  

Analog Input 
Use this process to verify that the analog input is within operating 
limits. 

Note:  If the value is incorrect, you should calibrate the input.  

1. Select Configure > I/O > AI Points. The Analog Input screen 
displays. 
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2. From the AI Calibration tab, click Freeze to stop the values of the 
input from being updated during verification. ROCLINK prompts you 
to create a calibration report file.  

Note:  The Freeze Value field displays the value received from the 
input when you clicked Freeze. This is the value the system 
uses in ongoing processing (such as flow calculations and 
history logging) while performing calibration.   

 
3. Click Yes to display a Save As dialog.  

Note:  If you do not need a calibration report, click No to 
immediately display the Calibration screen.   

4. Indicate the file name for the report and click Save. The AI 
Calibration screen displays with active Verify and Calibrate buttons.  

 
Figure 7-5. AI – AI Calibration tab  

5. Review the value in the Scan Mode field. Valid values are Normal 
(point scanning is enabled and is updated each scan period) or 
Manual (the point is not in scanning mode). 

6. Click Verify. A Verify dialog displays.  
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Figure 7-6. Verify  

7. Complete the Dead Weight/Tester Value field with a value against 
which the test equipment verifies. 

When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it to the value in the Live 
Reading field (obtained from the temperature probe) and calculating 
the percentage deviation between the two values. 

8. Click Log Verify. ROCLINK 800 completes the first log entry on the 
screen.  
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Figure 7-7. Verify – Log Entry   

Field Description 
Action Indicates the current action. Valid values are 

Verify or Calibrate. 
Actual Displays the value in the Live Reading field. 

Expected Displays the value in the Dead Weight/Tester 
Value field. 

Deviation Displays the amount of deviation between the 
actual and expected values. 

% Deviation Displays a percentage deviation between the 
Actual and Expected values. 

 
9. As the live reading value changes, click Log Verify as many times as 

necessary to establish the verification log. 
10. Typically you verify the same points you calibrate. Temperature 

might be an example (– 100, 200, 50). For each test point, you set 
your test equipment to produce the expected value, enter that 
expected value in the Tester Value field, wait for live input to 
stabilize, and then click Log Verify. You can verify as many points 
as you want. 

11. Click Done. The AI Calibration screen displays.  
12. If your verification is satisfactory, click OK to close the Analog Input 

screen. If you need to calibrate the AI, proceed to Calibrating an 
Analog Input. 

Calibrating an  
Analog Input 

Use this process to calibrate an analog input.  
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1. Select Configure > I/O > AI Points. The Analog Input screen 
displays. 

2. From the AI Calibration tab, click Freeze to stop the values of the 
input from being updated. ROCLINK prompts you to create a 
calibration report file.  

Note:  The Freeze Value field displays the value received from the 
input when you clicked Freeze. This is the value the system 
uses in ongoing processing (such as flow calculations and 
history logging) while performing calibration.  

 
3. Click Yes to display a Save As dialog. 

Note:  If you do not need a calibration report, click No to 
immediately display the Calibration screen.   

4. Indicate the file name for the report and click Save. The AI 
Calibration screen displays with active Verify and Calibrate buttons. 

5. Review the value in the Scan Mode field. Valid values are Normal 
(point scanning is enabled and is updated each scan period) or 
Manual (the point is not in scanning mode).  

6. Click Calibrate. A Set Zero dialog displays.  

  
Figure 7-8. Set Zero  
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7. Click Set Zero.  
8. For the Set Zero entry in the calibration log, ROCLINK 800 provides 

As Found and As Left values and calculates the Deviation and % 
Deviation values (between the Dead Weight/Tester Value and the 
Live Reading values). ROCLINK 800 also resets the value in the 
Dead Weight/Tester Value field to 100 and activates the Set Span 
button.  

 

Figure 7-9. Set Zero (Log)  

9. Click Set Span.  
10. ROCLINK 800 completes the Set Span entry in the calibration log 

and activates the Set Mid 1 button.   



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

7-14 Configure Menu Revised February 2024 

 
Figure 7-10. Set Span (Log)  

Note:  A calibration requires only two points (zero and span). Your 
organization determines whether additional points (midpoints 
1, 2, or 3 typically at 25%, 50%, and 75% respectively) are 
necessary for a calibration. For this example, we set one 
midpoint.  

11. Click Set Mid 1.  
12. ROCLINK 800 completes the Set Mid 1 entry in the calibration log 

and activates the Set Mid 2 button.  
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Figure 7-11. Set Midpoint 1  

13. If you do not wish to configure additional midpoints, click Done. The 
AI Calibration screen displays. 

When the AI Calibration screen displays, you can calibrate inputs for 
another AI by starting again at step 1. 

AI: Alarms Tab 
Use this tab to set the alarm parameters for this AI point.  You also 
enable alarming on the tab. You must enable alarming to configure the 
limit alarms (Low, High, LoLo, HiHi, Rate, and Deadband) on this tab. 

Note:  To conserve alarm log space, enable alarms only when 
necessary. Even if you do not plan to use all the alarms, check 
and adjust the value of each alarm to prevent the generation of 
false alarms. 

Select the Alarms tab. The Alarms screen displays.  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

7-16 Configure Menu Revised February 2024 

 
Figure 7-12. AI – Alarms tab  

Field Description 
Alarming  Sets the alarm option for the selected point. Valid 

values are Enabled (configures the limit alarms - 
four levels, Rate, and Deadband) or Disabled 
(does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the 

Active Alarms field, but it is not logged in 
the Alarms file. If you enable alarming, the 
system generates an alarm if you disable 
scanning. 

RBX  Sets the Spontaneous Report-by-Exception 
(SRBX or RBX) alarming for this point. Valid 
values are On Alarm Set (which generates an 
RBX message to the host when the point enters 
an alarm condition) and On Alarm Clear (which 
generates an RBX message to the host when the 
point exits an alarm condition).   
Note:  RBX alarming requires you to configure the 

communications port. 
HiHi Alarm  Sets, in engineering units, a value to which the 

input value must rise to generate a HiHi Alarm.  
Note:  Typically, you set the value for the HiHi 

Alarm higher than the value for the High 
Alarm. 

High Alarm  Sets, in engineering units, a value to which the 
input value must rise to generate a High Alarm.  

Low Alarm  Sets, in engineering units, a limit value to which 
the input value must fall to generate a Low Alarm.  
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Field Description 
LoLo Alarm  Sets, in engineering units, a limit value to which 

the input value must fall to generate a LoLo 
Alarm.  
Note:  Typically, you set the value for the LoLo 

Alarm lower than the value for the Low 
Alarm. 

Rate Alarm  Sets, in engineering units, a value that represents 
the maximum amount of change allowed in the 
calculated rate between updates before an alarm 
generates. If the change is equal to or greater than 
this value, an alarm occurs.  
Note:  To disable this Rate Alarm without 

disabling the other alarms, set the value 
greater than the scan value of the analog 
input. 

Alarm Deadband  Sets, in engineering units, an inactive zone above 
the Low Alarm limits and below the High Alarm 
limits. The Alarm Deadband prevents the alarm 
from being set and cleared continuously when the 
input value is oscillating around the alarm limit. 
This prevents the Alarm Log from being over-filled 
with data.  

 

7.1.2 Analog Output (AO) Configuration 
Analog outputs are analog signals the ROC generates and sends to 
regulate equipment such as any analog device requiring proportional 
control.  
Select Configure > I/O > AO Points. The Analog Output screen 
displays.  

 
The Analog Output screen has three tabs. Use each tab to configure a 
component of the output:  
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 Use the General tab to set the basic parameters for the analog 
output point. 

 Use the Advanced tab to configure features, such as on-restart 
power settings and RBX alarming. 

 Use the Alarms tab to set the alarm parameters for the AO point. 
Save 

Configuration 
After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start 

AO: General Tab 
Select Configure > I/O > AO Points. The Analog Output screen 
displays with the General tab active. Use this tab to set the basic 
parameters for the analog output point.  

 
Figure 7-13. AO – General tab  

Field Description 
Analog Outputs  Selects the analog output to be configured. Click 

▼ to display all available analog outputs.  
Note:  The selection in this field applies to each 

tab on this screen.   
Tag  Provides a 10-alphanumeric characters) identifier 

associated with each point.  
Note: The selection in this field applies to each 

tab on this screen. 
Point Number  This read-only field shows the rack location for 

this point.  
Auto Value  Reads the value from the field device. When 

scanning is disabled, enter a value to override the 
output. If scanning is enabled, this field displays 
the last analog scan in engineering units.  

Units  Sets the engineering units for the I/O (such as IN 
H2O, PSIG, MCF, degrees F, milliamps, or volts).  
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Field Description 
Low Reading EU  Sets the engineering unit (EU) for the low reading 

to zero percent output (low end of the EU range). 
Based on the EU range determined in part by this 
parameter, the EU value is converted to a 
corresponding analog signal.  

High Reading EU  Sets the engineering unit (EU) for the high reading 
to 100 percent output (or high end of the EU 
range). Based on the EU range determined in part 
by this parameter, the EU value is converted to a 
corresponding analog signal.  

Manual Value  When the Scanning Mode is set to Manual, use 
Manual Value to enter the value instead of the 
Auto Value field.  

Physical Value  The read-only field shows the current state of the 
AO. When the AO is in Manual Mode, this should 
reflect the Manual Value. When the AO is in Auto 
mode, this should reflect the Auto Value.  

Scanning Mode  Sets the scanning option for this point. Valid 
values are Auto (automatically process the field 
input and display the last analog output scan in the 
Auto Value field), Disabled (do not permit any 
updates of the Auto Value or Manual Value fields), 
or Manual (enter the value in the Manual Value 
field).  
Note:  If you enable alarming, the ROC generates 

a Manual Mode alarm when Scanning is 
Disabled. 

Active Alarms  This read-only field shows any active alarms for 
this point. When you Enable alarming, the limit 
alarms (such as Low Alarm and Rate Alarm) that 
are active appear. Even if you Disable alarming, 
the Point Fail (hardware reports a malfunction) 
alarm and Manual (Scanning Disabled) indicators 
can still appear.  
Note:  A read-back error indicates the AO is 

driving the output to a set level, but the loop 
is not responding. Example: An I/P 
converter is connected to the A/O and set 
to 25%. If the I/P is not connected or an 
open wire occurs, a read-back error would 
display. 

AO: Advanced Tab 
Use the Advanced tab to configure features such as resetting and output 
values for the analog output.  
Select Configure.> I/O > AO Points > Advanced tab. The Advanced 
screen displays. 
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Figure 7-14. AO – Advanced tab  

Field Description 
Raw D/A Output  This read-only field shows the current counts 

written to the digital-to-analog converter. The D/A 
value set to the AO is the raw D/A output. The 
default value is 0.  

Adjusted D/A 0%  Sets the count the digital-to-analog converter uses 
for zero percent output. This value is also used to 
scale the output to engineering units. The default 
is 0.  

Adjusted D/ A 100 %  Sets the count decoded by the digital-to-analog 
converter for 100 percent output. This value is also 
used to scale the output to engineering units.  

Value After Reset or 
Power Fail   

Sets what value the system uses on a power 
restart or a warm start. Valid values are Retain 
Last Value (maintain last output value ) or Use 
Failsafe Value (use specified value ). Retain Last 
Value is the default.  
Note:  If you select Use Failsafe Value, you must 

also complete the Failsafe Value field.  
Failsafe Value  If you select Use Failsafe Value, complete this 

field to indicate a value the system uses on a power 
restart or a warm start.  

AO: Alarms Tab 
Use this tab to enable or disable alarming and to indicate when RBX 
reporting occurs. Select Configure > I/O > AO Points > Alarms tab. 
The Alarms screen displays.  
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Figure 7-15. AO – Alarms tab  

Field Description 
Alarming Sets Alarming to generate alarms on point failure. 

When Alarming is Disabled, the Point Fail alarm 
appears in the Active Alarms field, but will not be 
written to the Alarm Log.  
To conserve Alarm Log space, enable alarms only 
when necessary. Even if you do not plan to use all 
the alarms, check and adjust the value of each 
one so that no false alarms generate. 

RBX  Sets the RBX Alarming option to configure 
Spontaneous-Report-By-Exception (SRBX or 
RBX) alarming for this point.  Valid values are On 
Alarm Set (which generates an RBX message to 
the host when the point enters an alarm condition) 
and On Alarm Clear (which generates an RBX 
message to the host when the point exits an 
alarm condition).  
Note:  RBX Alarming requires you to configure the 

communications port. 

7.1.3 Discrete Input (DI) Configuration 
Discrete Input (DI) modules monitor the status of relays, open 
collector/open drain type solid-state switches, and other two-state 
devices. Each DI channel can also be software configured to function as 
a "latched" DI, which remains in the active state until reset. Other 
parameters can invert the field signal and gather statistical information 
on the number of transitions and the time accumulated in the on or off 
state.  
Select Configure > I/O > DI Points. The Discrete Input screen 
displays. 
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The Discrete Input screen has three tabs. Use each tab to configure a 
component of the input.   
 Use the General tab to set the basic parameters for the DI point. 
 Use the Advanced tab to configure features, such as filtering, input 

inversion, and counter values for the discrete output. 
 Use the Alarms tab to set the alarm parameters for this DI point. 

Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start 

DI: General Tab 
Select Configure > I/O > DI Points. The Discrete Input screen displays 
with the General tab active. Use this tab to set the basic parameters for 
the discrete input point.  
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Figure 7-16. DI – General tab  

Field Description 
Discrete Inputs  Selects the discrete input to be configured. Click 

▼ to display all available discrete inputs.  
Note:  The selection in this field applies to each 

tab on this screen.   
Tag  Sets a short (10 alphanumeric characters) 

identifier for the point.  
Note:  The selection in this field applies to each 

tab on this screen. 
Point Number  This read-only field shows the rack location for 

this point.  
Module Scan Period  Sets, in seconds, how frequently the system scans 

the input.  
Status  Sets the state of the discrete input. Valid values 

are On (indicates that a contact is closed or input 
is on) or Off (indicates that a contact is open or 
input is off). Off is the default.   

Physical Status  This read-only field shows the state of the 
hardware. Off normally indicates that a switch is 
open; On normally indicates that a switch is 
closed. This may be different from the Status if 
Inverting or Latching is in effect.  

Scanning  Sets the scanning option for this point. Valid 
values: 

 Enabled Automatically process the field 
input. 

 Disabled Do not process the input. 
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Field Description 
DIN Type  Sets how the DI functions. Valid values are 

Standard (follow the actual field input) and 
Latched (maintain the input status). During an 
active transition from off to on, Latched mode 
enables the DI to remain in the on state until you 
clear the Status parameter either manually or 
through the software.  

Active Alarms  This read-only field shows any active alarms for 
this point. When you enable alarming, the limit 
alarms (such as Low Alarm and Rate Alarm) that 
are active appear. Even if you disable alarming, 
the Point Fail (hardware reports a malfunction) 
alarm and Manual (Scanning Disabled) indicators 
can still appear. Refer to User Interface Basics.  

DI: Advanced Tab 
Use the Advanced tab to configure features such as filtering, input 
inversion, and counter values for the discrete input.  
Select Configure > I/O > DI Points > Advanced tab. The Advanced 
screen displays. 

  
Figure 7-17. DI – Advanced tab  

Field Description 
Input  Sets the state of the input. Valid values are 

Normal (field input operates normally, so that On 
is On) or Inverted (inverts the field input in the 
Status field so that On becomes Off and vice-
versa).  Normal is the default.  
In the Inverted state, an open circuit in the field 
would then be indicated as On in the Status field, 
and closed contacts would be indicated as Off. 
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Field Description 
Filter  Sets, in seconds, the amount of time that the 

discrete input must remain in the On (high) state 
before the device recognizes it as such. Enter a 
value between 0 to 255. The discrete input returns 
to the Off state immediately upon detection of the 
On to Off transition; there is no filtering for this 
transition.  

Accumulated Value  Counts the number of times the discrete input 
goes from Off to On. The accumulator is a 32-bit 
number with a maximum count of 4,294,967,295. 
You can preset the accumulator by entering the 
desired value or clear the accumulator by entering 
0.  

On Counter  Counts the number of 50-millisecond periods 
when the Status parameter is in the On state. The 
On Counter is a 32-bit number that automatically 
rolls over when it reaches its maximum value. You 
can preset the On Counter by entering the desired 
value or clear the counter by entering 0.  
Note:  The On Counter does not function if you 

disable scanning. 
Off Counter  Counts the number of 50-millisecond periods 

when the Status parameter is in the Off state. The 
Off Counter is a 32-bit number that automatically 
"rolls over" when it reaches its maximum value. 
You can preset the Off Counter by entering the 
desired value or clear the counter by entering 0.  
Note:  The Off Counter does not function if you 

disable scanning. 
Actual Scan  This read-only field shows the actual amount of 

time in seconds that passes between scans. This 
number should be the same as shown for the 
Module Scan Period parameter if the system is not 
overloaded.  

DI: Alarms Tab 
Use the Alarms tab to configure the alarm parameters for this discrete 
input.  
Select the Alarms tab. The Alarms screen displays. 
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Figure 7-18. DI – Alarms tab  

Field Description 
Alarming  Sets the alarm option for the selected point. Valid 

values are Enabled (generates an alarm when the 
point’s status changes) or Disabled (no alarm 
generates). The default is Disabled.  
When you disable alarming, the Status Change 
alarm appears in the Active Alarms field, but is not 
written to the Alarms log.  
Note:  The Point Fail alarm may appear in the 

Active Alarms field, but is not logged in the 
Alarms file. If you enable alarming, the 
system generates an alarm if you disable 
scanning. 

RBX Alarming  Sets the Spontaneous-Report-by-Exception 
(SRBX or RBX) alarming for this point.  Valid 
values are On Alarm Set (which generates an 
RBX message to the host when the point enters 
an alarm condition) or On Alarm Clear (which 
Generates an RBX message to the host when the 
point exits an alarm condition):  
Note:  RBX Alarming also requires you to 

configure the communications. 

7.1.4 Discrete Output (DO) Configuration 
Discrete outputs are high/low outputs used to turn equipment on and off. 
You can set a discrete output to send a pulse to a specified device.  You 
can also configure a discrete output as latched, momentary, toggle, 
Timed Duration Output (TDO), and TDO toggle.  
Select Configure > I/O > DO Points. The Discrete Output screen 
displays.  
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Examine the default settings and adjust the parameters to suit your 
application on each of the tabs. 
 Use the General tab to set the basic parameters for the DO point. 
 Use the Advanced tab to configure accumulated value and state for 

reset for the selected DO. 
 Use the TDO Parameters tab to configure TDO parameters. 
 Use the Alarms tab set the alarm parameters for this DO point. 

Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start 

DO: General Tab 
Select Configure > I/O > DO Points. The Discrete Output screen 
displays with the General tab active. Use this tab to configure the basic 
parameters for the DO point.  
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Figure 7-19. DO – General tab  

Field Description 
Discrete Outputs Selects the discrete output to be configured. Click  

to display all available discrete outputs.  
Note:  The selection in this field applies to each 

tab on this screen.   
Tag  Provides a 10-alphanumeric character identifier 

associated with each point.  
Note:  The selection in this field applies to each 

tab on this screen. 
Point Number  This read-only field identifies the rack location for 

this point.  
Time On  This read-only field shows, in seconds, the 

amount of time for momentary operation. The 
default value is 1.0 seconds for a DO. The default 
value is 5 milliseconds for an ACIO DO.  
Note:  In Momentary mode, this is the amount of 

time (in seconds) that the momentary 
contact is energized. In the Toggle mode, 
this is the time (in seconds) between 
switching On or Off. In the TDO and TDO 
Toggle modes, the TDO configuration 
calculates this value.  

Auto Output  Indicates the state of the discrete output. Valid 
vaules are Off (the output is off or a switch is 
open) and On (the output is on or a switch is 
closed). The default is Off.   

Manual Output  Indicates the state of the discrete output. Valid 
values are Off (the output is off or a switch is 
open) and On (the output is On or a switch is 
closed). Select On and click Apply to force one 
transition of the DO.  
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Field Description 
Momentary  This read-only field shows the state of the 

discrete output when the DOUT Type is set to 
Momentary. Valid values are Off (the output is off 
or a switch is open) and On (the output is on or a 
switch is closed).  

Physical Output  This read-only field shows the actual status of the 
output channel at the field terminations regardless 
of the DOUT Type selected.  

DOUT Type  Selects the function of this discrete output. Valid 
values are:  

 Latched Changes on an active transition 
of the output (from off to on). 
The discrete output remains On 
until cleared by selecting Off in 
the Auto Output field.  

 Momentary Enables ROCLINK 800 to 
activate the discrete output for 
the amount of time defined in the 
Time On field. 

 Toggle Enables a square-wave output 
for which both the time on and 
time off are defined by the value 
in the Time On parameter. Time 
on and time off are equal. Use 
the TDO Parameters tab to 
define time-related parameters. 

 TDO Enables the discrete output to 
have a time duration between 
On and Off transitions based on 
time-related parameters 
configured in the TDO 
Parameters tab. 

 TDO Toggle Enables the discrete output to 
continuously repeat in a cycle 
defined by the value in the 
Cycle Time field on the TDO 
Parameters tab where the EU 
Value controls the on-time 
duration. 
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Field Description 
Scanning Mode  Sets the scanning type to configure how the DO is 

scanned. Valid values are:   
 Auto Automatically processes the field 

output.  
 Manual Prevents the ROC from updating 

the DO value; permits only 
manual updates of the output 
value. Set Manual Output to On 
and click Apply to override the 
output.  

 Disabled Prevents the ROC from updating 
the DO value; permits a manual 
process of the last output scan. 
Set Auto Output to On and click 
Apply to override the output.  

 Note:  If you enable alarming, the ROC generates 
a Manual Mode alarm when scanning is 
disabled. 

Active Alarms  This read-only field shows any active alarms for 
this point. When you Enable alarming, the limit 
alarms (such as Low Alarm and Rate Alarm) that 
are active appear. Even if you Disable alarming, 
the Point Fail (hardware reports a malfunction) 
alarm and Manual (Scanning Disabled) indicators 
can still appear.  

DO: Advanced Tab 
Use this tab to configure accumulated value and state for reset for the 
selected DO.  
Select Configure > I/O > DO Points > Advanced tab. The Advanced 
screen displays. 
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Figure 7-20. DO – Advanced tab  

Field Description 
Accumulated Value Sets a value for the accumulated number of off-to-

on transitions for the discrete output. The 
accumulator is a 32-bit number with a maximum 
count of 4,294,967,295. You can preset the 
accumulator to a desired value or clear it by 
entering zero (0).  

Action After Reset 
or Power Fail  

Indicates how the ROC handles the discrete 
output relay state on power reset or failure. Valid 
values are Use Failsafe Mode (discrete output 
uses value set in the Failsafe State frame: On or 
Off) or Retain Last Status (ROC retains the DO 
state, whether off or on).  

Failsafe State  Indicates whether the failsafe state is active 
following a reset due to a power restart or warn 
start. Valid values are On or Off.   
Note:  If you select On, you must also indicate (on 

the General tab) whether the Auto Output 
or Manual Output is set to On or Off after 
a reset of the ROC.  

Output  Indicates the state of the DO output. Valid values 
are Normal (energizes in time on) or Inverted 
(energizes in time off). Selecting Inverted inverts 
all outputs in any mode.  
Note:  If Failsafe State is set to On and Inverted is 

On, the Failsafe State returns to Off 
following a reset. 

DO: TDO Parameters Tab 
Use this tab to configure time duration parameters for this DO point.  
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Notes: To correctly configure time duration DO, ensure that you have 
selected TDO in the DOUT Type field and Auto as the 
Scanning Mode on the General tab for DO.  

Select Configure > I/O > DO Points > TDO Parameters tab. The 
TDO Parameters screen displays.   

 
Figure 7-21. DO – TDO Parameters tab  

Field Description 
Cycle Time  Sets, in seconds, the total amount of time the 

cycle spends in the on and off positions. The 
default is 15 seconds.  
The system uses Cycle Time to define the Off time 
in the TDO Toggle mode using the formula.  
 

Off Time = Cycle Time – On Time 
 
For example, a TDO is used to emulate a field 
instrument measuring flow. The TDO outputs a 
pulse width of 3 seconds for no flow and a pulse 
width of 12 seconds for 1000 MCF per day flow. 
The output is repeated every 15 seconds. 
 
If the Cycle Time is less than or equal to the On 
Time, set the Off Time to 1 (one). Care must be 
taken in configuration (including other places, such 
as FSTs) to ensure that the Cycle Time remains 
greater than the calculated On Time for proper 
operation. 
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Field Description 
Low Reading Time  Sets, in seconds, the Low Reading Time (0% 

Count) that represents a zero percent output pulse 
width. The default is 3 seconds. This is the 
minimum amount of time that the TDO can be 
energized to move the motor. Set to a value that 
allows movement, but also provides good 
resolution of control.  

High Reading Time  Sets, in seconds, the High Reading Time (100% 
Count) that represents a 100 percent output pulse 
width. The default is 12 seconds. This is the 
maximum amount of time that the TDO can be 
energized to move the motor. Normally, this is the 
amount of time it takes for the actuator to move 
the valve from fully open to fully closed.  

Low Reading EU  Sets the engineering unit (EU) for the low reading 
to zero percent output (low end of the EU range). 
Based on the EU range determined in part by this 
parameter, the EU value is converted to a 
corresponding signal. 

High Reading EU  Sets the engineering unit (EU) for the high reading 
to 100 percent output (or high end of the EU 
range). Based on the EU range determined in part 
by this parameter, the EU value is converted to a 
corresponding signal. 

EU Value  Current value, displayed in engineering units.  
In TDO Toggle mode, the EU Value controls the 
Time On: 

On Time = ((EU Value – Low Reading EU) / 
(High Reading EU – Low Reading EU) * 
(High Time – Low Time)) + Low Time 

Units  Sets the engineering units for the discrete output 
(such as percentage, IN H2O, PSIG, MCF, 
degrees F, milliamps, and volts).  

 
Defining the  

Output Pulse 
To define the TDO output pulse:  

1. Select Configure > I/O > DO Points. The Discrete Output screen 
displays.  

2. Select a DOUT Type of TDO or TDO Toggle. 
 TDO (Timed Duration) – The single-pulse output can be 

triggered by writing to the Status or the EU Value parameter of 
the DO point. This can be accomplished directly, by a PID point, 
or by an FST. 

 TDO Toggle – A continuous pulse is generated with the pulse 
length being controlled by writing to the EU Value parameter in 
the DO point. This can be accomplished directly or by an FST. 

3. Click the TDO Parameters tab. 
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The output pulse from the TDO function must be defined for proper 
engineering unit (EU) conversion. The minimum pulse width (Low 
Reading Time / 0% Count) and the maximum pulse width (High 
Reading Time / 100% Count) define the minimum and maximum On 
time of the output pulse. The values entered in the Low Reading Time 
and High Reading Time represent the number of seconds the output is 
On. 
Example: 
A TDO is used to emulate a field instrument measuring flow. The TDO 
outputs a pulse width of 3 seconds for no flow and a pulse width of 12 
seconds for 1000 MCF per day flow. 

Low Reading Time (0% Count) = 3 seconds 
High Reading Time (100% Count) = 12 seconds 
Low Reading EU = 0 
High Reading EU = 1000 

DO: Alarms Tab 
Use this tab to set the alarm parameter for this DO point. Select 
Configure > I/O > DO Points > Alarms tab. The Alarms screen 
displays.  

 

Figure 7-22. DO – Alarms tab  
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Field Description 
Alarming Sets the alarm option for this point. Valid values 

are Enabled (enables alarming) or Disabled 
(does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the 

Active Alarms field, but is not logged in the 
Alarms file. If you enable alarming, the 
system generates an alarm if you disable 
scanning. 

RBX Sets the Spontaneous-Report-by-Exception 
(SRBX or RBX) alarming for this point.  Valid 
values are On Alarm Set (which generates an 
RBX message to the host when the point enters 
an alarm condition) and On Alarm Clear (which 
generates an RBX message to the host when the 
point exits an alarm condition).   
Note:  RBX Alarming requires you to configure the 

communications port. 

7.1.5 Discrete Output Relay (DOR) Configuration 
The Discrete Output Relay (DOR) module provides the ROC800 with 
the ability to control various discrete output field devices.  
The DOR module provides six channels of discrete outputs. DOR 
modules use mechanical (SPST) latching relays to provide a set of 
normally-open dry contacts capable of switching 2 A at 32 Volts dc 
across the complete operating temperature. DO Relays are high/low 
outputs used to turn equipment on and off. You can set a discrete output 
to send a pulse to a specified device 
You configure the DOR module as you would a DO module. The major 
difference occurs in how you wire the modules. For that information, 
refer to Chapter 3 of the ROC800-Series Remote Operations Controller 
Instruction Manual (A6175).  

7.1.6 Pulse Input (PI) Configuration 
Pulse Input (PI) modules accept pulse trains (square wave signals) that 
measurement devices (such as turbine meters) generate. The pulse input 
accepts digital level on/off signals from an external device and 
accumulates the changes over a configured period of time. The PI can 
also determine a rate from the accumulated pulses over a configured 
period of time.  
Select Configure > I/O > PI Points. The Pulse Input screen displays.  
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The Pulse Input screen has three tabs. Use each tab to configure a 
component of this input.  
 Use the General tab to set the basic parameters for the PI point. 
 Use the Advanced tab to configure features, such as EU Options, 

Rate Period, Rollover value, and Conversion for the pulse input. 
 Use the Alarms tab to set the alarm parameters for this PI point. 

Note: If you enable Alarming, configure the limit alarms (four levels, 
rate, and deadband) on the Alarms tab. By disabling alarms, you 
can prevent alarms from generating for this point. To conserve 
alarm log space, enable alarms only when necessary. If you do 
not plan to use all the alarms, check and adjust the value of each 
one to prevent the generation of false alarms. 

Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start.  

PI: General Tab 
The Pulse Input screen initially displays the General tab. Use this tab to 
set the basic parameters for the pulse input point. Select Configure > 
I/O > PI Points.  
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Figure 7-1. PI – General tab  

Field Description 
Pulse Inputs  Selects the pulse input to configure. Click ▼ to 

display all available pulse inputs.  
Note:  The selection in this field applies to each 

tab on this screen. 
Tag  Sets a short (10 alphanumeric characters) 

identifier for the point.  
Note:  This selection in this field applies to each 

tab on this screen. 
Point Number  This read-only field shows the rack location 

(module slot and channel number) for this point.  
EU Value  Sets the value for engineering units (EUs).  

The EU Value is dependent on how you set the 
EU Options on the Advanced tab. If you set up the 
PI as a Rate (Max Rollover), then the system 
assigns the Current Rate to the EU Value. If you 
set up the PI as an accumulator using Today’s 
Total (Max Rollover), then the system assigns 
Today’s Total to the EU Value. 
If you set up the PI as an accumulator using 
Running Total (Entered Rollover), then the EU 
Value corresponds to the accumulated pulses 
times the Conversion. The system compares the 
EU Value to the value entered for the Rollover 
Value. If the EU Value is greater than or equal to 
the entered Rollover Value, the system sets the 
EU Value here to zero.  

Units  Sets the engineering units for the I/O (In H2O, 
PSIG, MCF, degrees F, milliamps, or volts).  
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Field Description 
Scan Period  Sets, in seconds, the amount of time between 

scans of the EU Value. The default value is 1.0 
second. The system calculates this rate by 
counting the number of pulses during the scan 
interval and dividing by the time interval.  
To avoid highly fluctuating calculation results, 
typically at least 10 pulses should occur between 
scans at low flow conditions. For example, if a flow 
meter produces one pulse per second at low flow, 
then set the Scan Period value to a minimum of 10 
seconds. 
Note:  Once the system reaches the scan period, 

it updates the values in the Accum’d 
Pulses, Pulses Today, Today’s Total, 
Yesterday’s Total, and Current Rate fields. 

Accum’d Pulses  Sets the number of raw counts stored in the 
accumulated value counter in firmware. For each 
scan period, the ROC determines the number of 
raw counts that have occurred since the last scan 
period and adds them to the accumulated value 
counter.  
The accumulated value rolls over to zero after 
reaching 16,000,000. 

Pulses For Day  This read-only field shows the total number of 
pulses that the PI has received for the contract 
day. At the end of the contract day, the ROC zeros 
this field and starts over, only if being totalized in 
History. The Contract Hour is specified on this 
screen.  

Today's Total  Displays the total EU Values accumulated for the 
current contract day, calculated by multiplying the 
conversion value by the accumulated pulses. The 
system resets this value to zero at the contract 
hour.  

Yesterday's Total  This read-only field shows the total EU Value 
accumulated the previous contract day, calculated 
as the previous day’s Today’s Total value at the 
contract hour before being cleared.  

Current Rate  This read-only field shows the calculated rate as 
of the most recent scan expressed in EUs per unit 
of time. You select time units using the Rate 
Period field on the Advanced tab. The system 
calculates the rate at the end of each scan period 
by multiplying the number of pulses received by 
the conversion value divided by the rate period. 

Active Alarms  This read-only field shows any active alarms for 
this point. When you Enable alarming, the limit 
alarms (such as Low Alarm and Rate Alarm) that 
are active appear. Even if you Disable alarming, 
the Point Fail (hardware reports a malfunction) 
alarm and Manual (Scanning Disabled) indicators 
can still appear.  
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Field Description 
Contract Hour  Sets the beginning of the day for the daily counted 

parameters. Click ▼ to display all defined contract 
hours.  

Conversion  Indicates a conversion factor by which the system 
multiplies or divides the number of pulses to 
determine the EU value. 
Note:  You specify how the system uses this value 

in the Conversion field on the Advance tab. 
Frequency  This read-only field shows, in pulses/second, the 

frequency of incoming pulses.  
Scanning  Sets the scanning option for this point. Valid 

values: 
 Enabled Automatically process the field 

input and display the last analog 
input scan in the Value field. 

 Disabled Permit only manual updates of 
the Value field. 

 Note:  If you enable alarming, the ROC generates 
a Manual Mode alarm when scanning is disabled. 
If you disable scanning, you must manually enter a 
value to override the input. 

PI: Advanced Tab  
Use this tab to configure features, such as EU Options, Rate Period, 
Rollover value, and Conversion for the pulse input.  
Select Configure > I/O > PI Points > Advanced tab. The Advanced 
screen displays. 

 

Figure 7-24. PI – Advanced tab  
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Field Description 
EU Options  Sets how the system assigns the value of the 

engineering units (EU). Valid values are:  
 Rate (Max 

Rollover) 
Uses the value of the Current 
Rate parameter (as shown on 
the General tab) 

 Running Total 
(Entered 
Rollover)  

Uses the value of Today’s Total 
parameter (as shown on the 
General tab) 

 Today’s Total 
(Max Rollover) 

Uses a value calculated by 
multiplying the accumulated 
pulses (shown on the General 
tab) by the Conversion factor. If 
the EU Value exceeds the 
Rollover value, it is cleared and 
starts to accumulate again from 
0. 

 Note:  This option does not clear EU values at the 
contract hour. 

Conversion/K 
Factor 

Sets how ROCLINK uses the number in the 
Conversion field on the PI General tab.  

Rollover Value 
(EUs) 

Sets a value in EUs (not pulses) to indicate when 
rollover should occur.  
Note:  This field is available only if you select 

Running Total as an EU Options value. 
Rate Period  Sets how the system calculates rates, if you 

selected Rate as an EU Option. Valid values are: 
 EU/sec Calculation based on EU second totals. 

 EU/hour Calculation based on EU hourly totals. 

 EU/min Calculation based on EU minute totals. 

 EU/day Calculation based on EU daily totals. 

 Note:  If you select EUs/Pulse as a conversion rate 
and EU/min as a rate period, the system 
calculates Current Rate as (accumulated 
pulses x Conversion) ÷ (Scan Period x 
conversion from seconds to minutes). If you 
select Pulses/EU as a conversion rate and 
EU/hour as a rate period, the system 
calculates Current Rate as (accumulated 
pulses ÷ Conversion) ÷ (Scan Period x 
conversion from seconds to minutes). 

Conversion  Specifies how the number entered in the 
Conversion field on the PI General tab is used. 
Valid values are: 

 EUs/Pulse Associates a specific number of 
engineering units, typically fractional 
parts such as 0.01, with a single pulse. 

 Pulses/EU Associates a specific number of 
pulses, such as 100, with one 
engineering unit. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Configure Menu 7-41 

PI: Alarms Tab 
Use this tab to configure the alarm parameters for this PI point.  You 
must enable alarming on the General tab to configure the limit alarms 
(Low, High, LoLo, HiHi, Rate, and Deadband) on this tab. If you 
disable alarming, no limit alarms generate for this point. The Point Fail 
alarm appears in the Active Alarms field on the General tab, but the 
system does not log it in the Alarms Log. 

Note:  To conserve alarm log space, enable alarms only when 
necessary. Even if you do not plan to use all the alarms, check 
and adjust the value of each one alarm to prevent the generation 
of false alarms 

Select Configure > I/O > PI Points > Alarms tab. The Alarms screen 
displays. 

 

Figure 7-25. PI – Alarms tab  

Field Description 
Alarming  Sets the alarm option for this point. Valid values 

are Enabled (configures the limit alarms - four 
levels, Rate, and Deadband) or Disabled (does 
not generate limit alarms).  
Note:  The Point Fail alarm may appear in the 

Active Alarms field, but is not logged in the 
Alarms file. If you Enable alarming, the 
system generates an alarm if you disable 
scanning. 
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Field Description 
RBX  Sets the Spontaneous-Report-by-Exception 

(SRBX or RBX) alarming for this point. Valid 
values are On Alarm Set (which generates an 
RBX message when the point enters an alarm 
condition) or On Alarm Clear (which generates an 
RBX message when the point exits an alarm 
condition).   
Note:  RBX Alarming requires you to configure the 

the communications port. 
HiHi Alarm Sets, in engineering units, a value to which the 

input value must rise to generate a HiHi alarm. 
Note:  Typically you set the value for the HiHi 

alarm higher than the value for the High 
Alarm.  

High Alarm  Sets, in engineering units, a value to which the 
input value must rise to generate a high alarm.  

Low Alarm  Sets, in engineering units, a limit value to which 
the input value must fall to generate a Low Alarm.  

LoLo Alarm  Sets, in engineering units, a value to which the 
input value must fall to generate a LoLo alarm. 
Note:  Typically you set the value for the LoLo 

alarm lower than the value for the Low 
Alarm.  

Rate Alarm  Sets, in engineering units, a value that represents 
the maximum amount of change allowed in the 
calculated rate between updates before an alarm 
generates. If the change is equal to or greater than 
this value, an alarm occurs.  
Note:  To disable the Rate alarm without disabling 

the other alarms, set the value greater than 
the scan value of the input. 

Alarm Deadband  Sets, in engineering units, an inactive zone above 
the Low Alarm limit and below the High Alarm 
limit. The Alarm Deadband prevents the alarm 
from being set and cleared continuously when the 
input value is oscillating around the alarm limit. 
This prevents the Alarm Log from being over-filled 
with data.  

7.1.7 Thermocouple (TC) Input Configuration 
Thermocouple (TC) Inputs monitor the extremely small voltage 
generated by a thermocouple sensor. These small voltages are converted 
to temperature values.  
Select Configure > I/O > TC Points. The Thermocouple Input screen 
displays.  
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 The Thermocouple Input screen has the following tabs. Use each tab 

to configure a component of the input.  
 Use the General tab to set the basic parameters for the TC Input point. 
 Use the Advanced tab to configure features, such as filtering and 

averaging for the selected TC point. 
 Use the Alarms tab to set the alarm parameters for this TC point. 

Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start 

Thermocouple: General Tab 
Select Configure > I/O > TC Points > General tab.  to configure the 
basic parameters for the TC Input point.  

 
Figure 7-26. Thermocouple – General tab  
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Field Description 
Thermocouple  Sets the input to be configured. The inputs are 

listed by both number and tag.  
Note:  This selection in this field applies to each 

tab on this screen. 
Tag  Sets a 10-character string name for identification 

of the Point Number.  
Note:  This selection in this field applies to each 

tab on this screen. 
Point Number Sets the value to identify the physical location of 

the input. The Point Number identifies the module 
slot. 
Note:  This selection in this field applies to each 

tab on this screen. 
Value  If Scanning is set to Disable, enter a Value to 

override the input. When Scanning is set to 
Enable, Value displays the last TC Input scan in 
engineering units.  

Units Tag  Sets a name to display in configuration screens, 
reports and custom displays. This should be the 
same unit of measure as was chosen in the Units 
Tag field. If this field is blank, configuration 
screens, reports, and custom displays show a 
blank where the unit of measure should be.  

Scan Period  Sets the amount of time between updates of the 
Filter value. All TC Inputs are updated based on 
their individual Scan Periods. The default value is 
1 second. The minimum scan period allowed is 
100 mSec.  

Type  Sets the type of thermocouple sensor in use. For 
the values, refer to Table 7-1. Thermocouple Input 
Type values. 

Units  Sets in which engineering unit (EU) the ROC 
calculates the temperature.  

Scanning  Sets the Scanning option.  
 For the input to automatically process the field 

input, select Enabled (Automatic Mode). 
When Scanning is set to Enabled, Value 
displays the last TC Input scan in engineering 
units. 

 When Scanning is set to Disabled (Manual 
Mode), the ROC does not update the 
engineering unit (EU) Value. If Alarming is 
Enabled, an alarm generates when Scanning 
is set to Disabled. If Scanning is set to 
Disabled, enter a Value to override the input. 
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Field Description 
Active Alarms  This read-only field shows the Active Alarms 

indicating any alarms that are active for this point. 
When Alarming is set to Enabled, the limit alarms 
(such as Low Alarm and Rate Alarm) that are 
active appear. Even if Alarming is Disabled, the 
Point Fail (hardware reports a malfunction) alarm 
indicator can still appear. If Alarming is set to 
Enabled, an alarm is generated when Scanning is 
disabled.  

 
Table 7-1. Thermocouple Input Type values 

TC Input Type Accuracy/Range 25˚C −40°C to 75° C 

B 100°C to 200°C 
200°C to 390°C 
390°C to 840°C 
840°C to 1800°C 

±8°C 
±4°C 
±2°C 
±1°C 

±16°C 
±8°C 
±4°C 
±2°C 

R −50°C to 50°C 
50°C to 1720°C 

±2°C 
±1°C 

±4°C 
±2°C 

S −50°C to 50°C 
50°C to 1760°C 

±2°C 
±1°C 

±4°C 
±2°C 

C 0°C to 2315°C ±0.75°C ±1.5°C 

N −270°C to −260°C 
−260°C to −250°C 
−250°C to −230°C 
−230°C to −150°C 
−150°C to 1300°C 

±8°C 
±4°C 
±2°C 
±1°C 
±0.5°C 

±16°C 
±8°C 
±4°C 
±2°C 
±1°C 

J −210°C to 190°C 
190°C to 1200°C 

±0.75°C 
±0.5°C 

±1.5°C 
±1°C 

E −270°C to −260°C 
−260°C to −225°C 
−225°C to −200°C 

−200°C to 1000°C 

±3°C 
±1°C 
±0.75°C 
±0.5°C 

±6°C 
±2°C 
±0.5°C 
±1°C 

K −270°C to −261°C 
−260°C to −246°C 
−245°C to −180°C 
−179°C to −145°C 
−145°C to 1372°C 

±5°C 
±2°C 
±1°C 
±0.75°C 
±0.5°C 

±10°C 
±4°C 
±2°C 
±1.5°C 
±1°C 
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TC Input Type Accuracy/Range 25˚C −40°C to 75° C 

T −270°C to −261°C 
−260°C to −251°C 
−250°C to −181°C 
−180°C to −136°C 
−135°C to 400°C 

±4°C 
±2°C 
±1°C 
±0.75°C 
±0.5°C 

±8°C 
±4°C 
±2°C 
±1.5°C 
±1°C 

 

Thermocouple: Advanced Tab 
Select Configure > I/O > TC Points > Advanced tab to configure 
features, such as filtering and averaging for the selected TC Input.  

 
Figure 7-27. Thermocouple – Advanced tab  

Field Description 
Filter  Sets a value, which is a weighted sample using a 

percentage of the last value, plus a percentage of 
the new value. The entered data is the percentage 
of the last value used. The filter is calculated every 
Scan Period by the formula:  
(Last Value × Entered %) + [New Value × (100 – 
Entered %)] = Filtered Value 

Actual Scan  This read-only field shows the actual amount of 
time, in seconds, that passes between scans. This 
number should be the same as the Scan Period 
parameter if the system is not overloaded. 
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Field Description 
Average Raw 
Values  

Sets how the system averages and calculates the 
raw readings during the Scan Period and use the 
outcome as the Raw A/D Input during EU 
calculations. For example: When Enabled, a TC 
Input point configured with a Scan Period of 1.5 
seconds obtains a new value from the A/D every 
100 milliseconds. During the Scan Period, 10 
values are obtained from the A/D and summed 
together. At EU calculation, the values summed 
are divided by the Actual Scan Period display and 
are used as the Raw A/D Input. Disable this 
function to acquire instantaneous values. 

EU Offset  Sets a bias the system adds to the EU Value, 
allowing you to set a zero shift that is applied to 
the entire temperature versus voltage curve.  

Thermocouple: Alarms Tab 
Select Configure > I/O > TC Points > Alarms tab to configure the 
alarm parameters for this TC point.  

 
Figure 7-28. Thermocouple – Alarms tab  

Field Description 
Alarming  When Alarming is Enabled, the limit alarms (four 

levels, Rate, and Deadband) are configured on the 
Alarms tab. When Alarming is Disabled, no limit 
alarms generate for this point. The Point Fail alarm 
appears in the Active Alarms field, but will not be 
logged in the Alarms Log.  
To conserve Alarm Log space, alarms should be 
enabled only when necessary. Even if you do not 
plan to use all the alarms, check and adjust the 
value of each one so that no false alarms 
generate. 
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Field Description 
RBX  If the host computer is configured to receive field-

initiated calls, you can select a Report-by-
Exception (RBX) option to send a Spontaneous-
Report-by-Exception (SRBX) message.  
 On Alarm Set – When the point enters an 

alarm condition, the ROC generates a RBX 
message. 

 On Alarm Clear – When the point leaves an 
alarm condition, the ROC generates a RBX 
message. 

Note:  RBX Alarming requires the communications 
port to be properly configured. 

HiHi Alarm  Sets, in engineering units, a value to which the 
input value must rise to generate a HiHi Alarm.  
Note:  The HiHi Alarm value is typically set higher 

than the High Alarm. 
High Alarm  Sets, in engineering units, a value to which the 

input value must rise to generate a High Alarm.  
Low Alarm  Sets, in engineering units, a limit value to which 

the input value must fall to generate a Low Alarm.  
LoLo Alarm  Sets, in engineering units, a limit value to which 

the input value must fall to generate a LoLo 
Alarm.  
Note:  The LoLo Alarm value is typically set lower 

than the Low Alarm. 
Rate Alarm  Sets the value, in engineering units, that 

represents the maximum amount of change 
allowed between updates. If the change is equal 
to, or greater than this value, an alarm is 
generated. To disable this Rate Alarm without 
disabling the other alarms, the Rate Alarm value 
must be set greater than the Span (Range) of the 
TC Input.  

Alarm Deadband  Sets the value, in engineering units, is an inactive 
zone above the Low Alarm and below the High 
Alarm. The purpose of the Alarm Deadband is to 
prevent the alarm from being set and cleared 
continuously when the input value is oscillating 
around the alarm limit. This also prevents the 
Alarm Log from being filled with nuisance alarm 
trips. 

7.1.8 Resistance Temperature Detector (RTD) Input Configuration 
RTD Inputs are analog signals generated by RTD (Resistance 
Temperature Detector) probes, a device to measure temperature.  
Select Configure > I/O > RTD Points. Examine the default settings 
and adjust the parameters to suit your application on each of the tabs in 
the order given below. 
 The General tab sets the basic parameters for the RTD Input 

point. 
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 The Advanced tab enables you to configure features, such as 
filtering, A/D conversions, and clipping for the selected RTD 
Input. 

 The RTD Calibration tab is available on-line for calibration of 
the RTD point. 

 The Alarms tab sets the alarm parameters for this RTD point. 
 

Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start.  

RTD: General Tab 
Select Configure > I/O > RTD Points > General tab to configure the 
basic parameters for the RTD Input point.  

  
Figure 7-29. RTD – General tab  

Field Description 
RTD Inputs  Sets the input to be configured. The inputs are 

listed by both number and tag.  
Note:  This selection applies to each tab on this 

screen. 
Tag  Sets a 10-character string Tag for identification of 

the point number. Any alphanumeric characters, 
including spaces, may be used.  
Note:  This selection applies to each tab on this 

screen. 
Point Number  The read-only field identifies the physical location 

of the input. The Point Number identifies the 
module slot – channel number.  
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Field Description 
Value  If Scanning is set to Disabled, enter a Value to 

override the RTD Input. When Scanning is set to 
Enabled, Value displays the last RTD Input scan 
in engineering unit. 

Units Tag  Sets a name to display in configuration screens, 
reports and custom displays. This should be the 
same unit of measure as was chosen in the Units 
field. If this field is blank, configuration screens, 
reports, and custom displays show a blank where 
the unit of measure should be. 

Scan Period  Sets the Scan Period as the amount of time 
between updates of the Filter value. All RTD 
Inputs are updated based on their individual Scan 
Periods. The default value is 1 second. The 
minimum scan period allowed is 64 mSec. 
ROCLINK 800 will not allow a value less than 64 
mSec in this field. The scan occurs in multiples of 
64 mSec, such as if you enter 0.20 sec, it will scan 
every 0.192 sec. 

Low Reading EU  Sets the value corresponding to a 0% input.  

High Reading EU  Sets the value corresponding to a 100% input.  

Units  Sets the engineering units (EU) in which the ROC 
calculates the temperature.  

Scanning  Sets the Scanning option.  
 For the input to automatically process the field 

input, select Enabled (Automatic Mode). 
When Scanning is set to Enabled, Value 
displays the last RTD Input scan in 
engineering units. 

 When Scanning is set to Disabled (Manual 
Mode), the engineering unit (EU) Value is no 
longer updated by the ROC. If Alarming is 
Enabled, an alarm generates when Scanning 
is set to Disabled. If Scanning is set to 
Disabled, enter a Value to override the input. 

Active Alarms  This read-only field shows the Active Alarms 
indicating any alarms that are active for this point. 
When Alarming is set to Enabled, the limit alarms 
(such as Low Alarm and Rate Alarm) that are 
active appear. Even if Alarming is Disabled, the 
Point Fail (hardware reports a malfunction) alarm 
indicator can still appear. If Alarming is set to 
Enabled, an alarm is generated when Scanning is 
Disabled. 

RTD: Advanced Tab 
Select Configure > I/O > RTD Points > Advanced tab to configure 
features, such as filtering, A/D conversions, and clipping for the 
selected RTD Input.  
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Figure 7-30. RTD – Advanced tab  

Field Description 
Filter  Sets a value, which is a weighted sample using a 

percentage of the last value, plus a percentage of 
the new value. The entered data is the percentage 
of the last value used. The filter is calculated every 
scan period by the formula:  
(Last Value × Entered %) + (New Value × (100 – 
Entered %)) = Filtered Value 

Adjusted A/D 0 %  This read-only field shows the calibrated Analog-
to-Digital (A/D) reading corresponding to zero 
percent input. In the Calibrate function, this value 
is changed to set the zero percent input exactly at 
the Low Reading EU value to eliminate transmitter 
and system errors. 

Adjusted A / D 100 
%  

This read-only field shows the calibrated A/D 
reading corresponding to 100 percent input. This 
value is used to convert the input to engineering 
units. In the Calibrate function, this value is 
changed to set the 100 percent input exactly at the 
High Reading EU value. 

Raw A/D Input  This read-only field shows the Raw A/D Input 
displaying the current reading directly from the 
Analog-to-Digital converter.  

Actual Scan  This read-only field shows the actual amount of 
time in seconds that passes between scans. This 
number should be the same as shown for the 
Scan Period parameter, if the system is not 
overloaded. 
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Field Description 
Average Raw Value  Sets the ROC to average and calculate the raw 

readings during the Scan Period and use the 
outcome as the Raw A/D Input during EU 
calculations. For example, when enabled, an RTD 
Input point configured with a Scan Period of 1.0 
seconds obtains a new value from the A/D every 
50 milliseconds. During the Scan Period, 20 
values are obtained from the A/D and summed 
together. At EU calculation, the values summed 
are divided by the Actual Scan Period display and 
are used as the Raw A/D Input. Disable this 
function to acquire instantaneous values.  

RTD Alpha  Sets the RTD Alpha of the RTD being used 
(0.00385 or 0.00392).  

Clipping  Sets the ROC to force the Filtered EUs to stay 
within the range defined by the cut off limits. Set 
the cut off limits by using the LoLo Alarm and HiHi 
Alarm parameters.  

Zero Shift  Sets a value if necessary to compensate for the 
zero shift effect on an input.  

RTD: RTD Calibration Tab 
Select Configure > I/O > RTD Points > RTD Calibration tab to select 
an RTD point to verify and calibrate.  

Note:  You can calibrate inputs at up to five points: zero, span, and up 
to three mid-points. You define at least and points for calibration. 

The calibration routine provides Verify, Calibrate, and Zero Shift 
functions for RTD inputs. You can calibrate differential pressure 
(orifice metering may be High or Low Differential Pressure, depending 
on the device), static pressure, or temperature readings for each meter 
run. 

Notes: 
 During calibration, the ROC times out and resumes Normal 

processing if it is left idle for an extended period. Calibration values 
are restored to the previous values, an event is logged, and you must 
reconnect to start calibration from the beginning. 

 Click Cancel to exit the calibration without saving the changes. The 
system retains previous calibration settings and logs an event.  
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Figure 7-31. RTD – RTD Calibration tab  

Field Description 
Freeze Values  These read-only fields show the value received 

from the analog input, DVS, HART, MVS, RTD or 
Meter inputs when the Update button was last 
clicked. The system uses these values in ongoing 
processing (such as flow calculations, history 
logging, or control) while calibration occurs. 

Verify  Click to start the verification process.  

Calibrate  Click to begin calibration and open the Set Zero 
dialog opens.  

Zero 
Shift/Offset/RTD 
Bias 

Click to set adjustment factors for the input. The 
value is sent to the device for:   

 Zero Shift Click to zeros the static pressure 
effect for the differential 
pressure input (Set Offset). 

 Offset Click to send the value of the 
live reading to set the reading as 
close to zero as possible for a 
static pressure inputs (Measured 
Pressure Reading). 

 RTD Bias Click to calibrate the offset (shift) 
of temperature throughout the 
RTD curve (Temperature 
Standard Reading). 

Auto Scan/Stop 
Scan  

Click to automatically request values each second 
from the meter. The request continues until you 
click Freeze.  

Update  Click to request a value update from the input to 
be used as the Freeze Values.  

 
Verifying an  Use this process to verify if an RTD is within the correct operating 
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RTD Input temperature limits. If the value is incorrect, calibrate the input.  
 

   
Figure 7-32. RTD Input Calibration  

1. Click Update to request one value update from the input. 

Note:  The Freeze Value field displays the value received from the 
RTD input when you last clicked Update. 

2. Disconnect the RTD sensor and connect a decade box (or comparable 
equipment) to the RTD terminals of the device. 

Note: You can also use a pocket current source or another 
deadweight test input source to test this value. 

3. Click Verify. A Verify dialog displays. 
4. Complete the Dead Weight/Tester Value field with a value against 

which the test equipment verifies. 
5. When you enter a value in the Dead Weight/Tester Value field, 

ROCLINK immediately begins comparing it to the value in the Live 
Reading field (obtained from the temperature probe) and calculating 
the percentage deviation between the two values. 

6. Click Log Verify. ROCLINK 800 completes the first log entry on the 
screen.  
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Figure 7-33. Verify   

Field Description 
Action Indicates the current action. Valid values are 

Verify or Calibrate. 
Actual Displays the value in the Live Reading field. 

Expected Displays the value in the Dead Weight/Tester 
Value field. 

Deviation Displays the amount of deviation between the 
actual and expected values. 

% Deviation Displays a percentage deviation between the 
Actual and Expected values. 

 
7. As the live reading value changes, click Log Verify as many times as 

necessary to establish the verification log. 
8. Typically you verify the same points you calibrate. Temperature might 

be an example (– 100, 200, 50). For each test point, you set your test 
equipment to produce the expected value, enter that expected value in 
the Tester Value field, wait for live input to stabilize, and then click 
Log Verify. You can verify as many points as you want. 

9. Click Done. 
10. Calibrate the input. 

 
Calibrating an  

RTD Input 
Use this process to calibrate an RTD.  

1. Select Configure > I/O > RTD Points > RTD Calibration tab. 
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2. Select an RTD input. 
3. Select the RTD Calibration tab. 

  
Figure 7-2. RTD Input Calibration  

4. Click Update to request one value update from the input. 

Note:  The Freeze Value field displays the value received from the 
RTD input when you last clicked Update. 

5. Disconnect the RTD sensor and connect a decade box (or comparable 
equipment) to the RTD terminals of the ROC 

Note:  You can also use a pocket current source or another 
deadweight test input source to test this value. 

6. Click Calibrate. A Set Zero screen displays. 
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Figure 7-35. Set Zero  

Note:  You can click Cancel to exit the calibration without saving 
the changes. The system retains the previous calibration 
settings but logs the event in the event log. 

7. Set test equipment to produce the expected results. 
8. Complete the Dead Weight/Tester Value field. This value represents 

the low range (0%) of the instrument’s measurement range. 
9. When you enter a value in the Dead Weight/Tester Value field, 

ROCLINK immediately begins comparing it once each second to the 
value in the Live Reading field (obtained from the static pressure 
sensor) and calculating the percentage deviation between the two 
values. 

10. Click Set Zero when the live reading stabilizes. ROCLINK 800 adds 
the first line in the calibration log, renames the screen to Set Span, 
and changes the label on the Set Zero button to Set Span. 
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Figure 7-36. Set Span  

11. Set test equipment to produce the expected results. 
12. Complete the Dead Weight/Tester Value field with a value 

represents the upper limit (100% or "span") of the instrument’s 
measurement range. 

Note: ROCLINK 800 provides 350 as a default span value. Edit 
this default as necessary. 

13. When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once each second to the 
value in the Live Reading field (obtained from the static pressure 
sensor) and calculating the percentage deviation between the two 
values. 

14. Click Set Span when the live reading stabilizes. ROCLINK 800 adds 
the next line in the calibration log, renames the screen, and changes 
the label on the Span button to Set Mid 1. 

Note: You can click Done at this point to complete the calibration 
or continue the calibration and define up to three calibration 
midpoints. 

15. Set test equipment to produce the expected results. 
16. Complete the Dead Weight/Tester Value field with the first 

midpoint calibration value (which in this example represents 50% of 
the instrument’s range). 

Note: ROCLINK 800 provides the previous midpoint value as a 
default value. Edit this default as necessary. 
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Figure 7-37. Set Midpoint 1  

17. When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once per second to the 
value in the Live Reading field (obtained from the static pressure 
sensor) and calculating the percentage deviation between the two 
values. 

18. Click Set Mid 1 when the live value stabilizes. ROCLINK 800 adds 
the next line in the calibration log, renames the screen, and changes 
the label on the Set Mid 1 button to Set Mid 2. 
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Figure 7-38. Set Midpoint 2 

Note: To define up to two more midpoints, repeat steps the 
previous steps. 

19. Click Done when you have sufficient calibration information. The 
Meter Calibration screen displays. 

Note: Following a calibration, you may re-run a verification to 
demonstrate to the customer that the measurement results are 
now within contractual parameters. 

RTD: Alarms Tab 
Select Configure > I/O > RTD Points > Alarms tab to configure the 
alarm parameters for this RTD point.  
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Figure 7-39. RTD – Alarms tab  

Field Description 
Alarming  Sets Alarming, the limit alarms (four levels, Rate, 

and Deadband) are configured on the Alarms tab. 
When Alarming is Disabled, no limit alarms 
generate for this point. The Point Fail alarm 
appears in the Active Alarms field, but will not be 
logged in the Alarms Log.  
To conserve log space, alarms should be enabled 
only when necessary. Even if you do not plan to 
use all the alarms, check and adjust the value of 
each one so that no false alarms generate. 

RBX Alarming  If you configure the host computer to receive field-
initiated calls, select a Report-by-Exception (RBX) 
option to send a Spontaneous-Report-by-
Exception message.  
 On Alarm Set – When the point enters an 

alarm condition, the ROC generates a RBX 
message. 

 On Alarm Clear – When the point leaves an 
alarm condition, the ROC generates a RBX 
message. 

Note:  RBX Alarming requires you to properly 
configure the communications. 

HiHi Alarm  Sets, in engineering units, a value to which the 
input value must rise to generate a HiHi Alarm.  
Note:  The HiHi Alarm value is typically set higher 

than the High Alarm. 
High Alarm  Sets, in engineering units, a value to which the 

input value must rise to generate a High Alarm.  
Low Alarm  Sets, in engineering units, a limit value to which 

the input value must fall to generate a Low Alarm.  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

7-62 Configure Menu Revised February 2024 

Field Description 
LoLo Alarm  Sets, in engineering units, a limit value to which 

the input value must fall to generate a LoLo 
Alarm.  
Note:  The LoLo Alarm value is typically set lower 

than the Low Alarm. 
Rate Alarm  Sets the value, in engineering units, that 

represents the maximum amount of change 
allowed between updates. If the change is equal to 
or greater than this value, an alarm generates. To 
disable this Rate Alarm without disabling the other 
alarms, the Rate Alarm value can be set greater 
than the Span of the analog input. 

Alarm Deadband  Sets the value, in engineering units, that is an 
inactive zone above the Low Alarm limits and 
below the High Alarm limits. The purpose of the 
Alarm Deadband is to prevent the alarm from 
being set and cleared continuously when the input 
value is oscillating around the alarm limit. This 
also prevents the Alarm Log from being over-filled 
with data. 

7.1.9 System Analog Input (AI) Configuration  
Select Configure > I/O > System AI Points. System analog inputs are 
analog signals generated by sources within the ROC. 
Select Configure > I/O > System AI Points General tab sets the basic 
parameters for the AI Input point. Examine the default settings and 
adjust the parameters to suit your application on each of the tabs. 
 The Advanced tab enables you to configure features, such as 

filtering, averaging, and clipping for the selected Input. 
 The Alarms tab sets the alarm parameters for this AI point. 

 
Save 

Configuration 
After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start.  
 

System AI: General Tab 
Select Configure > I/O > System AI Points > General tab to configure 
the basic parameters for the AI Input point.  
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Figure 7-40. System AI – General tab  

Field Description 
Analog Inputs  The ROC800-Series has five system analog 

inputs:  
 System AI #1 = Battery. 
 System AI #2 = Charge Voltage. 
 System AI #3 = Module Voltage. 
 System AI #4 = AI Default. 
 System AI #5 = Board Temperature. 
Note:  This selection in this field applies to each 

tab on this screen. 
Tag  Sets a 10-character name for identification of the 

point.  
Note:  This selection in this field applies to each 

tab on this screen. 
Point Number  Because this type of input has no physical 

location, the read-only portion of the Point 
Number refers to module location 0. The read-
only portion that refers to channel number is 1 to 
5 for the input numbers. 

Value  Sets a value to override the input if Scanning is set 
to Disabled. When Scanning is set to Enable, 
Value displays the last analog input scan in 
engineering units (EU). 

Units  Sets the Units value. Inputs #1, #2, and #3 are in 
Volts. Input #5 is in Degree C.  

Scan Period  Sets the amount of time between updates of the 
Filter value. The default value is 1 second. All 
System analog inputs are updated based on their 
individual Scan Periods. 

Low Reading EU  Sets the engineering unit corresponding to zero 
percent input.  

High Reading EU  Sets the engineering unit corresponding to 100 
percent input.  
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Field Description 
EU Value Units  Set the system AI units to be read and written in 

volts, millivolts, degree F, degree C, degree K, or 
Degree R.  

Scanning  Sets the Scanning option.  
 For the input to automatically process the field 

input, select Enabled (Automatic Mode). 
When Scanning is set to Enabled, Value 
displays the last System AI scan in 
engineering units. 

 When Scanning is set to Disabled (Manual 
Mode), the engineering unit (EU) Value is no 
longer updated by the ROC If Alarming is 
Enabled, an alarm generates when Scanning 
is set to Disabled. If Scanning is set to 
Disabled, enter a Value to override the input. 

Active Alarms  This read-only field any alarms that are active for 
this point. When Alarming is set to Enabled, the 
limit alarms (such as Low Alarm and Rate Alarm) 
that are active appear. Even if Alarming is 
Disabled, the Point Fail (hardware reports a 
malfunction) alarm indicator can still appear. If 
Alarming is set to Enabled, an alarm is generated 
when Scanning is Disabled. 

System AI: Advanced Tab  
Select Configure > I/O > System AI Points > Advanced tab to 
configure features, such as filtering, averaging, and clipping for the 
selected Input.  

 
Figure 7-41. System AI – Advanced tab  
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Field Description 
Filter  Sets a value, which is a weighted sample using a 

percentage of the last value plus a percentage of 
the new value. The entered data is the percentage 
of the last value used. The Filter is calculated 
every Scan Period by the formula:  
(Last Value × Entered %) + (New Value × (100 – 
Entered %)) = Filtered Value 

Adjusted AD 0 %  Sets the calibrated Analog-to-Digital (A/D) reading 
corresponding to zero percent input.  

Adjusted AD 100 %  Sets the calibrated A/D reading corresponding to 
100 percent input.  

Raw A/D Input  This read-only field shows the current reading 
directly from the Analog-to-Digital converter.  

Actual Scan  This read-only field shows the actual amount of 
time, in seconds, that passes between scans. This 
number should be the same as the Scan Period 
parameter if the system is not overloaded. 

Average Raw 
Values  

Sets the values to average and calculate the raw 
readings during the Scan Period and use the 
outcome as the Raw A/D Input during EU 
calculations. For example, when enabled, an 
analog input point configured with a Scan Period 
of 5 seconds obtains a new value from the A/D 
every second. During the Scan Period, five values 
are obtained from the A/D and summed together. 
At EU calculation, the values summed are divided 
by the number of samples and are used as the 
Raw A/D Input. Disable this function to acquire 
instantaneous values. 

Clipping  If enabled, the software forces the Filtered EUs to 
stay within the range defined by the cut off limits. 
Select the cut off limits by using the LoLo Alarm 
and HiHi Alarm parameters. 

System AI: Alarms Tab  
Select Configure > I/O > System AI Points > Alarms tab to configure 
the alarm parameters for this AI point.  
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Figure 7-42. System AI – Alarms tab  

Field Description 
Alarming  Sets Alarming for the point. If you Enable 

Alarming, the limit alarms (four levels, Rate, and 
Deadband) are configured on the Alarms tab. If 
you Disable Alarming, no limit alarms generate for 
this point. The Point Fail alarm appears in the 
Active Alarms field, but will not be logged in the 
Alarms Log.  
To conserve Alarm Log space, alarms should be 
enabled only when necessary. Even if you do not 
plan to use all the alarms, check and adjust the 
value of each one so that no false alarms 
generate. 

RBX Alarming If the host computer is configured to receive field-
initiated calls, you can select a Report-by-
Exception (RBX) option to send a Spontaneous-
Report-by-Exception (SRBX) message.  
 On Alarm Set – When the point enters an 

alarm condition, the ROC generates a RBX 
message. 

 On Alarm Clear – When the point leaves an 
alarm condition, the ROC generates a RBX 
message. 

Note:  RBX Alarming requires the 
communications port to be properly 
configured. 

HiHi Alarm  Sets, in engineering units, a value to which the 
input value must rise to generate a HiHi Alarm.  
Note:  The HiHi Alarm value is typically set higher 

than the High Alarm. 
High Alarm  Sets, in engineering units, a value to which the 

input value must rise to generate a High Alarm.  
Low Alarm  Sets, in engineering units, a limit value to which 

the input value must fall to generate a Low Alarm.  
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Field Description 
LoLo Alarm  Sets, in engineering units, a limit value to which 

the input value must fall to generate a LoLo 
Alarm.  
Note:  The LoLo Alarm value is typically set lower 

than the Low Alarm. 
Rate Alarm  Sets the value, in engineering units, that 

represents the maximum amount of change 
allowed between updates. If the change is equal to 
or greater than this value, an alarm is generated. 
To disable this Rate Alarm without disabling the 
other alarms, the Rate Alarm value can be set 
greater than the Span of the analog input. 

Alarm Deadband  Sets the value, in engineering units, that is an 
inactive zone above the Low Alarm limits and 
below the High Alarm limits. The purpose of the 
Alarm Deadband is to prevent the alarm from 
being set and cleared continuously when the input 
value is oscillating around the alarm limit. This 
also prevents the Alarm Log from being over-filled 
with data. 

7.1.10 Soft Points 
Softpoints are global data storage areas that any ROC application can 
use. A softpoint may store the results of a specified calculation from an 
FST or an intermediate result of a specified value an FST acquires. 
Softpoints consist of a ten-character identifier (tag), one integer value 
(16-bits from 0 to 65,535), and up to 20 floating point values. The ROC 
supports up to 32 softpoints. 
Softpoints consist of:  
 1 tag (10 character string) 
 20 floats (floating point values) 
 10 longs (32-bit) 
 10 shorts (16-bit) 
 10 bytes (8-bit) 

Select Configure > I/O > Soft Points. The Soft Point screen displays. 
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Figure 7-43. Soft Points  

Note: After you successfully configure a softpoint, access the Flags 
screen (ROC > Flags) and click Save Configuration. This saves 
a configuration (and any associated softpoints) to permanent 
memory in case you must perform a cold start. 

Field Description 
Softpoints  Sets the softpoint to configure. Click ▼ to display 

all available softpoints.  
Tag  Sets a 10-character identifier for the softpoint.  

Float and Data #1 
through #20 

Sets up to 20 parameters (Data #1 to Data #20) to 
provide storage for IEEE floating point values for 
the softpoint.  

Long  Sets long parameters to provide storage for 32-bit 
unsigned integer values.  

Short  Sets short parameters to provide storage for 16-bit 
unsigned integers.  

Byte Sets byte parameters to provide storage for 8-bit 
unsigned values. 

Double Sets up to 10 parameters (Data #1 to Data #10) to 
provide storage for double precision point values 
for the softpoint.  

Event Logging Select to enable (Enabled) logging of events for 
changes to the soft point parameters or select 
Disabled to not log Soft Point events. 
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7.1.11 Multi-Variable Sensor (MVS) Configuration  
The MVS Sensor setup screens provide you with an interface to a multi-
variable sensor, a device that measures temperature, static pressure, and 
differential pressure.   
Because of the graphical interface, you can use the Configure option on 
the ROCLINK 800 menu (Configure > I/O > MVS Sensor), click on 
the MVS module graphic, or use the configuration tree.)  

Note:  If you change a parameter on the MVS screens, click Write to 
update the sensor configuration. 

 
 Caution If you attempt to write data to a 4088 with the Security Switch in the ON 

position, ROCLINK saves the new transmitter information but is unable 
to write the new values to the transmitter. If you change the value in the 
Address field, communications fail between ROCLINK and the 
transmitter. Enter the transmitter address previously used in ROCLINK to 
regain communications. Changes made to all other fields revert to the 
values stored in the transmitter. 

MVS: General Tab 
The Multi-Variable Sensor (MVS) screens provide you with an interface 
to configure a multi-variable sensor.  

Note: If you have a dual-variable sensor (DVS) attached to the MVS 
module, you configure it as part of the MVS module.   

Select Configure > I/O > MVS Sensor. The Multi-Variable Sensor 
screen displays, showing the General tab. 

Note: You can also access this screen by clicking the TLP Browse 
button on the graphic interface’s I/O Points screen. 

If you change a parameter, click Write.  
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Figure 7-44. MVS Sensor – General tab  

Note: If you change any values on this tab – or on the Advanced, 
Calibration, or Alarms tabs – other than the MVS or Tag fields, 
you must click Write in the Sensor Configuration field to apply 
those changes to the sensor configuration.  

 
Field Description 

MVS Sensor  Sets the MVS sensor to configure. Each MVS has 
a unique address number to differentiate it from 
other MVS units, because MVS sensors can be 
multi-dropped.  

Tag  Sets the ten-character identifier that resides in the 
MVS.  
Note:  This selection in this field applies to each 

tab on this screen. 
Address  Sets the unique address for this device used in the 

device communications protocol. The default 
address is 1. If the MVS is used in the multi-drop 
mode, each MVS must have a unique address. 
Use Address 240 to poll the sensor to determine 
the address of the connected sensor. This is 
similar to polling a using Address and Group 240. 
When Address 240 is used, the sensor responds 
with its address by updating the Address field. 
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Field Description 
Voltage  This read-only field shows the voltage input to the 

sensor.  
If the MVS interface version (as shown on the 
Advanced tab’s Sensor Interface Version field) is 6 
or greater, this field should read approximately 5, 
which is the voltage to the microcontroller in the 
sensor. If the MVS interface version is less than 6, 
this field shows the input voltage to the sensor. 
Note:  For proper operation, the input voltage to 

the sensors with versions less than 6 must 
be at least 10.5 volts dc. 

Sensor 
Configuration  

Click Write to update the sensor with the current 
values on the screen or click Read to read the 
sensor’s current configuration data and process 
variables.  

Pressure / 
Temperature Values 
and Fault Values  

These read-only fields show scaled differential 
pressure readings from the sensor. The units 
display as either InH2O or kPa.  
The scaled Differential Pressure (Reverse DP) 
reading is from the sensor times a negative "1" for 
flow in the reverse direction. 
The scaled absolute Pressure (Static Pressure) 
reading from the sensor displays in either PSI or 
kPa. 
The scaled process Temperature reading from 
the sensor displays in either degrees Fahrenheit 
or degrees Celsius, based on global settings 
(ROC > Information). 
Enter Fault Values if you desire for the MVS to 
return to the values you configure upon on failure 
of the sensor, an input point, or communications.  

Scanning  Sets whether the input communicates with the 
MVS sensor. Valid values are Enabled (allow 
communications to the MVS sensor) or Disabled 
(the system does not update information from the 
sensor).  
Note:  The Scanning text field displays scanning 

status messages. Additionally, the system 
generates an alarm when you Disable 
scanning. 

Sensor Alarming  Sets the alarm conditions of the sensor or any 
alarms that are active for this point. Valid values 
are Enabled (display any active failed alarms, 
such as point fail or sensor fail) or Disabled (do 
not display alarms).  
Note:  When you enable sensor alarms, the 

system displays any loss of 
communications to the sensors by 
displaying an RS-485 Communications 
Failure. If you disable scanning, an Off 
Scan Mode alarm displays. 
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Field Description 
Active Alarms  These read-only fields indicate any alarms that 

are active for this point. If you Enable alarming, 
any active limit alarms (such as Low Alarm and 
Rate Alarm) appear. Even if you Disable alarming, 
the Point Fail (hardware reports a malfunction) 
alarm and Manual (Scanning Disabled) indicators 
can still appear  

Sensor This read-only field displays the type of MVS you are 
configuring. Valid values are MVS205, 4088A, 4088B, or 
3095. 
Note:  The value in this field applies to each tab on this 

screen 

MVS: Advanced Tab 
Use the MVS Advanced screen to configure how the ROC retains 
information on failure, what it uses as a reference temperature, and how 
it reports pressure.  
Select the Advanced tab. The Advanced screen displays. 

 
Figure 7-45. MVS Sensor – Advanced tab  

Note:  If you change any values, click Write on the General tab to save 
the configuration. 

Field Description 
Sensor Interface 
Version  

This read-only field shows the version of the 
sensor interface firmware for the sensor.  
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Field Description 
Units  Sets the engineering units for the process 

variable. If you change this value, click Write to 
update the configuration.  

Action on Failure Sets how the sensor retains values on failure of 
the sensor, an input point, or communications. 
Valid values are Hold Last Value (retains the last 
values before the failure) or Set to Fault Value 
(returns to the configured fault values).  
Note:  See the Alarms tab for the Fault Value. 

Report Pressure As  Sets the location of the static pressure tap in 
relation to the orifice and normal flow. Valid values 
are Upstream or Downstream. Upstream is the 
default. If you select Downstream, the system 
subtracts the Diff Pressure (DP) (in PSI) from the 
Static Pressure (SP) reading to obtain a 
Downstream Pressure measurement for archiving. 
For Downstream operation, adjustments to the 
calibration procedure may be required when 
setting the Span value.  
Note:  If you change this value, click Write on the 

General tab to save the configuration. 
Reference 
Temperature  

Sets a reference temperature the sensor uses 
when reporting differential pressure. The default 
value is 60 °F (15.6 °C). The system uses this 
value only when you change the Units selection or 
when you select the Downstream option is 
selected in Metric units.  
Note:  If you change this value, click Write on the 

General tab to save the configuration. 
Zero Shift  Sets a value if necessary to compensate for the 

zero shift effect on an input.  

MVS: Calibration Tab 
Use this tab to calibrate the MVS points.  

Notes: 
 You can calibrate sensors at up to five points: zero, span, and up to 

three mid-points. You must define at least zero and span points for 
calibration. 

 During calibration, the ROC times out and resumes Normal 
processing if it is left idle for an extended period. Calibration values 
are restored to the previous values, an event is logged, and you must 
reconnect to start calibration from the beginning. 

 Click Cancel to exit the calibration without saving the changes. The 
previous calibration settings are retained. An Event is also logged. 
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 Caution If you have an MVS transmitter, refer to Chapter 6, Sensor/Transmitter 
Accessories, in the ROC/FloBoss Accessories Instruction Manual (Form 
A4637) for the recommended way to remove or restore the device from 
or to working pressure during calibration. Failure to follow 
recommendations may damage the device.  

 

 
Figure 7-46. MVS Sensor – Calibration tab  

Field Description 
Freeze  Click to stop the system from updating analog, 

MVS, DVS, HART, or temperature (RTD) inputs 
during verification or calibration. Once you click 
Freeze, the input is frozen at the current Freeze 
Values. 

Scan Mode  This read-only field displays the current input 
status. Normal Poll indicates the system is 
functioning normally. After you click Freeze, the 
software changes to Input Freeze for the 
verification or calibration process and activates all 
buttons in the Freeze Values frame. Poll Mode is 
the initial communication to a sensor to gather all 
of the configuration data that is stored on the 
sensor. Off Scan indicates that the sensor is 
disabled. 

Diff Pressure, Static 
Pressure, 
Temperature  

These read-only fields show the values for the 
differential pressure, static pressure, and 
temperature received from the analog, MVS, or 
temperature (RTD) input. The system uses these 
values in ongoing processing (such as flow 
calculations, history logging, or control) while 
calibration occurs.  

Verify  Click to start the verification process.  
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Field Description 
Calibrate  Click to begin calibration and open the Set Zero 

dialog opens.  
Zero 
Shift/Offset/RTD 
Bias 

Click to set adjustment factors for the input. The 
value is sent to the device for:   

 Zero Shift Click to zeros the static pressure 
effect for the differential 
pressure input (Set Offset). 

 Offset Click to send the value of the 
live reading to set the reading as 
close to zero as possible for a 
static pressure inputs (Measured 
Pressure Reading). 

 RTD Bias Click to calibrate the offset (shift) 
of temperature throughout the 
RTD curve (Temperature 
Standard Reading). 

Auto Scan/Stop 
Scan  

Click to automatically request values each second 
from the meter. The request continues until you 
click Freeze.  

Update Click to request a value update from the input to 
be used as the Freeze Values.  

 
Verifying 

an MVS 
Use this process to verify an MVS is within the operating or contractual 
limits. If the value is incorrect, calibrate the input. You can verify the 
differential pressure, static pressure, and the temperature of an MVS 
sensor.  

1. Select Configure > I/O > MVS Sensor. The Multi-Variable Sensor 
screen displays. 

2. Select the Calibration tab. The Calibration screen displays. 
3. Select an MVS input point to calibrate. 
4. Click Update to request one value update from the input. 
5. Click Freeze to stop the values of the input from being updated during 

verification or calibration. 

Note: The Freeze Value field displays the value received from the 
MVS input when you last clicked Update and is the value the 
system uses in ongoing processing (such as flow calculations 
and history logging) while performing calibration. 

Review the value in the Scan Mode field. Valid values are Normal 
Poll (point scanning is enabled and is updated each scan period), 
Off Scan (the point is not in scanning mode), or Input Freeze 
(points are frozen). 

6. If you are calibrating a temperature input, disconnect the MVS or 
DVS sensor and connect a decade box (or comparable equipment) to 
the terminals of the ROC. 
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Note: You can also use a pocket current source or another 
deadweight test input source to test this value. 

7. Click Verify. A Verify dialog displays. 
8. Complete the Dead Weight/Tester Value field with a value against 

which the test equipment verifies. 
When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it to the value in the Live 
Reading field (obtained from the temperature probe) and calculating 
the percentage deviation between the two values. 

9. Click Log Verify. ROCLINK 800 completes the first log entry on the 
screen.  

  
Figure 7-47. Verify   

Field Description 
Action Indicates the current action. Valid values are 

Verify or Calibrate. 
Actual Displays the value in the Live Reading field. 

Expected Displays the value in the Dead Weight/Tester 
Value field. 

Deviation Displays the amount of deviation between the 
actual and expected values. 

% Deviation Displays a percentage deviation between the 
Actual and Expected values. 

 
10. As the live reading value changes, click Log Verify as many times as 

necessary to establish the verification log. 
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11. Typically you verify the same points you calibrate. Temperature 
might be an example (– 100, 200, 50). For each test point, you set 
your test equipment to produce the expected value, enter that 
expected value in the Tester Value field, wait for live input to 
stabilize, and then click Log Verify. You can verify as many points 
as you want. 

12. Click Done. 
13. Calibrate the input if required. 

Field Description 
Point  Identifies the point (differential pressure, static 

pressure, or temperature) being verified.  
Action - Verify 
Fields  

Shows the activity being performed as well as 
various values:  
 Actual – Displays the current Live Reading 

value from the sensor. 
 Expected – Displays the expected value as 

entered in the Dead Weight/Tester Value 
field. 

 Deviation – Displays the difference between 
the expected value and the actual value. 
(Deviation = Expected – Actual.)  

 % Deviation – Displays a percentage 
deviation between the Actual and Expected 
values. 

Note:  Click Log Verify to add lines to this screen. 
Dead Weight/Tester 
Value  

Sets the expected value against which the system 
tests and calibrates.  
Note:  This is the Expected value in the Action 

field.  
Live Reading with 
Offset applied 

This read-only field shows the current reading 
from the sensor. If you have configured an offset, 
the value appears in the Offset applied field.  

Deviation and % 
Deviation  

This read-only field shows the deviation between 
the Actual and Expected values, such as the 
difference between the live pressure or 
temperature reading and the measured pressure 
or temperature reading.  
(%Deviation = Deviation [(Span EU – Zero EU) x 
100%]). Use this value to determine the need for 
calibration or adjustment.  

Log Verify  Click to write the displayed data to the Event Log.  

 
Calibrating 

an MVS 
You can calibrate the differential pressure, static pressure, and 
temperature inputs of an MVS. ROCLINK allows you to perform either 
a five-point calibration on an MVS205 or 4088B or a two-point 
calibration on a 3095 or 4088A. The five-point calibration consists of 
setting the zero point, span, and up to three mid points. 
The two-point calibration process consists of setting the zero point and 
the span. To calibrate an MVS: 
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Note:   
 You cannot calibrate a 4088 if the Transmitter Security switch on 

the device is enabled. 
 The 4088 provides range checking on the input values. The 

calibration process fails if the input values deviate more than 10% 
from the expected values. 

 If you have a 4088B and click Cancel at any time during the 
calibration process, you must start the calibration process over from 
the beginning. 

1. Select Configure > I/O > MVS Sensor > Calibration tab. The MVS 
Calibration screen displays. 

 
2. Click ▼ in the MVS drop down box to select an MVS sensor to 

calibrate. 
3. Click Update to request one value update from the input. 
4. Click Freeze to stop the input values from being updated during 

verification or calibration. ROCLINK asks you if you want to create a 
calibration report file. 

Note: The Freeze Value field displays the value received from the 
MVS of DVS input when you last clicked Update and is the 
value the system uses in ongoing processing (such as flow 
calculations and history logging) while performing 
calibration. 
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5. If you click Yes, enter a file name and location to save the file, and 

click Save. The MVS screen displays with the values frozen, the Scan 
Mode field is set to Input Freeze, and the Verify and Calibrate 
buttons are activated. 

 
Figure 7-48. Input Freeze  

6. If you are calibrating a temperature input, disconnect the MVS sensor 
and connect a decade box (or comparable equipment) to the terminals 
of the device. 

Note: You can also use a pocket current source or another 
deadweight test input source to test this value. 

7. Click Calibrate in the column of the input type you want to calibrate 
(Diff Pressure, Static Pressure, Temperature). A Set Zero dialog box 
displays. 
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Figure 7-49. Set Zero Calibration 

8. Enter a value in the Dead Weight/Tester Value field. 
9. Click Set Zero to set a zero value. Note that ROCLINK 800 changes 

the screen name and button name to Set Span. 
For the Set Zero entry in the calibration log, ROCLINK 800 records 
the As Found and As Left values and calculates the Deviation and 
% Deviation values (between the Dead Weight/Tester Value and the 
Live Reading values). 

10. Enter a value in the Dead Weight/Tester Value field for the span 
and click Set Span to set a span value and record the values in the 
calibration log. 
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Figure 7-50. Set Span Calibration 

11. If you are calibrating a 3095, 4088A, or you do not wish to 
configure midpoints, click Done.  
If you are calibrating an MVS205 or 4088B and wish to configure 
midpoints, enter a value in the Dead Weight/Tester Value field and 
click click Set Mid 1 to define the first midpoint value. You can 
define up to three midpoints (typically at 25%, 50%, and 75%). Click 
Done when you finish configuring midpoints. 

 
Figure 7-51. Set Mid Points 
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12. If the calibration results indicate that you need to adjust the sensor, 
click Zero Shift/Offset/RTD Bias (depending on the point you are 
adjusting). The system displays a Set Zero (Offset) screen. 

Note: If calibration fails, check the communication wiring, entered 
values, and applied pressure. 

Field Description 
Point  Identifies the point (differential pressure, static 

pressure, or temperature) being verified. 
Calibration Fields Shows the activity being performed as well as 

various values: 
Action Indicates the current action. Valid values are Set 

Zero, Set Span, Set Mid 1, Set Mid2, or Set 
Mid3. 

As found Shows the sensor’s initial value. 

As Left Shows the sensor’s value after calibration 

Deviation Shows the difference between the As Found value 
and the As Left value. 

% Deviation Shows the difference between the As Found and 
As Left values as a percentage. 

Set Zero Calibrate the zero value (0% of range) for the in 
differential pressure (orifice only), 
static pressure, or temperature. Set the Dead 
Weight/Tester Value (in engineering 
units). This should correspond with the Low 
Reading EU (0% Count) and is the low 
value for the input. This is the input desired for the 
test value and is the actual value 
expected by the test equipment being calibrated 
against. For example: When 
calibrating temperature for an RTD input, enter the 
degree value associated with the 
resistance set up in the decade box or other 
equipment. 

Set Span Calibrate the span value (100% of range) for 
differential pressure (orifice only), static 
pressure, or temperature. Set the Dead 
Weight/Tester Value (in engineering units). 
This should correspond with the High Reading EU 
(100% Count) and is the high 
value to the input (the top end of the expected 
operating range). 
For static pressure on an absolute-pressure 
device, remember to add in the actual 
atmospheric pressure, for example, 300 + 14.73. 
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Field Description 
Set Midpoints If desired, calibrate midpoint 1 (such as 25% of 

range) for the differential pressure 
(orifice only), static pressure, or temperature, 
otherwise click the Done button. 
Midpoints allow you to specify the low, middle, and 
high calibration point between the 
zero and span endpoints. Set the Dead 
Weight/Tester Value (in engineering units). 
If desired, calibrate Midpoint 2 (such as 50% of 
range) for the Differential Pressure 
(orifice only), Static Pressure, or Temperature. Set 
Midpoint 2 allows you to specify 
the middle calibration point between the Zero and 
Span endpoints. 
If desired, calibrate Midpoint 3 (such as 75% of 
range) for the Differential Pressure 
(orifice only), Static Pressure, or Temperature. Set 
Midpoint 3 allows you to specify a 
third point between the Zero and Span endpoints. 

 
Note:  You can calibrate Midpoints in any order 

from low to high or high to low. 
  

Sending the Differential 
Pressure Zero Shift 

(Offset) 

After you have calibrated differential pressure, click Zero Shift to zero 
the static pressure effect for the differential pressure input if required.  

 
Figure 7-52. Set Zero Shift (Offset)  
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1. After you have calibrated differential pressure, click Zero Shift to 
zero the static pressure effect for the differential pressure input if 
required. 

2. Apply the typical line pressure to both the high and low side of the 
sensor. 

3. Click Set Offset to send the value to the live reading to get the reading 
as close to zero as possible. 

4. Click Done or Cancel to close the dialog. 
Sending the Static 

Pressure Offset 
Sets the Offset to send the value of the live reading to get the reading as 
close to zero as possible for a static pressure inputs.  

 
Figure 7-53. Set Zero Shift (Offset)  

5. After you have calibrated static pressure, click Offset to calibrate the 
offset (shift) of static pressure if required.  

6. Enter a value for the Measured Pressure Reading, which is the 
pressure as read from a calibrated pressure sensor. 

7. Click Set Offset to send the value to the live reading to get the reading 
as close to the measured reading as possible. 

8. Click Done to close the dialog.  
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Field Description 
Zero 
Shift/Offset/RTD 
Bias 

Click to set adjustment factors for the input. The 
value is sent to the device for:  
 Zero Shift – Zeros the static pressure effect 

for the differential pressure input (Set Offset).  
 Offset – Sends the value of the live reading to 

set the reading as close to zero as possible for 
a static pressure inputs (Measured Pressure 
Reading).  

 RTD Bias – Calibrates the offset (shift) of 
temperature throughout the RTD curve 
(Temperature Standard Reading).  

Measured Pressure 
Reading  

Sets the pressure as read from a calibrated 
pressure sensor.  
Note:  This field displays only for static pressure 

points. 
Pressure Offset  This read-only field shows the difference between 

the live pressure reading and the measured 
pressure reading that ROCLINK 800 applies to the 
pressure value.  
Note:  This field displays only for static pressure 

points. 
 

Sending the Temperature 
RTD Bias 

Calibrate the offset (shift) of temperature throughout the RTD curve if 
required.  

 
Figure 7-54. Temperature RTD Bias  

1. After you have calibrated the temperature input, click RTD Bias to 
calibrate the offset (shift) of temperature throughout the RTD curve if 
required.  
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2. Enter a value for the Temperature Standard Reading, which is read 
from a calibrated temperature probe.  

3. Click Set Offset to send the value to the live reading to get the reading 
as close to the measured reading as possible. 

4. Click Done to close the dialog.  
Field Description 

Temperature 
Standard Reading  

Sets the temperature as read from a calibrated 
temperature probe.  
Note:  This field displays only for temperature 

points. 
Temperature Bias  This read-only field shows the difference between 

the live temperature reading and the entered 
standard temperature reading that ROCLINK 800 
applies to the temperature value.   
Note:  This field displays only for temperature 

points. 

MVS: Alarms Tab 
Use this tab to establish limits for differential pressure, pressure, 
temperature, and RBX alarms.  
Select the Alarms tab. The Alarms screen displays. 

 
Figure 7-55. MVS Sensor – Alarms tab  

Note: If you change any values, click Write to save the configuration. 
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Field Description 
Enabled/Disabled  Sets whether, for the particular input, alarms are 

active. Valid values are Enabled (configure alarms 
using the set parameters) or Disabled (do not 
generate an alarm, regardless of configuration). 
The system logs alarms to the alarm log. To 
conserve log space, enable alarms only when 
necessary.  
Note:  If you disable an alarm, the system does 

not generate an alarm for this point, 
regardless of the alarm configuration. 
Alarm statuses display in the read-only 
Status field on the General tab.  

Low Alarm  Sets, in engineering units, a limit value to which 
the input value must fall to generate a Low Alarm.  

High Alarm  Sets, in engineering units, a value to which the 
input value must rise to generate a High Alarm.  

Alarm Deadband  Sets, in engineering units, an inactive zone above 
the Low Alarm limits and below the High Alarm 
limits. The Alarm Deadband prevents the alarm 
from being set and cleared continuously when the 
input value is oscillating around the alarm limit. 
This prevents the Alarm Log from being over-filled 
with data. 

Fault Value  Sets the point’s value on failure. If a point fails and 
you have previously set the value on the 
Advanced tab’s Action on Failure field to Set to 
Fault Value, the system uses the value entered in 
this field as the EU value for that point. 
Note:  Fault Values are only used in Modify Limits. 

Sensor RBX 
Alarming 

Sets the Spontaneous-Report-by-Exception 
(SRBX or RBX) alarming for this point. Valid 
values are:  
 On Alarm Set – Generates an RBX message 

to the host when the point enters an alarm 
condition. 

 On Alarm Clear – Generates an RBX 
message to the host when the point leaves an 
alarm condition. 

7.1.12 HART Input Configuration 
The Highway Addressable Remote Transmitter (HART®) module 
enables the ROC800-Series to process input from field-based HART 
devices. Depending on your need, you can configure the HART module 
either as an analog input or analog output.    

Series 1/Series 2 
HART Modules 

An earlier version (“Series 1”) of the HART module is still in use. 
Switches on the Series 1 module’s printed circuit board enable you to 
manually select analog input or output configurations. Series 2 HART 
modules use a software-selectable switch. Refer to the ROC800-Series 
HART® Module technical specifications (ROC800:HART) for specific 
physical and operational differences. As appropriate, this section notes 
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any differences for the Series 1 HART module. 
1. Select Configure > I/O > HART Points. The HART screen displays, 

showing the General tab by default.   

 
2. The HART screen can have as many as eight tabs. Use each tab to 

configure a component of the module’s operation.  
3. The General and Advanced tabs set parameters for the channel. Each 

HART module can support up to four channels. 
4. The Calibration tab enables you to calibrate the HART analog input. 
5. The Device tabs (1 through 5) set parameters specific to the devices in 

that channel. When you configure the module in analog output mode, 
each channel can support one device. When you configure the module 
in analog input mode, each channel can support up to five devices. 

Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start.  

HART: General Tab  
Select Configure > I/O > HART Points. The HART screen displays 
with the General tab active. Use this tab to configure parameters for the 
channel.  
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Figure 7-56. HART AI – General tab  

 
Figure 7-57. HART AO – General tab  
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Field Description 
Point Number Identifies the channel and its physical location. 

The first number indicates the total number of 
installed HART points (based on the sum of all 
installed HART modules) in the ROC. The last two 
numbers indicate the point’s location on a specific 
HART module. Click ▼ to display all available 
HART points. 
For example, 1 – 1-1 indicates the first point 
located on the HART module placed in slot #1 in 
the ROC chassis. 6 – 2-2 indicates the sixth HART 
point, located on the HART module placed in slot 
#2 in the ROC chassis.  
Note:  This selection in this field applies to each 

tab on this screen. 
Channel Version This read-only field shows the version of firmware 

present in the HART module for this channel.  
Note:  This field displays only if you have a Series 

1 HART module installed.  
Comm Status This read-only field shows the status of the 

communications channel. Scanning indicates the 
channel is currently scanning the device(s). Not 
Scanning indicates the device is currently off-line 
or not communicating. Dual Master indicates that 
the channel has another master connected.  
Examples of other masters include a Hand-Held 
Communicator and a device that is configured to 
be in Burst mode. When in Dual Master, the ROC 
is not scanning the device, which allows 
communications between the other master and the 
devices. When the hand-held communicator 
finishes communicating with the HART device (or 
Burst mode was turned off in the device), normal 
HART module scanning automatically resumes. 
Note:  The HART module does not support Burst 

mode. The device should not be configured 
in Burst mode when connected to the ROC 
If a device is in Burst mode, use a hand-
held communicator to turn off Burst mode. 

I/O Type Click ▼ to configure the HART module as an 
analog input or analog output.  
Note:  The Series 1 HART module requires you to 

manually change switches on the module 
itself. Refer to Chapter 4 in the ROC800-
Series Remote Operations Controller 
Instruction Guide (A6175).  
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Field Description 
Communication 
Mode 

Sets the communication mode for the point. Valid 
values are:   

 Disabled Stop all HART communication; no 
changes occur unless you manually 
enter them. 

 Point to 
Point 

Enables the channel to 
communication with one HART 
device per channel and the analog 
signal is still representative of the 
measured variable. 

 Multidrop Enables the channel to 
communications with the specified 
number of devices (maximum of five) 
that you connect to each channel in 
parallel. Each HART device in multi-
drop mode requires 4mA and does 
not represent any measured variable 
value. With all four channels in 
multidrop mode, the ROC800 can 
support a maximum of twenty HART 
devices. The ROC superimposes 
digital communications on the analog 
signal that you use for powering the 
HART devices. 
Note:  Multidrop is not a valid option 

if you select Analog Output 
as an I/O Type.  

Master Mode Sets sequencing to ensure that two masters can 
communicate with one slave device. Primary 
indicates that this HART point has priority in 
communications; any point set to Secondary must 
wait until the Primary communication has 
completed.  

EU Value Sets the engineering units value of the analog 
input or analog output.   
Note:  This field does not display if you select 

Analog Output as the I/O Type.  
Low Reading EU Sets the value in engineering units that 

corresponds to zero percent input.  
High Reading EU Sets the value in engineering units that 

corresponds to 100 percent input.  
Units Tag Provides a 10-character descriptor for the 

engineering units.  
Note:  This field does not display if you select 

Analog Output as the I/O Type. 
Analog Scanning Sets analog scanning options. Valid values are 

Enabled (automatically process the field input) 
and Disabled (stop processing the field input).  
Note:  This field displays only if you select 

Analog Input as the I/O Type. 
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Field Description 
Output Mode Identifies where the system obtains the output 

value. Valid values are Auto (system uses the 
value in the Auto Value field of the Output Value 
frame), Manual (system uses the value in the 
Manual Value field of the Output Value frame), or 
Disabled (system does not use a value).   
Note:  This field displays only if you select 

Analog Output as the I/O Type. 
250 Ohm 
Termination 
Resistor 

Indicates whether the software activates a 250Ω 
termination resistor for the HART module. Valid 
only for the Series 2 HART module.  
Note:  This field displays only if you select 

Analog Input as the I/O Type.   
Output Values Sets the actual output value the system uses, 

based on the setting in the Output Mode field. The 
system uses the value you enter in the Auto 
Value field if you also select Auto in the Output 
Mode field. The system uses the value you enter 
in the Manual Value field if you also select 
Manual in the Output Mode field. The Physical 
Value field is a read-only field that displays the 
actual value being sent.  
Note:  This field displays only if you select 

Analog Output as the I/O Type. 
Alarming Sets alarming on the channel. Select Enabled to 

activate alarming or Disabled to prevent alarming. 
Disabled is the default.  

AI High Alarm Sets the high point for the channel alarm.  

AI Low Alarm  Sets the low point for the channel alarm.  

AI Alarm Deadband Sets a deadband for the channel alarm.  

Active Alarm This read-only field shows any active alarms.  

HART: Advanced Tab 
Select Configure > I/O > HART Points> Advanced tab to configure 
parameters for the channel. Each HART module supports up to four 
channels.  
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Figure 7-58. HART – Advanced tab  

Field Description 
Adjusted A/D 0% or 
Adjusted D/A 0% 

Sets a value to adjust the calibrated Analog-to-
Digital (for AIs) or Digital-to-Analog (for AOs) 
reading to zero percent input. In the Calibrate 
function, this value is altered to set the zero 
percent input exactly at the Low Reading EU value 
to eliminate transmitter and system errors.  
Note:  This is a read-only field for the Series 1 

HART module.  
Adjusted A/D 100% 
or  
Adjusted D/A 100%  

Sets a value to adjust the calibrated Analog-to-
Digital (for AIs) or Digital-to-Analog (for AOs) 
reading corresponding to 100 percent input. This 
system uses this value to convert the input to 
engineering units. In the Calibrate function, this 
value is altered to set the 100 percent input 
exactly at the High Reading EU value.  
Note:  This is a read-only field for the Series 1 

HART module.  
Raw A/D or D/A 
Input 

This read-only field shows the current reading 
directly from the Analog-to-Digital (for AIs) or 
Digital-to-Analog (for AOs) converter.  

Analog Output EU 
Value on Reset 

Indicates the value the system uses on reset. 
When you select Retain Last Value, use the last 
EU value for the channel after a reset or a warm 
start. If you select Use Failsafe Value, enter a 
value to use after a reset or warm start.  
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Field Description 
Pass Through Sets how communications pass from a host device 

through the ROC and on to the HART devices. 
The communications must be in ROC Plus 
protocol (typically for Opcode 120 requests). Valid 
values are Disabled (no pass through occurs), 
Enabled – Strip (strip all preamble bytes in HART 
protocol) or Enabled – Don’t (leave the entire 
message intact).  
For the Series 1 HART Module, the Timeout field 
enables you to enter, in milliseconds, the amount 
of time the system pauses between the end of the 
pass through communication and the restarting of 
polling of the HART device.  

HART: Calibration Tab 
Select Configure > I/O > HART Points > Calibration tab to calibrate 
a HART channel that is acting as an analog input  HART inputs support 
a two-point calibration routine.   

Note: You can access and run Calibration only when the channel is in 
Point to Point mode or the device poll mode is Skip This 
Device.  

 
Figure 7-59. HART – Calibration tab  

Field Description 
Freeze Value  This read-only field shows the value received 

from inputs when the Update button was last 
clicked. The system uses these values in ongoing 
processing (such as flow calculations, history 
logging, or control) while calibration occurs.  

Calibrate  Click to begin calibration and displays the Set Zero 
dialog. 
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Calibrating a  
HART Input 

Use this process to calibrate an HART that is outside the temperature 
limits.  

1. Select a HART Point Number to calibrate. 
2. Verify that the Communication Mode on the General tab is set to 

Point-to-Point. 
3. Click the Device tab and verify that the Poll Mode is set to Skip This 

Device. 
4. Click the Calibration tab. 

 

Figure 7-60. HART Input Calibration  

5. Click Calibrate. A Set Zero screen displays. 
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Figure 7-61. Set Zero  

Note:  You can click Cancel to exit the calibration without saving the 
changes. The system retains the previous calibration settings but 
logs the event in the event log. 

6. Complete the Dead Weight/Tester Value field. This value represents 
the low range (0%) of the instrument’s measurement range. 
When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once each second to 
the value in the Live Reading field (obtained from the static 
pressure sensor) and calculating the percentage deviation between 
the two values. 

7. Click Set Zero when the live reading stabilizes. ROCLINK 800 adds 
the first line in the calibration log, renames the screen to Set Span, 
and changes the label on the Set Zero button to Set Span. 
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Figure 7-62. Set Span  

8. Set test equipment to produce the expected results. 
9. Complete the Dead Weight/Tester Value field with a value 

represents the upper limit (100% or "span") of the instrument’s 
measurement range.  
When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once each second to 
the value in the Live Reading field (obtained from the static 
pressure sensor) and calculating the percentage deviation between 
the two values. 
For the Set Zero entry in the calibration log, ROCLINK 800 records 
the As Found and As Left values and calculates the Deviation and 
% Deviation values (between the Dead Weight/Tester Value and 
the Live Reading values). 

10. Click Set Span when the live reading stabilizes. 
11. Click Done. 
When the Calibration tab displays, the calibration routine is complete. 

Note:  Following a calibration, you may re-run a verification to 
demonstrate to the customer that the measurement results are 
now within contractual parameters. 

HART: Device Tab 
Select Configure > I/O > HART Points > Device tabs to configure 
parameters specific to the devices in that channel. Each channel in 
analog output mode can support one device. Each channel in analog 
input mode can support up to five devices.  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

7-98 Configure Menu Revised February 2024 

If you select Point to Point as the communications mode on the 
General tab, the Device 1 tab presents device information. If you select 
Multidrop as the communications mode, each Device tab corresponds 
to the HART Tag (Point Number) defined for the ROC to poll. 

 
Figure 7-63. HART – Device tab  

Field Description 
Poll Mode Sets the polling behavior for this device. Valid 

values are:  
 Skip this 

Device 
Removes this device from the polling 
sequence 

 PV Only Poll only the Primary Variable value.  

 Process 
Variables 

Poll values for all of the Process 
Variables (primary, secondary, tertiary, 
and quaternary). 

 Dynamic 
Variables 

Poll only the values for the four Slot 
Variables. 

 Update Updates the device's static 
information. Static information includes 
transmitter ranges, units, tag, 
descriptor, PV limits, and ranges. 

Process Variables 
on Failure 

Sets the values to use after a failure if you have 
set the value in the In Use Selection frame to Live 
Value. Valid values are:   

 Retain Last 
Value 

Use the last values for the process 
variables. 

 Use Failsafe 
Value 

Use the value entered as the 
Failsafe Value.  

 Use 
Download PV 

Use the value entered in the 
Download PV field in the Extended 
Parameters frame; the other 
process values use their failsafe 
values.   



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Configure Menu 7-99 

Field Description 
Actual Scan Period This read-only field shows the actual amount of 

time in seconds that passes between scans.  
Current (mA) This read-only field shows the current, in 

milliamps, reported by the device.  
% of Range This read-only field shows the percentage of the 

range currently being reported by the device.  
Status This read-only field shows the state of the device. 

This field displays either No Device, 
Communicating, or Comm Error.  

Device Status This read-only field shows the response status 
code from the device. Refer to the documentation 
from the transmitter manufacturer for more 
information.  

ID Number This read-only field shows a 3-byte globally 
unique address of the device.  

Active Alarms This read-only field shows any alarms that are 
being sent from the device. These are not entered 
in the Alarm Log.  

Descriptor Provides up to 16 alphanumeric characters of 
information (in addition to the device Tag) to more 
specifically describe the device.  

Message Defines a message (up to 32 alphanumeric 
characters in length) sent to and stored in the 
device.  

PV This read-only field shows the value of the 
Primary Process Variable.  

PV Fail Safe Sets the value to use as the Primary Variable, 
after a failure if you select Use Failsafe Value in 
the Process Variables on Failure frame.   

SV This read-only field shows the value of the 
Secondary Process Variable.  

SV Fail Safe Sets the value to use as the Secondary Variable 
after a failure if you select Use Failsafe Value in 
the Process Variables on Failure frame.   

TV This read-only field shows the value of the 
Tertiary Process Variable.  

TV Fail Safe Sets the value to use as the Tertiary Variable after 
a failure if you select Use Failsafe Value in the 
Process Variables on Failure frame.   

QV This read-only field shows the value of the 
Quaternary Process Variable.  

QV Fail Safe Sets the value to use as the Quaternary Variable 
after a failure if you select Use Failsafe Value in 
the Dynamic Variables on Failure frame.  .  

Tag Sets the name for the HART device to identify it 
throughout the configuration. The tag should be 10 
characters or less. When in Multidrop mode, the 
tag must be unique for every device.  
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Field Description 
Poll Address This read-only field shows the address used for 

this HART device. In Point to Point mode, the Poll 
Address is 0. In Multidrop mode, the system uses 
addresses between 1 and 5.  

Device ID This read-only field shows the coded ID that 
reflects the manufacturer of the device, the device 
type, and the device ID.  

PV Sensor Serial 
Number 

This read-only field shows the serial number of 
the sensor.  

PV Upper Sensor 
Limit 

This read-only field shows the upper limit on the 
sensor.  

PV Lower Sensor 
Limit 

This read-only field shows the lower limit on the 
sensor.  

Sensor Units This read-only field shows the units of measure 
for the upper and lower sensor limits.  

Slot Assignment  
(0 through 3) 

Sets the value (0, 1, 2, or 3) to determine which 
variable in that slot to request.  

Slot Value  
(0 through 3) 

These read-only fields show the value (0, 1, 2 or 
3) of the variable requested from that slot. The 
read-only units defined in the device displays to 
the right of this field.  

PV Damping Value This read-only field shows the damping value 
reported by the device for the Primary Variable.  

PV Range Units This read-only field shows the units of measure 
for the analog output minimum span and upper 
and lower range limits.  

PV Upper Range 
Limit 

This read-only field shows the maximum value in 
the analog output range.  

PV Lower Range 
Limit 

This read-only field shows the minimum value in 
the analog output range.  

PV Minimum Span This read-only field shows the minimum sensor 
span.  

Alarming Activates alarms for this device. Valid values are 
Enabled (active alarms) or Disabled (prevent 
alarms for this device). The default is Disabled.  

High Alarm Sets a high value limit for alarms for this device.  

Low Alarm Sets a low value limit for alarms for this device.  

Alarm Deadband Sets a deadband 

Active Alarm This read-only field shows any current alarms for 
this device.  

In Use Selection Indicates the value the system uses for the 
primary value while in operation. Valid values are:  

 Live Value Use the value from the device. If 
device fails, use value specified in 
PV Fail Safe field.   

 Failsafe 
Value 

Sets PV value to the value entered 
in the PV Fail Safe field.  
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Field Description 
 Download 

Value 
Sets PV value to the value entered 
in the Download PV field.  

Download PV Sets a specific value the system uses if you select 
Use Download PV in the Dynamic Variables on 
Failure frame.  

Live PV This read-only field shows the live primary 
variable for the device.  

In Use Status This read-only field shows the current In-use 
settings.  

7.1.13 Advanced Pulse Module (APM) Configuration 
The optional Advanced Pulse Module (APM) for the ROC800-Series 
allows you to implement pulse-based I/O calculations and control for 
applications. The APM detects and counts pulses with advanced 
customizable pulse I/O.  
You can configure the APM to function as: 
 Simple four-point pulse input. 
 Advanced pulse input or densitometer with API checking. 
 Pulse output. 
 Interface with third-party proving applications. 

Custom APM Modes 
Many configurations of the APM are possible. You can use the APM to 
provide generic pulse input, pulse output, densitometer support, and 
turbine meter support.  

Pulse Inputs You can configure up to four generic pulse inputs on channels 1 through 
4. When APM is used as a generic four pulse input module, API fidelity 
checking is not available. The pulse inputs are read-only, non-resettable 
pulse accumulation counters. 

Pulse Outputs APM can support one pulse output on channel 4 (PI-4/PO) that 
represents the current flow as a frequency or as a pulse per engineering 
unit of accumulated product. A hardware switch configures this channel 
and the status (PI or PO) displays in the Configuration fields. You can 
configure the pulse output to support the indication of total by an 
external counter using API integrity checking Level D. 

Densitometer APM supports densitometer frequency inputs (Solartron models) on 
channel 3 that provides a frequency in the range of 0 to 10 KHz as a 
pulse input. 

API Standards APM also supports dual pulse chronometry for use in small volume 
provers. You can select API levels A through E and Marker Pulse for 
pulse integrity checking. API alarms occur if any of the API level 
checking has failed, such as a phase alarm or same channel alarm. 
ROCLINK also supports Marker Pulses. API standards are in 
accordance with the American Petroleum Institute Manual of Petroleum 
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Measurement Standards Chapter 5.5, August 1987. 

Note: Level D checking requires a mechanical counter be present. 

Pulse Counting 
between Detector 

Switch Trips 

You can configure pulse counts to occur on a single pulse input and not 
on a pair of pulses. If communication is lost during a prove, the proving 
application is notified of this condition to signify that the pulse 
accumulations are invalid. 

Master Meter Provers APM supports master meter provers in that the APM can accept a 
software detector switch simulation to start and stop pulse counting. 
APM accumulates whole pulses between the software detector switch 
triggers for both the meter being proved and the master meter. 

Note: While pulse interpolation is not required for the master meter 
proving, interpolated pulses are always provided. 

Detector Switches APM support two detector switches that gate the accumulation of pulses 
during a prove. APM recognizes a detector switch trigger at any change 
in state of a detector switch. APM starts the accumulation of whole 
pulses between detector switches at the first detector switch transition 
and stops the accumulation at the second detector switch transition. 
APM implements a detector switch filter time so as to not misinterpret 
"noise" after a detector switch transition as another transition. The APM 
displays the pulse counts and the interpolated pulse counts. 
Examples of APM configurations include:  

  Ch 1 Ch 2 Ch 3 Ch 4 Detector 1 & 2 
Config 1 PI PI PI PI Always Present 
Config 2 PI PI PI PO Always Present 
Config 3 PI PI Densitometer Input PI Always Present 
Config 4 PI PI Densitometer Input PO Always Present 
Config 5 PI PI API Pair 2 –  –  

– Ch 1 and Ch 2 Ch 3 Ch 4 Detector 1 & 2 
Config 6 API Pair 1 PI PI Always Present 
Config 7 API Pair 1 Densitometer Input PI Always Present 
Config 8 API Pair 1 Densitometer Input PO Always Present 

– Ch 1 and Ch 2 Ch 3 and Ch 4 Detector 1 & 2 
Config 9 API Pair 1 API Pair 2 Always Present 

 
APM Switches The Advanced Pulse Module has several switches you can set for 

specific actions.   
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Figure 7-64. APM Switches  

Table 7-2. APM Hardware Switches 

Switch Number Left/Right 
Side 1  Channel Channel Switch 

Position 1  
S1 –  1 = Standard PI –  Up 

S1 –  1 = Densitometer –  Down 

S2 Left 1 = In 2  1 = Out 3  Up 
S2 Right 2 = In 2 = Out Up 

S3 4  Left 3 = In 3 = Out Up 
S3 Right 4 = In 4 = Out Up 
S4 Left Detector switch 2 = In Detector switch 2 = Out Up 
S4 Right Detector switch 1 = In Detector switch 1 = Out Up 
S5 Left 4 = Pulse Output –  Up 

S5 Left 4 = Pulse Input –  Down 

S5 5  Right –  –  –  
1 Descriptors (up/down/right/left) assume that module terminal blocks face upward and daughter board is 
visible. 
2 In = Pull-up resistor is in the circuit. 
3 Out = Pull-up resistor is not in the circuit. 
4 If S1 is down, this switch is non-functional. 
5 Right side of switch 5 currently not used. 

 

APM: Pulse Input Tab 
Select Configure > I/O > Advanced Pulse Module. The Pulse Input 
tag displays by default. Use this tab to configure the pulse input 
parameters for the Advanced Pulse Module point. You can configure up 
to four generic pulse inputs on channels 1 through 4. API fidelity 
checking is not available when you use the APM as a generic four pulse 
input module.  

S4 

S3 

S2 

S1 

S5 
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You can configure the module as a two point pulse input for two pulse 
pairs. The pulse inputs are read-only, non-resettable pulse accumulation 
counters. 
APM supports a Micro Motion (formerly Solartron) densitometer on 
channel 3 that provides a frequency in the range of 0 to 10 KHz as a 
pulse input. 
The four pulse input channels have a number of applications. When 
used with dual pulse turbine meters, then you can use the APM to create 
two API 5.5, level B, C, D, and E compliant pairs, while Level (Pair) 
also supports API Level A. Both levels support marker pulses. 
Channel 3 can provide the hardware filtering to support the frequency 
input from a Micro Motion (formerly Solartron) 7835/7845 
densitometer. This hardware filtering is switched into channel 3 by a 
hardware switch located on the module. 
Channel 4 can be designated as either a pulse input or a pulse output.  
The pulse input can support up to 5-kilohertz inputs. When connected as 
pulse inputs, the APM module processes the PI signals from pulse-
generating devices and provides a calculated rate and an accumulated 
pulse total. The PI is most commonly used to interface to relays or open 
collector/open drain type solid-state devices. 
The pulse input can interface to either self-powered or ROC-powered 
devices with signals up to 5 kilohertz. With the pull-up resistor "in," the 
PI supports externally powered open collector and open drain devices as 
well as externally powered contact closure devices. If the pull-up 
resistor is "out," then pulse inputs supports 0 to 3 volts dc through 0 to 
12 Volts dc sourced square wave input signals. Refer to Table 7-2. APM 
Hardware Switches.  
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Figure 7-65. APM – Pulse Input tab  

Note: This screen displays various fields based on the options you 
select. Consequently, it is not possible for one screen image to 
display all options.  

Field Description 
Point Number  Sets the Advanced Pulse Module Point Number to 

configure.  
Note:  This selection applies to each tab on this 

screen.   
Tag  Sets a 10-character alphanumeric identifier for 

each point.  
Note:  This selection applies to each tab on this 

screen.  
Pulse Info (Pulse Input 1 through Pulse Input 4)  

Tag  Sets a 20-character identifier for the pulse input 
being configured.  

Raw Pulse Count  This read-only field shows the raw number of 
pulses.  

Frequency  This read-only field shows, in hertz, the frequency 
of incoming pulses.  

Scan Period  Sets the time period, in seconds, in which the 
system evaluations the parameters associated 
with the pulse input.  

Configuration  This read-only field shows the configuration 
(Pulse Input or Pulse Output) of the terminal for 
channel 4.  
Note:  For the APM to function as a pulse output 

on channel 4, you must manually set the 
S3 switch. Refer to Table 7-2. APM 
Hardware Switches. 
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Field Description 
Pulse Security 
Level (Pair 1 and 2) 

The APM supports different field devices based on 
various hardware switch settings. You can “pair” 
pulse inputs for use with API 5.5 compliant Pulsed 
Data Fidelity and Integrity algorithms. Pulse Input 
1 and Pulse Input 2 share the Pulse Fidelity Level 
(Pair 1) configuration. Likewise, Pulse Input 3 and 
Pulse Input 4 share the Pulse Fidelity Level (Pair 
2) configuration.  
Options for pulse fidelity checking (integrity 
security) are Level A through Level E for Level 
(Pair 1) and Level B through Level E for Level 
(Pair 2). API standards are in accordance with the 
American Petroleum Institute Manual of Petroleum 
Measurement Standards Chapter 5.5, August 
1987. Both levels also support Marker Pulse 
options for Pulse Fidelity. 

Level A This level of fidelity checking requires a dual pulse 
train and two Pulse Inputs. Level A performs 
continuous monitoring, detection, and corrections 
of errors as it compares one pulse train against 
the other. Continuous comparison of the pulse 
trains for missing pulses as well as simultaneous 
pulses occurs. In the event of missing pulses, the 
system simulates the missing pulses and adds 
them to the pulse accumulations. The system 
detects simultaneous interfering pulses but does 
not include them toward the total pulse count. If 
you enable alarming, the same channel alarm 
count increments in the event of missing pulses, 
the phase alarm count increments in the event of 
simultaneous pulses, and the total alarm count 
increments in both cases. You can use the alarm 
threshold to set a lower frequency limit below 
which alarms based on these bad pulses do not 
generate. 

Level B This level of fidelity checking requires a dual pulse 
train. Two pulse inputs enable Level B to perform 
continuous monitoring, detecting, and warning of 
errors (alarming), as it compares one pulse train 
against the other. Continuous comparison of the 
pulse trains for the number, frequency, phase, and 
sequence occur. Level B security provides 
warning of transients and other spurious 
influences and protection against functional errors 
and failures. Simultaneous interfering pulses are 
detected and indicated. If the pulses delivered are 
lost or gained on either channel (PI1/PI2 or 
PI3/PI4), a differential counter API warning occurs. 
Refer to the discussion of the Alarms tab. If the 
frequency of the pulses falls below 101 Hz, the 
APM defaults to a simulated Level C until the 
frequency increases above 111 Hz. 
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Field Description 
Level C This level of fidelity checking requires a dual pulse 

train. Two pulse inputs enable Level C to 
automatically detect and warn when errors occur, 
as it compares one pulse train against the other at 
approximately one-second intervals. Comparison 
of the pulse trains occurs automatically but not 
continuously. Level C security provides protection 
against functional errors and failures. If the pulses 
delivered become numerically out of step, a 
differential counter API warning occurs. Refer to 
the discussion of the Alarms tab. 

Level D This level of fidelity checking uses only a single 
pulse train and requires only one pulse input. 
Level D allows manual detection of errors, as the 
results of the pulse train calculations are 
compared by an operator against a mechanical 
readout (user supplied) at specified intervals. The 
manual error monitoring is at specified intervals by 
methods of comparison and provides amplification 
and frequency limiting, pulse shaping, and 
common mode inference rejection. The readout is 
visually checked against an independent totalizing 
system. Level D security provides protection 
against functional errors and failures. 

Level E This level of fidelity checking uses only a single 
pulse train and individual pulses using one pulse 
input. Level E is a straightforward totalizer system. 
The pulses are counted, but the system does not 
perform error detection; integrity depends solely 
on the quality of the equipment. Level E provides 
amplification and frequency limiting, pulse 
shaping, and common mode inference rejection. 
The system does not provide built-in provisions for 
error monitoring. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

7-108 Configure Menu Revised February 2024 

Field Description 
Marker Pulse This level of fidelity checking adds an option to the 

level checking for each pair, Check Pulse 
Verification. When set, the first pulse input of the 
pair is the standard pulse input and the second 
input of the pair is the check pulse input. You 
configure the check pulse as a configurable 
number of standard pulses, on a repeating basis. 
There are two additional accumulators, the first is 
an accumulation of standard pulses that updates 
at the time the system receives the check pulse. 
For example, if the system receives the check 
pulse every 500 pulses, this accumulator updates 
to 500, 1000, 1500, and so forth. The second 
accumulator is the difference between the 
expected standard pulses at the check pulse and 
the actual number. For example, if the system 
receives the check pulse every 500 pulses and the 
system receives the check pulse at 499, this 
accumulator would read –1. If the system receives 
the next pulse at 1002, it would then read 2. 
An alarm bit is available and set when the 
difference between the expected and actual 
standard pulses exceeds a user configured 
deadband. You can also trigger a reset, resetting 
the two accumulators and restarting the check 
pulse verification upon the first check pulse the 
system receives. 

Pulse Fidelity The Level options you select define which of the 
following fields display.  

Total Accum Pair  
(1 and 2) 

This read-only field shows the accumulated 
number of pulses (forward and backward) through 
the API level checks for pulse pair 1 and 2.  
Note:  This field displays only when you select 

Level A, B, or C for pair 1 or 2.  
Frequency Pair 

(1 and 2) 
This read-only field shows, in pulses/second, the 
frequency of incoming pulses on Pair 1 or Pair 2. 
These values assume the API level is set the 
same for both pairs under the Pulse Security 
frame.   

 Pulse 
Security 

2-Pulse  
Inputs 

4-Pulse  
Inputs 

 Level A 2000 Hz N/A 

 Level B 4000 Hz 2000 Hz 

 Level C 8000 Hz 4500 Hz 

 Level D/E 9000 Hz 5500 Hz 

 Note:  This field displays only when you select 
Level A, B, or C for pair 1 or 2. 

Forward Accum 
Pair (1 and 2) 

This read-only field shows the accumulated 
number of forward pulses through the API level 
checks for pulse pair 1 and 2.  
Note:  This field displays only when you select 

Level B or C for pair 1 or 2.    
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Field Description 
Reverse Accum  

Pair (1 and 2) 
This read-only field shows the accumulated 
number of reverse pulses through the API level 
checks for pulse pair 1 and 2.  
Note:  This field displays only when you select 

Level B or C for pair 1 or 2.  
Bad Pulse Counter This read-only field shows the number of bad 

pulse pairs the system receives before setting the 
API Pair 1 alarm status when using API Level A. 
Note:  This field displays only when you select 

Level A for pair 1.  
Alarm Threshold Sets the number of bad pulse pairs the system 

can receive before setting the API Pair 1 alarm 
status when using API Level A. 
Note:  This field displays only when you select 

Level A for pair 1.  
Reset Threshold Sets the number of good pulse pairs the system 

can receive before clearing the API Pair 1 alarm 
status.  
Note:  This field displays only when you select 

Level A for pair 1.  
Alarm Inhibit 

Frequency 
Sets a frequency below which the pair 1 alarm 
status no longer sets. Existing alarms clear either 
if you select Reset Alarm Count in the Action 
Below Alarm Inhibit Frequency frame or if the 
number of good pulse pairs the system receives 
falls below the good pulse threshold for Pair 1.   
Note:  This field displays only when you select 

Level A.  
Action Below Alarm 

Inhibit Frequency 
Indicates whether the number of bad pulse pairs 
contributing towards the Pair 1 bad pulse 
threshold and the existing alarm bits clear when 
the frequency falls below the low frequency cutoff 
for pair 1. Valid values are Retain Alarm Count 
(does not clear the alarm) and Reset Alarm 
Count (clears the alarms). 
Note:  This field displays only when you select 

Level A.  
Flow Pulses per 

Marker Pulse 
(Pair 1 and 2) 

Sets the number of flow pulses to expect between 
each marker pulse. The default is 1000.  
Note:  This field displays only when you select 

Marker Pulse for pair 1 or 2.  
Alarm Pulse 

Deadband 
Sets the deviation of flow pulses from expected 
pulses at a marker pulse that must occur before 
the system triggers the Marker Pulse alarm. The 
default is 5.   
Note:  This field displays only when you select 

Marker Pulse for pair 1 or 2.  
Flow Pulse Accum 

at Marker Pulse 
This read-only field shows the accumulation of 
flow pulses, updated whenever the system 
receives a marker pulse.  
Note:  This field displays only when you select 

Marker Pulse for pair 1 or 2.  
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Field Description 
Flow Pulses Drift 

from Expected 
This read-only field shows the drift from expected 
flow pulse value, updated whenever the system 
receives a marker pulse.  
Note:  This field displays only when you select 

Marker Pulse for pair 1 or 2. 
Reset Marker Pulse 

Values 
Click to reset the flow pulse accumulation and flow 
pulse drift for pair 1 or pair 2. Applies only when 
using Marker Pulse level checking. 
Note:  This button displays only when you select 

Marker Pulse for pair 1 or 2.  
Flow Direction (Pair 
1 and 2) 

This read-only field shows the direction of flow. 
Direction of flow is based on 180 degrees out of 
phase for the first and second pair of pulses. 
Forward indicates less than 180 degrees; Reverse 
indicates more than 180 degrees. The Forward 
and Reverse designators assume 90 degrees out-
of-phase.  
Note:  This field displays only if you select Level B 

for pair 1 or 2.  

APM: Pulse Output Tab 
Select Configure > I/O > Advanced Pulse Module > Pulse Output 
tab to configure the pulse output parameters for the APM point. The 
output signal occurs by switching a NPN transistor. The transistor 
output can also be an open collector or have the pull-up resistor 
included with a switch. This transistor can provide up to a 300 hertz 
signal, switching up to 200 milliamps at maximum of a nominal 24 
Volts dc.  
APM supports one pulse output on channel 4 (PI-4/PO) representing the 
current input flow rate as a frequency or as a pulse per engineering unit 
of accumulated product. A hardware switch configures this channel and 
the status (PI or PO) displays in the Configuration fields. 

Note: For the APM to function as a pulse output on channel 4, the S3 
switch on the APM module must be manually set with the pull-
up out. Refer to Table 7-2. APM Hardware Switches.  

You can configure the pulse output to support the indication of total by 
an external counter using API integrity checking Level D. 
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Figure 7-66 APM – Pulse Output tab  

Field Description 
PI-4 Configuration This read-only field shows the configuration of the 

PI-4/PO terminal of the APM. A hardware switch 
configures this value.  
Note:  For the module to support a pulse output 

on channel 4, you must manually set the 
left S5 switch in the up position. Refer to 
Table 7-2. APM Hardware Switches. 

PO Scan Period  Sets, in seconds, how often the firmware 
evaluates the inputs to determine how many 
pulses to send out. All other output pulses are at a 
50% duty cycle.  

PO Input TLP  Sets the value of the input TLP. The value is 
depends on you configure the PO Input mode (as 
a rate or an accumulation). Click the TLP button to 
set the input to be used in calculating the output 
pulses.  

PO Input Mode  Sets the interpretation of the Input TLP. Valid 
values are Rate (calculates the integrated rate by 
multiplying the time and rate to determine the 
quantity, and then by subtracting the new 
accumulated value from the old accumulated 
value to determine the pulse output value) or 
Accumulation (sets a constant accumulation 
value against which you can define a PO Scaling 
Value for adjustments, so that the old value minus 
the new value represents the accumulated change 
value or the pulse output value).  

PO Accumulator  This read-only field shows the accumulated 
number of pulses sent out.  
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Field Description 
PO Scaling Value  Sets the value the system applies to the 

accumulated pulse value based on the value in the 
PO Input Mode field.  

PO Max Frequency  Sets the maximum number of pulses per second 
that can be output by the pulse output (in Hz). If 
the calculated number of pulses exceeds this 
value, those pulses are placed in the buffer. For 
example, if you set the PO Max Frequency to 20, 
no more than 20 pulses are sent out within the 
Scan Period time.  

APM: Prover Data Tab 
Select Configure > I/O > Advanced Pulse Module > Prover Data tab 
to configure the proving related parameters so the ROC can interface 
with an external (user supplied) prover application.  
The APM module can accept a hardware or software detector switch 
simulation to start and stop counter pulses. APM accumulates whole 
pulses between the software detector switch triggers for meters being 
proved. Hardware detector switches are used for displacement provers 
and software detector switches are used for master meters. 
In all configurations, high-speed interrupt driven detector switch inputs 
are supported for use in proving applications. These inputs are designed 
for use with normally closed contact relays, drives with interrupt-based 
close-to-open solid-state switch transitions, and other two-state devices. 
You can wire the detector input channels with individually wired 
detector switches or detector switches that are wired in series from the 
prover on the same cable. 
APM supports detector switch inputs that gate the accumulation of 
pulses during a prove. APM recognizes a detector switch trigger at any 
change in state of a detector switch. APM starts the accumulation of 
whole pulses between detector switches at the first detector switch 
transition and stops the accumulation at the second detector switch 
transition. APM implements a detector switch filter time so as to not 
misinterpret "noise" after a detector switch transition as another 
transition.  
Proving occurs on a single pulse input and not on a pair of pulses. APM 
module supports a "reset" to signal the APM module that it needs to 
clear the old totals and get ready to count pulses. If communication is 
lost during a prove, the proving application is notified of this condition 
to signify that the pulse accumulations are invalid. 

Note: The APM module always calculates the pulse interpolation value 
for the pulse between detectors. Pulse interpolation standards are 
in accordance with the American Petroleum Institute Manual of 
Petroleum Measurement Standards Chapter 4.6, May 1999. 
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During a meter proving operation, detector inputs start and stop the 
accumulated pulse counts, a positive-to-negative transition on either 
detector input generates a time-stamped interrupt with the 30-megahertz 
on-board processor. This interrupt is used in the pulse accumulation 
between the detectors as well as the pulse interpolation calculations for 
use with small volume provers. 
When a displacement prover is used, the installed prover device uses the 
detector switch pulse count to acquire the whole (full) meter count 
pulses and interpolated pulses. Pulse interpolation determines if a trip 
occurred before or after a trip per the American Petroleum Institute's 
Manual of Petroleum Measurement Standards Chapter 4 - Proving 
Systems, Section 6 - Pulse Interpolation. 

 
Figure 7-67. APM – Prover Data tab  
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Field Description 
APM DET and SW 
LEDs 

Indicates, using light-emitting diodes (LEDs) on 
the APM module, the current status for each 
channel of the module. The DET and SW LEDs 
indicate the status of the detector switches:  
 Both LEDs blink simultaneously – APM has 

no firmware resident in the module. Refer to 
Update Firmware. 

 LEDs toggle blink – APM is in the process of 
programming the flash memory. Do not 
remove the module or power down the ROC. 

 Both LEDs are solid – APM is in the process 
of erasing the flash memory. Do not remove 
the module or power down the ROC. 

 LEDs blink independently – APM is 
transmitting or receiving pulses on the 
detector switches. 

Meter Input  Sets the pulse input to use for the Meter Prove. 
Hardware detector switches are used for 
displacement provers. This is the pulse to view at 
the meter gate to acquire the count.  

Master Meter Input  Sets the pulse input to use for the Master Meter 
Prove. Select this option when you are using 
another meter to provide the pulse counts and not 
an actual displacement prover.  
Software detector switches are used for master 
meters, so the Master Meter Input is only valid if 
the S/W Det. Switch Enabled field is set to Enable. 

S/W Det Switch 
Enabled  

Sets the proving for use with a Master Meter or 
tank prover. APM supports two detector switches 
which gate the accumulation of pulses.  

Detector Switch 
Status  

This read-only field shows the current physical 
open or closed contact status of the detector 
switch. Options include Contact Open or Contact 
Closed.  

Detector Switch 
State  

This read-only field shows the current state of the 
detector switch indicating what the trip is doing:  
 Reset has been received and the APM is 

expecting a detector switch transition. 
 Counting indicates a detector switch 

transition has occurred and the APM is 
currently counting whole pulses. 

 Complete indicates another detector switch 
transition has occurred and the Prove Run is 
complete. All values will be stored until the 
next reset. The values in the Proving Pulse 
Counts frame are valid to use in calculations. 

 Invalid Data indicates the accumulator does 
not contain valid values. This can be either at 
a power up or if you lost communication during 
a prove and the accumulators have been reset 
to zero. 
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Field Description 
Detector Switch 
Filter Time  

Sets, in milliseconds, the time allotted after a 
detector switch triggers but before the next trigger 
occurs. This is a de-bounce filter for the detector 
switches to ensure that any "noise" is filtered out 
and is not read as another detector switch trigger. 
This is the maximum filter time for how long the 
trip waits before the pulses are read again.  

S/W Detector Switch Sets to start and stop the software detection 
switch from counting pulses for a Master Meter or 
tank prove. Once the APM receives a trigger, the 
APM automatically resets to idle. Click Reset 
before starting a Master Meter prove.   
Note:  Use only if the S/W Detector Switch is 

Enabled.  
Reset Button  Notifies the APM to clear values in the Proving 

Pulse Counts frame and prepare to read the trip 
counter pulses. All accumulated pulse values and 
alarms are cleared. Accumulation of whole pulses 
starts at the first detector switch transition and 
stops at the second detector switch transition.  

Meter Whole Pulse 
Counts  

This read-only field shows the actual number of 
whole pulses accumulated between detector 
switches for a Meter Input. Click Reset to clear 
this value.  

Meter Interpolated 
Pulse Counts  

This read-only field shows the actual number of 
interpolated pulses accumulated between detector 
switches for a given pulse input. Click Reset to 
clear this value.  

Master Meter Whole 
Pulse Counts  

This read-only field shows the actual number of 
whole pulses accumulated between detector 
switches for a Master Meter Input. Click Reset to 
clear this value.  

Master Meter 
Interpolated Pulse 
Counts  

This read-only field shows the actual number of 
interpolated pulses accumulated between detector 
switches for a given pulse input. Click Reset to 
clear this value.  

 
Starting a Prove for a 
Displacement Prover 

To start a prove when using a displacement prover:  

1. Select the Point Number of the Advanced Pulse Module. 
2. Select the Pulse to use in the Meter Input field. 
3. Set the Max Time for the Detector Switch Filter. 
4. Click Apply. 
5. Click Reset. 

Starting a Prove for a 
Master Meter 

To start a prove when using a master meter:  

1. Select the Point Number of the APM. 
2. Select the Pulse to use in the Master Meter Input field. 
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3. Select Enable in the S/W Det. Switch Enabled field. 
4. Set the Max Time for the Detector Switch Filter. 
5. Click Apply. 
6. Click Reset. 
7. Click S/W Detector Switch. 

APM: Alarms Tab 
Select Configure > I/O > Advanced Pulse Module > Alarms to 
configure the alarming parameters for the Advanced Pulse Module 
point.  

 
Figure 7-68. APM – Alarms tab  

Field Description 
PI Alarming Sets Alarming for this point. If Alarming is set to 

Enabled, alarms are written to the Alarm Log. 
These are the API pulse fidelity alarms when 
performing dual pulse integrity checking on a pair 
of pulses. Specifically sequenced out of order, 
phase discrepancy, pulse synchronization, 
frequency discrepancy, and pulse failure alarms. 
These alarms are all dependent on what level of 
security is being used.  
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Field Description 
PI SRBX  Sets the SRBX Alarming option to configure 

Spontaneous-Report-By-Exception (SRBX) 
alarming for this point.  
 On Set – The point enters an alarm condition, 

the ROC generates a Spontaneous-Report-by-
Exception message to the host. 

 On Clear – The point leaves an alarm 
condition, the ROC generates a Spontaneous-
Report-by-Exception message to the host. 

Note:  SRBX Alarming requires the 
communications port to be configured. 

API Alarm Status  API Level Alarm Status indicating the failure error 
for the alarm.  
Note:  These are updated in real time 

API Phase Alarm 
Count  

This read-only field shows the total number of 
phase alarms.  

API Same Channel 
Count  

This read-only field shows the total number of the 
same channel alarms.  

Pulse Output 
Alarms  

PO alarms safeguard against the loss of too many 
pulse counts. Certain devices cannot read the 
pulse counts as fast as they are produced; thus, 
loosing pulse counts. The APM module buffers 
and tracks pulse counts to ensure the pulse count 
values read are the same as the actual pulse 
counts that are output. The buffer fields enable 
you to determine how many lost pulses can occur 
before an alarm is triggered.  
When enabled, enter a value in the Buffer 
Warning Set Point field. This is the maximum 
buffered pulses allowed before the buffer warning 
alarm is triggered. The value in the Maximum 
Buffered Pulses field is the maximum buffered 
pulses allowed. If the number of pulses requested 
to send out exceeds the Maximum Number of 
Buffered Pulses an alarm occurs and you 
essentially lose any pulses greater than the value 
set in this field. 

PO Alarming  Sets Alarming for this point. If Alarming is set to 
Enabled, alarms are written to the Alarm Log. 
These alarms are for the pulse output of the APM 
and are used when the PO begins to buffer 
pulses. There are two alarms, a buffer warning 
and a buffer overflow. When the warning alarm is 
present, it indicates that the buffer is being filled 
and it has passed a user specified set point. If the 
overflow has occurred, indicates that the buffer is 
filled up and pulses are being lost.  
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Field Description 
PO SRBX  Sets the SRBX Alarming option to configure 

Spontaneous-Report-By-Exception (SRBX) 
alarming for this point.  
 On Set – The point enters an alarm condition, 

the ROC generates a Spontaneous-Report-by-
Exception message to the host. 

 On Clear – The point leaves an alarm 
condition, the ROC generates a Spontaneous-
Report-by-Exception message to the host. 

Note:  SRBX Alarming requires the 
communications port to be configured. 

PO Alarm Status  This read-only field shows the type of alarm for a 
pulse output.  

Buffer Warning Set 
Point  

Sets the maximum buffered pulses allowed before 
the buffer warning alarm is triggered. This must be 
less than the Maximum Buffered Pulses allowed.  

Maximum Buffer 
Pulses  

Sets the maximum buffered pulses allowed. If 
the number of pulses requested to send out 
exceeds the Maximum Number of Buffered Pulses 
an alarm occurs and you essentially lose any 
pulses greater than the value set in this field.  

APM Module 
Alarming  

Sets Alarming for this point. If Alarming is set to 
Enabled, alarms are written to the Alarm Log. 
These are module only alarms. In other words, 
alarms which are related to the module as a 
whole. Currently only one alarm is available, which 
is a point fail alarm. If there is a malfunction with 
the APM, specifically a loss of communication 
between the module and the device, then this 
alarm will be set.  

Module SRBX  Sets the SRBX Alarming option to configure 
Spontaneous-Report-By-Exception (SRBX) 
alarming for this point.  
 On Set – The point enters an alarm condition, 

the ROC generates a Spontaneous-Report-by-
Exception message to the host. 

 On Clear – The point leaves an alarm 
condition, the ROC generates a Spontaneous-
Report-by-Exception message to the host. 

Note:  SRBX Alarming requires the 
communications port to be configured. 

PO Alarm Status This read-only field displays the type of alarm for 
a pulse output. 

APM: EU Data Tab 
Select Configure > I/O > Advanced Pulse Module > EU data to 
configure the engineering units (EU) for each pulse input, set the 
module contract hour, and view totals. 

Note: This tab applies only to channels with Pulse Security set to Level 
E. You configure Pulse Security on the Pulse Input tab. 
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Figure 7-69. APM – EU Data tab 

 Field Description 
Contract Hour  Sets the channel on the ACIO module that you 

desire to configure.  
Note:  This selection in this field applies to each 

tab on this screen.   
Rate Period Sets how the system calculates rates. Valid values 

are: 
EU/Sec Calculation based on EU second totals. 

EU/Min Calculates based on EU minute totals. 

EU/Hour Calculation based on EU hourly totals. 

EU/Day Calculation based on EU day totals. 

 Note:  The system calculates Current Rate as 
(accumulated pulses ÷ conversion) ÷ (scan 
period x conversion to correct time). 

Pulse Input 1-4 Sets a short (20-alphanumeric characters) 
identifier for the engineering units used for each 
pulse input. 

Pulses Today This read-only field displays the total number of 
pulses that the PI has received for the contract 
day. At the end of the contract day, it zeros and 
starts over, only if being totalized in History. The 
Contract Hour is specified on this screen. 

EU Today Displays the total EU Values accumulated for the 
current contract day, calculated by multiplying the 
conversion value by the accumulated pulses. The 
system resets this value to zero at the contract 
hour. 
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 Field Description 
EU Yesterday This read-only field shows the total EU Value 

accumulated the previous contract day, calculated 
as the previous day’s Today’s Total value at the 
contract hour before being cleared. 

EU Calc Rate This read-only field shows the calculated rate as of 
the most recent scan expressed in EUs per unit of 
time. You select time units using the Rate Period 
field on the Advanced tab. The system calculates 
the rate at the end of each scan period by dividing 
the number of pulses received by the conversion 
value divided by the rate period. 

EU Conv Value Sets a conversion factor that the system divides 
the number of pulses by to determine the rate. 

7.1.14 Alternating Current I/O (ACIO) Configuration  
The Alternating Current I/O module (ACIO) enables the ROC to control 
various AC output field devices and to monitor various AC input field 
values. The ROC809 supports up to nine ACIO modules. The ROC827 
can support up to 27 ACIO modules.  
Field Description 

ACIO Channel 
Number  

Sets the channel on the ACIO module that you 
desire to configure.  
Note:  This selection in this field applies to each 

tab on this screen.   
ACIO Tag  Sets the Tag, which includes up to 10 characters 

to identify the Point being defined in the I/O 
screen. Any alphanumeric characters, including 
spaces, may be used.  
Note:  This selection in this field applies to each 

tab on this screen.   
ACIO Channel Mode  This read-only field shows the DIP switch on the 

ACIO module is positioned Output mode or Input 
mode. The ACIO module has one bank of six DIP 
switches, which controls the input/output status of 
each of the six channels.  
Placing a switch in the ON position sets the 
corresponding channel to output mode.  
Placing a switch in the OFF position sets the 
channel to input mode.  
Dual-color light-emitting diodes (LEDs) indicate 
the current status for each channel. Red means 
AC is being output. Green means AC has been 
detected on an input channel.  
Note:  This selection in this field applies to each 

tab on this screen.  
ACIO Power In  This read-only field shows if the AC power is 

currently present at the AC IN channel.  
Note:  This selection in this field applies to each 

tab on this screen.   
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ACIO (Discrete Output): General Tab 
In output mode, the module provides up to six channels for switching 
discrete AC. Each channel uses a solid-state normally open relay rated 
at 1.5 Amps. Any AC switched out is directly related to the AC 
switched in. You can configure the module as latched, toggled, 
momentary, or Timed Duration Outputs (TDOs). Other parameters 
report the approximate load, overcurrent conditions, and AC input 
status. Discrete outputs can be configured to either retain the last value 
on reset or a user-specified fail-safe value.   
Select Configure > I/O > ACIO Module > General tab to configure 
the basic properties for the Alternating Current I/O module discrete 
output.  

 
Figure 7-70. ACIO (Discrete Output) – General tab  

Field Description 
Discrete Outputs Selects the discrete output to be configured. The 

outputs are listed by both Point Number and Tag.  
Note:  This selection in this field applies to each 

tab on this screen.   
Time On  Sets, in seconds, the amount of time for 

momentary operation. The default value is 1 
second for a DO. The default value is 5 
milliseconds for an ACIO DO.  
Note:  In Momentary mode, this is the amount of 

time (in seconds) that the momentary 
contact is energized. In the Toggle mode, 
this is the time (in seconds) between 
switching On or Off. In the TDO and TDO 
Toggle modes, the TDO configuration 
calculates this value.  
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Field Description 
Auto Output  Indicates the state of the discrete output. Off 

indicates that the output is Off or that a switch is 
open; On indicates that the output is On or that a 
switch is closed.  

Manual Output  This field indicates the state of the discrete output. 
Off indicates that the output is Off or that a switch 
is open; On indicates that the output is On or that 
a switch is closed. Select On and click Apply to 
force one transition of the DO.  

Momentary  This read-only field shows the state of the 
discrete output when the DOUT Type is set to 
Momentary. Off indicates that the output is Off or 
that a switch is open; On indicates that the output 
is On or that a switch is closed.  

Physical Output  This read-only field shows the actual status of the 
output channel at the field terminations regardless 
of the DOUT Type selected.  

DOUT Type  Selects the function of this discrete output. Valid 
values are:  

 Latched Changes on an active transition 
of the output (from off to on). 
The discrete output remains On 
until cleared by selecting Off in 
the Auto Output field. 

 TDO or Time 
Duration 

Enables the discrete output to 
have a time duration between 
On and Off transitions based on 
time-related parameters 
configured in the TDO 
Parameters Tab. 

 Momentary Enables ROCLINK 800 to 
activate the discrete output for 
the amount of time defined in the 
Time On field. 

 Toggle Enables a square-wave output 
for which both the time on and 
time off are defined by the value 
in the Time On parameter. Time 
on and time off are equal. Use 
the TDO Parameters Tab to 
define time-related parameters. 

 TDO Toggle Enables the discrete output to 
continuously repeat in a cycle 
defined by the value in the 
Cycle Time field on the TDO 
Parameters Tab where the EU 
Value controls the on-time 
duration. 
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Field Description 
Scanning or 
Scanning Mode  

Sets the scanning type to configure how the DO is 
scanned. Valid values are or Auto (automatically 
process the last output scan) or Disabled (permit 
only manual updates of the output). Manual 
(manually permit a process of the last output 
scan).  
Note:  If you enable alarming, the ROC generates 

a Manual Mode alarm when scanning is 
disabled.  

 For the output to automatically process the 
field output, select Auto. 

 When Scanning Mode is set to Disabled or 
Manual, the DO is no longer updated by the 
ROC  

 When the Scanning Mode is set to Manual, 
set Manual Output to On and click Apply to 
override the output.  

 When Scanning Mode is set to Disabled, set 
Auto Output to On and click Apply to 
override the output.  

Active Alarms  This read-only field shows any active alarms for 
this point. When you Enable alarming, the limit 
alarms (such as Low Alarm and Rate Alarm) that 
are active appear. Even if you Disable alarming, 
the Point Fail (hardware reports a malfunction) 
alarm and Manual (Scanning Disabled) indicators 
can still appear.  

ACIO (Discrete Output): Advanced Tab 
Select Configure > I/O > ACIO Module > Advanced tab to configure 
the advanced properties for the Alternating Current I/O module discrete 
output.  
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Figure 7-71. ACIO (Discrete Output) – Advanced tab  

Field Description 
Output Set to Inverted or Normal to define the action of 

the discrete output value. Normal output energizes 
in Time On and Inverted output energizes in off 
time.  
Note:  Selecting Inverted inverts all outputs in any 

mode. If you set both Failsafe State and 
Inverted to On, the Failsafe State returns to 
Off on a reset. 

Action After Reset 
or Power Fail  

Sets the Action After Reset or Power Fail 
parameter to determine the value for the output 
after a reset or power failure. The DO can retain 
the last values before the reset or power failure.  
If Use Failsafe State is selected, you must specify 
whether the Auto Output or Manual Output is set 
to On or Off after a reset of the ROC, such as a 
power restart or a warm start.  

Failsafe State  Sets the Action After Reset or Power Fail 
parameter to determine the value for the output 
after a reset or power failure. The DO can retain 
the last values before the reset or power failure.  
If use Failsafe State is selected, you must specify 
whether the Auto Output or Manual Output is set 
to On or Off after a reset of the ROC, such as a 
power restart or a warm start.  

Accumulated Value Sets a value for the accumulated number of off-to-
on transitions for the discrete output. The 
accumulator is a 32-bit number with a maximum 
count of 4,294,967,295. You can preset the 
accumulator to a desire value or clear it by enter 
zero (0).  
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Field Description 
Holding Current  This read-only field shows the current 

approximate load value of the output in milliamps.  
Module Inrush Time  Sets devices you connect to the ACIO module to 

draw more than 1.5A(rms) for the number of 
seconds you specify. This parameter assumes 
60hz AC.  

Module AC 
Frequency  

Sets the frequency of the AC input to ensure the 
correct functionality of fault detection.  

Relay Status  This read-only field shows the current status of 
the output:  
 Normal – The relay is healthy. 
 Fault – A fault condition has occurred on this 

channel, the channel has been shut down and 
may not be re-enabled without first resetting 
this parameter 

 Failure – A relay failure has been detected. 
This is a physical failure. This module must be 
repaired by the factory. 

Fault Reset Click to reset the output after a fault.  

ACIO (Discrete Output): TDO Parameters Tab 
Select Configure > I/O > ACIO Module > TDO Parameters tab to 
configure the Timed Duration Output parameters for the Alternating 
Current I/O module discrete output.  

 
Figure 7-72. ACIO (Discrete Output) – TDO Parameters tab  
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Field Description 
Cycle Time  Sets, in seconds, the total amount of time the 

cycle spends in the on and off positions. The 
default is 15 seconds.  
The Cycle Time entry is used to define the OFF 
time in the TDO Toggle mode. The OFF time is 
calculated by the formula: 
 

Off Time = Cycle Time – On Time 
 
For example, a TDO is used to emulate a field 
instrument measuring flow. The TDO outputs a 
pulse width of 3 seconds for no flow and a pulse 
width of 12 seconds for 1000 MCF per day flow. 
The output is repeated every 15 seconds. 
If the Cycle Time is less than, or equal to the On 
Time, the OFF time is set to one. Care must be 
taken in configuration (including other places, such 
as FSTs) to ensure that the Cycle Time remains 
greater than the calculated On Time for proper 
operation. 

Low Reading Time  Sets the Low Reading Time (0% Count) in 
seconds that represents a zero percent output 
pulse width. The default is 3 seconds. This is the 
minimum amount of time that the TDO can be 
energized to move the motor. Set to a value that 
allows movement, but also provides good 
resolution of control.  

High Reading Time  Sets the High Reading Time (100% Count) in 
seconds that represents a 100 percent output 
pulse width. The default is 12 seconds. This is the 
maximum amount of time that the TDO can be 
energized to move the motor. Normally, this is the 
amount of time it takes for the actuator to move 
the valve from fully open to fully closed.  

Low Reading EU  Sets the engineering unit (EU) for the low reading 
to zero percent output (low end of the EU range). 
Based on the EU range determined in part by this 
parameter, the EU value is converted to a 
corresponding signal.  

High Reading EU  Sets the engineering unit (EU) for the high reading 
to 100 percent output (or high end of the EU 
range). Based on the EU range determined in part 
by this parameter, the EU value is converted to a 
corresponding signal.  

EU Value  Current value, displayed in engineering units.  
In TDO Toggle mode, the EU Value controls the 
Time On:  

On Time = ((EU Value – Low Reading EU) / 
(High Reading EU – Low Reading EU) * 
(High Time – Low Time)) + Low Time 

Units  Sets the engineering units for the discrete output 
(such as percentage, IN H2O, PSIG, MCF, 
degrees F, milliamps, and volts).  
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ACIO (Discrete Output): DO Alarms Tab 
Select Configure > I/O > ACIO Module > DO Alarms tab to 
configure the alarm properties for the Alternating Current I/O module 
discrete output.  

 
Figure 7-73. ACI (Discrete Output) – DO Alarms tab  

Field Description 
Alarming Sets the alarm option for this point. Valid values 

are Enabled (enables alarming) or Disabled 
(does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the 

Active Alarms field, but is not logged in the 
Alarms file. If you enable alarming, the 
system generates an alarm if you disable 
scanning. 

RBX Alarming  Sets the Spontaneous-Report-by-Exception 
(SRBX or RBX) alarming for this point. Valid 
values are:  
 On Alarm Set - Generates an RBX message 

to the host when the point enters an alarm 
condition. 

 On Alarm Clear - Generates an RBX 
message to the host when the point leaves an 
alarm condition. 

Note:  SRBX Alarming requires the 
communications port to be configured. 

Failure Action  Sets the action to perform upon alarm detection:  
 Shut Down Channel, Log Alarm – Shuts 

down the DO and logs an alarm event. 
 Log Alarm Only – Leaves the DO in alarm 

state and logs an alarm event. 
 No Action – No action performed upon alarm 

detection. 
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ACIO (Discrete Input): DI General Tab 
You can configure each channel as an AC input/detector. Each channel 
can detect the presence of an AC signal between 90 and 265 Vrms at 47 
to 63 Hz. In discrete input mode the module monitors the status of 
various AC sources. Each channel can also be software-configured to 
function as a latched DI, which remains in active state until reset. Other 
parameters can invert the field signal and gather statistical information 
on the number of transitions and the time accumulated in the on or off 
state. The fastest time that each channel within the module can be read 
is 50 times per second.  
Select Configure > I/O > ACIO Module > DI General tab to 
configure the basic properties for the Alternating Current I/O module 
discrete input.  

 
Figure 7-74. ACIO (Discrete Input) – DI General tab  

Field Description 
Point Number  This read-only field identifies the rack location for 

this point.  
Scan Period  Sets, in seconds, how frequently the system scans 

the input.  
Status  Sets the state of the discrete input. Valid values 

are On (indicates that a contact is closed or input 
is on) or Off (indicates that a contact is open or 
input is off).  

Physical Status  This read-only field shows the state of the 
hardware. Off normally indicates that a switch is 
open; On normally indicates that a switch is 
closed. This may be different from the Status if 
Inverting or Latching is in effect.  
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Field Description 
Scanning  Sets the scanning option for this point. Valid 

values: 
 Enabled Automatically process the field 

input. 
 Disabled Do not process the input. 

DIN Type  Sets how the DI functions. Valid values are:  

 Standard Follow the actual field input. 

 Latched Maintains the input status. For 
example, in an active transition 
from off to on, the DI remains in 
the on state until you clear the 
Status parameter either 
manually or through the 
software. 

Active Alarms  This read-only field shows any active alarms for 
this point. When you Enable alarming, the limit 
alarms (such as Low Alarm and Rate Alarm) that 
are active appear. Even if you Disable alarming, 
the Point Fail (hardware reports a malfunction) 
alarm and Manual (Scanning Disabled) indicators 
can still appear. Refer to User Interface Basics.  

ACIO (Discrete Input): DI Advanced Tab 
Select Configure > I/O > ACIO Module > DI Advanced tab to 
configure the advanced properties for the Alternating Current I/O 
module discrete input.  

 
Figure 7-75. ACIO (Discrete Input) – DI Advanced tab  
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Field Description 
Input  Sets the state of the input. Valid values are 

Normal (field input operates normally, so that On 
is On) or Inverted (inverts the field input in the 
Status field so that On becomes Off and vice-
versa).  
In the Inverted state, an open circuit in the field 
would then be indicated as On in the Status field, 
and closed contacts would be indicated as Off. 

Filter  Sets, in conjunction with the Filter Intervals field, 
the amount of time that the discrete input must 
remain in the On (high) state before the device 
recognizes it as such. Enter the Filter value as a 
valid between 0 to 255. The discrete input returns 
to the Off state immediately upon detection of the 
On to Off transition; there is no filtering for this 
transition.  

Accumulated Value  Counts the number of times the discrete input 
goes from Off to On. The accumulator is a 32-bit 
number with a maximum count of 4,294,967,295. 
You can preset the accumulator by entering the 
desired value or clear the accumulator by entering 
0.  

On Counter  Counts the number of 50-millisecond periods 
when the Status parameter is in the On state. The 
On Counter is a 32-bit number that automatically 
"rolls over" when it reaches its maximum value. 
You can preset the On Counter by entering the 
desired value or clear the counter by entering 0.  
Note:  The On Counter does not function if you 

disable scanning. 
Off Counter  Counts the number of 50-millisecond periods 

when the Status parameter is in the Off state. The 
Off Counter is a 32-bit number that automatically 
"rolls over" when it reaches its maximum value. 
You can preset the Off Counter by entering the 
desired value or clear the counter by entering 0.  
Note:  The Off Counter does not function if you 

disable scanning. 
Actual Scan  This read-only field shows the actual amount of 

time in seconds that passes between scans. This 
number should be the same as shown for the 
Scan Period parameter if the system is not 
overloaded.  

ACIO (Discrete Input): DI Alarms Tab 
Select Configure > I/O > ACIO Module > DI Alarms tab to configure 
the alarm properties for the Alternating Current I/O module discrete 
input.  
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Figure 7-76. ACIO (Discrete Input) – DI Alarms tab  

Field Description 
Alarming  Generate alarms on point status change. When 

Alarming is Disabled, the Status Change alarm 
appears in the Active Alarms field but is not written 
to the Alarm Log.  
Note:  The Point Fail alarm may appear in the 

Active Alarms field, but is not logged in the 
Alarms file. If you Enable alarming, the 
system generates an alarm if you disable 
scanning. 

RBX Alarming  Sets the Spontaneous-Report-by-Exception 
(SRBX or RBX) alarming for this point. Valid 
values are:  
 On Alarm Set – Generates an RBX message 

to the host when the point enters an alarm 
condition. 

 On Alarm Clear – Generates an RBX 
message to the host when the point leaves an 
alarm condition. 

Note:  RBX Alarming also requires the 
communications port to be properly 
configured for RBX Alarming. 

7.1.15 Virtual Discrete Output (VDO) Configuration 
Virtual DO points do not require an output to an I/O module. Virtual 
DOs are like a soft point or FST register but for a discrete on or off 
event. You configure the number of virtual DO points you desire in 
ROC > Information > Virtual DO Points field. You configure a Virtual 
DO to reference an FSTs to indicate a status without a physical I/O card 
present. Other applications include using Virtual DO with the 
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Foundation Fieldbus user program to link FF application block inputs 
and outputs to points in the ROC.  
Select Configure > I/O > Virtual DO Points. The Virtual Discrete 
Output screen displays. Examine the default settings and adjust the 
parameters to suit your application on each of the tabs. 
 Use the General tab sets the basic parameters for the DO point. 
 Use the Advanced tab enables you to configure accumulated value 

and state for reset for the selected DO. 
 Use the TDO Parameters tab allows configuration of TDO 

parameters. 
 Use the Alarms tab sets the alarm parameters for this DO point for a 

ROC800-Series.  
 

Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start.  

Virtual DO: General Tab 
The Discrete Output screen initially displays the General tab. Use this 
tab to configure the basic parameters for the DO point. Select 
Configure > I/O > DO Points.   

 
Figure 7-77. Virtual DO – General tab  

Field Description 
Discrete Outputs Selects the discrete output to be configured. The 

outputs are listed by both Point Number and Tag.  
Note:  This selection applies to each tab on this 

screen.   
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Field Description 
Tag  Sets a short (10 alphanumeric characters) 

identifier for the point.  
Note:  This selection applies to each tab on this 

screen. 
Point Number  This read-only field shows the rack location for 

this point.  
Time On  Sets, in seconds, the amount of time for 

momentary operation. The default value is 1 
second for a DO. The default value is 5 
milliseconds for an ACIO DO.  
Note:  In Momentary mode, this is the amount of 

time (in seconds) that the momentary 
contact is energized. In the Toggle mode, 
this is the time (in seconds) between 
switching On or Off. In the TDO and TDO 
Toggle modes, the TDO configuration 
calculates this value.  

Auto Output  Indicates the state of the discrete output. Off 
indicates that the output is Off or that a switch is 
open; On indicates that the output is On or that a 
switch is closed.  

Momentary  This read-only field indicates the state of the 
discrete output when the DOUT Type is set to 
Momentary. Off indicates that the output is Off or 
that a switch is open; On indicates that the output 
is On or that a switch is closed.  

Manual Output  This field indicates the state of the discrete output. 
Off indicates that the output is Off or that a switch 
is open; On indicates that the output is On or that 
a switch is closed. Select On and click Apply to 
force one transition of the DO.  

Physical Output  This read-only field indicates the actual status of 
the output channel at the field terminations 
regardless of the DOUT Type selected.  

 DOUT Type  Selects the function of this discrete output. Valid 
values are:  

 Latched Changes on an active transition 
of the output (from off to on). 
The discrete output remains On 
until cleared by selecting Off in 
the Auto Output field. 

 TDO or Time 
Duration 

Enables the discrete output to 
have a time duration between 
On and Off transitions based on 
time-related parameters 
configured in the TDO 
Parameters Tab. 

 Momentary Enables ROCLINK 800 to 
activate the discrete output for 
the amount of time defined in the 
Time On field. 
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Field Description 
 Toggle Enables a square-wave output 

for which both the time on and 
time off are defined by the value 
in the Time On parameter. Time 
on and time off are equal. Use 
the TDO Parameters Tab to 
define time-related parameters. 

 TDO Toggle Enables the discrete output to 
continuously repeat in a cycle 
defined by the value in the 
Cycle Time field on the TDO 
Parameters Tab where the EU 
Value controls the on-time 
duration. 

Scanning or 
Scanning Mode  

Sets the scanning type to configure how the DO is 
scanned. Valid values are or Auto (automatically 
process the last output scan) or Disabled (permit 
only manual updates of the output). Manual 
(manually permit a process of the last output 
scan).  
Note:  If you enable alarming, the ROC generates 

a Manual Mode alarm when scanning is 
disabled.  

 For the output to automatically process the 
field output, select Auto. 

 When Scanning Mode is set to Disabled or 
Manual, the DO is no longer updated by the 
ROC  

 When the Scanning Mode is set to Manual, 
set Manual Output to On and click Apply to 
override the output.  

 When Scanning Mode is set to Disabled, set 
Auto Output to On and click Apply to 
override the output.  

Alarming Sets the alarm option for this point. Valid values 
are Enabled (enables alarming) or Disabled 
(does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the 

Active Alarms field, but is not logged in the 
Alarms file. If you enable alarming, the 
system generates an alarm if you disable 
scanning. 

Active Alarms  This read-only field shows any active alarms for 
this point. When you Enable alarming, the limit 
alarms (such as Low Alarm and Rate Alarm) that 
are active appear. Even if you Disable alarming, 
the Point Fail (hardware reports a malfunction) 
alarm and Manual (Scanning Disabled) indicators 
can still appear.  

Virtual DO: Advanced Tab 
Use this tab to configure accumulated value and state for reset for the 
selected DO.   
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Select Configure > I/O > Virtual DO Points > Advanced tab. The 
Advanced screen displays. 

 
Figure 7-78. Virtual DO – Advanced tab  

Field Description 
Accumulated Value Sets a value for the accumulated number of off-to-

on transitions for the discrete output. The 
accumulator is a 32-bit number with a maximum 
count of 4,294,967,295. You can preset the 
accumulator to a desire value or clear it by enter 
zero (0).  

Action After Reset 
or Power Fail  

Indicates how the ROC handles the discrete 
output station on resets or power failures. Valid 
values are Retain Last State (ROC retains the 
DO state, whether on or off) or Use Failsafe State 
(ROC uses the value you specify in the Failsafe 
State field). The default is Retain Last State.  

Failsafe State  Specifies, if you select the Use Failsafe State 
option, whether the system sets the virtual directo 
output on or off following a reset or power failure. 
The default is On. is selected, specify whether the 
Auto Output or Manual Output is set to On or Off 
after a reset of the ROC, such as a power restart 
or a warm start.  

Output Indicates whether the virtual DO output is Normal 
(that is, on is on) or Inverted (that is, on is off). 
The default is Normal.  

Virtual DO: TDO Parameters Tab 
Use this tab to configure time duration parameters for this DO point.   

Note: This tab does not display if you choose Latched in the DOUT 
Type field on the General tab. 
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Select Configure > I/O > Virtual DO Points > TDO Parameters tab. 
The TDO Parameters screen displays.   

 
Figure 7-79. Virtual DO – TDO Parameters tab  

Field Description 
Cycle Time  Sets, in seconds, the total amount of time the cycle 

spends in the on and off positions. The default is 
15 seconds.  
The Cycle Time entry is used to define the OFF 
time in the TDO Toggle mode. The OFF time is 
calculated by the formula: 
 

Off Time = Cycle Time – On Time 
 
For example, a TDO is used to emulate a field 
instrument measuring flow. The TDO outputs a 
pulse width of 3 seconds for no flow and a pulse 
width of 12 seconds for 1000 MCF per day flow. 
The output is repeated every 15 seconds. 
If the Cycle Time is less than, or equal to the On 
Time, the OFF time is set to one. Care must be 
taken in configuration (including other places, such 
as FSTs) to ensure that the Cycle Time remains 
greater than the calculated On Time for proper 
operation. 

Low Reading Time  Sets the Low Reading Time (0% Count) in 
seconds that represents a zero percent output 
pulse width. The default is 3 seconds. This is the 
minimum amount of time that the TDO can be 
energized to move the motor. Set to a value that 
allows movement, but also provides good 
resolution of control.  
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Field Description 
High Reading Time  Sets the High Reading Time (100% Count) in 

seconds that represents a 100 percent output 
pulse width. The default is 12 seconds. This is the 
maximum amount of time that the TDO can be 
energized to move the motor. Normally, this is the 
amount of time it takes for the actuator to move the 
valve from fully open to fully closed.  

Low Reading EU  Sets the engineering unit (EU) for the low reading 
to zero percent output (low end of the EU range). 
Based on the EU range determined in part by this 
parameter, the EU value is converted to a 
corresponding signal.  

High Reading EU  Sets the engineering unit (EU) for the high reading 
to 100 percent output (or high end of the EU 
range). Based on the EU range determined in part 
by this parameter, the EU value is converted to a 
corresponding signal.  

EU Value  Current value, displayed in engineering units.  
In TDO Toggle mode, the EU Value controls the 
Time On:  

On Time = ((EU Value – Low Reading EU) / 
(High Reading EU – Low Reading EU) * (High 
Time – Low Time)) + Low Time 

Units  Sets the engineering units for the discrete output 
(such as percentage, IN H2O, PSIG, MCF, 
degrees F, milliamps, and volts).  

TDO Time On The TDO Parameters tab allows configuration of 
TDO parameters when one of the DOUT Types 
TDO (Timed Duration) or TDO Toggle is selected 
in the discrete outputs screen.  
The Time On field is located on the general 
discrete outputs tab. The Time On field is 
calculated from the entered EU Value and the 
previous definitions of Low Reading Time, High 
Reading Time, Low Reading EU, and High 
Reading EU entered in the TDO Parameters 
screen. The calculation formulas are: 

EU Span = High Reading EU Value – Low Reading EU 

Count Span = High Reading Time (100% Count) – Low Reading Time (0% Count) 

On Time = (Entered EU Value × Count Span) + Low Reading Time (0% Count) 

  EU Span   
 

 
Defining the  

Output Pulse 
To define the TDO output pulse:  

1. Select Configure > I/O > DO Points or DO Relay Points or Virtual 
TDO. 

2. Select a DOUT Type of TDO or TDO Toggle in the discrete outputs 
dialog. 
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 TDO (Timed Duration) – The single-pulse output can be 
triggered by writing to the Status or the EU Value parameter of 
the DO point. This can be accomplished directly, by a PID point, 
or by an FST. 

 TDO Toggle – A continuous pulse is generated with the pulse 
length being controlled by writing to the EU Value parameter in 
the DO point. This can be accomplished directly or by an FST. 

3. Click the TDO Parameters tab. 
The output pulse from the TDO function must be defined for proper 
engineering unit (EU) conversion. The minimum pulse width (Low 
Reading Time / 0% Count) and the maximum pulse width (High 
Reading Time / 100% Count) define the minimum and maximum ON 
time of the output pulse. The values entered in the Low Reading Time 
and High Reading Time are the number of seconds the output is ON. 
Example: 
A TDO is used to emulate a field instrument measuring flow. The TDO 
outputs a pulse width of 3 seconds for no flow and a pulse width of 12 
seconds for 1000 MCF per day flow. 

Low Reading Time (0% Count) = 3 seconds 
High Reading Time (100% Count) = 12 seconds 
Low Reading EU = 0 
High Reading EU = 1000 

Virtual DO: Alarms Tab 
Select Configure > I/O > Virtual DO Points > Alarms tab to 
configure the alarm parameters for this DO point.   
Select the Alarms tab. The Alarms screen displays. 

  
Figure 7-80. Virtual DO – Alarms tab  
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Field Description 
Alarming Sets the alarm option for this point. Valid values 

are Enabled (enables alarming) or Disabled 
(does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the 

Active Alarms field, but is not logged in the 
Alarms file. If you enable alarming, the 
system generates an alarm if you disable 
scanning. 

RBX Alarming  Sets the Spontaneous-Report-by-Exception 
(SRBX or RBX) alarming for this point. Valid 
values are:  
 On Alarm Set - Generates an RBX message 

to the host when the point enters an alarm 
condition. 

 On Alarm Clear - Generates an RBX 
message to the host when the point leaves an 
alarm condition. 

Note:  SRBX Alarming requires the 
communications port to be configured. 

7.1.16 IEC62591 Module 
The IEC62591 module, when wired to a field-installed Field Link, 
enables the ROC800 to communicate wirelessly with a number of field-
installed WirelessHART devices.   

Note: For further information, refer to the IEC62591 Wireless Interface 
Instruction Manual (for ROC800-Series and FloBoss 107) (part 
D301708X012). This section only generally describes the tabs 
for this module.    

Select Configure > I/O > IEC62591 Module. The IEC62591 Module 
screen displays. Examine the default settings and adjust the parameters 
to suit your application on each of the tabs. 
 The Module tab provides read-only statistical information about the 

IEC62591 module, such as serial number and part numbers. 
 The Network tab identifies the Join Key and Network ID for the 

network. These values must correspond to the Network ID and Join 
Key in the devices. 

 The Commission tab auto-detects available uncommissioned 
devices and enables you to add them to the defined network. 

 The Transmitter tab enables you to access both read-only statistics 
and modifiable parameters for a specific device associated with the 
network. 

 The Statistics tab provides read-only statistics the Field Link has 
accumulated for the network. Click Reset Statistics to reset these 
values at any time. 

 The Diagnostics tab describes how to use the module’s USB port to 
generate log information for resolving issues. 
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Save 
Configuration 

After you configure a point and click Apply, click Flash Memory Save 
Configuration (on the ROC > Flags screen) to save I/O configuration 
to permanent memory in case you must perform a cold start.  

IEC62591: Module Tab  
Select Configure > I/O > IEC62591 Module > Module tab. The 
IEC62591 Module screen displays the IEC62591 Module screen, 
showing the Module tab.   

 
Figure 7-81. IEC62591- Module tab   

This tab provides the following read-only statistical information from 
the installed IEC62591 module:  
 Module Type 
 Description  
 Flash Part Number 
 Flash Revision 
 Flash Build Date 
 Serial Number 
 Boot Part Number 
 Boot Revision 
 Boot Build Date 
 System Mode 
 Board Health 
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IEC62591: Network Tab  
Select Configure > I/O > IEC62591 Module > Network tab. The 
IEC62591 Network screen displays.   
Use this screen to identify the Network ID and Join Key for the devices 
in your network. When you select the Network tab, you must complete 
two fields.    

 
Figure 7-82. IEC62591- Network tab   

Field  Description 
Network ID Enter a valid Network ID.  

Prior to starting this process, you should map the 
physical locations of your WirelessHART devices 
and identify device groupings that are meaningful to 
your organization. Once you have groups, assign 
each group a value (such as 0001, 0002, 0003, etc. 
These are Network IDs you may use for this field.  
Note: A Network ID cannot be all zeros (such as 
0000).   

Join Key (hex) Enter a valid Join Key to permit the device to 
access its defined network.  
A Join Key is a 128-byte value expressed as four 
32-bit portions. As shown in the example, you can 
use zeros for the first three parts of the Join Key.  
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Field  Description 
Status This read-only field shows the current status of the 

connection between the network and ROCLINK 
800. After you click Apply, this field shows 
Configuring Network (as the Field Link validates 
network values), Detecting Radio (as the Field 
Link recognizes the network), and On-line (as the 
Field Link accesses the network).   

 

IEC62591: Commission Tab  
Select Configure > I/O > IEC62591 Module > Commission tab. The 
IEC62591 Network screen displays.   

 
Figure 7-83. Commission tab  

Use this screen to individually or collectively commission devices. This 
screen has two lists, Uncommissioned and Commissioned. When the 
Status field on the Network screen displays On-line, ROCLINK 800 
automatically begins adding devices to the Uncommissioned list. To 
commission a device, you move it to the Commissioned list in either of 
two ways:  
 Select the device and click Commission. ROCLINK 800 places the 

device in the first available empty position.   
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Note: To select several devices, press Ctrl and left-click each 
additional device. Click Commission when you have 
finished selecting devices.  

 Select the device and “drag” it to a position on the Commissioned 
list.  

The number of rows on the Commission screen correlates to the number 
of wireless devices your controller supports. Each row represents a 
specific logical position. If, during commissioning, you want the 
controller to store information from a specific wireless device in a 
specific logical position, you can commission that device to that logical 
by selecting that device and “dragging” it to the appropriate position on 
the Commissioned list. 

Note: Once you commission a device to a particular logical, you 
cannot drag it another logical position. You must first 
decommission the device and then recommission it to the new 
logical position.  

When you select a device in the Uncommissioned column, the 
Commission button activates:  

 
Figure 7-84. Active Commission button 

Note: To select more than one device, press the Ctrl key and left-click 
each additional device.  

Click Commission. After a few minutes, the device moves from the 
Uncommissioned to the Commissioned list:   
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Figure 7-85. Commissioned Device  

Another indicator that the device has been successfully commissioned is 
the activation of the Transmitter tab.   
If you decide to remove a device from your network, use this screen to 
decommission the device.  Select the device and drag it to the 
Uncommissioned list.  

Note: Remember to adjust or redefine any TLPs you have designated 
to accumulate the information for the decommissioned device’s 
logical position.   

If a particular wireless device in your network stops working, you can 
easily replace it with a similar device.  

Note: Using this option does not require you to adjust or redefine any 
TLPs you have designated to accumulate the information for the 
decommissioned device’s logical position. The new device 
assumes all parameters you have defined for the old device. 

First, configure the device for the network, assigning it the appropriate 
Network ID and Join Key. Install the device in the field. Start 
ROCLINK 800, select the IEC62591 module, and display the 
Commission tab. When the replacement device appears on the 
Uncommissioned list, select it and drag it on top of the non-working 
device. This tells ROCLINK 800 that you want this new device to 
assume all the defined characteristics of the old device.  
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ROCLINK 800 displays a verification dialog to prevent you from 
accidentally replacing a device: 

 
Figure 7-86. Device Replacement Verification Dialog  

Click Yes to complete the replacement. ROCLINK commissions the 
new device and automatically decommissions the old device, moving it 
to the Uncommissioned list.  

IEC62591: Transmitter Tab  
Select Configure > I/O > IEC62591 Module > Transmitter tab. The 
IEC62591 Transmitter screen displays.   
The Transmitter tab can provide a variety of information on the installed 
device. Selecting the Transmitter tab displays the Transmitter screen:  

 
Figure 7-87. Transmitter tab 
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Field  Description 
Transmitter Displays the 8-character alphanumeric tag 

associated with the transmitter. The system adds 
the logical position (here, 1 - ) to the tag. Click  to 
display all devices currently defined for this 
network.  

Tag Defines an 8-character alphanumeric identifier for 
the transmitter (such as Tnk2Lvl or Pmp1Tmp).  

Message Provides an optional 40-character message 
associated with the transmitter. Use this field for 
explanatory or warning messages (such as Not to 
exceed 300 psi).  

Descriptor Provides an optional 13-character describing the 
transmitter (such as Casing press).  

Transmitter 
Information 

This section displays read-only information on the 
transmitter, including serial number, manufacturer 
ID, type of device, battery life, and other data. 

Burst Rate Indicates, in seconds, how often the transmitter 
sends out data. The default is 4 seconds.  

Response Code Indicates whether the transmitter is responding. For 
any value other than 0, the field turns red.  
Note: Response codes are manufacturer-defined. 
Refer to the documentation provided with the 
transmitter or to the manufacturer’s website for a 
complete list of response codes, their meanings, 
and their resolutions.  

Commission Status Indicates the current status of the device in the 
commissioning process. Valid values are:  
0 = Logical Not Used 
1 = Configuring Burst Command 
2 = Configuring Burst Variables 
3 = Configuring Burst Rate 
4 = Enabling Bursting  
5 = Bursting (field highlighted in green) 
6 = Data Stale (field highlighted in yellow) 
7 = Communication Failure (field highlighted in red) 
8 = Disabling Bursting  

Poll Mode Indicates the mode the transmitter uses to acquire 
information. The default is Normal, based on the 
value in the Burst Rate field. Select Update and 
click Apply to immediately perform an on-demand 
polling and refresh all fields on this screen. The 
mode reverts to Normal at the next Burst Rate 
interval.  

Dynamic Variables Displays the values for the primary (PV), secondary 
(SV), tertiary (TV), and quaternary (FV) dynamic 
variables.  
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Field  Description 
Slot Variables Defines the slot assignment and associated value 

for up to four slot-based variables.   
Each wireless transmitter contains up to 250 slots 
able to store variable information (such as 
temperature, pressure, scaling factors, altitude, 
flow, and so on). Each transmitter manufacturer 
defines which slots contain what information. Refer 
to the documentation provided with the transmitter 
or to the manufacturer’s website for a complete list 
of slot assignments.  
Note: WirelessHART conventions require that all 

manufacturers reserve slots 246 through 249 
for the dynamic variables PV, SV, TV, and 
FV, respectively. Slot 250 is also reserved as 
permanently unassigned, and does not 
accumulate values. 

Click Apply to save any changes you may make to the values on this 
screen.   

Note: You can also double-click a commissioned device on the 
Commission screen to immediately access the Transmitter 
screen for that device.   

 

IEC62591: Statistics Tab  
Select Configure > I/O > IEC62591 Module > Statistics tab. The 
IEC62591 Statistics screen displays.   
The network accumulates a variety of statistical information you can 
review to assess system health. This content displays when you select 
the Statistics tab.   
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Figure 7-88. Statistics screen 

This screen displays accumulated read-only statistics about the network. 
Click Reset Statistics at any time to zero-out all accumulated values.  

IEC62591: Diagnostics Tab  
Select Configure > I/O > IEC62591 Module > Diagnostics tab. The 
IEC62591 Diagnostics screen displays.   
The IEC62591 module has a USB port which you can use to retrieve a 
diagnostic log to assist in troubleshooting. Select the Diagnostics tab to 
display the Diagnostics screen:   
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Figure 7-89. Diagnostics tab 

The screen provides basic information to create and process the 
diagnostic log. However, Technical Support personnel can use the 
Logging Severity frame to more thoroughly identify problems with your 
system.   

Field  Description 
Logging Severity Sets the amount of accumulated system activity 

data included on the diagnostic log. 1 is the least 
comprehensive setting and 9 is the most 
comprehensive setting. The default setting is 7.  
Note: Use this field only under the direction of 

Technical Support personnel. 
Set Logging Level Click to set the severity of logs. The system 

validates your selection by displaying the message 
Set Logging Severity X COMPLETED, where X 
represents the severity you have selected.   

7.2 Control Menu 
Use the Control menu options to configure FST Registers, Radio Power 
Control, DS800, Sampler/Odorizer, and PID Loops.  

7.2.1 FST Registers 
Use the FST Registers screen to configure FST registers and add timers 
and other execution controls.  
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Select Configure > Control > FST Registers. The FST Registers 
screen displays. 
The FST Registers screen has two tabs. Use each tab to configure a 
component of the FST.  
 Use the General tab to configure and enable the FST registers. 
 Use the Advanced tab to add timers, execution controls, and other 

features to the FSTs. 

Note: After you configure a point and click Apply, click Flash 
Memory Save Configuration (on the ROC > Flags screen) to 
save I/O configuration to permanent memory in case you must 
perform a cold start. 

FST Registers: General Tab 
The FST Registers screen initially displays the General tab. Use this tab 
to enable and configure the FST registers.  

 
Figure 7-90. FST Registers – General tab  

Field Description 
FST  Sets the FST sensor to configure. Click ▼ to 

display all available FSTs.  
Note:  The selection in this field applies to each 

tab on this screen. 
Tag  Sets the ten-character identifier for the FST.  

Note:  The selection in this field applies to each 
tab on this screen. 

Version  This read-only field shows the version (if 
assigned) of the FST on download.  
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Field Description 
Description  This read-only field shows the description (if 

assigned) of the FST on download.  
Status Sets the current state and enables you to start or 

stop the FST. Valid values are Enabled (FST is 
active) or Disabled (FST is not active).  
Note:  If you change the value in this field, click 

Apply. 
Registers #1 to #10  Provides up to 10 storage points for FST floating 

point values.  
Use FST registers to store calculated or manually-
entered values. You can also those values from 
one FST to another. For example, an FST can 
write values to the registers and also read the 
values stored in the FST Register storage points. 
Registers may be read from, or written to, any FST 
configured for the ROC 

FST Registers: Advanced Tab 
Select Configure > Control > FST Registers > Advanced tab to add 
timers, execution controls, and other features to the FSTs.  

 
Figure 7-91. FST Registers – Advanced tab  

Field Description 
Timer #1 through #4  Sets up to four countdown timers that signal 

certain periods or times have elapsed. You set the 
time, and the FST updates the time. These four 
timers, when set to values greater than 0, 
decrement by 1 every cycle time. The scan period 
determines the cycle times. Cycle time equals:  

Misc #1 to #4  Sets up to four unsigned 8-bit integers (with valid 
values from 0 to 255) the FST can use for global 
storage.  
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Field Description 
Mesg #1 and Mesg 
#2  

Provides two 30-character fields for storing 
messages that display in the FST Message area.  

Msg Data #1 and 
Msg Data #2  

Displays any values associated with the 
messages.  

Execution Delay  Sets a period, in seconds, between the execution 
of successive FST command steps. The default is 
0 seconds. The minimum delay is 0.1.  

Results Register  Sets a special-purpose register that stores the 
floating point result from the most currently 
executed command. The Result Register (RR) 
may also be known as the Signal Value Analog 
(SVA).  

Compare Flag  Sets a special-purpose 8-bit register that stores an 
integer representing the numbers 0 through 255. 
The logic commands manipulate the Compare 
Flag. The Compare Flag may also be known as 
the Signal Value Discrete (SVD).  

FST Steps/Task 
Cycle  

Sets the number of tasks (steps) that you desire 
the FST to complete in the amount of time set in 
the FST Cycle Time (in seconds) field, which is 
configured in the FST Editor Monitor Display.  

FST Cycle Time  This read-only field shows, in seconds, the 
amount of time in which an FST will cycle as set in 
the FST Editor Monitor Display.  

EVT Command - 
Log Events 

Set in which log the FST Event (EVT) command 
creates a file. Select in Standard Event Log to 
record the event in the main Events Log. Select in 
Weights & Measures Event Log to record the 
event in the Weights & Measures Event Log if the 
register is related to a weight or measurement 
event. 

Code Size Bytes  This read-only field shows the number of bytes 
the FST uses.  

Code Pointer Byte  This read-only field shows the pointer byte for the 
FST.  
Note:  Use FST Monitor within the FST Editor to 

monitor these operations. 

7.2.2 Proportional, Integral, and Derivative (PID) 
Proportional, Integral, and Derivative (PID) controls enable you to 
provide smooth and stable operation for feedback control loops that 
employ a regulating device, such as a control valve or a motor. The 
typical use for PID is to control a process variable to a setpoint.  
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PID is the most common control methodology in process control. PID is 
a continuous feedback loop that keeps the process flowing normally by 
taking corrective action whenever any deviation from the desired value 
(setpoint) of the process variable (rate of flow, temperature, voltage, and 
such) occurs. An "error" occurs when an operator manually changes the 
setpoint or when an event (such as a valve opening or closing) or a 
disturbance changes the load, thus causing a change in the process 
variable. 
The PID controller receives signals from sensors and computes 
corrective action to the actuators from a computation based on the error 
(proportional), the sum of all previous errors (integral) and the rate of 
change of the error (derivative). 

Enabling  
PID Loops 

Before you can configure a PID loop, you must first enable the ROC to 
recognize them. 

1. Select ROC > Information. The Device Information screen displays. 
2. Select the Points tab. The Points screen displays. 
3. Complete the PIDs Active field with the number of PIDs you want to 

configure.   

Note: The read-only Maximum field shows the maximum number 
of PIDs you can define. 

4. Click Apply to save the value and then OK to close the Device 
Information screen and return to the ROCLINK 800 menu. 

PID Overview 
Select Configure > Control > PID Loop. In a given PID point, two 
separate PID loops are available: Primary and Override. In Primary 
Only mode, the Override Control loop is disabled, leaving only the 
Primary Control loop active.  
The PID control loop can use either one analog output or two discrete 
outputs to control the regulating device. If discrete output control is to 
be used, one DO will provide open/forward control and the other DO 
provides close/reverse control. 
Each active PID loop acquires the Process Variable input and calculates 
the change in output required to maintain its Setpoint. If Override 
Control is enabled, the calculation result that is applied to the output 
depends upon whether the High or Low Override Type Select is chosen. 
If the output type is analog, the selected change in output is added to the 
current value of the output. If the output type is discrete, the change in 
output is sent to one of the two discrete outputs. The magnitude of the 
correction determines the amount of time that an output is energized. If 
the correction is positive, it is routed to the open/forward DO. If the 
correction is negative, it is sent to the close/reverse DO. 
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One application of Override PID control allows pressure control to 
Override flow control when the pressure exceeds a Setpoint value. For 
example: The output of the Primary flow control loop would be selected 
until the pressure input approaches the Override Setpoint of 700 PSIG. 
As the pressure input approaches its Setpoint, the pressure loop tries to 
close the valve and take over control at the point when the output 
calculated by the pressure loop is less than the output calculated by the 
flow loop. Control returns to the Primary flow control loop, when the 
change in output required to maintain the Override Setpoint no longer 
outweighs the flow loop's attempts to maintain its Setpoint. 
Through the use of an FST, you may implement a switchover algorithm. 
When the input exceeds a predetermined switchover value, the FST can 
switch the mode to Override only. When the FST determines that the 
input value is no longer in a critical range, the PID mode can be 
switched back to Primary only. 

PID Loop: General Tab 
Select Configure > Control > PID Loop. The PID Loop screen 
initially displays the General tab. Use this screen to configure general 
PID loop parameters.  

 
Figure 7-92. PID – General tab  

TLP “Browse” button.  
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Field Description 
Tag  Sets the ten-character identifier for the PID.  

Note:  This selection applies to each tab on this 
screen. 

PID  Selects the PID point to configure. Click ▼ to 
display all available PIDs.  
Note:  This selection applies to each tab on this 

screen.  
Control Type  Sets the control type for PID loop. Valid values 

are:  
 Primary Only – Sets the Primary loop as the 

only active loop. The system uses the output 
the Primary loop calculates to adjust the 
control output. 

 Override Only – Sets the Override loop as the 
only active loop. The system uses the output 
the Override loop calculates to adjust the 
control output. 

Note:  This control type is used mainly for tuning 
the Override loop or when loop selection is 
controlled by an FST or other logic external 
to the PID algorithm. 

 Override Control – Sets both the Primary and 
Override loops as active. The system 
compares the outputs from the two loops and 
uses either the lesser or greater of the two 
outputs (based on the selection in the 
Override Type Select field) to adjust the 
control output. 

Output Type  Sets the output type for the PID loop. Valid values 
are Analog (the system writes the PID output to 
the assigned analog output point EU value) or 
Discrete (the system writes the PID output to the 
assigned DO Open Point EU value if the change in 
output is positive or writes to the assigned DO 
Close Point EU value if the change in output is 
negative). Any discrete outputs must be 
configured as Timed Duration Outputs (TDO). 
Digital Valve (the system writes the PID output to 
the assigned ACIO or DO point EU value).  
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Field Description 
Mode  Sets the Mode for the PID Loop:  

 Disabled – No loops are active and the PID 
output parameter is not written to the assigned 
control output.  

 Manual – No loops are active and the system 
writes the PID output parameter to the 
assigned control output, allowing you to adjust 
the output as required. 

 Auto – PID loops are active as configured 
under Control Type; you enter the setpoint of 
the loops and the system automatically sends 
any change in the calculated output to the 
configured output point. 

 Remote SP – PID loops are active as 
configured under Control Type. The Setpoint 
of the loops are read from the Setpoint I/O 
Definition.  

Loop Status  Indicates which loop (Primary or Override) is 
currently selected or disabled.  

Loop Period  Sets, in seconds, the period of time between 
executions of the PID algorithm. This is the 
amount of time between executions from the 
beginning of one execution to the beginning of the 
next.  
Note:  If you select Override Control, both loops 
executed in this time period.  

Actual Period  This read-only field shows the actual amount of 
time (in seconds) from the beginning of the last 
execution of the loop to the beginning of the 
current execution of the loop.  

Primary Setpoint  Set an input using the TLP Browse button or enter 
a Value for controlling the Primary PID loop's 
Process Variable.  
Note:  This field does not display if you select 

Override Only as a Control Type. 
Primary Process 
Variable  

Click the TLP Browse button to select a process 
variable for the Primary PID Loop or enter a value 
to use for comparison to the Primary Setpoint.  

Override Setpoint  Set an input using the TLP Browse button or enter 
a Value for controlling the Override PID loop's 
Process Variable.  
Note:  This field does not display if you select 

Primary Only as a Control Type.  
Override Process 
Variable  

Click the TLP Browse button to select a process 
variable for the Override PID Loop or enter a value 
to use for comparison to the Primary Setpoint.  

Output Point  Click the TLP Browse button to select an analog 
output point for the loop.  
Note:  This field displays only if you select 

Analog as an Output Type on the General 
tab. 
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Field Description 
DO Open Point  Click the TLP Browse button to select a discrete 

output open point for the loop. The DO Open Point 
and DO Close Point values, respectively, open or 
close the valve or other device. You must 
configure these values as TDO (Time Duration 
Output) discrete output mode.  
Note:  This fields display only if you select 

Discrete as an Output Type on the 
General tab.  

DO Close Point  Click the TLP Browse button to select a discrete 
output close point for the loop. The DO Open Point 
and DO Close Point values, respectively, open or 
close the valve or other device. You must 
configure these values as TDO (Time Duration 
Output) discrete output mode.  
Note:  This field display only if you select 

Discrete as an Output Type on the General 
tab. 

Output Low Limit  Sets the low limit for the analog or discrete output. 
If a change in output causes the current value to 
drop below this value, the system sets the output 
to this value.  

Output High Limit  Sets the high limit for the analog or discrete 
output. If a change in output causes the current 
value to rise above this value, the system sets the 
output to this value.  

Show Trend / Hide 
Trend  

Click Show Trend to display a graphical 
representation of the PID output and process 
variable in reference to the set point over time. 
Use the graph to assist in tuning the control loop. 
When you hover over the trend line, the number 
on the left updates indicating the SP, PV, and 
Output at the point in time. Click Pause to stop the 
update and Continue to restart the scanning.  
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Figure 7-93. PID Loop - Show Trend/Hide Trend  

PID Loop: Tuning Tab 
Select Configure > Control > PID Loop > Tuning tab to set Tuning 
parameters for the PID Loop.  
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Figure 7-94. PID Loop – Tuning tab  

Field Description 
Gain  Sets proportional gain as the ratio of the change in 

output to the change in the error.  
Override Type 
Select  

Sets the control output for the Override Type. 
Valid values are High (system selects as the 
control output the higher of the Primary Output 
Change value or the Override Output Change 
value) or Low (system selects as the control 
output the lesser of the Primary Output Change 
value or the Override Output Change value).  

Reset  Sets integral gain or reset as the ratio of the 
change in output to the change in the integral of 
the error with respect to time. This value is in 
terms of repeats per minute.  
Typically calculated as either (Primary Process 
Variable – Primary Setpoint) or (Override Process 
Variable – Override Setpoint). 

Rate  Sets the derivative gain or rate as the ratio of the 
change in output to the change in the error with 
respect to time. This value is in terms of minutes. 
Typically calculated as (Primary Process Variable 
Primary Setpoint) or (Override Process Variable 
Override Setpoint).  
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Field Description 
Scale Factor  Sets values representing the ratio of the output 

span to input (Process Variable) span. The sign of 
the number specifies the action of the loop output: 
negative for reverse action or positive for direct 
action.  

Primary Control 
Deadband  

Sets a "window" around the setpoint for the 
Primary PID. When the process variable is within 
this window, the system does not recalculate a 
change in output. If you enter 5, the deadband is a 
region of 5 units above and 5 units below the 
setpoint in which the process variable can move 
without affecting the output.  

Override Control 
Deadband  

Sets a "window" around the setpoint for the 
Override PID. When the process variable is within 
this window, the system does not recalculate a 
change in output. If you enter 5, the deadband is a 
region of 5 units above and 5 units below the 
setpoint in which the process variable can move 
without affecting the output.  

Primary SP Ramp 
Rate  

Sets the maximum rate at which the Primary PID 
setpoint can ramp to a new value. Maximum rate 
is in EU per minute where engineering units are 
the units of the process variable.  

Override SP Ramp 
Rate  

Sets the maximum rate at which the Override PID 
setpoint can ramp to a new value. Maximum rate 
is in EU per minute where engineering units are 
the units of the process variable.  

SP Low Limit  Sets the SP Low Limit as the lowest allowed 
value for the Setpoint.  

SP High Limit  Sets the SP High Limit as the highest allowed 
value for the Setpoint.  

Change in Output or  This read-only field shows the calculated change 
in output from the associated loop. You define 
these values on the Inputs/Outputs tab.  
Note:  If you select Primary Only as a Control 

Type, the Override Output Change field 
does not display. If you select Override 
Only as a Control Type, the Primary Output 
Change field does not display. 

Threshold  Sets the threshold to prevent premature selection 
of the Override loop. If the Override process 
variable is outside of this threshold on the safe 
side of the Override setpoint, the system always 
selects the Primary loop. However, if the Override 
process variable is within the threshold of the 
Override setpoint or is on the unsafe side of that 
setpoint, the system can select the Override loop.  
Note:  If you set the override Threshold to 0.0, the 
system uses the high/low value of the Override 
Type Select field (defined on the General tab) to 
select the appropriate change, regardless of the 
error in the Override loop. 
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Field Description 
Manual Tracking  Sets how the system tracks setpoint and process 

variable values in moving between Auto and 
Manual Modes (defined on the General tab). Valid 
values are Enabled (sets the Primary loop’s 
setpoint equal to the process variable when the 
PID point is in Manual mode) or Disabled (does 
not equalize these values). This is typically used to 
eliminate a value "bump" when transferring from 
Manual to Auto mode.  

Halt PID on Reset  Sets the status of the PID control loop following a 
power restart or a warm start. Valid values are 
Enabled (activate the PID loop) or Disabled (do 
not activate the PID loop).  

 Enabled Do not activate the PID loop. 

 Disabled Activate the PID loop. 

Override Type 
Select  

Sets the control output for the Override Type. 
Valid values are High (system selects as the 
control output the higher of the Primary Output 
Change value or the Override Output Change 
value) or Low (system selects as the control 
output the lesser of the Primary Output Change 
value or the Override Output Change value).  

PID Loop: Status Tab 
Select Configure > Control > PID Loop > Status tab to view the 
Status of the Primary and Output values.  
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Figure 7-95. PID Loop – Status tab  

Field Description 
Output Low Limit 
Status  

This read-only field shows, when a PID loop is 
enabled, whether the output of the Primary PID 
loop has been clipped by the low output limit. Valid 
values are Limited or Not Limited.  

Output High Limit 
Status  

This read-only field shows, when a PID loop is 
enabled, whether the output of the Primary PID 
loop has been clipped by the high output limit. 
Valid values are Limited or Not Limited.  

Primary PV Status  This read-only field shows, when a PID loop has 
been enabled, the status of the Primary loop's 
Process Variable data. Valid values are OK, 
Questionable Data, or Invalid TLP.  

Primary SP Low 
Limit Status  

This read-only field shows whether the setpoint of 
the Primary PID loop has been clipped by the low 
Setpoint limit. Valid values are Limited or Not 
Limited.  

Primary SP High 
Limit Status  

This read-only field shows whether the setpoint of 
the Primary PID loop has been clipped by the high 
Setpoint limit. Valid values are Limited or Not 
Limited.  

Primary SP Rate 
Limited Status  

This read-only field shows whether the setpoint of 
the Primary PID loop is currently being limited by 
the maximum Setpoint change rate (as defined by 
the SP Ramp Rate on the Tuning tab).  
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Field Description 
Override PV Status  This read-only field indicates the status of the 

Override loop's Process Variable data. Valid 
values are OK, Questionable Data, and Invalid 
TLP.  

Override SP Low 
Limit Status  

This read-only field shows whether the setpoint of 
the Override PID loop has been clipped by the low 
Setpoint limit. Valid values are Limited or Not 
Limited.  

Override SP High 
Limit Status  

This read-only field shows whether the setpoint of 
the Override PID loop has been clipped by the 
high Setpoint limit. Valid values are Limited or 
Not Limited.  

Override SP Rate 
Limited  

This read-only field shows whether the setpoint of 
the Override PID loop is currently being limited by 
the maximum Setpoint change rate (as defined by 
the SP Ramp Rate on the Tuning tab).  

Change in Output 
Algorithm  

This read-only field shows the algorithm the 
system uses for the PID. Valid values are 
Standard  (Change in Output = SF x PG x (errCng 
+ (IG x ALP x err) + (DG x RPC)) or Digital 
(Change in Output = SF x IG x err), where:  
 
SF = user-entered Scale Factor  
PG = user-entered Proportional Gain  
IG = user-entered Integral Gain  
DG = user-entered Derivative Gain  
errCng = Error Change (error – last error)  
ALP = Actual Loop Periop, measured in minutes  
Err = error (Process Variable – Setpoint) 
RPC = Delta Rate of Process Variable Change 
(Rate of PV Change – Last Rate of PV Change)  

 
Example PID 

 Configuration 
The following example describes how to configure a PID point and 
associated inputs and outputs to implement flow control with pressure 
override to protect against over-pressuring the line.  
In this example, the Primary process variable (Primary PV) is the 
volumetric flow rate per day obtained from an orifice meter run point. 
The system obtains the Override process variable (Override PV) from 
the static pressure value from an MVS or analog input. Both the Primary 
and Override loops require you to define a setpoint (the value at which 
you wish to control the loop). The example describes the process for 
setting up either discrete or analog control for the control output. 
If a 4 to 20 mA signal to an I/O converter controls the control valve: 
 Configure an analog output with the appropriate Low and High 

Reading EU (engineering units). The units can either be in terms of 
the valve position (0 to 100%) or in terms of flow capacity (0 to 
1000 MCF/Day). 

 Set the Output Type on the PID screen to Analog. 
 On the Inputs/Outputs tab, define an output point TLP using as an 

analog input, the desired Logical Number, and EU Value parameter. 
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If a motorized actuator on the valve controls the control valve: 
 Configure two discrete output points for the open and close contacts 

as TDO (Time Duration Output) DOUT types. Set the Low Reading 
Time to the minimum amount of time (in seconds) the TDO can be 
energized to move the motor. Set the High Reading Time to the 
amount of time (in seconds) the TDO must be energized for full 
travel. Set the Low and High Reading EU values. The units can 
either be in terms of the valve position (0 to 100%) or in terms of 
flow capacity (0 to 1000 MCF/Day). 

 Set the Output type on the PID screen to Discrete. Under DO Open 
Point and DO Close Point, select a TLP with Point Type of Discrete 
Outputs, the desired logical number, and EU Value parameter. 

 Configure the PID point with a Control Type of Override Control. 
This causes available fields to appear on the PID screen to enter the 
I/O definition of the process variable and setpoint for both the 
Primary and Override loops. Select a TLP with Point Type of 
Orifice Meter Run Values, the desired Logical Number, and a 
parameter of Flow Rate Per Day for the Primary process variable. 
For the Override process variable, select a TLP with Point Type of 
MVS, the desired Logical Number, and a parameter of SP Reading. 
Leave the Setpoint I/O Definition undefined, because you enter the 
values. The setpoint for the Primary loop is the desired amount of 
flow per day. The setpoint for the Override loop is the pressure 
value where control should switch to the override loop. Set the Loop 
Period in seconds, typically one-fourth of the time required for the 
actuator to move the valve from fully open to fully closed. 

 On the Tuning tab, select the Override Type Select of Low. This 
selects the lower of the change in outputs from the primary and 
secondary loops. As the pressure approaches the Override setpoint, 
the pressure (Override) loop pinches back the output. At the point 
that the pressure loop requests an output change less than the flow 
(primary) loop, the output from the pressure loop is selected and 
controls the valve. Set the Scale Factor for each of the Primary and 
Override loops as (span of output)/(span of input). 

Both loops have scale factors, which permit the control action to close 
the valve when the process variable is above the setpoint. With the scale 
factor set according to the above formula, the initial settings for gain, 
reset, and rate produce stable control (under most circumstances). Gain 
controls the magnitude of the initial change in output for a given change 
in the process variable (or setpoint). Reset controls the magnitude of the 
change in output based on the continuing difference between the process 
variable and the setpoint over time. You can then adjust these values to 
produce the desired control actions. 

7.2.3 Radio Power Control 
Select Configure > Control > Radio Power Control to conserve 
battery power to a radio or any other communicating device.  
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Radio power is controlled either by the DTR signal or by a discrete 
output. Because there are separate Radio Control points for COM1 and 
COM2, radio power cycling for COM1 can be configured differently 
from that for COM2, including independent timer values and separate 
output controls using the Output Definitions options.  
For each Radio Power Control point, the power cycling can be 
configured to automatically change three times a day. During each of 
these three periods, called Zone 1, Zone 2, and Zone 3, the ON and OFF 
times can be set up to operate at various intervals to conserve battery 
power. The figure below is a graphical depiction of how the power 
control operates within each time "zone." 

 
Figure 7-96. Radio Power Control  

During the ON time: 
 The power output DO is switched to ON. DTR signal for the Comm 

Port is activated. 
 Communications may occur. 

During the OFF time: 
 The power output DO is set to OFF. DTR signal for the Comm Port 

is in-activated. 
 Communications may not occur. 

If communications occur during the ON time, the ON time is extended 
by the Hold Time. The DO and DTR signal remains ON and receive 
interrupts remain enabled for the duration of the Hold Time. 
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When you Enable the Radio Power Control parameter, radio power 
cycling is activated. The Low Battery Shutoff parameter allows power 
cycling to be automatically disabled whenever the input voltage to the 
ROC falls below the specified threshold. 
To use Radio Power Control, select Configure > Radio Power 
Control. 
After configuring the Radio Control points, click Apply. Save the 
configuration to programmable memory using the Flash Memory Save 
Configuration function in the ROC > Flags screen.  
Field Description 

Radio Power 
Control Point  

Selects a point to configure.  

Tag Sets a 10-character name to identify this point with 
its respective comm port.  

Radio Power Status  Indicates the current status of the Power Control 
function of Power Enabled (On), Power Disabled 
(Off), or RBX.  

Active Zone  This read-only field shows which zone is currently 
activated for determining the Start Time, On Time, 
and Off Time. Some of the On Time is also used 
by the radio during power-up initialization of the 
receiver, causing part of the On Time to be 
unavailable for receiving requests.  

Radio Power 
Control  

Enables or disables the Radio Power Control 
function.  

Zone  Sets the Zone parameters to indicate when Radio 
Power Control is active and inactive for various 
Zones.  
Start Time in hours and minutes (HHMM) that the 
respective Zone begins. Time is expressed in local 
time, 24-hour clock. For example: "1500" under 
Zone 2 means that the associated On Time and 
Off Time are used beginning at 3:00 p.m. The 
Zone is active unit the start time for the next zone 
is encountered. 
On Time during a control cycle when the output is 
in the ON state. 
Off Time during a control cycle that the output is 
in the OFF state. 
Note:  The On Time and Off Time alternate 

throughout the period the zone is active. 
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Field Description 
Hold Time  Sets the time that the output remains ON after 

detection of communications activity in Seconds or 
Minutes depending on the Time Units mode. This 
value applies to all Zones. When communications 
occur during the On Time, the On Time is 
extended by the Hold Time. The DTR signal and 
discrete output remain in the ON state.  
If a Spontaneous-Report-by-Exception (SRBX) 
message needs to be sent to the host computer, 
the radio power will be turned on for the Hold Time 
allowing the SRBX message to be transmitted. 
The Hold Time should be configured for a length 
of time long enough to allow the ROC to receive a 
response back from the host.  

Low Battery Shutoff  Sets a value that specifies the voltage at which 
Power Control is automatically disabled. The 
voltage being sensed is the System AI Battery 
Input voltage (0 to 1). The Low Battery Shutoff 
parameter allows power cycling to be 
automatically disabled whenever the input voltage 
to the ROC falls below the specified threshold. 
The default value is 11 volts.  
Radio Power Control is automatically enabled 
again when the input voltage rises up to this value. 

Low Battery 
Deadband  

Sets the value to add to the Low Battery Shutoff to 
determine when the Radio Power Control function 
is enabled again and allows the DO to turn on 
when needed.  

Power Timer  This read-only field shows the amount of time (On 
Time, Off Time, or Hold Time) that the Radio 
Control is currently using. The value is the number 
of seconds or minutes remaining.  

Discrete Output  Sets which DO point to use to power the radio.  

On Counter  Sets the value to indicate the cumulative time that 
the Power Control has been in the ON state in 
seconds or minutes.  

Off Counter  Sets the value to indicate the cumulative time that 
the Power Control has been in the OFF state in 
seconds or minutes.  

7.2.4 Sampler/Odorizer 
Use the Sampler/Odorizer to set up a discrete output (DO) channel of 
the ROC800-Series to send and control the timing and duration of a 
pulse output to another device, such as an odorizer (odor injector).  

Note You can also control a gas sampler. Enable the Sampler points on 
the ROC > Information screen. 
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Figure 7-97. Sampler/Odorizer  

Field Description 
Sampler/Odorizer  Sets the specific number of the Sampler or 

Odorizer (Sampler/Odorizer) to configure.  
Mode  Sets how the DO to sends a signal when the 

specified flow conditions are met.  
Input Rate Point  Sets the input point from which to acquire the rate. 

Click the TLP Browse button to display a Select 
TLP dialog you use to define the point.  

Input Rate Value  This read-only field shows the value of the current 
Input Rate Point selected. The unit of measure for 
the Input Rate Value and Unit Accumulation will be 
the same as the unit of the input point selected for 
Input Rate Point.  

Time Basis  Sets the time base for which the Input Rate Point 
is integrated: every second, minute, hour, or day.  

Unit Accumulation  Sets when an output pulse generates. The Input 
Rate Value is integrated over the Time Basis. 
When the total matches the Unit Accumulation 
value, a pulse is generated for the duration 
specified in the duration field.  

Duration  Sets, in seconds, how long the output pulse will be 
on. This is how long the DO stays ON. The DO is 
turned on for the amount of time set in the 
Duration field every time the Unit Accumulation 
value is exceeded.  

Output Point  Sets the DO point to be used. Click the TLP 
Browse button to display a Select TLP dialog you 
use to define the point.  
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7.2.5 DS800 Development Suite Software  
The DS800 Software Suite provides additional functionality for the 
ROC800-Series. For more information on DS800 programs, refer to the 
online help that accompanies the DS800 Development Suite or the 
DS800 Development Suite User Manual (A6126).  

DS800: General Tab 
Select Configure > Control > DS800. The General tab displays by 
default. This screen provides parameters related to the DS800 
application. It is good practice to check these settings prior to 
downloading a DS800 application.  

  
Figure 7-98 DS800 – General tab  

Field Description 
Mode Enables the execution of all DS800 resources 

loaded into the ROC.  
RSI Task  Sets whether you are communicating via serial 

communications for downloading and debugging 
DS800 applications. Distributed applications 
(multiple resource projects) are not supported over 
serial links.  

TCP/IP Task  Sets whether you are communicating via Ethernet.  

IXD Task  Enables the download of resources to a ROC. 
This would only be Disabled to save processor 
time, if there were no bindings between resources 
using the HSD network.  
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Field Description 
Clear Resources  Click to remove all downloaded resources from the 

ROC800-Series's permanent storage. This does 
not affect or stop a currently executing resource, 
because this resource was copied to RAM before 
it is started. The resources reside in RAM until you 
perform a restart, until a Warm Start occurs at the 
ROC800-Series, or you set the Mode on the 
DS800 screen to Off. When you set the Mode to 
On or restart the ROC800-Series, only the 
resources downloaded to the ROC after you 
pressed Clear Resources attempt to start.  

DS800: Advanced Tab 
Select Configure > Control > DS800 > Advanced. This screen 
displays information about each of the resources running in the ROC. 
Up to four resources can be running in each ROC.  

 
Figure 7-99. DS800 – Advanced tab  

Field Description 
Name  Provides a description of the resource.  
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Field Description 
Status  Shows the resource’s current state. Valid values 

are:  
 Fatal Error. 
 No resource running. 
 Stored resource available (Resource loaded 

in the ROC, but not running). 
 Resource is running in normal mode of 

operation. 
 Resource is running in a cycle by cycle debug 

mode that allows a single execution of the 
resource. 

 Resource is running in a debug mode and is 
currently stopped at a breakpoint. 

Set Cycle Time  Shows the frequency, in milliseconds, that the 
resource has been defined to run. This is the 
beginning of one execution to the beginning of the 
next execution.  

Current Cycle Time  Shows the actual execution time, in milliseconds, 
of the resource. This is from the beginning to the 
end of one execution.  

7.3 History Segment Configuration 
Select Configure > History Segments. The number of History Points 
available in each Segment is determined by the History Segment 
Configuration screen. Once the History Segment has been configured, 
you may configure the History Points in each Segment.  

Note: Assign only one station per history segment.  

 
Figure 7-100. History Segments  
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For a ROC800-Series, you can distribute history points among history 
segments 1 through 13 and the General History Segment. For each 
history segment, you can configure the number of periodic history 
values archived, the frequency of archiving the periodic values, the 
number of daily values archived, and the contract hour for each 
Segment. The number of minute values is fixed at 60. Additionally, you 
can enable or disable logging and force the logging of daily values on a 
per Segment basis. In addition, you can enable or disable logging and 
force the logging of a daily value on a per-segment basis. 
In history segments 1 through 13, the number of points in the segment is 
configurable. The maximum total number of points available for all 
history points in all segments is 240, but may be less depending on the 
number of periodic and daily values configured. The number of points 
in the general history segment is determined by the system, based on 
remaining memory. All history points in a segment share the same time 
stamps, with one time stamp allotted for each of the minute, periodic, 
and daily logs available in that segment. 
You can tie history segments 1 through 13 to meter stations by 
configuring the history segment under Meter > Setup > Station. This 
allows the history segment to inform the station when the contract hour 
has occurred so that the station can maintain daily and monthly 
accumulations, and to retrieve the appropriate flow dependency and 
flow weighting factors. This also allows the station to inform the history 
segment that a configuration parameter has changed, and therefore 
periodic values need to be logged, per API Section 21.1. 
Once you configure the history segment you can configure the points in 
each segment. 

Note: The required points for AGA3 and AGA7 calculation methods 
are not pre-configured. You should begin the configuration of an 
AGA calculated Meter Run by configuring those points.  

Field Description 
Tag  Sets a name for each segment that identifies the 

group of historical points to be archived there.  
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Field Description 
Number of Points  Sets the number of history points required for 

segments 1 through 10 for a ROC800-Series 
Series1 or 1 through 13 for a ROC800-Series 
Series 2.  
For a ROC800-Series Series 1 device, the 
maximum number of 200 points is based on 60 
minute values, 840 periodic values logged hourly 
(35 days x 24 hours per day) and 35 daily values 
for a total of 187,000 history values. Each 
Segment also has storage allotted for the time 
stamp values with a default of 935 time stamps 
per Segment (60 minute times stamps + 840 
periodic time stamps + 35 daily time stamps) x 11 
Segments for a total of 10,285 time stamp values. 
The 197,285 Available Space shown on the 
ROCLINK 800 History Segment Configuration 
screen indicates the total of history and time 
stamp values. 

Space Allocated = (Number of Points + 1) 
x (Minute Entries + Periodic Entries + 
Daily Entries) 

For a ROC800-Series Series 2 device, the 
maximum number of 240 points is based on 60 
minute values, 840 periodic values logged hourly 
(35 days x 24 hours per day) and 35 daily values 
for a total of 187,000 history values. Each 
Segment also has storage allotted for the time 
stamp values with a default of 935 time stamps 
per Segment (60 minute times stamps + 840 
periodic time stamps + 35 daily time stamps) x 14 
Segments for a total of 13,090 time stamp values. 
The 197,285 Available Space shown on the 
ROCLINK 800 History Segment Configuration 
screen indicates the total of history and time 
stamp values.  

Space Allocated = (Number of Points + 1) 
x (Minute Entries + Periodic Entries + 
Daily Entries) 

Minute Entries  This read-only field displays the number of entries 
in the minute log for this segment.  

Periodic Entries  Sets the desired number of points in the Periodic 
(hourly) log. The Number of Entries (in the 
Periodic log) multiplied by the Periodic Sample 
Rate (minutes) will give the number of minutes 
before the periodic log begins to write over itself.  

Daily Entries  Sets the desired number of Daily Entries in the 
Daily log.  

Space Allocated  This read-only field displays how many history 
and time stamp entries are currently allocated by 
this segment.  
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Field Description 
Periodic Sample 
Rate  

Setss the Periodic Sample Rate (minutes). This 
indicates how often a time-stamped value will be 
written to the Periodic Log. If this Segment is tied 
to a meter Station, an entry will also be written 
whenever a configuration change is made to a 
Station or meter that is part of that Station. All 
options for Periodic Sample Rates are evenly 
distributed into 60, and logging will be 
synchronized with the top of the hour.  

Contract Hour  Sets the time when the daily values are logged. If 
this segment is tied to a meter station, this will also 
be the Contract Hour for the station and will be 
the time that daily and monthly (if it is the first of 
the month) accumulations will be reset. Additional 
entries will be made if Force End of Day is 
exercised for this segment.  

Logging  Sets to enable or disable logging for all history 
points in the segment. Select User to indicate that 
the segment if for user program history.  

User Flow Weight Sets the input point from which to acquire the 
weight by which history points of the appropriate 
archive type within this segment will be averaged. 
This is typically a dynamic value, such as an 
accumulator or flowrate. 
Notes:   
 This field applies only to liquid meters. 

Typical gas meter run history configurations 
do not make use of this feature. 

 When using the Liquid Meter history 
configuration wizard for the ROC800L, this 
field will be automatically populated. 

 Only history points with an Archive Type of 
Avg - User Weighted are averaged using this 
value. If no history points are configured or 
planned to be configured with this archive 
type, the User Flow Weight selection should 
be left undefined. 

Force End of Day  Sets each segment to force logging of entries in 
the daily log for all history points in the segment.  

Available Space  This read-only field shows the total number of 
history and time stamp entries possible. The 
maximum number of entries is 236,555.  

Total Space 
Allocated  

This read-only field shows the number of history 
and time stamp entries allocated to all the 
segments.  

Available Space to 
Allocate  

This read-only field shows the number of entries 
unallocated. This number is the Available Space 
minus the Space Allocated.  
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7.4 History Point Configuration 
The History options allow you to copy and store to the historical 
database data values and calculated variables stored in the current value 
database. You configure the historical database to log only the values 
that need to be logged. The system logs values in the standard (minute, 
hourly, daily) time base of the ROC, unless you use FST control. By 
using the FST Editor utility, you can use an FST to control the period 
under which the data is logged.   

Note:   
 Configure the History Points for each meter run to allow the EFM 

Report utility to properly access data. 
 Configure gas meter history in segments 1-12 so that a segment 

number corresponds to a station number (that is, meter history for 
station 1 is in segment 1, and so on). This allows configuration 
changes to trigger archive records in accordance with API 2.1 
guidelines.  

Field Description 
Archive Type  Sets the Archive Type to specify how the logged 

value is calculated; included are some special 
purpose types for FST control.  
 Disabled/ Undefined – Point not configured. 
 Avg – Flow Dependant Linear – Discards 

samples when there is no measurable flow and 
performs a straightforward (linear) average of 
the remaining samples to compute the minute 
and hour values. This is the default method for 
calculating the average for the flow input and is 
the simplest and most commonly used method. 
 
For differential meters with analog input values, 
no flow conditions are defined as the differential 
pressure meter input less than or equal to the 
Low Flow Cutoff. 
 
For pulse meters with a pulse input values, no 
flow conditions are defined as the no flow time 
elapsing without receiving a pulse. A linear 
average of all samples is performed if there is no 
flow during the logging period. 

 Avg – Flow Dependant Formulaic – Discards 
samples for periods when there is no flow (like 
the Flow-Dependent Linear method), but when 
calculating the average, this method typically 
takes the square root of each sample before 
averaging the samples together and then 
squares the result. This formulaic method 
typically produces a slightly lower value than the 
linear method. 

 Avg – Flow Weighted Linear – Determines a 
relative "weight" for each sample (without 
discarding any samples) by first multiplying the 
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Field Description 
sample by a flow value (see below) and then 
calculates a linear average by dividing the sum 
of the flow-weighted sample by the sum of the 
flow values. This results in minute and hourly 
values that are more reflective of short periods 
of high flow. 
Note:  The flow value used when calculating the 
relative weight for each sample is based on your 
meter type: 
DP Meter = Square root of the differential 
pressure measured during the sample period 
Turbine/Auto-Adjust Meter = Uncorrected 
volume flow rate measured during the sample 
period 
Coriolis Meter = Mass flow rate measured 
during the sample period  

 Avg – Flow Weighted Formulaic – Combines 
the flow-weighting action with the formulaic 
averaging technique, both of which were 
described previously. 

 Avg – User Weighted – Other flow weighted 
averaging archive types will weigh values 
against the gas flow from the associated gas 
meter run.Ave – User Weighted allows for the 
creation of flow weighted averages using any 
arbitrary user selected input point as the 
weighting factor. This technique multiplies a 
one-second sample of the configured User Flow 
Weight TLP (Configure>History Segments) by a 
one-second sample of the value and then 
divides the answer by the total accumulation 
over the time period (minute, hour or 
day).History points using this method will have a 
value of zero if no flow is accumulated during 
the time period, and therefore no weight. 
Note: This archive type is used only with liquid 

meters.Typical gas meter run history 
configurations do not make use of this 
feature. 

 Avg – Linear – Averages one-second samples 
to compute minute, periodic, and daily values. 

 Accumulate/Second – Sums one-second 
samples of a per second rate value over the 
logging interval to compute the archived value. 
Select this archive type when the History Point 
being archived is a rate in EUs/second. 

 Accumulate/Minute – Converts the one-second 
samples of a per minute rate value to a per 
second rate and sums them over the logging 
interval to compute the archived value. Select 
this archive type when the History Point being 
archived is a rate in EUs/minute. 

 Accumulate/Hour – Converts the one-second 
samples of a per hour rate value to a per second 
rate and sums them over the logging interval to 
compute the archived value. Select this archive 
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Field Description 
type when the History Point being archived is a 
rate in EUs/hour. 

 Accumulate/Day – Converts the one-second 
samples of a per day rate value to a per second 
rate and sums them over the logging interval to 
compute the archived value. Select this archive 
type when the History Point being archived is a 
rate in EUs/day. 
 

 Current Value – Logs a snapshot of the current 
sampled value. 

 Totalize – Logs the difference between the 
current value at the end of the period and the 
current value at the last logging interval.   

 Minimum Value – Archive the minimum value 
read. 

 Maximum Value – Archive the maximum value 
read. 

 FST Time - Minute – Allocates space for the 
FST to write time-stamps to the periodic archive 
using the WTM command.  
Note:  The number of periodic entries in the 

segment determines the number of time-
stamps that can be written. The value 
takes the format MM: DD: HH:MM. The 
FST determines which index in the 
periodic archive to write to independently 
of the current index for the segment. 

 FST Time - Second – Allocates space for the 
FST to write time-stamps to the periodic archive 
using the WTM command. 
Note:  The number of periodic entries in the 

segment determines the number of time-
stamps that can be written. The value 
takes the format DD: HH:MM:SS. The 
FST determines which index in the 
periodic archive to write to independently 
of the current index for the segment. 

 FST Data – Allocates space for the FST to write 
values to the periodic archive using the WDB 
command. 
Note:  The number of periodic entries in the 

segment determines the number of 
values that can be written. The FST 
determines which index in the periodic 
archive to write to independently of the 
segment’s current index. 

 User Program Time – This Archive Type should 
only be used as instructed in the respective user 
program documentation.  

 User Program Data – This Archive Type should 
only be used as instructed in the respective user 
program documentation.  
 
You may enter a User Description of the 
selected Archive Point for identification 
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Field Description 
purposes.  
 
Once you have determined what archive type to 
use, set the archive point by clicking the TLP 
Browse button that displays at the right-hand 
side of each Archive Point field. This displays a 
Select TLP dialog you use to configure the 
associated TLP.  

Archive Point  Sets the point to enter in history. Click the TLP 
Browse button to display a Select TLP dialog you 
use to define the point type, logical number, and 
parameter to be archived.  

Point Tag  This read-only field displays the name of the Tag 
associated with the Archive Point you selected.  

User Description  Sets a description of the history point that you are 
storing. For example, you may enter Units or 
Engineering Units.  

Current Value  This read-only field shows the last historical value 
recorded.  

Last Daily Value  This read-only field shows the last daily historical 
value recorded.  

7.4.1 History  
The Configure > History Points option allows you to setup the History 
Points for any numeric parameter in the ROC to archive and to select 
which archiving method to use for each parameter.  

 
Figure 7-101. History Segment Point Configuration – General tab  
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The historical database can be configured to log only the values that you 
require to be logged. The values are logged in the standard (minute-
hourly-periodic-daily) time base of the ROC, unless FST control is 
used. By using the FST Editor utility, the period at which the data is 
logged can be placed under FST program control. Periodic history can 
be configured for 1 to 6 minutes, 10 minutes, 15 minutes, 30 minutes, or 
in 60-minute frequencies. 
The ROC maintains the following types of historical databases: 
 Minimum/Maximum (Min/Max) Database. 
 Minute Database. 
 Periodic (Hourly) Database. 
 Hourly Database. 
 Daily Database. 

The Min/Max Database is for viewing only and cannot be saved to a 
disk file. 

Note: The time stamp used for standard logging of historical values 
reflects the time at the end of the period, not at the beginning. 
For example, data collected from 8:00 to 9:00 is time-stamped 
9:00. 

History values can be collected from the ROC via ROCLINK 800 or 
other third-party host systems. From the View > History selection, you 
can view history directly from the device or from a previously saved 
disk file. 
The required History Points for AGA3 and AGA7 calculation methods 
are not pre-configured. You should begin the configuration of an AGA 
calculated Meter Run by configuring those points. Make sure that the 
History Points for each Meter Run are configured to allow the EFM 
Report utility to properly access data.  
Several options are available for the type of history values archived 
(Archive Type). Linear averaging is available for all parameters. Meter 
run and Station parameters may be averaged using one of the four 
averaging techniques recommended in API Section 21.1 (flow 
dependent linear, flow dependent formulaic, flow weighted linear, and 
flow weighted formulaic). 
Parameters that represent a rate (engineering units/time period) may be 
accumulated (integrated) to give total values when the time period of the 
rate is specified. Parameters that represent an accumulated total can be 
totalized to give total values by taking the difference between the value 
at the end of the current logging period and the value at the end of the 
previous logging period. Finally, the current value of any parameter can 
be logged at the end of each logging period. 
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Note: In previous products, the totalize Archive Type was intended to 
be used for parameters that return to zero at contract hour. The 
Totalize Archive Type is intended to be used for parameters that 
represent on-going accumulators. 
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Field Description 
Archive Type  Sets the Archive Type to specify how the logged 

value is calculated; included are some special 
purpose types for FST control.  
 Disabled/ Undefined – Point not configured. 
 Avg – Flow Dependant Linear – Discards 

samples when there is no measurable flow 
and performs a straightforward (linear) 
average of the remaining samples to compute 
the minute and hour values. This is the default 
method for calculating the average for the flow 
input and is the simplest and most commonly 
used method. 
 
For differential meters with analog input 
values, no flow conditions are defined as the 
differential pressure meter input less than or 
equal to the Low Flow Cutoff. 
 
For pulse meters with a pulse input values, no 
flow conditions are defined as the no flow time 
elapsing without receiving a pulse. A linear 
average of all samples is performed if there is 
no flow during the logging period. 

 Avg – Flow Dependant Formulaic – 
Discards samples for periods when there is no 
flow (like the Flow-Dependent Linear method), 
but when calculating the average, this method 
typically takes the square root of each sample 
before averaging the samples together and 
then squares the result. This formulaic method 
typically produces a slightly lower value than 
the linear method. 

 Avg – Flow Weighted Linear – Determines a 
relative "weight" for each sample (without 
discarding any samples) by first multiplying the 
sample by a flow value (square root of the 
differential pressure measured during the 
sample period) and then calculates a linear 
average by dividing the sum of the flow-
weighted sample by the sum of the flow 
values. This results in minute and hourly 
values that are more reflective of short periods 
of high flow. 

 Avg – Flow Weighted Formulaic – 
Combines the flow-weighting action with the 
formulaic averaging technique, both of which 
were described previously. 

 Avg – Linear – Averages one-second 
samples to compute minute, periodic, and 
daily values. 

 Accumulate/Second – Sums one-second 
samples of a per second rate value over the 
logging interval to compute the archived value. 
Select this archive type when the History Point 
being archived is a rate in EUs/second. 

 Accumulate/Minute – Converts the one-
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Field Description 
second samples of a per minute rate value to 
a per second rate and sums them over the 
logging interval to compute the archived value. 
Select this archive type when the History Point 
being archived is a rate in EUs/minute. 

 Accumulate/Hour – Converts the one-second 
samples of a per hour rate value to a per 
second rate and sums them over the logging 
interval to compute the archived value. Select 
this archive type when the History Point being 
archived is a rate in EUs/hour. 

 Accumulate/Day – Converts the one-second 
samples of a per day rate value to a per 
second rate and sums them over the logging 
interval to compute the archived value. Select 
this archive type when the History Point being 
archived is a rate in EUs/day. 

 Current Value – Logs a snapshot of the 
current sampled value. 

 Totalize – Logs the difference between the 
current value at the end of the period and the 
current value at the last logging interval.   

 Minimum Value – Archive the minimum value 
read. 

 Maximum Value – Archive the maximum 
value read. 

 FST Time - Minute – Allocates space for the 
FST to write time-stamps to the periodic 
archive using the WTM command. Note:  The 
number of periodic entries in the segment 
determines the number of time-stamps that 
can be written. The value takes the format 
MM: DD: HH:MM. The FST determines which 
index in the periodic archive to write to 
independently of the current index for the 
segment. 

 FST Time - Second – Allocates space for the 
FST to write time-stamps to the periodic 
archive using the WTM command. 

Note:  The number of periodic entries in 
the segment determines the number of 
time-stamps that can be written. The value 
takes the format DD: HH:MM:SS. The FST 
determines which index in the periodic 
archive to write to independently of the 
current index for the segment. 

 FST Data – Allocates space for the FST to 
write values to the periodic archive using the 
WDB command. 

Note:  The number of periodic entries in 
the segment determines the number of 
values that can be written. The FST 
determines which index in the periodic 
archive to write to independently of the 
segment’s current index. 

 User Program Time – This Archive Type 
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Field Description 
should only be used as instructed in the 
respective user program documentation.  

 User Program Data – This Archive Type 
should only be used as instructed in the 
respective user program documentation.  
 
You may enter a User Description of the 
selected Archive Point for identification 
purposes.  
 
Once you have determined what archive type 
to use, set the archive point by clicking the 
TLP button that displays at the right-hand side 
of each Archive Point field. This displays a 
Select TLP dialog you use to configure the 
associated TLP.  

Archive Point  Sets the point to enter in history. Click the TLP 
Browse button to display a Select TLP dialog you 
use to define the point type, logical number, and 
parameter to be archived.  

Point Tag  This read-only field shows the name of the Tag 
associated with the Archive Point you selected.  

User Description  Sets a description of the history point that you are 
storing. For example, you may enter Units or 
Engineering Units.  

Current Value  This read-only field shows the last historical value 
recorded.  

Last Daily Value  This read-only field shows the last daily historical 
value recorded.  

7.4.2 History Wizard 
Use the Gas Meter History Wizard to define up to 240 standard history 
points for a Series 2 ROC800. 

Note: For linear meter runs, the gas history wizard configures the 
single precision point type 116,x,31. If you require additional 
resolution, you can replace that point type with the double 
precision point type 116,x,44. 

1. Select Configure > History Points. When the History Segment Point 
Configuration screen displays, click Gas Wizard. The Gas Meter 
History Configuration Wizard screen displays. 

2. Click ▼ in the Select Meter to select the meter to configure. 
3. Select the Starting History where you desire to store the history data. 
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Figure 7-102. History Point Configuration  

4. Click the Create History button and a confirmation message displays. 

 
5. Click Yes and the associated Archive Points display in the History 

Wizard screen. 
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Figure 7-103. Gas Meter History Wizard- Create History Completed 

6. Click Close. 

7.4.3 Undefining a Gas History Point 
To undefine a history point:  

1. Select Configure > History Points. When the History Segment Point 
Configuration screen displays, click Wizard. The Meter History 
Configuration Wizard screen displays. 

2. Select the point to delete. 
3. Click Undefine History. 
4. Click Yes in the confirmation prompt. 

7.5 Opcode Table 
Use the Opcode table to group data being polled for more efficient 
communications. You can assign parameters from different point types 
to the Opcode table data points, which can substantially reduce the 
number of polls from a host computer.  

Note: Use of the term “opcode” in this context does not refer to the 
operator identification codes in ROC protocols. 

1. Select Configure > Opcode Table. The Opcode Table Settings screen 
displays. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

7-186 Configure Menu Revised February 2024 

2. Review the fields for your organization’s values. 
3. Click Apply if you change any parameters on this screen. 

 

Figure 7-104. Opcode Table Settings  

Field Description 
Table No.  Selects an Opcode table.  

Version No.  Associates a version number with the Opcode 
table. By default, the version number (a floating 
point number) is one less than the number of the 
Opcode table.  
Note:  If you change the configuration of data 

points, update the version number of the 
table. 

Data  Assigns a value to each Opcode data point. Click 
the TLP Browse button to display a Select TLP 
dialog. Use the dialog to map values into the 
Opcode table data point. If a host computer asks 
for a specific Opcode data point, the ROC returns 
the value that is referred by the mapped TLP.  

7.6 Modbus Communications 
This section describes how to configure the ROC to communicate using 
the Modbus protocol and integrate the ROC and Modbus devices into 
the same host/slave system.  
The ROC800-Series can act as a slave or a host device and does not 
require a user program. 
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The Modbus Master mode of operation, which is enabled by selecting 
the correct port owner designation in the ROC > Comm Ports screen, 
allows the ROC800-Series to simulate a Master device that can poll 
other Modbus devices for data and stores the data in TLP locations 
within the ROC800-Series. The TLPs can be virtually any location 
within the ROC, such as softpoints, FST Registers, User Program TLPs, 
and point types (AGA or I/O). You can map Modbus Registers to any 
TLP with the correct data types and conversions configurations. 
The ROC800-Series can also send commands to set outputs and write 
data to a Slave device. COMM1, COMM2, COMM3, COMM4, and 
COMM5 support Modbus Host in the ROC800-Series. Modbus Host is 
not supported on the LOI (Local Port). For more information on 
Modbus Master configuration and functionality, refer to the discussion 
of the Modbus Master Table tab. 
In Slave mode, the data link between the Host device and the ROC800-
Series can use any of the communications ports. When using a dialup 
modem, you can only designate communications to switch between 
ROC or Modbus Slave. The Ethernet port can always recognize Modbus 
messages. The system limits Modbus TCP/IP slave connections to six.  

Note: For more information about Modbus communications on the 
Ethernet port, refer to Chapter 3, Section 3.4.1, Configuring 
TCP/IP Communications on the Ethernet Port. 

Any serial or modem communications port configured with a Port 
Owner of ROC Plus Protocol/Modbus Slave (ROC > Comm Ports) 
automatically determines if the incoming communication request is in 
ROC Protocol or Modbus Protocol. The ROC responds using the same 
protocol as the incoming request. 
The Ethernet communications port automatically determines if the 
incoming communications request is in ROC Protocol, Modbus RTU 
encapsulated in TCP/IP, or Modbus TCP/IP Protocol. The ROC 
responds using the same protocol as the incoming request. 

7.6.1 Modbus Configuration 
Use this option to set basic Modbus communication parameters. The 
General tab sets the basic communication parameters. The Scale Values 
tab allows you to enter eight low and high floating-point scale values 
with one low and high integer values for converting floating-point 
numbers to a scaled integer. Select Configure > MODBUS. The 
Modbus Configuration screen displays. 
Use the following tabs to configure a Modbus component.  
 Use the General tab to configure Modbus communication 

parameters. 
 Use the Scale Values tab to convert floating point numbers to scaled 

integers. 
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 Use the Master Table tab to map Modbus registers to specific TLP 
numbers.  

 Use the Master Modem tab to configure the ROC to communicate 
to multiple Slave devices through modems and phone lines. 

 Use the Registers tab to map Modbus registers to specific TLP 
numbers.  

 Use the History Table tab to configure the Periodic and Daily 
history values, Event records, and Alarm records for retrieval 
through Modbus Protocol, using Function Code 03.  

Note: After you configure a point and click Apply, click Flash 
Memory Save Configuration (on the ROC > Flags screen) to 
save the configuration to permanent memory in case you must 
perform a cold start. 

Modbus: General Tab 
The Modbus Configuration screen initially displays the General tab. Use 
this tab to configure basic Modbus communication parameters.  

1. Select Configure > MODBUS. The Modbus Configuration screen 
displays. 

2. Review the fields for your organization’s values. 

Note: This screen initially displays with Local Port as the default 
comm port. The example screen uses the RS-485 choice so that 
all the possible fields on this screen display. 
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Figure 7-105. Modbus Configuration – General tab  

Field Description 
Comm Port  Selects a comm port to configure. Click ▼ to 

display all defined comm ports.  
Note:  This screen’s Master Mode frame does not 

display if you select either Local Port or 
LCD Port as a comm port option. 
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Field Description 
Comm Mode and 
Modbus Type 

Sets the communications mode for the selected 
comm port. The Modbus protocol supports two 
modes of transmission, ASCII and RTU. RTU is 
the default.  
Note:  You must configure all devices in the same 

communications network with the same 
mode of transmission. Additionally, In either 
ASCII or RTU mode, the transmitting 
device places the Modbus message into a 
frame that has a known beginning and 
ending point. 

 ASCII – American Standard Code for 
Information Interchange mode represents 
each 8-bit byte of data as two ASCII 
characters that are the hexadecimal 
representation of the value. This allows the 
messages to be read with the use of a dumb 
terminal, but uses twice as many characters 
as the RTU mode. Each character sent is 
composed of a start bit, 7 or 8 data bits, and 
one or two stop bits with Even, Odd, or No 
parity. ASCII mode uses Longitudinal 
Redundancy Checking (LRC) error checking. 

 RTU – Remote Terminal Unit mode allows for 
greater character density and better data 
throughput than ASCII for the same baud rate. 
Each message is transmitted in a continuous 
stream. Data is sent in 8-bit binary characters. 
RTU mode uses Cyclic Redundancy Check 
(CRC) error checking. By default, RTU is 
enabled. 

In either mode, ASCII or RTU, a Modbus message 
is placed by the transmitting device into a frame 
that has a known beginning and ending point. 
 

ASCII Message Framing 
Begin of 
Frame 

Address Function Data LRC Error 
Check 

End 

: 2 Chars 2 Chars N Chars 2 Chars CRLF 
RTU Message Framing 
Begin of 
Frame 

Address Function Data CRC Error 
Check 

End 

T1-T2- 
T3-T4 

1 Byte 1 Byte N * 1 Byte 2 Bytes T1-T2- 
T3-T4 

Byte Order Sets the order of data bytes in a transmission or 
requests, which can be reversed. This only affects 
the Data field of a Modbus message and has no 
effect on the data bytes for Function Codes 01, 02, 
and 05. Valid values are Least Significant Byte 
First (places the Least Significant Byte first; this is 
the default value) and Most Significant Byte First 
(places the Most Significant Byte first).  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Configure Menu 7-191 

Field Description 
Exception Status  This read-only field shows the error message for 

the last Modbus message received.  
Note:  This field applies only in Slave mode. 

Event Logging  Sets whether the system writes to the Event log all 
parameter changes made via Modbus. Valid 
values are Enabled (logs all events) or Disabled 
(does not log events). Enabled is the default.  

Start Polling  Controls whether the system begins a Modbus 
Master polling sequence. The default is off. The 
system clears this field when the polling sequence 
completes.  
Note:  You must have previously selected 

Modbus Master as the port owner on the 
Comm Port screen (ROC > Comm Ports). 
The ROC begins polling at the value 
defined in the Starting Request field and 
proceeds through the entries in the table. 

Starting Request  Sets a beginning value from which the Modbus 
Master polling sequence begins. This number 
corresponds to a line number on the Modbus 
Master Table associated with this comm port.  

Number of 
Requests  

Sets the total number of requests the Modbus 
Master makes for this polling sequence. This value 
specifies the total number of lines in the Master 
tables on which to execute the polls. The default 
value 0 prevents the polling from occurring.  
Note:  You can define up to three Modbus Master 

tables for this comm port. The tables are 
contiguous. If you indicate more requests 
that are on a single table, the system 
accesses the second or third table to 
complete the request. 

Timeout  Sets the amount of time, in seconds, that the 
Master (Host) waits to receive a valid message 
after the ROC or sends a request to a device.  
Note:  Do not enter 0 (zero) in this field. 

Retries  Sets the number of times (after the initial try) that 
the Master ROC attempts to establish 
communications with the specified device before 
reporting a timeout error. Valid values are between 
0 and 25; the default is 2.  

Modbus Continuous 
Polling  

Indicates whether the system continually executes 
the Modbus Master polling sequence. Valid values 
are Enabled (polling occurs continually) or 
Disabled (polling occurs only as requested).  
Note:  Use the Request Delay field to schedule 

the continual polling. 
Request Delay  Sets a delay time, in seconds, between polling 

request sequences. This field is valid only when 
you enable Continuous Polling.  
Note:  The system considers each line in a 

Modbus Master Table as a request. 
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Modbus: Scale Values Tab 
Use the Scale Values tab to define eight low and high floating-point 
scale values, each with a low and high integer values, used to convert 
floating-point numbers to a scaled integer.  
The system uses integer scale values and the float scale values in 
conjunction with one another whenever you use the Convert Code 1 
through 8. In older Modbus devices, the system exchanged data without 
applying scaling using raw A/D counts sent between devices. 
Scaling factors allow values to be exchanged between Modbus, 
emulating raw, unscaled values. For example, a 4 to 20 mA loop might 
have a raw A/D value in which 4 mA equaled 800 counts and 20 mA 
equaled 4095 counts. At midrange (12 mA), the raw A/D count would 
be 2448. If this AI signal was representative of a 0 to 250 pound 
pressure, 4 mA would equal 800 counts (or 0 PSIG), 20 mA would 
equal 4095 counts (or 250 PSIG), and midrange at 12 mA would equal 
2448 counts (or 125 PSIG). 
Convert Codes 1 to 8 support both reads and writes.  
 Select Configure > MODBUS > Scale Values tab. The Scale 

Values screen displays. 

 
Figure 7-106. Modbus Configuration – Scale Values tab  
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Field Description 
Integer Scale - Low 
and High Values  

Sets values the system uses to scale analog I/O to 
integer values with an implied decimal point. The 
Low Value determines the low integer scaling that 
represents the data and the High Value 
represents the highest integer value used to scale 
the data.  
The High Value and Low Value fields are signed 
integers and can range from – 32768 to 32767. 

Float Scale # Scales data in conjunction with the Low and High 
Integer Scale values. Provide high and low values 
for each float scale #.  
For host systems that do not accept floating-point 
numbers, you can specify eight sets of floating-
point ranges for values. This allows the host to 
read and set floating-point values (such as PID 
setpoints, softpoint values, and flow values) as 
integer values. 
The system converts floating-point values to 
integers by configuring a register or range of 
registers with the Conversion field set in the 
Modbus Registers definition configuration to a 
Convert Code from 1 to 8. 

The system uses the following equations to convert floating point values 
to integers: 
 Float Range = High Value Float Scale – Low Value 
 Float Scale (for example, 100.0 = 120.0 – 20.0) 
 Integer Range = High Value Integer Scale – Low Value Integer Scale 

(for example, 6000 = 7000 – 1000) 
 Adjusted Reading = Float Reading – Low Value Float Scale (for 

example, 50.0 = 70.0 – 20.0) 
 Integer = [(Integer Range x Adjusted Reading) Float Range] + Low 

Integer Scale (for example, 3500 = [(6000 x 50.0) 100.0] + 1000) 
The system uses the following equations to convert integers to floating 
point values: 
 Float Range = High Value Float Scale – Low Value 
 Float Scale (for example, 100.0 = 120.0 – 20.0) 
 Integer Range = High Value Integer Scale – Low Value Integer Scale 

(for example, 6000 = 7000 – 1000) 
 Adjusted Integer = Integer Sent – Low Value Integer 
 Scale (for example, 3000 = 4000 – 1000) 
 Float Value = [(Adjusted Integer x Float Range) Integer Range] + Low 

Float Scale (for example, 70.0 = [(3000 x 100) 6000] + 20) 

Modbus: Master Table Tab  
The Modbus Master mode of operation allows a ROC to simulate a 
master device that can poll other devices for data and to store that data 
within the ROC in any valid TLP. The ROC can also send commands to 
set outputs and write data to a slave device.  
You can configure the Modbus Master functionality on the EIA-232 
(RS-232), EIA-485 (RS-485), Ethernet (COMM1) and modem 
communications ports (COMM2 to COMM5). 
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Each command can transmit or receive up to 240 bytes of data. 
ROCLINK 800 supports Modbus function codes 1, 2, 3, 4, 5, 6, 15, and 
16. Function codes 1 to 4 request data from slaves, while function 
codes 5, 6, 15, and 16 transmit data to a slave device. 
Each master request you configure uses data read from or written to 
registers defined in the Modbus Registers table. When using Modbus 
function codes 1 to 4, the ROC reads data from a slave device and 
writes it to the TLP specified in the Modbus Registers table. When 
using Modbus function codes 5, 6, 15, and 16, the ROC reads data from 
the TLP specified in the Modbus Registers table and writes it to the 
slave device. 
You can use an FST or User C program to schedule Modbus master 
requests. Enable the comm port on the Comm Port screen (ROC > 
Comm Ports). Set the Start Polling option on the Modbus General 
screen (Configure > MODBUS > General) if continuous polling is 
desired. Alternately, you can manage, enable, or disable master polling 
using a control application. Using FSTs, the ROC can dial other 
Modbus slave devices at regular intervals.  
Select Configure > MODBUS > Master Table tab. The Master Tables 
screen displays. 

 
Figure 7-107. Modbus Configuration - Master Table  
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Field Description 
Logical Point  Sets the logical point of the communication port.  

Note:  You can configure the Modbus Master 
functionality on the EIA-232 (RS-232), EIA-
485 (RS-485), and modem communications 
ports (COMM1 to COMM5). The LOI (Local 
Port) port does not support Modbus Master 
communications.  

Tag  Sets a 10-character alphanumeric identifier for the 
master table.  

Modbus Format Sets the format of Modbus messages sent from 
this device. Possible options are: 
Note:  This field displays only if you select the 

Ethernet port in the Comm Port drop-down 
list.  

 TCP Adds a 6 byte header to Modbus 
messages, and then encapsulates 
it for transmission over TCP/IP. 
This is the default. The header 
consists of the following: 
 A 2 byte transaction ID that 

increments for each packet 
sent. 

 A 2 byte protocol ID. The 
protocol ID for Modbus is 0. 

 A 2 byte indicator of the packet 
length. 

 Standard 
Wrapped 

Encapsulates Modbus messages 
for transmission over TCP/IP. 
Note:  Use this option only with 

legacy devices that do not 
support the additional 
header added with the TCP 
format. 

Server IP Address Specifies the IP address of the device to be polled. 
Note:  This field displays only if you select the 

Ethernet port in the Comm Port drop-down 
list. 

Server Port Number Specifies the IP port number of the device to be 
polled. 
Note:  This field displays only if you select the 

Ethernet port in the Comm Port drop-down 
list. 

RTU Address  Sets the RTU address for the slave device to be 
queried.  

Function Code  Sets the Modbus function code to be sent to the 
slave device. Select the field and click ▼ to 
display all valid function codes.  

Slave Registers  Sets the starting register number from which data 
is drawn from the slave device.  

Master Registers  Sets the starting register number into which data is 
stored on the master device.  
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Field Description 
Number of 
Registers  

Sets the total number of registers to poll.  

Comm Status  This read-only field shows the status of the query. 
Refer to Table 7-3.  

Table 7-3. Status of Host Request or Command 

Status Description 
0 Inactive or Start of Transmission 
1 Receive Timeout Error 
2 Received Address Check 
3 Received Function Number Check 
4 Number of expected bytes Check 
5 Receiving Slave Response 
6 CRC or LRC Check 
7 CRC or LRC Check 
8 Valid Slave Response 

128 Write Device Data Error 
129 Access Device Data Error 
130 Host Function Table Error 
131 Transmit Timeout Error 
144 Transmit or Receive Buffer Overflow 
145 Invalid Function Number in Request 

Modbus: Master Modem Tab 
Select Configure > MODBUS > Master Modem tab to display the 
Master Modem screen. As a Modbus Master, the ROC may have to 
communicate to multiple slave devices through modems and phone 
lines. The Modbus Master Modem screen provides the necessary 
parameters to configure the modems and map RTU Addresses to phone 
numbers.  
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Figure 7-108. Modbus Configuration - Master Modem tab  

Field Description 
Tag  Sets a 10-character identifier for the master 

modem.  
Corresponding 
Comm Port  

Sets the communications port with which to 
associate the master modem port.  

RTU Address  Sets the RTU Address of the slave device to be 
associated with the Connect Command. Up to six 
different Modbus slave devices can be dialed up 
through one communications port.  

Connect Command  Sets the Connect Command (telephone number) 
to be sent to the slave device.  

Only COMM2 to COMM5 support Modbus Master functionality; the 
LOI (Local Port) and COMM1 (Ethernet) port do not. 
This communications point associates a Modbus Slave RTU Address to 
their respective phone numbers (Connect Command). Up to six different 
Modbus slaves can be dialed up through one communications port. The 
ROC retries three times to establish a connection with a slave.  

Configuring a 
Modbus Host 

To configure a Modbus host:  
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Note:  The steps outlined below assume that you are connecting to the 
module using a serial connection. If you are using an Ethernet 
connection, you may skip Steps 1 to 5 and proceed directly to 
Step 6.  

1. Select ROC > Comm Ports. The Comm Port General tab screen 
displays.  

  
Figure 7-109. Comm Port, General tab 

2. Select the appropriate communications port from the drop down list at 
the top of the screen.  

3. Configure the appropriate parameters (Baud Rate, Parity, Data Bits, 
Stop Bit and Key On/Off Delay) for the port.  

4. Select Modbus Master in the Port Owner section.  
5. Click Apply to save the settings and click OK to close the screen.   
6. Select Configure > MODBUS. The Modbus Configuration screen 

displays.  
7. Select the appropriate communications port from the drop down list 

at the top of the screen.  
8. Select the Registers tab and define the Modbus Registers within the 

host by mapping them to TLPs. These Modbus Registers will “hold” 
the information that the host will transmit and receive. The selection 
of Register numbers in the host is arbitrary and is user-defined.  
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Figure 7-110. Modbus Configuration, Registers tab 

9. When you complete the mapping, click Apply to save the settings 
and click OK to close the screen. 

10. On the Modbus Configuration Screen, select the Master Table tab. 
Select the appropriate comm port from the drop down list at the top of 
the screen.  
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Figure 7-111. Modbus Configuration, Master Table tab 

11. Define the polling sequence, Modbus devices (RTU addresses), slave 
registers, and Master Registers (Host). In the case of an Ethernet 
connection, enter the IP address and port number of the slave device 
for each set of registers.  

12. When configuration is complete, click Apply to save the changes. 
13. Still on the Modbus Configuration screen, select the General tab. 

Select the appropriate comm port from the drop down list at the top of 
the screen.   
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Figure 7-112. Modbus Configuration, General tab 

14. Match the configuration of the Modbus protocol settings (Byte order 
and Comm Mode) with the Modbus device(s) to be polled.  

15. If the selected comm port provides Modbus master functionality, a 
Master Mode section will be visible. Within this section, configure 
appropriate values for the starting request, number of requests, 
timeout, retries, and request delay. Apply the changes.  

16. When ready to initiate polling, tick the Start Polling check box and 
select the Enabled option under the Continuous Polling section.  

17. Click Apply to save the changes and click OK to close the screen. 

Modbus: Registers Tab 
Use Modbus Register tables to map Modbus registers to specific TLP 
numbers. You can map one line in the Modbus Register table to more 
than one register or TLP pair by using either Point Indexing or 
Parameter Indexing.  
 Point Indexing maps the starting register to the selected TLP. 

Subsequent registers (through the ending register) map to the same 
point type and parameter and increment the point logical number. 

 Parameter Indexing maps the starting register to the selected TLP. 
Subsequent registers, (through the ending register) map to the same 
point type and point logical number and increment the parameter 
number. 
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Point Indexing Example 
When using Point Indexing the configuration of:  

Starting Register Ending Register Device Parameter(s) Indexing Conversion 
100 103 AIN, 4-1, EU Point 0 

specifies four registers (100, 101, 102, and 103) that are mapped to a 
group of analog input (AIN) values in engineering units (EU) starting at 
the analog input in the fourth module location, first position (4-1). 
 Register 100 = EU of AIN point in location 4-1. 
 Register 101 = EU of AIN point in location 4-2. 
 Register 102 = EU of AIN point in location 4-3. 
 Register 103 = EU of AIN point in location 4-4. 

Parameter Indexing Example 
When using Parameter Indexing the configuration of:  

Starting Register Ending Register Device Parameter(s) Indexing Conversion 
109 114 FST 1, R1 Parameter 1 

specifies six registers (109, 110, 111, 112, 113, and 114) that are 
mapped to a group of FST 1 parameters starting at FST Register 1. 
 Register 109 = Register 1 of FST Point Number 1. 
 Register 110 = Register 2 of FST Point Number 1. 
 Register 111 = Register 3 of FST Point Number 1. 
 Register 112 = Register 4 of FST Point Number 1. 
 Register 113 = Register 5 of FST Point Number 1. 
 Register 114 = Register 6 of FST Point Number 1. 
Use conversion code 1 (Float to Integer, Float Scale 1) to convert the 
floating point value to an integer before the response message returns to 
the host. Once you map a register, you can reference it in any Modbus 
request, providing the data type of the TLP is appropriate for the 
Function Code. 

Notes:  
 If the native ROC data type does not meet the requirements of the 

Modbus host device, conversion codes are available to convert the 
data to the required data type. Refer to Table 7-5. Modbus Convert 
Codes. 

 You can select to have the mapping apply to all ROC 
communication ports or on a selected port only. 

When a device receives a Modbus request, it searches for the referenced 
register(s). If it finds a register number match, it builds a response based 
on the device point type and parameter configured in the table. If the 
device cannot find a register number match, it returns an error message. 

18. Select Configure > MODBUS > Registers tab. The Modbus 
Registers screen displays. 

19. Review the fields for your organization’s values. 
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Figure 7-113. Modbus Configuration – Registers tab  

Field Description 
Table Selects a table to which you map registers.  

Each table entry can define multiple registers by 
using either Point Indexing or Parameter Indexing. 
By making the registers continuous (when the 
Start Register address of a new line is one greater 
than the End Register address of the previous 
line) you can create a continuous data table for 
Modbus Function Codes 3, 4, or 16 up to the limit 
of 240 bytes per request. This type of data table 
allows access to all its data with one request. 
Map Periodic (Hourly) or Daily History Index 
registers to the TLP for the Periodic Index (Point 
Type 124, Parameter 5) or Daily Index (Point Type 
124, Parameter 6).. 

Tag  Sets a 10-character alphanumeric identifier for this 
table.  

Modbus Function 
Codes 

Sets a Modbus function. Valid values (and 
meanings) are:  

Code Meaning Action 
01 Read Logic Coil 

Status 
Obtain current status (ON/OFF) of a group of 
logic coils (outputs). 

02 Read Discrete 
Input Status 

Obtain current status (ON/OFF) of a group of 
discrete inputs. 
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Field Description 
03 Read Output 

Registers 
(Holding) 

Obtain current binary value in one or more 
holding registers. 

04 Read Input 
Registers 

Obtain current binary value in one or more input 
registers. 

05 Force Single 
Logic Coil 

Force logic coil to a state of ON or OFF. 
Acknowledge Alarm or Event request. 

06 Preset Single 
Holding Register 

Place a specific binary value into a holding 
register. 

15 Force Multiple 
Logic Coils 

Force a series of consecutive logic output coils to 
defined ON or OFF states. 

16 Preset Multiple 
Holding 
Registers 

Place specific binary values into a series of 
consecutive holding registers. 

Start Register Sets the first data register in the address span.  
Any number from 0 to 65535 is valid. You can 
duplicate register numbers as long as you assign 
them to separate communication ports. Number 
the tables from smallest to largest. 
In certain Modbus Host devices, the register 
40101 is actually transmitted as "100". The value 
"100" should be placed in this field as the ROC 
uses the actual number sent by the Host. 
For example, the Host device requests the 
Starting Register 500 through Ending Register 
700. The Starting Register is 400 and the Ending 
Register is 700. All register numbers requested by 
the Host (500 through 700) are valid and would be 
responded to because the requested register 
numbers match or fall in between the Starting 
Register and Ending Register numbers (400 
through 700). 

End Register Sets the last register in the address span. 
Compute the value for this field by adding the total 
number of registers used to the Start Register 
number and subtracting 1.  

Device Parameter  Defines the parameter of the point types to set or 
to acquire. Be aware of the different data types 
(Character, Integer, Long, Float) and the size of 
the data types. Use the Select TLP button to 
select parameters.  
This field indicates the type of data associated 
with an address (defined by the Start Register 
through the End Register). When the host 
requests a valid range of register numbers, the 
function code tells the slave what to do and 
between which registers (Start Register through 
End Register). 
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Field Description 
Indexing  Sets a block of register values as successive 

Logical Point Numbers or Parameters without 
having to define each separately. Valid values are 
Point Indexing or Parameter Indexing.  
Point Indexing maps the Start Register to the 
selected Device Parameter. Subsequent registers, 
through the End Register, are mapped to the 
same Point Type and Parameter and increment 
the point Logical Number. 
Parameter Indexing maps the Start Register to 
the selected Device Parameter. Subsequent 
registers, through the End Register, are mapped 
to the same Point Type and point Logical Number, 
and increment the Parameter Number.  

Conversion  Sets the type of conversion performed (if any) on 
data before it is either sent to the Host or written 
to the ROC The conversions are used to allow for 
differences in data types between the Master and 
Slave devices.  
Conversion Codes affect Function Codes 3, 4, 6, 
8, and 16. 

Comm Port  Sets the comm port affected by the register.  
Register numbers should be unique for any given 
communications port. Registers may be 
duplicated, as long as they are assigned to 
separate ports. If a register number is duplicated 
within the port, the first occurrence is used. 

Modbus: History Table Tab 
Use this tab to configure the Modbus History. Select Configure > 
MODBUS > History Table tab. The History Table screen displays.  
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Figure 7-114. Modbus Configuration - History Table tab  

The Modbus History Table allows the Periodic and Daily history values, 
Event records, and Alarm records to be configured for retrieval through 
Modbus Protocol, using Function Code 03. Three registers are defined 
to retrieve the current date in the ROC, the current time in the ROC, and 
the Event/Alarm records. The Modbus History Table also allows the 
Periodic and Daily registers to be defined for up to twenty groups of 
History Points.  

Note: Before you configure the Modbus History, configure the 
Configure > History Segments and Configure > History 
Points. 

The Event Registers and Alarm Registers are Modbus Register 
Numbers used to acquire the Current Date value, Current Time value, 
and Event Log and Alarm Log. Enter registers or use the defaults. 
Using the defaults is highly recommended. The Current Date and 
Current Time values identify the current date and time from the ROC 
and may be most useful when you desire the date and time as floating 
point numbers in the format of DDMMYY and HHMM. For more 
information on the Modbus retrieval of the Event Log and Alarm Log, 
refer to Section 7.6.4, Modbus Events & Alarms.  
Select Configure > Modbus > History. Communications functionality 
allows the Periodic (Hourly) and Daily history values and Event/Alarm 
records to be retrieved through Modbus protocol using Function Code 
03.  
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Each historical record contains a time and date stamp with all history 
archives or values for which the Register Number is configured. 
The Modbus Function Code 03 and the History Archive Register are 
used to collect the archived data. Two separate Modbus registers 
indicate the current Periodic (Hourly) and Daily history index. These 
can be configured on the Modbus Registers screen as the Periodic 
(Hourly) History Index Register and the Daily History Index Register 
for the Segment being referenced (subtract 1 to get the last archived 
value). These indexes identify the current history archive at which data 
is about to be logged. 
When the ROC receives a Function Code 03 request referencing the 
Periodic History Index (commonly Register 7161) or Daily History 
Index (commonly Register 7160), the value returned is interpreted as an 
index into the specified History Log. The Host reads the indexes and 
then compares the index to the last polled history index that the Host 
maintains and decides whether to request history. 
If the Host decides to request history, the reply message contains the 
date and time stamp and historical values configured for the specified 
Register for that index. 
The response message contains two floating-point values for the time 
and date stamp of the history archive and floating point values for each 
of the defined History Points for that History Archive Register. 
The date stamp for history uses the current year and does not figure the 
number of years since 1980. For example, if the current year is 2013, 
the year (YY) for the date stamp would be 13. 
History collection is mapped on the Modbus History Table. 
Field Definition 

Current Date  Sets the register number to acquire the current 
date. The default is 7046.  

Current Time  Sets the register number to acquire the current 
time. The default is 7047.  

Events/Alarms  Sets the Modbus Register Number to acquire the 
most current Event and Alarms Log entry. The 
default is 32.  
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Field Definition 
History Index Mode  Sets the History Index Mode. Internally, the 

History Index is stored as the location in the 
historical database where the next record will be 
written, accounting for rollover based on the total 
number of records configured. It is a zero-based 
index. For example, if there are 35 daily entries 
configured, valid indexes are 0 to 34. The History 
Index Mode allows you to modify the History Index 
value and history record returned as follows:  
 EFM Extensions Mode – History Index will be 

returned as one less than the internal History 
Index, accounting for rollover (the index to the 
most recent data record written). History data 
will be returned for the index requested. For 
example, if there are 35 daily entries, valid 
indexes are 0 to 34. If the internal index is 5, 5 
represents the index where the next record will 
be written. A request for the current index will 
return 4 (one less) and a request for data at 
index 4 will return the last record written at 
index 4. 

 Override Mode 1 – History Index will be 
returned as stored internally in the historical 
database (index to the next record to be 
written) and history data values will be 
returned for the index requested. For example, 
if there are 35 daily entries, valid indexes are 0 
to 34. If the internal index is 5, 5 represents 
the index where the next record will be written. 
A request for the current index will return 5 
and the host must request data at index 4 to 
get the most recent record. 

 Override Mode 2 – History Index will be 
returned as stored internally in the historical 
database (index to the next record to be 
written), but the history values returned will be 
for one less than the index requested, 
accounting for rollover. For example, if there 
are 35 daily entries, valid indexes are 0 to 34. 
If the internal index is 5, 5 represents the 
index where the next record will be written. A 
request for the current index will return 5, but a 
request for history values at index 5 will 
actually return values at index 4. In addition, 
this mode will return history values at the last 
valid index if an index of greater than or equal 
to the number of records is requested. For 
example, if there are 35 daily entries, valid 
indexes are 0 to 34. A request for history 
values at index 35, 36, 37, and so on will 
return history values at index 34. 

Year Format Sets the reference date for time stamp conversion 
for Modbus EFM Events & Alarms.Valid values are 
1980 and 2000.  
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Table 7-4. Modbus History, Event, and Alarm Functionality 
Function 

Code Register Field Data Field Description 

05 32 – Event/Alarm 
Register 

Ignored After Events and Alarms have been returned, there 
must be an acknowledgment made so that the 
same Events and Alarms are not returned on the 
next request. 

03 703 – Daily History Daily History 
Archive Register 
Index (0 to 34) 

Response contains two floating point values for the 
time and date stamp of the history archive (time 
stamp = HHMMSS and date stamp = MMDDYY) 
and floating point values for each of the defined 
History Points for that History Archive Register. 

03 704 – Hourly History Hourly or Periodic 
History Archive 
Register Index (0 to 
839) 

Response contains two floating point values for the 
time and date stamp of the history archive (time 
stamp = HHMMSS and date stamp = MMDDYY) 
and floating point values for each of the defined 
History Points for that History Archive Register. 

03 X – Extended History Extended History 
Archive Register 
Index (0 to Max) 

Response contains two floating point values for the 
time and date stamp of the history archive (time 
stamp = HHMMSS and date stamp = MMDDYY) 
and floating point values for each of the defined 
History Points for that History Archive Register. 

1. The Hourly (periodic) Index, Daily Index, Event, and Alarm Log data fields are used to address a history index 
number.  

2. The Event and Alarm Log record consists of the bytes shown in Table 7-9. Modbus Events and Alarms Log 
Contents. A breakdown of the bit map in Byte 1-2 is given in Table 7-10. Event & Alarm Change Bit Map 
Contents. 

 
Field Description 

Group  Sets a contiguous group of history points from a 
single segment. You can access the values 
through a Modbus function code 03 request for a 
user-defined Modbus register. Twenty groups are 
available.  

Periodic and Daily 
History Registers  

Sets the Modbus Register Number to acquire the 
group of history points defined in the Start History 
Point and End History Point fields. One Register 
(commonly Register 704) can retrieve periodic 
data and another Register (commonly Register 
703) can retrieve daily data for the Group of 
History Points. The time Period for the Periodic 
history is set on the Configuration > History 
Segment configuration screen (if the Period is set 
as 60, this will be Hourly history).  

History Segment  Sets a segment from which the ROC acquires the 
history. Make sure you configure this segment 
through the Configure > History Segments 
screen. The General Segment displays on this 
table as 0.  
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Field Description 
Starting History 
Point  

Sets the starting history point (first retrieved 
history point) for a group of points, you define in 
the Register Number field. You must complete 
both this field and the Ending History Points field. 
The value in the Ending History Points field must 
be different and larger than this value.  

Ending History 
Point  

Sets the ending history point (last retrieved history 
point) for a group of points, as defined in the 
Register Number field. You must complete both 
this field and the Starting History Points field, and 
the value in the Starting History Points field must 
be different and smaller than this value.  

Conversion  Sets the type of data conversion (if any) before the 
data returns to the host or is written to the ROC 
Conversions allow the unit's floating point values 
to transmit or receive as integer values. Table 7-
10. Event & Alarm Change Bit Map Contents lists 
the Convert Codes.  

7.6.2 Modbus Conversion Codes 
Modbus conversion codes convert data into a format that is compatible 
to a Modbus device.  
Use the Conversion field (located on either the Modbus Registers or 
Modbus History screen) to specify the type of conversion you require, if 
any, on the data before it is either sent to the host/slave or written to the 
ROC. Conversions account for differences in data types between the 
master and slave devices. 
Conversion codes 65 to 72 allow a 4-byte IEEE formatted floating-point 
number to be sent or received in two Modbus registers with the byte 
orders configurable. A check is made to ensure that an even number of 
registers is requested, that the Start Register number does not begin in 
the middle of a register pair, and that the number of registers does not 
exceed the number of registers you configure. 

Modbus 
Convert Codes 

The Modbus Conversion field corresponds to every register or range of 
registers set up. The Conversion field parameter specifies the type of 
conversion required, if any, on the data before it is sent to the master or 
before it is written to the ROC. 
The conversions are used to allow integer values to be transmitted and 
received instead of floating-point values. The conversions only affect 
Function Codes 02, 03, 04, 06, and 16. The following table describes the 
type of conversion to take place on the register or range of registers: 

Table 7-5. Modbus Convert Codes   

Convert 
Code Description Slave 

Function Definition 

0 No Conversion N/A N/A 
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Convert 
Code Description Slave 

Function Definition 

1 Float to Signed 
Integer, Float Scale 
1 

3,4 The Float to Signed Integer conversion changes the ROC floating 
point data to a two-byte signed integer for transmission. The 
number of the Conversion Code specifies which floating point 
scaling value is to be used for the conversion.  2 Float to Signed 

Integer, Float Scale 
2 

3,4 

3 Float to Signed 
Integer, Float Scale 
3 

3,4 

4 Float to Signed 
Integer, Float Scale 
4 

3,4 

5 Float to Signed 
Integer, Float Scale 
5 

3,4 

6 Float to Signed 
Integer, Float Scale 
6 

3,4 

7 Float to Signed 
Integer, Float Scale 
7 

3,4 

8 Float to Signed 
Integer, Float Scale 
8 

3,4 

Conversion codes 1 through 8, Float to Signed Integer are calculated as: 
Integer = [(Integer Range x Adj Reading)]/Float Range] + Low Integer Scale 

Where: 
Float Range = High Float Scale — Low Flow Scale 
Integer Range = High Integer Scale — Low Integer Scale 
Adj Reading = Float Reading — Low Flow Scale 

Convert 
Code Description Slave 

Function Definition 

9 Any Type to Signed 
Long with 1 Implied 
Decimal Place 

3,4,6,16 Value within ROC is multiplied by 10.0 and converted to a 
signed 32 bit integer. (A value of – 1.234567 would be sent as – 
12). 

10 Any Type to Signed 
Long with 2 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 100.0 and converted to a 
signed 32 bit integer. (A value of – 1.234567 would be sent as – 
123). 

11 Any Type to Signed 
Long with 3 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 1000.0 and converted to a 
signed 32 bit integer. (A value of – 1.234567 would be sent as – 
1234). 

12 Any Type to Signed 
Long with 4 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 10000.0 and converted to a 
signed 32 bit integer. (A value of – 1.234567 would be sent as – 
12345). 

13 Any Type to Signed 
Long with 5 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 100000.0 and converted to a 
signed 32 bit integer. (A value of – 1.234567 would be sent as – 
123456). 
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Convert 
Code Description Slave 

Function Definition 

14 Any Type to Signed 
Long with 6 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 1000000.0 and converted to a 
signed 32 bit integer. (A value of – 1.234567 would be sent as – 
1234567). 

15 Any Type to Signed 
Long with 7 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 10000000.0 and converted to 
a signed 32 bit integer. (A value of – 1.234567 would be sent as 
– 12345670). 

16 Any Type to Signed 
Long with 8 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 100000000.0 and converted to 
a signed 32 bit integer. (A value of – 1.234567 would be sent as 
– 123456700). 

17 Any Type to Signed 
Long with 1 Implied 
Decimal Place 

3,4,6,16 Value within ROC is multiplied by 10.0 and converted to a 
signed 32 bit integer. (A value of 1.234567 would be sent as 12). 

18 Any Type to Signed 
Long with 2 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 100.0 and converted to a 
signed 32 bit integer. (A value of 1.234567 would be sent as 
123). 

19 Any Type to Signed 
Long with 3 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 1000.0 and converted to a 
signed 32 bit integer. (A value of 1.234567 would be sent as 
1234). 

20 Any Type to Signed 
Long with 4 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 10000.0 and converted to a 
signed 32 bit integer. (A value of 1.234567 would be sent as 
12345). 

21 Any Type to Signed 
Long with 5 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 100000.0 and converted to a 
signed 32 bit integer. (A value of 1.234567 would be sent as 
123456). 

22 Any Type to Signed 
Long with 6 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 1000000.0 and converted to a 
signed 32 bit integer. (A value of 1.234567 would be sent as 
1234567). 

23 Any Type to Signed 
Long with 7 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 10000000.0 and converted to 
a signed 32 bit integer. (A value of 1.234567 would be sent as 
12345670). 

24 Any Type to Signed 
Long with 8 Implied 
Decimal Places 

3,4,6,16 Value within ROC is multiplied by 100000000.0 and converted to 
a signed 32 bit integer. (A value of 1.234567 would be sent as 
123456700). 

25 Any Type to Float, 
No Scaling 

3,4,6,16 Changes any ROC data type (except an ASCII tag) to a four-
byte floating point without scaling. The conversion is typically 
performed using a type cast. This is for both transmitting and 
receiving. 

26 Any Type to Signed 
Short Integer 

3,4,6,16 Changes any ROC data type (except an ASCII tag) to a two-byte 
signed short integer. This is for both transmitting and receiving. 

27 Any Type to Signed 
Long Integer 

3,4,6,16 Changes any ROC data type (except an ASCII tag) to a four-
byte signed long integer. This is for both transmitting and 
receiving 

28 Any Type to 
Unsigned Short 
Integer 

3,4,6,16 Changes any ROC data type (except an ASCII tag) to a two-byte 
unsigned signed short integer. This is for both transmitting and 
receiving. 

29 Any Type to 
Unsigned Long 
Integer 

3,4,6,16 Changes any ROC data type (except an ASCII tag) to a four-
byte unsigned long integer. This is for both transmitting and 
receiving. 

30 to 36 No Conversion N/A N/A 
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Convert 
Code Description Slave 

Function Definition 

37 Unsigned Byte to 
Packed Bit 

3,4,6,16 Response is identical that for a function 1 or 2 request. All 
registers in the range requested must be unsigned integer 8 
values and have a conversion code of 37 

38 to 40 No Conversion N/A N/A 
41 Any Type to Signed 

Short Implied 1 
3,4,6,16 Value within ROC is multiplied by 10.0 and converted to a 

signed 16 bit integer. (A value of – 0.12345 would be sent as – 
1). 

42 Any Type to Signed 
Short Implied 2 

3,4,6,16 Value within ROC is multiplied by 100.0 and converted to a 
signed 16 bit integer. (A value of – 0.12345 would be sent as – 
12). 

43 Any Type to Signed 
Short Implied 3 

3,4,6,16 Value within ROC is multiplied by 1000.0 and converted to a 
signed 16 bit integer. (A value of – 0.12345 would be sent as – 
123). 

44 Any Type to Signed 
Short Implied 4 

3,4,6,16 Value within ROC is multiplied by 10000.0 and converted to a 
signed 16 bit integer. (A value of – 0.12345 would be sent as – 
1234). 

45 Any Type to Signed 
Short Implied 5 

3,4,6,16 Value within ROC is multiplied by 100000.0 and converted to a 
signed 16 bit integer. (A value of – 0.12345 would be sent as – 
12345). 

46 Any Type to Signed 
Short Implied 6 

3,4,6,16 Value within ROC is multiplied by 1000000.0 and converted to a 
signed 16 bit integer. (A value of – 0.01234567 would be sent as 
– 12345). 

47 Any Type to Signed 
Short Implied 7 

3,4,6,16 Value within ROC is multiplied by 100000.0 and converted to a 
signed 16 bit integer. (A value of – 0.0012345 would be sent as 
– 12345). 

48 Any Type to Signed 
Short Implied 8 

3,4,6,16 Value within ROC is multiplied by 1000000.0 and converted to a 
signed 16 bit integer. (A value of – 0.0001234567 would be sent 
as – 12345). 

49 Any Type to 
Unsigned Short 
Implied 1 

3,4,6,16 Value within ROC is multiplied by 10.0 and converted to an 
unsigned 16 bit integer. (A value of 0.1234567 would be sent as 
1). 

50 Any Type to 
Unsigned Short 
Implied 2 

3,4,6,16 Value within ROC is multiplied by 100.0 and converted to an 
unsigned 16 bit integer. (A value of 0.1234567 would be sent as 
12). 

51 Any Type to 
Unsigned Short 
Implied 3 

3,4,6,16 Value within ROC is multiplied by 1000.0 and converted to an 
unsigned 16 bit integer. (A value of 0.1234567 would be sent as 
123). 

52 Any Type to 
Unsigned Short 
Implied 4 

3,4,6,16 Value within ROC is multiplied by 10000.0 and converted to an 
unsigned 16 bit integer. (A value of 0.1234567 would be sent as 
1234). 

53 Any Type to 
Unsigned Short 
Implied 5 

3,4,6,16 Value within ROC is multiplied by 100000.0 and converted to an 
unsigned 16 bit integer. (A value of 0.1234567 would be sent as 
12345). 

54 Any Type to 
Unsigned Short 
Implied 6 

3,4,6,16 Value within ROC is multiplied by 1000000.0 and converted to 
an unsigned 16 bit integer. (A value of 0.01234567 would be 
sent as 12345). 

55 Any Type to 
Unsigned Short 
Implied 7 

3,4,6,16 Value within ROC is multiplied by 10000000.0 and converted to 
an unsigned 16 bit integer. (A value of 0.001234567 would be 
sent as 12345). 
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Convert 
Code Description Slave 

Function Definition 

56 Any Type to 
Unsigned Short 
Implied 8 

3,4,6,16 Value within ROC is multiplied by 100000000.0 and converted to 
an unsigned 16 bit integer. (A value of 0.0001234567 would be 
sent as 12345). 

57 Any Type to Signed 
Long 0, 1, 2, 3 

3,4,6,16 Response is similar to dual register floating point conversions. 
Dual register: byte order 0-1-2-3. 
Note: 0 = Byte MSB and Byte 3 = LSB 

58 Any Type to Signed 
Long 1, 0, 3, 2 

3,4,6,16 Response is similar to dual register floating point conversions. 
Dual register: byte order 1-0-3-2. 
Note: 0 = Byte MSB and Byte 3 = LSB 

59 Any Type to Signed 
Long 2, 3, 0, 1 

3,4,6,16 Response is similar to dual register floating point conversions. 
Dual register: byte order 2-3-0-1. 
Note: 0 = Byte MSB and Byte 3 = LSB 

60 Any Type to Signed 
Long 3, 2, 1, 0 

3,4,6,16 Response is similar to dual register floating point conversions. 
Dual register: byte order 3-2-1-0. 
Note: 0 = Byte MSB and Byte 3 = LSB 

61 Any Type to 
Unsigned Long 0, 
1, 2, 3 

3,4,6,16 Response is similar to dual register floating point conversions. 
Dual register: byte order 0-1-2-3. 
Note: 0 = Byte MSB and Byte 3 = LSB 

62 Any Type to 
Unsigned Long 1, 
0, 3, 2 

3,4,6,16 Response is similar to dual register floating point conversions. 
Dual register: byte order 1-0-3-2. 
Note: 0 = Byte MSB and Byte 3 = LSB 

63 Any Type to 
Unsigned Long 2, 
3, 0, 1 

3,4,6,16 Response is similar to dual register floating point conversions. 
Dual register: byte order 2-3-0-1. 
Note: 0 = Byte MSB and Byte 3 = LSB 

64 Any Type to 
Unsigned Long 3, 
2, 1, 0 

3,4,6,16 Response is similar to dual register floating point conversions. 
Dual register: byte order 3-2-1-0. 
Note: 0 = Byte MSB and Byte 3 = LSB 

65 to 72 IEEE Floating Point 
Number 

3,4,16 Conversion Codes 65 to 72 allow a four-byte IEEE 754 
formatted floating point number to be sent or received in two 
Modbus registers with the byte orders configurable. Since these 
conversions require two registers. A check is made to ensure 
that an even number of registers is requested, that the starting 
register number does not begin in the middle of a register pair, 
and that the number of registers does not exceed the number of 
registers configured. 

   Byte 0 Byte 1 Byte 2 Byte 3 
   seee 

eeee 
emmm 
mmmm 

mmmm 
mmmm 

mmmm 
mmmm 

   Where s = sign bit, e = exponent bit, m = mantissa bit 
Note: Each conversion code is listed individually below. 

65 IEEE Floating Point 
Number 

3,4,16 Places byte 0 and byte 1 in register XXXXXX and places byte 2 
and byte 3 in register XXXXXX + 1. 

   Register XXXXXX byte 0, byte 1 
   Register XXXXXX + 1 byte 2, byte 3 

66 IEEE Floating Point 
Number 

3,4,16 Places byte 0 and byte 1 in register XXXXXX and places byte 2 
and byte 3 in register XXXXXX + 1. Same as conversion code 
65 regardless of MSB 1st flag.  

   Register XXXXXX byte 0, byte 1 
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Convert 
Code Description Slave 

Function Definition 

   Register XXXXXX + 1 byte 2, byte 3 
67 IEEE Floating Point 

Number 
3,4,16 Places byte 0 and byte 1 in register XXXXXX and places byte 2 

and byte 3 in register XXXXXX + 1. 
   Register XXXXXX byte 0, byte 1 
   Register XXXXXX + 1 byte 2, byte 3 

68 IEEE Floating Point 
Number 

3,4,16 Places byte 0 and byte 1 in register XXXXXX and places byte 2 
and byte 3 in register XXXXXX + 1. Same as conversion code 
67 regardless of MSB 1st flag. 

   Register XXXXXX byte 1, byte 0 
   Register XXXXXX + 1 byte 3, byte 2 

69 IEEE Floating Point 
Number 

3,4,16 Places byte 2 and byte 3 in register XXXXXX and places byte 0 
and byte 1 in register XXXXXX + 1.  

   Register XXXXXX byte 2, byte 3 
 v  Register XXXXXX + 1 byte 0, byte 1 

70 IEEE Floating Point 
Number 

3,4,16 Places byte 2 and byte 3 in register XXXXXX and places byte 0 
and byte 1 in register XXXXXX + 1. Same as conversion code 
69 regardless of MSB 1st flag. 

   Register XXXXXX byte 2, byte 3 
   Register XXXXXX + 1 byte 0, byte 1 

71 IEEE Floating Point 
Number 

3,4,16 Places byte 3 and byte 2 in register XXXXXX and places byte 1 
and byte 0 in register XXXXXX + 1.  

   Register XXXXXX byte 3, byte 2 
   Register XXXXXX + 1 byte 1, byte 0 

72 IEEE Floating Point 
Number 

3,4,16 Places byte 3 and byte 2 in register XXXXXX and places byte 1 
and byte 0 in register XXXXXX + 1. Same as conversion code 
71 regardless of MSB 1st flag. 

   Register XXXXXX byte 3, byte 2 
   Register XXXXXX + 1 byte 1, byte 0 

73 Double 01, 23, 45, 
67, Disregard MSB 
flag 

3,4,6,16 Places byte 0 and byte 1 in register XXXXXX, places byte 2 and 
byte 3 in register XXXXXX + 1, places byte 4 and byte 5 in 
register XXXXXX + 2, and places byte 6 and byte 7 in register 
XXXXXX + 3. This places an 8-byte double value into four 2-
byte registers to allow double values to be transmitted. Ignores 
the Byte Order field in the Modbus Configuration screen.  

   Register XXXXXX byte 0, byte 1 
   Register XXXXXX + 1 byte 2, byte 3 
   Register XXXXXX + 2 byte 4, byte 5 
   Register XXXXXX + 3 byte 6, byte 7 

74 Double 23, 01, 67, 
45, Disregard MSB 
flag 

3,4,6,16 Places an 8-byte double value into four 2-byte registers to allow 
double values to be transmitted. Ignores the Byte Order field in 
the Modbus Configuration screen.  

   Register XXXXXX byte 2, byte 3 
   Register XXXXXX + 1 byte 0, byte 1 
   Register XXXXXX + 2 byte 6, byte 7 
   Register XXXXXX + 3 byte 4, byte 5 
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Convert 
Code Description Slave 

Function Definition 

75 Double 45, 67, 04, 
23, Disregard MSB 
flag  

3,4,6,16 Places an 8-byte double value into four 2-byte registers to allow 
double values to be transmitted. Ignores the Byte Order field in 
the Modbus Configuration screen.  

   Register XXXXXX byte 4, byte 5 
   Register XXXXXX + 1 byte 6, byte 7 
   Register XXXXXX + 2 byte 0, byte 1 
   Register XXXXXX + 3 byte 2, byte 3 

76 Double 67, 45, 23, 
04, Disregard MSB 
flag  

3,4,6,16 Places an 8-byte double value into four 2-byte registers to allow 
double values to be transmitted. Ignores the Byte Order field in 
the Modbus Configuration screen.  

   Register XXXXXX byte 6, byte 7 
   Register XXXXXX + 1 byte 4, byte 5 
   Register XXXXXX + 2 byte 2, byte 3 
   Register XXXXXX + 3 byte 0, byte 1 

77 Double 10, 32, 54, 
76, Disregard MSB 
flag  

3,4,6,16 Places an 8-byte double value into four 2-byte registers to allow 
double values to be transmitted. Ignores the Byte Order field in 
the Modbus Configuration screen.  

   Register XXXXXX byte 1, byte 0 
   Register XXXXXX + 1 byte 3, byte 2 
   Register XXXXXX + 2 byte 7, byte 6 
   Register XXXXXX + 3 byte 5, byte 4 

78 Double 35, 10, 76, 
54, Disregard MSB 
flag  

3,4,6,16 Places an 8-byte double value into four 2-byte registers to allow 
double values to be transmitted. Ignores the Byte Order field in 
the Modbus Configuration screen.  

   Register XXXXXX byte 3, byte 2 
   Register XXXXXX + 1 byte 1, byte 0 
   Register XXXXXX + 2 byte 7, byte 6 
   Register XXXXXX + 3 byte 5, byte 4 

79 Double 54, 76, 10, 
32, Disregard MSB 
flag  

3,4,6,16 Places byte 0 and byte 1 in register XXXXXX, places byte 2 and 
byte 3 in register XXXXXX + 1, places byte 4 and byte 5 in 
register XXXXXX + 2, and places byte 6 and byte 7 in register 
XXXXXX + 3. This places an 8-byte double value into four 2-
byte registers to allow double values to be transmitted. Ignores 
the Byte Order field in the Modbus Configuration screen.  

   Register XXXXXX byte 5, byte 4 
   Register XXXXXX + 1 byte 7, byte 6 
   Register XXXXXX + 2 byte 1, byte 0 
   Register XXXXXX + 3 byte 3, byte 2 

80 Double 76, 54, 32, 
10, Disregard MSB 
flag  

3,4,6,16 Places an 8-byte double value into four 2-byte registers to allow 
double values to be transmitted. Ignores the Byte Order field in 
the Modbus Configuration screen.  

   Register XXXXXX byte 7, byte 6 
   Register XXXXXX + 1 byte 5, byte 4 
   Register XXXXXX + 2 byte 3, byte 2 
   Register XXXXXX + 3 byte 1, byte 0 
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Convert 
Code Description Slave 

Function Definition 

81 ASCII 3,4,6,16 Breaks an ASCII string parameter into multiple 2-byte registers.  
Number of registers id dependent upon the size of the string.  
Supports strings of 3, 7, 10, 12, 20, 30, and 40 bytes.  Odd sized 
strings are padded with a space character. 

82 to 255 No conversion N/A N/A 
 

7.6.3 Modbus Events and Alarms 
To view the Modbus Event Log and Alarm Log, select Configure > 
Modbus. Select the History Table tab. The History Table displays.  
The record formats for the event log and alarm log are the same size and 
have similar contents. The first word in a record is a bit map in which 
bit 9 indicates if the log record is an Event (1) or an Alarm (0). The 
meanings of the other bits are specific to either the Event or the Alarm 
Log records. Refer to Table 7-10. Event & Alarm Change Bit Map 
Contents.  
The ROC supports the Modbus with EFM extensions method for 
retrieving alarms and events. When the ROC receives a Function Code 
03 request referencing defined Events and Alarms Register (usually 32), 
the ROC begins to collect records from first the Event Log and then the 
Alarm Log, starting where the last poll left off. The ROC collect records 
until either there are not any more new events, alarms, or it collects the 
maximum of 12 records. The ROC sends the information back to the 
Host, which in return replies with Function Code 05, referencing the 
same Events and Alarms Register, indicating that the points have been 
received and that the Host is ready for the next 12 records. 
The following paragraphs detail how ROCLINK 800 places event log 
and alarms log information in Modbus event and alarm messages and 
how (or what) is generated upon the event or alarm condition.  

Normal Event Record A normal event record has the format:  
 

Bit Map Register Time as float Date as float Old Value as float New Value as float 
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

 
System Text Events When you set the System Command Change Bit (bit 7) in the Operator 

Change Bit Map of the Event, it sets the Register number for all System 
Command Change events will be set to the Event/Alarm Register 
number (default is 32). 
 

Bit Map Register Time as float Date as float Code Text 
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

 
ROCLINK 800 uses this format for the following event codes: 
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 144 Initialization Sequence 
 146 Initialize From Defaults 
 147 ROM CRC Error 
 148 Database Initialization 
 150 Program Flash 
 248 Text Message 
 249 Download Configuration 
 250 Upload Configuration 
 251 Calibration Timeout 
 252 Calibration Cancel 
 253 Calibration Success 

FST Events For FST events, the code is the FST number (1 to 6). Unused will be set 
to zero.  
 

Bit Map Register Time as float Date as float Code Unused Value as float 
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

 
Time-related  

System Events 
The time is the number of seconds since January 1, 1970. Unused will 
be set to zero. 
 

Bit map Register Time as float Date as float Code Unused Time as time_t 
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

 
Events are formatted as: 
 145 All Power Removed 
 200 Clock Set 

Alarms Use the Alarms table to determine the alarming source. The Register 
number for all unmapped Alarms will be set to the Event/Alarm 
Register number (default is 32). 
Follows is a normal alarm record format:  

Bit map Register Time as float Date as float Value as float Unused 
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

  
Unmapped Parameter 

Alarms 
If the alarming point is not mapped to a Modbus Register, identifying 
the point using the following table. The TLP will be the source TLP of 
the alarm. The type will be set to 1 
 

Bit Map Register Time as float Date as float Value as float TLP Type 
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

  
FST Alarms If the Alarm is an FST Alarm, ROCLINK 800 uses the following 

format. The FST Number is the source FST Number that generated the 
alarm. Unused is set to zero and the type is set to 2. 
 

Bit Map Register Time as float Date as float Value as float FST# Unused Type 
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0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 
 

User Text Alarms A User Text alarm uses the following format. Text is filled in with 
seven bytes of User Text and the Type will be set to 3. 
 

Bit Map Register Time as float Date as float Text Type 
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

  
User Value Alarms If the alarm is a User Value Alarm, the following format will be used. 

Unused will be set to zero and the Type will be set to 4. 
 

Bit Map Register Time as float Date as float Value as float Unused Type 
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

 
Reading Events and 

Alarms Register 
The Modbus request to read the Event Log and Alarm Log uses the 
standard read Function Codes 03 or 04 and the Register Number defined 
in the History Access configuration. In this request, the number of 
Registers is included to maintain format compatibility, but is ignored by 
the receiving ROC.  
Twenty bytes are returned for each event and alarm in the response. Up 
to 12 events and alarms can be returned in a single response. If no 
events and alarms have occurred since the last collection, the response 
contains 0 data bytes. 
For the date stamp in the events and alarms returned, the year (YY) is 
really the number of years since 1980. For example, if the current year 
is 2007, the year (YY) for the date stamp would be 27. 
Following is an example of a request for events and alarms with the 
history access event/alarm register defined as 32 (0x0020 hex). 
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Table 7-6. Host Event/Alarm Request Example Message 

 
Message Field 

 
Device Address 

 
Function Code 

 
Register Offset 

Num Reads 
(ignored) 

 
Error Check 

Bytes 1 1 2 2 2 

TX Order     MS LS MS LS LS MS 

Value 01H 03H 00H 20H 00H 01H CRC-16 
 
The following example shows a response returning three events and 
alarms. 

Table 7-7. Event/Alarm Response Example Message 

Message 
Field 

Device 
Address 

Function 
Code 

Byte 
Count 

 
Data 

Error 
Check 

Bytes 1 1 1 (20 bytes per event or alarm) 2 

TX Order    Integers — MS LS LS MS 

Floats — Selectable 

Value 01H 03H 3CH CRC-16 

 

Acknowledging 
Events and Alarms 

After the host has correctly received event and alarm data, it transmits 
an acknowledgement message to the ROC to clear these events and 
alarms from the Modbus buffer.  
Until it receives that acknowledgement message, the ROC continues to 
send the same event and alarm records to the host. The Modbus 
acknowledgement (to clear the Event Log and Alarm Log buffer) uses 
Function Code 05 and the Register Number defined in the History 
Access configuration. In this request, the data value is always one (1). 

Table 7-8. Event and Alarm Acknowledgement Response Example Message 

Message 
Field 

Device 
Address 

Function 
Code 

 
Register 

 
Data 

 
Error Check 

Bytes 1 1 2 2 2 

TX Order MS LS MS LS MS LS MS LS 

Value 01H 05H 00H 20H FFH 00H CRC-16 

Table 7-9. Modbus Events and Alarms Log Contents 
Byte Contents of Event Log Record Contents of Alarm Log Record 

1 to 2 Operator change (Event Log) bit map (16-bit 
integer). See Table 7-11, Event & Alarm 
Changes Bit Map Contents. 

Alarm change bit map (16-bit integer). See Table 
7-11, Event & Alarm Changes Bit Map Contents. 

3 to 4 Modbus Register number of variable (16-bit 
integer) 

Modbus Register number of variable (16-bit 
integer) 

5 to 8 Time Stamp (HHMMSS; 32-bit floating point) Time Stamp (HHMMSS; 32-bit floating point) 
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9 to 12 Date Stamp (MMDDYY; 32-bit floating point) Date Stamp (MMDDYY; 32-bit floating point) 
13 to 16 Previous value of variable (32-bit floating 

point) 
Current (alarmed) value of variable (32-bit floating 
point) 

17 to 20 Current (New) value of variable (32-bit 
floating point) 

Unused at the current time (zero filled when 
transmitted to the Master) 

Table 7-10. Event & Alarm Change Bit Map Contents 
Bit Operator Change Bit Map Alarm Change Bit Map 
0 Fixed value – change to an EU value on an I/O point in Manual Mode Not Used 
1 Zero scale – change to the 0% Adjusted on an AO or AI Not Used 
2 Full scale – change to the 100% Adjusted on an AO or AI Not Used 
3 Operator entry work value – change to any parameter other than those 

described 
Not Used 

4 Boolean fixed bit – change to Status in DO or DI Not Used 
5 Fixed/variable flag – change to Manual Mode for an I/O point Manual Alarm 
6 Table entry change – change to Modbus Function Tables Status Change Alarm 
7 System command change – events logged by system (Power up) No Flow Alarm 
8 Not Used Point Fail Alarm 
9 Operator change (Event Log) identifier bit 0 for Alarm 
10 Low Low Limit – change to Low Low Alarm parameter Low Low Alarm 
11 Low Limit – change to Low Alarm parameter Low Alarm 
12 High Limit – change to High Alarm parameter High Alarm 
13 High High Limit – change to High High Alarm parameter High High Alarm 
14 Rate of Change Limit – change to Rate Alarm parameter Rate Alarm 
15 Not Used Set/Clear Alarm 

(1 = Set or 0 = Clear) 
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Chapter 8 – The Meter Menu 

In This Chapter 

8.1 Setup ...................................................................................................... 8-1 
8.1.1 Station Configuration .................................................................. 8-2 
8.1.2 Meter Setup Configuration ....................................................... 8-13 

8.2 Meter Calibration Basics ...................................................................... 8-26 
8.2.1 Verifying an Input ..................................................................... 8-28 
8.2.2 Calibrating an Input Example ................................................... 8-32 
8.2.3 Zero Shift/Offset/RTD Bias ....................................................... 8-40 

8.3 Meter Values ........................................................................................ 8-45 
8.3.1 Meter Values: Values Tab ........................................................ 8-45 
8.3.2 Meter Values: Factors Tab ....................................................... 8-46 

8.4 Plate Change ....................................................................................... 8-47 
 

 
Use the Meter menu to define, configure, and calibrate meter runs; 
review meter runs; and perform plate changes for orifice and linear 
(turbine, PD, ultrasonic, Coriolis) meters.  

  
Figure 8-1. Meter Menu  

 

8.1 Setup 
Use Meter Setup to configure meter runs and stations. The Meter 
configuration screens contain the functions directly associated with 
measuring and logging flow, including setup of American Gas 
Association (AGA), American Petroleum Institute (API), or 
International Standards Organization (ISO) calculation configuration 
parameters, and calibrating the meter depending on the device that you 
are configuring. 
The ROC800-Series organizes meter runs into stations. The 12 meter 
runs can be grouped among the 12 stations in any combination. Meter 
are assigned to stations in the Meter > Setup > Orifice Meter or 
Linear Meter screens. Meter runs belong in the same station when they 
have the same gas data, calculation methods, and base/contract 
conditions.  
Refer to for the defaults in Metric and US engineering units. 
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Table 8-1. Meter Run Engineering Units (EU)2345 

Flow Parameter U.S. Units Metric Units 
Meter Input (AGA3) Inches H2O kPa 
Meter Input (AGA7) – Volume MCF/day km3/day 
Meter Input (AGA7) – Mass lb/hour kg/hour 
Static Pressure PSIG or PSIA kPaG or kPaA 
Temperature Deg F Deg C 
Instantaneous Volume/Hour CF/hour m3/hour 
Instantaneous Volume/Day MCF/day km3/day 
Instantaneous Energy/Hour Btu/hour MJ/hour 
Instantaneous Energy/Day MMBtu/day GJ/day 
Volume Flow Today/Yesterday MCF km3  
Energy Today/Yesterday MMBtu GJ 
Viscosity lb/ft-sec cP 
Diameters Inches Millimeters 
Elevation Feet Meter 
Inst Mass/Hour lb/hour kg/hour 
Inst Mass/Day Mlb/day tonnes/day 
Mass Flow Today/Yesterday Mlb tonnes 
Density lb/CF kg/m3 
Heating Value Btu/CF or Btu/lb MJ/m3 or MJ/kg 

 

8.1.1 Station Configuration 
To configure a station, select a station icon in the configuration tree 
menu or select Meter> Setup > Station. Configure stations before 
configuring the meter runs. 
Meters are assigned to stations in the Meter > Setup > Orifice or 
Linear screens. Meter runs belong in the same station when they have 
the same gas data, calculation methods, and base/contract conditions. 
Each station may be given a unique tag, and each meter may be given a 
unique tag and meter description. 
If you are using constant gas quality data from a lab analysis report, 
then all 12 stations can be employed. If you are using live gas quality 
data from a gas chromatograph, no more than ten stations are 
recommended. 

Note: Contract hours can be set differently for each station in 
Configure > History Segments. 

 Use the General tab to set basic parameters that all the meter runs 
assigned to a station have in common. 
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 Use the Gas Quality tab to set the gas information parameters. The 
Gas Quality tab defines the mole percentages of twenty-one gas 
components, as well as the Heating Value Basis, the Heating Value, 
and the Specific Gravity. 

 Use the Advanced tab to configure a number of additional 
parameters that affect the flow calculation. 

 Use the Alarms tab to configure alarming parameters for station 
flow rates. 

Notes: 
 After configuring a station and clicking Apply, use Flash Memory 

Save Configuration in the ROC > Flags screen to save station 
configuration to permanent memory in case you must perform a cold 
start. 

 If other stations have similar characteristics, use the copy and paste 
buttons to simplify configurations. 

Station Setup: General Tab 
Use the General tab to set basic parameters that all the meter runs in the 
station have in common. The General tab displays when you first access 
the Station Setup screen. 

 
Figure 8-2. Station Setup – General tab  

1. Review the following fields for your organization’s values.  
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Field Description 
Station Sets the station to configure. This lists all active 

stations.  
Note: The selection in this field applies to each tab 

on this screen. 

Tag Sets a (10 alphanumeric character) identifier for the 
point.  
Note: The selection in this field applies to each tab 

on this screen. 

History Segment Sets the history segment in the historical database 
that you use to configure history points for the 
meters in this station.  
Note: Assign only one station per history segment. 

Contract Hour Sets the time when the daily values are logged. If 
this segment is tied to a meter station, this will also 
be the contract hour for the station and will be the 
time that daily and monthly (if it is the first of the 
month) accumulations will be reset. Additional 
entries will be made if Force End of Day is 
exercised for this segment.  
Note: The contract hour for the station may also 

be set in the Configure > History Segment 
screen. 

Calculation 
Standard 

Sets the set of calculation standards that are to be 
used for orifice, gas linear meters, and mass linear 
meters in this station. There is only one edition of 
AGA and ISO flow calculations. Calculation 
standards include:  

 Gas, AGA3-
92/AGA7-

96/AGA11-2003 

American Gas Association (AGA) 
standard for gas flow through an 
orifice, a linear meter, and a mass 
(Coriolis) meter. 
Select Gas, AGA3-92/AGA7-
1996/AGA11-2003 for the station 
when you want AGA 3 
calculations for all orifice meters 
in the station and AGA 7 
calculations for all turbine meters 
and all mass (Coriolis) meters in 
a station. 
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Field Description 
 Gas, ISO5167-

98/ISO9951-
93/ISO10790-

2003 

International Standard 
Organization (ISO) standard for 
gas flow through an orifice, a 
linear meter, and a mass 
(Coriolis) meter. 
Select Gas, ISO5167-
98/ISO9951-93/ISO10790-2003 
for all orifice meters in the station 
and ISO9951 calculations for all 
turbine meters and all mass 
(Coriolis) meters in a station. 
Note: ISO9951 calculations are 

identical to AGA 7 
calculations. 

 Liquid, 
ISO5167-

98/API 12-
95/ISO10790-

1999 

ISO and API (American 
Petroleum Institute) standards for 
liquid flow through an orifice, a 
linear meter, and a mass 
(Coriolis) meter. 
Select Liquid, ISO5167-98/API 
12-95/ISO10790-1999 for all 
orifice meters with an expansion 
factor set to 1.0. Linear volumetric 
meters will calculate a corrected 
volume using user-
entered/calculated pressure and 
temperature correction factors. 
Mass (Coriolis) meters calculate a 
corrected volume form the Mass 
Flow Rate and the Base Density. 

 Gas, ISO5167-
2003/ISO9951-

93/ISO10790-
2003 

International Standard 
Organization (ISO) standard for 
gas flow through an orifice, a 
linear meter, and a mass 
(Coriolis) meter in circular cross-
section conduits running full. 
Select Gas, ISO5167-
2003/ISO9951-93/ISO10790-
2003 for all orifice meters in the 
station and ISO9951 calculations 
for all turbine meters and all mass 
(Coriolis) meters in a station with 
circular cross-section conduits 
running full. 
Note: ISO9951 calculations are 

identical to AGA 7 
calculations. 
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Field Description 
 Note: For linear volumetric meters using API 12, 

the user-entered/calculated pressure and 
temperature correction factors, as well as 
the base density and flowing density values, 
need to be supplied by a FST, User C 
program, a host computer, a DS800 
program, or manually entered from a custom 
display. The FPV Method parameter (see 
Section 8.1.1.3, Station Setup Advanced 
tab) must be set to User so the density 
values can be entered. 

Flow Rate This read-only field shows the volume flow rate at 
base condition in MCF/day or km3/day. 

Energy Rate This read-only field shows the energy rate at base 
conditions in mmBtu/day or GJ/day. 

Mass Rate This read-only field shows the mass rate 
conditions in Mlb/day or tonnes/day. 

Flow Today This read-only field shows the total accumulation 
of flow for the current contract day in MCF or km3. 

Energy Today This read-only field shows the total accumulation 
of energy for the current contract day in mmBtu or 
GJ. 

Mass Today This read-only field shows the total mass for the 
day in Mlb or Tonnes. 

Zs This read-only field shows the represents the 
compressibility at standard conditions. 

Zb This read-only field shows the represents the 
compressibility at base conditions. 

Base Density This read-only field shows the represents the 
density of the measured fluid at base conditions in 
lbm/ft3 or kg/m3. 

Flow Yesterday This read-only field shows the total accumulation 
of flow for the previous contract day in MMCF or 
km3. 

Energy Yesterday This read-only field shows the total accumulation 
of energy for the previous contract day in MMBtu or 
GJ. 

Mass Yesterday This read-only field shows the total accumulation 
of mass for the previous contract day in Mlb or 
tonnes. 

Active Alarms  This read-only field shows the active alarms 
displaying the current alarm conditions at the 
station. 

 
2. Click Apply if you change any parameters on this screen.  
3. Proceed to the Station Setup’s Gas Quality tab.  
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Station Setup: Gas Quality Tab 
Use the Gas Quality tab to set the parameters for the gas information. 
The Gas Quality tab defines the mole percentages of twenty gas 
components, as well as the Heating Value Basis, the Heating Value, and 
the Specific Gravity. 
1. Select the Gas Quality tab. The Gas Quality tab screen displays. 

 
Figure 8-3. Station Setup – Gas Quality tab 

2. Review the following fields for your organization’s values.  

Field Description 
Gas Component  Sets the mole percent of each gas component 

present in the gas for this station. This value is 
required to calculate the compressibility of gas 
using the AGA 8 detailed method. 

Total Mole %  If the AGA 8 detailed method is selected, this read-
only field should equal 100% after you enter all the 
component mole percentages. 
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Field Description 
Heavy Gas Option  Sets the option to separate the heavy gas 

percentage (C6+) into individual components in the 
mole percentages for n-Hexane, n-Heptane, n-
Octane, n-Nonane, and n-Decane. To enter heavy 
gases, select the Heavy Gas Option and enter the 
percentage of heavy gases under Hexane+. In the 
Advanced tab, enter the amount of each heavy gas.  
The mole percentages in the Heavy Gas 
Distribution fields on the Advanced tab must equal 
100%. If the total percentage of the distribution 
among the five heavier components is less than 
100%, Hexane is increased to make the total add 
up to 100%. If the total percentage of the 
distribution is greater than 100%, reduction occurs 
in the following order: Decane > Nonane > Octane 
> Heptane > Hexane until the total is equal to 
100%. 

Gas Quality  Indicates the source for determining gas quality 
readings. Valid values are Live (readings come 
from a gas chromatograph or are periodically 
downloaded from a host) or Constant (manually 
enter the gas composition and changes are entered 
in the Event Log). 

Normalization Type  Sets what action is taken if the total of the gas mole 
percentages do not add up to 100%. Valid values 
are Methane Adjust (automatically adjust the 
Methane component up or down to compensate for 
the difference if the total does not equal 100%) or 
Full Normalization (adjust each component if the 
total does not equal 100%). 

Heating Value Basis  Indicates the basis for determining the entered 
heating value. Valid values are Dry (no water vapor 
present in the gas), Wet (saturated water vapor 
present in the gas), or As Delivered (may contain 
some water vapor) for the Heating Value Basis. 
This field does not affect the flow or energy 
calculations, and is for accounting purposes only. 

Heating Value  Sets the gross volumetric heating value of the 
measured fluid at base conditions. For gas, this 
value represents the real heating value, rather than 
the ideal heating value. 

Specific Gravity Indicates the value the system uses to calculate 
specific gravity, which is the ratio of the density of 
the flowing gas to the density of the reference gas. 
You must enter this value if it is not provided by a 
gas chromatograph. 

 
3. Click Apply if you change any parameters on this screen.  
4. Proceed to the Station Setup’s Advanced tab.   
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Station Setup: Advanced Tab  
Use the Advanced tab to configure a number of additional parameters 
that affect the flow calculation. 
1. Select the Advanced tab. The Advanced tab screen displays. 

 
Figure 8-4. Station Setup – Advanced tab 

2. Review the following fields for your organization’s values.  

Field Description 
FPV Method  Sets the method of determining a compressibility 

factor for AGA8 calculations.  Value values are: 

 Detailed Requires the natural gas composition in 
mole percent to be entered. 

 Gross I 
Uses the specific gravity of the natural 
gas; the real gas gross heating value per 
unit volume; and the mole % of CO2 as 
the quantity of non-hydrocarbon 
components.  

 Gross II Uses the specific gravity of the natural 
gas; the real gas gross heating value per 
unit volume; and the mole % of CO2 and 
the mole % of N2 as the quantity of non-
hydrocarbon components. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

8-10 Meters Menu Revised February 2024 

Field Description 
 User Requires the base compressibility, 

standard compressibility, flowing 
compressibility, base density, and 
flowing density values to be entered. 
These values become Read/Write 
enabled and may be obtained from a 
non-calculated source. The values may 
come from a User C program, FST, host 
computer, DS800 program, or a custom 
display. If none of these sources provide 
values, the last value will be held. 

 Notes:  
 If either Gross Method is chosen, manually 

enter the Specific Gravity and Heating Value in 
the Gas Quality screen. For Gross Method I, 
the Heating Value is required only for 
calculating the gas energy flow. 

 The Detailed method provides the highest 
accuracy in a broader range of measurement 
conditions; however, one of the Gross methods 
can be used when:  
o Temperature is between 0 and 54°C (32 

and 130°F). 
o Pressure is between 0 and 8274 kPa (0 

and 1200 psia). 
o Gas composition is within the normal range 

as defined in the 1992 AGA8 report. 
Use Gross methods for applications with a 
more specific range of measurement 
conditions. 

Units Sets either US (English), Metric (kPa), or Metric 
(bar) units for calculations. The difference between 
Metric (kPa) and Metric (bar) is the pressure units 
used in calculations. If you select Metric (kPa), the 
calculation expects all pressure inputs to be in kPa 
(such as kPa for the static pressure input). If you 
select Metric (bar), the calculation expects all 
pressure inputs to be in bar (such as bar for the 
static pressure input and millibar for the differential 
pressure input).  
Note: If you change this selection, remember that 
any existing entered values do not automatically 
convert to the newly selected pressure units. 

Atmospheric 
Pressure 

Sets the value of the atmospheric pressure 
(absolute) at the metering location. Valid values are 
Calculate (the value is calculated based on the 
Elevation) or Enter (type a value for the pressure). 
The units of measurement are in PSIA (US) or kPa 
(Metric). If entered, the value must be greater than 
zero. 
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Field Description 
Local Gravitational 
Acceleration 

Sets the gravitational acceleration at the metering 
location. Valid values are Calculate (the value is 
calculated from the Elevation and Latitude) or 
Enter (type a value for the acceleration). The units 
of measurement are in ft/sec2 or M/sec2. If entered, 
the value must be greater than zero. 

Base Pressure Sets the flow measurement base pressure 
specified in the gas contract. The pressure units 
are in PSIA, or kPa for Metric.  

Base Temperature Sets the flow measurement base temperature 
specified in the gas contract. The temperature units 
are in degrees Fahrenheit or degrees Celsius.  

Elevation Sets the elevation or altitude of the metering 
location. The units are in feet or meters.  

Latitude Sets the geographic latitude of the metering 
location. The units are in degrees and minutes, 
separated by a decimal point. For example: 46.15.  

Heavy Gas 
Distribution 

Set the mole percentages of heavy gas distribution 
(hydrocarbons Hexane and heavier) if the Heavy 
Gas Option was enabled on the Gas Quality tab. 
The mole percentages in the Heavy Gas 
Distribution fields must equal 100%. If the Total % 
of the distribution among the five heavier 
components is less than 100%, Hexane is 
increased to make the Total % add up to 100%. If 
the Total % of the distribution is greater than 
100%, reduction occurs in the following order: 
Decane > Nonane > Octane > Heptane > Hexane 
until the total is equal to 100%. 

 
3. Click Apply if you change any parameters on this screen.  
4. Proceed to the Station Setup’s Alarms tab. 

Station Setup: Alarms Tab 
Use the Alarms tab to configure station-wide alarming parameters. You 
can either enable or disable alarming for each station. Alarms can be 
configured for the individual meter runs and the stations. This generates 
meter-specific and station-wide alarm conditions. 
If you enable alarms, the alarms can be configured using the Alarms tab 
and are logged to the Alarm Log. To conserve log space, alarms should 
be enabled only when necessary. If you disable alarms, no alarm 
generates for this point, regardless of the alarm configuration. Alarm 
conditions display in the Active Alarms fields located in the Station 
Configuration General tab. 
Even if you do not plan to use all of the alarms, check and adjust the 
value of each alarm so that the system does not generate false alarms. 
1. Select the Alarms tab. The Alarms screen displays. 
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Figure 8-5. Station Setup – Alarms tab 

2. Review the following fields for your organization’s values.  
Field Description 
Alarming Sets Alarming as:  

 Disabled No alarms occur for this station. 

 Alarm on 
Volume/Day or 

MCF/Day 

Alarm values occur based on 
volumetric flow rate per day. 

 Alarm on 
Mass/Day or 

Mlb/Day 

Alarm values occur based on 
mass flow rate per day. 

High Alarm Sets the High Alarm limit value, in engineering units 
(EU), to which the Volumetric or Mass Flow Rate 
value must rise to generate a High Alarm. The 
Mass units assumed for the input are MCF per day 
(1000 ft3/day) or cubic meters per day (m3/day). 
The Volumetric units assumed for the input are 
MLb per day (1000 lb/day) or tonnes per day (1000 
kg/day). 

Low Alarm Sets the Low Alarm limit value, in engineering units, 
to which the Volumetric or Mass Flow Rate value 
must fall to generate a Low Alarm. The units 
assumed for the input are MCF per day (1000 
ft3/day) or cubic meters per day (m3/day). The 
Volumetric units assumed for the input are MLb per 
day (1000 lb/day) or tonnes per day (1000 kg/day). 
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Field Description 
Alarm Deadband Sets the value, in engineering units that the flow 

value must be above the Low Alarm limit and below 
the High Alarm limit before the alarm clears. The 
purpose of the Alarm Deadband is to prevent the 
alarm from being set and cleared continuously 
when the input value is oscillating around the alarm 
limit. 

RBX Sets the RBX Alarming option to configure 
Spontaneous-Report-by-Exception (SRBX) 
alarming for this point. Valid values are On Alarm 
Set (The point enters an alarm condition, the ROC 
generates a Spontaneous-Report-by-Exception 
message to the host) or On Alarm Clear (The point 
leaves an alarm condition, the ROC generates a 
Spontaneous-Report-by-Exception message to the 
host). 
Note: SRBX Alarming requires the 

communications port to be properly 
configured. 

 
3. Click Apply if you change any parameters on this screen.  
4. Click OK to return the ROC800-Series graphic.   
5. This completes the process of configuring the station. Proceed to 

Section 8.1.2, Meter Setup Configuration.  

8.1.2 Meter Setup Configuration 
To configure the meter runs, select Meter > Setup > Orifice Meter or 
Linear Meter or click on the meter icon in the configuration tree to 
open the Meter Setup screen. 
Configure the parameters on each tab as pertains to your application. 
 Set up the Stations in the Meter > Setup > Station tab. 
 Use the General tab to set basic parameters for the meter. 
 Use the Inputs tab to define the field inputs for differential pressure 

(AGA3), uncorrected volume or mass (AGA7), static pressure, and 
temperature to be used in the flow calculation. 

 Use the Advanced tab to specify additional parameters for the 
meter. 

 Use the Alarms tab to set Alarm parameters for the meter. 
 Use the Calibration Factors tab to display parameters that allow 

the selection and calculation of optional flow adjustment factor to 
compensate for the difference in condition between the meter 
location and the location where the calibration instruments were 
certified. 
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 Use the Calibration Factors tab to configure parameters that allow 
select and calculation of optional flow adjustment factor to 
compensate for the difference in condition between the meter 
location and the location where the calibration instruments were 
certified. 

 If the Linear Meter Input Type on the General tab was configured to 
Mass, use the Mass Meter Press Effect tab to setup pressure 
settings. 

Note: After configuring a meter and clicking Apply, use Flash 
Memory Save Configuration in the ROC > Flags screen to 
save I/O configuration to permanent memory in case you must 
perform a cold start. 

Meter Setup: General Tab 
Use the General tab to define basic parameters for the Meter. The 
General tab displays when you first access the Meter Setup screen. 

  

Figure 8-6. Meter Setup (Orifice) – General tab Figure 8-7. Meter Setup (Linear) – General tab 

1. Review the following fields for your organization’s values.  

Field Description 
Meter Run  Selects the number of the meter to be configured. 

Note:  The selection in this field applies to each tab 
on this screen. 

Meter Tag  Sets a short (10 alphanumeric characters) identifier 
for the meter.  
Note: The selection in this field applies to each tab 

on this screen.  
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Field Description 
Meter Description  Sets a unique description, up to 30 alphanumeric 

characters in length that further identifies or 
provides information about this meter.  

Station  Sets the station in which this meter belongs.  

Pipe Diameter  Sets the inside diameter for the pipe near the orifice 
plate in this meter run. The units are inches or 
millimeters.  
Note: This field displays only for an orifice meter. 

Orifice Diameter  Sets the diameter of the orifice plate in this meter 
run. The units are inches or millimeters.  
Note: This field displays only for an orifice meter. 

Low Flow Cutoff  Sets the low flow cutoff point. When the differential 
pressure value of the metering device is less than 
this value, the system sets the calculated flow rate 
to zero and, if alarming is enabled, records a No 
Flow alarm in the Alarm Log.  
For the AGA3-92 or ISO5167-2003 standard, this 
value is in terms of inches of water column or kPa. 
For the AGA7-96 standard, this value is in terms of 
MCF/Day. 

Meter Type  Sets the meter type that you are configuring.  
Select Flange Tapped Orifice or User Defined 
Device, for a ROC800-Series with an orifice meter 
type. 
Valid values are Volume (volume metering device) 
or Mass (Micro Motion Coriolis Mass Meter or 
similar mass meter).  

Process or Active 
Alarms  

This read-only field shows the active Process or 
Active Alarms. For example, Low indicates that the 
calculated flow is below the Low Alarm limit. Other 
alarms can include High, No Flow, and Manual 
Mode. 

AGA3/ISO5167 
Alarms 

This read-only field shows the AGA3/ISO5167 
Alarms indicating any current alarms. For example, 
Low indicates that the flow is below the Low Alarm 
limit. Other alarms can include High, No Flow, and 
Manual Mode. 

 
2. Click Apply if you change any parameters on this screen.  
3. Proceed to the Meter Setup’s Inputs tab.  

Meter Setup: Inputs Tab 
Use the Inputs tab to define the field inputs for differential pressure, 
uncorrected volume, static pressure, and temperature, which the system 
uses in the flow calculation.  
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1. Select the Inputs tab. The Inputs screen displays. 

  
Figure 8-8. Meter Setup (Orifice) – Inputs tab Figure 8-9. Meter Setup (Linear) – Inputs tab 

 

Note: Which screen displays depends on the calculation standard you 
selected on the General tab. 

2. Review the following fields for your organization’s values.  

Field Description 
Differential 
Pressure  

Sets the input that senses the differential pressure 
(or high differential pressure, if you enabled 
Stacked DP). Click the Browse button to display a 
Select TLP dialog box you use to assign the input. 
The system assumes the units for the input to be 
inches of water column (In H2O) or kPa.  
If Manual appears, use the Values field to enter an 
engineering units value for the meter input. 
Otherwise, the Values field indicates the current 
input value. 
Note: This field displays only for an orifice meter. 

Uncorrected 
Volume 

Sets the input that senses the input from a turbine 
meter (typically pulses). Click the Browse button to 
display a Select TLP dialog box you use to assign 
the input. The units assumed for the input are MCF 
per day (1000 ft3/day) or 1000 cubic meters per day 
(kM3/day) if the Metric conversion is enabled. If 
Manual appears, the Values field can be used to 
enter an engineering units value for the meter input. 
Otherwise, the Values field indicates the current 
input value, based on non-adjusted pulses from the 
turbine meter. 
Note: This field displays only for a linear meter. 

Browse Button 
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Field Description 
Static Pressure Sets the input that senses static pressure. Click the 

Browse button to display a Select TLP dialog box 
you use to assign the input. The system assumes 
the units for the input to be PSIG/PSIA or 
kPaG/kPaA.  
If Manual appears, use the Values field to enter a 
engineering units value for the static pressure input. 
Otherwise, the Values field indicates the current 
input value. 

Temperature Sets the input that senses the temperature of the 
flowing gas. Click the Browse button to display a 
Select TLP dialog box you use to assign the input. 
The system assumes units for the input to be 
degrees Fahrenheit or degrees Celsius.  
If Manual appears, use the Values field to enter an 
engineering units value for the temperature input. 
Otherwise, the Values field indicates the current 
input value. 

Stacked DP Enables the use of standard differential pressure 
transmitters for low and high pressure ranges. Valid 
values are Enabled (use stacked DP transmitters) 
or Disabled (do not allow use of stacked DP 
transmitters).  
Note: This field displays only for an orifice meter. 

Low DP Input Sets the input for monitoring low differential 
pressure. Click the Browse button to display a Set 
TLP dialog box you use to assign the input.  
You must Enable the Stacked DP parameter to use 
this input or you can leave this input in Manual 
Mode when you Disable Stacked DP. 
Note: This field displays only for an orifice meter. 

Low DP Setpoint Sets the differential pressure point at which the 
system switches over to the low differential 
pressure input.  
When the High DP input is active and the High DP 
reading drops below this value, the Low DP input 
becomes the active input. The system assumes the 
units for this input to be inches of water column (In 
H2O) or kPa. 
Note: This field displays only for an orifice meter. 

High DP Setpoint Sets the differential pressure point at which the 
system switches over to the high differential 
pressure input.  
When the Low DP input is active and the Low DP 
reading rises above this setpoint, the High DP input 
becomes the active input. The system assumes the 
units for this input to be inches of water column (In 
H2O) or kPa. 
Note: This field displays only for an orifice meter. 

 
3. Click Apply if you change any parameters on this screen.  
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4. Proceed to the Meter Setup’s Advanced tab.  

Meter Setup: Advanced Tab 
Use the Advanced tab to specify additional meter parameters.  
1. Select the Advanced tab. The Advanced screen displays.  

  

Figure 8-10. Meter Setup (Orifice) – Advanced 
tab 

Figure 8-11. Meter Setup (Linear) – Advanced 
tab 

2. Review the following fields for your organization’s values.  

Field Description 
Pressure Tap  Indicates the pressure tap type and location for this 

meter run. Valid values are: 

 Gauge or 
Absolute 

Indicates the type of pressure tap. 
This choice must match the static 
pressure type as actually measured 
by the sensor. Order the MVS 
sensor, DVS sensor, or other 
pressure transmitter to provide 
absolute or gauge measurements. 

 Upstream or 
Downstream 

Indicates the location of the static 
pressure tap in relation to the orifice 
and normal flow. Upstream is the 
default. 
Note: This field displays only for 

an ISO5167 or AGA3 
calculations. 
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Field Description 
Static Pressure 
Units  

Sets Absolute or Gauge for calculations used in 
this meter run. This choice must match the static 
pressure type is actually measured by the sensor. 
The MVS sensor, DVS sensor, or other pressure 
transmitter can be ordered to provide either absolute 
or gauge measurements. 
Note: This field displays only for an orifice meter. 

Orifice Material Indicates the material from which the orifice is made. 
Nearly all natural gas applications use stainless 
steel orifice plates.  
You must also complete the Ref Temperature field. 
This indicates the reference temperature at which 
the bore diameter of the orifice plate was measured, 
expressed in degrees Fahrenheit or degrees 
Celsius. 
Note: This field displays only for ISO5167 or AGA3 

calculations. 

Pipe Material Indicates the material from which the orifice meter 
tube material is made. Nearly all natural gas 
applications use carbon steel meter tube.  
You must also complete the Ref Temperature field. 
This indicates the reference temperature at which 
the internal diameter of the pipe was measured, 
expressed in degrees Fahrenheit or degrees 
Celsius. 
Note: This field displays only for ISO5167 or AGA3 

calculations. 

Viscosity Sets the dynamic viscosity of the flowing gas. Units 
of measure either Lbm/Ft-Sec (US Units) or cP 
(Metric Units).  

Sp Heat Ratio Sets the specific heat ratio of the gas (defined as the 
specific heat of the gas at constant pressure divided 
by the specific heat of the gas at constant volume). 
Accepted practice for natural gas applications is to 
use a value of 1.3, which was used to develop the 
expansion factor tables in the AGA 3 Report – Part 
3. If entered, the value must be greater than zero. 

Static K Factor Sets the Static K Factor for the turbine linear meter 
constant in counts/pulses per unit volume or mass, 
such as 4 pulses per cubic foot or 235 pulses/ft3. 
The volume units are in pulses ft3 or pulses m3. The 
mass units are pulses lb or pulses kg. The Static K-
factor cannot be less than zero.  

No Flow Time Sets the No Flow Time. This is the amount of time 
without a pulse after which the ROC declares a No 
Flow condition. The flow cutoff is the analog signal 
lower limit; below this limit a no flow condition exists. 
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Field Description 
Low Flow Cutoff Sets the low flow cutoff value. When the value of the 

uncorrected volume input is less than or equal to the 
low flow cutoff value, the calculated flow is set equal 
to zero. A No Flow alarm is recorded in the Alarm 
Log if Alarming is Enabled. The units are MCF/Day 
(1000 cubic feet per day) and the metric units are 
km3/day (1000 cubic meters per day). This 
parameter is only used if the uncorrected volume 
input selected is not a pulse input point type.  

Speed of Sound Sets the status of the speed of sound calculation. If 
Enabled, the system calculates AGA10 feet per 
second or meter per second based on the Pressure, 
Temperature, and Gas Composition. AGA8 Detail 
Method must be selected and a full Gas 
Composition entered to calculate the Speed of 
Sound.  
For diagnostic purposes, Speed of Sound measures 
may be read through a serial connection to an 
ultrasonic flow meter and stored under the 
Measured Speed of Sound to be compared to the 
Calculated value. 

Variable K Factor Sets the K Factor values at multiple input 
frequencies, if the Variable K Factor is enabled. If 
the Variable K Factor is disabled, a static factor will 
be used.  
The K factor is used in the flow calculations to 
convert raw pulses to either Volume or Mass. This 
conversion may vary with flow rate and Variable K 
Factors allow you to specify flow rates as indicated 
by Frequency. The K Factor values cannot be less 
than zero. Up to twelve K Factor and Frequency 
values can be entered. 

Temperature Tap Indicates the location of the temperature tap for this 
meter run. Valid values are: 
Upstream (the default) and Downstream. If you 
select Downstream, the system displays the 
Calculate Upstream Temperature option. Leave that 
option blank to indicate that you do not require a 
calculation, or click the option to display the Joule-
Thompson Coefficient field and specify how the 
system calculates upstream temperature.  
Note: This field displays only if you select ISO5167-

2003 as a Calculation Standard on the 
General tab. 
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Field Description 
Joule-Thomson 
Coefficient 

Sets how the system obtains the value for the Joule-
Thompson coefficient used in upstream temperature 
calculations. Valid values are Calculate (the default) 
or Enter (use a specific value). If you click Enter, the 
system enables the coefficient value field. The 
specific coefficient value must be greater than zero.  
Note: This field displays only if you select ISO5167-

2003 as a Calculation Standard on the 
General tab and check the Calculate 
Upstream Temperature field in the 
Temperature Tap frame. 

3. Click Apply if you change any parameters on this screen.  
4. Proceed to Meter Setup Alarms Tab.  

Meter Setup: Alarms Tab 
Use the Alarms tab to configure alarm parameters. You can either 
enable or disable alarming for each meter run. You can configure alarms 
for the individual meter runs and identify meter-specific alarm 
conditions.  
If you enable alarms, the system logs alarms on the alarm log. To 
conserve log space, enable alarms only when required. If you disable 
alarms, the system does not generate an alarm for this point, regardless 
of the alarm configuration. However, the system displays alarm 
conditions in the Active Alarms field located in the Meter Setup General 
tab or the Station Configuration General tab. 
Even if you do not plan to use all the alarms, check and adjust the value 
of each alarm to prevent the generation of false alarms. 
1. Select the Alarms tab. The Alarms screen displays. 

  

Figure 8-12. Meter Setup (Orifice) – Alarms tab Figure 8-13. Meter Setup (Linear) – Alarms tab 
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2. Review the following fields for your organization’s values. 

Field Description 
Process Alarming / 
Alarming 

Sets the alarming option for the selected meter.. 
Enabled alarms can be based on either the 
Corrected Volume Flow Rate per Day, the 
Corrected Volume Flow Rater per Hour, the Mass 
Flow Rate per Day, or the Mass Flow Rate per 
Hour. Valid values are: 

 Disabled No alarms occur for this station. 

 Alarm on 
Volume/Day   

Alarm values occur based on 
volume per day. Units are 
MCF/day or km3/day. 

 Alarm on 
Mass/Day  

Alarm values occur based on 
mass per day. Units are Mlb/day 
or tonnes/day 

 Alarm on 
Volume/Hour  

Alarm values occur based on 
volume per hour. Units are 
CF/hour or m3/hour. 

 Alarm on 
Mass/Hour  

Alarm values occur based on 
mass per hour. or lb/hour 

AGA3/ISO5167 
Alarming 

Sets the alarm option for this point. Valid values are 
Enabled (configures the limit alarms - high, low, 
and Deadband) or Disabled (does not generate 
limit alarms).  
Note: The Point Fail alarm may appear in the 

Active Alarms field, but is not logged in the 
Alarms file. If you Enable alarming, the 
system generates an alarm if you disable 
scanning. 

RBX Alarming  Sets the Spontaneous Report-by-Exception (RBX 
or SRBX) alarming options for the meter run. Valid 
values are On Alarm Set (When the point enters 
an alarm condition, the ROC generates a 
Spontaneous-Report-by-Exception message to the 
host) or On Alarm Clear (When the point leaves 
an alarm condition, the ROC generates a 
Spontaneous-Report-by-Exception message to the 
host). 

High Alarm Sets the value to which the calculated flowrate 
must rise to generate a high alarm. Units are 
dependent upon the alarm selected. 

Low Alarm Sets the value to which the calculated flowrate 
must fall to generate a low alarm. Units are 
dependent upon the alarm selected. 

Alarm Deadband Sets a value that defines an inactive zone above 
the Low Alarm limits and below the High Alarm 
limits. This deadband prevents the system from 
setting and clearing the alarm continuously when 
the input value is oscillating around the alarm limit. 
Units assumed for the input are MCF per day (1000 
ft3/day) or cubic meters per day (m3/day). 
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3. Click Apply if you change any parameters on this screen.  
4. Proceed to the Meter Setup’s Calibration Factors tab.  

Meter Setup: Calibration Factors Tab 
Use the Calibration Factors tab to define instrument-specific parameters 
that can affect calibration of the meter inputs. 
1. Select the Calibration Factors tab. The Calibration Factors screen 

displays. 

  
Figure 8-14. Meter Setup (Orifice) – Calibration 

Factors tab 
Figure 8-15. Meter Setup (Linear) – Calibration 

Factors tab 
 

2. Review the following fields for your organization’s values. 

Field Description 
Deadweight 
Gravitational 
Calibration  

Sets when the factor Fpwl is used to correct for the 
effect of local gravity on the weights of a 
deadweight calibrator. The calibrator weights are 
usually sized for use at a standard gravitational 
force or at some specified gravitational force. A 
correction factor must then be applied to correct the 
calibrations to the local gravitational force. 
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Field Description 
Deadweight 
Gravitational 
Calibration: Static 
Pressure  

Sets whether any corrections occur for local 
gravity’s effects on dead weight calibrations to 
static pressure. The system multiplies the factor 
Fpwl by the base volume flow equation. The 
system uses the factor Fpwl to correct for the effect 
of local gravity on the weights of a dead weight 
calibrator, which are usually sized for use at a 
standard gravitational force or at some specified 
gravitational force. A correction factor must then be 
applied to correct the calibrations to the local 
gravitational force. 
Note: When a dead weight calibrator is used for 

the differential pressure and the static 
pressure, both must be corrected for local 
gravity. This involves using Fpwl twice. 

Deadweight 
Gravitational 
Calibration: Diff 
Pressure  

Sets whether any corrections occur for local 
gravity’s effects on dead weight calibrations to 
differential pressure. 
Note: This field displays only for an orifice meter. 
For each selection, the system multiplies the factor 
Fpwl by the base volume flow equation once for 
each selection. 
The system uses the factor Fpwl to correct for the 
effect of local gravity on the weights of a dead 
weight calibrator, which are usually sized for use at 
a standard gravitational force or at some specified 
gravitational force. A correction factor must then be 
applied to correct the calibrations to the local 
gravitational force. When a dead weight calibrator 
is used for the differential pressure and the static 
pressure, both must be corrected for local gravity. 
This involves using Fpwl twice. 

Calibrated Grav. 
Accel.  

Sets a gravitational acceleration value if the tester 
value differs from the indicated value. The system 
assumes the units to be Ft/Sec 2 or m/Sec 2. 

User Correction 
Factor  

Sets a factor the system multiplies by the base 
volume flow equation to make a desired adjustment 
to the flow. 
Note: If you use the default value of 1, the system 

does not apply any correction. 
 
3. Click Apply if you change any parameters on this screen.  
4. Proceed to the Meter Setup’s Mass Meter Press Effect tab.  

Meter Setup: Mass Meter Press Effect Tab 
If the Linear Meter Input Type on the General tab was configured to 
Mass, use the Mass Meter Press Effect tab to setup pressure settings.    

Note: You must select Mass as the Linear Meter Input Type on the 
General tab to access the Mass Meter Press Effect screen. 
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1. Select the Mass Meter Press Effect tab. The Mass Meter Press 
Effect screen displays.   

 
Figure 8-16. Meter Setup (Linear) – Mass Meter Press Effect tab 

2. Review the following fields for your organization’s values. 

Field Description 
Correction for 
Pressure Effect on 
Mass Flow 
Accuracy 

Sets the Correction for Pressure Effect on Mass 
Flow Accuracy when the mass input requires 
compensation for process pressure on the Coriolis 
tube. If Correction for Pressure Effect on Mass 
Flow Accuracy is Enabled, enter a Pressure Effect 
in percent per PSI. 

Pressure Effect  If Correction for Pressure Effect on Mass Flow 
Accuracy is Enabled, enter a pressure correction 
Pressure Effect in percent per PSI. This value is 
supplied by the manufacturer of the mass meter. 

Calibration 
Pressure  

Sets the pressure of the mass meter as calibrated 
in PSI. 

 
3. Click Apply if you change any parameters on this screen.  
4. Click OK to return to the ROC800-Series graphic.   
5. This completes the process of configuring the station. Proceed to 

Section 8.2, Meter Calibration Basics.  
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8.2 Meter Calibration Basics 
Use the Calibration option to verify the accuracy of your input within 
contractual parameters, to calibrate those inputs to desired parameters, 
or to establish calculation adjustment factors to assure the inputs are 
within desired parameters. 
The Calibration routine provides verify, calibrate, and zero 
shift/offset/RTD Bias functions for AI, MVS, DVS, and RTD inputs. 
You can calibrate Differential Pressure (orifice metering may be high or 
low differential pressure, depending on the device), static pressure, or 
temperature readings are available for each meter run. Calibration 
parameters include zero, span, and up to three midpoints. 
The system automatically logs all new calibration values in the Event 
Log and optionally to a calibration log. 
Select Meter > Calibration > Orifice Meter or Linear Meter. The 
Meter Calibration screen displays.  

  
Figure 8-17. Meter Calibration (Orifice) Figure 8-18. Meter Calibration (Linear) 

Notes:  
 ROCLINK 800 removes input categories from the Freeze Values 

frame of this screen depending on the selected meter. For orifice 
meters, you can calibrate differential pressure, static pressure, and 
temperature inputs. For a turbine meter, you can calibrate static 
pressure and temperature inputs. When calibrating stacked 
differential pressure, you can calibrate either high differential 
pressure (Diff Pressure) input or low differential pressure (Low DP) 
input. 
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 During calibration, the ROC times out and resumes normal 
processing if it is left idle for an extended period of time. Calibration 
values are restored to the previous values, an event is logged, and 
you must reconnect to start calibration from the beginning. 

 Click Cancel to exit the calibration without saving the changes. The 
previous calibration settings are retained. An Event is also logged. 

 

Field Description 
Meter  Selects the meter for verification or calibration. 

Click ▼ to display all defined meter runs.  

Meter Tag This read-only field shows the short description 
associated with the selected meter.  

Freeze Button Click to stop the system from updating meter data, 
analog, DVS, MVS, or temperature (RTD) inputs 
during verification or calibration.  

Freeze Values These read-only fields show the value received 
from the analog input, DVS, HART, MVS, RTD or 
Meter inputs when the Update button was last 
clicked. The system uses these values in ongoing 
processing (such as flow calculations, history 
logging, or control) while calibration occurs. 

Verify Click to start the verification process.  

Calibrate Click to begin calibration. When this button is 
pressed, the Set Zero dialog box opens. 

Zero 
Shift/Offset/RTD 
Bias 

Click to set adjustment factors for the input. The 
value is sent to the device for:  

 Zero Shift Zeros the static pressure effect for 
the differential pressure input (Set 
Offset). 

 Offset Sends the value of the live reading 
to set the reading as close to zero 
as possible for a static pressure 
inputs (Measured Pressure 
Reading). 

 RTD Bias Calibrates the offset (shift) of 
temperature throughout the RTD 
curve (Temperature Standard 
Reading). 

Auto Scan/Stop 
Scan 

Click to automatically request values each second 
from the meter. The request continues until you 
click Freeze.  

Update Button  Click to request a value update from the input to be 
used as the Freeze Values.  
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8.2.1 Verifying an Input 
To verify an input:  
1. Select Meter > Calibration > Orifice Meter or Linear Meter. The 

Meter Calibration screen displays.  

 
Figure 8-19. Linear Meter Calibration 

2. Select a Meter input to verify. 

Note: ROCLINK 800 retains or removes the appropriate inputs 
from the Meter Calibration screen. The following example 
verifies a temperature sensor for a turbine meter. 

3. Click Freeze. ROCLINK 800 displays a dialog asking if you want 
to create a calibration report file. 

 
Figure 8-20. Calibration Report File 

4. Click Yes to display a Save As dialog box and specify a storage 
location for the report, which you can review later. Click No to 
proceed with verification without generating a report. ROCLINK 
800 displays the Meter Calibration screen with frozen values and 
active buttons. 
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Figure 8-21. Linear Meter Calibration – Frozen Values 

5. Click Verify. A Verify screen displays. 

 
Figure 8-22. Verify 

Field Description 
Point  This read-only field shows the point (differential 

pressure, static pressure, or temperature) being 
verified.  

Action Indicates the current action. Valid values are Verify 
or Calibrate. 

Actual Displays the value in the Live Reading field. 
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Field Description 
Expected Displays the value in the Dead Weight/Tester 

Value field. 
Deviation Displays the amount of deviation between the 

actual and expected values.  
% Deviation Displays a percentage deviation between the 

Actual and Expected values. 
Dead Weight/Tester 
Value  

Sets the expected value against which the system 
tests and calibrates. 
Note: This is the Expected value in the Action 

field. 
Live Reading with 
Offset applied 

This read-only field shows the current reading 
from the sensor. If you have configured an offset, 
the value appears in the Offset applied field.  

Deviation and % 
Deviation  

This read-only field shows the deviation between 
the Actual and Expected values, such as the 
difference between the live pressure or 
temperature reading and the measured pressure or 
temperature reading. 
(%Deviation = Deviation [(Span EU – Zero EU) x 
100%]). Use this value to determine the need for 
calibration or adjustment.  

Log Verify  Click to write the displayed data to the Event Log. 
 
6. Complete the Dead Weight/Tester Value field with a value against 

which the test equipment verifies. 

 
Figure 8-23. Dead Weight/Tester Value 
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When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it to the value in the Live 
Reading field (obtained from the temperature probe) and calculating the 
percentage deviation between the two values. 
7. Click Log Verify. ROCLINK 800 completes the first log entry on 

the screen. 

 
Figure 8-24. Verify Log Entry 

8. As the live reading value changes, click Log Verify as many times 
as necessary to establish the verification log. 

Typically you verify the same points you calibrate (zero, span, and 
mids). Temperature might be an example (– 100, 200, 50). For each test 
point, you set your test equipment to produce the expected value, enter 
that expected value in the Tester Value field, wait for live input to 
stabilize, and then click Log Verify. You can verify as many points as 
you want. 

Note: If you have chosen to save the verification log, ROCLINK 800 
saves it in the location you specified in step 4. 
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Figure 8-25. Verify Log Entry 

9. Review the verification log and determine whether the results are 
within contractual limits. If they are not, you may need to calibrate 
the temperature probe. See Section 8.2.2, Calibrating an Input 
Example. 

10. Click Done. The Meter Calibration screen displays. 

8.2.2 Calibrating an Input Example 
Following verification, you may determine that the input needs to 
calibrate. A standard calibration requires you to define a zero and a span 
point; you can also define up to three midpoints that can represent 25%, 
50%, and 75% of the span. 
 

 Caution If you are calibrating a pressure input, isolate the sensor from the 
process. Set up the pressure calibrator and make the necessary 
connections to the sensor.  
If you are calibrating a temperature input, disconnect the RTD sensor 
and connect a decade box (or compatible equipment) to the device’s 
RTD terminal.    

 

Note: You can exit a calibration without saving the changes. The 
system retains the previous calibration settings but logs the event 
in the event log. 

To calibrate an input (in this example, the static pressure input): 
1. Select Meter > Calibration > Orifice Meter or Linear Meter. The 

Meter Calibration screen displays.  
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2. Select a Meter input to calibrate. 

Note: ROCLINK 800 retains or removes the appropriate inputs from 
the Meter Calibration screen. The following example calibrates a 
static pressure sensor for a turbine meter. 

 
Figure 8-26. Linear Meter Calibration 

3. Click Freeze. ROCLINK 800 displays a dialog asking if you want 
to create a calibration report file using the original format or the 
BLM format. 

 
Figure 8-27. Calibration Report File 

4. Select one of the following choices: 
 Click Yes-Original Format to display a Save As dialog box and 

specify a storage location for the report, which you can review 
later. 

 Click Yes-BLM Format to display a Save As dialog box, 
specify a storage location for the report, and then display the 
BLM Report Required Information screen and input the required 
information. The BLM format allows you to enter site, 
calibration equipment, tester, and witness information that 
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appears on your calibration report. You can also copy this 
information from a previous BLM Format calibration report to 
the current report on the BLM Report Required Information 
screen. 

 
Figure 8-28. BLM Report Required Information 

 Click No Report to proceed with verification without generating 
a report. ROCLINK 800 displays the Meter Calibration screen 
with frozen values and active buttons. 
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Figure 8-29. Calibration – Frozen Values 

5. Click Calibrate. A Set Zero screen displays. 

 
Figure 8-30. Set Zero 

Note: You can click Cancel to exit the calibration without saving the 
changes. The system retains the previous calibration settings but 
logs the event in the event log. 

Field Description 
Point  This read-only field identifies the point (differential 

pressure, static pressure, or temperature) being 
verified.  

Action Shows the activity being performed. Valid values 
are Set Zero, Set Span, Set Mid 1, Set Mid 2, and 
Set Mid 3 
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Field Description 
As Found Shows the sensor’s initial value. 

As Left Shows the sensor’s value after calibration. 

Deviation Shows the difference between the As Found value 
and the As Left value. 

% Deviation Shows the difference between the As Found and 
As Left values as a percentage. 

Set Zero  Calibrate the zero value (0% of range) for the in 
differential pressure (orifice only), static pressure, 
or temperature. This should correspond with the 
Low Reading EU (0% Count) and is the low value 
for the input. Set the Dead Weight/Tester Value 
(in engineering units). This is the input desired for 
the test value and is the actual value expected by 
the test equipment being calibrated against. For 
example: When calibrating temperature for an RTD 
input, enter the degree value associated with the 
resistance set up in the decade box or other 
equipment. 

Set Span  Calibrate the span value (100% of range) for 
differential pressure (orifice only), static pressure, 
or temperature. Set the Dead Weight/Tester Value 
(in engineering units). This should correspond with 
the High Reading EU (100% Count) and is the high 
value to the input (the top end of the expected 
operating range).  
For static pressure on an absolute-pressure 
device, remember to add in the actual atmospheric 
pressure, for example, 300 + 14.73. 

Set Midpoints If desired, calibrate midpoint 1 (such as 25% of 
range) for the differential pressure (orifice only), 
static pressure, or temperature, otherwise click the 
Done button. Midpoints allow you to specify the 
low, middle, and high calibration point between the 
zero and span endpoints. Set the Dead 
Weight/Tester Value (in engineering units). 
If desired, calibrate Midpoint 2 (such as 50% of 
range) for the Differential Pressure (orifice only), 
Static Pressure, or Temperature. Set Midpoint 2 
allows you to specify the middle calibration point 
between the Zero and Span endpoints. 
If desired, calibrate Midpoint 3 (such as 75% of 
range) for the Differential Pressure (orifice only), 
Static Pressure, or Temperature. Set Midpoint 3 
allows you to specify a third point between the Zero 
and Span endpoints. 
Note: You can calibrate Midpoints in any order 

from low to high or high to low. 
 
6. Set test equipment to produce the expected results. 
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7. Complete the Dead Weight/Tester Value field. This value 
represents the low range (0%) of the instrument’s measurement 
range. 

 
Figure 8-31. Dead Weight/Tester Value 

When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once each second to the 
value in the Live Reading field (obtained from the static pressure 
sensor) and calculating the percentage deviation between the two values. 
8. Click Set Zero when the live reading stabilizes. ROCLINK 800 

adds the first line in the calibration log, renames the screen to Set 
Span, and changes the label on the Set Zero button to Set Span. 

 
Figure 8-32. Set Span 
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9. Set test equipment to produce the expected results. 
10. Complete the Dead Weight/Tester Value field with a value 

represents the upper limit (100% or "span") of the instrument’s 
measurement range. 

Note: ROCLINK 800 provides 100 as a default span value. Edit 
this default as necessary. 

 
Figure 8-33. Set Span 

When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once each second to the 
value in the Live Reading field (obtained from the static pressure 
sensor) and calculating the percentage deviation between the two 
values. 

11. Click Set Span when the live reading stabilizes. ROCLINK 800 
adds the next line in the calibration log, renames the screen, and 
changes the label on the Span button to Set Mid 1. 
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Figure 8-34. Set Span 

Note: You can click Done at this point to complete the calibration 
or continue the calibration and define up to three calibration 
midpoints. 

12. Set test equipment to produce the expected results. 
13. Complete the Dead Weight/Tester Value field with the first 

midpoint calibration value (which in this example represents 50% of 
the instrument’s range). 

Note: ROCLINK 800 provides the previous midpoint value as a 
default value. Edit this default as necessary. 

 
Figure 8-35. Set Midpoint 1 
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When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once per second to the 
value in the Live Reading field (obtained from the static pressure 
sensor) and calculating the percentage deviation between the two 
values. 

14. Click Set Mid 1 when the live value stabilizes. ROCLINK 800 adds 
the next line in the calibration log, renames the screen, and changes 
the label on the Set Mid 1 button to Set Mid 2. 

 
Figure 8-36. Set Midpoint 2 

Note: To define up to two more midpoints, repeat steps 13 and 14. 

15. Click Done when you have sufficient calibration information. The 
Meter Calibration screen displays. 

Note: Following a calibration, you may re-run a verification to 
demonstrate to the customer that the measurement results are 
now within contractual parameters. 

8.2.3 Zero Shift/Offset/RTD Bias  
Use these buttons on the Meter Calibration screen to make adjustments 
to calibrated values. These allow you to adjust the calibrations at 
flowing conditions. The following example shows a zero shift 
adjustment. 

Note: Because these adjustments can affect the contractual delivery of 
product, exercise caution in using these options. 

1. From the Meter Calibration screen, click Offset. The Set Zero Shift 
(Offset) screen displays. 
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Figure 8-28. Set Zero Shift 

Field Description 
Zero Shift Click to zero the static pressure effect for the 

differential pressure input (Set Offset).  

Offset Click to send the value of the live reading to set the 
reading as close to zero as possible for a static 
pressure inputs (Measured Pressure Reading).  

RTD Bias Click to calibrate the offset (shift) of temperature 
throughout the RTD curve (Temperature Standard 
Reading).   

Measured Pressure 
Reading  

Sets the pressure as read from a calibrated 
pressure sensor. 
Note: This field displays only for static pressure 

points. 

Pressure Offset  This read-only field shows the difference between 
the live pressure reading and the measured 
pressure reading that ROCLINK 800 applies to the 
pressure value.  
Note: This field displays only for static pressure 

points. 
 
2. Complete the Measured Pressure Reading field with a line 

pressure value obtained from an independent pressure measurement 
device and begin monitoring the value in the Pressure Offset field. 
Each second the system compares the live reading against the value 
you enter. When the value in the Pressure Offset field stabilizes, 
click Set Offset. ROCLINK 800 sets the pressure offset and adds a 
line to the calibration log. 
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Figure 8-29. Set Zero Shift 

3. The system then reflects this offset as an adjustment in calculations 
and lists this value on the AI Calibration Values screen (Utilities > 
AI Calibration Values). 

 
Figure 8-30. AI Calibration Values 

Sending the Differential Pressure Zero Shift (Offset) 
After you have calibrated differential pressure, click Zero Shift to zero 
the static pressure effect for the differential pressure input if required. 
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Figure 8-31. Set Zero Shift (Offset)  

1. After you have calibrated differential pressure, click Zero Shift to 
zero the static pressure effect for the differential pressure input if 
required. 

2. Apply the typical line pressure to both the high and low side of the 
sensor. 

3. Click Set Offset to send the value to the live reading to get the 
reading as close to zero as possible. 

4. Click Done or Cancel to close the dialog box. 

Sending the Static Pressure Offset 
Sets the Offset to send the value of the live reading to get the reading as 
close to zero as possible for a static pressure input. 

 
Figure 8-32. Set Zero Shift (Offset 

1. After you have calibrated static pressure, click Offset to calibrate 
the offset (shift) of static pressure if required.  
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2. Enter a value for the Measured Pressure Reading, which is the 
pressure as read from a calibrated pressure sensor. 

3. Click Set Offset to send the value to the live reading to get the 
reading as close to the measured reading as possible. 

4. Click Done to close the dialog box.  

Sending the Temperature RTD Bias 
Calibrate the offset (shift) of temperature throughout the RTD curve if 
required. 
1. After you have calibrated the temperature input, click RTD Bias 

button on to calibrate the offset (shift) of temperature throughout the 
RTD curve if required. The Set RTD Bias screen displays. 

 
Figure 8-33. Set RTD Bias 

Field Description 
Temperature 
Standard Reading  

Sets the temperature as read from a calibrated 
temperature probe. 
Note: This field displays only for temperature 

points. 

Live Reading This read-only field shows the live temperature 
reading. 

With Offset Applied This read-only field shows the live temperature 
reading with the calibrated offset applied. 

Temperature Bias  This read-only field shows the difference between 
the live temperature reading and the entered 
standard temperature reading that ROCLINK 800 
applies to the temperature value. 
Note: This field displays only for temperature 

points. 
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2. Enter a value for the Temperature Standard Reading, which is 
read from a calibrated temperature probe.  

3. Click Set Offset to send the value to the live reading to get the 
reading as close to the measured reading as possible. 

4. Click Done to close the dialog box.  

8.3 Meter Values 
The Meter Values screen displays a variety of values from the orifice or 
linear meter. You can use these for diagnostics or monitoring. Select 
either Meter > Values > Orifice Meter or Meter > Values > Linear 
Meter. The meter values screen displays. 

8.3.1 Meter Values: Values Tab 
Use the Values tab to view a variety of values from the selected meter. 
The Values tab displays when you first access the Meter Values screen.  

  

Figure 8-34. Meter Values (Orifice) – Values tab Figure 8-35. Meter Values (Linear) – Values tab 

1. Review the following fields for your organization’s values. 

Field Description 
Meter Selects the meter that you wish to monitor. Click ▼ 

to display all defined meter runs. 

Tag This read-only field shows the short description 
associated with the selected meter. 

Description This read-only field shows the description 
associated with the selected meter.  

Differential 
Pressure (orifice) 

This read-only field shows the differential pressure 
value for the selected meter run. 

Uncorrected Flow 
(linear)  

This read-only field shows the uncorrected flow 
value for the selected meter run. 

Static Pressure This read-only field shows the static pressure 
value for the selected meter run. 
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Field Description 
Temperature This read-only field shows the temperature value 

for the selected meter run. 

Current Flow Rates  These read-only fields display the current Flow 
Rate, Energy Rate, and Mass Rate. 

Accumulation  The read-only field shows the accumulated flow, 
energy, flowing minute, and mass values. 

 
2. Click ▼ select a defined orifice or turbine meter. 
3. Review the screen’s contents. You can click Update to refresh the 

display on demand or Auto Scan to start updating the display once 
per second. 

4. Proceed to Section 8.3.2 to view the Meter Factors tab. 

8.3.2 Meter Values: Factors Tab 
Use the Factors tab to view meter factor values for the selected meter 
run. 
1. Select the Factors tab. The Factors screen displays.  

  

Figure 8-36. Meter Values (Orifice) – Factors tab Figure 8-37. Meter Values (Linear) – Factors tab 

2. Review the following fields for your organization’s values. 

Field Description 
Factors  The read-only fields show current status of 

calculated and entered parameters of the meter. 
These values are calculated by the firmware. 

 
3. Review the screen’s contents. You can click Update to refresh the 

display on demand or Auto Scan to start updating the display once 
per second.  
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8.4 Plate Change 
The Plate Change option allows you to change the size of an orifice 
plate under flowing or non-flowing conditions. 
1. Select Meter > Plate Change. The Plate Change field displays. 

 
Figure 8-38. Plate Change  

2. Review the following fields for your organization’s values. 

Field Description 
Meter Number Sets the meter number to be changed. Click  to 

display all defined meters.   
Will Plate Change… Indicates the conditions during the plate change. 

Valid values are Yes (plate change occurs during 
flowing conditions) or No (plate change occurs during 
non-flowing conditions).  
Note: If you choose Yes, you can freeze inputs for 

the duration of the plate change.  
Freeze Click to freeze input values for the duration of the 

plate change.  
Note: This button is active only if you are 

performing the plate change under flowing 
conditions. The system holds all I/O values in 
manual mode at the current value. Click OK 
to return values to an active state at the 
completion of the plate change.  

Differential Press This read-only field shows the frozen differential 
pressure value during the plate change.  

Static Press  This read-only field shows the frozen static pressure 
value during the plate change.  

Temperature This read-only field shows the frozen temperature 
value during the plate change.  

Pipe Diameter This read-only field shows the size of the pipe 
diameter for the selected meter.  
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Field Description 
Orifice Diameter Sets, in inches or millimeters, the exact size of the 

orifice diameter of the new plate.  
 
3. Click ▼ to select the correct Meter Number for the meter run you 

are changing. 
4. Select Yes if the plate change occurs during flowing conditions. You 

will be allowed to freeze the inputs for the duration of the plate 
change process. Click No for non-flowing conditions. 

5. Click Freeze if you are performing the plate change under flowing 
conditions, the dialog box shows you the freeze value of each meter 
input (for the purpose of calculating gas flow) while the change 
occurs. All I/O values are held in manual mode at the current value. 
The values are returned to an active state after clicking OK in the 
plate change dialog box. 

6. Set the exact size of the Orifice Diameter (inches or millimeters) of 
the new plate. 

7. Click Apply if you change any parameters on this screen. 
8. Click OK when you complete the plate change. If you have frozen 

values, this returns system values to flowing conditions. 
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Chapter 9 – The Utilities Menu 

In This Chapter 

9.1 Update Firmware ............................................................................. 9-2 
9.1.1 CPU Firmware Tab ............................................................... 9-2 
9.1.2 Additional Update Firmware Tabs ........................................ 9-5 

9.2 License Key Administrator ............................................................... 9-6 
9.2.1 Managing Licenses .............................................................. 9-7 

9.3 Converting EFM Report Files .......................................................... 9-9 
9.3.1 Flow-Cal (.CFX) Conversions ............................................. 9-12 
9.3.2 PGAS Conversions ............................................................ 9-12 

9.4 User Program Administrator .......................................................... 9-21 
9.4.1 Downloading a User Program ............................................ 9-23 
9.4.2 MPU Loading Threshold ..................................................... 9-23 

9.5 ROCLINK 800 Security .................................................................. 9-24 
9.5.1 Defining Access .................................................................. 9-25 

9.6 RTD Input Calibration Values ........................................................ 9-29 
9.7 Analog Input (AI) Calibration Values ............................................. 9-30 
9.8 MVS Input Calibration Values ........................................................ 9-32 
9.9 FST Editor ...................................................................................... 9-33 
9.10 Keypad Display Editor ................................................................... 9-33 

9.10.1 Creating a Keypad Display File .......................................... 9-34 
9.10.2 Editing a Keypad Display File ............................................. 9-36 

9.11 Custom Display Editor ................................................................... 9-40 
9.12 Custom EFM Report Editor ............................................................ 9-41 

9.12.1 Viewing Custom EFM Reports ........................................... 9-42 
9.13 Read File from Device ................................................................... 9-45 
9.14 Communications Monitor ............................................................... 9-46 
 

Use the options on the Utilities menu to update firmware, manage 
software licenses, convert EFM files, manage user programs, set 
ROCLINK 800 security, view AI, RTD, and MVS calibration values, 
access the FST Editor, and monitor communications.  

  
Figure 9-1. Utilities Menu  
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Note:  For information on the FST Editor and writing FSTs, refer to the 
Function Sequence Table (FST) User Manual (part 
D301058X012).  

9.1 Update Firmware 
Select Utilities > Update Firmware to display the Update Firmware 
screen:  

  
Figure 9-2. Update Firmware  

9.1.1 CPU Firmware Tab 
Use the Update Firmware tab to update the ROC’s internal software 
(“firmware”) that is stored in the CPU module’s flash ROM.   
Notes: 
 This option does not update the ROCLINK 800 software. 
 Firmware cannot be updated over an Ethernet connection. 
 

 Caution During the update, this option disables measurement and control. It is a 
good practice to preserve the contents of the event and alarm logs 
(saved to a file) BEFORE you update any firmware. You CANNOT reload 
event logs or alarm logs.   

 
1. Create a backup copy of the firmware update disk or download the 

firmware file from the Remote Automation Solutions website 
(http:// www.EmersonProcess.com/Remote). 

2. Read the README text file included with the firmware update. 
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3. Select Utilities > Update Firmware. The Update Firmware screen 
displays. 

Note:  By default, the system selects the Device Configuration options 
Save Device Configuration Before Firmware Update and 
Restore Device Configuration After Firmware Update. This 
saves your current configuration, calibration, communication 
settings, and FSTs to the file name you specify.  

4. Click Browse to select or specify a file name the system uses to save 
and restore the system configuration file. The default file location is 
C:\Program Files\ROCLINK800. The default file extension is .800.  

Note: You can also save the configuration to flash memory using 
the Save Configuration button on the Flags screen (ROC > 
Flags > Save Configuration).  

5. In the Firmware Image to Download frame, click Browse to specify 
the location of the update firmware code.  

Note:  The ROC800-Series uses the file extension *.dli. You can 
obtain firmware updates either from your factory 
representative or from the Remote Automation Solution 
SupportNet website 
(www.EmersonProcess.com/Remote/Emerson/support/ 
support_index.html). Regardless of source, you must store the 
firmware update files on your PC before you can apply them.  

6. Once you select a firmware upgrade, ROCLINK 800 completes the 
lower portion of the Firmware Image to Download frame with 
information related to that upgrade. Review the information to make 
sure you want to apply that upgrade. 
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Figure 9-3. Update Firmware – CPU Firmware tab  

7. Click Start. The system displays a confirmation dialog box. 
8. Click Yes to confirm the update.  

Note: The loading process typically takes several minutes. Do not 
disturb the ROC during this time. 

When firmware load completes, a dialog box displays. 

 
9. Click OK to accept the dialog box. 

ROCLINK 800 automatically loads the configuration files into the 
ROC (if you selected the Restore Device Configuration option) and 
records the actions in the event log. 
When the backup reload completes, a "Reconnect to Device 
Completed" message displays in the Status field at the bottom of the 
Update Firmware screen. ROCLINK 800 also adds an "Updated" 
flag to the information displayed in the Firmware Image to 
Download frame. You can also verify the upgrade on the Device 
Information screen (ROC > Information > Revision Info). 

10. If you saved the configuration to flash memory, ROCLINK 800 
performs a cold start to reload the configuration. 
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Note: If you selected the Restore Device Configuration After 
Firmware Update option on the Update Firmware screen, 
this step is not required. 

11. Check the configuration and FSTs. If they are not correct, reload 
them (using File > Download) from the files you created in Step 4. 

12. Save the configuration (using ROC > Flags > Save Configuration) 
to permanent memory. 

The Utilities > Update Firmware > CPU Firmware tab initially 
displays the CPU tab. Use this tab to view the currently installed 
firmware version, save a current configuration before downloading a 
new configuration, download a new firmware image, and restore a 
configuration after updating the firmware.  

9.1.2 Additional Update Firmware Tabs 
Depending on the configuration of your ROC800-Series, one or more 
additional tabs may display on the Update Firmware screen. These 
additional tabs enable you to update the firmware for the selected 
hardware. The additional tabs may include:  
 ACIO Module – Updates the firmware for the Alternating Current 

I/O (ACIO) module.  
 APM Module – Updates the firmware for the Advanced Pulse 

Module (APM). 
 CPU Backplane – Updates the firmware for the ROC827 CPU 

backplane. 
 Expanded Backplane – Updates the firmware for the ROC827 

expanded backplane. 
 Keypad Display – Updates the firmware for the optional Keypad 

Display. 
 MVS Module – Updates the firmware for the optional Multi-

Variable Sensor module. 
The process for updating firmware for these additional components is 
the same as the process for updating the CPU firmware. However, the 
additional Update Firmware screens identify the firmware level 
currently installed and monitor the available flash space remaining:  
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Figure 9-4. Update Firmware Example  

Note: The upgrade file may have either a .dli or a .ddi file type. This is 
normal.  

9.2 License Key Administrator 
Use the License Key Administrator screen to view and manage 
information on any software licenses currently installed on the ROC 
800-Series. Some applications require that you install a license in the 
CPU to run the application. These licenses are typically housed on a 
license key, which you insert in a specific location on the CPU (see 
License Keys in Chapter 2 of the ROC800-Series Preset Controller 
Instruction Manual (Form A6212).  
Select Utilities > License Key Administrator. The License Key 
Administrator screen displays.   
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Figure 9-5. License Key Administrator  

A ROC800-Series CPU can contain up to two license keys. The upper 
and lower portions of this screen indicate whether keys are installed and 
what licenses are present on each key. Figure 9-5 shows that the key 
installed in slot 2 contains a Liquid Calcs license and an AGA license.  

9.2.1 Managing Licenses  
You can also use this screen to manage licenses. For example, your 
organization may have obtained AGA licenses for your ROC800-Series. 
Place the license key with the AGA licenses in an empty slot in the CPU 
and use this utility to transfer a license to the ROC800-Series.   
1. Select Utilities > License Key Administrator. The License Key 

Administrator screen displays.  
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Figure 9-6. License Key Administrator  

The AGA licenses are on the second license key. To move an AGA 
license to key #1:   

2. Select the license to move. The Move and Split buttons activate. 
Note that the Quantity field indicates there are two AGA licenses.   

3. Click Split. The AGA license splits into two individual licenses.  

  

Figure 9-7. Split Licenses  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Utilities Menu 9-9 

4. Select one of the AGA licenses. The Move and Merge buttons 
activate, indicating available actions.   

5. Click Move. The selected AGA license moves to key #1.  

  

Figure 9-8. Moved License  

6. You can now remove the second license key or leave it in place, as 
your organization requires.   

9.3 Converting EFM Report Files 
Note: This section applies only to gas applications for the ROC800-

Series.  

The Convert EFM File option enables you to convert an EFM report 
file (.EFM database file) to the report file format you select. ROCLINK 
800 version 1.60 or greater supports batch conversion of EFM files to 
PGAS and Flow-Cal formats.  
To convert an EFM file: 
1. Select Utilities > Convert EFM File. The Convert EFM File screen 

displays.  
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Figure 9-9. Convert EFM File  

2. Select ROC800 as the Device Type.  
3. Select a conversion format:  
 PGAS provides .EVT, .ANA, .ARM, and .VOL file formats (for 

EMS Pipeline Services)  
 Flow-Cal provides the .CFX file format (for Coastal Flow 

Measurement, Inc.)  
Note:   
 If you select Flow-Cal, select the CFX version the system 

uses for the conversion in the CFX Version field. 
 You must configure device history in order to generate a 

CFX file that will successfully import into the Flow-Cal 
software.   

 .AGA/.DET provides standard history points for the meter run.  
Note: The Converted File Name Prefix, Select Meter Run(s) 

to Convert, and Period frames are not valid for this 
selection.   

4. Click the Browse button to select a file to convert. The Select EFM 
Files to Convert screen displays.  
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Figure 9-10. Select EFM File  

By default, the screen displays the ROCLINK800 folder and selects 
any .EFM files in that folder. If the .EFM files you want to convert 
are located in another folder, navigate to that folder and select the 
appropriate files.  

5. Select the files to convert. You can individually select files using the 
checkboxes or click Select All to select all of the EFM files in the 
folder. (Click Deselect All to unselect all files in the folder.)  

6. Click OK. 
ROCLINK 800 verifies that each file is a valid file type. If any file 
is invalid, a notification dialog displays. 
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If this dialog displays, click OK to continue. ROCLINK 800 
removes the invalid file(s) and notes the action in the Log frame on 
the Convert EFM File screen.   

7. Select the Converted File Name(s) Prefix options to determine the 
converted file name format.  
 Use Station Address & Group – Includes the Station Address 

and Group in the file name. 
 Use Current Data & Time – Includes the current data and time 

in the file name. 
8. Select meter runs in the Select Meter Run(s) to Convert frame.  
9. Select the Period Start Date and End Date to define the time frame 

for which the conversion of data is performed. The Start Date is 
automatically post dated 35 days prior to the end date. The End Date 
defaults to the current date. You can manually enter a date or click 
▼ to display a calendar and make your date selections.  

10. Click Start Conversion. 
11. Click OK when the conversion completes. 

Note:  If you click Cancel any time during the conversion, you must 
click OK when prompted to acknowledge that you’ve canceled 
the conversion process. 

9.3.1 Flow-Cal (.CFX) Conversions 
Selecting Flow-Cal performs conversion of EFM files to the Flow-Cal 
(Coastal Flow) .CFX format. For additional information on the Flow-
Cal and the .CFX file format, refer to the documentation provided with 
your Flow-Cal product and the web site www.flowcal.com. 

Note:  You must configure device history in order to generate a CFX 
file that will successfully import into the Flow-Cal software. 

9.3.2 PGAS Conversions 
The PGAS exports the EFM file data to four files. The PGAS event file 
(.EVT) lists all of the events in the Event Log that are related in any 
way to a meter run. The exception is gas quality events that are included 
in the PGAS quality file (.ANA).   

PGAS Gas 
Quality Files 

All gas quality data converts to an .ANA file. The gas quality data is 
retrieved from the roc in the form of parameter change events to the gas 
quality parameters if the gas quality type (Point Type 112, Parameter 
24) is configured for entered values (0). The event log scans for gas 
quality events and any group of unique gas quality events that occur 
within a five minute period appear as one record. Use the date and time 
stamp for the latest event for the SAMPLE_DATE.  

http://www.flowcal.com/
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The gas quality data is retrieved from the ROC in the form of hourly 
historical averages of the gas quality parameters if the gas quality (Point 
Type 112, Parameter 24) is configured for live values (1). 

# Column Name Data Type Description 
1 METER_ID char(16) Identification number for the measurement point in the 

field. Tag of the orifice or turbine point associated with 
the alarm. 

2 SAMPLE_DATE datetime Actual date and time of the sample in mm/dd/yyyy 
hh:mm format and is the date and time of the event 
excluding the seconds. 

3 EFFECTIVE_DATE datetime Optional date and time for which the sample should be 
considered "effective" in mm/dd/yyyy hh:mm format. Not 
used for the gas quality events. 

4 GAS_SAMPLE_TYPE char(2) Sample Type: 
CO = Continuous if the gas quality type in the ROC (Point 

Type 112, Parameter 24) is equal to 1 for live Gas 
Quality values. 

SP = Spot if the gas quality type is equal to 0 for entered 
gas quality values. 

5 SAMPLE_ID char(2) Not used by PGAS or ROC (informational only). 
6 METHANE_MOL float ROC Point Type 112 (Station), Parameter 28 
7 ETHANE_MOL float ROC Point Type 112 (Station), Parameter 29 
8 PROPANE_MOL float ROC Point Type 112 (Station), Parameter 30 
9 IBUTANE_MOL float ROC Point Type 112 (Station), Parameter 32 
10 NBUTANE_MOL float ROC Point Type 112 (Station), Parameter 31 
11 IPENTANE_MOL float ROC Point Type 112 (Station), Parameter 34 
12 NPENTANE_MOL float ROC Point Type 112 (Station), Parameter 33 
13 NHEXANE_MOL float ROC Point Type 112 (Station), Parameter 35 
14 NHEPTANE_MOL float ROC Point Type 112 (Station), Parameter 36 
15 NOCTANE_MOL float ROC Point Type 112 (Station), Parameter 37 
16 NNONANE_MOL float ROC Point Type 112 (Station), Parameter 38 
17 NDECANE_MOL float ROC Point Type 112 (Station), Parameter 39 
18 N2_MOL float ROC Point Type 112 (Station), Parameter 26 
19 CO2_MOL float ROC Point Type 112 (Station), Parameter 27 
20 H2O_MOL float ROC Point Type 112 (Station), Parameter 41 
21 H2S_MOL float ROC Point Type 112 (Station), Parameter 40 
22 H2_MOL float ROC Point Type 112 (Station), Parameter 45 
23 CO_MOL float ROC Point Type 112 (Station), Parameter 44 
24 O2_MOL float ROC Point Type 112 (Station), Parameter 43 
25 HE_MOL float ROC Point Type 112 (Station), Parameter 42 
26 AR_MOL float ROC Point Type 112 (Station), Parameter 62 
27 GRAVITY float ROC Point Type 112 (Station), Parameter 23 
28 AMPLE_PRESSURE_BASE float Pressure base at which the BTU value was measured; 

however, this is left blank as the ROC does not include a 
Parameter. 

29 DRY_ENERGY_FACTOR float This field is for heating value (ROC Point Type 112, 
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# Column Name Data Type Description 
Parameter 22) if "Dry" (0) is selected for the Heating 
Value Basis (ROC Point Type 112, Parameter 21). 

30 SAT_ENERGY_FACTOR float This field is for heating value (ROC Point Type 112, 
Parameter 22) if "Wet" (1) is selected for the Heating 
Value Basis (ROC Point Type 112, Parameter 21). 

31 AS_DELIVERED_ENERGY_FACT
OR 

float This field is for heating value (ROC Point Type 112, 
Parameter 22) if "As Delivered" (2) is selected for the 
Heating Value Basis ROC Point Type 112, Parameter 
21). 

32 to 
53 

N/A N/A These fields are not used by the ROC and will be left 
blank. 

 
The PGAS system does not support stations. All gas quality data is part 
of the station point in the ROC. All .ANA files duplicate for each meter 
run in the station, the only difference being the METER_IDs. 

PGAS  
Alarm Files 

All alarms in the alarm log (.ARM) that are related in any way to a 
meter run are included in the PGAS .ARM file. These alarms include 
High, Low, and No Flow alarms for meter run and station flows; and 
Low, Low Low, High, High High, Rate, Manual Mode, and Point Fail 
alarms for points configured as inputs to meter points, including 
communication alarms for an MVS points configured as inputs to a 
meter point. Station alarms duplicate for each meter included in the 
station.  
 

# Column Name Data Type Description 
1 METER_ID char(16) Identification number for the measurement 

point in the field. Tag of the orifice or turbine 
point associated with the alarm. 

2 ALARM_DATE datetime Date and time the alarm occurred in 
mm/dd/yyyy hh:mm:ss format. 

3 PRIORITY_LEVEL U8 This represents the importance of the event: 
0 = Alarm will not affect volume calculations. 
1 = Alarm will affect volume calculations. 

4 ALARM_TEXT varchar(64) Text description of the alarm. 
5 TRIGGER_VALUE char(16) Value that triggered the alarm. 
6 ALARM_VALUE char(16) Alarm Value. 

 
PGAS 

Event Files 
PGAS Event Files (.EVT) detail meter information.   

 
# Column Name Data Type Description 
1 METER_ID char(16) Identification number for the 

measurement point in the field. 
This must be the tag id of the 
orifice or turbine point associated 
with the event. 
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# Column Name Data Type Description 
2 EVENT_DATE Datetime Date and time the event occurred 

in mm/dd/yyyy hh:mm:ss format. 
3 METER_CALC_COLUMN_NAME char(32) Actual column name within the 

METER_CALC table. This 
information is only required for 
events that are to trigger record 
insertion into the METER_CALC 
table. 

4 NEW_VALUE char(16) New value to be used in the 
METER_CALC record. This is the 
ASCII representation of the 
number. 

5 OLD_VALUE char(16) Old value to be used in the 
METER_CALC record. This is the 
ASCII representation of the 
number. The event name, new 
value, and old value appear in the 
Comment for the new 
METER_CALC record. 

6 PRIORITY_LEVEL U8 This represents the importance of 
the event: 
0 = Alarm will not affect volume 
calculations. 
1 = Alarm will affect volume 
calculations. 
This is redundant. If 
METER_CALC_COLUMN_NAME 
exists for the event, the 
PRIORITY_LEVEL will be a 1, if 
not, it will be a 0. 

7 DESCRIPTION varchar(64) Text description of the event. 
8 COMMENT varchar(100) Comment (optional) 

 
PGAS Meter 

Event-related Files 
Meter related events include changes to meter and  points, parameters, 
and calibration verification events for points configured as inputs to 
meter points;  changes to the number of active stations, orifice, or 
turbine points; changes to the clock; system events; and parameter 
change events for history points when the old or new point being 
archived is a meter or station point.  
Events such as warm starts, cold starts, system initializations, and clock 
changes duplicate for every meter run in the unit. Station parameter 
change events duplicate for every meter run in that station. Events used 
by the PGAS system to recalculate meter values are indicated by 
including a METER_CALC_COLUMN_NAME in the PGAS event 
record. The point types and parameters map to PGAS METER_CALC 
events. 

Description METER_CALC_COLUMN_NAME Data 
Type Point Types Parameters 

Orifice Diameter ORIFICE_SIZE Float Orifice Config (113) 15 
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Description METER_CALC_COLUMN_NAME Data 
Type Point Types Parameters 

Pipe Diameter TUBE_DIAMETER Float Orifice Config (113) 12 
Base 

Temperature 
TEMP_BASE Float Station (112) 14 

Base Pressure CONTRACT_PRES_BASE Float Station (112) 13 
Atm Pressure SITE_ATMOS_PRES Float Station (112) 16 

Orifice Material PLATE_MATERIAL U8 Orifice Config (113) 17 
Pipe Material TUBE_MATERIAL U8 Orifice Config (113) 14 
Tap Location STAT_TAP_LOCA U8 Orifice Config (113) 3 

Diff Press Span1 DIFF_HI_RANGE Float Orifice Config (113) 25 
Static Press 

Span2 
STATIC_HI_RANGE Float Orifice Config (113) or 

Turbine Config (115) 
27 or 15 

Temp 0% EU3 TEMP_LO_RANGE Float Orifice Config (113) or 
Turbine Config (115) 

29 or 17 

Temp Span3 TEMP_HI_RANGE Float Orifice Config (113) or 
Turbine Config (115) 

29 or 17 

1 The ROC Point Type and Parameter listed for this entry contains a 3-byte value that is the Point Type, Point Number, 
and Parameter to use for the differential pressure value. If the Point Type of the differential pressure input is MVS (108) or 
analog input (103), the differential pressure span will be the same Point Type and Point Number as the differential 
pressure value and (coincidentally) the Parameter will be 17 for both of these Point Types. If the Point Type is any other 
type, a span will not be available. 
2 The ROC Point Type and Parameter listed for this entry contains a 3-byte value that is the Point Type, Point Number, 
and Parameter to use for the static pressure value. If the Point Type of the static pressure input is MVS (108), the static 
pressure span will be the same Point Type and Point Number as the static pressure value and the Parameter will be 33. If 
the Point Type of the static pressure input is analog input (103), the static pressure span will be the same Point Type and 
Point Number as the static pressure value and the Parameter will be 17. If the Point Type is any other type, a span will not 
be available. 
3 The ROC Point Type and Parameter listed for this entry contains a 3-byte value that is the Point Type, Point Number, 
and Parameter to use for the temperature value. If the Point Type of the temperature input is MVS (108), analog input 
(103), or RTD (106), the temperature zero and span will be the same Point Type and Point Number as the temperature 
value and the Parameters will be as follows: 

 
Point Type 

Zero 
Parameter 

Span 
Parameter 

MVS (108) 44 48 
AIN (103) 13 17 
RTD (106) 9 13 

  
PGAS Volume Files The PGAS .VOL file contains the hourly volume data related to a meter 

run including the meter fun ID, report information, general meter flow 
parameters, and calculated factors. The Archive Type and TLP of the 
history points expected for the hourly volume report also display.   
  

PGAS Volume 
 Files Format 

The PGAS .VOL file contains the hourly volume data related to a meter 
run including the meter run ID, report information, general meter flow 
parameters, and calculated factors.  
The Archive Type and TLP of the history points expected for the hourly 
volume report also display. 
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# Column Name Data Type Description 
1 METER_ID char(16) Identification number for the measurement point in the field. 

Tag of the orifice or turbine point associated with the alarm. 

2 PRODUCATION_DATE_START datetime Start date and time of the record in mm/dd/yyyy hh:mm 
format. Since date and time stamps of ROC history are for 
the end of the record, this will be the date and time stamp of 
the previous record. 

3 PRODUCTION_DATE_END datetime Ending date and time of the record in mm/dd/yyyy hh:mm 
format. This will be the history date and time stamp from the 
ROC. 

4 FLOW_TIME_MINUTES float Hourly value for the meter run flow minutes. 
5 EFM_VOLUME float Hourly accumulation of volume for the meter run in MCF. 
6 EFM_ENERGY float Hourly accumulation of energy for the meter run in MMBTU. 

7 FLOW_EXTN float Hourly value for hwPf (Orifice only). 
8 DIFF_PRESS float Hourly average of differential pressure in Inches H2O (Orifice 

only). 
9 STAT_PRESS float Hourly average of static pressure in PSI. 
10 FLOW_TEMP float Hourly average of the flowing temperature in Deg F. 
11 ROTARY_CURR_UNCO_VOL float Hourly accumulation of uncorrected volume at flowing 

conditions in MCF (Turbine only). 
12 ROTARY_PREV_UNCO_VOL float N/A 
13 ROTARY_AVG_FREQ float Hourly accumulation of raw pulses (Turbine only). 
14 C_PRIME float Hourly average of the multiplier value (Orifice or Turbine). 
15 FA float N/A 
16 FB float N/A 
17 FG float N/A 
18 FPB float N/A 
19 FPM float N/A 
20 FPV float N/A 
21 FR float N/A 
22 FTB float N/A 
23 FTF float N/A 
24 Y float N/A 
25 F_MASS float N/A 
26 C_D_FT float N/A 
27 RHO_T_P float N/A 
28 RHO_B_GAS float N/A 
29 EFM_N2_MOL float N/A 
30 EFM_CO2_MOL float N/A 
31 EFM_GRAVITY float N/A 
32 EFM_ENERGY_FACTOR float N/A 
33 DP_MAN_OVR U8 N/A 
34 DP_LO_ALM U8 N/A 
35 DP_HI_ALM U8 N/A 
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# Column Name Data Type Description 
36 DP_TX_FAIL U8 N/A 
37 SP_MAN_OVR U8 N/A 
38 SP_LO_ALM U8 N/A 
39 SP_HI_ALM U8 N/A 
40 SP_TX_FAIL U8 N/A 
41 TEMP_MAN_OVR U8 N/A 
42 TEMP_LO_ALM U8 N/A 
43 TEMP_HI_ALM U8 N/A 
44 TEMP_TX_FAIL U8 N/A 
45 VOL_MAN_OVR U8 N/A 
46 VOL_LO_ALM U8 N/A 
47 VOL_HI_ALM U8 N/A 
48 VOL_TX_FAIL U8 N/A 
49 N/A float N/A 
50 N/A float N/A 
51 COMMENT char(100) N/A 
52 EFM_PRESSURE_BASE float N/A 
53 BACK_FLOW float N/A 
54 LITHIUM_ALARM_FLAG U8 N/A 
55 BATTERY_VOLTAGE U8 N/A 
56 AVG_METHANE float N/A 
57 AVG_ETHANE float N/A 
58 AVG_PROPANE float N/A 
59 AVG_H2O float N/A 
60 AVG_H2S float N/A 
61 AVG_H2 float N/A 
62 AVG_CO float N/A 
63 AVG_O2 float N/A 
64 AVG_IBUTANE float N/A 
65 AVG_NBUTANE float N/A 
66 AVG_IPENTANE float N/A 
67 AVG_NPENTANE float N/A 
68 AVG_NHEXANE float N/A 
69 AVG_NHEPTANE float N/A 
70 AVG_NOCTANE float N/A 
71 AVG_NNONANE float N/A 
72 AVG_NDECANE float N/A 
73 AVG_HELIUM float N/A 
74 AVG_ARGON float N/A 
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Note: For additional information on the PGAS and the .EVT, .ANA, 
.ARM, and .VOL file formats, refer to the documentation 
provided with your PGAS or the web site www.pgas.com. 

PGAS Volume 
 Files For Orifice Meter 

The PGAS .VOL file contains the hourly volume data related to a meter 
fun including the meter run ID, report information, general meter flow 
parameters, and calculated factors.  
The Archive Type and TLP of the history points expected for the hourly 
volume report also display. 

Description Archive Type Averaging / Rate 
Type Point Type Parameter 

Flowing 
Minutes 

Totalize (134) None (0) Orifice Values (114) Minutes Accumulated (28) 

Differential 
Pressure 

Average (128) Flow Dependent 
Linear (1) 

Orifice Configuration 
(113) 

DP (26) 

  Average (128) Flow Dependent 
Formulaic (2) 

Orifice Configuration 
(113) 

DP (26) 

  Average (128) Flow Weighted Linear 
(3) 

Orifice Configuration 
(113) 

DP (26) 

  Average (128) Flow Weighted 
Formulaic (4) 

Orifice Configuration 
(113) 

DP (26) 

Static 
Pressure 

Average (128) Flow Dependent 
Linear (1) 

Orifice Configuration 
(113) 

SP (28) 

  Average (128) Flow Dependent 
Formulaic (2) 

Orifice Configuration 
(113) 

SP (28) 

  Average (128) Flow Weighted Linear 
(3) 

Orifice Configuration 
(113) 

SP (28) 

  Average (128) Flow Weighted 
Formulaic (4) 

Orifice Configuration 
(113) 

SP (28) 

Temperature Average (128) Flow Dependent 
Linear (1) 

Orifice Configuration 
(113) 

TMP (30) 

  Average (128) Flow Dependent 
Formulaic (2) 

Orifice Configuration 
(113) 

TMP (30) 

  Average (128) Flow Weighted Linear 
(3) 

Orifice Configuration 
(113) 

TMP (30) 

  Average (128) Flow Weighted 
Formulaic (4) 

Orifice Configuration 
(113) 

TMP (30) 

Pressure 
Extension 

Average (128) Flow Dependent 
Linear (1) 

Orifice Values (114) Pressure Extension (4) 

  Average (128) Flow Dependent 
Formulaic (2) 

Orifice Values (114) Pressure Extension (4) 

  Average (128) Flow Weighted Linear 
(3) 

Orifice Values (114) Pressure Extension (4) 

  Average (128) Flow Weighted 
Formulaic (4) 

Orifice Values (114) Pressure Extension (4) 

C Prime Average (128) Flow Dependent 
Linear (1) 

Orifice Values (114) Multiplier Value (12) 

  Average (128) Flow Dependent 
Formulaic (2) 

Orifice Values (114) Multiplier Value (12) 
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Description Archive Type Averaging / Rate 
Type Point Type Parameter 

  Average (128) Flow Weighted Linear 
(3) 

Orifice Values (114) Multiplier Value (12) 

  Average (128) Flow Weighted 
Formulaic (4) 

Orifice Values (114) Multiplier Value (12) 

Volume Totalize (134) None (0) Orifice Values (114) Flow Accumulated (23) 
  Accumulate 

(129) 
Per Day (13) Orifice Values (114) Flow Rate Per Day (0) 

  Accumulate 
(129) 

Per Hour (12) Orifice Values (114) Flow Rate Per Hour (2) 

Energy Totalize (134) None (0) Orifice Values (114) Energy Accumulated (33) 
  Accumulate 

(129) 
Per Day (13) Orifice Values (114) Energy Rate Per Day (1) 

  Accumulate 
(129) 

Per Hour (12) Orifice Values (114) Energy Rate Per Hour (3) 

 
PGAS Volume 

 Files For Turbine Meter 
The PGAS .VOL file contains the hourly volume data related to a meter 
fun including the meter fun ID, report information, general meter flow 
parameters, and calculated factors.  
The Archive Type and TLP of the history points expected for the hourly 
volume report also display. 

Description Archive Type Averaging / Rate 
Type Point Type Parameter 

Flowing 
Minutes 

Totalize (134) None (0) Turbine Values 
(116) 

Minutes Accumulated (21) 

Raw Pulses Totalize (134) None (0) Turbine Values 
(116) 

Pulses Accumulated (9) 

Static 
Pressure 

Average (128) Flow Dependent 
Linear (1) 

Turbine 
Configuration (113) 

SP (16) 

  Average (128) Flow Dependent 
Formulaic (2) 

Turbine 
Configuration (113) 

SP (16) 

  Average (128) Flow Weighted Linear 
(3) 

Turbine 
Configuration (113) 

SP (16) 

  Average (128) Flow Weighted 
Formulaic (4) 

Turbine 
Configuration (113) 

SP (16) 

Temperature Average (128) Flow Dependent 
Linear (1) 

Turbine 
Configuration (113) 

TMP (18) 

  Average (128) Flow Dependent 
Formulaic (2) 

Turbine 
Configuration (113) 

TMP (18) 

  Average (128) Flow Weighted Linear 
(3) 

Turbine 
Configuration (113) 

TMP (18) 

  Average (128) Flow Weighted 
Formulaic (4) 

Turbine 
Configuration (113) 

TMP (18) 

C Prime Average (128) Flow Dependent 
Linear (1) 

Turbine Values 
(114) 

Multiplier Value (12) 

  Average (128) Flow Dependent 
Formulaic (2) 

Turbine Values 
(114) 

Multiplier Value (12) 
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Description Archive Type Averaging / Rate 
Type Point Type Parameter 

  Average (128) Flow Weighted Linear 
(3) 

Turbine Values 
(114) 

Multiplier Value (12) 

  Average (128) Flow Weighted 
Formulaic (4) 

Turbine Values 
(114) 

Multiplier Value (12) 

Uncorrected 
Volume 

Totalize (134) None (0) Turbine Values 
(114) 

Uncorrected Accumulated 
(31) 

  Accumulate 
(129) 

Per Hour (12) Turbine 
Configuration (113) 

Uncorrected Flow Rate 
(14) 

Volume Totalize (134) None (0) Turbine Values 
(114) 

Flow Accumulated (16) 

  Accumulate 
(129) 

Per Day (13) Turbine Values 
(114) 

Flow Rate Per Day (0) 

  Accumulate 
(129) 

Per Hour (12) Turbine Values 
(114) 

Flow Rate Per Hour (2) 

Energy Totalize (134) None (0) Turbine Values 
(114) 

Energy Accumulated (26) 

  Accumulate 
(129) 

Per Day (13) Turbine Values 
(114) 

Energy Rate Per Day (1) 

  Accumulate 
(129) 

Per Hour (12) Turbine Values 
(114) 

Energy Rate Per Hour (3) 

9.4 User Program Administrator 
User programs provide the ROC800-Series with extended functions and 
applications (such as gas chromatograph support or GOST calculations). 
Use this option to download, start, stop, and remove user programs.  

Note:  Extensive documentation covering configuration and usage 
information accompanies each user program. 

Select Utilities > User Program Administrator. The User Program 
Administrator screen displays. 
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Figure 9-11. User Program Administrator  

Field Description 
Device User 
Program 
Environment  

These read-only fields show the amount of used 
and available memory. The user program that you 
intend to load must be able to access the memory 
location.  

User Programs 
Installed in Device  

Displays any currently installed user programs. 

If you select a currently installed program, the 
system completes the User Programs Installed in 
Device frame with information detailing specific 
information about that user program. 

Clear  Click to delete the selected user program from 
memory.  

Start  Click to start the selected user program.  

Stop  Click to stop the selected user program from 
running.  

All - Option Select to perform the same action (Clear, Start, or 
Stop) on every user program. 

Status  This read-only field indicates the status of the 
selected program. Valid values are:  

 Empty No program installed.  

 Loaded Program loaded but not running.  

 Running Program loaded and active.  

 License 
Not Found 

Program requires a license to 
operate.  

Reset Counter  Click to clear the value that indicates how many 
times the user program has been restarted.  
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Field Description 
Download User 
Program File  

Identifies the program file to be downloaded to the 
ROC. Click Browse to locate the file you desire to 
download.  
When you select a user program file, the system 
completes the lower portion of the screen with 
configuration information detailing for the user 
program.  

Download & Start  Click to download and start the user program 
running.  

Download  Click Download to download but not start the 
user program.  
Note:  If you download several programs, they 

may need to be started in a particular 
order. Use this button to download without 
starting the programs. 

Update Click to update values on the screen.  

Close Click to close the screen.  

9.4.1 Downloading a User Program 
Note:  As of the publication date of this manual, Remote Automation 

Solutions has not published any downloadable user programs for 
the ROC800-Series. As we release user programs, refer to the 
documentation accompanying those programs for directions on 
downloading and configuring the programs.  

9.4.2 MPU Loading Threshold 
To maximize the performance of your ROC800 device, always verify 
the performance of specific application combinations before using them 
in the field to ensure the MPU load typically remains below 85% with 
peak MPU loading levels below 95%. 
To check the current MPU load at any time, select ROC > Information 
> Other Information and review the value in the MPU loading field. 
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Figure 9-12. MPU Loading 

9.5 ROCLINK 800 Security 
Use the ROCLINK 800 Security screen to set access to ROCLINK 800.  

Note:   
 This section focuses on security related to software. For device-

related security, refer to Device Security in Chapter 3, 
Communications and Secuirty. 

 The requirements for the Operator ID and Password fields are 
dependent on your selection in the Enable Enhanced Security 
Features field on the Device Security screen (ROC > Security). 
For more information, refer to Section 3.7.3 Enhanced Security. 

 The ROCLINK 800 Security table can be a mix of the older 
username/password format and the new complex 
username/password formats. 

To access this screen, select Utilities > ROCLINK 800 Security. The 
ROCLINK 800 Security screen displays. Its table format enables you to 
define, by operator ID, password, and security level, who can log on to 
ROCLINK 800 and the screens that those IDs can access. You may 
define up to 64 different users. 

Note: Utilities > ROCLINK 800 Security must match ROC > 
Security (Device Security) in order for users to log into 
ROCLINK 800. 
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Figure 9-13. ROCLINK 800 Security  

Note:  The default Operator ID is LOI. The default password is 1000. 
 

 Caution The settings you define in Utilities > ROCLINK 800 Security must match 
the settings you define in ROC > Security (Device Security) in order for 
users to log onto ROCLINK 800.   

 

9.5.1 Defining Access 
1. Select Utilities > ROCLINK 800 Security. The ROCLINK 800 

Security screen displays:  

  
Figure 9-14. ROCLINK 800 Security  

2. Enter an Operator ID used to log into ROCLINK 800. The 
requirements for the Operator ID field differ based on if you have 
selected Enable Enhanced Security Features (ROC > Security). 
For more information, refer to Section 3.7.3 Enhanced Security: 
 If you have not selected Enable Enhanced Security Features, 

enter three alphanumeric characters for the Operator ID. 
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Typically these are the initials of the person who operates the 
device.  

Note:  Each Operator ID must be unique and is case-sensitive 
(that is, ABC is different from Abc). 

 If you have selected Enable Enhanced Security Features, 
enter between three and 30 alphanumeric/special characters for 
the Operator ID.  

Note:  The Operator ID is not case-sensitive. 

3. Enter a Password for the Operator ID. The requirements for the 
Password field differ based on if you have selected Enable 
Enhanced Security Features (ROC > Security): 
 If you have not selected Enable Enhanced Security Features, 

enter four numeric characters (between 0000 and 9999) to define 
the operator Password. More than one user can have the same 
password.  

Note:  If you precede a password value with zeroes (such as 
0006), ROCLINK 800 saves that password as 6. 

 If you have selected Enable Enhanced Security Features, 
enter between eight and 32 alphanumeric/special characters to 
define the operator Password. More than one user can have the 
same password.  

4. Enter the desired Access Level for the user. 0 is the lowest (least 
inclusive) access level and allows access to the fewest number of 
screens. 5 is the highest (most inclusive) access level and allows 
access to all screens. Each access level permits access to screens at 
that level and any inherited from lower access levels. For example, 
an operator ID with Access Level 3 can access screens with levels 0, 
1, 2, and 3. Refer to Table 9-1, Security Access Levels. 

Note: Click User Access Levels to display a User Access Levels 
dialog that shows all menu options and their access levels.  

5. Click Save. 
Security  

Access Levels 
Table 9-1 lists the system screens and their system-assigned security 
access levels. The Menu Options focus on the activity while you use 
the Access Levels to increase or decrease responsibility levels within 
the Menu Options.  
To access this screen, select Utilities > ROCLINK 800 Security > 
User Access Levels.  

Notes: 
 If you enable security on any port, at least one operator ID must 

have the highest level of security (level 5). 
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 ROCLINK 800 rejects login requests if access levels are greater 
than device security.  

Table 9-1. Security Access Levels  

 Menu Menu Option Access Level 
1 Configure Transaction History 5 
15 View Display New 5 
24 ROC Security 5 
71 Utilities License Key Admin 107 5 
72 Utilities License Key Administrator 800 5 
80 Utilities Custom Display Editor 5 
81 Utilities Custom EFM Report Editor 4 
20 ROC Display Administrator 4 
69 Utilities Update Firmware 4 
70 Utilities Upgrade Hardware 4 
74 Utilities User Program Administrator 3 
2 File New 3 
4 File Download 3 
5 File Save Configuration 3 
18 View Display From File 3 
19 View Display From Device 3 
23 ROC Clock 3 
25 ROC Comm Ports 3 
27 ROC Information 3 
28 ROC Flags 3 
29 Configure IO AI Points 3 
30 Configure IO AO Points 3 
31 Configure IO DI Points 3 
32 Configure IO DO Points 3 
33 Configure IO PI Points 3 
34 Configure IO TC Points 3 
35 Configure IO RTD Points 3 
36 Configure IO System AI Points 3 
37 Configure IO Soft Points 3 
38 Configure IO Extended Soft Point 3 
39 Configure IO MVS Sensor 3 
40 Configure IO HART Points 3 
41 Configure IO Setup 3 
42 Configure IO Advanced Pulse Module 3 
43 Configure IO ACIO Module 3 
44 Configure IO Virtual Discrete Output 3 
45 Configure Control FST Registers 3 
46 Configure Control PID Loop 3 
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 Menu Menu Option Access Level 
47 Configure Control Radio Power Control 3 
48 Configure Control Sampler/Odorizer 3 
49 Configure Control DS800 3 
50 Configure History Segments 3 
51 Configure HistoryPoints 3 
52 Configure Opcode Table 3 
53 Configure Modbus 3 
54 Configure Rtu Network 3 
55 Configure LCD User List 3 
56 Configure User Data UD1 3 
73 Utilities Convert EFM File 3 
75 Utilities AI Calibration Values 3 
76 Utilities MVS Calibration Values 3 
77 Utilities FST Editor 3 
78 Utilities Keypad Display Editor 3 
79 Utilities Read File From Device 3 
82 Utilities Options 3 
84 Tools Data Logger 3 
7 View EFM Report 2 
8 View Calibration Report 2 
22 ROC Collect Data 2 
57 Meter Setup 2 
58 Meter Setup 800 Station 2 
59 Meter Setup 800 Orifice meter 2 
60 Meter Setup 800 Linear meter 2 
61 Meter Calibration 2 
62 Meter Calibration 800 Orifice meter 2 
63 Meter Calibration 800 Linear Meter 2 
64 Meter Values 2 
65 Meter Values 800 Orifice meter 2 
66 Meter Values 800 Linear Meter 2 
67 Meter Plate Change 2 
68 Meter History 2 
3 File open 1 
6 File Print Configuration 1 
9 View History From Device 1 
10 View History From File 1 
11 View Alarms From Device 1 
12 View Alarms From File 1 
13 View Events From Device 1 
14 View Events From File 1 
21 View I/O Monitor 1 
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 Menu Menu Option Access Level 
26 ROC Memory 1 
16 View Display Display 1 0 
17 View Display Display 2 0 
83 Utilities Communications Monitor 0 

9.6 RTD Input Calibration Values  
Select Utilities > RTD Calibration Values to view all the calibration 
values for a specific RTD input point.  

  
Figure 9-15. RTD Input Calibration Values  

Field Description 
Point  Click ▼ to select an RTD point.  

Raw Value (1 - 5) These read-only fields show the calibrated raw 
values, where Raw Value 1 is the lowest 
calibrated raw A/D input and Raw Value 5 is the 
highest calibrated raw A/D input.  

RTD Bias  This read-only field shows the Press Effect is the 
Zero Shift or RTD Bias adjustment value (applies 
only to points configured as the Differential 
Pressure input to a Meter Run) or temperature 
input.  

Set EU Value  This read-only field shows the Tester Value 
specified for the last calibration value that was set.  

Manual EU  This read-only field shows the Manual EU Live 
Reading for the last calibration value that was set.   
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Field Description 
EU Value (1 - 5) These read-only fields show the five calibration 

settings in engineering unit values, converted from 
the raw values, based on the Low Reading EU 
and High Reading EU defined for the point. EU 
Value 1 is the Zero value and EU Value 5 is the 
Span value. The rest are midpoint values.  

Timer This read-only field shows, in seconds, the last 
inactivity count-down (typically starting from 3600 
seconds) that occurred during the last calibration 
session. Had the countdown reached 0, time-out 
would have taken place, automatically ending the 
calibration mode.  

Mode  Indicates the calibration mode. Valid values are:  
0 = Use Current Calibration 
1 = Start Calibration 
2 = Calibrate 
3 = Restore Previous Calibration 
4 = Stop Calibration 

Type  Indicates the calibration value currently being set. 
Valid values are:   
0 = Inactive (no value) 
1 = Zero 
2 = Span 
3 = Midpoint 1 
4 = Midpoint 2 
5 = Midpoint 3 
6 = Unused 

9.7 Analog Input (AI) Calibration Values 
Use this option to review all the calibration values for a specific analog 
input point.  
1. Select Utilities > AI Calibration Values. The AI Calibration screen 

displays. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Utilities Menu 9-31 

  
Figure 9-16. AI Calibration Values  

Field Description 
Point   Click ▼ to select an AI point.  

Raw Value (1 - 5)  These read-only fields show the calibrated raw 
A/D input, where Value 1 is the lowest calibrated 
input and Value 5 is the highest calibrated input.  

Offset  This read-only field shows the zero shift 
adjustment value for a differential pressure input. 
This value is an offset to the calibrated EU Values, 
and compensates for the effect of working static 
pressure on a DP transmitter that was calibrated 
at atmospheric pressure.  

Set EU Value  This read-only field shows the Tester Value 
specified for the last calibration.  

Manual EU  This read-only field shows the Live Reading for 
the last calibration.  

EU Value (1 - 5)  These read-only fields show the five calibration 
settings in Engineering Unit values, converted 
from the raw values, based on the low reading EU 
and the high reading EU defined for the point. 
Value #1 is the zero value, value #5 is the span 
value, and values 2, 3, and 4 are midpoint values.  

Timer  This read-only field shows the last inactivity 
count-down in seconds (typically starting from 
3600 seconds) that occurred during the last 
calibration session. Had the countdown reached 0, 
time-out would have taken place, automatically 
ending the calibration mode.  
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Field Description 
Mode  This read-only field shows the status of the 

calibration. Valid values are:  
0 = Use Current Calibration 
1 = Start Calibration 
2 = Calibrate 
3 = Restore Previous Calibration 
4 = Stop Calibration 

Type  This read-only field shows the currently set 
calibration value. Valid values are:  
0 = Inactive (no value) 
1 = Zero 
2 = Span 
3 = Midpoint 1 
4 = Midpoint 2 
5 = Midpoint 3 
6 = Zero Shift 

9.8 MVS Input Calibration Values  
Use this option to display a screen that shows all the current calibration 
values for MVS sensor points.  
Select Utilities > MVS Calibration Values > Calibration tab. The 
MVS Calibration Values screen displays.  

 
Figure 9-17. MVS Calibration Values  

Field Description 
MVS Sensor  Click ▼ to select an MVS sensor.  

Sensor Tag  This read-only field shows the label associated 
with the selected MVS sensor.  

  

Differential Pressure 
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Field Description 
Manual Value This read-only field shows the value of the input 

at the last meter Freeze.  
Cal Value (1 – 5) These read-only fields show the differential 

pressure calibration values the selected MVS 
sensor currently uses. 

Pressure Effect This read-only field shows the adjustment factor 
for pressure.  

Static Pressure  
Manual Value This read-only field shows the value of the input 

at the last meter Freeze.  
Cal Value (1 – 5) These read-only fields show the static pressure 

calibration values the selected MVS sensor uses.  
Pressure Offset This read-only field shows the adjustment factor 

for pressure.  
Temperature  

Manual Value This read-only field shows the value of the input 
at the time of the last meter “Freeze.”  

Cal Value (1 – 5) these read-only fields show the temperature 
calibration values the selected MVS sensor 
currently uses.  

Set To Factory 
Defaults  

Click to return the MVS calibration values to their 
original values and reset the MVS.  
Note:  You must answer Yes to a verification 

dialog before the reset occurs. When the 
reset completes, a verification dialog box 
displays. This resets the MVS address to 
the default value of 1 and the Sensor Tag 
to MV Sensor. 

9.9 FST Editor 
ROCLINK 800’s Function Sequence Table (FST) utility provides an 
instruction list programming language you can use to define and 
perform a set of specific actions when a set of conditions exists. For 
complete documentation on this option, refer to the Function Sequence 
Table (FST) User Manual (part D301058X012). 

9.10 Keypad Display Editor 
Select Utilities > Keypad Display Editor to create and edit keypad 
display files. You can store these files on a PC or download them to the 
ROC. While in use on the ROC Keypad Display, the display file resides 
in the configuration memory of the ROC.  

Note:  Keypad display files use the extension .DCFG.  

The Keypad Display Editor is available while on-line with a ROC800-
Series that has a keypad display connected. 
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The Keypad Display allows interaction with TLPs in the ROC database. 
An understanding of TLPs is crucial to configuring a keypad display 
file. TLP refers to Point Type, Logical number (Instance), and 
Parameter. For example, the TLP DIN 4-2, ACC is the Accumulated 
Value parameter of channel 2 of the discrete Input module in slot 4. 
This TLP can also be expressed numerically as 101, 4-2, 6. 

9.10.1 Creating a Keypad Display File  
You can create display files either by editing an existing file or by 
creating one in the Editor  
To create a new display file:  
1. Select Utilities > Keypad Display Editor. A blank Keypad Display 

Editor screen displays:  

  
Figure 9-18. Keypad Display Editor (Blank)  

2. Right-click on Main Menu in the Hierarchy Menu in the left pane of 
the editor. A menu displays.  

3. Select Add Menu as many times as your display requires. 
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4. The Hierarchy Menu determines the navigation for the display. Each 
level in the Hierarchy Menu represents a screen with menu choices. 
Add menus and screens to each level in the Hierarchy Menu to suit 
your application. 

5. Right-click on a menu in the Hierarchy Menu and select Add 
Screen.  

 
6. Use this menu to select the type of screen:  

Menu Type Description 
User Scrollable Provides displays and interaction with TLP 

names and values. 
Events Displays the Events log.  

Note: You can insert only one instance of this 
screen type in a display file.  

Alarms Displays the Alarms log.  
Note: You can insert only one instance of this 

screen type in a display file. 
Screen Saver Provides a scrolling list of parameters that 

appears when no user is logged on. The 
function of the screen saver is the same no 
matter where you place it in the hierarchy 
menu.   
Note: You can insert only one instance of this 

screen type in a display file.  
Calibration Allows you to perform a deadweight calibration 

of the I/O channels for which calibration is 
appropriate.  
Note: You can insert only one instance of this 

screen type in a display file. 
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Once you add the required number of menus and screens, it is good 
practice to save the file to the PC. Use the Save As button in the right 
pane of the editor. ROCLINK 800 saves keypad display files using the 
extension DCFG. You can also save a display file in a configuration file 
(*.800) using either the Download button (when on-line) or the Save 
button (when off-line). 
Creating the display file is only the first step. You must now edit the 
display file to select TLPs and assign security. Refer to the steps in the 
Editing a Keypad Display File. Once you complete the edit process, you 
must again save the file. Then you can download it to the ROC.  

9.10.2 Editing a Keypad Display File 
The Keypad Display Editor also enables you to edit an existing keypad 
display file. ROCLINK 800 includes a sample display file 
(display_config.dcfg) you can use it in its current state or customized it 
to suit your application..  
To edit a display file: 
1. Select Utilities > Keypad Display Editor. 
2. Click Read Device (if file is stored in the ROC) or Open File (if file 

is saved on the PC) to open the display. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Utilities Menu 9-37 

  
Figure 9-19. Example Keypad Display Editor  

Field Description 
Hierarchy Menu  The Hierarchy Menu determines the navigation 

for the display. Each level in the Hierarchy Menu 
represents a screen with menu choices. Add 
menus and screens to each level in the Hierarchy 
Menu to suit your application.  

Title  Sets the Title for this configuration file. Use of all 
capital letters is recommended.  

On Open TLP and 
On Close TLP  

When the ROC Keypad Display is in use (logged 
on), the system writes the value indicated in the 
Value field to the TLP specified in the On Open 
TLP field. 
When the ROC Keypad Display is no longer in use 
(logged off), the system writes the value indicated 
in the Value field to the TLP specified in the On 
Close TLP field.   

Point Types  Enables you to scroll through the logical instances 
of the point types assigned in the Point Types 
field.  
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Field Description 
Line Entries  You can add, delete, and move Line Entries. 

Each line represents one line on the display. Each 
field of the entry is configured separately. 
However, a command to Add Entry, Move Up, 
Move Down, or Delete Entry causes the entry to 
add, move or delete the entire line.  
Note: Once you create a line entry, use the 

parameters in the Field frame to control the 
values for that line entry. 

Add Entry Click to add a line entry field.  

Delete Entry Click to delete the highlighted line entry field.  

Move Up Click to move the selected line entry field up one 
position.  

Move Down Click to move the selected line entry field down 
one position.  

Value  If the field highlighted in the Line Entry frame is to 
have manually entered text or numbers, select a 
Value of Manual Value.  
If the field is to have a parameter name in full, 
select Parameter Name. 
If the field is to have an abbreviation of the 
Parameter name, select Parameter Abbreviation. 
If the field is to have the value of the parameter, 
select Parameter Value. 

Text If the Value selected was Manual Value, set the 
text or number in the Text field.  

TLP  Indicates the TLP for the field’s value. 
Note: This field displays only if you selected 

Parameter Name, Parameter Abbreviation, 
or Parameter Value in the Value field.  

Justify and Length  Controls the positioning of the value in the 
selected field. Valid values are Left (the default) 
Center, or Right.  
Length determines the maximum length of the 
text or numbers in the entry field.  

Length Indicates the maximum number of characters (text 
or digits) in the selected line  

Read Only  Select Read Only (R/O) if the TLP selected is to 
be a display only on the ROC Keypad Display. If 
not selected, the TLP will be Read Write (R/W) if 
the keypad user has Read-write privileges to TLPs 
in that access group. Note that only one field in an 
entry line can be R/W.  

Leading Text and 
Trailing Text  

In some circumstances, when you select 
Parameter Value, you can type text to go before 
or after the value. Leading and Trailing Text 
allows units of measurement or some other text to 
appear on the screen.  
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Field Description 
Data Format  In some circumstances, when you select the 

Parameter Value and the Use Default Format 
checkbox, set whether the Data Format will be the 
default that has a Precision of two characters or 
another manually entered precision.  

Open File Click to open a .DCFG file residing on your PC. 

Read Device Click to read a .DCFG file residing on your ROC.  

Save As Click to save the current .DCFG file wit the name 
you indicate.  

Download Click to download the current .DCFG file to the 
connected ROC.  
Note: Before you download a file, ensure that you 

have assigned the ROC comm port to LCD 
(Comm Port Owner field on ROC > Comm 
Ports). 

Cancel Click to close the Keypad Display Editor without 
saving any changes.  

 
3. Click Save As to save your keypad display file.  
 

Keypad 
Display Security 

The ROC Keypad Display utility provides security to help you control 
user access to information. You can place users in "groups" that have a 
predefined access level. Within each group, individuals can be assigned 
an additional level of access that overrides the group access level. The 
panels on the right side of the Keypad Display Editor provide this 
functionality.  
You can define customer display screens that  allow users to view and 
edit parameters, view parameters only, or have no display access based 
on their group or individual access level. Typically, you assign group or 
individual access based on job function. Each user within a group 
assumes that group’s access level. However, you can grant or deny to an 
individual user’s access to a specific display based on that user’s 
individual access level. 
For example, John, Joe, and Pat are members of a "Technicians" group 
that is allowed to view and edit the PID display. You can prevent Joe 
from changing the set point of a PID loop if you define individual 
access that restricts him to viewing (R/O) only. The rest of the group’s 
members are unaffected by Joe’s individual restriction. 
If you assign a user to more than one group, each of which has different 
access levels, the user assumes the access level of the highest group for 
all of their assigned groups. 
For example, John is in the Technicians group, which has access to edit 
and view. You also assign him to the Meter Setup group, which only has 
view access. John automatically has edit access in the Meter Setup 
group because of his membership in the Technicians group. However, 
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you can individually restrict him to read only access in the Meter Setup 
group. 

Note:  The User Access and Group Access lists for a ROC800-Series 
unit are established on the ROC > Security screen. For more 
information on security in the ROC, refer to Device Security. 

Field Description 
Group Access  Sets the Group Access to determine the type of 

access (Read/Write or Read/Only) allowed by the 
groups of users to a given display.  

User Access  Sets the User Access to determine the type of 
access (Read/Write or Read/Only) allowed by the 
individual users to a given display.  

 
Updating Keypad  
Display Firmware 

You can update the firmware in the keypad display while connected by 
a serial or TCP/IP (Ethernet) communications connection.  
1. The updated firmware files are typically supplied on in a .zip file. It 

is recommended that you create a backup copy of the firmware 
update file after you unzip the file. 

2. Read the README text file included with the firmware update. 
3. Select Utilities > Update Firmware and select the Keypad Display 

tab. 
4. Click Browse and navigate to the new firmware file on the PC. 
5. Once the file is found, click Start. The update may take a while; do 

not interrupt the update while it is in progress. 
6. Click OK when the Firmware Update Completed dialog box 

appears. 

9.11 Custom Display Editor  
The custom display options in ROCLINK 800 allow you to create 
customized ROC display files (*.DSP) and load them to a ROC. The 
ROC can store up to 246 displays (including both custom user displays 
you create and user program displays that accompany user programs).    
 

 Caution You should be familiar with Visual Basic before attempting to create 
custom displays.   

 
Refer to Appendix B, Display Editor, for a complete discussion of 
creating customer displays.  
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9.12 Custom EFM Report Editor 
The Custom EFM Report Editor allows you to create a custom .EFM 
report format. Custom EFM report formats enable you to present EFM 
data in a way most useful to your organization. The ROC can store up to 
246 report formats (including both custom user reports and custom 
displays you create, as well as user program displays that may 
accompany user programs). 
The process of creating a custom .EFM report is similar to the process 
for creating a custom displays, but creates a file with an *.RPT file 
extension that you subsequently store on your PC’s hard drive.   
 

 Caution You should be familiar with Visual Basic before attempting to create 
custom reports.    

 
Select Utilities > Custom EFM Report Editor. A blank Custom EFM 
Report Editor screen displays:   

 
Figure 9-20. Custom EFM Report Editor (blank)  

Use the techniques and tool described in Appendix B to create a custom 
EFM report (an example appears in Figure 9-21).   
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Figure 9-21. Custom EFM Report (Completed)  

One major feature of a custom EFM report is the ability to include 
detailed history. This enables you to display summarized information as 
well as supporting detailed information.  

9.12.1 Viewing Custom EFM Reports 
Once you have created a custom .EFM report file, you use it to view a 
Custom EFM Report file:  
1. Select View > EFM Report. An Open dialog displays.  
2. Select an EFM report (which has an .efm file extension) and click 

Open. The View EFM Report screen displays.  

Detailed 
hour or daily 
history 

Summarized 
information 
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Figure 9-22. View EFM Report  

3. Select Custom in the Report Type frame.  
4. Click Browse in the Custom Report File frame. A Select Custom 

Report dialog displays.  
5. Select the appropriate *.RPT report file and click Open. The View 

EFM Report screen displays showing the custom report file you 
have selected.   
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Figure 9-23. View EFM Report  

6. Select the report options (Meter Run, Start Date, End Date, and 
Report Sections) and click Print Preview. An on-screen version of 
the report displays.  
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Figure 9-24. Custom EFM Report  

7. Use the print (or export) options on this screen to produce the report.  

9.13 Read File from Device 
Use the Read File From Device screen to extract saved files from the 
device’s flash file system. These files are generated through device 
features such as saving report files, or the creation of a constant log.  
1. Select Utilities > Read File from Device. The Read File From 

Device screen displays:  
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Figure 9-25. Read File From Deivce 

2. Select a file to read and click Read File.  

Note:  You can also click Read All to select all files listed.  

3. The system displays a “Save As” dialog. Indicate the location where 
you want the .txt file to reside and click Save. When the save 
completes, the system displays a completion dialog:  

 
4. Click OK. The Read File From Device screen redisplays.   

9.14 Communications Monitor 
Select Utilities > Communications Monitor and perform an operation 
to display the data bytes (in hexadecimal format) sent and received from 
the ROCLINK 800 during that operation.  
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Figure 9-26. Communications Monitor  

The system shows bytes sent in black and bytes received in red. Data 
received since the last good response (and before a request) are shown 
in aqua. 
Right-click on the display to display a menu that enables you to Copy 
highlighted data, Clear All data, Unselect, or Export the data to several 
formats.   

 
You can paste copied data in a file for analysis. 
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Chapter 10 – The Tools Menu 

Use the Tools menu to configure how your Point Type (T), Logical 
Number (L), and Parameter (P) options display and to customize your 
toolbars.  

  
Figure 10-1. Tools Menu 

Note: The Customize option is currently unavailable with the ROC800-
Series.   

10.1 Options 
ROCLINK 800 enables you to display TLP selections either as text or 
numbers.   

 When the Browse button (shown on left) is associated with a TLP, click 
the Browse button to display the Select TLP dialog (see Figure 10-2).  
Use the Select TLP dialog to assign specific inputs and outputs to 
parameters. ROCLINK 800 uses Point Type (T), Logical Number (L), 
and Parameter (P) to define point locations. 

  
Figure 10-2. Textual TLP Display  
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Figure 10-3. Numeric TLP Display  

To select how TLP values display, select Tools > Options. The Options 
dialog displays.  

  
Figure 10-4. Options 
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Field Description 
Display TLP Displays values on the Select TLP screen as 

either text or numbers. For example, the TLP for 
Register 2 of FST 1 could display as either 
FST 1, R2 or 96, 0, 3. 

Auto Scan Interval  Sets, in seconds, the time interval at which the 
Auto Scan feature (present on numerous 
ROCLINK 800 screens) polls a ROC.  

TLP Selection  Select to display all TLP options if the TLP does 
not pertain to the option you are configuring.  

TLP ToolTip Popup Select to display a context-sensitive TLP source 
data detailing the selection when you hover over it.  
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Chapter 11 – The Windows Menu 

In This Chapter 

11.1 Cascade ............................................................................................... 11-1 
11.2 Tile ....................................................................................................... 11-2 
11.3 Active View .......................................................................................... 11-3 
 

 
Use the Windows menu to configure how your screens display and to 
sets the ROCLINK screen you desire to view.  

  
Figure 11-1. Windows Menu 

11.1 Cascade 
Select Window > Cascade to view all open ROCLINK 800 windows in 
a Cascade view.  

  
  Figure 11-2. Cascade 
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Button Description 

 Minimizes the size of the window and places it at the 
bottom of the screen.  

 Maximizes the size of the window to fill the screen 
area. 

 Restores the original size of the window. 

 Closes a window.  

11.2 Tile 
Select Window > Tile to view all open ROCLINK 800 windows in a 
Tile view.  

  
Figure 11-3. Tile   

Note the difference in color intensity of the title bars: the system 
highlights the title bar for the currently active window.   

Active 
window  

Inactive 
window  
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11.3 Active View 
To switch between active views in ROCLINK 800, select Window and 
select one of the options in the lower portion of the menu. A check mark 
appears next to the active view. A view must be active before you can 
alter information on that screen.  

  
Figure 11-4. Active View  
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Chapter 12 – The Help Menu 

In This Chapter 

12.1 Help Topics .......................................................................................... 12-1 
12.2 About ROCLINK 800 ........................................................................... 12-2 
 

 
Use the Help menu to access the on-line help system and view the 
About ROCLINK 800 screen.  

 
Figure 12-1. Help Menu 

12.1 Help Topics 
ROCLINK 800 has a comprehensive help system. To access help, click 
Help Topics on the Help menu. To display context-sensitive help on a 
specific issue, select the item, parameter, field, or button, and press F1.  
When you select Help > Help Topics, you display the ROCLINK 800 
main help screen:  

 
Figure 12-2. ROCLINK 800 Software Help   

A table of contents for all help topics appears on the left of the help 
topic contents. The Help Topics consist of parameter names and menu 

Topic 
Menu

  Topic 
Content.  
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options. Note that some topic names have been abbreviated. For 
example: analog input functions appear with "AI" in front of the name, 
such as in AI Alarms, AI Scanning, or AI-analog inputs.  

12.2 About ROCLINK 800 
Select Help > About ROCLINK to display the About ROCLINK 800 
dialog.  

  
Figure 12-3. About ROCLINK  

This dialog displays a variety of information, including the version 
number, license agreement, creation (software build) date, and version 
information for supporting files. Click OK to close the dialog. 

Note:  Figure 12-3 represents the current version as of the publication 
date of this manual. Newer versions may be available. Consult 
with your LBP.   
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Appendix A – Glossary 

Note: This is a generalized glossary of terms. Not all the terms may 
necessarily correspond to the particular device or software 
described in this manual. For that reason, the term “ROC” is 
used to identify all varieties of Remote Operations Controllers.  

A 
A/D Analog to Digital signal conversion.  
ABS Acrylonitrile Butadiene Styrene. 
ADC Analog to Digital Converter. Used to convert analog inputs (AI) to a format the flow 

computer can use.  
Additive A liquid that is injected into a primary liquid component in relatively small quantities, 

usually less than four percent of the delivered volume total. Additives are injected 
into the primary liquid component by an injector mechanism which places a known, 
fixed volume of the additive into the primary liquid component stream for each 
injector pulse received from the DL8000 Preset.  

AGA American Gas Association. A professional organization that oversees the AGA3 
(orifice), AGA5 (heating value), AGA7 (turbine), AGA8 (compressibility), AGA9 
(Ultrasonic), and AGA11 (Coriolis) gas flow calculation standards. See http:// 
www.aga.org. 

AWG American Wire Gauge. 
AI Analog Input. 
AO Analog Output. 
Analog Analog data is represented by a continuous variable, such as an electrical current 

signal. 
Annubar A device that uses Pitot tubes to measure the gas flow rate within a pipeline. The gas 

volume is calculated from the difference between the flowing pressure and the static 
pressure of the gas. 

AP Absolute Pressure. 
API American Petroleum Institute. See http://www.api.org. 
Area A user-defined grouping of database entities.  
Arm A movable pipe or hose assembly used at a tanker truck loading island (also: swing 

arm, loading arm). The arm can be designed for either top loading or bottom loading 
to the tanker compartments. A swing arm can be positioned to load at either side of 
the loading island or the parked state. 

ASCII American (National) Standard Code for Information Interchange. 
Attribute A parameter that provides information about an aspect of a database point. For 

example, the alarm attribute is an attribute that uniquely identifies the configured 
value of an alarm. 

B 
Batch A preset, quantity-based product delivery or blended component delivery of a single 

recipe. 
Blend Stream A product stream blended of both gasoline and ethanol. 
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Blending The process of mixing two or more liquid components to form a composite delivered 
stream. The DL8000 controls blending based on a predetermined recipe by either 
the sequential (automatic or manual) or the inline (proportional or non-proportional) 
method. The quantity of each component in a blend is typically greater than two to 
four percent of the blended product. Injection of very small quantities of liquids, less 
than four percent of the blended product, is usually controlled by the additive 
injection process. 

BMV Base Multiplier Value, used in AGA7 (turbine) calculations.  
BPS Bits Per Second, associated with baud rate. 
BTU British Thermal Unit, a measure of heat energy. 
Built-in I/O I/O channels that are fabricated into the ROC and do not require a separate option. 

Also called “on-board” I/O. 

C 
CID2 Class I, Division 2 hazardous area 
CF Compare Flag; stores the Signal Value Discrete (SVD). 
CMOS Complementary Metal Oxide Semiconductor, a type of microprocessor used in a 

ROC. 
Coil Digital output, a bit to be cleared or set.  
COL Ethernet Packet Collision. 
COM Communications port on a personal computer (PC).  
COMM Communications port on a ROC used for host communications.  
Comm Module Module that plugs into a ROC to provide a channel for communications via a 

specified communications protocol, such as EIA-422 (RS-422) or HART. 
Component Any liquid metered and controlled by the DL8000. Liquid hydrocarbons refined from 

crude oil and LPGs (such as propane) are usually referred to as products. 
Components are base products or tank products stored at a distribution terminal. 
The component is measured before being blended with other components. Additives 
may be injected before (upstream of) or after (downstream of) the component meter. 

Configuration Refers either to the process of setting up the software for a given system or the 
result of performing this process. The configuration activity includes editing the 
database, building schematic displays and reports, and defining user calculations. 
Typically, the software set up of a device that can often be defined and changed. 
Can also mean the hardware assembly scheme. 

Configuration 
Tree 

In ROCLINK 800, the graphical display that appears when a configuration file opens 
(also Directory Tree). It is a hierarchical branching (“tree-style”) method for 
navigating within the configuration screens.  

CPU Central Processing Unit. 
CRC Cyclical Redundancy Check error checking. 
Crosstalk The amount of signal that crosses over between the receive and transmit pairs, and 

signal attenuation, which is the amount of signal loss encountered on the Ethernet 
segment. 

CSA Canadian Standards Association. See http://www.csa.ca. 
CSMA/CD Carrier Sense Multiple Access with Collision Detection. 
CTS Clear to Send modem communications signal. 

D 
D/A Digital to Analog signal conversion.  
DB Database. 
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dB Decibel. A unit for expressing the ratio of the magnitudes of two electric signals on a 
logarithmic scale. 

DCD Data Carrier Detect modem communications signal. In addition, Discrete Control 
Device – A discrete control device energizes a set of discrete outputs for a given 
setpoint and matches the desired result against a set of discrete inputs (DI).  

DCE Data Communication Equipment. 
Deadband A value that is an inactive zone above the low limits and below the high limits. The 

purpose of the deadband is to prevent a value (such as an alarm) from being set and 
cleared continuously when the input value is oscillating around the specified limit. 
This also prevents the logs or data storage location from being over-filled with data. 

Device 
Directory 

In ROCLINK 800, the graphical display that allows navigation through the PC Comm 
Ports and ROC Comm Ports set up screen.  

DI Discrete Input. 
Discrete Input or output that is non-continuous, typically representing two levels (such as 

on/off). 
DMM Digital multimeter.  
DO Discrete Output. 
Download The process of sending data, a file, or a program from a PC to a ROC. 
DP Differential Pressure. 
DSR Data Set Ready modem communications signal. 
DTE Data Terminal Equipment. 
DTR Data Terminal Ready modem communications signal. 
Duty Cycle Proportion of time during a cycle that a device is activated. A short duty cycle 

conserves power for I/O channels, radios, and so on. 
DVM Digital voltmeter. 
DVS Dual-Variable Sensor. A device that provides static and differential pressure inputs to 

a ROC.  

E 
EDS Electronic Static Discharge. 
EEPROM Electrically Erasable Programmable Read-Only Memory, a form of permanent 

memory on a ROC. 
EFM Electronic Flow Metering or Measurement. 
EIA-232  
(RS-232) 

Serial Communications Protocol using three or more signal lines, intended for short 
distances. Concerning RS232D and RS232C, the letters C or D refer to the physical 
connector type. D specifies the RJ-11 connector where a C specifies a DB25 type 
connector. 

EIA-422 
(RS-422) 

Serial Communications Protocol using four signal lines. 

EIA-485 
(RS-485) 

Serial Communications Protocol requiring only two signal lines. Can allow up to 32 
devices to be connected together in a daisy-chained fashion. 

EMF Electro-Motive Force. 
EMI Electro-Magnetic Interference. 
ESD Electro-Static Discharge. 
EU Engineering Units. Units of measure, such as MCF/DAY. 

F 
FCC Federal Communications Commission. See http://www.fcc.gov.  



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

A-4 Glossary Revised February 2024 

Firmware Internal software that is factory-loaded into a form of ROM. In a ROC, the firmware 
supplies the software used for gathering input data, converting raw input data values, 
storing values, and providing control signals. 

FlashPAC 
module 

ROM and RAM module for a ROC300-Series unit that contains the operating system, 
applications firmware, and communications protocol. 

Flash ROM A type of read-only memory that can be electrically re-programmed. It is a form of 
permanent memory (requires no backup power). Also called Flash memory. 

FloBoss A microprocess-based device that provides flow calculations, remote monitoring, and 
remote control. A FloBoss is a type of ROC.  

FM Factory Mutual. 
Force Write an ON/OFF, True/False, or 1/0 value to a coil. 
FPV Compressibility Factor. 
FSK Frequency Shift Keypad.  
FST Function Sequence Table, a type of user-written program in a high-level language 

designed by Emerson Process Management’s Remote Automation Solutions 
Division.  

Ft Foot or feet. 

G 
GFA Ground Fault Analysis. 
GND Electrical ground, such as used by the ROC unit’s power supply. 
GP Gauge Pressure. 
Gross Quantity The indicated quantity times the meter factor derived from a meter proving of the flow 

meter at a specific flow rate. Calculation: gross quantity = indicated quantity times 
meter factor.  

H 
HART® Highway Addressable Remote Transducer.  
Holding 
Register 

Analog output number value to be read. 

Hw Differential pressure. 
Hz Hertz.  

I, J 
IC Integrated Circuit. Also, Industry Canada (more recently known as Measurement 

Canada), an organization that grants custody transfer approvals on certain ROC 
units.  

ID Identification. 
IEC Industrial Electrical Code or International Electrotechnical Commission. See 

http://www.iec.ch.  
IEEE Institute of Electrical and Electronic Engineers. A professional organization that, in 

conjunction with the International Standards Organization (ISO), establishes and 
maintains the Open System Interconnection (OSI) reference model and an 
international standard for the organization of local area networks (LANs). Refer to 
http://www.ieee.org. 

IMV Integral Multiplier Value, used in AGA3 (orifice) calculations.  
Indicated 
Quantity 

The change in the flow meter reading that occurs during a product flow measurement 
operation. (Not displayed by the device calculation: indicated quantity = end reading 
minus start reading.) 
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Input Digital input, a bit to be read. 
Input Register Input numeric value to be read. 
I/O Input/Output. 
I/O Module Module that plugs into an I/O slot on a ROC to provide an I/O channel. 
IP-252 Institute of Petroleum standard 252. A British standard for pulse fidelity and security 

for pulse output type flow meters. Program codes 233 and 234 define the operation 
of this function.  
Note:  Equivalent standard is API Manual of Petroleum Measurement Standards / 

Chapter 5 - Metering / 
IRQ Interrupt Request. Hardware address oriented. 
ISO International Standards Organization. See http://www.iso.ch. 
IV Integral Value. 

K 
KB Kilobytes. 
KHz KiloHertz. 
K-factor The pulses per unit quantity generated by a pulse output type flow meter (also 

system factor). The nominal value is determined by flow meter design and factory 
water flow calibration. The “average” K-factors for the flow meters are usually 
indicated on the flow meter nameplates. 

L 
LCD Liquid Crystal Display.  
LDP Local Display Panel, a display-only device that plugs into ROC300 (via a parallel 

interface cable) used to access information stored in the ROC. 
LED Light-Emitting Diode. 
Load For sequential blending: In multi-component blending, a load is the completed 

delivery of one component of a batch. The completion of loading all components in 
the batch completes the batch delivery. If the recipe only loads one component, a 
load corresponds to a batch delivery.  
For inline blending:  Each component of the blend is loaded simultaneously. 
Depending on the blend ratio, the low-proportion components are loaded completely 
during the time that the high proportion component(s) are being loaded. After loading 
of the highest proportion component has been terminated, all component loads and 
the batch delivery are complete. 

Loading Island Also loading rack; an installation of one or more loading arms or risers used to 
deliver liquid components to a tanker vehicle located on one or both sides of the 
island, depending on the design of the island.  

Loading Riser The related instruments and devices, located in a meter stream, that provide the 
liquid component loading capability to a mobile tanker vehicle. 
Note:  The flow meter piping can also be installed horizontally, if desired.) 

Load Spot Also bay or lane; one side of a loading island, a position where a tanker vehicle 
parks for a loading operation. One load spot can have one or more loading arms. 

Local Port Also LOI; the serial EIA-232 (RS-232) port on the ROC through which local 
communications are established, typically for configuration software running on a 
PC.  

Logical Number The point number the ROC and ROC Plus protocols use for I/O point types are 
based on a physical input or output with a terminal location; the point numbers for all 
other point types are “logical” and are simply numbered in sequence.  

LNK Ethernet has linked. 
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LOI Local Operator Interface (or Local Port). Refers to the serial  EIA-232 (RS-232) port 
on the ROC through which local communications are established, typically for 
configuration software running on a PC. 

LPM Lightning Protection Module; a device that provides lightning and power surge 
protection for ROCs. 

LRC Longitudinal Redundancy Checking error checking. 

M 
m Meter. 
mA Milliamp(s); one thousandth of an ampere. 
MAC Address Media Access Control Address; a hardware address that uniquely identifies each 

node of a network.  
Manual mode For a ROC, indicates that the I/O scanning has been disabled.  
MAU Medium Attachment Unit. 
MCU Master Controller Unit.  
Meter Factor A number obtained by dividing the actual volume of liquid passed through a flow 

meter during a meter proving operation by the volume registered by the flow meter. 
The meter factor is used in flow calculations to correct the indicated volume (end flow 
meter registration minus start flow meter registration) to the observed gross volume 
(actual flow meter throughput at operating conditions). 
Meter factor = (Meter prover volume corrected to standard conditions) ÷ (Flow meter 
indicated volume corrected to std conditions)  

Meter Proving A procedure used to determine the meter factor for a flow meter. The K-factor (exact 
number of pulses per a volume unit that a flow meter generates) is determined at the 
factory. The K-factor is used to derive a mathematical factor, known as meter factor, 
which is used to adjust results of the internal flow calculations the DL8000 performs.  
Note:  The flow meter is not re-calibrated; determining the meter factor allows the 

operator to manually re-calibrate the DL8000 so that the flow meter’s 
nonadjustable calibration characteristic [pulses per volume unit (K-factor)] are 
incorporated into the flow calculations.  

Modbus A popular device communications protocol developed by Gould-Modicon. 
MPU Micro-Processor Unit.  
mm Millimeter. 
MMBTU Million British Thermal Units. 
msec Millisecond, or 0.001 second. 
MVS Multi-Variable Sensor. A device that provides differential pressure, static pressure, 

and temperature inputs to a ROC for orifice flow calculations.  
mV Millivolts, or 0.001 volt. 
mW Milliwatts, or 0.001 watt. 

N 
NEC National Electrical Code. 
NEMA National Electrical Manufacturer’s Association. See http://www.nema.org. 

O 
OH Off-Hook modem communications signal. 
Off-line Accomplished while the target device is not connected (by a communications link). 

For example, “off-line configuration” refers to configuring an electronic file that is later 
loaded into a ROC.  
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Ohms Units of electrical resistance. 
On-line Accomplished while connected (by a communications link) to the target device. For 

example, “on-line configuration” refers to configuring a ROC800-Series unit while 
connected to it, so that you can view the current parameter values and immediately 
load new values. 

Opcode Type of message protocol the ROC uses to communicate with the configuration 
software, as well as host computers with ROC driver software. 

Operator 
Interface 

Also LOI or Local Port; the serial EIA-232 (RS-232) port on the ROC through which 
local communications are established, typically for configuration software running on 
a PC.  

Orifice meter A meter that records the flow rate of gas through a pipeline. The flow rate is 
calculated from the pressure differential created by the fluid passing through an 
orifice of a particular size and other parameters.  

P, Q 
Parameter A property of a point that typically can be configured or set. For example, the Point 

Tag ID is a parameter of an Analog Input point. Parameters are normally edited by 
using configuration software running on a PC. 

PC Personal Computer. 
Permissive A discrete signal from a device that is input to a discrete input in the DL8000. The 

DL8000 uses this signal to allow a product delivery to be initiated or allow a product 
delivery to continue. Permissive contacts are CLOSED in the normal or safe state 
and OPEN in the abnormal or unsafe state. 

Pf Flowing pressure. 
P/DP Pressure/Differential Pressure. 
PI Pulse Input. 
PID Proportional, Integral, and Derivative control feedback action. 
PIT Periodic Timer Interrupt. 
PLC Programmable Logic Controller.  
Point Software-oriented term for an I/O channel or some other function, such as a flow 

calculation. Points are defined by a collection of parameters. 
Point Number The physical location of an I/O point (module slot and channel) as installed in the 

ROC. 
Point Type Defines the database point to be a specific type of point available to the system. The 

point type determines the basic functions of a point. 
Preset Number value previously determined for a register.  

Also: 
A generic term that describes the functional instrument group to which the DL8000 
belongs. The term originated from mechanical and electrical preset counters. The 
DL8000 provides much more versatility and capability compared to a simple 
mechanical or electrical preset counter. 

PRI Primary PID control loop. 
Primary Blend 
Stream 
Component 

A blended product measured by a primary blend stream meter.  

Primary Blend 
Stream Meter 

A meter measuring the gasoline-ethanol blend. 

Protocol A set of standards that enables communication or file transfers between two 
computers. Protocol parameters include baud rate, parity, data bits, stop bit, and the 
type of duplex.  
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PSTN Public Switched Telephone Network. 
PT Process Temperature. 
PTT Push-to-Talk signal. 
Pulse Transient variation of a signal whose value is normally constant. 
Pulse Interface 
module 

A module that provides line pressure, auxiliary pressure, and pulse counts to a ROC. 

PV Process Variable or Process Value. 
Quantity The resulting amount of product measured after compensation for operational 

temperature and pressure, indicated in one of the following corrected units: cubic 
meters, liters, barrels, gallons. 

R 
Rack A row of slots on a ROC into which I/O modules can be plugged. Racks are given a 

letter to physically identify the location of an I/O channel (such as “A” for the first 
rack). Built-in I/O channels are assigned a rack identifier of “A” while diagnostic I/O 
channels are considered to be in “E” rack.  

RAM Random Access Memory. RAM is used to store history, data, most user programs, 
and additional configuration data. 

RBX Report-by-exception. RBX always refers to Spontaneous RBX in which the ROC 
contacts the host to report an alarm condition. 

RR Results Register; stores the Signal Value Analog (SVA). 
Recipe A pre-entered delivery/blending/control description that allows the DL8000 to 

automatically control the product quantity or total quantity based on percentages of 
multiple components during a batch delivery operation. The DL8000 supports up to 
thirty recipes. 

RFI Radio Frequency Interference. 
RI Ring Indicator modem communications signal. 
ROC Remote Operations Controller microprocessor-based unit that provides remote 

monitoring and control. 
ROCLINK 800 Microsoft® Windows®-based software used to configure functionality in ROC units.  
ROM Read-only memory. Typically used to store firmware. Flash memory. 
Rotary Meter A positive displacement meter used to measure flow rate, also known as a Roots 

meter. 
RTC Real-Time Clock. 
RTD Resistance Temperature Device. 
RTS Ready to Send modem communications signal. 
RTU Remote Terminal Unit. 
RTV  Room Temperature Vulcanizing, typically a sealant or caulk such as silicon rubber.  
RS-232  Serial Communications Protocol using three or more signal lines, intended for short 

distances. Also referred to as the EIA-232 standard.  
RS-422 Serial Communications Protocol using four signal lines. Also referred to as the EIA-

422 standard.  
RS-485 Serial Communications Protocol requiring only two signal lines. Can allow up to 32 

devices to be connected together in a daisy-chained fashion. Also referred to as the 
EIA-485 standard. 

RX or RXD Received Data communications signal. 
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S 
SAMA Scientific Apparatus Maker’s Association.  
Script An uncompiled text file (such as keystrokes for a macro) that a program interprets in 

order to perform certain functions. Typically, the end user can easily create or edit 
scripts to customize the software. 

Side Stream The controlled stream, often called the ethanol product. The side stream is metered 
and can be controlled and measured. 

Side Stream 
Component 

A mix component measured by both a side stream meter and a primary blend stream 
meter. Ethanol is often referred as a side stream component.  

Side Stream 
Meter 

A meter that measures the side component (ethanol).  

Smart module A module, typically for the ROC800-Series or FloBoss 107 devices, having an on-
board processor which can execute a program.  

Soft Points A type of ROC point with generic parameters that can be configured to hold data as 
desired by the user. 

SP Setpoint, or Static Pressure. 
SPI Slow Pulse Input. 
SPK Speaker.  
SRAM Static Random Access Memory. Stores data as long as power is applied; typically 

backed up by a lithium battery or supercapacitor. 
SRBX Spontaneous Report-By-Exception. SRBX always refers to Spontaneous RBX in 

which the ROC contacts the host to report an alarm condition.  
Standard 
Quantity 

The gross quantity corrected to standard temperature and/or pressure. This is a 
quantity measurement. Calculation: standard quantity = gross quantity times CTLM 
(correction factor for the effect of temperature on the liquid in the meter) times CPLM 
(correction factor for the effect of pressure on the liquid in the meter)  

SVA Signal Value Analog. Stored in the Results Register, it is the analog value that is 
passed between functions in an FST.  

SVD Signal Value Discrete. Stored in the Compare Flag, it is the discrete value that is 
passed down the sequence of functions in an FST. 

System 
Variables 

Configured parameters that describe the ROC; set using ROCLINK software.  

T 
T/C Thermocouple Input. 
TCP/IP Transmission Control Protocol/Internet Protocol.  
TDI Time Duration Input. 
TDO Time Duration Output. 
Tf Flowing temperature. 
TLP Type (of point), Logical (or point) number, and Parameter number. 
Transaction Group of one or more consecutive batch deliveries for accounting purposes. The 

batches that comprise a transaction always use one recipe, one additive selection, 
and one loading side. An example of a transaction is the delivery of multiple batches 
to different compartments in a single tanker vehicle. 

Turbine meter A device used to measure flow rate and other parameters.  
TX or TXD Transmitted Data communications signal. 
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U 
Upload Send data, a file, or a program from the ROC to a PC or other host.  

V-Z 
V Volts. 
Volume The actual space occupied by the product measured, indicated in one of the 

following actual units: cubic meters, liters, barrels, gallons.  
Wild Stream Wild stream is the uncontrolled stream, often referring to the gasoline product. This 

is because the gasoline product cannot be exclusively metered, controlled, or 
measured. 

Wild Stream 
Component 

A product component measured as part of (Primary Blend Stream Component – 
Side Stream Component) a primary blend stream component by a primary blend 
stream meter is called a wild stream component. Gasoline is referred as wild stream 
component.  
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Appendix B – The Display Editor 

In This Chapter 

B.1 Creating a New Custom Display ..................................................... B-2 
B.2 Adding Custom Display Objects ..................................................... B-5 
B.3 Managing Custom Display Objects............................................... B-19 
B.4 Adding an Expression to an Object .............................................. B-22 
B.5 Editing a Custom Display from a File ........................................... B-24 
 

The custom display option in ROCLINK 800 software allows you to 
create customized displays or load a display from a file. The ROC can 
store up to 246 displays (including both custom user displays you create 
and user program displays that accompany user programs).   
 

 Caution You should be familiar with Visual Basic before attempting to create 
custom displays.  

 
You can add fields to monitor flow, I/O points, and other TLPs. Select 
View > Display > New. A blank Display Editor screen displays.   

 
Figure B-1. Display Editor 

By adding objects (tabs, fields, labels, text, etc.) to the display, you can 
incorporate “live” data as well as images and other information you 
wish to convey. One use of custom displays is to graphically represent 
the application that a ROC monitors and controls. Another use is to 

Object buttons on toolbar 

Object Properties box 

Display 
Editor 
toolbar 
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monitor the ROC, giving you to opportunity to change commonly used 
parameters from a single screen.  
Each custom display has parameters specific to the entire display that 
you are creating. By default, the system places the Display object 
properties box at the upper right of the screen in a pop-up window. A 
similar object properties box displays for each object you add to the 
display.  

 Caution When creating a custom display with multiple iterations that includes 
writable ROC800 HART-2 parameters, the system writes HART-2 values 
for all logicals to logical one. This means that the value for logical one 
is overwritten when the system writes each additional logical value. For 
example, if the value of logical one is 3, the current value of logical two 
is 5, and the new value of logical two is 7, the system overwrites the 
value in logical one (3) with the new value of logical two (7) and does 
not update the current value of logical two (5). 
 
You can avoid this issue by creating a custom display with a single 
iteration that includes the fields for all logicals on a single screen. By 
manually assigning the TLP values for each field, the system writes all 
values to the correct logicals.  

 
Drag and drop the object buttons from the toolbar to the Display Editor 
screen and set the associated parameters. Each option has parameters 
associated with it depending on the type of option you have selected and 
you can customize the parameters in the object properties box.  

Note: Custom displays developed with ROCLINK for Windows are 
not compatible with ROCLINK 800 Configuration software.  

Sections B.1 and B.2 discuss the process of creating a new custom 
display and of adding and arranging objects on that display.  

B.1 Creating a New Custom Display 
To create a new display:  
1. Select View > Display > New. A blank Display Editor screen 

displays.  
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Figure B-2. Display Editor (blank)  

Note: You can also click the New Display button (at the extreme 
left of the Display Editor toolbar) to create a new display.  

2. Specify the properties for the new custom display:   

Field Description 
Display Name  Names the display. Although you can enter up to 50 

characters for a display name, a maximum of 10-20 
characters should be sufficient to uniquely identify 
the display.  

Logical Point List Indicates whether the display is unique or one of 
several iterations. Click  (which appears when you 
click the field) to display the values. Valid values are 
Disabled (screen is unique) or Enabled (number of 
screens equals the number of logicals). The default 
is Disabled.   
Note:  The number of screens is based of the 

number of logicals for the first point type 
selected in the Point Type field.  

New Display button 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

B-4 Display Editor Revised February 2024 

Field Description 
Point Type(s)  Sets, if you enable the Logical Point List option, the 

point type(s) whose logicals track the iteration of the 
display. Click … (which appears when you click the 
field) to display the Select Point Type(s) screen. Use 
that screen to associate one or more point types 
with this Logical Point List.   

Picture  Identifies a graphic used for the background of the 
display. Click … (which appears when you click the 
field) to display a Select Picture File screen. Use 
that screen to associate an image with the display.  

Menu Location  Allows you to hide, replace, or rename a menu 
selection in the ROCLINK 800 menu. This option 
applies only to displays physically residing in the 
ROC.  

 Hide Hides a menu selection in the Meter, 
View, or ROC menu. Requires the 
syntax H:menuname.submenuname 
(as in H:Meter.Plate Change).  

 Replace Replaces a screen in the Meter menu 
with the current custom display. 
Requires the syntax 
R:menuname.submenuname (as in 
R:Meter.Setup).  

 Rename Replaces a menu in the Meter, View, or 
ROC menu with the current display 
using the indicated name. Requires the 
syntax N:menuname.submenuname: 
newsubmenuname (as in 
N:Meter.Calibration:Coriolis Cal).  

 Note:  Use a comma to hide, replace, or rename 
multiple features, as in 
N:Meter.Calibration:Coriolis 
Cal,N:Meter,Calibration:Central Cal.  

Tree Location  Currently unavailable.   
Update Mode  Sets when the system updates data on this screen. 

Valid values are Normal (system does not update 
the screen content) or AutoScan (system updates 
the screen content based on the interval you specify 
in the Auto Scan Update Interval field on the 
Options screen (Tools > Options). The default 
value is Normal.  
Note:  If you include dynamic content on your 

custom display, you may want the system to 
refresh that content for the most current 
values.  

 
3. Add display content to the custom display. You can either drag an 

object from the toolbar and place it on the custom display or place 
the cursor on the display where you want the object, right-click, and 
select from the pop-up menu. Refer to Section B.2, Adding Custom 
Display Objects, for a description of each object and its properties. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Display Editor B-5 

 Add as many objects to the screen as you need. You can place 
objects anywhere on the Display Editor screen. Use a frame with 
a label to logically group certain options (such as option buttons 
or check boxes) to ensure that others know the use context for 
the options.  

 For each object you enter, complete that object’s Properties box. 
Each object’s Properties box has different items, and you can 
edit those properties at any time.   

 Move and re-shape objects within the display as necessary. To 
modify an object’s placement or shape:  
o Click and drag on the control squares to change the size of 

the object.  
o Press Shift + arrow keys to change an object’s size. Press 

Shift +Alt + arrow keys for smaller changes. 
o Press Ctrl + arrow keys to move an object to the desired 

position. Press Ctrl + Alt + arrow keys for smaller moves. 
o Select the Align Lefts icon to align all selected objects to the 

furthest left point in the group. 
o Select the Size to Widest icon to change the width of all 

selected objects to the width of the widest element. 
o Select the Make Vertical Spacing Equal icon to evenly 

adjust the vertical spacing between all the selected objects. 
o Select the Make Horizontal Spacing Equal icon to evenly 

adjust the horizontal spacing between all the selected objects. 
o Remove objects by selecting the object and pressing Delete.  

4. Click the Test icon to verify that the completed custom display 
works correctly.  

5. Click the Save Display to File icon to save the completed and tested 
custom display. ROCLINK 800 displays use the suffix .DSP (as in 
TestScreen.dsp).  

B.2 Adding Custom Display Objects 
The right-hand side of the Display Editor toolbar (see Figure B-3) 
includes a number of buttons for custom objects.  

 
Figure B-3. Custom Display Objects 

Tab Control 
 

Adds an twelve-tab image, which you can size appropriately and edit to 
fewer tabs. You can then drag and drop objects onto each tab.   
This object has the following properties:  
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Property Description 
Tabs Sets the number of tabs (up to 12) on the screen. 

Click  (which displays when you click in the field) to 
specify the number of tabs.  

Caption 1 through 12  Sets a label or caption for each tab. The size of the 
tab increases to accommodate the text.  

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Editing is permitted based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section B.4, Adding an 
Expression to an Object. 

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object.  
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Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Frame 

 
Adds an organizing frame, which you use to group similar user 
selections. Once a frame is in place, drag and drop objects onto the 
frame. 
This object has the following properties:  

 
Property Description 
Caption  Sets a label or caption for the object. The default is 

Frame(1); the system uniquely names each object 
until you rename it.   

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Editing is allowed based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section B.4, Adding an 
Expression to an Object. 

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
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Property Description 
Section B.4, Adding an Expression to 
an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Label 

 
Adds labels to identify objects. This object has the following properties: 

 
Property Description 
Caption  Sets a label or caption for the object. The default is 

Label(1); the system uniquely names each object 
until you rename it.  

Alignment Indicates where the label text displays. Click  
(which displays when you click in the field) to display 
the valid values: Left (text is flush left), Right (text is 
flush right), or Center (text is centered).  

Property Description 
TLP Associates the object with a TLP. Click … (which 

displays when you click in the field) to display a 
Select TLP screen you use to define the associated 
TLP.  

Expression Associates the object with a Visual Basic expression. 
Click … (which displays when you click in the field) to 
display an Expression Builder window which you use 
to define the expression. Refer to Section B.4, 
Adding an Expression to an Object. 
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Property Description 
Visible Indicates whether the object appears in the final 

version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Text Box 

 
Adds a data entry field. This object has the following properties:   

 
Property Description 
Text  Sets text that appears in the object. You can enter as 

many characters as necessary. Use the control 
squares to change the size of the text box. The 
default is TextBox(1); the system uniquely names 
each object until you rename it. 

Property Description 
TLP Associates the object with a TLP. Click … (which 

displays when you click in the field) to display a 
Select TLP screen you use to define the associated 
TLP.  
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Property Description 
Allow Data Entry Sets whether the user can edit the object. Click  

(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Allows editing based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section B.4, Adding an 
Expression to an Object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object. 

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Option Button 

 
Adds a radio button to limit input to a single selection. This object has 
the following properties:  

 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Display Editor B-11 

Property Description 
Caption  Sets a label or caption for each object. The default is 

OptionButton(1); the system uniquely names each 
object until you rename it. 

TLP Associates the object with a TLP. Click … (which 
displays when you click in the field) to display a 
Select TLP screen you use to define the associated 
TLP.  

Mask Value Identifies individual bits of an 8-bit integer ROCLINK 
uses when calculating the value to be compared to 
the value specified in the Selected When or 
Checked When fields. ROCLINK performs a 
mathematical AND comparing this masked value and 
the value in the Selected When or Checked When 
field and activates the button or box if the values are 
equal. The default value is 255. 

Selected When = Specifies the value at which the option button 
activates. Works in conjunction with the value in the 
Mask Value field.   

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Allows editing based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section B.4, Adding an 
Expression to an Object.   

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  
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Check Box 
 

Adds a check box for multiple selections. This object has the following 
properties:  

 
Property Description 
Caption  Sets a label or caption for the object. The default is 

CheckBox(1); the system uniquely names each 
object until you rename it.  

TLP Associates the object with a TLP. Click … (which 
displays when you click in the field) to display a 
Select TLP screen you use to define the associated 
TLP.  

Mask Value Identifies individual bits of an 8-bit integer ROCLINK 
uses when calculating the value to be compared to 
the value specified in the Selected When or 
Checked When fields. ROCLINK performs a 
mathematical AND comparing this masked value and 
the value in the Selected When or Checked When 
field and activates the button or box if the values are 
equal. The default value is 255. 

Checked When = Specifies the value at which the checkbox activates. 
Works in conjunction with the value in the Mask 
Value field.   

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Allows editing based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section B.4, Adding an 
Expression to an Object.  
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Property Description 
Visible Indicates whether the object appears in the final 

version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object. 

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Combo Box 

 
Adds a list of options that opens when you click . This object has the 
following properties:  

 
 

Property Description 
TLP Associates the object with a TLP. Click … (which 

displays when you click in the field) to display a 
Select TLP screen you use to select the associated 
TLP.  
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Property Description 
Item List Enables you to build a drop-down list of up to 30 

selectable items. Click … (which displays when you 
click in the field) to display an Item List screen:  

 
Use this screen to add items to the drop-down menu. 
ROCLINK 800 expands the list as you add items. 

 Item Value Associates the label in the drop-down 
menu with a value in the designated 
TLP.  

 List Item Sets the label that appears in the 
drop-down menu.  

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing    
 Expression Allows editing based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section B.4, Adding an 
Expression to an Object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object. 



ROCLINK 800 Configuration Software User Manual (for ROC800-Series) 

Revised February 2024 Display Editor B-15 

Property Description 
Tab Order  Sets the object-to-object order the cursor follows on 

the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Line 

 
Adds a line to mark borders between objects. This object has the 
following properties:  

 
Property Description 
Line Width Sets the thickness of the line. The default is 1.   
Color  Sets the color of the object. Enter a hexadecimal 

color value or click in the field to display a Color 
screen, which you use to assign a color to the object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object. 
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Rectangle 
 

Adds a rectangle to mark borders between objects. This option has the 
following properties:  

 
Property Description 
Color  Sets the color of the object. Enter a hexadecimal 

color value or click in the field to display a Color 
screen, which you use to assign a color to the object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object 

 
Oval 

 
Adds an oval to mark borders between objects. This object has the 
following properties:  

 
Property Description 
Color  Sets the color of the object. Enter a hexadecimal 

color value or click in the field to display a Color 
screen, which you use to assign a color to the object.  
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Property Description 
Visible Indicates whether the object appears in the final 

version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object.  

 
Image 

 
Adds an image (.JPG, .BMP, .PNG, .GIF, or other graphic formats) 
from a file. This object has the following properties:  

 
Property Description 
Picture  Sets an image (.JPG, .BMP, .GIF, or other graphic 

formats) to display with the object. Click in the field to 
display a Select Picture File screen which you use to 
indicate the appropriate image. The default is None.   

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object. 
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Chart 
 

Adds a chart to represent data graphically.  
Note:  You can view real-time data by configuring what figures display 

on the chart. After you configure the chart, view the display and 
select Auto-Scan. The chart displays the collected data in real-
time. You cannot save the chart data to system memory. 

This option has the following properties:  

 
Property Description 
Header  Sets a title for the object.  
TLP 1  through 4 Associates up to four TLPs with the chart. Click … 

(which displays when you click in the field) to display 
a Select TLP screen you use to define the TLPs. 

 
Button 

 
Adds a button to the screen. This object has the following properties:  

 
Property Description 
Caption  Sets a label or caption for the object. The default is 

Button(1); the system uniquely names each object 
until you rename it.  

Action Associates an activity with the button. Write Value is 
the only action currently associated with this control. 
The system writes the value identified in the Value 
property   

TLP Associates the object with a TLP. Click … (which 
displays when you click in the field) to display a 
Select TLP screen you use to define the TLP.  
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Property Description 
Value Opens an Expression Builder window which you use 

to determine the conditions under which the object is 
visible. Refer to Section 5.6.4, Adding an Expression 
to an Object. 

Enabled Indicates whether the button is active. Valid values 
are:  

 Yes Object is always active. This is the 
default.  

 No Object is not active.  
 Expression Selection is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section B.4, Adding an Expression to 
an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

B.3 Managing Custom Display Objects 
The left-hand side of the Custom Display toolbar (see Figure B-4) 
provides utilities you use to manage the objects placed on the custom 
display.  

 
Figure B-4. Object Management Tools 
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New Display 
 

Creates a new custom display file.   

 
Open Display File 

 

Opens an existing custom display file. Click this button to display an 
Open screen that shows all available .DSP files in the default 
ROCLINK 800 directory. If you store .DSP files elsewhere, use this 
screen to navigate to that location and select a file.   
 

Save Display to File 
 

Saves the current display. Click this button to display a Save As screen 
that shows the .DSP files in the default ROCLINK 800 directory. If you 
store .DSP files elsewhere, use this screen to navigate to that location 
and save the display file.   
 

Test 
 

Closes edit mode for the custom display and shows the custom display 
as defined. If any errors exist, the system displays appropriate error 
messages.   
 

Align Lefts 
 

Aligns selected objects to the left. Click  to display a drop-down 
menu that provides more specific alignment options:   

 

 
 

Size to Widest 

 

Adjusts the size of the selected objects to the width of the widest object. 
Click  to display a drop-down menu that provides more specific sizing 
options:   
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Make Vertical Spacing 
Equal 

 

Equalizes the vertical spacing between the selected objects. Click  to 
display a drop-down menu that provides more specific spacing options:   

 

 
 

Make Horizontal 
Spacing Equal 

 

Equalizes the horizontal spacing between the selected objects. Click  
to display a drop-down menu that provides more specific spacing 
options:   

 

 
 

Other Tools 
 

Provides additional object-management tools. Click  to display a 
drop-down menu that provides more specific spacing options:   

 

 
 
Option Description 
Set Tab-Key Order Allows you to specify the object-to-object sequence 

for the cursor on the custom display when you press 
Tab. When you click this option, the system displays 
a message:  
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Option Description 
Import Display 
Objects 

Allows you to import another custom display into the 
current custom display. Use this to quickly duplicate 
custom displays or build similar custom displays.  
When you click this option, the system displays an 
Import screen that you use to select the .DSP file to 
import.  

Export Display 
Objects 

Allows you to save the current custom display.  
When you click this option, the system displays a 
Save As screen. Use it to save the .DSP file to the 
default (or other) ROCLINK 800 directory.  

 
Lock Controls 

 
Restricts the movement of objects on the custom display. This control is 
helpful when you want to make minor changes to the custom display 
without accidentally modifying the location of objects.   

B.4 Adding an Expression to an Object 
Some custom display objects—tab, label, button, text box, option, check 
box, combo box, line, circle, square, and image—allow you to add 
Visual Basic expressions that cause the display to change under specific 
conditions.   
The Expression Builder screen enables you to quickly build and test a 
Visual Basic expression to provide customized functioning. For 
example, you could set a frame’s Visible property to Expression and 
then specify the conditions (such as a particular TLP value) under which 
the frame displays. Until that value occurs, the frame does not appear on 
the custom display.  
 

 Caution We strongly suggest prior experience in Visual Basic programming if you 
want to create display element expressions. 

 
To add an expression:  
1. Click an object’s property that includes Expression as an option.  
2. Click  and select Expression.  
3. Click … (which displays as part of the Expression option). The 

Expression Builder screen displays:  
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Figure B-5. Expression Builder 

Note: If you are skilled in Visual Basic or already know the 
specific expression you want to add, you can enter the 
desired expression directly in the upper (Expression) box on 
this screen.  

4. Build an expression using the buttons immediately under the 
Expression box and/or the three boxes in the center of the screen. 
Click Add to include each expression component to the screen.   

Note: Based on your selected expression category, ROCLINK 800 
changes the options displayed in the other two boxes to help 
you in the building process. Additionally, ROCLINK 800 
displays definitions and explanations at the bottom of the 
screen.  

5. When your expression is complete, click Evaluate. ROCLINK 800 
checks your expression for errors. Correct any errors.   

6. Click OK when your expression is complete. The Display Editor 
screen displays.  

Note: At this point it is strongly recommended that you save the 
custom display to save the expression.  
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B.5 Editing a Custom Display from a File  
Once you have created a custom display, you save the display as a .DSP 
file you can later edit. Click Save Display to File on the Display Editor 
toolbar and indicate the name and location for the saved display.   
To edit a saved display, select View > Display > From File. An Open 
screen displays. Select the .DSP file and click Open. ROCLINK 800 
opens that display.  
If Edit is not included in the buttons displayed at the bottom of the 
ROCLINK 800 screen, you need to change the attributes of the .DSP 
file. Using Window’s Explorer, access the directory that houses your 
.DSP files (typically C:\Program Files\ROCLINK800\Displays, if you 
accepted defaults during system installation). If you store your .DSP 
files in another location, access that directory. Locate the .DSP file and 
left-click the file to display a pop-up menu. Select Properties. A 
window similar to this one should appear:  

 
Figure B-6. Properties 

Uncheck the Read-only Attributes box and click Apply. You can now 
edit the .DSP file.  
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